/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.112 Revision 1.123
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2013 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.112 2012/01/17 11:20:03 johu Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.123 2013/02/07 03:38:33 alexxy Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed 13# NOTE: KDE 4 ebuilds currently support EAPIs 3, 4, and 5. This will be
14# over time as new EAPI versions are approved. 14# reviewed over time as new EAPI versions are approved.
15 15
16# @ECLASS-VARIABLE: KDE_SELINUX_MODULE 16# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
17# @DESCRIPTION: 17# @DESCRIPTION:
18# If set to "none", do nothing. 18# If set to "none", do nothing.
19# For any other value, add selinux to IUSE, and depending on that useflag 19# For any other value, add selinux to IUSE, and depending on that useflag
20# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND 20# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
21: ${KDE_SELINUX_MODULE:=none} 21: ${KDE_SELINUX_MODULE:=none}
22 22
23# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
24# @DESCRIPTION:
25# If defined, launch and use a private dbus session during src_test.
26
23# @ECLASS-VARIABLE: VIRTUALX_REQUIRED 27# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
24# @DESCRIPTION: 28# @DESCRIPTION:
25# For proper description see virtualx.eclass manpage. 29# For proper description see virtualx.eclass manpage.
26# Here we redefine default value to be manual, if your package needs virtualx 30# Here we redefine default value to be manual, if your package needs virtualx
27# for tests you should proceed with setting VIRTUALX_REQUIRED=test. 31# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
28: ${VIRTUALX_REQUIRED:=manual} 32: ${VIRTUALX_REQUIRED:=manual}
29 33
30inherit kde4-functions toolchain-funcs fdo-mime gnome2-utils base virtualx versionator eutils 34inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils base virtualx versionator eutils multilib
31 35
32if [[ ${BUILD_TYPE} = live ]]; then 36if [[ ${KDE_BUILD_TYPE} = live ]]; then
33 case ${KDE_SCM} in 37 case ${KDE_SCM} in
34 svn) inherit subversion ;; 38 svn) inherit subversion ;;
35 git) inherit git-2 ;; 39 git) inherit git-2 ;;
36 esac 40 esac
37fi 41fi
60case ${KDEBASE} in 64case ${KDEBASE} in
61 kde-base) 65 kde-base)
62 SLOT=4 66 SLOT=4
63 KDE_MINIMAL="${PV}" 67 KDE_MINIMAL="${PV}"
64 ;; 68 ;;
65 koffice)
66 SLOT="2"
67 ;;
68 kdevelop) 69 kdevelop)
69 if [[ ${BUILD_TYPE} = live ]]; then 70 if [[ ${KDE_BUILD_TYPE} = live ]]; then
70 # @ECLASS-VARIABLE: KDEVELOP_VERSION 71 # @ECLASS-VARIABLE: KDEVELOP_VERSION
71 # @DESCRIPTION: 72 # @DESCRIPTION:
72 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages. 73 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
73 # Applies to KDEBASE=kdevelop only. 74 # Applies to KDEBASE=kdevelop only.
74 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}" 75 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
81 case ${PN} in 82 case ${PN} in
82 kdevelop|quanta) 83 kdevelop|quanta)
83 KDEVELOP_VERSION=${PV} 84 KDEVELOP_VERSION=${PV}
84 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)" 85 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
85 ;; 86 ;;
86 kdevplatform) 87 kdevplatform|kdevelop-php*)
87 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)" 88 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
88 KDEVPLATFORM_VERSION=${PV} 89 KDEVPLATFORM_VERSION=${PV}
89 ;; 90 ;;
90 *) 91 *)
91 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}" 92 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
153# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE 154# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
154# @DESCRIPTION: 155# @DESCRIPTION:
155# Set this varible if you want your live package to manage its 156# Set this varible if you want your live package to manage its
156# translations. (Mostly all kde ebuilds does not ship documentation 157# translations. (Mostly all kde ebuilds does not ship documentation
157# and translations in live ebuilds) 158# and translations in live ebuilds)
158if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then 159if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
159 # Kdebase actualy provides the handbooks even for live stuff 160 # Kdebase actualy provides the handbooks even for live stuff
160 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never 161 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
161 KDE_LINGUAS="" 162 KDE_LINGUAS=""
162fi 163fi
163 164
164# Setup packages inheriting this eclass 165# Setup packages inheriting this eclass
165case ${KDEBASE} in 166case ${KDEBASE} in
166 kde-base) 167 kde-base)
167 HOMEPAGE="http://www.kde.org/" 168 HOMEPAGE="http://www.kde.org/"
168 LICENSE="GPL-2" 169 LICENSE="GPL-2"
169 if [[ $BUILD_TYPE = live ]]; then 170 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
170 # Disable tests for live ebuilds 171 # Disable tests for live ebuilds by default
171 RESTRICT+=" test" 172 RESTRICT+=" test"
172 fi
173
174 # Only add the kdeprefix USE flag for older versions, to help
175 # non-portage package managers handle the upgrade
176 if [[ ${PV} < 4.6.4 && ( ( ${KMNAME} != kdepim && ${PN} != kdepim-runtime ) || ${PV} < 4.6 ) ]]; then
177 IUSE+=" kdeprefix"
178 fi 173 fi
179 174
180 # This code is to prevent portage from searching GENTOO_MIRRORS for 175 # This code is to prevent portage from searching GENTOO_MIRRORS for
181 # packages that will never be mirrored. (As they only will ever be in 176 # packages that will never be mirrored. (As they only will ever be in
182 # the overlay). 177 # the overlay).
184 *9999* | 4.?.[6-9]?) 179 *9999* | 4.?.[6-9]?)
185 RESTRICT+=" mirror" 180 RESTRICT+=" mirror"
186 ;; 181 ;;
187 esac 182 esac
188 ;; 183 ;;
189 koffice)
190 HOMEPAGE="http://www.koffice.org/"
191 LICENSE="GPL-2"
192 ;;
193 kdevelop) 184 kdevelop)
194 HOMEPAGE="http://www.kdevelop.org/" 185 HOMEPAGE="http://www.kdevelop.org/"
195 LICENSE="GPL-2" 186 LICENSE="GPL-2"
196 ;; 187 ;;
197esac 188esac
198 189
199# @ECLASS-VARIABLE: QT_MINIMAL 190# @ECLASS-VARIABLE: QT_MINIMAL
200# @DESCRIPTION: 191# @DESCRIPTION:
201# Determine version of qt we enforce as minimal for the package. 192# Determine version of qt we enforce as minimal for the package.
202if version_is_at_least 4.7.80 "${KDE_MINIMAL}"; then 193if version_is_at_least 4.8.50 "${KDE_MINIMAL}"; then
194 # Upstream has added an *undeclared* dependency on Qt 4.8...
195 QT_MINIMAL="${QT_MINIMAL:-4.8.0}"
196else
203 QT_MINIMAL="${QT_MINIMAL:-4.7.4}" 197 QT_MINIMAL="${QT_MINIMAL:-4.7.4}"
204else
205 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
206fi 198fi
207 199
208# Declarative dependencies 200# Declarative dependencies
209qtdeclarativedepend=" 201qtdeclarativedepend="
210 >=x11-libs/qt-declarative-${QT_MINIMAL}:4 202 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
282 ;; 274 ;;
283 *) ;; 275 *) ;;
284esac 276esac
285unset cppuintdepend 277unset cppuintdepend
286 278
287
288# WebKit use dependencies
289case ${KDE_REQUIRED} in
290 always)
291 qtwebkitusedeps="[kde]"
292 ;;
293 optional)
294 qtwebkitusedeps="[kde?]"
295 ;;
296 *) ;;
297esac
298# KDE dependencies 279# KDE dependencies
299# Qt accessibility classes are needed in various places, bug 325461 280# Qt accessibility classes are needed in various places, bug 325461
300kdecommondepend=" 281kdecommondepend="
301 dev-lang/perl 282 dev-lang/perl
302 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl] 283 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
284 >=x11-libs/qt-dbus-${QT_MINIMAL}:4
303 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus] 285 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
304 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde] 286 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility]
305 >=x11-libs/qt-script-${QT_MINIMAL}:4 287 >=x11-libs/qt-script-${QT_MINIMAL}:4
306 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support] 288 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
307 >=x11-libs/qt-svg-${QT_MINIMAL}:4 289 >=x11-libs/qt-svg-${QT_MINIMAL}:4
308 >=x11-libs/qt-test-${QT_MINIMAL}:4 290 >=x11-libs/qt-test-${QT_MINIMAL}:4
309 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps} 291 >=x11-libs/qt-webkit-${QT_MINIMAL}:4
310 !aqua? ( 292 !aqua? (
311 x11-libs/libXext 293 x11-libs/libXext
312 x11-libs/libXt 294 x11-libs/libXt
313 x11-libs/libXxf86vm 295 x11-libs/libXxf86vm
314 x11-libs/libXcomposite 296 x11-libs/libXcomposite
337 fi 319 fi
338fi 320fi
339 321
340kdedepend=" 322kdedepend="
341 dev-util/automoc 323 dev-util/automoc
342 dev-util/pkgconfig 324 virtual/pkgconfig
343 !aqua? ( 325 !aqua? (
344 >=x11-libs/libXtst-1.1.0 326 >=x11-libs/libXtst-1.1.0
345 x11-proto/xf86vidmodeproto 327 x11-proto/xf86vidmodeproto
346 ) 328 )
347" 329"
394 IUSE+=" selinux" 376 IUSE+=" selinux"
395 kdecommondepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )" 377 kdecommondepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
396 ;; 378 ;;
397esac 379esac
398 380
381# We always need the aqua useflag because otherwise we cannot = refer to it inside
382# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
383# (where referring to a use flag not in IUSE masks the ebuild).
384# The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
385IUSE+=" aqua"
386
399case ${KDE_REQUIRED} in 387case ${KDE_REQUIRED} in
400 always) 388 always)
401 IUSE+=" aqua"
402 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}" 389 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
403 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}" 390 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
404 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}" 391 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
405 ;; 392 ;;
406 optional) 393 optional)
407 IUSE+=" aqua kde" 394 IUSE+=" kde"
408 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 395 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
409 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )" 396 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
410 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )" 397 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
411 ;; 398 ;;
412 *) ;; 399 *) ;;
422DEPEND+=" ${COMMONDEPEND}" 409DEPEND+=" ${COMMONDEPEND}"
423RDEPEND+=" ${COMMONDEPEND}" 410RDEPEND+=" ${COMMONDEPEND}"
424unset COMMONDEPEND 411unset COMMONDEPEND
425 412
426# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 413# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
427# koffice ebuild, the URI should be set in the ebuild itself 414# kdevelop ebuild, the URI should be set in the ebuild itself
428_calculate_src_uri() { 415_calculate_src_uri() {
429 debug-print-function ${FUNCNAME} "$@" 416 debug-print-function ${FUNCNAME} "$@"
430 417
431 local _kmname _kmname_pv 418 local _kmname _kmname_pv
432 419
447 fi 434 fi
448 _kmname_pv="${_kmname}-${PV}" 435 _kmname_pv="${_kmname}-${PV}"
449 case ${KDEBASE} in 436 case ${KDEBASE} in
450 kde-base) 437 kde-base)
451 case ${PV} in 438 case ${PV} in
452 4.[456789].8[05] | 4.[456789].9[0235678]) 439 4.4.11.1)
440 # KDEPIM 4.4, special case
441 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
442 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
443 4.?.[6-9]? | 4.??.[6-9]?)
453 # Unstable KDE SC releases 444 # Unstable KDE SC releases
445 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
446 4.[1-7].[12345])
447 # Stable KDE SC with old .bz2 support
454 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" 448 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
455 if ! version_is_at_least 4.6.80 ${PV}
456 then
457 # KDEPIM IS SPECIAL
458 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname_pv}.tar.bz2"
459 fi
460 ;;
461 *) 449 *)
462 # Stable KDE SC releases 450 # Stable KDE SC releases
463 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" 451 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz" ;;
464 if ! version_is_at_least 4.6.80 ${PV}
465 then
466 # KDEPIM IS SPECIAL
467 # TODO: It might not be with KDE 4.7 (see above)
468 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
469 fi
470 ;;
471 esac 452 esac
472 ;; 453 ;;
473 koffice) 454 kdevelop|kdevelop-php*|kdevplatform)
474 case ${PV} in 455 case ${KDEVELOP_VERSION} in
475 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 456 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
476 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 457 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
477 esac 458 esac
478 ;;
479 kdevelop)
480 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
481 ;; 459 ;;
482 esac 460 esac
483} 461}
484 462
485_calculate_live_repo() { 463_calculate_live_repo() {
538 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta 516 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
539 # build packages from same svn location. 517 # build packages from same svn location.
540 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 518 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
541 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 519 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
542 ;; 520 ;;
543 koffice)
544 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
545 ;;
546 *) 521 *)
547 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 522 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
548 ;; 523 ;;
549 esac 524 esac
550 else 525 else
553 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 528 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
554 fi 529 fi
555 # @ECLASS-VARIABLE: ESVN_UP_FREQ 530 # @ECLASS-VARIABLE: ESVN_UP_FREQ
556 # @DESCRIPTION: 531 # @DESCRIPTION:
557 # This variable is used for specifying the timeout between svn synces 532 # This variable is used for specifying the timeout between svn synces
558 # for kde-base and koffice modules. Does not affect misc apps. 533 # for kde-base modules. Does not affect misc apps.
559 # Default value is 1 hour. 534 # Default value is 1 hour.
560 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1} 535 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
561 ;; 536 ;;
562 git) 537 git)
563 local _kmname 538 local _kmname
564 # @ECLASS-VARIABLE: EGIT_MIRROR 539 # @ECLASS-VARIABLE: EGIT_MIRROR
565 # @DESCRIPTION: 540 # @DESCRIPTION:
591 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}" 566 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
592 ;; 567 ;;
593 esac 568 esac
594} 569}
595 570
596case ${BUILD_TYPE} in 571case ${KDE_BUILD_TYPE} in
597 live) _calculate_live_repo ;; 572 live) _calculate_live_repo ;;
598 *) _calculate_src_uri ;; 573 *) _calculate_src_uri ;;
599esac 574esac
600 575
601debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}" 576debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
613 debug-print-function ${FUNCNAME} "$@" 588 debug-print-function ${FUNCNAME} "$@"
614 589
615 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then 590 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
616 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild." 591 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
617 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors." 592 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
618 fi
619
620 if use_if_iuse kdeprefix; then
621 eerror "Sorry, kdeprefix support has been removed."
622 eerror "Please remove kdeprefix from your USE variable."
623 die "kdeprefix support has been removed"
624 fi
625
626 if [[ ${CATEGORY}/${PN} != kde-base/kdelibs && ${CATEGORY}/${PN} != kde-base/kde-env ]] && \
627 { [[ ${KDE_REQUIRED} == always ]] || { [[ ${KDE_REQUIRED} == optional ]] && use kde; }; } && \
628 has_version kde-base/kdelibs[kdeprefix]; then
629 eerror "Sorry, kdeprefix support has been removed."
630 eerror "Please rebuild kdelibs without kdeprefix support."
631 die "kdeprefix support has been removed"
632 fi 593 fi
633 594
634 # Don't set KDEHOME during compilation, it will cause access violations 595 # Don't set KDEHOME during compilation, it will cause access violations
635 unset KDEHOME 596 unset KDEHOME
636 597
663# @DESCRIPTION: 624# @DESCRIPTION:
664# This function unpacks the source tarballs for KDE4 applications. 625# This function unpacks the source tarballs for KDE4 applications.
665kde4-base_src_unpack() { 626kde4-base_src_unpack() {
666 debug-print-function ${FUNCNAME} "$@" 627 debug-print-function ${FUNCNAME} "$@"
667 628
668 if [[ ${BUILD_TYPE} = live ]]; then 629 if [[ ${KDE_BUILD_TYPE} = live ]]; then
669 case ${KDE_SCM} in 630 case ${KDE_SCM} in
670 svn) 631 svn)
671 migrate_store_dir 632 migrate_store_dir
672 subversion_src_unpack 633 subversion_src_unpack
673 ;; 634 ;;
717 enable_selected_doc_linguas 678 enable_selected_doc_linguas
718 fi 679 fi
719 fi 680 fi
720 681
721 # SCM bootstrap 682 # SCM bootstrap
722 if [[ ${BUILD_TYPE} = live ]]; then 683 if [[ ${KDE_BUILD_TYPE} = live ]]; then
723 case ${KDE_SCM} in 684 case ${KDE_SCM} in
724 svn) subversion_src_prepare ;; 685 svn) subversion_src_prepare ;;
725 esac 686 esac
726 fi 687 fi
727 688
736 # Inject library dependencies 697 # Inject library dependencies
737 if [[ -n ${KMLOADLIBS} ]] ; then 698 if [[ -n ${KMLOADLIBS} ]] ; then
738 load_library_dependencies 699 load_library_dependencies
739 fi 700 fi
740 701
741 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/... 702 # Hack for manuals relying on outdated DTD, only outside kde-base/...
742 if [[ -z ${KDEBASE} ]]; then 703 if [[ -z ${KDEBASE} ]]; then
743 find "${S}" -name "*.docbook" \ 704 find "${S}" -name "*.docbook" \
744 -exec sed -i -r \ 705 -exec sed -i -r \
745 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \ 706 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
746 || die 'failed to fix DocBook variant version' 707 || die 'failed to fix DocBook variant version'
756 # Build tests in src_test only, where we override this value 717 # Build tests in src_test only, where we override this value
757 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF) 718 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
758 719
759 if use_if_iuse debug; then 720 if use_if_iuse debug; then
760 # Set "real" debug mode 721 # Set "real" debug mode
761 CMAKE_BUILD_TYPE="Debugfull" 722 CMAKE_KDE_BUILD_TYPE="Debugfull"
762 else 723 else
763 # Handle common release builds 724 # Handle common release builds
764 append-cppflags -DQT_NO_DEBUG 725 append-cppflags -DQT_NO_DEBUG
765 fi 726 fi
766 727
783 744
784 # sysconf needs to be /etc, not /usr/etc 745 # sysconf needs to be /etc, not /usr/etc
785 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc) 746 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
786 747
787 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then 748 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
749 if [[ ${mycmakeargs} ]]; then
750 eqawarn "mycmakeargs should always be declared as an array, not a string"
751 fi
788 mycmakeargs=(${mycmakeargs}) 752 mycmakeargs=(${mycmakeargs})
789 fi 753 fi
790 754
791 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}") 755 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
792 756
805# @FUNCTION: kde4-base_src_test 769# @FUNCTION: kde4-base_src_test
806# @DESCRIPTION: 770# @DESCRIPTION:
807# Function for testing KDE4 applications. 771# Function for testing KDE4 applications.
808kde4-base_src_test() { 772kde4-base_src_test() {
809 debug-print-function ${FUNCNAME} "$@" 773 debug-print-function ${FUNCNAME} "$@"
774
775 local kded4_pid
776
777 _test_runner() {
778 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
779 export $(dbus-launch)
780 kded4 2>&1 > /dev/null &
781 kded4_pid=$!
782 fi
783
784 cmake-utils_src_test
785 }
786
787 # When run as normal user during ebuild development with the ebuild command, the
788 # kde tests tend to access the session DBUS. This however is not possible in a real
789 # emerge or on the tinderbox.
790 # > make sure it does not happen, so bad tests can be recognized and disabled
791 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
810 792
811 # Override this value, set in kde4-base_src_configure() 793 # Override this value, set in kde4-base_src_configure()
812 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON) 794 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
813 cmake-utils_src_configure 795 cmake-utils_src_configure
814 kde4-base_src_compile 796 kde4-base_src_compile
815
816 # When run as normal user during ebuild development with the ebuild command, the
817 # kde tests tend to access the session DBUS. This however is not possible in a real
818 # emerge or on the tinderbox.
819 # > make sure it does not happen, so bad tests can be recognized and disabled
820 unset DBUS_SESSION_BUS_ADDRESS
821 797
822 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then 798 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
823 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default 799 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
824 if [[ ${VIRTUALX_COMMAND} != emake ]]; then 800 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
825 # surprise- we are already INSIDE virtualmake!!! 801 # surprise- we are already INSIDE virtualmake!!!
826 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality." 802 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
827 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild." 803 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
828 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the" 804 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
829 debug-print " kde4-base.eclass docs for details... Applying workaround." 805 debug-print " kde4-base.eclass docs for details... Applying workaround."
830 cmake-utils_src_test 806 _test_runner
831 else 807 else
832 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake 808 VIRTUALX_COMMAND="_test_runner" virtualmake
833 fi 809 fi
834 else 810 else
835 cmake-utils_src_test 811 _test_runner
812 fi
813
814 if [ -n "${kded4_pid}" ] ; then
815 kill ${kded4_pid}
816 fi
817
818 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
819 kill ${DBUS_SESSION_BUS_PID}
836 fi 820 fi
837} 821}
838 822
839# @FUNCTION: kde4-base_src_install 823# @FUNCTION: kde4-base_src_install
840# @DESCRIPTION: 824# @DESCRIPTION:
870# Function storing icon caches 854# Function storing icon caches
871kde4-base_pkg_preinst() { 855kde4-base_pkg_preinst() {
872 debug-print-function ${FUNCNAME} "$@" 856 debug-print-function ${FUNCNAME} "$@"
873 857
874 gnome2_icon_savelist 858 gnome2_icon_savelist
875 if [[ ${BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then 859 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
876 subversion_pkg_preinst 860 subversion_pkg_preinst
877 fi 861 fi
878} 862}
879 863
880# @FUNCTION: kde4-base_pkg_postinst 864# @FUNCTION: kde4-base_pkg_postinst
887 fdo-mime_desktop_database_update 871 fdo-mime_desktop_database_update
888 fdo-mime_mime_database_update 872 fdo-mime_mime_database_update
889 buildsycoca 873 buildsycoca
890 874
891 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 875 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
892 if [[ ${BUILD_TYPE} = live ]]; then 876 if [[ ${KDE_BUILD_TYPE} = live ]]; then
893 echo 877 echo
894 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}" 878 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
895 einfo "Use it at your own risk." 879 einfo "Use it at your own risk."
896 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!" 880 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
897 echo 881 echo

Legend:
Removed from v.1.112  
changed lines
  Added in v.1.123

  ViewVC Help
Powered by ViewVC 1.1.20