/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.34 Revision 1.143
1# Copyright 2007-2009 Gentoo Foundation 1# Copyright 1999-2014 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.34 2009/04/13 00:02:45 scarabeus Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.143 2014/11/13 04:19:51 kensington Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds currently support EAPIs 4 and 5. This will be
14# eclass will fail with version older than 2. 14# reviewed over time as new EAPI versions are approved.
15 15
16inherit base cmake-utils eutils kde4-functions 16if [[ -z ${_KDE4_BASE_ECLASS} ]]; then
17_KDE4_BASE_ECLASS=1
17 18
18get_build_type 19# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
20# @DESCRIPTION:
21# If set to "none", do nothing.
22# For any other value, add selinux to IUSE, and depending on that useflag
23# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
24: ${KDE_SELINUX_MODULE:=none}
25
26# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
27# @DESCRIPTION:
28# If defined, launch and use a private dbus session during src_test.
29
30# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
31# @DESCRIPTION:
32# For proper description see virtualx.eclass manpage.
33# Here we redefine default value to be manual, if your package needs virtualx
34# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
35: ${VIRTUALX_REQUIRED:=manual}
36
37inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils virtualx versionator eutils multilib
38
19if [[ ${BUILD_TYPE} = live ]]; then 39if [[ ${KDE_BUILD_TYPE} = live ]]; then
40 case ${KDE_SCM} in
20 inherit subversion 41 svn) inherit subversion ;;
42 git) inherit git-r3 ;;
43 esac
21fi 44fi
22 45
23EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_test src_install pkg_postinst pkg_postrm 46# @ECLASS-VARIABLE: CMAKE_REQUIRED
47# @DESCRIPTION:
48# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
49# Please note that if it's set to 'never' you need to explicitly override following phases:
50# src_configure, src_compile, src_test and src_install.
51# Defaults to 'always'.
52: ${CMAKE_REQUIRED:=always}
53if [[ ${CMAKE_REQUIRED} = always ]]; then
54 buildsystem_eclass="cmake-utils"
55 export_fns="src_configure src_compile src_test src_install"
56fi
57
58# @ECLASS-VARIABLE: KDE_MINIMAL
59# @DESCRIPTION:
60# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
61# version for apps to work. Currently defaults to 4.4
62# One may override this variable to raise version requirements.
63# Note that it is fixed to ${PV} for kde-base packages.
64KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
65
66# Set slot for KDEBASE known packages
67case ${KDEBASE} in
68 kde-base)
69 case ${EAPI} in
70 5)
71 SLOT=4/$(get_version_component_range 1-2)
72 ;;
73 *)
74 SLOT=4
75 ;;
76 esac
77 KDE_MINIMAL="${PV}"
78 ;;
79 kdevelop)
80 if [[ ${KDE_BUILD_TYPE} = live ]]; then
81 # @ECLASS-VARIABLE: KDEVELOP_VERSION
82 # @DESCRIPTION:
83 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
84 # Applies to KDEBASE=kdevelop only.
85 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.9999}"
86 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
87 # @DESCRIPTION:
88 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
89 # Applies to KDEBASE=kdevelop only.
90 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-4.9999}"
91 else
92 case ${PN} in
93 kdevelop)
94 KDEVELOP_VERSION=${PV}
95 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
96 ;;
97 kdevplatform|kdevelop-php*|kdevelop-python)
98 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
99 KDEVPLATFORM_VERSION=${PV}
100 ;;
101 *)
102 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
103 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
104 esac
105 fi
106 SLOT="4"
107 ;;
108esac
109
110inherit ${buildsystem_eclass}
111
112EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
113
114unset buildsystem_eclass
115unset export_fns
116
117# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
118# @DESCRIPTION:
119# Is qtdeclarative required? Possible values are 'always', 'optional' and 'never'.
120# This variable must be set before inheriting any eclasses. Defaults to 'never'.
121DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
122
123# @ECLASS-VARIABLE: QTHELP_REQUIRED
124# @DESCRIPTION:
125# Is qthelp required? Possible values are 'always', 'optional' and 'never'.
126# This variable must be set before inheriting any eclasses. Defaults to 'never'.
127QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
24 128
25# @ECLASS-VARIABLE: OPENGL_REQUIRED 129# @ECLASS-VARIABLE: OPENGL_REQUIRED
26# @DESCRIPTION: 130# @DESCRIPTION:
27# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 131# Is qtopengl required? Possible values are 'always', 'optional' and 'never'.
28# This variable must be set before inheriting any eclasses. Defaults to 'never'. 132# This variable must be set before inheriting any eclasses. Defaults to 'never'.
29OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 133OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
30 134
31# @ECLASS-VARIABLE: WEBKIT_REQUIRED 135# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
32# @DESCRIPTION: 136# @DESCRIPTION:
33# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'. 137# Is qtmultimedia required? Possible values are 'always', 'optional' and 'never'.
34# This variable must be set before inheriting any eclasses. Defaults to 'never'. 138# This variable must be set before inheriting any eclasses. Defaults to 'never'.
35WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}" 139MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
36 140
37# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 141# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
38# @DESCRIPTION: 142# @DESCRIPTION:
39# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 143# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
40# This variable must be set before inheriting any eclasses. Defaults to 'never'. 144# This variable must be set before inheriting any eclasses. Defaults to 'never'.
42 146
43# @ECLASS-VARIABLE: KDE_REQUIRED 147# @ECLASS-VARIABLE: KDE_REQUIRED
44# @DESCRIPTION: 148# @DESCRIPTION:
45# Is kde required? Possible values are 'always', 'optional' and 'never'. 149# Is kde required? Possible values are 'always', 'optional' and 'never'.
46# This variable must be set before inheriting any eclasses. Defaults to 'always' 150# This variable must be set before inheriting any eclasses. Defaults to 'always'
47# If set to always or optional, KDE_MINIMAL may be overriden as well. 151# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
48# Note that for kde-base packages this variable is fixed to 'always'. 152# Note that for kde-base packages this variable is fixed to 'always'.
49KDE_REQUIRED="${KDE_REQUIRED:-always}" 153KDE_REQUIRED="${KDE_REQUIRED:-always}"
50 154
51# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here) 155# @ECLASS-VARIABLE: KDE_HANDBOOK
52if [[ -n ${KDE_MINIMAL} ]]; then 156# @DESCRIPTION:
53 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 157# Set to enable handbook in application. Possible values are 'always', 'optional'
54 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break 158# (handbook USE flag) and 'never'.
55 done 159# This variable must be set before inheriting any eclasses. Defaults to 'never'.
56 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL 160# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
57else 161# ensures buildtime and runtime dependencies.
58 KDE_MINIMAL_VALID=1 162KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
163
164# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
165# @DESCRIPTION:
166# Set this varible if you want your live package to manage its
167# translations. (Mostly all kde ebuilds does not ship documentation
168# and translations in live ebuilds)
169if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
170 # Kdebase actualy provides the handbooks even for live stuff
171 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
172 KDE_LINGUAS=""
59fi 173fi
60 174
175# Setup packages inheriting this eclass
176case ${KDEBASE} in
177 kde-base)
178 HOMEPAGE="http://www.kde.org/"
179 LICENSE="GPL-2"
180 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
181 # Disable tests for live ebuilds by default
182 RESTRICT+=" test"
183 fi
184
185 # This code is to prevent portage from searching GENTOO_MIRRORS for
186 # packages that will never be mirrored. (As they only will ever be in
187 # the overlay).
188 case ${PV} in
189 *9999* | 4.?.[6-9]? | 4.??.[6-9]?)
190 RESTRICT+=" mirror"
191 ;;
192 esac
193 ;;
194 kdevelop)
195 HOMEPAGE="http://www.kdevelop.org/"
196 LICENSE="GPL-2"
197 ;;
198esac
199
61# @ECLASS-VARIABLE: KDE_MINIMAL 200# @ECLASS-VARIABLE: QT_MINIMAL
62# @DESCRIPTION: 201# @DESCRIPTION:
63# This wariable is used when KDE_REQUIRED is set, to specify required KDE minimal 202# Determine version of qt we enforce as minimal for the package.
64# version for apps to work. Currently defaults to 4.2
65# One may override this variable to raise version requirements.
66# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
67# Note that for kde-base packages is fixed to ${SLOT}.
68KDE_MINIMAL="${KDE_MINIMAL:-4.2}" 203QT_MINIMAL="${QT_MINIMAL:-4.8.5}"
69 204
70# Fallback behaviour (for now) 205# Declarative dependencies
71# TODO Remove when tree is clean 206qtdeclarativedepend="
72if [[ -n ${NEED_KDE} ]]; then 207 >=dev-qt/qtdeclarative-${QT_MINIMAL}:4
73 case ${NEED_KDE} in 208"
74 none) 209case ${DECLARATIVE_REQUIRED} in
75 KDE_REQUIRED="never" 210 always)
211 COMMONDEPEND+=" ${qtdeclarativedepend}"
76 ;; 212 ;;
77 *) 213 optional)
78 KDE_REQUIRED="always" 214 IUSE+=" declarative"
79 KDE_MINIMAL="${NEED_KDE}" 215 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
80 ;; 216 ;;
217 *) ;;
81 esac 218esac
82fi 219unset qtdeclarativedepend
220
221# QtHelp dependencies
222qthelpdepend="
223 >=dev-qt/qthelp-${QT_MINIMAL}:4
224"
225case ${QTHELP_REQUIRED} in
226 always)
227 COMMONDEPEND+=" ${qthelpdepend}"
228 ;;
229 optional)
230 IUSE+=" qthelp"
231 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
232 ;;
233esac
234unset qthelpdepend
83 235
84# OpenGL dependencies 236# OpenGL dependencies
85qtopengldepend=" 237qtopengldepend="
86 x11-libs/qt-opengl:4 238 >=dev-qt/qtopengl-${QT_MINIMAL}:4
87" 239"
88case ${OPENGL_REQUIRED} in 240case ${OPENGL_REQUIRED} in
89 always) 241 always)
90 COMMONDEPEND="${COMMONDEPEND} ${qtopengldepend}" 242 COMMONDEPEND+=" ${qtopengldepend}"
91 ;; 243 ;;
92 optional) 244 optional)
93 IUSE="${IUSE} opengl" 245 IUSE+=" opengl"
94 COMMONDEPEND="${COMMONDEPEND}
95 opengl? ( ${qtopengldepend} ) 246 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
96 "
97 ;; 247 ;;
98 *) ;; 248 *) ;;
99esac 249esac
100unset qtopengldepend 250unset qtopengldepend
101 251
102# WebKit dependencies 252# MultiMedia dependencies
103qtwebkitdepend=" 253qtmultimediadepend="
104 x11-libs/qt-webkit:4 254 >=dev-qt/qtmultimedia-${QT_MINIMAL}:4
105" 255"
106case ${WEBKIT_REQUIRED} in 256case ${MULTIMEDIA_REQUIRED} in
107 always) 257 always)
108 COMMONDEPEND="${COMMONDEPEND} ${qtwebkitdepend}" 258 COMMONDEPEND+=" ${qtmultimediadepend}"
109 ;; 259 ;;
110 optional) 260 optional)
111 IUSE="${IUSE} webkit" 261 IUSE+=" multimedia"
112 COMMONDEPEND="${COMMONDEPEND} 262 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
113 webkit? ( ${qtwebkitdepend} )
114 "
115 ;; 263 ;;
116 *) ;; 264 *) ;;
117esac 265esac
118unset qtwebkitdepend 266unset qtmultimediadepend
119 267
120# CppUnit dependencies 268# CppUnit dependencies
121cppuintdepend=" 269cppuintdepend="
122 dev-util/cppunit 270 dev-util/cppunit
123" 271"
124case ${CPPUNIT_REQUIRED} in 272case ${CPPUNIT_REQUIRED} in
125 always) 273 always)
126 DEPEND="${DEPEND} ${cppuintdepend}" 274 DEPEND+=" ${cppuintdepend}"
127 ;; 275 ;;
128 optional) 276 optional)
129 IUSE="${IUSE} test" 277 IUSE+=" test"
130 DEPEND="${DEPEND}
131 test? ( ${cppuintdepend} ) 278 DEPEND+=" test? ( ${cppuintdepend} )"
132 "
133 ;; 279 ;;
134 *) ;; 280 *) ;;
135esac 281esac
136unset cppuintdepend 282unset cppuintdepend
137 283
138# DEPRECATED block
139if [[ ${NEED_KDE} != "none" ]]; then
140 # localization deps
141 # DISABLED UNTIL PMS decide correct approach :(
142 if [[ -n ${KDE_LINGUAS} ]]; then
143 LNG_DEP=""
144 for _lng in ${KDE_LINGUAS}; do
145 # there must be or due to issue if lingua is not present in kde-l10n so
146 # it wont die but pick kde-l10n as-is.
147 LNG_DEP="${LNG_DEP}
148 || (
149 kde-base/kde-l10n[linguas_${_lng},kdeprefix=]
150 kde-base/kde-l10n[kdeprefix=]
151 )
152 "
153 done
154 fi
155fi # NEED_KDE != NONE block
156
157# Setup packages inheriting this eclass
158case ${KDEBASE} in
159
160 kde-base)
161 if [[ $BUILD_TYPE = live ]]; then
162 # Disable tests for live ebuilds
163 RESTRICT="${RESTRICT} test"
164 # Live ebuilds in kde-base default to kdeprefix by default
165 IUSE="${IUSE} +kdeprefix"
166 else
167 # All other ebuild types default to -kdeprefix as before
168 IUSE="${IUSE} kdeprefix"
169 fi
170 # Determine SLOT from PV
171 case ${PV} in
172 4.3* | 4.2.9* | 4.2.8* | 4.2.7* | 4.2.6*) SLOT="4.3" ;;
173 4.2* | 4.1.9* | 4.1.8* | 4.1.7* | 4.1.6*) SLOT="4.2" ;;
174 *9999*) SLOT="live" ;;
175 *) die "Unsupported ${PV}" ;;
176 esac
177 _kdedir="${SLOT}"
178 _pv="-${PV}:${SLOT}"
179 _pvn="-${PV}"
180
181 # Block installation of other SLOTS unless kdeprefix
182 for slot in ${KDE_SLOTS[@]}; do
183 # Block non kdeprefix ${PN} on other slots
184 if [[ ${SLOT} != ${slot} ]]; then
185 RDEPEND="${RDEPEND}
186 !kdeprefix? ( !kde-base/${PN}:${slot}[-kdeprefix] )
187 "
188 fi
189 done
190 ;;
191
192 koffice)
193 SLOT="2"
194 _pv="-${KDE_MINIMAL}"
195 _pvn="${_pv}"
196 ;;
197
198 *)
199 _pv="-${KDE_MINIMAL}"
200 _pvn="${_pv}"
201 ;;
202
203esac
204
205# KDE dependencies 284# KDE dependencies
285# Qt accessibility classes are needed in various places, bug 325461
206kdecommondepend=" 286kdecommondepend="
207 dev-lang/perl 287 dev-lang/perl
208 x11-libs/libXext 288 >=dev-qt/qt3support-${QT_MINIMAL}:4[accessibility]
209 x11-libs/libXt 289 >=dev-qt/qtcore-${QT_MINIMAL}:4[qt3support,ssl]
210 x11-libs/libXxf86vm 290 >=dev-qt/qtdbus-${QT_MINIMAL}:4
211 x11-libs/qt-core:4[qt3support,ssl] 291 >=dev-qt/designer-${QT_MINIMAL}:4[-phonon]
212 x11-libs/qt-gui:4[accessibility,dbus] 292 >=dev-qt/qtgui-${QT_MINIMAL}:4[accessibility,dbus(+)]
213 x11-libs/qt-qt3support:4[accessibility] 293 >=dev-qt/qtscript-${QT_MINIMAL}:4
214 x11-libs/qt-script:4 294 >=dev-qt/qtsql-${QT_MINIMAL}:4[qt3support]
215 x11-libs/qt-sql:4[qt3support] 295 >=dev-qt/qtsvg-${QT_MINIMAL}:4
216 x11-libs/qt-svg:4 296 >=dev-qt/qttest-${QT_MINIMAL}:4
217 x11-libs/qt-test:4 297 >=dev-qt/qtwebkit-${QT_MINIMAL}:4
218" 298"
299
219if [[ ${PN} != kdelibs ]]; then 300if [[ ${PN} != kdelibs ]]; then
301 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
220 if [[ ${KDEBASE} = kde-base ]]; then 302 if [[ ${KDEBASE} = kdevelop ]]; then
221 kdecommondepend="${kdecommondepend} 303 if [[ ${PN} != kdevplatform ]]; then
222 kdeprefix? ( >=kde-base/kdelibs${_pv}[kdeprefix] ) 304 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
223 !kdeprefix? ( >=kde-base/kdelibs${_pvn}[-kdeprefix] ) 305 # @DESCRIPTION:
306 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
307 # Applies to KDEBASE=kdevelop only.
308 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
309 case ${KDEVPLATFORM_REQUIRED} in
310 always)
311 kdecommondepend+="
312 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}:4
313 "
314 ;;
315 *) ;;
316 esac
317 fi
318 fi
319fi
320
321kdedepend="
322 dev-util/automoc
323 virtual/pkgconfig
324 !aqua? (
325 >=x11-libs/libXtst-1.1.0
326 x11-proto/xf86vidmodeproto
327 )
328"
329
330kderdepend=""
331
332# all packages needs oxygen icons for basic iconset
333if [[ ${PN} != oxygen-icons ]]; then
334 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
335fi
336
337# add a dependency over kde-l10n
338if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} ]]; then
339 for _lingua in ${KDE_LINGUAS}; do
340 # if our package has lignuas, pull in kde-l10n with selected lingua enabled,
341 # but only for selected ones.
342 # this can't be done on one line because if user doesn't use any localisation
343 # then he is probably not interested in kde-l10n at all.
344 kderdepend+="
345 linguas_${_lingua}? ( $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") )
224 " 346 "
225 else 347 done
226 kdecommondepend="${kdecommondepend} 348 unset _lingua
227 >=kde-base/kdelibs${_pv}
228 "
229 fi
230fi 349fi
231unset _pv _pvn 350
232kdedepend=" 351kdehandbookdepend="
233 >=dev-util/cmake-2.6.2 352 app-text/docbook-xml-dtd:4.2
234 dev-util/pkgconfig 353 app-text/docbook-xsl-stylesheets
235 >=sys-apps/sandbox-1.3.2
236" 354"
355kdehandbookrdepend="
356 $(add_kdebase_dep kdelibs 'handbook')
357"
358case ${KDE_HANDBOOK} in
359 always)
360 kdedepend+=" ${kdehandbookdepend}"
361 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
362 ;;
363 optional)
364 IUSE+=" +handbook"
365 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
366 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
367 ;;
368 *) ;;
369esac
370unset kdehandbookdepend kdehandbookrdepend
371
372case ${KDE_SELINUX_MODULE} in
373 none) ;;
374 *)
375 IUSE+=" selinux"
376 kdecommondepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
377 ;;
378esac
379
380# We always need the aqua useflag because otherwise we cannot = refer to it inside
381# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
382# (where referring to a use flag not in IUSE masks the ebuild).
383# The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
384IUSE+=" aqua"
385
237case ${KDE_REQUIRED} in 386case ${KDE_REQUIRED} in
238 always) 387 always)
239 COMMONDEPEND="${COMMONDEPEND} ${kdecommondepend}" 388 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
240 DEPEND="${DEPEND} ${kdedepend}" 389 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
390 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
241 ;; 391 ;;
242 optional) 392 optional)
243 IUSE="${IUSE} kde" 393 IUSE+=" kde"
244 COMMONDEPEND="${COMMONDEPEND} 394 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
245 kde? ( ${kdecommondepend} )" 395 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
246 DEPEND="${DEPEND} 396 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
247 kde? ( ${kdedepend} )"
248 ;; 397 ;;
249 *) ;; 398 *) ;;
250esac 399esac
400
251unset kdecommondepend kdedepend 401unset kdecommondepend kdedepend kderdepend
252 402
253debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}" 403debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
254debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}" 404debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
255debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}" 405debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
256 406
257# Accumulate dependencies set by this eclass 407# Accumulate dependencies set by this eclass
258DEPEND="${DEPEND} ${COMMONDEPEND}" 408DEPEND+=" ${COMMONDEPEND}"
259RDEPEND="${RDEPEND} ${COMMONDEPEND}" 409RDEPEND+=" ${COMMONDEPEND}"
410unset COMMONDEPEND
260 411
261# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 412# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
262# koffice ebuild, the URI should be set in the ebuild itself 413# kdevelop ebuild, the URI should be set in the ebuild itself
263case ${BUILD_TYPE} in 414_calculate_src_uri() {
264 live) 415 debug-print-function ${FUNCNAME} "$@"
265 SRC_URI="" 416
266 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde} 417 local _kmname _kmname_pv
267 # Split ebuild, or extragear stuff 418
419 # we calculate URI only for known KDEBASE modules
420 [[ -n ${KDEBASE} ]] || return
421
422 # calculate tarball module name
268 if [[ -n ${KMNAME} ]]; then 423 if [[ -n ${KMNAME} ]]; then
269 ESVN_PROJECT="${KMNAME}" 424 _kmname="${KMNAME}"
270 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then 425 else
271 KMMODULE="${PN}" 426 _kmname=${PN}
272 fi 427 fi
273 # Split kde-base/ ebuilds: (they reside in trunk/KDE) 428 _kmname_pv="${_kmname}-${PV}"
274 case ${KMNAME} in 429 case ${KDEBASE} in
275 kdebase-*) 430 kde-base)
276 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/KDE/kdebase/${KMNAME#kdebase-}" 431 case ${PV} in
432 4.4.11.1)
433 # KDEPIM 4.4, special case
434 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
435 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
436 4.?.[6-9]? | 4.??.[6-9]?)
437 # Unstable KDE SC releases
438 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
439 4.[1-7].[12345])
440 # Stable KDE SC with old .bz2 support
441 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
442 4.11.9)
443 # Part of 4.12 actually, sigh. Not stable for next release!
444 SRC_URI="mirror://kde/stable/4.12.5/src/${_kmname_pv}.tar.xz" ;;
445 4.11.11)
446 # Part of 4.13 actually, sigh. Not stable for next release!
447 SRC_URI="mirror://kde/stable/4.13.3/src/${_kmname_pv}.tar.xz" ;;
448 4.11.12)
449 # Part of 4.14 actually, sigh. Not stable for next release!
450 SRC_URI="mirror://kde/stable/4.14.1/src/${_kmname_pv}.tar.xz" ;;
451 4.11.13)
452 # Part of 4.14 actually, sigh. Not stable for next release!
453 SRC_URI="mirror://kde/stable/4.14.2/src/${_kmname_pv}.tar.xz" ;;
454 4.11.14)
455 # Part of 4.14 actually, sigh. Not stable for next release!
456 SRC_URI="mirror://kde/stable/4.14.3/src/${_kmname_pv}.tar.xz" ;;
457 *)
458 # Stable KDE SC releases
459 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz" ;;
460 esac
277 ;; 461 ;;
278 kdereview) 462 kdevelop|kdevelop-php*|kdevplatform)
279 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 463 case ${KDEVELOP_VERSION} in
464 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
465 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
466 esac
280 ;; 467 ;;
281 kdesupport) 468 esac
282 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 469}
283 ESVN_PROJECT="${PN}" 470
284 ;; 471_calculate_live_repo() {
285 kde*) 472 debug-print-function ${FUNCNAME} "$@"
286 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/KDE/${KMNAME}" 473
287 ;; 474 SRC_URI=""
288 extragear*|playground*) 475 case ${KDE_SCM} in
289 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta 476 svn)
290 # build packages from same svn location. 477 # Determine branch URL based on live type
291 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 478 local branch_prefix
292 ESVN_PROJECT="${PN}" 479 case ${PV} in
293 ;; 480 4.9999*)
294 koffice) 481 # trunk
295 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}" 482 branch_prefix="trunk/KDE"
296 ;; 483 ;;
297 *) 484 *)
298 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 485 # branch
486 branch_prefix="branches/KDE/$(get_kde_version)"
487 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
488 # @DESCRIPTION
489 # Suffix appended to ESVN_PROJECT depending on fetched branch.
490 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
491 ESVN_PROJECT_SUFFIX="-${PV}"
299 ;; 492 ;;
300 esac 493 esac
301 else 494 # @ECLASS-VARIABLE: ESVN_MIRROR
302 # kdelibs, kdepimlibs 495 # @DESCRIPTION:
303 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/KDE/${PN}" 496 # This variable allows easy overriding of default kde mirror service
304 ESVN_PROJECT="${PN}" 497 # (anonsvn) with anything else you might want to use.
305 fi 498 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
306 # limit syncing to 1 hour. 499 # Split ebuild, or extragear stuff
307 ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
308 ;;
309 *)
310 if [[ -n ${KDEBASE} ]]; then
311 if [[ -n ${KMNAME} ]]; then 500 if [[ -n ${KMNAME} ]]; then
501 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
502 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
503 KMMODULE="${PN}"
504 fi
505 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
312 case ${KMNAME} in 506 case ${KMNAME} in
313 kdebase-apps) 507 kdebase-*)
314 _kmname="kdebase" ;; 508 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
509 ;;
510 kdelibs-*)
511 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
512 ;;
513 kdereview*)
514 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
515 ;;
516 kdesupport)
517 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
518 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
519 ;;
520 kde*)
521 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
522 ;;
523 extragear*|playground*)
524 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
525 # build packages from same svn location.
526 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
527 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
528 ;;
315 *) 529 *)
316 _kmname="${KMNAME}" ;; 530 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
531 ;;
317 esac 532 esac
533 else
534 # kdelibs, kdepimlibs
535 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
536 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
537 fi
538 # @ECLASS-VARIABLE: ESVN_UP_FREQ
539 # @DESCRIPTION:
540 # This variable is used for specifying the timeout between svn synces
541 # for kde-base modules. Does not affect misc apps.
542 # Default value is 1 hour.
543 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
544 ;;
545 git)
546 local _kmname
547 # @ECLASS-VARIABLE: EGIT_MIRROR
548 # @DESCRIPTION:
549 # This variable allows easy overriding of default kde mirror service
550 # (anongit) with anything else you might want to use.
551 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
552
553 # @ECLASS-VARIABLE: EGIT_REPONAME
554 # @DESCRIPTION:
555 # This variable allows overriding of default repository
556 # name. Specify only if this differ from PN and KMNAME.
557 if [[ -n ${EGIT_REPONAME} ]]; then
558 # the repository and kmname different
559 _kmname=${EGIT_REPONAME}
560 elif [[ -n ${KMNAME} ]]; then
561 _kmname=${KMNAME}
318 else 562 else
319 _kmname=${PN} 563 _kmname=${PN}
320 fi 564 fi
321 _kmname_pv="${_kmname}-${PV}" 565
322 if [[ $NEED_KDE != live ]]; then 566 # default branching
323 case ${KDEBASE} in 567 [[ ${PV} != 4.9999* && ${KDEBASE} == kde-base ]] && \
324 kde-base) 568 EGIT_BRANCH="KDE/$(get_kde_version)"
325 case ${PV} in 569
326 4.2.9* | 4.2.8* | 4.2.7* | 4.2.6*) 570 # default repo uri
327 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.lzma" ;; 571 EGIT_REPO_URI+=( "${EGIT_MIRROR}/${_kmname}" )
328 4.1.9* | 4.1.8* | 4.1.7* | 4.1.6* | 4.0.9* | 4.0.8*) 572
329 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 573 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
330 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 574 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
331 esac
332 ;;
333 koffice)
334 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2"
335 ;; 575 ;;
336 esac 576 esac
337 fi 577}
338 unset _kmname _kmname_pv 578
339 fi 579case ${KDE_BUILD_TYPE} in
340 ;; 580 live) _calculate_live_repo ;;
581 *) _calculate_src_uri ;;
341esac 582esac
342 583
343debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}" 584debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
344 585
345# @ECLASS-VARIABLE: PREFIX 586# @ECLASS-VARIABLE: PREFIX
346# @DESCRIPTION: 587# @DESCRIPTION:
347# Set the installation PREFIX for non kde-base applications. It defaults to /usr. 588# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
348# kde-base packages go into KDE4 installation directory (KDEDIR) by default. 589# kde-base packages go into KDE4 installation directory (/usr).
349# No matter the PREFIX, package will be built agains KDE installed in KDEDIR. 590# No matter the PREFIX, package will be built against KDE installed in /usr.
350 591
351# @FUNCTION: kde4-base_pkg_setup 592# @FUNCTION: kde4-base_pkg_setup
352# @DESCRIPTION: 593# @DESCRIPTION:
353# Do the basic kdeprefix KDEDIR settings and determine with which kde should 594# Do some basic settings
354# optional applications link
355kde4-base_pkg_setup() { 595kde4-base_pkg_setup() {
356 debug-print-function ${FUNCNAME} "$@" 596 debug-print-function ${FUNCNAME} "$@"
357 597
358 # QA ebuilds 598 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
359 case ${NEED_KDE} in 599 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
360 none) ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_REQUIRED=\"never\" or KDE_REQUIRED=\"optional\" instead. You may want to override KDE_MINIMAL as well (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;; 600 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
361 *) [[ -n ${NEED_KDE} ]] && ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_MINIMAL instead (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;; 601 fi
362 esac
363 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
364 602
365 # Don't set KDEHOME during compilation, it will cause access violations 603 # Don't set KDEHOME during compilation, it will cause access violations
366 unset KDEHOME 604 unset KDEHOME
367 605
368 if [[ ${KDEBASE} = kde-base ]]; then 606 # Check if gcc compiler is fresh enough.
369 if use kdeprefix; then 607 # In theory should be in pkg_pretend but we check it only for kdelibs there
370 KDEDIR="/usr/kde/${_kdedir}" 608 # and for others we do just quick scan in pkg_setup because pkg_pretend
371 else 609 # executions consume quite some time (ie. when merging 300 packages at once will cause 300 checks)
372 KDEDIR="/usr" 610 if [[ ${MERGE_TYPE} != binary ]]; then
611 [[ $(gcc-major-version) -lt 4 ]] || \
612 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 6 ]] ) \
613 && die "Sorry, but gcc-4.6 and earlier wont work for some KDE packages."
373 fi 614 fi
374 PREFIX="${PREFIX:-${KDEDIR}}" 615
375 else
376 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
377 KDEDIR=
378 local kde_minimal_met
379 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
380 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
381 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
382 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
383 KDEDIR="/usr/kde/${slot}"
384 else
385 KDEDIR="/usr" 616 KDEDIR=/usr
386 fi 617 : ${PREFIX:=/usr}
387 break; 618 EKDEDIR=${EPREFIX}/usr
388 fi
389 done
390 [[ -z KDEDIR ]] && die "Failed to determine KDEDIR!"
391 PREFIX="${PREFIX:-/usr}"
392 fi
393 619
394 # Not needed anymore 620 # Point to correct QT plugins path
395 unset _kdedir 621 QT_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/kde4/plugins/"
396 622
397 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 623 # Fix XDG collision with sandbox
398 echo 624 export XDG_CONFIG_HOME="${T}"
399 elog "WARNING! This is an experimental live ebuild of ${KMNAME:-${PN}}"
400 elog "Use it at your own risk."
401 elog "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
402 echo
403 fi
404} 625}
405 626
406# @FUNCTION: kde4-base_src_unpack 627# @FUNCTION: kde4-base_src_unpack
407# @DESCRIPTION: 628# @DESCRIPTION:
408# This function unpacks the source tarballs for KDE4 applications. 629# This function unpacks the source tarballs for KDE4 applications.
409kde4-base_src_unpack() { 630kde4-base_src_unpack() {
410 debug-print-function ${FUNCNAME} "$@" 631 debug-print-function ${FUNCNAME} "$@"
411 632
412 if [[ ${BUILD_TYPE} = live ]]; then 633 if [[ ${KDE_BUILD_TYPE} = live ]]; then
413 migrate_store_dir 634 case ${KDE_SCM} in
635 svn)
414 subversion_src_unpack 636 subversion_src_unpack
637 ;;
638 git)
639 git-r3_src_unpack
640 ;;
641 esac
415 else 642 else
416 base_src_unpack 643 unpack ${A}
417 fi 644 fi
418} 645}
419 646
420# @FUNCTION: kde4-base_src_compile 647# @FUNCTION: kde4-base_src_prepare
421# @DESCRIPTION: 648# @DESCRIPTION:
422# General pre-configure and pre-compile function for KDE4 applications. 649# General pre-configure and pre-compile function for KDE4 applications.
423# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and 650# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
651# enable_selected_linguas() and enable_selected_doc_linguas()
424# enable_selected_linguas() in kde4-functions.eclass(5) for further details. 652# in kde4-functions.eclass(5) for further details.
425kde4-base_src_prepare() { 653kde4-base_src_prepare() {
426 debug-print-function ${FUNCNAME} "$@" 654 debug-print-function ${FUNCNAME} "$@"
655
656 # enable handbook and linguas only when not using live ebuild
427 657
428 # Only enable selected languages, used for KDE extragear apps. 658 # Only enable selected languages, used for KDE extragear apps.
429 if [[ -n ${KDE_LINGUAS} ]]; then 659 if [[ -n ${KDE_LINGUAS} ]]; then
430 enable_selected_linguas 660 enable_selected_linguas
431 fi 661 fi
432 662
433 base_src_prepare 663 # Enable/disable handbooks for kde4-base packages
664 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
665 # kdelibs inherits kde4-base but handle installing the handbook itself
666 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
667 if [[ ${KDEBASE} == kde-base ]]; then
668 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
669 # documentation in kde4-functions
670 : ${KDE_DOC_DIRS:=doc}
671 local dir
672 for dir in ${KDE_DOC_DIRS}; do
673 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
674 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
675 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
676 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
677 -i CMakeLists.txt || die "failed to comment out handbook"
678 done
679 fi
680 else
681 enable_selected_doc_linguas
682 fi
683 fi
684
685 # SCM bootstrap
686 if [[ ${KDE_BUILD_TYPE} = live ]]; then
687 case ${KDE_SCM} in
688 svn) subversion_src_prepare ;;
689 esac
690 fi
691
692 # Apply patches, cmake-utils does the job already
693 cmake-utils_src_prepare
434 694
435 # Save library dependencies 695 # Save library dependencies
436 if [[ -n ${KMSAVELIBS} ]] ; then 696 if [[ -n ${KMSAVELIBS} ]] ; then
437 save_library_dependencies 697 save_library_dependencies
438 fi 698 fi
439 699
440 # Inject library dependencies 700 # Inject library dependencies
441 if [[ -n ${KMLOADLIBS} ]] ; then 701 if [[ -n ${KMLOADLIBS} ]] ; then
442 load_library_dependencies 702 load_library_dependencies
443 fi 703 fi
704
705 # Hack for manuals relying on outdated DTD, only outside kde-base/...
706 if [[ -z ${KDEBASE} ]]; then
707 find "${S}" -name "*.docbook" \
708 -exec sed -i -r \
709 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
710 || die 'failed to fix DocBook variant version'
711 fi
444} 712}
445 713
446# @FUNCTION: kde4-base_src_configure 714# @FUNCTION: kde4-base_src_configure
447# @DESCRIPTION: 715# @DESCRIPTION:
448# Function for configuring the build of KDE4 applications. 716# Function for configuring the build of KDE4 applications.
449kde4-base_src_configure() { 717kde4-base_src_configure() {
450 debug-print-function ${FUNCNAME} "$@" 718 debug-print-function ${FUNCNAME} "$@"
451 719
720 # Build tests in src_test only, where we override this value
721 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
722
723 if use_if_iuse debug; then
724 # Set "real" debug mode
725 CMAKE_KDE_BUILD_TYPE="Debugfull"
726 else
452 # Handle common release builds 727 # Handle common release builds
453 if ! has debug ${IUSE//+} || ! use debug; then
454 append-cppflags -DQT_NO_DEBUG 728 append-cppflags -DQT_NO_DEBUG
455 fi 729 fi
456 730
457 # Build tests in src_test only, where we override this value
458 local cmakeargs="-DKDE4_BUILD_TESTS=OFF"
459
460 # Set distribution name 731 # Set distribution name
461 [[ ${PN} = kdelibs ]] && cmakeargs="${cmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo" 732 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
462 733
463 # Here we set the install prefix 734 # Here we set the install prefix
464 cmakeargs="${cmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}" 735 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
465 736
466 # Set environment 737 # Use colors
467 QTEST_COLORED=1 738 QTEST_COLORED=1
468 QT_PLUGIN_PATH="${KDEDIR}/$(get_libdir)/kde4/plugins/"
469 739
470 # Hardcode path to *.pc KDE files
471 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}${KDEDIR}/$(get_libdir)/pkgconfig"
472
473 # Shadow existing /usr installations 740 # Shadow existing installations
474 unset KDEDIRS 741 unset KDEDIRS
475 742
476 # Override some environment variables - only when kdeprefix is different, 743 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
477 # to not break ccache/distcc 744 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
478 if [[ ${KDEDIR} != /usr ]]; then 745 #kde-config -path data unavailable when cross-compiling
479 PATH="${KDEDIR}/bin:${PATH}" 746 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
480 LDPATH="${KDEDIR}/$(get_libdir):${LDPATH}" 747
748 # sysconf needs to be /etc, not /usr/etc
749 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
750
751 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
752 if [[ ${mycmakeargs} ]]; then
753 eqawarn "mycmakeargs should always be declared as an array, not a string"
481 fi 754 fi
482 755 mycmakeargs=(${mycmakeargs})
483 if has kdeprefix ${IUSE//+} && use kdeprefix; then
484 # Set cmake prefixes to allow buildsystem to localize valid KDE installation
485 # when more are present
486 cmakeargs="${cmakeargs} -DCMAKE_SYSTEM_PREFIX_PATH=${KDEDIR}"
487 else
488 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
489 cmakeargs="${cmakeargs} -DSYSCONF_INSTALL_DIR=/etc"
490 fi 756 fi
491 757
492 mycmakeargs="${cmakeargs} ${mycmakeargs}" 758 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
493 759
494 cmake-utils_src_configure 760 cmake-utils_src_configure
495} 761}
496 762
497# @FUNCTION: kde4-base_src_compile 763# @FUNCTION: kde4-base_src_compile
498# @DESCRIPTION: 764# @DESCRIPTION:
499# General function for compiling KDE4 applications. 765# General function for compiling KDE4 applications.
500kde4-base_src_compile() { 766kde4-base_src_compile() {
501 debug-print-function ${FUNCNAME} "$@" 767 debug-print-function ${FUNCNAME} "$@"
502 768
503 cmake-utils_src_compile 769 cmake-utils_src_compile "$@"
504} 770}
505 771
506# @FUNCTION: kde4-base_src_test 772# @FUNCTION: kde4-base_src_test
507# @DESCRIPTION: 773# @DESCRIPTION:
508# Function for testing KDE4 applications. 774# Function for testing KDE4 applications.
509kde4-base_src_test() { 775kde4-base_src_test() {
510 debug-print-function ${FUNCNAME} "$@" 776 debug-print-function ${FUNCNAME} "$@"
511 777
778 local kded4_pid
779
780 _test_runner() {
781 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
782 export $(dbus-launch)
783 kded4 2>&1 > /dev/null &
784 kded4_pid=$!
785 fi
786
787 cmake-utils_src_test
788 }
789
790 # When run as normal user during ebuild development with the ebuild command, the
791 # kde tests tend to access the session DBUS. This however is not possible in a real
792 # emerge or on the tinderbox.
793 # > make sure it does not happen, so bad tests can be recognized and disabled
794 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
795
512 # Override this value, set in kde4-base_src_configure() 796 # Override this value, set in kde4-base_src_configure()
513 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 797 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
514 cmake-utils_src_configure 798 cmake-utils_src_configure
515 kde4-base_src_compile 799 kde4-base_src_compile
516 800
517 cmake-utils_src_test 801 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
802 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
803 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
804 # surprise- we are already INSIDE virtualmake!!!
805 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
806 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
807 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
808 debug-print " kde4-base.eclass docs for details... Applying workaround."
809 _test_runner
810 else
811 VIRTUALX_COMMAND="_test_runner" virtualmake
812 fi
813 else
814 _test_runner
815 fi
816
817 if [ -n "${kded4_pid}" ] ; then
818 kill ${kded4_pid}
819 fi
820
821 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
822 kill ${DBUS_SESSION_BUS_PID}
823 fi
518} 824}
519 825
520# @FUNCTION: kde4-base_src_install 826# @FUNCTION: kde4-base_src_install
521# @DESCRIPTION: 827# @DESCRIPTION:
522# Function for installing KDE4 applications. 828# Function for installing KDE4 applications.
525 831
526 if [[ -n ${KMSAVELIBS} ]] ; then 832 if [[ -n ${KMSAVELIBS} ]] ; then
527 install_library_dependencies 833 install_library_dependencies
528 fi 834 fi
529 835
530 kde4-base_src_make_doc 836 # Install common documentation of KDE4 applications
837 local doc
838 if ! has kde4-meta ${INHERITED}; then
839 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
840 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
841 done
842 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
843 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
844 done
845 fi
846
531 cmake-utils_src_install 847 cmake-utils_src_install
532}
533 848
534# @FUNCTION: kde4-base_src_make_doc 849 # We don't want ${PREFIX}/share/doc/HTML to be compressed,
535# @DESCRIPTION: 850 # because then khelpcenter can't find the docs
536# Function for installing the documentation of KDE4 applications. 851 [[ -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
537kde4-base_src_make_doc() { 852 docompress -x ${PREFIX}/share/doc/HTML
538 debug-print-function ${FUNCNAME} "$@" 853}
539 854
540 local doc 855# @FUNCTION: kde4-base_pkg_preinst
541 for doc in AUTHORS ChangeLog* README* NEWS TODO; do 856# @DESCRIPTION:
542 [[ -s ${doc} ]] && dodoc ${doc} 857# Function storing icon caches
543 done 858kde4-base_pkg_preinst() {
859 debug-print-function ${FUNCNAME} "$@"
544 860
545 if [[ -z ${KMNAME} ]]; then 861 gnome2_icon_savelist
546 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do 862 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
547 if [[ -s ${doc} ]]; then 863 subversion_pkg_preinst
548 local doc_complete=${doc}
549 doc="${doc#*/}"
550 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
551 fi
552 done
553 fi
554
555 if [[ -n ${KDEBASE} ]] && [[ -d "${D}/usr/share/doc/${PF}" ]]; then
556 # work around bug #97196
557 dodir /usr/share/doc/KDE4 && \
558 mv "${D}/usr/share/doc/${PF}" "${D}"/usr/share/doc/KDE4/ || \
559 die "Failed to move docs to KDE4/."
560 fi 864 fi
561} 865}
562 866
563# @FUNCTION: kde4-base_pkg_postinst 867# @FUNCTION: kde4-base_pkg_postinst
564# @DESCRIPTION: 868# @DESCRIPTION:
565# Function to rebuild the KDE System Configuration Cache after an application has been installed. 869# Function to rebuild the KDE System Configuration Cache after an application has been installed.
566kde4-base_pkg_postinst() { 870kde4-base_pkg_postinst() {
567 debug-print-function ${FUNCNAME} "$@" 871 debug-print-function ${FUNCNAME} "$@"
568 872
873 gnome2_icon_cache_update
874 fdo-mime_desktop_database_update
875 fdo-mime_mime_database_update
569 buildsycoca 876 buildsycoca
877
878 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
879 if [[ ${KDE_BUILD_TYPE} = live ]]; then
880 echo
881 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
882 einfo "Use it at your own risk."
883 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
884 echo
885 fi
886 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
887 if [[ ${KDEBASE} != kde-base ]] && \
888 ! has_version 'kde-base/kdebase-runtime-meta' && \
889 ! has_version 'kde-base/kdebase-startkde'; then
890 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
891 echo
892 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
893 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
894 ewarn "With this setting you are unsupported by KDE team."
895 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
896 fi
897 fi
898 fi
570} 899}
571 900
572# @FUNCTION: kde4-base_pkg_postrm 901# @FUNCTION: kde4-base_pkg_postrm
573# @DESCRIPTION: 902# @DESCRIPTION:
574# Function to rebuild the KDE System Configuration Cache after an application has been removed. 903# Function to rebuild the KDE System Configuration Cache after an application has been removed.
575kde4-base_pkg_postrm() { 904kde4-base_pkg_postrm() {
576 debug-print-function ${FUNCNAME} "$@" 905 debug-print-function ${FUNCNAME} "$@"
577 906
907 gnome2_icon_cache_update
908 fdo-mime_desktop_database_update
909 fdo-mime_mime_database_update
578 buildsycoca 910 buildsycoca
579} 911}
912
913fi

Legend:
Removed from v.1.34  
changed lines
  Added in v.1.143

  ViewVC Help
Powered by ViewVC 1.1.20