/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.102 Revision 1.157
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2015 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.102 2011/07/10 17:53:37 tampakrap Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.157 2015/07/01 11:28:23 mrueg Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed 13# NOTE: KDE 4 ebuilds currently support EAPI 5. This will be
14# over time as new EAPI versions are approved. 14# reviewed over time as new EAPI versions are approved.
15
16if [[ -z ${_KDE4_BASE_ECLASS} ]]; then
17_KDE4_BASE_ECLASS=1
18
19# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
20# @DESCRIPTION:
21# If set to "none", do nothing.
22# For any other value, add selinux to IUSE, and depending on that useflag
23# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
24: ${KDE_SELINUX_MODULE:=none}
25
26# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
27# @DESCRIPTION:
28# If defined, launch and use a private dbus session during src_test.
15 29
16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED 30# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION: 31# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage. 32# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx 33# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test. 34# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual} 35: ${VIRTUALX_REQUIRED:=manual}
22 36
23inherit kde4-functions toolchain-funcs fdo-mime gnome2-utils base virtualx versionator eutils 37inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils virtualx versionator eutils multilib
24 38
25if [[ ${BUILD_TYPE} = live ]]; then 39if [[ ${KDE_BUILD_TYPE} = live ]]; then
26 case ${KDE_SCM} in 40 case ${KDE_SCM} in
27 svn) inherit subversion ;; 41 svn) inherit subversion ;;
28 git) inherit git-2 ;; 42 git) inherit git-r3 ;;
29 esac 43 esac
30fi 44fi
31 45
32# @ECLASS-VARIABLE: CMAKE_REQUIRED 46# @ECLASS-VARIABLE: CMAKE_REQUIRED
33# @DESCRIPTION: 47# @DESCRIPTION:
50KDE_MINIMAL="${KDE_MINIMAL:-4.4}" 64KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
51 65
52# Set slot for KDEBASE known packages 66# Set slot for KDEBASE known packages
53case ${KDEBASE} in 67case ${KDEBASE} in
54 kde-base) 68 kde-base)
55 SLOT=4 69 SLOT=4/$(get_version_component_range 1-2)
56 KDE_MINIMAL="${PV}" 70 KDE_MINIMAL="${PV}"
57 ;; 71 ;;
58 koffice)
59 SLOT="2"
60 ;;
61 kdevelop) 72 kdevelop)
62 if [[ ${BUILD_TYPE} = live ]]; then 73 if [[ ${KDE_BUILD_TYPE} = live ]]; then
63 # @ECLASS-VARIABLE: KDEVELOP_VERSION 74 # @ECLASS-VARIABLE: KDEVELOP_VERSION
64 # @DESCRIPTION: 75 # @DESCRIPTION:
65 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages. 76 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
66 # Applies to KDEBASE=kdevelop only. 77 # Applies to KDEBASE=kdevelop only.
67 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}" 78 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.9999}"
68 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION 79 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
69 # @DESCRIPTION: 80 # @DESCRIPTION:
70 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages. 81 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
71 # Applies to KDEBASE=kdevelop only. 82 # Applies to KDEBASE=kdevelop only.
72 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}" 83 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-4.9999}"
73 else 84 else
74 case ${PN} in 85 case ${PN} in
75 kdevelop|quanta) 86 kdevelop)
76 KDEVELOP_VERSION=${PV} 87 KDEVELOP_VERSION=${PV}
77 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)" 88 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
78 ;; 89 ;;
79 kdevplatform) 90 kdevplatform|kdevelop-php*|kdevelop-python)
80 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)" 91 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
81 KDEVPLATFORM_VERSION=${PV} 92 KDEVPLATFORM_VERSION=${PV}
82 ;; 93 ;;
83 *) 94 *)
84 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}" 95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
96unset buildsystem_eclass 107unset buildsystem_eclass
97unset export_fns 108unset export_fns
98 109
99# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED 110# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
100# @DESCRIPTION: 111# @DESCRIPTION:
101# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'. 112# Is qtdeclarative required? Possible values are 'always', 'optional' and 'never'.
102# This variable must be set before inheriting any eclasses. Defaults to 'never'. 113# This variable must be set before inheriting any eclasses. Defaults to 'never'.
103DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}" 114DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
104 115
105# @ECLASS-VARIABLE: QTHELP_REQUIRED 116# @ECLASS-VARIABLE: QTHELP_REQUIRED
106# @DESCRIPTION: 117# @DESCRIPTION:
107# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'. 118# Is qthelp required? Possible values are 'always', 'optional' and 'never'.
108# This variable must be set before inheriting any eclasses. Defaults to 'never'. 119# This variable must be set before inheriting any eclasses. Defaults to 'never'.
109QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}" 120QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
110 121
111# @ECLASS-VARIABLE: OPENGL_REQUIRED 122# @ECLASS-VARIABLE: OPENGL_REQUIRED
112# @DESCRIPTION: 123# @DESCRIPTION:
113# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 124# Is qtopengl required? Possible values are 'always', 'optional' and 'never'.
114# This variable must be set before inheriting any eclasses. Defaults to 'never'. 125# This variable must be set before inheriting any eclasses. Defaults to 'never'.
115OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 126OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
116 127
117# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED 128# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
118# @DESCRIPTION: 129# @DESCRIPTION:
119# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'. 130# Is qtmultimedia required? Possible values are 'always', 'optional' and 'never'.
120# This variable must be set before inheriting any eclasses. Defaults to 'never'. 131# This variable must be set before inheriting any eclasses. Defaults to 'never'.
121MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}" 132MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
122 133
123# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 134# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
124# @DESCRIPTION: 135# @DESCRIPTION:
146# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE 157# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
147# @DESCRIPTION: 158# @DESCRIPTION:
148# Set this varible if you want your live package to manage its 159# Set this varible if you want your live package to manage its
149# translations. (Mostly all kde ebuilds does not ship documentation 160# translations. (Mostly all kde ebuilds does not ship documentation
150# and translations in live ebuilds) 161# and translations in live ebuilds)
151if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then 162if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
152 # Kdebase actualy provides the handbooks even for live stuff 163 # Kdebase actualy provides the handbooks even for live stuff
153 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never 164 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
154 KDE_LINGUAS="" 165 KDE_LINGUAS=""
155fi 166fi
156 167
157# Setup packages inheriting this eclass 168# Setup packages inheriting this eclass
158case ${KDEBASE} in 169case ${KDEBASE} in
159 kde-base) 170 kde-base)
160 HOMEPAGE="http://www.kde.org/" 171 HOMEPAGE="http://www.kde.org/"
161 LICENSE="GPL-2" 172 LICENSE="GPL-2"
162 if [[ $BUILD_TYPE = live ]]; then 173 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
163 # Disable tests for live ebuilds 174 # Disable tests for live ebuilds by default
164 RESTRICT+=" test" 175 RESTRICT+=" test"
165 fi
166
167 # Only add the kdeprefix USE flag for older versions, to help
168 # non-portage package managers handle the upgrade
169 if [[ ${PV} < 4.6.4 && ( ( ${KMNAME} != kdepim && ${PN} != kdepim-runtime ) || ${PV} < 4.6 ) ]]; then
170 IUSE+=" kdeprefix"
171 fi 176 fi
172 177
173 # This code is to prevent portage from searching GENTOO_MIRRORS for 178 # This code is to prevent portage from searching GENTOO_MIRRORS for
174 # packages that will never be mirrored. (As they only will ever be in 179 # packages that will never be mirrored. (As they only will ever be in
175 # the overlay). 180 # the overlay).
176 case ${PV} in 181 case ${PV} in
177 *9999* | 4.?.[6-9]?) 182 *9999* | 4.?.[6-9]? | 4.??.[6-9]? | ??.?.[6-9]? | ??.??.[6-9]?)
178 RESTRICT+=" mirror" 183 RESTRICT+=" mirror"
179 ;; 184 ;;
180 esac 185 esac
181 ;; 186 ;;
182 koffice)
183 HOMEPAGE="http://www.koffice.org/"
184 LICENSE="GPL-2"
185 ;;
186 kdevelop) 187 kdevelop)
187 HOMEPAGE="http://www.kdevelop.org/" 188 HOMEPAGE="http://www.kdevelop.org/"
188 LICENSE="GPL-2" 189 LICENSE="GPL-2"
189 ;; 190 ;;
190esac 191esac
191 192
192# @ECLASS-VARIABLE: QT_MINIMAL 193# @ECLASS-VARIABLE: QT_MINIMAL
193# @DESCRIPTION: 194# @DESCRIPTION:
194# Determine version of qt we enforce as minimal for the package. 195# Determine version of qt we enforce as minimal for the package.
195if version_is_at_least 4.5.50 "${KDE_MINIMAL}"; then
196 QT_MINIMAL="${QT_MINIMAL:-4.7.0}" 196QT_MINIMAL="${QT_MINIMAL:-4.8.5}"
197else
198 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
199fi
200 197
201# Declarative dependencies 198# Declarative dependencies
202qtdeclarativedepend=" 199qtdeclarativedepend="
203 >=x11-libs/qt-declarative-${QT_MINIMAL}:4 200 >=dev-qt/qtdeclarative-${QT_MINIMAL}:4
204" 201"
205case ${DECLARATIVE_REQUIRED} in 202case ${DECLARATIVE_REQUIRED} in
206 always) 203 always)
207 COMMONDEPEND+=" ${qtdeclarativedepend}" 204 COMMONDEPEND+=" ${qtdeclarativedepend}"
208 ;; 205 ;;
214esac 211esac
215unset qtdeclarativedepend 212unset qtdeclarativedepend
216 213
217# QtHelp dependencies 214# QtHelp dependencies
218qthelpdepend=" 215qthelpdepend="
219 >=x11-libs/qt-assistant-${QT_MINIMAL}:4 216 >=dev-qt/qthelp-${QT_MINIMAL}:4
220" 217"
221case ${QTHELP_REQUIRED} in 218case ${QTHELP_REQUIRED} in
222 always) 219 always)
223 COMMONDEPEND+=" ${qthelpdepend}" 220 COMMONDEPEND+=" ${qthelpdepend}"
224 ;; 221 ;;
229esac 226esac
230unset qthelpdepend 227unset qthelpdepend
231 228
232# OpenGL dependencies 229# OpenGL dependencies
233qtopengldepend=" 230qtopengldepend="
234 >=x11-libs/qt-opengl-${QT_MINIMAL}:4 231 >=dev-qt/qtopengl-${QT_MINIMAL}:4
235" 232"
236case ${OPENGL_REQUIRED} in 233case ${OPENGL_REQUIRED} in
237 always) 234 always)
238 COMMONDEPEND+=" ${qtopengldepend}" 235 COMMONDEPEND+=" ${qtopengldepend}"
239 ;; 236 ;;
245esac 242esac
246unset qtopengldepend 243unset qtopengldepend
247 244
248# MultiMedia dependencies 245# MultiMedia dependencies
249qtmultimediadepend=" 246qtmultimediadepend="
250 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4 247 >=dev-qt/qtmultimedia-${QT_MINIMAL}:4
251" 248"
252case ${MULTIMEDIA_REQUIRED} in 249case ${MULTIMEDIA_REQUIRED} in
253 always) 250 always)
254 COMMONDEPEND+=" ${qtmultimediadepend}" 251 COMMONDEPEND+=" ${qtmultimediadepend}"
255 ;; 252 ;;
275 ;; 272 ;;
276 *) ;; 273 *) ;;
277esac 274esac
278unset cppuintdepend 275unset cppuintdepend
279 276
280
281# WebKit use dependencies
282case ${KDE_REQUIRED} in
283 always)
284 qtwebkitusedeps="[kde]"
285 ;;
286 optional)
287 qtwebkitusedeps="[kde?]"
288 ;;
289 *) ;;
290esac
291# KDE dependencies 277# KDE dependencies
292# Qt accessibility classes are needed in various places, bug 325461 278# Qt accessibility classes are needed in various places, bug 325461
293kdecommondepend=" 279kdecommondepend="
294 dev-lang/perl 280 dev-lang/perl
281 >=dev-qt/qt3support-${QT_MINIMAL}:4[accessibility]
295 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl] 282 >=dev-qt/qtcore-${QT_MINIMAL}:4[qt3support,ssl]
283 >=dev-qt/qtdbus-${QT_MINIMAL}:4
284 >=dev-qt/designer-${QT_MINIMAL}:4
296 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus] 285 >=dev-qt/qtgui-${QT_MINIMAL}:4[accessibility,dbus(+)]
297 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
298 >=x11-libs/qt-script-${QT_MINIMAL}:4 286 >=dev-qt/qtscript-${QT_MINIMAL}:4
299 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support] 287 >=dev-qt/qtsql-${QT_MINIMAL}:4[qt3support]
300 >=x11-libs/qt-svg-${QT_MINIMAL}:4 288 >=dev-qt/qtsvg-${QT_MINIMAL}:4
301 >=x11-libs/qt-test-${QT_MINIMAL}:4 289 >=dev-qt/qttest-${QT_MINIMAL}:4
302 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps} 290 >=dev-qt/qtwebkit-${QT_MINIMAL}:4
303 !aqua? (
304 x11-libs/libXext
305 x11-libs/libXt
306 x11-libs/libXxf86vm
307 x11-libs/libXcomposite
308 )
309" 291"
310 292
311if [[ ${PN} != kdelibs ]]; then 293if [[ ${PN} != kdelibs ]]; then
312 kdecommondepend+=" $(add_kdebase_dep kdelibs)" 294 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
313 if [[ ${KDEBASE} = kdevelop ]]; then 295 if [[ ${KDEBASE} = kdevelop ]]; then
318 # Applies to KDEBASE=kdevelop only. 300 # Applies to KDEBASE=kdevelop only.
319 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}" 301 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
320 case ${KDEVPLATFORM_REQUIRED} in 302 case ${KDEVPLATFORM_REQUIRED} in
321 always) 303 always)
322 kdecommondepend+=" 304 kdecommondepend+="
323 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION} 305 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}:4
324 " 306 "
325 ;; 307 ;;
326 *) ;; 308 *) ;;
327 esac 309 esac
328 fi 310 fi
329 fi 311 fi
330fi 312fi
331 313
332kdedepend=" 314kdedepend="
333 dev-util/automoc 315 dev-util/automoc
334 dev-util/pkgconfig 316 virtual/pkgconfig
335 !aqua? ( 317 !aqua? (
336 >=x11-libs/libXtst-1.1.0 318 >=x11-libs/libXtst-1.1.0
337 x11-proto/xf86vidmodeproto 319 x11-proto/xf86vidmodeproto
338 ) 320 )
339" 321"
340 322
341kderdepend="" 323kderdepend=""
342 324
325if [[ ${CATEGORY} == kde-apps ]]; then
326 kderdepend+=" !kde-base/${PN}"
327fi
328
343# all packages needs oxygen icons for basic iconset 329# all packages needs oxygen icons for basic iconset
344if [[ ${PN} != oxygen-icons ]]; then 330if [[ ${PN} != oxygen-icons ]]; then
345 kderdepend+=" $(add_kdebase_dep oxygen-icons)" 331 kderdepend+=" kde-apps/oxygen-icons"
346fi 332fi
347 333
348# add a dependency over kde-l10n if EAPI4 or better is around 334# add a dependency over kde-l10n
349if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} && ${EAPI:-0} != 3 ]]; then 335if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} ]]; then
350 for _lingua in ${KDE_LINGUAS}; do 336 for _lingua in ${KDE_LINGUAS}; do
351 # if our package has lignuas, pull in kde-l10n with selected lingua enabled, 337 # if our package has linguas, pull in kde-l10n with selected lingua enabled,
352 # but only for selected ones. 338 # but only for selected ones.
353 # this can't be done on one line because if user doesn't use any localisation 339 # this can't be done on one line because if user doesn't use any localisation
354 # then he is probably not interested in kde-l10n at all. 340 # then he is probably not interested in kde-l10n at all.
355 kderdepend+=" 341 kderdepend+="
356 linguas_${_lingua}? ( $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") ) 342 linguas_${_lingua}? ( $(add_kdeapps_dep kde4-l10n "linguas_${_lingua}(+)") )
357 " 343 "
358 done 344 done
359 unset _lingua 345 unset _lingua
360fi 346fi
361 347
378 ;; 364 ;;
379 *) ;; 365 *) ;;
380esac 366esac
381unset kdehandbookdepend kdehandbookrdepend 367unset kdehandbookdepend kdehandbookrdepend
382 368
369case ${KDE_SELINUX_MODULE} in
370 none) ;;
371 *)
372 IUSE+=" selinux"
373 kderdepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
374 ;;
375esac
376
377# We always need the aqua useflag because otherwise we cannot = refer to it inside
378# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
379# (where referring to a use flag not in IUSE masks the ebuild).
380# The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
381IUSE+=" aqua"
382
383case ${KDE_REQUIRED} in 383case ${KDE_REQUIRED} in
384 always) 384 always)
385 IUSE+=" aqua"
386 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}" 385 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
387 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}" 386 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
388 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}" 387 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
389 ;; 388 ;;
390 optional) 389 optional)
391 IUSE+=" aqua kde" 390 IUSE+=" kde"
392 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 391 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
393 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )" 392 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
394 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )" 393 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
395 ;; 394 ;;
396 *) ;; 395 *) ;;
405# Accumulate dependencies set by this eclass 404# Accumulate dependencies set by this eclass
406DEPEND+=" ${COMMONDEPEND}" 405DEPEND+=" ${COMMONDEPEND}"
407RDEPEND+=" ${COMMONDEPEND}" 406RDEPEND+=" ${COMMONDEPEND}"
408unset COMMONDEPEND 407unset COMMONDEPEND
409 408
410# Add experimental kdeenablefinal, masked by default
411IUSE+=" kdeenablefinal"
412
413# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 409# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
414# koffice ebuild, the URI should be set in the ebuild itself 410# kdevelop ebuild, the URI should be set in the ebuild itself
415_calculate_src_uri() { 411_calculate_src_uri() {
416 debug-print-function ${FUNCNAME} "$@" 412 debug-print-function ${FUNCNAME} "$@"
417 413
418 local _kmname _kmname_pv 414 local _kmname _kmname_pv
419 415
420 # we calculate URI only for known KDEBASE modules 416 # we calculate URI only for known KDEBASE modules
421 [[ -n ${KDEBASE} ]] || return 417 [[ -n ${KDEBASE} ]] || return
422 418
423 # calculate tarball module name 419 # calculate tarball module name
424 if [[ -n ${KMNAME} ]]; then 420 if [[ -n ${KMNAME} ]]; then
425 # fixup kdebase-apps name
426 case ${KMNAME} in
427 kdebase-apps)
428 _kmname="kdebase" ;;
429 *)
430 _kmname="${KMNAME}" ;; 421 _kmname="${KMNAME}"
431 esac
432 else 422 else
433 _kmname=${PN} 423 _kmname=${PN}
434 fi 424 fi
435 _kmname_pv="${_kmname}-${PV}" 425 _kmname_pv="${_kmname}-${PV}"
436 case ${KDEBASE} in 426 case ${KDEBASE} in
437 kde-base) 427 kde-base)
438 case ${PV} in 428 case ${PV} in
439 4.[456].8[05] | 4.[456].9[023568]) 429 4.4.11.1)
430 # KDEPIM 4.4, special case
431 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
432 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
433 4.4.20*)
434 # KDEPIM 4.4 no-akonadi branch, special case
435 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
436 SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${_kmname_pv}.tar.xz" ;;
437 4.?.[6-9]? | 4.??.[6-9]?)
440 # Unstable KDE SC releases 438 # Unstable KDE SC releases
441 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" 439 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
442 # KDEPIM IS SPECIAL 440 4.11.14)
443 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname_pv}.tar.bz2" 441 # Part of 4.14 actually, sigh. Not stable for next release!
444 ;; 442 SRC_URI="mirror://kde/stable/4.14.3/src/${_kmname_pv}.tar.xz" ;;
443 4.11.17)
444 # Part of 14.12.3 actually, sigh. Not stable for next release!
445 SRC_URI="mirror://kde/stable/applications/14.12.3/src/${_kmname_pv}.tar.xz" ;;
446 4.11.18)
447 # Part of 15.04.0 actually, sigh. Not stable for next release!
448 SRC_URI="mirror://kde/stable/applications/15.04.0/src/${_kmname_pv}.tar.xz" ;;
449 4.11.19)
450 # Part of 15.04.1 actually, sigh. Not stable for next release!
451 SRC_URI="mirror://kde/stable/applications/15.04.1/src/${_kmname_pv}.tar.xz" ;;
452 4.11.20)
453 # Part of 15.04.2 actually, sigh. Not stable for next release!
454 SRC_URI="mirror://kde/stable/applications/15.04.2/src/${_kmname_pv}.tar.xz" ;;
455 4.11.21)
456 # Part of 15.04.3 actually, sigh. Not stable for next release!
457 SRC_URI="mirror://kde/stable/applications/15.04.3/src/${_kmname_pv}.tar.xz" ;;
458 4.14.3)
459 # Last SC release
460 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz" ;;
461 4.14.6)
462 # Part of 14.12.3 actually, sigh. Not stable for next release!
463 SRC_URI="mirror://kde/stable/applications/14.12.3/src/${_kmname_pv}.tar.xz" ;;
464 4.14.7)
465 # Part of 15.04.0 actually, sigh. Not stable for next release!
466 SRC_URI="mirror://kde/stable/applications/15.04.0/src/${_kmname_pv}.tar.xz" ;;
467 4.14.8)
468 # Part of 15.04.1 actually, sigh. Not stable for next release!
469 SRC_URI="mirror://kde/stable/applications/15.04.1/src/${_kmname_pv}.tar.xz" ;;
470 4.14.9)
471 # Part of 15.04.2 actually, sigh. Not stable for next release!
472 SRC_URI="mirror://kde/stable/applications/15.04.2/src/${_kmname_pv}.tar.xz" ;;
473 4.14.10)
474 # Part of 15.04.3 actually, sigh. Not stable for next release!
475 SRC_URI="mirror://kde/stable/applications/15.04.3/src/${_kmname_pv}.tar.xz" ;;
476 ??.?.[6-9]? | ??.??.[4-9]?)
477 # Unstable KDE Applications releases
478 SRC_URI="mirror://kde/unstable/applications/${PV}/src/${_kmname}-${PV}.tar.xz" ;;
445 *) 479 *)
446 # Stable KDE SC releases 480 # Stable KDE Applications releases
447 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" 481 SRC_URI="mirror://kde/stable/applications/${PV}/src/${_kmname}-${PV}.tar.xz"
448 # KDEPIM IS SPECIAL
449 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
450 ;; 482 ;;
451 esac 483 esac
452 ;; 484 ;;
453 koffice) 485 kdevelop|kdevelop-php*|kdevplatform)
454 case ${PV} in 486 case ${KDEVELOP_VERSION} in
455 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 487 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz" ;;
456 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 488 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz" ;;
457 esac 489 esac
458 ;;
459 kdevelop)
460 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
461 ;; 490 ;;
462 esac 491 esac
463} 492}
464 493
465_calculate_live_repo() { 494_calculate_live_repo() {
518 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta 547 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
519 # build packages from same svn location. 548 # build packages from same svn location.
520 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 549 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
521 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 550 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
522 ;; 551 ;;
523 koffice)
524 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
525 ;;
526 *) 552 *)
527 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 553 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
528 ;; 554 ;;
529 esac 555 esac
530 else 556 else
533 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 559 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
534 fi 560 fi
535 # @ECLASS-VARIABLE: ESVN_UP_FREQ 561 # @ECLASS-VARIABLE: ESVN_UP_FREQ
536 # @DESCRIPTION: 562 # @DESCRIPTION:
537 # This variable is used for specifying the timeout between svn synces 563 # This variable is used for specifying the timeout between svn synces
538 # for kde-base and koffice modules. Does not affect misc apps. 564 # for kde-base modules. Does not affect misc apps.
539 # Default value is 1 hour. 565 # Default value is 1 hour.
540 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1} 566 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
541 ;; 567 ;;
542 git) 568 git)
543 local _kmname 569 local _kmname
544 # @ECLASS-VARIABLE: EGIT_MIRROR 570 # @ECLASS-VARIABLE: EGIT_MIRROR
545 # @DESCRIPTION: 571 # @DESCRIPTION:
559 else 585 else
560 _kmname=${PN} 586 _kmname=${PN}
561 fi 587 fi
562 588
563 # default branching 589 # default branching
564 case ${PV} in 590 [[ ${PV} != 4.9999* && ${PV} != 9999 && ${KDEBASE} == kde-base ]] && \
565 9999*) ;;
566 *)
567 # set EGIT_BRANCH and EGIT_COMMIT to $(get_kde_version)
568 # every package is listed explicitly now, as upstream
569 # seems to love being different :(
570 case ${_kmname} in
571 blinken|cantor|kalgebra|kalzium|kanagram|kbruch| \
572 kdeplasma-addons|kdepim|kdepim-runtime|kdepimlibs| \
573 kgeography|khangman|kig|kiten|klettres|kmplot|kstars| \
574 ktouch|kturtle|kwordquiz|libkdeedu|mobipocket|okular| \
575 parley|rocs|step)
576 EGIT_BRANCH="$(get_kde_version)"
577 ;;
578 marble)
579 EGIT_BRANCH="kde-$(get_kde_version)"
580 ;;
581 gwenview|kamera|kate|kcolorchooser|kde-baseapps| \
582 kde-runtime|kde-workspace|kgamma| \
583 kdegraphics-strigi-analyzer|kdegraphics-thumbnailers| \
584 kdelibs|kimono|kolourpaint|konsole|korundum| \
585 kross-interpreters|kruler|ksaneplugin|ksnapshot| \
586 libkdcraw|libkexiv2|libkipi|libksane|perlqt|perlkde| \
587 pykde4|qtruby|qyoto|smokegen|smokekde|smokeqt|svgpart)
588 EGIT_BRANCH="KDE/$(get_kde_version)" 591 EGIT_BRANCH="KDE/$(get_kde_version)"
589 ;; 592
590 *) 593 # Applications branching
591 ewarn "Unknown KMNAME ${_kmname}: Guessing branch name 'KDE/$(get_kde_version)'" 594 [[ ${PV} == ??.??.49.9999 && ${KDEBASE} == kde-base ]] && \
592 EGIT_BRANCH="KDE/$(get_kde_version)" ;; 595 EGIT_BRANCH="Applications/$(get_kde_version)"
593 esac
594 ;;
595 esac
596 596
597 # default repo uri 597 # default repo uri
598 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}" 598 EGIT_REPO_URI+=( "${EGIT_MIRROR}/${_kmname}" )
599 599
600 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}" 600 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
601 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}" 601 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
602 ;; 602 ;;
603 esac 603 esac
604} 604}
605 605
606case ${BUILD_TYPE} in 606case ${KDE_BUILD_TYPE} in
607 live) _calculate_live_repo ;; 607 live) _calculate_live_repo ;;
608 *) _calculate_src_uri ;; 608 *) _calculate_src_uri ;;
609esac 609esac
610 610
611debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}" 611debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
620# @DESCRIPTION: 620# @DESCRIPTION:
621# Do some basic settings 621# Do some basic settings
622kde4-base_pkg_setup() { 622kde4-base_pkg_setup() {
623 debug-print-function ${FUNCNAME} "$@" 623 debug-print-function ${FUNCNAME} "$@"
624 624
625 if has kdeprefix ${IUSE//+} && use kdeprefix; then 625 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
626 eerror "Sorry, kdeprefix support has been removed." 626 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
627 eerror "Please remove kdeprefix from your USE variable." 627 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
628 die "kdeprefix support has been removed"
629 fi
630
631 if [[ ${CATEGORY}/${PN} != kde-base/kdelibs && ${CATEGORY}/${PN} != kde-base/kde-env ]] && \
632 { [[ ${KDE_REQUIRED} == always ]] || { [[ ${KDE_REQUIRED} == optional ]] && use kde; }; } && \
633 has_version kde-base/kdelibs[kdeprefix]; then
634 eerror "Sorry, kdeprefix support has been removed."
635 eerror "Please rebuild kdelibs without kdeprefix support."
636 die "kdeprefix support has been removed"
637 fi 628 fi
638 629
639 # Don't set KDEHOME during compilation, it will cause access violations 630 # Don't set KDEHOME during compilation, it will cause access violations
640 unset KDEHOME 631 unset KDEHOME
641 632
642 # Check if gcc compiler is fresh enough. 633 # Check if gcc compiler is fresh enough.
643 # In theory should be in pkg_pretend but we check it only for kdelibs there 634 # In theory should be in pkg_pretend but we check it only for kdelibs there
644 # and for others we do just quick scan in pkg_setup because pkg_pretend 635 # and for others we do just quick scan in pkg_setup because pkg_pretend
645 # executions consume quite some time. 636 # executions consume quite some time (ie. when merging 300 packages at once will cause 300 checks)
646 if [[ ${MERGE_TYPE} != binary ]]; then 637 if [[ ${MERGE_TYPE} != binary ]]; then
647 [[ $(gcc-major-version) -lt 4 ]] || \ 638 [[ $(gcc-major-version) -lt 4 ]] || \
648 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \ 639 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 6 ]] ) \
649 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)." 640 && die "Sorry, but gcc-4.6 and earlier wont work for some KDE packages."
650 fi 641 fi
651 642
652 KDEDIR=/usr 643 KDEDIR=/usr
653 : ${PREFIX:=/usr} 644 : ${PREFIX:=/usr}
654 EKDEDIR=${EPREFIX}/usr 645 EKDEDIR=${EPREFIX}/usr
664# @DESCRIPTION: 655# @DESCRIPTION:
665# This function unpacks the source tarballs for KDE4 applications. 656# This function unpacks the source tarballs for KDE4 applications.
666kde4-base_src_unpack() { 657kde4-base_src_unpack() {
667 debug-print-function ${FUNCNAME} "$@" 658 debug-print-function ${FUNCNAME} "$@"
668 659
669 if [[ ${BUILD_TYPE} = live ]]; then 660 if [[ ${KDE_BUILD_TYPE} = live ]]; then
670 case ${KDE_SCM} in 661 case ${KDE_SCM} in
671 svn) 662 svn)
672 migrate_store_dir
673 subversion_src_unpack 663 subversion_src_unpack
674 ;; 664 ;;
675 git) 665 git)
676 git-2_src_unpack 666 git-r3_src_unpack
677 ;; 667 ;;
678 esac 668 esac
679 else 669 else
680 unpack ${A} 670 unpack ${A}
681 fi 671 fi
698 fi 688 fi
699 689
700 # Enable/disable handbooks for kde4-base packages 690 # Enable/disable handbooks for kde4-base packages
701 # kde-l10n inherits kde4-base but is metpackage, so no check for doc 691 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
702 # kdelibs inherits kde4-base but handle installing the handbook itself 692 # kdelibs inherits kde4-base but handle installing the handbook itself
703 if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then 693 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
704 if [[ ${KDEBASE} == kde-base ]]; then 694 if [[ ${KDEBASE} == kde-base ]]; then
705 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then 695 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
706 # documentation in kde4-functions 696 # documentation in kde4-functions
707 : ${KDE_DOC_DIRS:=doc} 697 : ${KDE_DOC_DIRS:=doc}
708 local dir 698 local dir
718 enable_selected_doc_linguas 708 enable_selected_doc_linguas
719 fi 709 fi
720 fi 710 fi
721 711
722 # SCM bootstrap 712 # SCM bootstrap
723 if [[ ${BUILD_TYPE} = live ]]; then 713 if [[ ${KDE_BUILD_TYPE} = live ]]; then
724 case ${KDE_SCM} in 714 case ${KDE_SCM} in
725 svn) subversion_src_prepare ;; 715 svn) subversion_src_prepare ;;
726 esac 716 esac
727 fi 717 fi
728 718
729 # Apply patches 719 # Apply patches, cmake-utils does the job already
730 base_src_prepare 720 cmake-utils_src_prepare
731 721
732 # Save library dependencies 722 # Save library dependencies
733 if [[ -n ${KMSAVELIBS} ]] ; then 723 if [[ -n ${KMSAVELIBS} ]] ; then
734 save_library_dependencies 724 save_library_dependencies
735 fi 725 fi
737 # Inject library dependencies 727 # Inject library dependencies
738 if [[ -n ${KMLOADLIBS} ]] ; then 728 if [[ -n ${KMLOADLIBS} ]] ; then
739 load_library_dependencies 729 load_library_dependencies
740 fi 730 fi
741 731
742 # Replace KDE4Workspace library targets
743 find "${S}" -name CMakeLists.txt \
744 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
745 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
746 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
747 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
748 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
749 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
750 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
751 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
752 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
753 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
754 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
755 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
756 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
757 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
758 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
759 || die 'failed to replace KDE4Workspace library targets'
760
761 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/... 732 # Hack for manuals relying on outdated DTD, only outside kde-base/...
762 if [[ -z ${KDEBASE} ]]; then 733 if [[ -z ${KDEBASE} ]]; then
763 find "${S}" -name "*.docbook" \ 734 find "${S}" -name "*.docbook" \
764 -exec sed -i -r \ 735 -exec sed -i -r \
765 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \ 736 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
766 || die 'failed to fix DocBook variant version' 737 || die 'failed to fix DocBook variant version'
774 debug-print-function ${FUNCNAME} "$@" 745 debug-print-function ${FUNCNAME} "$@"
775 746
776 # Build tests in src_test only, where we override this value 747 # Build tests in src_test only, where we override this value
777 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF) 748 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
778 749
779 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then 750 if use_if_iuse debug; then
780 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
781 fi
782
783 if has debug ${IUSE//+} && use debug; then
784 # Set "real" debug mode 751 # Set "real" debug mode
785 CMAKE_BUILD_TYPE="Debugfull" 752 CMAKE_KDE_BUILD_TYPE="Debugfull"
786 else 753 else
787 # Handle common release builds 754 # Handle common release builds
788 append-cppflags -DQT_NO_DEBUG 755 append-cppflags -DQT_NO_DEBUG
789 fi 756 fi
790 757
807 774
808 # sysconf needs to be /etc, not /usr/etc 775 # sysconf needs to be /etc, not /usr/etc
809 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc) 776 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
810 777
811 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then 778 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
779 if [[ ${mycmakeargs} ]]; then
780 eqawarn "mycmakeargs should always be declared as an array, not a string"
781 fi
812 mycmakeargs=(${mycmakeargs}) 782 mycmakeargs=(${mycmakeargs})
813 fi 783 fi
814 784
815 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}") 785 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
816 786
829# @FUNCTION: kde4-base_src_test 799# @FUNCTION: kde4-base_src_test
830# @DESCRIPTION: 800# @DESCRIPTION:
831# Function for testing KDE4 applications. 801# Function for testing KDE4 applications.
832kde4-base_src_test() { 802kde4-base_src_test() {
833 debug-print-function ${FUNCNAME} "$@" 803 debug-print-function ${FUNCNAME} "$@"
804
805 local kded4_pid
806
807 _test_runner() {
808 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
809 export $(dbus-launch)
810 kded4 2>&1 > /dev/null &
811 kded4_pid=$!
812 fi
813
814 cmake-utils_src_test
815 }
816
817 # When run as normal user during ebuild development with the ebuild command, the
818 # kde tests tend to access the session DBUS. This however is not possible in a real
819 # emerge or on the tinderbox.
820 # > make sure it does not happen, so bad tests can be recognized and disabled
821 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
834 822
835 # Override this value, set in kde4-base_src_configure() 823 # Override this value, set in kde4-base_src_configure()
836 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON) 824 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
837 cmake-utils_src_configure 825 cmake-utils_src_configure
838 kde4-base_src_compile 826 kde4-base_src_compile
839
840 # When run as normal user during ebuild development with the ebuild command, the
841 # kde tests tend to access the session DBUS. This however is not possible in a real
842 # emerge or on the tinderbox.
843 # > make sure it does not happen, so bad tests can be recognized and disabled
844 unset DBUS_SESSION_BUS_ADDRESS
845 827
846 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then 828 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
847 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default 829 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
848 if [[ ${VIRTUALX_COMMAND} != emake ]]; then 830 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
849 # surprise- we are already INSIDE virtualmake!!! 831 # surprise- we are already INSIDE virtualmake!!!
850 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality." 832 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
851 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild." 833 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
852 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the" 834 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
853 debug-print " kde4-base.eclass docs for details... Applying workaround." 835 debug-print " kde4-base.eclass docs for details... Applying workaround."
854 cmake-utils_src_test 836 _test_runner
855 else 837 else
856 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake 838 VIRTUALX_COMMAND="_test_runner" virtualmake
857 fi 839 fi
858 else 840 else
859 cmake-utils_src_test 841 _test_runner
842 fi
843
844 if [ -n "${kded4_pid}" ] ; then
845 kill ${kded4_pid}
846 fi
847
848 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
849 kill ${DBUS_SESSION_BUS_PID}
860 fi 850 fi
861} 851}
862 852
863# @FUNCTION: kde4-base_src_install 853# @FUNCTION: kde4-base_src_install
864# @DESCRIPTION: 854# @DESCRIPTION:
881 done 871 done
882 fi 872 fi
883 873
884 cmake-utils_src_install 874 cmake-utils_src_install
885 875
886 # In EAPI 4+, we don't want ${PREFIX}/share/doc/HTML to be compressed, 876 # We don't want ${PREFIX}/share/doc/HTML to be compressed,
887 # because then khelpcenter can't find the docs 877 # because then khelpcenter can't find the docs
888 [[ ${EAPI:-0} != 3 && -d ${ED}/${PREFIX}/share/doc/HTML ]] && 878 [[ -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
889 docompress -x ${PREFIX}/share/doc/HTML 879 docompress -x ${PREFIX}/share/doc/HTML
890} 880}
891 881
892# @FUNCTION: kde4-base_pkg_preinst 882# @FUNCTION: kde4-base_pkg_preinst
893# @DESCRIPTION: 883# @DESCRIPTION:
894# Function storing icon caches 884# Function storing icon caches
895kde4-base_pkg_preinst() { 885kde4-base_pkg_preinst() {
896 debug-print-function ${FUNCNAME} "$@" 886 debug-print-function ${FUNCNAME} "$@"
897 887
898 gnome2_icon_savelist 888 gnome2_icon_savelist
889 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
890 subversion_pkg_preinst
891 fi
899} 892}
900 893
901# @FUNCTION: kde4-base_pkg_postinst 894# @FUNCTION: kde4-base_pkg_postinst
902# @DESCRIPTION: 895# @DESCRIPTION:
903# Function to rebuild the KDE System Configuration Cache after an application has been installed. 896# Function to rebuild the KDE System Configuration Cache after an application has been installed.
908 fdo-mime_desktop_database_update 901 fdo-mime_desktop_database_update
909 fdo-mime_mime_database_update 902 fdo-mime_mime_database_update
910 buildsycoca 903 buildsycoca
911 904
912 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 905 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
913 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
914 echo
915 ewarn "WARNING! you have kdeenable final useflag enabled."
916 ewarn "This useflag needs to be enabled on ALL kde using packages and"
917 ewarn "is known to cause issues."
918 ewarn "You are using this setup at your own risk and the kde team does not"
919 ewarn "take responsibilities for dead kittens."
920 echo
921 fi
922 if [[ ${BUILD_TYPE} = live ]]; then 906 if [[ ${KDE_BUILD_TYPE} = live ]]; then
923 echo 907 echo
924 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}" 908 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
925 einfo "Use it at your own risk." 909 einfo "Use it at your own risk."
926 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!" 910 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
927 echo 911 echo
928 fi 912 fi
929 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta 913 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
930 if [[ ${KDEBASE} != kde-base ]] && \ 914 if [[ ${KDEBASE} != kde-base ]] && \
931 ! has_version 'kde-base/kdebase-runtime-meta' && \ 915 ! has_version 'kde-apps/kdebase-runtime-meta' && \
932 ! has_version 'kde-base/kdebase-startkde'; then 916 ! has_version 'kde-base/kdebase-startkde'; then
933 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then 917 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
934 echo 918 echo
935 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\"" 919 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
936 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above." 920 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
950 gnome2_icon_cache_update 934 gnome2_icon_cache_update
951 fdo-mime_desktop_database_update 935 fdo-mime_desktop_database_update
952 fdo-mime_mime_database_update 936 fdo-mime_mime_database_update
953 buildsycoca 937 buildsycoca
954} 938}
939
940fi

Legend:
Removed from v.1.102  
changed lines
  Added in v.1.157

  ViewVC Help
Powered by ViewVC 1.1.20