/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.4 Revision 1.95
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.4 2008/03/10 21:41:56 zlin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.95 2011/06/06 18:42:55 abcd Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# over time as new EAPI versions are approved.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual}
17 22
23inherit kde4-functions toolchain-funcs fdo-mime gnome2-utils base virtualx versionator eutils
24
25if [[ ${BUILD_TYPE} = live ]]; then
26 case ${KDE_SCM} in
27 svn) inherit subversion ;;
28 git) inherit git-2 ;;
29 esac
30fi
31
32# @ECLASS-VARIABLE: CMAKE_REQUIRED
33# @DESCRIPTION:
34# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
35# Please note that if it's set to 'never' you need to explicitly override following phases:
36# src_configure, src_compile, src_test and src_install.
37# Defaults to 'always'.
38: ${CMAKE_REQUIRED:=always}
39if [[ ${CMAKE_REQUIRED} = always ]]; then
40 buildsystem_eclass="cmake-utils"
41 export_fns="src_configure src_compile src_test src_install"
42fi
43
44# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
45if [[ -n ${KDE_MINIMAL} ]]; then
46 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
47 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
48 done
49 unset slot
50 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
51else
52 KDE_MINIMAL_VALID=1
53fi
54
55# @ECLASS-VARIABLE: KDE_MINIMAL
56# @DESCRIPTION:
57# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
58# version for apps to work. Currently defaults to 4.4
59# One may override this variable to raise version requirements.
60# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
61# Note that it is fixed to ${SLOT} for kde-base packages.
62KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
63
64# Set slot for KDEBASE known packages
65case ${KDEBASE} in
66 kde-base)
67 SLOT=$(_calculate_kde_slot)
68 [[ -z ${SLOT} ]] && die "Unsupported ${PV}"
69 KDE_MINIMAL="${SLOT}"
70 ;;
71 koffice)
72 SLOT="2"
73 ;;
74 kdevelop)
75 if [[ ${BUILD_TYPE} = live ]]; then
76 # @ECLASS-VARIABLE: KDEVELOP_VERSION
77 # @DESCRIPTION:
78 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
79 # Applies to KDEBASE=kdevelop only.
80 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
81 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
82 # @DESCRIPTION:
83 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
84 # Applies to KDEBASE=kdevelop only.
85 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
86 else
87 case ${PN} in
88 kdevelop|quanta)
89 KDEVELOP_VERSION=${PV}
90 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
91 ;;
92 kdevplatform)
93 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
94 KDEVPLATFORM_VERSION=${PV}
95 ;;
96 *)
97 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
98 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
99 esac
100 fi
101 SLOT="4"
102 ;;
103esac
104
105inherit ${buildsystem_eclass}
106
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 107EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
19 108
20COMMONDEPEND="|| ( ( 109unset buildsystem_eclass
21 x11-libs/qt-core:4 110unset export_fns
22 x11-libs/qt-gui:4 111
23 x11-libs/qt-qt3support:4 112# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
24 x11-libs/qt-svg:4 113# @DESCRIPTION:
25 x11-libs/qt-test:4 ) 114# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
26 >=x11-libs/qt-4.3.3:4 )" 115# This variable must be set before inheriting any eclasses. Defaults to 'never'.
116DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
117
118# @ECLASS-VARIABLE: QTHELP_REQUIRED
119# @DESCRIPTION:
120# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
121# This variable must be set before inheriting any eclasses. Defaults to 'never'.
122QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
27 123
28# @ECLASS-VARIABLE: OPENGL_REQUIRED 124# @ECLASS-VARIABLE: OPENGL_REQUIRED
29# @DESCRIPTION: 125# @DESCRIPTION:
30# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 126# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
31# This variable must be set before inheriting any eclasses. Defaults to 'never'. 127# This variable must be set before inheriting any eclasses. Defaults to 'never'.
32OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 128OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
33 129
34OPENGLDEPEND="|| ( x11-libs/qt-opengl:4 130# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
35 >=x11-libs/qt-4.3.3:4 )" 131# @DESCRIPTION:
36case "${OPENGL_REQUIRED}" in 132# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
37 always) 133# This variable must be set before inheriting any eclasses. Defaults to 'never'.
38 COMMONDEPEND="${COMMONDEPEND} 134MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
39 ${OPENGLDEPEND}"
40 ;;
41 optional)
42 IUSE="${IUSE} opengl"
43 COMMONDEPEND="${COMMONDEPEND}
44 opengl? ( ${OPENGLDEPEND} )"
45 ;;
46 *)
47 OPENGL_REQUIRED="never"
48 ;;
49esac
50
51DEPEND="${DEPEND} ${COMMONDEPEND}
52 >=dev-util/cmake-2.4.7-r1
53 dev-util/pkgconfig
54 x11-libs/libXt
55 x11-proto/xf86vidmodeproto"
56RDEPEND="${RDEPEND} ${COMMONDEPEND}"
57 135
58# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 136# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
59# @DESCRIPTION: 137# @DESCRIPTION:
60# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 138# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
61# This variable must be set before inheriting any eclasses. Defaults to 'never'. 139# This variable must be set before inheriting any eclasses. Defaults to 'never'.
62CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 140CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
63 141
64case "${CPPUNIT_REQUIRED}" in 142# @ECLASS-VARIABLE: KDE_REQUIRED
143# @DESCRIPTION:
144# Is kde required? Possible values are 'always', 'optional' and 'never'.
145# This variable must be set before inheriting any eclasses. Defaults to 'always'
146# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
147# Note that for kde-base packages this variable is fixed to 'always'.
148KDE_REQUIRED="${KDE_REQUIRED:-always}"
149
150# @ECLASS-VARIABLE: KDE_HANDBOOK
151# @DESCRIPTION:
152# Set to enable handbook in application. Possible values are 'always', 'optional'
153# (handbook USE flag) and 'never'.
154# This variable must be set before inheriting any eclasses. Defaults to 'never'.
155# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
156# ensures buildtime and runtime dependencies.
157KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
158
159# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
160# @DESCRIPTION:
161# Set this varible if you want your live package to manage its
162# translations. (Mostly all kde ebuilds does not ship documentation
163# and translations in live ebuilds)
164if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
165 # Kdebase actualy provides the handbooks even for live stuff
166 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
167 KDE_LINGUAS=""
168fi
169
170# Setup packages inheriting this eclass
171case ${KDEBASE} in
172 kde-base)
173 HOMEPAGE="http://www.kde.org/"
174 LICENSE="GPL-2"
175 if [[ $BUILD_TYPE = live ]]; then
176 # Disable tests for live ebuilds
177 RESTRICT+=" test"
178 # Live ebuilds in kde-base default to kdeprefix by default
179 IUSE+=" +kdeprefix"
180 else
181 # All other ebuild types default to -kdeprefix as before
182 IUSE+=" kdeprefix"
183 fi
184 # This code is to prevent portage from searching GENTOO_MIRRORS for
185 # packages that will never be mirrored. (As they only will ever be in
186 # the overlay).
187 case ${PV} in
188 *9999* | 4.?.[6-9]?)
189 RESTRICT+=" mirror"
190 ;;
191 esac
192 # Block installation of other SLOTS unless kdeprefix
193 RDEPEND+=" $(block_other_slots)"
194 ;;
195 koffice)
196 HOMEPAGE="http://www.koffice.org/"
197 LICENSE="GPL-2"
198 ;;
199 kdevelop)
200 HOMEPAGE="http://www.kdevelop.org/"
201 LICENSE="GPL-2"
202 ;;
203esac
204
205# @ECLASS-VARIABLE: QT_MINIMAL
206# @DESCRIPTION:
207# Determine version of qt we enforce as minimal for the package.
208if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
209 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
210else
211 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
212fi
213
214# Declarative dependencies
215qtdeclarativedepend="
216 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
217"
218case ${DECLARATIVE_REQUIRED} in
65 always) 219 always)
66 DEPEND="${DEPEND} dev-util/cppunit" 220 COMMONDEPEND+=" ${qtdeclarativedepend}"
67 ;; 221 ;;
68 optional) 222 optional)
69 IUSE="${IUSE} test" 223 IUSE+=" declarative"
70 DEPEND="${DEPEND} 224 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
71 test? ( dev-util/cppunit )"
72 ;; 225 ;;
73 *) 226 *) ;;
74 CPPUNIT_REQUIRED="never"
75 ;;
76esac 227esac
228unset qtdeclarativedepend
77 229
78# @ECLASS-VARIABLE: NEED_KDE 230# QtHelp dependencies
231qthelpdepend="
232 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
233"
234case ${QTHELP_REQUIRED} in
235 always)
236 COMMONDEPEND+=" ${qthelpdepend}"
237 ;;
238 optional)
239 IUSE+=" qthelp"
240 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
241 ;;
242esac
243unset qthelpdepend
244
245# OpenGL dependencies
246qtopengldepend="
247 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
248"
249case ${OPENGL_REQUIRED} in
250 always)
251 COMMONDEPEND+=" ${qtopengldepend}"
252 ;;
253 optional)
254 IUSE+=" opengl"
255 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
256 ;;
257 *) ;;
258esac
259unset qtopengldepend
260
261# MultiMedia dependencies
262qtmultimediadepend="
263 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
264"
265case ${MULTIMEDIA_REQUIRED} in
266 always)
267 COMMONDEPEND+=" ${qtmultimediadepend}"
268 ;;
269 optional)
270 IUSE+=" multimedia"
271 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
272 ;;
273 *) ;;
274esac
275unset qtmultimediadepend
276
277# CppUnit dependencies
278cppuintdepend="
279 dev-util/cppunit
280"
281case ${CPPUNIT_REQUIRED} in
282 always)
283 DEPEND+=" ${cppuintdepend}"
284 ;;
285 optional)
286 IUSE+=" test"
287 DEPEND+=" test? ( ${cppuintdepend} )"
288 ;;
289 *) ;;
290esac
291unset cppuintdepend
292
293
294# WebKit use dependencies
295case ${KDE_REQUIRED} in
296 always)
297 qtwebkitusedeps="[kde]"
298 ;;
299 optional)
300 qtwebkitusedeps="[kde?]"
301 ;;
302 *) ;;
303esac
304# KDE dependencies
305# Qt accessibility classes are needed in various places, bug 325461
306kdecommondepend="
307 dev-lang/perl
308 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
309 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
310 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
311 >=x11-libs/qt-script-${QT_MINIMAL}:4
312 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
313 >=x11-libs/qt-svg-${QT_MINIMAL}:4
314 >=x11-libs/qt-test-${QT_MINIMAL}:4
315 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
316 !aqua? (
317 x11-libs/libXext
318 x11-libs/libXt
319 x11-libs/libXxf86vm
320 x11-libs/libXcomposite
321 )
322"
323
324if [[ ${PN} != kdelibs ]]; then
325 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
326 if [[ ${KDEBASE} = kdevelop ]]; then
327 if [[ ${PN} != kdevplatform ]]; then
328 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
79# @DESCRIPTION: 329 # @DESCRIPTION:
80# This variable sets the version of KDE4 which will be used by the eclass. 330 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
81# This variable must be set by the ebuild, for all categories except for "kde-base". 331 # Applies to KDEBASE=kdevelop only.
82# For kde-base packages, if it is not set by the ebuild, 332 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
83# it's assumed that the required KDE4 version is the latest, non-live, available. 333 case ${KDEVPLATFORM_REQUIRED} in
84# 334 always)
85# @CODE 335 kdecommondepend+="
86# Acceptable values are: 336 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
87# - latest - Use latest version in the portage tree 337 "
88# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 338 ;;
89# - svn - Use svn release (live ebuilds) 339 *) ;;
90# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value. 340 esac
91# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value. 341 fi
92# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
93# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
94# @CODE
95#
96# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
97# koffice, so you must set it explicitly in the ebuild, in all other cases.
98if [[ -z ${NEED_KDE} ]]; then
99 if [[ -n ${KDEBASE} ]]; then
100 NEED_KDE="latest"
101 else
102 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
103 fi 342 fi
104fi 343fi
105export NEED_KDE
106 344
107case ${NEED_KDE} in 345kdedepend="
108 latest) 346 dev-util/automoc
109 # Should only be used by 'kde-base'-ebuilds 347 dev-util/pkgconfig
110 if [[ "${KDEBASE}" == "kde-base" ]]; then 348 !aqua? (
111 case ${PV} in 349 >=x11-libs/libXtst-1.1.0
112 3.9*) _kdedir="3.9" ;; 350 x11-proto/xf86vidmodeproto
113 4*) _kdedir="4.0" ;; 351 )
114 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 352"
115 esac 353
116 _operator=">=" 354kderdepend=""
117 _pv="-${PV}:kde-4" 355
118 else 356# all packages needs oxygen icons for basic iconset
119 _kdedir="4.0" 357if [[ ${PN} != oxygen-icons ]]; then
120 _pv=":kde-4" 358 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
121 fi 359fi
360
361# add a dependency over kde-l10n if EAPI4 or better is around
362if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} && ${EAPI:-0} != 3 ]]; then
363 for _lingua in ${KDE_LINGUAS}; do
364 # if our package has lignuas, pull in kde-l10n with selected lingua enabled,
365 # but only for selected ones.
366 # this can't be done on one line because if user doesn't use any localisation
367 # then he is probably not interested in kde-l10n at all.
368 kderdepend+="
369 linguas_${_lingua}? ( $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") )
370 "
371 done
372 unset _lingua
373fi
374
375kdehandbookdepend="
376 app-text/docbook-xml-dtd:4.2
377 app-text/docbook-xsl-stylesheets
378"
379kdehandbookrdepend="
380 $(add_kdebase_dep kdelibs 'handbook')
381"
382case ${KDE_HANDBOOK} in
383 always)
384 kdedepend+=" ${kdehandbookdepend}"
385 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
122 ;; 386 ;;
123 svn|9999*|:kde-svn) 387 optional)
124 _kdedir="svn" 388 IUSE+=" +handbook"
125 _pv=":kde-svn" 389 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
126 export NEED_KDE="svn" 390 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
127 ;; 391 ;;
128 *:kde-svn) 392 *) ;;
129 _kdedir="svn"
130 _operator=">="
131 _pv="-${NEED_KDE}"
132 export NEED_KDE="svn"
133 ;;
134 # The ebuild handles dependencies, KDEDIR, SLOT.
135 none)
136 :
137 ;;
138 # NEED_KDE=":${SLOT}"
139 :kde-4)
140 _kdedir="4.0"
141 _pv="${NEED_KDE}"
142 ;;
143 # NEED_KDE="${PV}:${SLOT}"
144 *:kde-4)
145 _kdedir="4.0"
146 _operator=">="
147 _pv="-${NEED_KDE}"
148 ;;
149 3.9*)
150 _kdedir="3.9"
151 _operator=">="
152 _pv="-${NEED_KDE}:kde-4"
153 ;;
154 4*)
155 _kdedir="4.0"
156 _operator=">="
157 _pv="-${NEED_KDE}:kde-4"
158 ;;
159 *) die "NEED_KDE=${NEED_KDE} currently not supported."
160 ;;
161esac 393esac
394unset kdehandbookdepend kdehandbookrdepend
162 395
163if [[ ${NEED_KDE} != none ]]; then 396case ${KDE_REQUIRED} in
164 KDEDIR="/usr/kde/${_kdedir}" 397 always)
165 KDEDIRS="/usr:/usr/local:${KDEDIR}" 398 IUSE+=" aqua"
399 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
400 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
401 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
402 ;;
403 optional)
404 IUSE+=" aqua kde"
405 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
406 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
407 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
408 ;;
409 *) ;;
410esac
166 411
167 if [[ -n ${KDEBASE} ]]; then 412unset kdecommondepend kdedepend kderdepend
168 if [[ ${NEED_KDE} = svn ]]; then
169 SLOT="kde-svn"
170 else
171 SLOT="kde-4"
172 fi
173 fi
174 413
175 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 414debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
176 if [[ ${PN} != "kdelibs" ]]; then 415debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
416debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
417
418# Accumulate dependencies set by this eclass
177 DEPEND="${DEPEND} 419DEPEND+=" ${COMMONDEPEND}"
178 ${_operator}kde-base/kdelibs${_pv}"
179 RDEPEND="${RDEPEND} 420RDEPEND+=" ${COMMONDEPEND}"
180 ${_operator}kde-base/kdelibs${_pv}" 421unset COMMONDEPEND
181 if [[ ${PN} != "kdepimlibs" ]]; then
182 DEPEND="${DEPEND}
183 ${_operator}kde-base/kdepimlibs${_pv}"
184 RDEPEND="${RDEPEND}
185 ${_operator}kde-base/kdepimlibs${_pv}"
186 fi
187 fi
188 422
189 unset _operator _pv _kdedir 423# Add experimental kdeenablefinal, masked by default
190fi 424IUSE+=" kdeenablefinal"
191 425
192# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 426# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
193# koffice ebuild, the URI should be set in the ebuild itself 427# koffice ebuild, the URI should be set in the ebuild itself
194if [[ -n ${KDEBASE} ]]; then 428_calculate_src_uri() {
429 debug-print-function ${FUNCNAME} "$@"
430
431 local _kmname _kmname_pv
432
433 # we calculate URI only for known KDEBASE modules
434 [[ -n ${KDEBASE} ]] || return
435
436 # calculate tarball module name
195 if [[ -n ${KMNAME} ]]; then 437 if [[ -n ${KMNAME} ]]; then
438 # fixup kdebase-apps name
439 case ${KMNAME} in
440 kdebase-apps)
441 _kmname="kdebase" ;;
442 *)
196 _kmname=${KMNAME} 443 _kmname="${KMNAME}" ;;
444 esac
197 else 445 else
198 _kmname=${PN} 446 _kmname=${PN}
199 fi 447 fi
200 _kmname_pv="${_kmname}-${PV}" 448 _kmname_pv="${_kmname}-${PV}"
201 if [[ ${NEED_KDE} != "svn" ]]; then
202 case ${KDEBASE} in 449 case ${KDEBASE} in
203 kde-base) 450 kde-base)
204 case ${PV} in 451 case ${PV} in
452 4.[456].8[05] | 4.[456].9[023568])
453 # Unstable KDE SC releases
454 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
455 # KDEPIM IS SPECIAL
456 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname_pv}.tar.bz2"
457 ;;
458 4.4.[6789] | 4.4.1?*)
459 # Stable kdepim releases
460 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
461 ;;
462 *)
463 # Stable KDE SC releases
205 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 464 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
465 ;;
206 esac 466 esac
207 ;; 467 ;;
208 koffice) 468 koffice)
469 case ${PV} in
470 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
209 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" 471 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
472 esac
210 ;; 473 ;;
474 kdevelop)
475 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
476 ;;
477 esac
478}
479
480_calculate_live_repo() {
481 debug-print-function ${FUNCNAME} "$@"
482
483 SRC_URI=""
484 case ${KDE_SCM} in
485 svn)
486 # Determine branch URL based on live type
487 local branch_prefix
488 case ${PV} in
489 9999*)
490 # trunk
491 branch_prefix="trunk/KDE"
492 ;;
493 *)
494 # branch
495 branch_prefix="branches/KDE/${SLOT}"
496 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
497 # @DESCRIPTION
498 # Suffix appended to ESVN_PROJECT depending on fetched branch.
499 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
500 ESVN_PROJECT_SUFFIX="-${PV}"
501 ;;
502 esac
503 # @ECLASS-VARIABLE: ESVN_MIRROR
504 # @DESCRIPTION:
505 # This variable allows easy overriding of default kde mirror service
506 # (anonsvn) with anything else you might want to use.
507 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
508 # Split ebuild, or extragear stuff
509 if [[ -n ${KMNAME} ]]; then
510 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
511 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
512 KMMODULE="${PN}"
513 fi
514 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
515 case ${KMNAME} in
516 kdebase-*)
517 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
518 ;;
519 kdelibs-*)
520 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
521 ;;
522 kdereview*)
523 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
524 ;;
525 kdesupport)
526 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
527 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
528 ;;
529 kde*)
530 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
531 ;;
532 extragear*|playground*)
533 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
534 # build packages from same svn location.
535 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
536 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
537 ;;
538 koffice)
539 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
540 ;;
541 *)
542 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
543 ;;
544 esac
545 else
546 # kdelibs, kdepimlibs
547 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
548 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
549 fi
550 # @ECLASS-VARIABLE: ESVN_UP_FREQ
551 # @DESCRIPTION:
552 # This variable is used for specifying the timeout between svn synces
553 # for kde-base and koffice modules. Does not affect misc apps.
554 # Default value is 1 hour.
555 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
556 ;;
557 git)
558 local _kmname
559 # @ECLASS-VARIABLE: EGIT_MIRROR
560 # @DESCRIPTION:
561 # This variable allows easy overriding of default kde mirror service
562 # (anongit) with anything else you might want to use.
563 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
564
565 # @ECLASS-VARIABLE: EGIT_REPONAME
566 # @DESCRIPTION:
567 # This variable allows overriding of default repository
568 # name. Specify only if this differ from PN and KMNAME.
569 if [[ -n ${EGIT_REPONAME} ]]; then
570 # the repository and kmname different
571 _kmname=${EGIT_REPONAME}
572 elif [[ -n ${KMNAME} ]]; then
573 _kmname=${KMNAME}
574 else
575 _kmname=${PN}
576 fi
577
578 # default branching
579 case ${PV} in
580 9999*) ;;
581 *)
582 # set EGIT_BRANCH and EGIT_COMMIT to ${SLOT}
583 case ${_kmname} in
584 kdeplasma-addons | kdepim | kdepim-runtime | kdepimlibs | okular)
585 EGIT_BRANCH="${SLOT}"
586 ;;
587 marble)
588 EGIT_BRANCH="kde-${SLOT}"
589 ;;
590 *) EGIT_BRANCH="KDE/${SLOT}" ;;
591 esac
592 ;;
593 esac
594
595 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
596
597 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
598 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
599 ;;
600 esac
601}
602
603case ${BUILD_TYPE} in
604 live) _calculate_live_repo ;;
605 *) _calculate_src_uri ;;
606esac
607
608debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
609
610# @ECLASS-VARIABLE: PREFIX
611# @DESCRIPTION:
612# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
613# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
614# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
615
616# @FUNCTION: kde4-base_pkg_setup
617# @DESCRIPTION:
618# Do the basic kdeprefix KDEDIR settings and determine with which kde should
619# optional applications link
620kde4-base_pkg_setup() {
621 debug-print-function ${FUNCNAME} "$@"
622
623 if has kdeprefix ${IUSE//+} && use kdeprefix; then
624 eerror "Sorry, kdeprefix support has been removed."
625 eerror "Please remove kdeprefix from your USE variable."
626 die "kdeprefix support has been removed"
627 fi
628
629 if [[ ${CATEGORY}/${PN} != kde-base/kdelibs && ${CATEGORY}/${PN} != kde-base/kde-env ]] && \
630 { [[ ${KDE_REQUIRED} == always ]] || { [[ ${KDE_REQUIRED} == optional ]] && use kde; }; } && \
631 has_version kde-base/kdelibs[kdeprefix]; then
632 eerror "Sorry, kdeprefix support has been removed."
633 eerror "Please rebuild kdelibs without kdeprefix support."
634 die "kdeprefix support has been removed"
635 fi
636
637 # QA ebuilds
638 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
639
640 # Don't set KDEHOME during compilation, it will cause access violations
641 unset KDEHOME
642
643 # Check if gcc compiler is fresh enough.
644 # In theory should be in pkg_pretend but we check it only for kdelibs there
645 # and for others we do just quick scan in pkg_setup because pkg_pretend
646 # executions consume quite some time.
647 [[ $(gcc-major-version) -lt 4 ]] || \
648 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \
649 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)."
650
651 if [[ ${KDEBASE} = kde-base ]]; then
652 if use kdeprefix; then
653 KDEDIR=/usr/kde/${SLOT}
654 else
655 KDEDIR=/usr
656 fi
657 : ${PREFIX:=${KDEDIR}}
658 else
659 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
660 KDEDIR=
661 local kde_minimal_met
662 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
663 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
664 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
665 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
666 KDEDIR=/usr/kde/${slot}
667 else
668 KDEDIR=/usr
669 fi
670 break;
671 fi
672 done
673 unset slot
674
675 # Bail out if kdelibs required but not found
676 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
677 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
678 else
679 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
680 fi
681
682 : ${PREFIX:=/usr}
683 fi
684 EKDEDIR=${EPREFIX}${KDEDIR}
685
686 # Point pkg-config path to KDE *.pc files
687 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
688 # Point to correct QT plugins path
689 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
690
691 # Fix XDG collision with sandbox
692 export XDG_CONFIG_HOME="${T}"
693}
694
695# @FUNCTION: kde4-base_src_unpack
696# @DESCRIPTION:
697# This function unpacks the source tarballs for KDE4 applications.
698kde4-base_src_unpack() {
699 debug-print-function ${FUNCNAME} "$@"
700
701 if [[ ${BUILD_TYPE} = live ]]; then
702 case ${KDE_SCM} in
703 svn)
704 migrate_store_dir
705 subversion_src_unpack
706 ;;
707 git)
708 git-2_src_unpack
709 ;;
211 esac 710 esac
212 fi
213 unset _kmname _kmname_pv
214fi
215
216debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
217debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
218
219# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
220# If KMNAME is not set then this is not a split package
221if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
222 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
223 DEPEND="${DEPEND} !${_x}:${SLOT}"
224 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
225 done
226 unset _x
227fi
228
229debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
230
231# @ECLASS-VARIABLE: PREFIX
232# @DESCRIPTION:
233# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
234# Applications installed by the other ebuilds go into /usr/ by default, this value
235# can be superseded by defining PREFIX before inheriting kde4-base.
236if [[ -n ${KDEBASE} ]]; then
237 PREFIX=${KDEDIR}
238else
239 # if PREFIX is not defined we set it to the default value of /usr
240 PREFIX="${PREFIX:-/usr}"
241fi
242
243debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
244
245# @FUNCTION: kde4-base_pkg_setup
246# @DESCRIPTION:
247# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
248# kde4-functions_check_use from kde4-functions.eclass to print appropriate
249# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
250# $KDE4_BUILT_WITH_USE_CHECK are missing.
251kde4-base_pkg_setup() {
252 debug-print-function $FUNCNAME "$@"
253
254 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
255 if has_version '<x11-libs/qt-4.4_alpha:4'; then
256 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
257 else 711 else
258 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 712 unpack ${A}
259 x11-libs/qt-core qt3support ssl 713 fi
260 x11-libs/qt-gui accessibility dbus 714}
261 x11-libs/qt-qt3support accessibility" 715
716# @FUNCTION: kde4-base_src_prepare
717# @DESCRIPTION:
718# General pre-configure and pre-compile function for KDE4 applications.
719# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
720# enable_selected_linguas() and enable_selected_doc_linguas()
721# in kde4-functions.eclass(5) for further details.
722kde4-base_src_prepare() {
723 debug-print-function ${FUNCNAME} "$@"
724
725 # enable handbook and linguas only when not using live ebuild
726
727 # Only enable selected languages, used for KDE extragear apps.
728 if [[ -n ${KDE_LINGUAS} ]]; then
729 enable_selected_linguas
730 fi
731
732 # Enable/disable handbooks for kde4-base packages
733 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
734 # kdelibs inherits kde4-base but handle installing the handbook itself
735 if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then
736 if [[ ${KDEBASE} == kde-base ]]; then
737 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
738 # documentation in kde4-functions
739 : ${KDE_DOC_DIRS:=doc}
740 local dir
741 for dir in ${KDE_DOC_DIRS}; do
742 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
743 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
744 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
745 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
746 -i CMakeLists.txt || die "failed to comment out handbook"
747 done
748 fi
749 else
750 enable_selected_doc_linguas
751 fi
752 fi
753
754 # SCM bootstrap
755 if [[ ${BUILD_TYPE} = live ]]; then
756 case ${KDE_SCM} in
757 svn) subversion_src_prepare ;;
758 esac
759 fi
760
761 # Apply patches
762 base_src_prepare
763
764 # Save library dependencies
765 if [[ -n ${KMSAVELIBS} ]] ; then
766 save_library_dependencies
767 fi
768
769 # Inject library dependencies
770 if [[ -n ${KMLOADLIBS} ]] ; then
771 load_library_dependencies
772 fi
773
774 # Replace KDE4Workspace library targets
775 find "${S}" -name CMakeLists.txt \
776 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
777 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
778 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
779 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
780 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
781 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
782 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
783 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
784 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
785 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
786 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
787 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
788 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
789 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
790 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
791 || die 'failed to replace KDE4Workspace library targets'
792
793 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
794 if [[ -z ${KDEBASE} ]]; then
795 find "${S}" -name "*.docbook" \
796 -exec sed -i -r \
797 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
798 || die 'failed to fix DocBook variant version'
799 fi
800}
801
802# @FUNCTION: kde4-base_src_configure
803# @DESCRIPTION:
804# Function for configuring the build of KDE4 applications.
805kde4-base_src_configure() {
806 debug-print-function ${FUNCNAME} "$@"
807
808 # Build tests in src_test only, where we override this value
809 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
810
811 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
812 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
262 fi 813 fi
263 814
264 if has debug ${IUSE//+} && use debug; then 815 if has debug ${IUSE//+} && use debug; then
265 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then 816 # Set "real" debug mode
266 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug" 817 CMAKE_BUILD_TYPE="Debugfull"
818 else
819 # Handle common release builds
820 append-cppflags -DQT_NO_DEBUG
821 fi
822
823 # Set distribution name
824 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
825
826 # Here we set the install prefix
827 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
828
829 # Use colors
830 QTEST_COLORED=1
831
832 # Shadow existing /usr installations
833 unset KDEDIRS
834
835 # Handle kdeprefix-ed KDE
836 if [[ ${KDEDIR} != /usr ]]; then
837 # Override some environment variables - only when kdeprefix is different,
838 # to not break ccache/distcc
839 PATH="${EKDEDIR}/bin:${PATH}"
840
841 # Append library search path
842 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
843
844 # Append full RPATH
845 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
846
847 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
848 # when more are present
849 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
850 fi
851
852 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
853 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
854 #kde-config -path data unavailable when cross-compiling
855 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
856
857 # Handle kdeprefix in application itself
858 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
859 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
860 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
861 fi
862
863 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
864 mycmakeargs=(${mycmakeargs})
865 fi
866
867 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
868
869 cmake-utils_src_configure
870}
871
872# @FUNCTION: kde4-base_src_compile
873# @DESCRIPTION:
874# General function for compiling KDE4 applications.
875kde4-base_src_compile() {
876 debug-print-function ${FUNCNAME} "$@"
877
878 cmake-utils_src_compile "$@"
879}
880
881# @FUNCTION: kde4-base_src_test
882# @DESCRIPTION:
883# Function for testing KDE4 applications.
884kde4-base_src_test() {
885 debug-print-function ${FUNCNAME} "$@"
886
887 # Override this value, set in kde4-base_src_configure()
888 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
889 cmake-utils_src_configure
890 kde4-base_src_compile
891
892 # When run as normal user during ebuild development with the ebuild command, the
893 # kde tests tend to access the session DBUS. This however is not possible in a real
894 # emerge or on the tinderbox.
895 # > make sure it does not happen, so bad tests can be recognized and disabled
896 unset DBUS_SESSION_BUS_ADDRESS
897
898 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
899 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
900 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
901 # surprise- we are already INSIDE virtualmake!!!
902 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
903 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
904 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
905 debug-print " kde4-base.eclass docs for details... Applying workaround."
906 cmake-utils_src_test
267 else 907 else
268 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 908 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
269 x11-libs/qt-core:4 debug 909 fi
270 x11-libs/qt-gui:4 debug 910 else
271 x11-libs/qt-qt3support:4 debug 911 cmake-utils_src_test
272 x11-libs/qt-svg:4 debug 912 fi
273 x11-libs/qt-test:4 debug" 913}
274 if [[ ${OPENGL_REQUIRED} == always ]] || has opengl ${IUSE//+} && use opengl; then 914
275 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 915# @FUNCTION: kde4-base_src_install
276 x11-libs/qt-opengl:4 debug" 916# @DESCRIPTION:
917# Function for installing KDE4 applications.
918kde4-base_src_install() {
919 debug-print-function ${FUNCNAME} "$@"
920
921 if [[ -n ${KMSAVELIBS} ]] ; then
922 install_library_dependencies
923 fi
924
925 # Install common documentation of KDE4 applications
926 local doc
927 if ! has kde4-meta ${INHERITED}; then
928 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
929 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
930 done
931 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
932 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
933 done
934 fi
935
936 cmake-utils_src_install
937
938 # In EAPI 4+, we don't want ${PREFIX}/share/doc/HTML to be compressed,
939 # because then khelpcenter can't find the docs
940 [[ ${EAPI:-0} != 3 && -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
941 docompress -x ${PREFIX}/share/doc/HTML
942}
943
944# @FUNCTION: kde4-base_pkg_preinst
945# @DESCRIPTION:
946# Function storing icon caches
947kde4-base_pkg_preinst() {
948 debug-print-function ${FUNCNAME} "$@"
949
950 gnome2_icon_savelist
951}
952
953# @FUNCTION: kde4-base_pkg_postinst
954# @DESCRIPTION:
955# Function to rebuild the KDE System Configuration Cache after an application has been installed.
956kde4-base_pkg_postinst() {
957 debug-print-function ${FUNCNAME} "$@"
958
959 gnome2_icon_cache_update
960 fdo-mime_desktop_database_update
961 fdo-mime_mime_database_update
962 buildsycoca
963
964 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
965 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
966 echo
967 ewarn "WARNING! you have kdeenable final useflag enabled."
968 ewarn "This useflag needs to be enabled on ALL kde using packages and"
969 ewarn "is known to cause issues."
970 ewarn "You are using this setup at your own risk and the kde team does not"
971 ewarn "take responsibilities for dead kittens."
972 echo
973 fi
974 if [[ ${BUILD_TYPE} = live ]]; then
975 echo
976 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
977 einfo "Use it at your own risk."
978 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
979 echo
980 fi
981 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
982 if [[ ${KDEBASE} != kde-base ]] && \
983 ! has_version 'kde-base/kdebase-runtime-meta' && \
984 ! has_version 'kde-base/kdebase-startkde'; then
985 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
986 echo
987 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
988 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
989 ewarn "With this setting you are unsupported by KDE team."
990 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
277 fi 991 fi
278 fi 992 fi
279 fi 993 fi
280 994 if has kdeprefix ${IUSE//+} && use kdeprefix; then
281 if [[ ${OPENGL_REQUIRED} == always ]] || has opengl ${IUSE//+} && use opengl; then 995 # warning about kdeprefix
282 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then 996 echo
283 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl" 997 ewarn "WARNING! You have the kdeprefix useflag enabled."
998 eerror "This setting will be removed on or about 2011-06-06."
999 ewarn "You are using this setup at your own risk and the kde team does not"
1000 ewarn "take responsibilities for dead kittens."
1001 echo
284 fi 1002 fi
285 fi
286
287 kde4-functions_check_use
288}
289
290# @FUNCTION: kde4-base_apply_patches
291# @DESCRIPTION:
292# This function applies patches.
293#
294# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
295# directory, provided they follow this format:
296# @CODE
297# - Monolithic ebuilds, (from kde-base)
298# - $CATEGORY=kde-base:
299# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
300# - $CATEGORY=!kde-base:
301# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
302# - Split ebuilds:
303# - $CATEGORY=kde-base:
304# Apply ${PN}-${SLOT}-*{diff,patch}
305# - $CATEGORY!=kde-base:
306# Apply ${PN}-${PV}-*{diff,patch}
307# @CODE
308#
309# If ${PATCHES} is non-zero all patches in it gets applied.
310kde4-base_apply_patches() {
311 local _patchdir _packages _p
312 _patchdir="${WORKDIR}/patches/"
313 if [[ -d "${_patchdir}" ]]; then
314 if is-parent-package ${CATEGORY}/${PN} ; then
315 _packages="$(get-child-packages ${CATEGORY}/${PN})"
316 _packages="${_packages//${CATEGORY}\//} ${PN}"
317 else
318 _packages="${PN}"
319 fi
320 for _p in ${_packages}; do
321 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
322 if [[ -n "${KDEBASE}" ]]; then
323 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
324 fi
325 done
326 fi
327 [[ -n ${PATCHES} ]] && base_src_unpack autopatch
328}
329
330# @FUNCTION: kde4-base_src_unpack
331# @DESCRIPTION:
332# This function unpacks the source tarballs for KDE4 applications.
333#
334# If no argument is passed to this function, then standard src_unpack is
335# executed. Otherwise options are passed to base_src_unpack.
336#
337# In addition it calls kde4-base_apply_patches when no arguments are passed to
338# this function.
339kde4-base_src_unpack() {
340 debug-print-function $FUNCNAME "$@"
341
342 [[ -z "${KDE_S}" ]] && KDE_S="${S}"
343
344 if [[ -z $* ]]; then
345 # Unpack first and deal with KDE patches after examing possible patch sets.
346 # To be picked up, patches need to conform to the guidelines stated before.
347 # Monolithic ebuilds will use the split ebuild patches.
348 [[ -d "${KDE_S}" ]] || unpack ${A}
349 kde4-base_apply_patches
350 else
351 # Call base_src_unpack, which unpacks and patches
352 # step by step transparently as defined in the ebuild.
353 base_src_unpack $*
354 fi
355
356 # Updated cmake dir
357 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then
358 ebegin "Updating cmake/ directory..."
359 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory"
360 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory"
361 eend 0
362 fi
363}
364
365# @FUNCTION: kde4-base_src_compile
366# @DESCRIPTION:
367# General function for compiling KDE4 applications.
368kde4-base_src_compile() {
369 debug-print-function ${FUNCNAME} "$@"
370
371 kde4-base_src_configure
372 kde4-base_src_make
373}
374
375# @FUNCTION: kde4-base_src_configure
376# @DESCRIPTION:
377# Function for configuring the build of KDE4 applications.
378kde4-base_src_configure() {
379 debug-print-function ${FUNCNAME} "$@"
380
381 # Final flag handling
382 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
383 einfo "Activating enable-final flag"
384 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
385 fi
386
387 # Enable generation of HTML handbook
388 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
389 einfo "Enabling building of HTML handbook"
390 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
391 fi
392
393 # Build tests in src_test only, where we override this value
394 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
395
396 # Set distribution name
397 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
398
399 # runpath linking
400 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
401
402 # Here we set the install prefix
403 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
404
405 # Set environment
406 QTEST_COLORED=1
407 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
408
409 cmake-utils_src_configureout
410}
411
412# @FUNCTION: kde4-base_src_make
413# @DESCRIPTION:
414# Function for building KDE4 applications.
415# Options are passed to cmake-utils_src_make.
416kde4-base_src_make() {
417 debug-print-function ${FUNCNAME} "$@"
418
419 cmake-utils_src_make "$@"
420}
421
422# @FUNCTION: kde4-base_src_test
423# @DESCRIPTION:
424# Function for testing KDE4 applications.
425kde4-base_src_test() {
426 debug-print-function ${FUNCNAME} "$@"
427
428 # Override this value, set in kde4-base_src_configure()
429 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON"
430 cmake-utils_src_compile
431
432 cmake-utils_src_test
433}
434
435# @FUNCTION: kde4-base_src_install
436# @DESCRIPTION:
437# Function for installing KDE4 applications.
438kde4-base_src_install() {
439 debug-print-function ${FUNCNAME} "$@"
440
441 kde4-base_src_make_doc
442 cmake-utils_src_install
443}
444
445# @FUNCTION: kde4-base_src_make_doc
446# @DESCRIPTION:
447# Function for installing the documentation of KDE4 applications.
448kde4-base_src_make_doc() {
449 debug-print-function ${FUNCNAME} "$@"
450
451 local doc
452 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
453 [[ -s $doc ]] && dodoc ${doc}
454 done
455
456 if [[ -z ${KMNAME} ]]; then
457 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
458 if [[ -s $doc ]]; then
459 local doc_complete=${doc}
460 doc="${doc#*/}"
461 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
462 fi
463 done
464 fi
465
466 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
467 # work around bug #97196
468 dodir /usr/share/doc/kde && \
469 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
470 die "Failed to move docs to kde/ failed."
471 fi
472}
473
474# @FUNCTION: kde4-base_pkg_postinst
475# @DESCRIPTION:
476# Function to rebuild the KDE System Configuration Cache after an application has been installed.
477kde4-base_pkg_postinst() {
478 buildsycoca
479} 1003}
480 1004
481# @FUNCTION: kde4-base_pkg_postrm 1005# @FUNCTION: kde4-base_pkg_postrm
482# @DESCRIPTION: 1006# @DESCRIPTION:
483# Function to rebuild the KDE System Configuration Cache after an application has been removed. 1007# Function to rebuild the KDE System Configuration Cache after an application has been removed.
484kde4-base_pkg_postrm() { 1008kde4-base_pkg_postrm() {
1009 debug-print-function ${FUNCNAME} "$@"
1010
1011 gnome2_icon_cache_update
1012 fdo-mime_desktop_database_update
1013 fdo-mime_mime_database_update
485 buildsycoca 1014 buildsycoca
486} 1015}

Legend:
Removed from v.1.4  
changed lines
  Added in v.1.95

  ViewVC Help
Powered by ViewVC 1.1.20