/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.6 Revision 1.59
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.6 2008/03/26 20:39:05 zlin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.59 2010/04/07 21:16:33 scarabeus Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# eclass will fail with version older than 2.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: CMAKE_REQUIRED
17# @DESCRIPTION:
18# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
19# Please note that if it's set to 'never' you need to explicitly override following phases:
20# src_configure, src_compile, src_test and src_install.
21# Defaults to 'always'.
22: ${CMAKE_REQUIRED:=always}
23if [[ ${CMAKE_REQUIRED} = false || ${CMAKE_REQUIRED} = never ]]; then
24 buildsystem_eclass=""
25 export_fns=""
26else
27 buildsystem_eclass="cmake-utils"
28 export_fns="src_configure src_compile src_test src_install"
29fi
17 30
31inherit kde4-functions
32
33get_build_type
34if [[ ${BUILD_TYPE} = live ]]; then
35 subversion_eclass="subversion"
36fi
37
38inherit base ${buildsystem_eclass} eutils ${subversion_eclass}
39
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 40EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
19 41
20COMMONDEPEND="|| ( ( 42unset buildsystem_eclass
21 x11-libs/qt-core:4 43unset export_fns
22 x11-libs/qt-gui:4 44unset subversion_eclass
23 x11-libs/qt-qt3support:4 45
24 x11-libs/qt-svg:4 46case ${KDEBASE} in
25 x11-libs/qt-test:4 ) 47 kde-base)
26 >=x11-libs/qt-4.3.3:4 )" 48 HOMEPAGE="http://www.kde.org/"
49 LICENSE="GPL-2"
50 ;;
51 koffice)
52 HOMEPAGE="http://www.koffice.org/"
53 LICENSE="GPL-2"
54 ;;
55esac
27 56
28# @ECLASS-VARIABLE: OPENGL_REQUIRED 57# @ECLASS-VARIABLE: OPENGL_REQUIRED
29# @DESCRIPTION: 58# @DESCRIPTION:
30# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 59# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
31# This variable must be set before inheriting any eclasses. Defaults to 'never'. 60# This variable must be set before inheriting any eclasses. Defaults to 'never'.
32OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 61OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
33 62
34OPENGLDEPEND="|| ( x11-libs/qt-opengl:4 63# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
35 >=x11-libs/qt-4.3.3:4 )" 64# @DESCRIPTION:
36case "${OPENGL_REQUIRED}" in 65# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
37 always) 66# This variable must be set before inheriting any eclasses. Defaults to 'never'.
38 COMMONDEPEND="${COMMONDEPEND} 67MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
39 ${OPENGLDEPEND}"
40 ;;
41 optional)
42 IUSE="${IUSE} opengl"
43 COMMONDEPEND="${COMMONDEPEND}
44 opengl? ( ${OPENGLDEPEND} )"
45 ;;
46 *)
47 OPENGL_REQUIRED="never"
48 ;;
49esac
50 68
51DEPEND="${DEPEND} ${COMMONDEPEND} 69# @ECLASS-VARIABLE: WEBKIT_REQUIRED
52 >=dev-util/cmake-2.4.7-r1 70# @DESCRIPTION:
53 dev-util/pkgconfig 71# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
54 x11-libs/libXt 72# This variable must be set before inheriting any eclasses. Defaults to 'never'.
55 x11-proto/xf86vidmodeproto" 73WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
56RDEPEND="${RDEPEND} ${COMMONDEPEND}"
57 74
58# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 75# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
59# @DESCRIPTION: 76# @DESCRIPTION:
60# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 77# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
61# This variable must be set before inheriting any eclasses. Defaults to 'never'. 78# This variable must be set before inheriting any eclasses. Defaults to 'never'.
62CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 79CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
63 80
81# @ECLASS-VARIABLE: KDE_REQUIRED
82# @DESCRIPTION:
83# Is kde required? Possible values are 'always', 'optional' and 'never'.
84# This variable must be set before inheriting any eclasses. Defaults to 'always'
85# If set to always or optional, KDE_MINIMAL may be overriden as well.
86# Note that for kde-base packages this variable is fixed to 'always'.
87KDE_REQUIRED="${KDE_REQUIRED:-always}"
88
89# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
90if [[ -n ${KDE_MINIMAL} ]]; then
91 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
92 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
93 done
94 unset slot
95 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
96else
97 KDE_MINIMAL_VALID=1
98fi
99
100# @ECLASS-VARIABLE: KDE_MINIMAL
101# @DESCRIPTION:
102# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
103# version for apps to work. Currently defaults to 4.3
104# One may override this variable to raise version requirements.
105# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
106# Note that it is fixed to ${SLOT} for kde-base packages.
107KDE_MINIMAL="${KDE_MINIMAL:-4.3}"
108
109# Setup packages inheriting this eclass
110case ${KDEBASE} in
111 kde-base)
112 if [[ $BUILD_TYPE = live ]]; then
113 # Disable tests for live ebuilds
114 RESTRICT+=" test"
115 # Live ebuilds in kde-base default to kdeprefix by default
116 IUSE+=" +kdeprefix"
117 else
118 # All other ebuild types default to -kdeprefix as before
119 IUSE+=" kdeprefix"
120 fi
121 # Determine SLOT from PVs
122 case ${PV} in
123 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
124 4.5* | 4.4.[6-9]*) SLOT="4.5" ;;
125 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
126 4.3*) SLOT="4.3" ;;
127 9999*) SLOT="live" ;; # regular live
128 *) die "Unsupported ${PV}" ;;
129 esac
130 # This code is to prevent portage from searching GENTOO_MIRRORS for
131 # packages that will never be mirrored. (As they only will ever be in
132 # the overlay).
133 case ${PV} in
134 *9999* | 4.?.[6-9]?)
135 RESTRICT+=" mirror"
136 ;;
137 esac
138 KDE_MINIMAL="${SLOT}"
139 _kdedir="${SLOT}"
140
141 # Block installation of other SLOTS unless kdeprefix
142 RDEPEND+=" $(block_other_slots)"
143 ;;
144 koffice)
145 SLOT="2"
146 ;;
147esac
148
149# @ECLASS-VARIABLE: QT_MINIMAL
150# @DESCRIPTION:
151# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1..
152# Currently defaults to 4.5.1 for KDE 4.3 and earlier
153# or 4.6.0_rc1 for KDE 4.4 and later
154if slot_is_at_least 4.4 "${KDE_MINIMAL}"; then
155 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
156fi
157
158QT_MINIMAL="${QT_MINIMAL:-4.5.1}"
159
160# OpenGL dependencies
161qtopengldepend="
162 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
163"
64case "${CPPUNIT_REQUIRED}" in 164case ${OPENGL_REQUIRED} in
65 always) 165 always)
66 DEPEND="${DEPEND} dev-util/cppunit" 166 COMMONDEPEND+=" ${qtopengldepend}"
67 ;; 167 ;;
68 optional) 168 optional)
69 IUSE="${IUSE} test" 169 IUSE+=" opengl"
70 DEPEND="${DEPEND} 170 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
71 test? ( dev-util/cppunit )"
72 ;; 171 ;;
73 *) 172 *) ;;
74 CPPUNIT_REQUIRED="never" 173esac
174unset qtopengldepend
175
176# MultiMedia dependencies
177qtmultimediadepend="
178 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
179"
180case ${MULTIMEDIA_REQUIRED} in
181 always)
182 COMMONDEPEND+=" ${qtmultimediadepend}"
75 ;; 183 ;;
184 optional)
185 IUSE+=" multimedia"
186 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
187 ;;
188 *) ;;
76esac 189esac
190unset qtmultimediadepend
77 191
78# @ECLASS-VARIABLE: NEED_KDE 192# WebKit dependencies
79# @DESCRIPTION: 193case ${KDE_REQUIRED} in
80# This variable sets the version of KDE4 which will be used by the eclass. 194 always)
81# This variable must be set by the ebuild, for all categories except for "kde-base". 195 qtwebkitusedeps="[kde]"
82# For kde-base packages, if it is not set by the ebuild, 196 ;;
83# it's assumed that the required KDE4 version is the latest, non-live, available. 197 optional)
84# 198 qtwebkitusedeps="[kde?]"
85# @CODE 199 ;;
86# Acceptable values are: 200 *) ;;
87# - latest - Use latest version in the portage tree 201esac
88# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 202qtwebkitdepend="
89# - svn - Use svn release (live ebuilds) 203 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
90# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value. 204"
91# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value. 205unset qtwebkitusedeps
92# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value. 206case ${WEBKIT_REQUIRED} in
93# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ... 207 always)
94# @CODE 208 COMMONDEPEND+=" ${qtwebkitdepend}"
95# 209 ;;
96# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of 210 optional)
97# koffice, so you must set it explicitly in the ebuild, in all other cases. 211 IUSE+=" webkit"
98if [[ -z ${NEED_KDE} ]]; then 212 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
213 ;;
214 *) ;;
215esac
216unset qtwebkitdepend
217
218# CppUnit dependencies
219cppuintdepend="
220 dev-util/cppunit
221"
222case ${CPPUNIT_REQUIRED} in
223 always)
224 DEPEND+=" ${cppuintdepend}"
225 ;;
226 optional)
227 IUSE+=" test"
228 DEPEND+=" test? ( ${cppuintdepend} )"
229 ;;
230 *) ;;
231esac
232unset cppuintdepend
233
234# KDE dependencies
235kdecommondepend="
236 dev-lang/perl
237 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
238 >=x11-libs/qt-gui-${QT_MINIMAL}:4[dbus]
239 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[kde]
240 >=x11-libs/qt-script-${QT_MINIMAL}:4
241 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
242 >=x11-libs/qt-svg-${QT_MINIMAL}:4
243 >=x11-libs/qt-test-${QT_MINIMAL}:4
244 !aqua? (
245 x11-libs/libXext
246 x11-libs/libXt
247 x11-libs/libXxf86vm
248 )
249"
250if [[ ${PN} != kdelibs ]]; then
99 if [[ -n ${KDEBASE} ]]; then 251 if [[ ${KDEBASE} = kde-base ]]; then
100 NEED_KDE="latest" 252 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
253 # libknotificationitem only when SLOT is 4.3
254 [[ ${PN} != libknotificationitem ]] && [[ ${SLOT} = 4.3 ]] && \
255 kdecommondepend+=" $(add_kdebase_dep libknotificationitem)"
101 else 256 else
102 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild" 257 kdecommondepend+="
258 >=kde-base/kdelibs-${KDE_MINIMAL}
259 "
103 fi 260 fi
104fi 261fi
105export NEED_KDE 262kdedepend="
106 263 dev-util/pkgconfig
107case ${NEED_KDE} in 264 !aqua? (
108 latest) 265 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
109 # Should only be used by 'kde-base'-ebuilds 266 x11-proto/xf86vidmodeproto
110 if [[ "${KDEBASE}" == "kde-base" ]]; then 267 )
111 case ${PV} in 268"
112 3.9*) _kdedir="3.9" ;; 269case ${KDE_REQUIRED} in
113 4*) _kdedir="4.0" ;; 270 always)
114 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 271 IUSE+=" aqua"
115 esac 272 COMMONDEPEND+=" ${kdecommondepend}"
116 _operator=">=" 273 DEPEND+=" ${kdedepend}"
117 _pv="-${PV}:kde-4"
118 else
119 _kdedir="4.0"
120 _pv=":kde-4"
121 fi
122 ;; 274 ;;
123 svn|9999*|:kde-svn) 275 optional)
124 _kdedir="svn" 276 IUSE+=" aqua kde"
125 _pv=":kde-svn" 277 COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
126 export NEED_KDE="svn" 278 DEPEND+=" kde? ( ${kdedepend} )"
127 ;; 279 ;;
128 *:kde-svn) 280 *) ;;
129 _kdedir="svn"
130 _operator=">="
131 _pv="-${NEED_KDE}"
132 export NEED_KDE="svn"
133 ;;
134 # The ebuild handles dependencies, KDEDIR, SLOT.
135 none)
136 :
137 ;;
138 # NEED_KDE=":${SLOT}"
139 :kde-4)
140 _kdedir="4.0"
141 _pv="${NEED_KDE}"
142 ;;
143 # NEED_KDE="${PV}:${SLOT}"
144 *:kde-4)
145 _kdedir="4.0"
146 _operator=">="
147 _pv="-${NEED_KDE}"
148 ;;
149 3.9*)
150 _kdedir="3.9"
151 _operator=">="
152 _pv="-${NEED_KDE}:kde-4"
153 ;;
154 4*)
155 _kdedir="4.0"
156 _operator=">="
157 _pv="-${NEED_KDE}:kde-4"
158 ;;
159 *) die "NEED_KDE=${NEED_KDE} currently not supported."
160 ;;
161esac 281esac
162 282
163if [[ ${NEED_KDE} != none ]]; then 283unset kdecommondepend kdedepend
164 KDEDIR="/usr/kde/${_kdedir}"
165 KDEDIRS="/usr:/usr/local:${KDEDIR}"
166 284
167 if [[ -n ${KDEBASE} ]]; then 285debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
168 if [[ ${NEED_KDE} = svn ]]; then 286debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
169 SLOT="kde-svn" 287debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
170 else
171 SLOT="kde-4"
172 fi
173 fi
174 288
175 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 289# Accumulate dependencies set by this eclass
176 if [[ ${PN} != "kdelibs" ]]; then
177 DEPEND="${DEPEND} 290DEPEND+=" ${COMMONDEPEND}"
178 ${_operator}kde-base/kdelibs${_pv}"
179 RDEPEND="${RDEPEND} 291RDEPEND+=" ${COMMONDEPEND}"
180 ${_operator}kde-base/kdelibs${_pv}" 292unset COMMONDEPEND
181 if [[ ${PN} != "kdepimlibs" ]]; then
182 DEPEND="${DEPEND}
183 ${_operator}kde-base/kdepimlibs${_pv}"
184 RDEPEND="${RDEPEND}
185 ${_operator}kde-base/kdepimlibs${_pv}"
186 fi
187 fi
188 293
189 unset _operator _pv _kdedir 294# Add experimental kdeenablefinal, disabled by default
190fi 295IUSE+=" kdeenablefinal"
191 296
192# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 297# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
193# koffice ebuild, the URI should be set in the ebuild itself 298# koffice ebuild, the URI should be set in the ebuild itself
194if [[ -n ${KDEBASE} ]]; then 299case ${BUILD_TYPE} in
300 live)
301 # Determine branch URL based on live type
302 local branch_prefix
303 case ${PV} in
304 9999*)
305 # trunk
306 branch_prefix="trunk/KDE"
307 ;;
308 *)
309 # branch
310 branch_prefix="branches/KDE/${SLOT}"
311 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
312 # @DESCRIPTION
313 # Suffix appended to ESVN_PROJECT depending on fetched branch.
314 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
315 ESVN_PROJECT_SUFFIX="-${PV}"
316 ;;
317 esac
318 SRC_URI=""
319 # @ECLASS-VARIABLE: ESVN_MIRROR
320 # @DESCRIPTION:
321 # This variable allows easy overriding of default kde mirror service
322 # (anonsvn) with anything else you might want to use.
323 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
324 # Split ebuild, or extragear stuff
195 if [[ -n ${KMNAME} ]]; then 325 if [[ -n ${KMNAME} ]]; then
326 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
327 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
328 KMMODULE="${PN}"
329 fi
330 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
331 case ${KMNAME} in
332 kdebase-*)
333 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
334 ;;
335 kdelibs-*)
336 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
337 ;;
338 kdereview*)
339 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
340 ;;
341 kdesupport)
342 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
343 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
344 ;;
345 kde*)
346 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
347 ;;
348 extragear*|playground*)
349 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
350 # build packages from same svn location.
351 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
352 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
353 ;;
354 koffice)
355 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
356 ;;
357 *)
358 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
359 ;;
360 esac
361 else
362 # kdelibs, kdepimlibs
363 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
364 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
365 fi
366 # @ECLASS-VARIABLE: ESVN_UP_FREQ
367 # @DESCRIPTION:
368 # This variable is used for specifying the timeout between svn synces
369 # for kde-base and koffice modules. Does not affect misc apps.
370 # Default value is 1 hour.
371 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
372 ;;
373 *)
374 if [[ -n ${KDEBASE} ]]; then
375 if [[ -n ${KMNAME} ]]; then
376 case ${KMNAME} in
377 kdebase-apps)
378 _kmname="kdebase" ;;
379 *)
196 _kmname=${KMNAME} 380 _kmname="${KMNAME}" ;;
381 esac
382 else
383 _kmname=${PN}
384 fi
385 _kmname_pv="${_kmname}-${PV}"
386 case ${KDEBASE} in
387 kde-base)
388 case ${PV} in
389 4.[34].8[05] | 4.[34].9[0568])
390 # block for normally packed unstable releases
391 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
392 4.[34].[6-9]*)
393 # Repacked tarballs: need to depend on xz-utils to ensure that they can be unpacked
394 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.xz"
395 DEPEND+=" app-arch/xz-utils"
396 ;;
397 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
398 esac
399 ;;
400 koffice)
401 case ${PV} in
402 2.0.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;;
403 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
404 esac
405 esac
406 unset _kmname _kmname_pv
407 fi
408 ;;
409esac
410
411debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
412
413# @ECLASS-VARIABLE: PREFIX
414# @DESCRIPTION:
415# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
416# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
417# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
418
419# @FUNCTION: kde4-base_pkg_setup
420# @DESCRIPTION:
421# Do the basic kdeprefix KDEDIR settings and determine with which kde should
422# optional applications link
423kde4-base_pkg_setup() {
424 debug-print-function ${FUNCNAME} "$@"
425
426 # Prefix compat:
427 if [[ ${EAPI} == 2 ]] && ! use prefix; then
428 EPREFIX=
429 EROOT=${ROOT}
430 fi
431
432 # Append missing trailing slash character
433 [[ ${EROOT} = */ ]] || EROOT+="/"
434
435 # QA ebuilds
436 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
437
438 # Don't set KDEHOME during compilation, it will cause access violations
439 unset KDEHOME
440
441 if [[ ${KDEBASE} = kde-base ]]; then
442 if use kdeprefix; then
443 KDEDIR=/usr/kde/${_kdedir}
444 else
445 KDEDIR=/usr
446 fi
447 : ${PREFIX:=${KDEDIR}}
197 else 448 else
198 _kmname=${PN} 449 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
199 fi 450 KDEDIR=
200 _kmname_pv="${_kmname}-${PV}" 451 local kde_minimal_met
201 if [[ ${NEED_KDE} != "svn" ]]; then 452 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
202 case ${KDEBASE} in 453 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
203 kde-base) 454 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
204 case ${PV} in 455 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
205 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 456 KDEDIR=/usr/kde/${slot}
206 esac
207 ;;
208 koffice)
209 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2"
210 ;;
211 esac
212 fi
213 unset _kmname _kmname_pv
214fi
215
216debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
217debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
218
219# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
220# If KMNAME is not set then this is not a split package
221if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
222 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
223 DEPEND="${DEPEND} !${_x}:${SLOT}"
224 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
225 done
226 unset _x
227fi
228
229debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
230
231# @ECLASS-VARIABLE: PREFIX
232# @DESCRIPTION:
233# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
234# Applications installed by the other ebuilds go into /usr/ by default, this value
235# can be superseded by defining PREFIX before inheriting kde4-base.
236if [[ -n ${KDEBASE} ]]; then
237 PREFIX=${KDEDIR}
238else
239 # if PREFIX is not defined we set it to the default value of /usr
240 PREFIX="${PREFIX:-/usr}"
241fi
242
243debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
244
245# @FUNCTION: kde4-base_pkg_setup
246# @DESCRIPTION:
247# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
248# kde4-functions_check_use from kde4-functions.eclass to print appropriate
249# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
250# $KDE4_BUILT_WITH_USE_CHECK are missing.
251kde4-base_pkg_setup() {
252 debug-print-function $FUNCNAME "$@"
253
254 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
255 if has_version '<x11-libs/qt-4.4_alpha:4'; then
256 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
257 else
258 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
259 x11-libs/qt-core qt3support ssl
260 x11-libs/qt-gui accessibility dbus
261 x11-libs/qt-qt3support accessibility"
262 fi
263
264 if has debug ${IUSE//+} && use debug; then
265 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
266 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug"
267 else 457 else
268 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 458 KDEDIR=/usr
269 x11-libs/qt-core:4 debug
270 x11-libs/qt-gui:4 debug
271 x11-libs/qt-qt3support:4 debug
272 x11-libs/qt-svg:4 debug
273 x11-libs/qt-test:4 debug"
274 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
275 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
276 x11-libs/qt-opengl:4 debug"
277 fi 459 fi
278 fi 460 break;
279 fi
280
281 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
282 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
283 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
284 fi
285 fi
286
287 kde4-functions_check_use
288}
289
290# @FUNCTION: kde4-base_apply_patches
291# @DESCRIPTION:
292# This function applies patches.
293#
294# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
295# directory, provided they follow this format:
296# @CODE
297# - Monolithic ebuilds, (from kde-base)
298# - $CATEGORY=kde-base:
299# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
300# - $CATEGORY=!kde-base:
301# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
302# - Split ebuilds:
303# - $CATEGORY=kde-base:
304# Apply ${PN}-${SLOT}-*{diff,patch}
305# - $CATEGORY!=kde-base:
306# Apply ${PN}-${PV}-*{diff,patch}
307# @CODE
308#
309# If ${PATCHES} is non-zero all patches in it gets applied.
310kde4-base_apply_patches() {
311 local _patchdir _packages _p
312 _patchdir="${WORKDIR}/patches/"
313 if [[ -d "${_patchdir}" ]]; then
314 if is-parent-package ${CATEGORY}/${PN} ; then
315 _packages="$(get-child-packages ${CATEGORY}/${PN})"
316 _packages="${_packages//${CATEGORY}\//} ${PN}"
317 else
318 _packages="${PN}"
319 fi
320 for _p in ${_packages}; do
321 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
322 if [[ -n "${KDEBASE}" ]]; then
323 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
324 fi 461 fi
325 done 462 done
463 unset slot
464
465 # Bail out if kdelibs required but not found
466 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
467 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
468 else
469 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
326 fi 470 fi
327 [[ -n ${PATCHES} ]] && base_src_unpack autopatch 471
472 : ${PREFIX:=/usr}
473 fi
474 EKDEDIR=${EPREFIX}${KDEDIR}
475
476 # Point pkg-config path to KDE *.pc files
477 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
478 # Point to correct QT plugins path
479 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
480
481 # Fix XDG collision with sandbox
482 export XDG_CONFIG_HOME="${T}"
483 # Not needed anymore
484 unset _kdedir
328} 485}
329 486
330# @FUNCTION: kde4-base_src_unpack 487# @FUNCTION: kde4-base_src_unpack
331# @DESCRIPTION: 488# @DESCRIPTION:
332# This function unpacks the source tarballs for KDE4 applications. 489# This function unpacks the source tarballs for KDE4 applications.
333#
334# If no argument is passed to this function, then standard src_unpack is
335# executed. Otherwise options are passed to base_src_unpack.
336#
337# In addition it calls kde4-base_apply_patches when no arguments are passed to
338# this function.
339kde4-base_src_unpack() { 490kde4-base_src_unpack() {
340 debug-print-function $FUNCNAME "$@" 491 debug-print-function ${FUNCNAME} "$@"
341 492
342 [[ -z "${KDE_S}" ]] && KDE_S="${S}" 493 if [[ ${BUILD_TYPE} = live ]]; then
343 494 migrate_store_dir
344 if [[ -z $* ]]; then 495 subversion_src_unpack
345 # Unpack first and deal with KDE patches after examing possible patch sets. 496 elif [[ ${EAPI} == 2 ]]; then
346 # To be picked up, patches need to conform to the guidelines stated before. 497 local file
347 # Monolithic ebuilds will use the split ebuild patches. 498 for file in ${A}; do
348 [[ -d "${KDE_S}" ]] || unpack ${A} 499 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
349 kde4-base_apply_patches 500 # directly, so we do it ourselves (using the exact same code as portage)
501 case ${file} in
502 *.tar.xz)
503 echo ">>> Unpacking ${file} to ${PWD}"
504 xz -dc "${DISTDIR}"/${file} | tar xof -
505 assert "failed unpacking ${file}"
506 ;;
507 *)
508 unpack ${file}
509 ;;
510 esac
511 done
350 else 512 else
351 # Call base_src_unpack, which unpacks and patches 513 # For EAPI >= 3, we can just use unpack() directly
352 # step by step transparently as defined in the ebuild. 514 unpack ${A}
353 base_src_unpack $*
354 fi 515 fi
516}
355 517
356 # Updated cmake dir 518# @FUNCTION: kde4-base_src_prepare
357 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then 519# @DESCRIPTION:
358 ebegin "Updating cmake/ directory..." 520# General pre-configure and pre-compile function for KDE4 applications.
359 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory" 521# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
360 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory" 522# enable_selected_linguas() and enable_selected_doc_linguas()
361 eend 0 523# in kde4-functions.eclass(5) for further details.
524kde4-base_src_prepare() {
525 debug-print-function ${FUNCNAME} "$@"
526
527 # Only enable selected languages, used for KDE extragear apps.
528 if [[ -n ${KDE_LINGUAS} ]]; then
529 enable_selected_linguas
362 fi 530 fi
531
532 # Enable/disable handbooks for kde4-base packages
533 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
534 # kdelibs inherits kde4-base but handle installing the handbook itself
535 if ! has kde4-meta ${INHERITED}; then
536 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
537 fi
538
539 [[ ${BUILD_TYPE} = live ]] && subversion_src_prepare
540
541 # Apply patches
542 base_src_prepare
543 epatch_user
544
545 # Save library dependencies
546 if [[ -n ${KMSAVELIBS} ]] ; then
547 save_library_dependencies
548 fi
549
550 # Inject library dependencies
551 if [[ -n ${KMLOADLIBS} ]] ; then
552 load_library_dependencies
553 fi
554}
555
556# @FUNCTION: kde4-base_src_configure
557# @DESCRIPTION:
558# Function for configuring the build of KDE4 applications.
559kde4-base_src_configure() {
560 debug-print-function ${FUNCNAME} "$@"
561
562 # Build tests in src_test only, where we override this value
563 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
564
565 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
566 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
567 fi
568
569 if has debug ${IUSE//+} && use debug; then
570 # Set "real" debug mode
571 CMAKE_BUILD_TYPE="Debugfull"
572 else
573 # Handle common release builds
574 append-cppflags -DQT_NO_DEBUG
575 fi
576
577 # Set distribution name
578 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
579
580 # Here we set the install prefix
581 cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
582
583 # Use colors
584 QTEST_COLORED=1
585
586 # Shadow existing /usr installations
587 unset KDEDIRS
588
589 # Handle kdeprefix-ed KDE
590 if [[ ${KDEDIR} != /usr ]]; then
591 # Override some environment variables - only when kdeprefix is different,
592 # to not break ccache/distcc
593 PATH="${EKDEDIR}/bin:${PATH}"
594 LDPATH="${EKDEDIR}/$(get_libdir)${LDPATH+:}${LDPATH}"
595
596 # Append full RPATH
597 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
598
599 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
600 # when more are present
601 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
602 fi
603
604 # Handle kdeprefix in application itself
605 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
606 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
607 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
608 fi
609
610 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
611 mycmakeargs=(${mycmakeargs})
612 fi
613
614 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
615
616 cmake-utils_src_configure
363} 617}
364 618
365# @FUNCTION: kde4-base_src_compile 619# @FUNCTION: kde4-base_src_compile
366# @DESCRIPTION: 620# @DESCRIPTION:
367# General function for compiling KDE4 applications. 621# General function for compiling KDE4 applications.
368kde4-base_src_compile() { 622kde4-base_src_compile() {
369 debug-print-function ${FUNCNAME} "$@" 623 debug-print-function ${FUNCNAME} "$@"
370 624
371 kde4-base_src_configure
372 kde4-base_src_make
373}
374
375# @FUNCTION: kde4-base_src_configure
376# @DESCRIPTION:
377# Function for configuring the build of KDE4 applications.
378kde4-base_src_configure() {
379 debug-print-function ${FUNCNAME} "$@"
380
381 # Final flag handling
382 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
383 echo "Activating enable-final flag"
384 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
385 fi
386
387 # Enable generation of HTML handbook
388 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
389 echo "Enabling building of HTML handbook"
390 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
391 fi
392
393 # Build tests in src_test only, where we override this value
394 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
395
396 # Set distribution name
397 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
398
399 # runpath linking
400 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
401
402 # Here we set the install prefix
403 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
404
405 # Set environment
406 QTEST_COLORED=1
407 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
408
409 cmake-utils_src_configureout
410}
411
412# @FUNCTION: kde4-base_src_make
413# @DESCRIPTION:
414# Function for building KDE4 applications.
415# Options are passed to cmake-utils_src_make.
416kde4-base_src_make() {
417 debug-print-function ${FUNCNAME} "$@"
418
419 cmake-utils_src_make "$@" 625 cmake-utils_src_compile "$@"
420} 626}
421 627
422# @FUNCTION: kde4-base_src_test 628# @FUNCTION: kde4-base_src_test
423# @DESCRIPTION: 629# @DESCRIPTION:
424# Function for testing KDE4 applications. 630# Function for testing KDE4 applications.
425kde4-base_src_test() { 631kde4-base_src_test() {
426 debug-print-function ${FUNCNAME} "$@" 632 debug-print-function ${FUNCNAME} "$@"
427 633
428 # Override this value, set in kde4-base_src_configure() 634 # Override this value, set in kde4-base_src_configure()
429 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 635 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
430 cmake-utils_src_compile 636 cmake-utils_src_configure
637 kde4-base_src_compile
431 638
432 cmake-utils_src_test 639 cmake-utils_src_test
433} 640}
434 641
435# @FUNCTION: kde4-base_src_install 642# @FUNCTION: kde4-base_src_install
436# @DESCRIPTION: 643# @DESCRIPTION:
437# Function for installing KDE4 applications. 644# Function for installing KDE4 applications.
438kde4-base_src_install() { 645kde4-base_src_install() {
439 debug-print-function ${FUNCNAME} "$@" 646 debug-print-function ${FUNCNAME} "$@"
440 647
648 # Prefix support, for usage in ebuilds
649 if [[ ${EAPI} == 2 ]] && ! use prefix; then
650 ED=${D}
651 fi
652
653 if [[ -n ${KMSAVELIBS} ]] ; then
654 install_library_dependencies
655 fi
656
441 kde4-base_src_make_doc 657 kde4-base_src_make_doc
442 cmake-utils_src_install 658 cmake-utils_src_install
443} 659}
444 660
445# @FUNCTION: kde4-base_src_make_doc 661# @FUNCTION: kde4-base_src_make_doc
448kde4-base_src_make_doc() { 664kde4-base_src_make_doc() {
449 debug-print-function ${FUNCNAME} "$@" 665 debug-print-function ${FUNCNAME} "$@"
450 666
451 local doc 667 local doc
452 for doc in AUTHORS ChangeLog* README* NEWS TODO; do 668 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
453 [[ -s $doc ]] && dodoc ${doc} 669 [[ -s ${doc} ]] && dodoc ${doc}
454 done 670 done
455 671
456 if [[ -z ${KMNAME} ]]; then 672 if [[ -z ${KMNAME} ]]; then
457 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do 673 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
458 if [[ -s $doc ]]; then 674 if [[ -s ${doc} ]]; then
459 local doc_complete=${doc} 675 local doc_complete=${doc}
460 doc="${doc#*/}" 676 doc="${doc#*/}"
461 newdoc "$doc_complete" "${doc%/*}.${doc##*/}" 677 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
462 fi 678 fi
463 done 679 done
464 fi 680 fi
465
466 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
467 # work around bug #97196
468 dodir /usr/share/doc/kde && \
469 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
470 die "Failed to move docs to kde/ failed."
471 fi
472} 681}
473 682
474# @FUNCTION: kde4-base_pkg_postinst 683# @FUNCTION: kde4-base_pkg_postinst
475# @DESCRIPTION: 684# @DESCRIPTION:
476# Function to rebuild the KDE System Configuration Cache after an application has been installed. 685# Function to rebuild the KDE System Configuration Cache after an application has been installed.
477kde4-base_pkg_postinst() { 686kde4-base_pkg_postinst() {
687 debug-print-function ${FUNCNAME} "$@"
688
478 buildsycoca 689 buildsycoca
690
691 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
692 echo
693 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
694 einfo "Use it at your own risk."
695 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
696 echo
697 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
698 # warning about kdeprefix for non-live users
699 echo
700 ewarn "WARNING! You have the kdeprefix useflag enabled."
701 ewarn "This setting is strongly discouraged and might lead to potential trouble"
702 ewarn "with KDE update strategies."
703 ewarn "You are using this setup at your own risk and the kde team does not"
704 ewarn "take responsibilities for dead kittens."
705 echo
706 fi
707 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
708 # warn about not supported approach
709 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
710 echo
711 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
712 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
713 ewarn "With this setting you are unsupported by KDE team."
714 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
715 fi
716 fi
479} 717}
480 718
481# @FUNCTION: kde4-base_pkg_postrm 719# @FUNCTION: kde4-base_pkg_postrm
482# @DESCRIPTION: 720# @DESCRIPTION:
483# Function to rebuild the KDE System Configuration Cache after an application has been removed. 721# Function to rebuild the KDE System Configuration Cache after an application has been removed.
484kde4-base_pkg_postrm() { 722kde4-base_pkg_postrm() {
723 debug-print-function ${FUNCNAME} "$@"
724
485 buildsycoca 725 buildsycoca
486} 726}

Legend:
Removed from v.1.6  
changed lines
  Added in v.1.59

  ViewVC Help
Powered by ViewVC 1.1.20