/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.6 Revision 1.87
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.6 2008/03/26 20:39:05 zlin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.87 2011/04/06 14:22:14 scarabeus Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# over time as new EAPI versions are approved.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual}
17 22
23inherit kde4-functions fdo-mime gnome2-utils base virtualx versionator eutils
24
25if [[ ${BUILD_TYPE} = live ]]; then
26 case ${KDE_SCM} in
27 svn) inherit subversion ;;
28 git) inherit git ;;
29 esac
30fi
31
32# @ECLASS-VARIABLE: CMAKE_REQUIRED
33# @DESCRIPTION:
34# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
35# Please note that if it's set to 'never' you need to explicitly override following phases:
36# src_configure, src_compile, src_test and src_install.
37# Defaults to 'always'.
38: ${CMAKE_REQUIRED:=always}
39if [[ ${CMAKE_REQUIRED} = always ]]; then
40 buildsystem_eclass="cmake-utils"
41 export_fns="src_configure src_compile src_test src_install"
42fi
43
44# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
45if [[ -n ${KDE_MINIMAL} ]]; then
46 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
47 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
48 done
49 unset slot
50 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
51else
52 KDE_MINIMAL_VALID=1
53fi
54
55# @ECLASS-VARIABLE: KDE_MINIMAL
56# @DESCRIPTION:
57# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
58# version for apps to work. Currently defaults to 4.4
59# One may override this variable to raise version requirements.
60# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
61# Note that it is fixed to ${SLOT} for kde-base packages.
62KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
63
64# Set slot for KDEBASE known packages
65case ${KDEBASE} in
66 kde-base)
67 SLOT=$(_calculate_kde_slot)
68 [[ -z ${SLOT} ]] && die "Unsupported ${PV}"
69 KDE_MINIMAL="${SLOT}"
70 ;;
71 koffice)
72 SLOT="2"
73 ;;
74 kdevelop)
75 if [[ ${BUILD_TYPE} = live ]]; then
76 # @ECLASS-VARIABLE: KDEVELOP_VERSION
77 # @DESCRIPTION:
78 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
79 # Applies to KDEBASE=kdevelop only.
80 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
81 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
82 # @DESCRIPTION:
83 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
84 # Applies to KDEBASE=kdevelop only.
85 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
86 else
87 case ${PN} in
88 kdevelop|quanta)
89 KDEVELOP_VERSION=${PV}
90 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
91 ;;
92 kdevplatform)
93 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
94 KDEVPLATFORM_VERSION=${PV}
95 ;;
96 *)
97 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
98 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
99 esac
100 fi
101 SLOT="4"
102 ;;
103esac
104
105inherit ${buildsystem_eclass}
106
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 107EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
19 108
20COMMONDEPEND="|| ( ( 109unset buildsystem_eclass
21 x11-libs/qt-core:4 110unset export_fns
22 x11-libs/qt-gui:4 111
23 x11-libs/qt-qt3support:4 112# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
24 x11-libs/qt-svg:4 113# @DESCRIPTION:
25 x11-libs/qt-test:4 ) 114# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
26 >=x11-libs/qt-4.3.3:4 )" 115# This variable must be set before inheriting any eclasses. Defaults to 'never'.
116DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
117
118# @ECLASS-VARIABLE: QTHELP_REQUIRED
119# @DESCRIPTION:
120# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
121# This variable must be set before inheriting any eclasses. Defaults to 'never'.
122QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
27 123
28# @ECLASS-VARIABLE: OPENGL_REQUIRED 124# @ECLASS-VARIABLE: OPENGL_REQUIRED
29# @DESCRIPTION: 125# @DESCRIPTION:
30# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 126# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
31# This variable must be set before inheriting any eclasses. Defaults to 'never'. 127# This variable must be set before inheriting any eclasses. Defaults to 'never'.
32OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 128OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
33 129
34OPENGLDEPEND="|| ( x11-libs/qt-opengl:4 130# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
35 >=x11-libs/qt-4.3.3:4 )" 131# @DESCRIPTION:
36case "${OPENGL_REQUIRED}" in 132# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
37 always) 133# This variable must be set before inheriting any eclasses. Defaults to 'never'.
38 COMMONDEPEND="${COMMONDEPEND} 134MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
39 ${OPENGLDEPEND}"
40 ;;
41 optional)
42 IUSE="${IUSE} opengl"
43 COMMONDEPEND="${COMMONDEPEND}
44 opengl? ( ${OPENGLDEPEND} )"
45 ;;
46 *)
47 OPENGL_REQUIRED="never"
48 ;;
49esac
50 135
51DEPEND="${DEPEND} ${COMMONDEPEND} 136# @ECLASS-VARIABLE: WEBKIT_REQUIRED
52 >=dev-util/cmake-2.4.7-r1 137# @DESCRIPTION:
53 dev-util/pkgconfig 138# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
54 x11-libs/libXt 139# This variable must be set before inheriting any eclasses. Defaults to 'never'.
55 x11-proto/xf86vidmodeproto" 140WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
56RDEPEND="${RDEPEND} ${COMMONDEPEND}"
57 141
58# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 142# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
59# @DESCRIPTION: 143# @DESCRIPTION:
60# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 144# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
61# This variable must be set before inheriting any eclasses. Defaults to 'never'. 145# This variable must be set before inheriting any eclasses. Defaults to 'never'.
62CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 146CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
63 147
64case "${CPPUNIT_REQUIRED}" in 148# @ECLASS-VARIABLE: KDE_REQUIRED
149# @DESCRIPTION:
150# Is kde required? Possible values are 'always', 'optional' and 'never'.
151# This variable must be set before inheriting any eclasses. Defaults to 'always'
152# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
153# Note that for kde-base packages this variable is fixed to 'always'.
154KDE_REQUIRED="${KDE_REQUIRED:-always}"
155
156# @ECLASS-VARIABLE: KDE_HANDBOOK
157# @DESCRIPTION:
158# Set to enable handbook in application. Possible values are 'always', 'optional'
159# (handbook USE flag) and 'never'.
160# This variable must be set before inheriting any eclasses. Defaults to 'never'.
161# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
162# ensures buildtime and runtime dependencies.
163KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
164
165# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
166# @DESCRIPTION:
167# Set this varible if you want your live package to manage its
168# translations. (Mostly all kde ebuilds does not ship documentation
169# and translations in live ebuilds)
170if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} && ${KDEBASE} != "kde-base" ]]; then
171 KDE_HANDBOOK=never
172 KDE_LINGUAS=""
173fi
174
175# Setup packages inheriting this eclass
176case ${KDEBASE} in
177 kde-base)
178 HOMEPAGE="http://www.kde.org/"
179 LICENSE="GPL-2"
180 if [[ $BUILD_TYPE = live ]]; then
181 # Disable tests for live ebuilds
182 RESTRICT+=" test"
183 # Live ebuilds in kde-base default to kdeprefix by default
184 IUSE+=" +kdeprefix"
185 else
186 # All other ebuild types default to -kdeprefix as before
187 IUSE+=" kdeprefix"
188 fi
189 # This code is to prevent portage from searching GENTOO_MIRRORS for
190 # packages that will never be mirrored. (As they only will ever be in
191 # the overlay).
192 case ${PV} in
193 *9999* | 4.?.[6-9]?)
194 RESTRICT+=" mirror"
195 ;;
196 esac
197 # Block installation of other SLOTS unless kdeprefix
198 RDEPEND+=" $(block_other_slots)"
199 ;;
200 koffice)
201 HOMEPAGE="http://www.koffice.org/"
202 LICENSE="GPL-2"
203 ;;
204 kdevelop)
205 HOMEPAGE="http://www.kdevelop.org/"
206 LICENSE="GPL-2"
207 ;;
208esac
209
210# @ECLASS-VARIABLE: QT_MINIMAL
211# @DESCRIPTION:
212# Determine version of qt we enforce as minimal for the package.
213if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
214 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
215else
216 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
217fi
218
219# Declarative dependencies
220qtdeclarativedepend="
221 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
222"
223case ${DECLARATIVE_REQUIRED} in
65 always) 224 always)
66 DEPEND="${DEPEND} dev-util/cppunit" 225 COMMONDEPEND+=" ${qtdeclarativedepend}"
67 ;; 226 ;;
68 optional) 227 optional)
69 IUSE="${IUSE} test" 228 IUSE+=" declarative"
70 DEPEND="${DEPEND} 229 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
71 test? ( dev-util/cppunit )"
72 ;; 230 ;;
73 *) 231 *) ;;
74 CPPUNIT_REQUIRED="never" 232esac
233unset qtdeclarativedepend
234
235# QtHelp dependencies
236qthelpdepend="
237 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
238"
239case ${QTHELP_REQUIRED} in
240 always)
241 COMMONDEPEND+=" ${qthelpdepend}"
75 ;; 242 ;;
243 optional)
244 IUSE+=" qthelp"
245 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
246 ;;
76esac 247esac
248unset qthelpdepend
77 249
78# @ECLASS-VARIABLE: NEED_KDE 250# OpenGL dependencies
251qtopengldepend="
252 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
253"
254case ${OPENGL_REQUIRED} in
255 always)
256 COMMONDEPEND+=" ${qtopengldepend}"
257 ;;
258 optional)
259 IUSE+=" opengl"
260 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
261 ;;
262 *) ;;
263esac
264unset qtopengldepend
265
266# MultiMedia dependencies
267qtmultimediadepend="
268 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
269"
270case ${MULTIMEDIA_REQUIRED} in
271 always)
272 COMMONDEPEND+=" ${qtmultimediadepend}"
273 ;;
274 optional)
275 IUSE+=" multimedia"
276 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
277 ;;
278 *) ;;
279esac
280unset qtmultimediadepend
281
282# WebKit dependencies
283case ${KDE_REQUIRED} in
284 always)
285 qtwebkitusedeps="[kde]"
286 ;;
287 optional)
288 qtwebkitusedeps="[kde?]"
289 ;;
290 *) ;;
291esac
292qtwebkitdepend="
293 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
294"
295unset qtwebkitusedeps
296case ${WEBKIT_REQUIRED} in
297 always)
298 COMMONDEPEND+=" ${qtwebkitdepend}"
299 ;;
300 optional)
301 IUSE+=" webkit"
302 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
303 ;;
304 *) ;;
305esac
306unset qtwebkitdepend
307
308# CppUnit dependencies
309cppuintdepend="
310 dev-util/cppunit
311"
312case ${CPPUNIT_REQUIRED} in
313 always)
314 DEPEND+=" ${cppuintdepend}"
315 ;;
316 optional)
317 IUSE+=" test"
318 DEPEND+=" test? ( ${cppuintdepend} )"
319 ;;
320 *) ;;
321esac
322unset cppuintdepend
323
324# KDE dependencies
325# Qt accessibility classes are needed in various places, bug 325461
326kdecommondepend="
327 dev-lang/perl
328 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
329 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
330 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
331 >=x11-libs/qt-script-${QT_MINIMAL}:4
332 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
333 >=x11-libs/qt-svg-${QT_MINIMAL}:4
334 >=x11-libs/qt-test-${QT_MINIMAL}:4
335 !aqua? (
336 x11-libs/libXext
337 x11-libs/libXt
338 x11-libs/libXxf86vm
339 )
340"
341
342if [[ ${PN} != kdelibs ]]; then
343 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
344 if [[ ${KDEBASE} = kdevelop ]]; then
345 if [[ ${PN} != kdevplatform ]]; then
346 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
79# @DESCRIPTION: 347 # @DESCRIPTION:
80# This variable sets the version of KDE4 which will be used by the eclass. 348 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
81# This variable must be set by the ebuild, for all categories except for "kde-base". 349 # Applies to KDEBASE=kdevelop only.
82# For kde-base packages, if it is not set by the ebuild, 350 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
83# it's assumed that the required KDE4 version is the latest, non-live, available. 351 case ${KDEVPLATFORM_REQUIRED} in
84# 352 always)
85# @CODE 353 kdecommondepend+="
86# Acceptable values are: 354 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
87# - latest - Use latest version in the portage tree 355 "
88# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 356 ;;
89# - svn - Use svn release (live ebuilds) 357 *) ;;
90# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value. 358 esac
91# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value. 359 fi
92# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
93# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
94# @CODE
95#
96# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
97# koffice, so you must set it explicitly in the ebuild, in all other cases.
98if [[ -z ${NEED_KDE} ]]; then
99 if [[ -n ${KDEBASE} ]]; then
100 NEED_KDE="latest"
101 else
102 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
103 fi 360 fi
104fi 361fi
105export NEED_KDE
106 362
107case ${NEED_KDE} in 363kdedepend="
108 latest) 364 dev-util/automoc
109 # Should only be used by 'kde-base'-ebuilds 365 dev-util/pkgconfig
110 if [[ "${KDEBASE}" == "kde-base" ]]; then 366 !aqua? (
111 case ${PV} in 367 >=x11-libs/libXtst-1.1.0
112 3.9*) _kdedir="3.9" ;; 368 x11-proto/xf86vidmodeproto
113 4*) _kdedir="4.0" ;; 369 )
114 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 370"
115 esac
116 _operator=">="
117 _pv="-${PV}:kde-4"
118 else
119 _kdedir="4.0"
120 _pv=":kde-4"
121 fi
122 ;;
123 svn|9999*|:kde-svn)
124 _kdedir="svn"
125 _pv=":kde-svn"
126 export NEED_KDE="svn"
127 ;;
128 *:kde-svn)
129 _kdedir="svn"
130 _operator=">="
131 _pv="-${NEED_KDE}"
132 export NEED_KDE="svn"
133 ;;
134 # The ebuild handles dependencies, KDEDIR, SLOT.
135 none)
136 :
137 ;;
138 # NEED_KDE=":${SLOT}"
139 :kde-4)
140 _kdedir="4.0"
141 _pv="${NEED_KDE}"
142 ;;
143 # NEED_KDE="${PV}:${SLOT}"
144 *:kde-4)
145 _kdedir="4.0"
146 _operator=">="
147 _pv="-${NEED_KDE}"
148 ;;
149 3.9*)
150 _kdedir="3.9"
151 _operator=">="
152 _pv="-${NEED_KDE}:kde-4"
153 ;;
154 4*)
155 _kdedir="4.0"
156 _operator=">="
157 _pv="-${NEED_KDE}:kde-4"
158 ;;
159 *) die "NEED_KDE=${NEED_KDE} currently not supported."
160 ;;
161esac
162 371
163if [[ ${NEED_KDE} != none ]]; then 372kderdepend=""
164 KDEDIR="/usr/kde/${_kdedir}"
165 KDEDIRS="/usr:/usr/local:${KDEDIR}"
166 373
167 if [[ -n ${KDEBASE} ]]; then 374# all packages needs oxygen icons for basic iconset
168 if [[ ${NEED_KDE} = svn ]]; then
169 SLOT="kde-svn"
170 else
171 SLOT="kde-4"
172 fi
173 fi
174
175 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs"
176 if [[ ${PN} != "kdelibs" ]]; then 375if [[ ${PN} != oxygen-icons ]]; then
177 DEPEND="${DEPEND} 376 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
178 ${_operator}kde-base/kdelibs${_pv}"
179 RDEPEND="${RDEPEND}
180 ${_operator}kde-base/kdelibs${_pv}"
181 if [[ ${PN} != "kdepimlibs" ]]; then
182 DEPEND="${DEPEND}
183 ${_operator}kde-base/kdepimlibs${_pv}"
184 RDEPEND="${RDEPEND}
185 ${_operator}kde-base/kdepimlibs${_pv}"
186 fi
187 fi
188
189 unset _operator _pv _kdedir
190fi 377fi
378
379# add a dependency over kde-l10n if EAPI4 is around
380if [[ ${KDEBASE} != "kde-base" ]] && [[ -n ${KDE_LINGUAS} ]] && has "${EAPI:-0}" 4; then
381 usedep=''
382 for _lingua in ${KDE_LINGUAS}; do
383 [[ -n ${usedep} ]] && usedep+=","
384 usedep+="linguas_${_lingua}(+)?"
385 done
386 # if our package has lignuas pull in kde-l10n with selected lingua
387 kderdepend+=" $(add_kdebase_dep kde-l10n ${usedep})"
388 unset usedep _lingua
389fi
390
391kdehandbookdepend="
392 app-text/docbook-xml-dtd:4.2
393 app-text/docbook-xsl-stylesheets
394"
395kdehandbookrdepend="
396 $(add_kdebase_dep kdelibs 'handbook')
397"
398case ${KDE_HANDBOOK} in
399 always)
400 kdedepend+=" ${kdehandbookdepend}"
401 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
402 ;;
403 optional)
404 IUSE+=" +handbook"
405 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
406 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
407 ;;
408 *) ;;
409esac
410unset kdehandbookdepend kdehandbookrdepend
411
412case ${KDE_REQUIRED} in
413 always)
414 IUSE+=" aqua"
415 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
416 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
417 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
418 ;;
419 optional)
420 IUSE+=" aqua kde"
421 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
422 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
423 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
424 ;;
425 *) ;;
426esac
427
428unset kdecommondepend kdedepend kderdepend
429
430debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
431debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
432debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
433
434# Accumulate dependencies set by this eclass
435DEPEND+=" ${COMMONDEPEND}"
436RDEPEND+=" ${COMMONDEPEND}"
437unset COMMONDEPEND
438
439# Add experimental kdeenablefinal, masked by default
440IUSE+=" kdeenablefinal"
191 441
192# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 442# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
193# koffice ebuild, the URI should be set in the ebuild itself 443# koffice ebuild, the URI should be set in the ebuild itself
194if [[ -n ${KDEBASE} ]]; then 444_calculate_src_uri() {
445 debug-print-function ${FUNCNAME} "$@"
446
447 local _kmname _kmname_pv
448
449 # we calculate URI only for known KDEBASE modules
450 [[ -n ${KDEBASE} ]] || return
451
452 # calculate tarball module name
195 if [[ -n ${KMNAME} ]]; then 453 if [[ -n ${KMNAME} ]]; then
454 # fixup kdebase-apps name
455 case ${KMNAME} in
456 kdebase-apps)
457 _kmname="kdebase" ;;
458 *)
196 _kmname=${KMNAME} 459 _kmname="${KMNAME}" ;;
460 esac
197 else 461 else
198 _kmname=${PN} 462 _kmname=${PN}
199 fi 463 fi
200 _kmname_pv="${_kmname}-${PV}" 464 _kmname_pv="${_kmname}-${PV}"
201 if [[ ${NEED_KDE} != "svn" ]]; then
202 case ${KDEBASE} in 465 case ${KDEBASE} in
203 kde-base) 466 kde-base)
204 case ${PV} in 467 case ${PV} in
468 4.[456].8[05] | 4.[456].9[023568] | 4.5.94.1)
469 # Unstable KDE SC releases
470 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
471 # KDEPIM IS SPECIAL
472 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/src/${_kmname_pv}.tar.bz2"
473 ;;
474 4.4.[6789] | 4.4.1?)
475 # Stable kdepim releases
476 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
477 ;;
478 *)
479 # Stable KDE SC releases
205 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 480 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
481 ;;
206 esac 482 esac
207 ;; 483 ;;
208 koffice) 484 koffice)
485 case ${PV} in
486 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
209 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" 487 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
488 esac
210 ;; 489 ;;
490 kdevelop)
491 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
492 ;;
493 esac
494}
495
496_calculate_live_repo() {
497 debug-print-function ${FUNCNAME} "$@"
498
499 SRC_URI=""
500 case ${KDE_SCM} in
501 svn)
502 # Determine branch URL based on live type
503 local branch_prefix
504 case ${PV} in
505 9999*)
506 # trunk
507 branch_prefix="trunk/KDE"
508 ;;
509 *)
510 # branch
511 branch_prefix="branches/KDE/${SLOT}"
512 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
513 # @DESCRIPTION
514 # Suffix appended to ESVN_PROJECT depending on fetched branch.
515 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
516 ESVN_PROJECT_SUFFIX="-${PV}"
517 ;;
518 esac
519 # @ECLASS-VARIABLE: ESVN_MIRROR
520 # @DESCRIPTION:
521 # This variable allows easy overriding of default kde mirror service
522 # (anonsvn) with anything else you might want to use.
523 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
524 # Split ebuild, or extragear stuff
525 if [[ -n ${KMNAME} ]]; then
526 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
527 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
528 KMMODULE="${PN}"
529 fi
530 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
531 case ${KMNAME} in
532 kdebase-*)
533 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
534 ;;
535 kdelibs-*)
536 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
537 ;;
538 kdereview*)
539 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
540 ;;
541 kdesupport)
542 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
543 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
544 ;;
545 kde*)
546 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
547 ;;
548 extragear*|playground*)
549 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
550 # build packages from same svn location.
551 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
552 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
553 ;;
554 koffice)
555 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
556 ;;
557 *)
558 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
559 ;;
560 esac
561 else
562 # kdelibs, kdepimlibs
563 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
564 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
565 fi
566 # @ECLASS-VARIABLE: ESVN_UP_FREQ
567 # @DESCRIPTION:
568 # This variable is used for specifying the timeout between svn synces
569 # for kde-base and koffice modules. Does not affect misc apps.
570 # Default value is 1 hour.
571 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
572 ;;
573 git)
574 local _kmname
575 # @ECLASS-VARIABLE: EGIT_MIRROR
576 # @DESCRIPTION:
577 # This variable allows easy overriding of default kde mirror service
578 # (anongit) with anything else you might want to use.
579 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
580
581 # @ECLASS-VARIABLE: EGIT_REPONAME
582 # @DESCRIPTION:
583 # This variable allows overriding of default repository
584 # name. Specify only if this differ from PN and KMNAME.
585 if [[ -n ${EGIT_REPONAME} ]]; then
586 # the repository and kmname different
587 _kmname=${EGIT_REPONAME}
588 elif [[ -n ${KMNAME} ]]; then
589 _kmname=${KMNAME}
590 else
591 _kmname=${PN}
592 fi
593
594 # default branching
595 case ${PV} in
596 9999*) ;;
597 *)
598 # set EGIT_BRANCH and EGIT_COMMIT to ${SLOT}
599 case ${_kmname} in
600 kdeplasma-addons | kdepim | kdepim-runtime | kdepimlibs)
601 EGIT_BRANCH="${SLOT}"
602 ;;
603 *) EGIT_BRANCH="KDE/${SLOT}" ;;
604 esac
605 ;;
606 esac
607
608 case $_kmname in
609 kdepim|kdepim-runtime)
610 case ${PV} in
611 # kdepim still did not branch
612 4.6.9999)
613 EGIT_BRANCH="master"
614 ;;
615 esac
616 ;;
617 esac
618 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
619 EGIT_PROJECT="${_kmname}"
620
621 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
622 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
623 ;;
624 esac
625}
626
627case ${BUILD_TYPE} in
628 live) _calculate_live_repo ;;
629 *) _calculate_src_uri ;;
630esac
631
632debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
633
634# @ECLASS-VARIABLE: PREFIX
635# @DESCRIPTION:
636# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
637# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
638# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
639
640# @FUNCTION: kde4-base_pkg_setup
641# @DESCRIPTION:
642# Do the basic kdeprefix KDEDIR settings and determine with which kde should
643# optional applications link
644kde4-base_pkg_setup() {
645 debug-print-function ${FUNCNAME} "$@"
646
647 # QA ebuilds
648 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
649
650 # Don't set KDEHOME during compilation, it will cause access violations
651 unset KDEHOME
652
653 if [[ ${KDEBASE} = kde-base ]]; then
654 if use kdeprefix; then
655 KDEDIR=/usr/kde/${SLOT}
656 else
657 KDEDIR=/usr
658 fi
659 : ${PREFIX:=${KDEDIR}}
660 else
661 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
662 KDEDIR=
663 local kde_minimal_met
664 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
665 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
666 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
667 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
668 KDEDIR=/usr/kde/${slot}
669 else
670 KDEDIR=/usr
671 fi
672 break;
673 fi
674 done
675 unset slot
676
677 # Bail out if kdelibs required but not found
678 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
679 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
680 else
681 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
682 fi
683
684 : ${PREFIX:=/usr}
685 fi
686 EKDEDIR=${EPREFIX}${KDEDIR}
687
688 # Point pkg-config path to KDE *.pc files
689 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
690 # Point to correct QT plugins path
691 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
692
693 # Fix XDG collision with sandbox
694 export XDG_CONFIG_HOME="${T}"
695}
696
697# @FUNCTION: kde4-base_src_unpack
698# @DESCRIPTION:
699# This function unpacks the source tarballs for KDE4 applications.
700kde4-base_src_unpack() {
701 debug-print-function ${FUNCNAME} "$@"
702
703 if [[ ${BUILD_TYPE} = live ]]; then
704 case ${KDE_SCM} in
705 svn)
706 migrate_store_dir
707 subversion_src_unpack
708 ;;
709 git)
710 git_src_unpack
711 ;;
211 esac 712 esac
212 fi
213 unset _kmname _kmname_pv
214fi
215
216debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
217debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
218
219# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
220# If KMNAME is not set then this is not a split package
221if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
222 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
223 DEPEND="${DEPEND} !${_x}:${SLOT}"
224 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
225 done
226 unset _x
227fi
228
229debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
230
231# @ECLASS-VARIABLE: PREFIX
232# @DESCRIPTION:
233# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
234# Applications installed by the other ebuilds go into /usr/ by default, this value
235# can be superseded by defining PREFIX before inheriting kde4-base.
236if [[ -n ${KDEBASE} ]]; then
237 PREFIX=${KDEDIR}
238else
239 # if PREFIX is not defined we set it to the default value of /usr
240 PREFIX="${PREFIX:-/usr}"
241fi
242
243debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
244
245# @FUNCTION: kde4-base_pkg_setup
246# @DESCRIPTION:
247# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
248# kde4-functions_check_use from kde4-functions.eclass to print appropriate
249# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
250# $KDE4_BUILT_WITH_USE_CHECK are missing.
251kde4-base_pkg_setup() {
252 debug-print-function $FUNCNAME "$@"
253
254 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
255 if has_version '<x11-libs/qt-4.4_alpha:4'; then
256 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
257 else 713 else
258 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 714 unpack ${A}
259 x11-libs/qt-core qt3support ssl 715 fi
260 x11-libs/qt-gui accessibility dbus 716}
261 x11-libs/qt-qt3support accessibility" 717
718# @FUNCTION: kde4-base_src_prepare
719# @DESCRIPTION:
720# General pre-configure and pre-compile function for KDE4 applications.
721# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
722# enable_selected_linguas() and enable_selected_doc_linguas()
723# in kde4-functions.eclass(5) for further details.
724kde4-base_src_prepare() {
725 debug-print-function ${FUNCNAME} "$@"
726
727 # enable handbook and linguas only when not using live ebuild
728
729 # Only enable selected languages, used for KDE extragear apps.
730 if [[ -n ${KDE_LINGUAS} ]]; then
731 enable_selected_linguas
732 fi
733
734 # Enable/disable handbooks for kde4-base packages
735 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
736 # kdelibs inherits kde4-base but handle installing the handbook itself
737 if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then
738 if [[ ${KDEBASE} == kde-base ]]; then
739 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
740 # documentation in kde4-functions
741 : ${KDE_DOC_DIRS:=doc}
742 local dir
743 for dir in ${KDE_DOC_DIRS}; do
744 sed -e "/^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)/s/^/#DONOTCOMPILE /" \
745 -e "/^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)/s/^/#DONOTCOMPILE /" \
746 -e "/^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)/s/^/#DONOTCOMPILE /" \
747 -e "/^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)/s/^/#DONOTCOMPILE /" \
748 -i CMakeLists.txt || die "failed to comment out handbook"
749 done
750 fi
751 else
752 enable_selected_doc_linguas
753 fi
754 fi
755
756 # SCM bootstrap
757 if [[ ${BUILD_TYPE} = live ]]; then
758 case ${KDE_SCM} in
759 svn) subversion_src_prepare ;;
760 esac
761 fi
762
763 # Apply patches
764 base_src_prepare
765
766 # Save library dependencies
767 if [[ -n ${KMSAVELIBS} ]] ; then
768 save_library_dependencies
769 fi
770
771 # Inject library dependencies
772 if [[ -n ${KMLOADLIBS} ]] ; then
773 load_library_dependencies
774 fi
775
776 # Replace KDE4Workspace library targets
777 find "${S}" -name CMakeLists.txt \
778 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
779 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
780 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
781 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
782 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
783 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
784 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
785 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
786 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
787 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
788 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
789 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
790 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
791 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
792 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
793 || die 'failed to replace KDE4Workspace library targets'
794
795 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
796 if [[ -z ${KDEBASE} ]]; then
797 find "${S}" -name "*.docbook" \
798 -exec sed -i -r \
799 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
800 || die 'failed to fix DocBook variant version'
801 fi
802}
803
804# @FUNCTION: kde4-base_src_configure
805# @DESCRIPTION:
806# Function for configuring the build of KDE4 applications.
807kde4-base_src_configure() {
808 debug-print-function ${FUNCNAME} "$@"
809
810 # Build tests in src_test only, where we override this value
811 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
812
813 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
814 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
262 fi 815 fi
263 816
264 if has debug ${IUSE//+} && use debug; then 817 if has debug ${IUSE//+} && use debug; then
265 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then 818 # Set "real" debug mode
266 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug" 819 CMAKE_BUILD_TYPE="Debugfull"
820 else
821 # Handle common release builds
822 append-cppflags -DQT_NO_DEBUG
823 fi
824
825 # Set distribution name
826 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
827
828 # Here we set the install prefix
829 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
830
831 # Use colors
832 QTEST_COLORED=1
833
834 # Shadow existing /usr installations
835 unset KDEDIRS
836
837 # Handle kdeprefix-ed KDE
838 if [[ ${KDEDIR} != /usr ]]; then
839 # Override some environment variables - only when kdeprefix is different,
840 # to not break ccache/distcc
841 PATH="${EKDEDIR}/bin:${PATH}"
842
843 # Append library search path
844 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
845
846 # Append full RPATH
847 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
848
849 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
850 # when more are present
851 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
852 fi
853
854 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
855 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
856 #kde-config -path data unavailable when cross-compiling
857 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
858
859 # Handle kdeprefix in application itself
860 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
861 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
862 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
863 fi
864
865 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
866 mycmakeargs=(${mycmakeargs})
867 fi
868
869 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
870
871 cmake-utils_src_configure
872}
873
874# @FUNCTION: kde4-base_src_compile
875# @DESCRIPTION:
876# General function for compiling KDE4 applications.
877kde4-base_src_compile() {
878 debug-print-function ${FUNCNAME} "$@"
879
880 cmake-utils_src_compile "$@"
881}
882
883# @FUNCTION: kde4-base_src_test
884# @DESCRIPTION:
885# Function for testing KDE4 applications.
886kde4-base_src_test() {
887 debug-print-function ${FUNCNAME} "$@"
888
889 # Override this value, set in kde4-base_src_configure()
890 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
891 cmake-utils_src_configure
892 kde4-base_src_compile
893
894 # When run as normal user during ebuild development with the ebuild command, the
895 # kde tests tend to access the session DBUS. This however is not possible in a real
896 # emerge or on the tinderbox.
897 # > make sure it does not happen, so bad tests can be recognized and disabled
898 unset DBUS_SESSION_BUS_ADDRESS
899
900 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
901 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
902 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
903 # surprise- we are already INSIDE virtualmake!!!
904 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
905 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
906 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
907 debug-print " kde4-base.eclass docs for details... Applying workaround."
908 cmake-utils_src_test
267 else 909 else
268 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 910 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
269 x11-libs/qt-core:4 debug 911 fi
270 x11-libs/qt-gui:4 debug 912 else
271 x11-libs/qt-qt3support:4 debug 913 cmake-utils_src_test
272 x11-libs/qt-svg:4 debug 914 fi
273 x11-libs/qt-test:4 debug" 915}
274 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then 916
275 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 917# @FUNCTION: kde4-base_src_install
276 x11-libs/qt-opengl:4 debug" 918# @DESCRIPTION:
919# Function for installing KDE4 applications.
920kde4-base_src_install() {
921 debug-print-function ${FUNCNAME} "$@"
922
923 if [[ -n ${KMSAVELIBS} ]] ; then
924 install_library_dependencies
925 fi
926
927 # Install common documentation of KDE4 applications
928 local doc
929 if ! has kde4-meta ${INHERITED}; then
930 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
931 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
932 done
933 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
934 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
935 done
936 fi
937
938 cmake-utils_src_install
939}
940
941# @FUNCTION: kde4-base_pkg_preinst
942# @DESCRIPTION:
943# Function storing icon caches
944kde4-base_pkg_preinst() {
945 debug-print-function ${FUNCNAME} "$@"
946
947 gnome2_icon_savelist
948}
949
950# @FUNCTION: kde4-base_pkg_postinst
951# @DESCRIPTION:
952# Function to rebuild the KDE System Configuration Cache after an application has been installed.
953kde4-base_pkg_postinst() {
954 debug-print-function ${FUNCNAME} "$@"
955
956 gnome2_icon_cache_update
957 fdo-mime_desktop_database_update
958 fdo-mime_mime_database_update
959 buildsycoca
960
961 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
962 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
963 echo
964 ewarn "WARNING! you have kdeenable final useflag enabled."
965 ewarn "This useflag needs to be enabled on ALL kde using packages and"
966 ewarn "is known to cause issues."
967 ewarn "You are using this setup at your own risk and the kde team does not"
968 ewarn "take responsibilities for dead kittens."
969 echo
970 fi
971 if [[ ${BUILD_TYPE} = live ]]; then
972 echo
973 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
974 einfo "Use it at your own risk."
975 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
976 echo
977 elif [[ ${BUILD_TYPE} != live ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
978 # warning about kdeprefix for non-live users
979 echo
980 ewarn "WARNING! You have the kdeprefix useflag enabled."
981 ewarn "This setting is strongly discouraged and might lead to potential trouble"
982 ewarn "with KDE update strategies."
983 ewarn "You are using this setup at your own risk and the kde team does not"
984 ewarn "take responsibilities for dead kittens."
985 echo
986 fi
987 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
988 if [[ ${KDEBASE} != kde-base ]] && \
989 ! has_version 'kde-base/kdebase-runtime-meta' && \
990 ! has_version 'kde-base/kdebase-startkde'; then
991 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
992 echo
993 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
994 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
995 ewarn "With this setting you are unsupported by KDE team."
996 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
277 fi 997 fi
278 fi 998 fi
279 fi 999 fi
280
281 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
282 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
283 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
284 fi
285 fi
286
287 kde4-functions_check_use
288}
289
290# @FUNCTION: kde4-base_apply_patches
291# @DESCRIPTION:
292# This function applies patches.
293#
294# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
295# directory, provided they follow this format:
296# @CODE
297# - Monolithic ebuilds, (from kde-base)
298# - $CATEGORY=kde-base:
299# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
300# - $CATEGORY=!kde-base:
301# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
302# - Split ebuilds:
303# - $CATEGORY=kde-base:
304# Apply ${PN}-${SLOT}-*{diff,patch}
305# - $CATEGORY!=kde-base:
306# Apply ${PN}-${PV}-*{diff,patch}
307# @CODE
308#
309# If ${PATCHES} is non-zero all patches in it gets applied.
310kde4-base_apply_patches() {
311 local _patchdir _packages _p
312 _patchdir="${WORKDIR}/patches/"
313 if [[ -d "${_patchdir}" ]]; then
314 if is-parent-package ${CATEGORY}/${PN} ; then
315 _packages="$(get-child-packages ${CATEGORY}/${PN})"
316 _packages="${_packages//${CATEGORY}\//} ${PN}"
317 else
318 _packages="${PN}"
319 fi
320 for _p in ${_packages}; do
321 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
322 if [[ -n "${KDEBASE}" ]]; then
323 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
324 fi
325 done
326 fi
327 [[ -n ${PATCHES} ]] && base_src_unpack autopatch
328}
329
330# @FUNCTION: kde4-base_src_unpack
331# @DESCRIPTION:
332# This function unpacks the source tarballs for KDE4 applications.
333#
334# If no argument is passed to this function, then standard src_unpack is
335# executed. Otherwise options are passed to base_src_unpack.
336#
337# In addition it calls kde4-base_apply_patches when no arguments are passed to
338# this function.
339kde4-base_src_unpack() {
340 debug-print-function $FUNCNAME "$@"
341
342 [[ -z "${KDE_S}" ]] && KDE_S="${S}"
343
344 if [[ -z $* ]]; then
345 # Unpack first and deal with KDE patches after examing possible patch sets.
346 # To be picked up, patches need to conform to the guidelines stated before.
347 # Monolithic ebuilds will use the split ebuild patches.
348 [[ -d "${KDE_S}" ]] || unpack ${A}
349 kde4-base_apply_patches
350 else
351 # Call base_src_unpack, which unpacks and patches
352 # step by step transparently as defined in the ebuild.
353 base_src_unpack $*
354 fi
355
356 # Updated cmake dir
357 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then
358 ebegin "Updating cmake/ directory..."
359 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory"
360 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory"
361 eend 0
362 fi
363}
364
365# @FUNCTION: kde4-base_src_compile
366# @DESCRIPTION:
367# General function for compiling KDE4 applications.
368kde4-base_src_compile() {
369 debug-print-function ${FUNCNAME} "$@"
370
371 kde4-base_src_configure
372 kde4-base_src_make
373}
374
375# @FUNCTION: kde4-base_src_configure
376# @DESCRIPTION:
377# Function for configuring the build of KDE4 applications.
378kde4-base_src_configure() {
379 debug-print-function ${FUNCNAME} "$@"
380
381 # Final flag handling
382 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
383 echo "Activating enable-final flag"
384 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
385 fi
386
387 # Enable generation of HTML handbook
388 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
389 echo "Enabling building of HTML handbook"
390 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
391 fi
392
393 # Build tests in src_test only, where we override this value
394 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
395
396 # Set distribution name
397 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
398
399 # runpath linking
400 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
401
402 # Here we set the install prefix
403 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
404
405 # Set environment
406 QTEST_COLORED=1
407 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
408
409 cmake-utils_src_configureout
410}
411
412# @FUNCTION: kde4-base_src_make
413# @DESCRIPTION:
414# Function for building KDE4 applications.
415# Options are passed to cmake-utils_src_make.
416kde4-base_src_make() {
417 debug-print-function ${FUNCNAME} "$@"
418
419 cmake-utils_src_make "$@"
420}
421
422# @FUNCTION: kde4-base_src_test
423# @DESCRIPTION:
424# Function for testing KDE4 applications.
425kde4-base_src_test() {
426 debug-print-function ${FUNCNAME} "$@"
427
428 # Override this value, set in kde4-base_src_configure()
429 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON"
430 cmake-utils_src_compile
431
432 cmake-utils_src_test
433}
434
435# @FUNCTION: kde4-base_src_install
436# @DESCRIPTION:
437# Function for installing KDE4 applications.
438kde4-base_src_install() {
439 debug-print-function ${FUNCNAME} "$@"
440
441 kde4-base_src_make_doc
442 cmake-utils_src_install
443}
444
445# @FUNCTION: kde4-base_src_make_doc
446# @DESCRIPTION:
447# Function for installing the documentation of KDE4 applications.
448kde4-base_src_make_doc() {
449 debug-print-function ${FUNCNAME} "$@"
450
451 local doc
452 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
453 [[ -s $doc ]] && dodoc ${doc}
454 done
455
456 if [[ -z ${KMNAME} ]]; then
457 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
458 if [[ -s $doc ]]; then
459 local doc_complete=${doc}
460 doc="${doc#*/}"
461 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
462 fi
463 done
464 fi
465
466 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
467 # work around bug #97196
468 dodir /usr/share/doc/kde && \
469 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
470 die "Failed to move docs to kde/ failed."
471 fi
472}
473
474# @FUNCTION: kde4-base_pkg_postinst
475# @DESCRIPTION:
476# Function to rebuild the KDE System Configuration Cache after an application has been installed.
477kde4-base_pkg_postinst() {
478 buildsycoca
479} 1000}
480 1001
481# @FUNCTION: kde4-base_pkg_postrm 1002# @FUNCTION: kde4-base_pkg_postrm
482# @DESCRIPTION: 1003# @DESCRIPTION:
483# Function to rebuild the KDE System Configuration Cache after an application has been removed. 1004# Function to rebuild the KDE System Configuration Cache after an application has been removed.
484kde4-base_pkg_postrm() { 1005kde4-base_pkg_postrm() {
1006 debug-print-function ${FUNCNAME} "$@"
1007
1008 gnome2_icon_cache_update
1009 fdo-mime_desktop_database_update
1010 fdo-mime_mime_database_update
485 buildsycoca 1011 buildsycoca
486} 1012}

Legend:
Removed from v.1.6  
changed lines
  Added in v.1.87

  ViewVC Help
Powered by ViewVC 1.1.20