/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.84 Revision 1.145
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2014 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.84 2011/01/28 05:05:13 tampakrap Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.145 2014/12/09 18:38:57 mrueg Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds currently support EAPIs 4 and 5. This will be
14# eclass will fail with version older than 2. 14# reviewed over time as new EAPI versions are approved.
15
16if [[ -z ${_KDE4_BASE_ECLASS} ]]; then
17_KDE4_BASE_ECLASS=1
18
19# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
20# @DESCRIPTION:
21# If set to "none", do nothing.
22# For any other value, add selinux to IUSE, and depending on that useflag
23# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
24: ${KDE_SELINUX_MODULE:=none}
25
26# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
27# @DESCRIPTION:
28# If defined, launch and use a private dbus session during src_test.
15 29
16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED 30# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION: 31# @DESCRIPTION:
18# Do we need an X server? Valid values are "always", "optional", and "manual". 32# For proper description see virtualx.eclass manpage.
19# "tests" is a synonym for "optional". While virtualx.eclass supports in principle 33# Here we redefine default value to be manual, if your package needs virtualx
20# also the use of an X server during other ebuild phases, we only use it in 34# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21# src_test here. Most likely you'll want to set "optional", which introduces the
22# use-flag "test" (if not already present), adds dependencies conditional on that
23# use-flag, and automatically runs (only) the ebuild test phase with a virtual X server
24# present. This makes things a lot more comfortable than the bare virtualx eclass.
25
26# In case the variable is not set in the ebuild, let virtualx eclass not do anything
27: ${VIRTUALX_REQUIRED:=manual} 35: ${VIRTUALX_REQUIRED:=manual}
28 36
29inherit kde4-functions base virtualx eutils 37inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils virtualx versionator eutils multilib
30 38
31get_build_type
32if [[ ${BUILD_TYPE} = live ]]; then 39if [[ ${KDE_BUILD_TYPE} = live ]]; then
33 if [[ ${KDEBASE} = kdevelop ]]; then 40 case ${KDE_SCM} in
34 inherit git
35 else
36 inherit subversion 41 svn) inherit subversion ;;
37 fi 42 git) inherit git-r3 ;;
43 esac
38fi 44fi
39 45
40# @ECLASS-VARIABLE: CMAKE_REQUIRED 46# @ECLASS-VARIABLE: CMAKE_REQUIRED
41# @DESCRIPTION: 47# @DESCRIPTION:
42# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'. 48# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
47if [[ ${CMAKE_REQUIRED} = always ]]; then 53if [[ ${CMAKE_REQUIRED} = always ]]; then
48 buildsystem_eclass="cmake-utils" 54 buildsystem_eclass="cmake-utils"
49 export_fns="src_configure src_compile src_test src_install" 55 export_fns="src_configure src_compile src_test src_install"
50fi 56fi
51 57
52# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
53if [[ -n ${KDE_MINIMAL} ]]; then
54 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
55 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
56 done
57 unset slot
58 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
59else
60 KDE_MINIMAL_VALID=1
61fi
62
63# @ECLASS-VARIABLE: KDE_MINIMAL 58# @ECLASS-VARIABLE: KDE_MINIMAL
64# @DESCRIPTION: 59# @DESCRIPTION:
65# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal 60# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
66# version for apps to work. Currently defaults to 4.4 61# version for apps to work. Currently defaults to 4.4
67# One may override this variable to raise version requirements. 62# One may override this variable to raise version requirements.
68# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
69# Note that it is fixed to ${SLOT} for kde-base packages. 63# Note that it is fixed to ${PV} for kde-base packages.
70KDE_MINIMAL="${KDE_MINIMAL:-4.4}" 64KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
71 65
72# Set slot for packages in kde-base, koffice and kdevelop 66# Set slot for KDEBASE known packages
73case ${KDEBASE} in 67case ${KDEBASE} in
74 kde-base) 68 kde-base)
75 # Determine SLOT from PVs
76 case ${PV} in 69 case ${EAPI} in
77 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live 70 5)
78 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;; 71 SLOT=4/$(get_version_component_range 1-2)
79 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;; 72 ;;
80 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;; 73 *)
81 9999*) SLOT="live" ;; # regular live 74 SLOT=4
82 *) die "Unsupported ${PV}" ;; 75 ;;
83 esac 76 esac
84 KDE_MINIMAL="${SLOT}" 77 KDE_MINIMAL="${PV}"
85 ;;
86 koffice)
87 SLOT="2"
88 ;; 78 ;;
89 kdevelop) 79 kdevelop)
90 if [[ ${BUILD_TYPE} = live ]]; then 80 if [[ ${KDE_BUILD_TYPE} = live ]]; then
91 # @ECLASS-VARIABLE: KDEVELOP_VERSION 81 # @ECLASS-VARIABLE: KDEVELOP_VERSION
92 # @DESCRIPTION: 82 # @DESCRIPTION:
93 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages. 83 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
94 # Applies to KDEBASE=kdevelop only. 84 # Applies to KDEBASE=kdevelop only.
95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}" 85 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.9999}"
96 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION 86 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
97 # @DESCRIPTION: 87 # @DESCRIPTION:
98 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages. 88 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
99 # Applies to KDEBASE=kdevelop only. 89 # Applies to KDEBASE=kdevelop only.
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}" 90 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-4.9999}"
101 else 91 else
102 case ${PN} in 92 case ${PN} in
103 kdevelop|quanta) 93 kdevelop)
104 KDEVELOP_VERSION=${PV} 94 KDEVELOP_VERSION=${PV}
105 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)" 95 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
106 ;; 96 ;;
107 kdevplatform) 97 kdevplatform|kdevelop-php*|kdevelop-python)
108 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)" 98 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
109 KDEVPLATFORM_VERSION=${PV} 99 KDEVPLATFORM_VERSION=${PV}
110 ;; 100 ;;
111 *) 101 *)
112 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}" 102 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
115 fi 105 fi
116 SLOT="4" 106 SLOT="4"
117 ;; 107 ;;
118esac 108esac
119 109
120slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
121
122inherit ${buildsystem_eclass} 110inherit ${buildsystem_eclass}
123 111
124EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm 112EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
125 113
126unset buildsystem_eclass 114unset buildsystem_eclass
127unset export_fns 115unset export_fns
128 116
129# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED 117# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
130# @DESCRIPTION: 118# @DESCRIPTION:
131# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'. 119# Is qtdeclarative required? Possible values are 'always', 'optional' and 'never'.
132# This variable must be set before inheriting any eclasses. Defaults to 'never'. 120# This variable must be set before inheriting any eclasses. Defaults to 'never'.
133DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}" 121DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
134 122
135# @ECLASS-VARIABLE: QTHELP_REQUIRED 123# @ECLASS-VARIABLE: QTHELP_REQUIRED
136# @DESCRIPTION: 124# @DESCRIPTION:
137# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'. 125# Is qthelp required? Possible values are 'always', 'optional' and 'never'.
138# This variable must be set before inheriting any eclasses. Defaults to 'never'. 126# This variable must be set before inheriting any eclasses. Defaults to 'never'.
139QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}" 127QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
140 128
141# @ECLASS-VARIABLE: OPENGL_REQUIRED 129# @ECLASS-VARIABLE: OPENGL_REQUIRED
142# @DESCRIPTION: 130# @DESCRIPTION:
143# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 131# Is qtopengl required? Possible values are 'always', 'optional' and 'never'.
144# This variable must be set before inheriting any eclasses. Defaults to 'never'. 132# This variable must be set before inheriting any eclasses. Defaults to 'never'.
145OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 133OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
146 134
147# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED 135# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
148# @DESCRIPTION: 136# @DESCRIPTION:
149# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'. 137# Is qtmultimedia required? Possible values are 'always', 'optional' and 'never'.
150# This variable must be set before inheriting any eclasses. Defaults to 'never'. 138# This variable must be set before inheriting any eclasses. Defaults to 'never'.
151MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}" 139MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
152
153# @ECLASS-VARIABLE: WEBKIT_REQUIRED
154# @DESCRIPTION:
155# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
156# This variable must be set before inheriting any eclasses. Defaults to 'never'.
157WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
158 140
159# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 141# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
160# @DESCRIPTION: 142# @DESCRIPTION:
161# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 143# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
162# This variable must be set before inheriting any eclasses. Defaults to 'never'. 144# This variable must be set before inheriting any eclasses. Defaults to 'never'.
177# This variable must be set before inheriting any eclasses. Defaults to 'never'. 159# This variable must be set before inheriting any eclasses. Defaults to 'never'.
178# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it 160# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
179# ensures buildtime and runtime dependencies. 161# ensures buildtime and runtime dependencies.
180KDE_HANDBOOK="${KDE_HANDBOOK:-never}" 162KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
181 163
164# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
165# @DESCRIPTION:
166# Set this varible if you want your live package to manage its
167# translations. (Mostly all kde ebuilds does not ship documentation
168# and translations in live ebuilds)
169if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
170 # Kdebase actualy provides the handbooks even for live stuff
171 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
172 KDE_LINGUAS=""
173fi
174
182# Setup packages inheriting this eclass 175# Setup packages inheriting this eclass
183case ${KDEBASE} in 176case ${KDEBASE} in
184 kde-base) 177 kde-base)
185 HOMEPAGE="http://www.kde.org/" 178 HOMEPAGE="http://www.kde.org/"
186 LICENSE="GPL-2" 179 LICENSE="GPL-2"
187 if [[ $BUILD_TYPE = live ]]; then 180 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
188 # Disable tests for live ebuilds 181 # Disable tests for live ebuilds by default
189 RESTRICT+=" test" 182 RESTRICT+=" test"
190 # Live ebuilds in kde-base default to kdeprefix by default
191 IUSE+=" +kdeprefix"
192 else
193 # All other ebuild types default to -kdeprefix as before
194 IUSE+=" kdeprefix"
195 fi 183 fi
184
196 # This code is to prevent portage from searching GENTOO_MIRRORS for 185 # This code is to prevent portage from searching GENTOO_MIRRORS for
197 # packages that will never be mirrored. (As they only will ever be in 186 # packages that will never be mirrored. (As they only will ever be in
198 # the overlay). 187 # the overlay).
199 case ${PV} in 188 case ${PV} in
200 *9999* | 4.?.[6-9]?) 189 *9999* | 4.?.[6-9]? | 4.??.[6-9]? | ??.?.[6-9]? | ??.??.[6-9]?)
201 RESTRICT+=" mirror" 190 RESTRICT+=" mirror"
202 ;; 191 ;;
203 esac 192 esac
204 # Block installation of other SLOTS unless kdeprefix
205 RDEPEND+=" $(block_other_slots)"
206 ;;
207 koffice)
208 HOMEPAGE="http://www.koffice.org/"
209 LICENSE="GPL-2"
210 ;; 193 ;;
211 kdevelop) 194 kdevelop)
212 HOMEPAGE="http://www.kdevelop.org/" 195 HOMEPAGE="http://www.kdevelop.org/"
213 LICENSE="GPL-2" 196 LICENSE="GPL-2"
214 ;; 197 ;;
215esac 198esac
216 199
217# @ECLASS-VARIABLE: QT_MINIMAL 200# @ECLASS-VARIABLE: QT_MINIMAL
218# @DESCRIPTION: 201# @DESCRIPTION:
219# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1... 202# Determine version of qt we enforce as minimal for the package.
220# 4.6.0 for 4.4, 4.6.3 for 4.5, and 4.7.0 for 4.6 and later
221if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
222 QT_MINIMAL="${QT_MINIMAL:-4.7.0}" 203QT_MINIMAL="${QT_MINIMAL:-4.8.5}"
223elif slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
224 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
225else
226 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
227fi
228 204
229# Declarative dependencies 205# Declarative dependencies
230qtdeclarativedepend=" 206qtdeclarativedepend="
231 >=x11-libs/qt-declarative-${QT_MINIMAL}:4 207 >=dev-qt/qtdeclarative-${QT_MINIMAL}:4
232" 208"
233case ${DECLARATIVE_REQUIRED} in 209case ${DECLARATIVE_REQUIRED} in
234 always) 210 always)
235 COMMONDEPEND+=" ${qtdeclarativedepend}" 211 COMMONDEPEND+=" ${qtdeclarativedepend}"
236 ;; 212 ;;
242esac 218esac
243unset qtdeclarativedepend 219unset qtdeclarativedepend
244 220
245# QtHelp dependencies 221# QtHelp dependencies
246qthelpdepend=" 222qthelpdepend="
247 >=x11-libs/qt-assistant-${QT_MINIMAL}:4 223 >=dev-qt/qthelp-${QT_MINIMAL}:4
248" 224"
249case ${QTHELP_REQUIRED} in 225case ${QTHELP_REQUIRED} in
250 always) 226 always)
251 COMMONDEPEND+=" ${qthelpdepend}" 227 COMMONDEPEND+=" ${qthelpdepend}"
252 ;; 228 ;;
257esac 233esac
258unset qthelpdepend 234unset qthelpdepend
259 235
260# OpenGL dependencies 236# OpenGL dependencies
261qtopengldepend=" 237qtopengldepend="
262 >=x11-libs/qt-opengl-${QT_MINIMAL}:4 238 >=dev-qt/qtopengl-${QT_MINIMAL}:4
263" 239"
264case ${OPENGL_REQUIRED} in 240case ${OPENGL_REQUIRED} in
265 always) 241 always)
266 COMMONDEPEND+=" ${qtopengldepend}" 242 COMMONDEPEND+=" ${qtopengldepend}"
267 ;; 243 ;;
273esac 249esac
274unset qtopengldepend 250unset qtopengldepend
275 251
276# MultiMedia dependencies 252# MultiMedia dependencies
277qtmultimediadepend=" 253qtmultimediadepend="
278 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4 254 >=dev-qt/qtmultimedia-${QT_MINIMAL}:4
279" 255"
280case ${MULTIMEDIA_REQUIRED} in 256case ${MULTIMEDIA_REQUIRED} in
281 always) 257 always)
282 COMMONDEPEND+=" ${qtmultimediadepend}" 258 COMMONDEPEND+=" ${qtmultimediadepend}"
283 ;; 259 ;;
286 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )" 262 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
287 ;; 263 ;;
288 *) ;; 264 *) ;;
289esac 265esac
290unset qtmultimediadepend 266unset qtmultimediadepend
291
292# WebKit dependencies
293case ${KDE_REQUIRED} in
294 always)
295 qtwebkitusedeps="[kde]"
296 ;;
297 optional)
298 qtwebkitusedeps="[kde?]"
299 ;;
300 *) ;;
301esac
302qtwebkitdepend="
303 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
304"
305unset qtwebkitusedeps
306case ${WEBKIT_REQUIRED} in
307 always)
308 COMMONDEPEND+=" ${qtwebkitdepend}"
309 ;;
310 optional)
311 IUSE+=" webkit"
312 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
313 ;;
314 *) ;;
315esac
316unset qtwebkitdepend
317 267
318# CppUnit dependencies 268# CppUnit dependencies
319cppuintdepend=" 269cppuintdepend="
320 dev-util/cppunit 270 dev-util/cppunit
321" 271"
333 283
334# KDE dependencies 284# KDE dependencies
335# Qt accessibility classes are needed in various places, bug 325461 285# Qt accessibility classes are needed in various places, bug 325461
336kdecommondepend=" 286kdecommondepend="
337 dev-lang/perl 287 dev-lang/perl
288 >=dev-qt/qt3support-${QT_MINIMAL}:4[accessibility]
338 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl] 289 >=dev-qt/qtcore-${QT_MINIMAL}:4[qt3support,ssl]
290 >=dev-qt/qtdbus-${QT_MINIMAL}:4
291 >=dev-qt/designer-${QT_MINIMAL}:4[-phonon]
339 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus] 292 >=dev-qt/qtgui-${QT_MINIMAL}:4[accessibility,dbus(+)]
340 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
341 >=x11-libs/qt-script-${QT_MINIMAL}:4 293 >=dev-qt/qtscript-${QT_MINIMAL}:4
342 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support] 294 >=dev-qt/qtsql-${QT_MINIMAL}:4[qt3support]
343 >=x11-libs/qt-svg-${QT_MINIMAL}:4 295 >=dev-qt/qtsvg-${QT_MINIMAL}:4
344 >=x11-libs/qt-test-${QT_MINIMAL}:4 296 >=dev-qt/qttest-${QT_MINIMAL}:4
345 !aqua? ( 297 >=dev-qt/qtwebkit-${QT_MINIMAL}:4
346 x11-libs/libXext
347 x11-libs/libXt
348 x11-libs/libXxf86vm
349 )
350" 298"
351 299
352if [[ ${PN} != kdelibs ]]; then 300if [[ ${PN} != kdelibs ]]; then
353 kdecommondepend+=" $(add_kdebase_dep kdelibs)" 301 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
354 if [[ ${KDEBASE} = kdevelop ]]; then 302 if [[ ${KDEBASE} = kdevelop ]]; then
359 # Applies to KDEBASE=kdevelop only. 307 # Applies to KDEBASE=kdevelop only.
360 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}" 308 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
361 case ${KDEVPLATFORM_REQUIRED} in 309 case ${KDEVPLATFORM_REQUIRED} in
362 always) 310 always)
363 kdecommondepend+=" 311 kdecommondepend+="
364 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION} 312 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}:4
365 " 313 "
366 ;; 314 ;;
367 *) ;; 315 *) ;;
368 esac 316 esac
369 fi 317 fi
370 fi 318 fi
371fi 319fi
320
372kdedepend=" 321kdedepend="
373 dev-util/automoc 322 dev-util/automoc
374 dev-util/pkgconfig 323 virtual/pkgconfig
375 !aqua? ( 324 !aqua? (
376 >=x11-libs/libXtst-1.1.0 325 >=x11-libs/libXtst-1.1.0
377 x11-proto/xf86vidmodeproto 326 x11-proto/xf86vidmodeproto
378 ) 327 )
379" 328"
329
380kderdepend="" 330kderdepend=""
381 331
332if [[ ${CATEGORY} == kde-apps ]]; then
333 kderdepend+=" !kde-base/${PN}"
334fi
335
336# all packages needs oxygen icons for basic iconset
382if [[ ${PN} != oxygen-icons ]]; then 337if [[ ${PN} != oxygen-icons ]]; then
383 kderdepend+=" $(add_kdebase_dep oxygen-icons)" 338 kderdepend+=" || ( kde-apps/oxygen-icons $(add_kdebase_dep oxygen-icons) )"
339fi
340
341# add a dependency over kde-l10n
342if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} ]]; then
343 for _lingua in ${KDE_LINGUAS}; do
344 # if our package has linguas, pull in kde-l10n with selected lingua enabled,
345 # but only for selected ones.
346 # this can't be done on one line because if user doesn't use any localisation
347 # then he is probably not interested in kde-l10n at all.
348 kderdepend+="
349 linguas_${_lingua}? ( || ( kde-apps/kde-l10n[linguas_${_lingua}(+)] $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") ) )
350 "
351 done
352 unset _lingua
384fi 353fi
385 354
386kdehandbookdepend=" 355kdehandbookdepend="
387 app-text/docbook-xml-dtd:4.2 356 app-text/docbook-xml-dtd:4.2
388 app-text/docbook-xsl-stylesheets 357 app-text/docbook-xsl-stylesheets
402 ;; 371 ;;
403 *) ;; 372 *) ;;
404esac 373esac
405unset kdehandbookdepend kdehandbookrdepend 374unset kdehandbookdepend kdehandbookrdepend
406 375
376case ${KDE_SELINUX_MODULE} in
377 none) ;;
378 *)
379 IUSE+=" selinux"
380 kdecommondepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
381 ;;
382esac
383
384# We always need the aqua useflag because otherwise we cannot = refer to it inside
385# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
386# (where referring to a use flag not in IUSE masks the ebuild).
387# The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
388IUSE+=" aqua"
389
407case ${KDE_REQUIRED} in 390case ${KDE_REQUIRED} in
408 always) 391 always)
409 IUSE+=" aqua"
410 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}" 392 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
411 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}" 393 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
412 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}" 394 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
413 ;; 395 ;;
414 optional) 396 optional)
415 IUSE+=" aqua kde" 397 IUSE+=" kde"
416 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 398 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
417 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )" 399 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
418 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )" 400 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
419 ;; 401 ;;
420 *) ;; 402 *) ;;
429# Accumulate dependencies set by this eclass 411# Accumulate dependencies set by this eclass
430DEPEND+=" ${COMMONDEPEND}" 412DEPEND+=" ${COMMONDEPEND}"
431RDEPEND+=" ${COMMONDEPEND}" 413RDEPEND+=" ${COMMONDEPEND}"
432unset COMMONDEPEND 414unset COMMONDEPEND
433 415
434# Add experimental kdeenablefinal, disabled by default
435IUSE+=" kdeenablefinal"
436
437# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 416# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
438# koffice ebuild, the URI should be set in the ebuild itself 417# kdevelop ebuild, the URI should be set in the ebuild itself
439case ${BUILD_TYPE} in 418_calculate_src_uri() {
440 live) 419 debug-print-function ${FUNCNAME} "$@"
420
421 local _kmname _kmname_pv
422
423 # we calculate URI only for known KDEBASE modules
424 [[ -n ${KDEBASE} ]] || return
425
426 # calculate tarball module name
427 if [[ -n ${KMNAME} ]]; then
428 _kmname="${KMNAME}"
429 else
430 _kmname=${PN}
431 fi
432 _kmname_pv="${_kmname}-${PV}"
433 case ${KDEBASE} in
434 kde-base)
435 case ${PV} in
436 4.4.11.1)
437 # KDEPIM 4.4, special case
438 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
439 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
440 4.?.[6-9]? | 4.??.[6-9]?)
441 # Unstable KDE SC releases
442 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
443 4.[1-7].[12345])
444 # Stable KDE SC with old .bz2 support
445 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
446 4.11.9)
447 # Part of 4.12 actually, sigh. Not stable for next release!
448 SRC_URI="mirror://kde/stable/4.12.5/src/${_kmname_pv}.tar.xz" ;;
449 4.11.11)
450 # Part of 4.13 actually, sigh. Not stable for next release!
451 SRC_URI="mirror://kde/stable/4.13.3/src/${_kmname_pv}.tar.xz" ;;
452 4.11.12)
453 # Part of 4.14 actually, sigh. Not stable for next release!
454 SRC_URI="mirror://kde/stable/4.14.1/src/${_kmname_pv}.tar.xz" ;;
455 4.11.13)
456 # Part of 4.14 actually, sigh. Not stable for next release!
457 SRC_URI="mirror://kde/stable/4.14.2/src/${_kmname_pv}.tar.xz" ;;
458 4.11.14)
459 # Part of 4.14 actually, sigh. Not stable for next release!
460 SRC_URI="mirror://kde/stable/4.14.3/src/${_kmname_pv}.tar.xz" ;;
461 ??.?.[6-9]? | ??.??.[4-9]?)
462 # Unstable KDE Applications releases
463 SRC_URI="mirror://kde/unstable/applications/${PV}/src/${_kmname}-${PV}.tar.xz" ;;
464 *)
465 if [[ ${CATEGORY} == kde-apps ]]; then
466 # Stable KDE Applications releases
467 SRC_URI="mirror://kde/stable/applications/${PV}/src/${_kmname}-${PV}.tar.xz"
468 else
469 # Stable KDE SC releases
470 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz"
471 fi
472 ;;
473 esac
474 ;;
475 kdevelop|kdevelop-php*|kdevplatform)
476 case ${KDEVELOP_VERSION} in
477 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
478 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
479 esac
480 ;;
481 esac
482}
483
484_calculate_live_repo() {
485 debug-print-function ${FUNCNAME} "$@"
486
441 SRC_URI="" 487 SRC_URI=""
442 if has subversion ${INHERITED}; then 488 case ${KDE_SCM} in
489 svn)
443 # Determine branch URL based on live type 490 # Determine branch URL based on live type
444 local branch_prefix 491 local branch_prefix
445 case ${PV} in 492 case ${PV} in
446 9999*) 493 4.9999*)
447 # trunk 494 # trunk
448 branch_prefix="trunk/KDE" 495 branch_prefix="trunk/KDE"
449 ;; 496 ;;
450 *) 497 *)
451 # branch 498 # branch
452 branch_prefix="branches/KDE/${SLOT}" 499 branch_prefix="branches/KDE/$(get_kde_version)"
453 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX 500 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
454 # @DESCRIPTION 501 # @DESCRIPTION
455 # Suffix appended to ESVN_PROJECT depending on fetched branch. 502 # Suffix appended to ESVN_PROJECT depending on fetched branch.
456 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise. 503 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
457 ESVN_PROJECT_SUFFIX="-${PV}" 504 ESVN_PROJECT_SUFFIX="-${PV}"
490 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta 537 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
491 # build packages from same svn location. 538 # build packages from same svn location.
492 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 539 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
493 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 540 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
494 ;; 541 ;;
495 koffice)
496 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
497 ;;
498 *) 542 *)
499 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 543 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
500 ;; 544 ;;
501 esac 545 esac
502 else 546 else
505 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 549 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
506 fi 550 fi
507 # @ECLASS-VARIABLE: ESVN_UP_FREQ 551 # @ECLASS-VARIABLE: ESVN_UP_FREQ
508 # @DESCRIPTION: 552 # @DESCRIPTION:
509 # This variable is used for specifying the timeout between svn synces 553 # This variable is used for specifying the timeout between svn synces
510 # for kde-base and koffice modules. Does not affect misc apps. 554 # for kde-base modules. Does not affect misc apps.
511 # Default value is 1 hour. 555 # Default value is 1 hour.
512 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1} 556 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
513 elif has git ${INHERITED}; then
514 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
515 KMMODULE="${PN}"
516 fi
517 case ${KDEBASE} in
518 kdevelop)
519 EGIT_REPO_URI="git://git.kde.org/${KMMODULE}"
520 ;;
521 esac
522 fi
523 ;; 557 ;;
524 *) 558 git)
559 local _kmname
560 # @ECLASS-VARIABLE: EGIT_MIRROR
561 # @DESCRIPTION:
562 # This variable allows easy overriding of default kde mirror service
563 # (anongit) with anything else you might want to use.
564 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
565
566 # @ECLASS-VARIABLE: EGIT_REPONAME
567 # @DESCRIPTION:
568 # This variable allows overriding of default repository
569 # name. Specify only if this differ from PN and KMNAME.
525 if [[ -n ${KDEBASE} ]]; then 570 if [[ -n ${EGIT_REPONAME} ]]; then
571 # the repository and kmname different
572 _kmname=${EGIT_REPONAME}
526 if [[ -n ${KMNAME} ]]; then 573 elif [[ -n ${KMNAME} ]]; then
527 case ${KMNAME} in
528 kdebase-apps)
529 _kmname="kdebase" ;;
530 *)
531 _kmname="${KMNAME}" ;; 574 _kmname=${KMNAME}
532 esac
533 else 575 else
534 _kmname=${PN} 576 _kmname=${PN}
535 fi 577 fi
536 _kmname_pv="${_kmname}-${PV}" 578
537 case ${KDEBASE} in 579 # default branching
538 kde-base) 580 [[ ${PV} != 4.9999* && ${KDEBASE} == kde-base ]] && \
539 case ${PV} in 581 EGIT_BRANCH="KDE/$(get_kde_version)"
540 4.5.93) 582
541 # Only kdepim and kdepim-runtime 4.6beta here 583 # default repo uri
542 SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname}-4.6beta3.tar.bz2" 584 EGIT_REPO_URI+=( "${EGIT_MIRROR}/${_kmname}" )
543 ;; 585
544 4.[456].8[05] | 4.[456].9[023568]) 586 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
545 # Unstable KDE SC releases 587 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
546 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
547 ;;
548 4.4.6 | 4.4.7 | 4.4.8 | 4.4.9 | 4.4.10)
549 # Only kdepim here
550 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
551 ;;
552 *)
553 # Stable KDE SC releases
554 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
555 ;;
556 esac
557 ;;
558 koffice)
559 case ${PV} in
560 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
561 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
562 esac
563 ;;
564 kdevelop)
565 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
566 ;;
567 esac
568 unset _kmname _kmname_pv
569 fi
570 ;; 588 ;;
589 esac
590}
591
592case ${KDE_BUILD_TYPE} in
593 live) _calculate_live_repo ;;
594 *) _calculate_src_uri ;;
571esac 595esac
572 596
573debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}" 597debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
574 598
575# @ECLASS-VARIABLE: PREFIX 599# @ECLASS-VARIABLE: PREFIX
576# @DESCRIPTION: 600# @DESCRIPTION:
577# Set the installation PREFIX for non kde-base applications. It defaults to /usr. 601# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
578# kde-base packages go into KDE4 installation directory (KDEDIR) by default. 602# kde-base packages go into KDE4 installation directory (/usr).
579# No matter the PREFIX, package will be built against KDE installed in KDEDIR. 603# No matter the PREFIX, package will be built against KDE installed in /usr.
580 604
581# @FUNCTION: kde4-base_pkg_setup 605# @FUNCTION: kde4-base_pkg_setup
582# @DESCRIPTION: 606# @DESCRIPTION:
583# Do the basic kdeprefix KDEDIR settings and determine with which kde should 607# Do some basic settings
584# optional applications link
585kde4-base_pkg_setup() { 608kde4-base_pkg_setup() {
586 debug-print-function ${FUNCNAME} "$@" 609 debug-print-function ${FUNCNAME} "$@"
587 610
588 # Prefix compat: 611 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
589 if [[ ${EAPI} == 2 ]] && ! use prefix; then 612 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
590 EPREFIX= 613 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
591 EROOT=${ROOT}
592 fi 614 fi
593
594 # Append missing trailing slash character
595 [[ ${EROOT} = */ ]] || EROOT+="/"
596
597 # QA ebuilds
598 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
599 615
600 # Don't set KDEHOME during compilation, it will cause access violations 616 # Don't set KDEHOME during compilation, it will cause access violations
601 unset KDEHOME 617 unset KDEHOME
602 618
603 if [[ ${KDEBASE} = kde-base ]]; then 619 # Check if gcc compiler is fresh enough.
604 if use kdeprefix; then 620 # In theory should be in pkg_pretend but we check it only for kdelibs there
605 KDEDIR=/usr/kde/${SLOT} 621 # and for others we do just quick scan in pkg_setup because pkg_pretend
606 else 622 # executions consume quite some time (ie. when merging 300 packages at once will cause 300 checks)
623 if [[ ${MERGE_TYPE} != binary ]]; then
624 [[ $(gcc-major-version) -lt 4 ]] || \
625 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 6 ]] ) \
626 && die "Sorry, but gcc-4.6 and earlier wont work for some KDE packages."
627 fi
628
607 KDEDIR=/usr 629 KDEDIR=/usr
608 fi
609 : ${PREFIX:=${KDEDIR}}
610 else
611 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
612 KDEDIR=
613 local kde_minimal_met
614 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
615 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
616 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
617 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
618 KDEDIR=/usr/kde/${slot}
619 else
620 KDEDIR=/usr
621 fi
622 break;
623 fi
624 done
625 unset slot
626
627 # Bail out if kdelibs required but not found
628 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
629 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
630 else
631 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
632 fi
633
634 : ${PREFIX:=/usr} 630 : ${PREFIX:=/usr}
635 fi 631 EKDEDIR=${EPREFIX}/usr
636 EKDEDIR=${EPREFIX}${KDEDIR}
637 632
638 # Point pkg-config path to KDE *.pc files
639 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
640 # Point to correct QT plugins path 633 # Point to correct QT plugins path
641 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/" 634 QT_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/kde4/plugins/"
642 635
643 # Fix XDG collision with sandbox 636 # Fix XDG collision with sandbox
644 export XDG_CONFIG_HOME="${T}" 637 export XDG_CONFIG_HOME="${T}"
645} 638}
646 639
648# @DESCRIPTION: 641# @DESCRIPTION:
649# This function unpacks the source tarballs for KDE4 applications. 642# This function unpacks the source tarballs for KDE4 applications.
650kde4-base_src_unpack() { 643kde4-base_src_unpack() {
651 debug-print-function ${FUNCNAME} "$@" 644 debug-print-function ${FUNCNAME} "$@"
652 645
653 if [[ ${BUILD_TYPE} = live ]]; then 646 if [[ ${KDE_BUILD_TYPE} = live ]]; then
654 if has subversion ${INHERITED}; then 647 case ${KDE_SCM} in
655 migrate_store_dir 648 svn)
656 subversion_src_unpack 649 subversion_src_unpack
657 elif has git ${INHERITED}; then
658 git_src_unpack
659 fi
660 elif [[ ${EAPI} == 2 ]]; then
661 local file
662 for file in ${A}; do
663 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
664 # directly, so we do it ourselves (using the exact same code as portage)
665 case ${file} in
666 *.tar.xz)
667 echo ">>> Unpacking ${file} to ${PWD}"
668 xz -dc "${DISTDIR}"/${file} | tar xof -
669 assert "failed unpacking ${file}"
670 ;; 650 ;;
671 *) 651 git)
672 unpack ${file} 652 git-r3_src_unpack
673 ;; 653 ;;
674 esac 654 esac
675 done
676 else 655 else
677 # For EAPI >= 3, we can just use unpack() directly
678 unpack ${A} 656 unpack ${A}
679 fi 657 fi
680} 658}
681 659
682# @FUNCTION: kde4-base_src_prepare 660# @FUNCTION: kde4-base_src_prepare
686# enable_selected_linguas() and enable_selected_doc_linguas() 664# enable_selected_linguas() and enable_selected_doc_linguas()
687# in kde4-functions.eclass(5) for further details. 665# in kde4-functions.eclass(5) for further details.
688kde4-base_src_prepare() { 666kde4-base_src_prepare() {
689 debug-print-function ${FUNCNAME} "$@" 667 debug-print-function ${FUNCNAME} "$@"
690 668
669 # enable handbook and linguas only when not using live ebuild
670
691 # Only enable selected languages, used for KDE extragear apps. 671 # Only enable selected languages, used for KDE extragear apps.
692 if [[ -n ${KDE_LINGUAS} ]]; then 672 if [[ -n ${KDE_LINGUAS} ]]; then
693 enable_selected_linguas 673 enable_selected_linguas
694 fi 674 fi
695 675
696 # Enable/disable handbooks for kde4-base packages 676 # Enable/disable handbooks for kde4-base packages
697 # kde-l10n inherits kde4-base but is metpackage, so no check for doc 677 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
698 # kdelibs inherits kde4-base but handle installing the handbook itself 678 # kdelibs inherits kde4-base but handle installing the handbook itself
699 if ! has kde4-meta ${INHERITED}; then 679 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
700 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas 680 if [[ ${KDEBASE} == kde-base ]]; then
681 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
682 # documentation in kde4-functions
683 : ${KDE_DOC_DIRS:=doc}
684 local dir
685 for dir in ${KDE_DOC_DIRS}; do
686 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
687 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
688 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
689 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
690 -i CMakeLists.txt || die "failed to comment out handbook"
691 done
692 fi
693 else
694 enable_selected_doc_linguas
695 fi
701 fi 696 fi
702 697
703 # SCM bootstrap 698 # SCM bootstrap
704 if [[ ${BUILD_TYPE} = live ]]; then 699 if [[ ${KDE_BUILD_TYPE} = live ]]; then
705 if has subversion ${INHERITED}; then 700 case ${KDE_SCM} in
706 subversion_src_prepare 701 svn) subversion_src_prepare ;;
707 elif has git ${INHERITED}; then 702 esac
708 git_src_prepare
709 fi 703 fi
710 fi
711 704
712 # Apply patches 705 # Apply patches, cmake-utils does the job already
713 base_src_prepare 706 cmake-utils_src_prepare
714 707
715 # Save library dependencies 708 # Save library dependencies
716 if [[ -n ${KMSAVELIBS} ]] ; then 709 if [[ -n ${KMSAVELIBS} ]] ; then
717 save_library_dependencies 710 save_library_dependencies
718 fi 711 fi
720 # Inject library dependencies 713 # Inject library dependencies
721 if [[ -n ${KMLOADLIBS} ]] ; then 714 if [[ -n ${KMLOADLIBS} ]] ; then
722 load_library_dependencies 715 load_library_dependencies
723 fi 716 fi
724 717
725 # Replace KDE4Workspace library targets
726 find "${S}" -name CMakeLists.txt \
727 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
728 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
729 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
730 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
731 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
732 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
733 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
734 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
735 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
736 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
737 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
738 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
739 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
740 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
741 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
742 || die 'failed to replace KDE4Workspace library targets'
743
744 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/... 718 # Hack for manuals relying on outdated DTD, only outside kde-base/...
745 if [[ -z ${KDEBASE} ]]; then 719 if [[ -z ${KDEBASE} ]]; then
746 find "${S}" -name "*.docbook" \ 720 find "${S}" -name "*.docbook" \
747 -exec sed -i -r \ 721 -exec sed -i -r \
748 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \ 722 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
749 || die 'failed to fix DocBook variant version' 723 || die 'failed to fix DocBook variant version'
757 debug-print-function ${FUNCNAME} "$@" 731 debug-print-function ${FUNCNAME} "$@"
758 732
759 # Build tests in src_test only, where we override this value 733 # Build tests in src_test only, where we override this value
760 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF) 734 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
761 735
762 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then 736 if use_if_iuse debug; then
763 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
764 fi
765
766 if has debug ${IUSE//+} && use debug; then
767 # Set "real" debug mode 737 # Set "real" debug mode
768 CMAKE_BUILD_TYPE="Debugfull" 738 CMAKE_KDE_BUILD_TYPE="Debugfull"
769 else 739 else
770 # Handle common release builds 740 # Handle common release builds
771 append-cppflags -DQT_NO_DEBUG 741 append-cppflags -DQT_NO_DEBUG
772 fi 742 fi
773 743
778 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}") 748 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
779 749
780 # Use colors 750 # Use colors
781 QTEST_COLORED=1 751 QTEST_COLORED=1
782 752
783 # Shadow existing /usr installations 753 # Shadow existing installations
784 unset KDEDIRS 754 unset KDEDIRS
785 755
786 # Handle kdeprefix-ed KDE
787 if [[ ${KDEDIR} != /usr ]]; then
788 # Override some environment variables - only when kdeprefix is different,
789 # to not break ccache/distcc
790 PATH="${EKDEDIR}/bin:${PATH}"
791
792 # Append library search path
793 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
794
795 # Append full RPATH
796 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
797
798 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
799 # when more are present
800 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
801 fi
802
803 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling 756 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
804 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4) 757 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
805 #kde-config -path data unavailable when cross-compiling 758 #kde-config -path data unavailable when cross-compiling
806 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/) 759 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
807 760
808 # Handle kdeprefix in application itself
809 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
810 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 761 # sysconf needs to be /etc, not /usr/etc
811 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc) 762 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
812 fi
813 763
814 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then 764 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
765 if [[ ${mycmakeargs} ]]; then
766 eqawarn "mycmakeargs should always be declared as an array, not a string"
767 fi
815 mycmakeargs=(${mycmakeargs}) 768 mycmakeargs=(${mycmakeargs})
816 fi 769 fi
817 770
818 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}") 771 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
819 772
832# @FUNCTION: kde4-base_src_test 785# @FUNCTION: kde4-base_src_test
833# @DESCRIPTION: 786# @DESCRIPTION:
834# Function for testing KDE4 applications. 787# Function for testing KDE4 applications.
835kde4-base_src_test() { 788kde4-base_src_test() {
836 debug-print-function ${FUNCNAME} "$@" 789 debug-print-function ${FUNCNAME} "$@"
790
791 local kded4_pid
792
793 _test_runner() {
794 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
795 export $(dbus-launch)
796 kded4 2>&1 > /dev/null &
797 kded4_pid=$!
798 fi
799
800 cmake-utils_src_test
801 }
802
803 # When run as normal user during ebuild development with the ebuild command, the
804 # kde tests tend to access the session DBUS. This however is not possible in a real
805 # emerge or on the tinderbox.
806 # > make sure it does not happen, so bad tests can be recognized and disabled
807 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
837 808
838 # Override this value, set in kde4-base_src_configure() 809 # Override this value, set in kde4-base_src_configure()
839 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON) 810 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
840 cmake-utils_src_configure 811 cmake-utils_src_configure
841 kde4-base_src_compile 812 kde4-base_src_compile
842 813
843 if [[ ${VIRTUALX_REQUIRED} == always ]] || 814 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
844 ( [[ ${VIRTUALX_REQUIRED} != manual ]] && use test ); then 815 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
845 816 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
846 if [[ ${maketype} ]]; then
847 # surprise- we are already INSIDE virtualmake!!! 817 # surprise- we are already INSIDE virtualmake!!!
848 ewarn "QA Notice: This version of kde4-base.eclass includes the virtualx functionality." 818 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
849 ewarn " You may NOT set maketype or call virtualmake from the ebuild. Applying workaround." 819 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
850 cmake-utils_src_test 820 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
821 debug-print " kde4-base.eclass docs for details... Applying workaround."
822 _test_runner
851 else 823 else
852 export maketype="cmake-utils_src_test" 824 VIRTUALX_COMMAND="_test_runner" virtualmake
853 virtualmake
854 fi 825 fi
855 else 826 else
856 cmake-utils_src_test 827 _test_runner
828 fi
829
830 if [ -n "${kded4_pid}" ] ; then
831 kill ${kded4_pid}
832 fi
833
834 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
835 kill ${DBUS_SESSION_BUS_PID}
857 fi 836 fi
858} 837}
859 838
860# @FUNCTION: kde4-base_src_install 839# @FUNCTION: kde4-base_src_install
861# @DESCRIPTION: 840# @DESCRIPTION:
862# Function for installing KDE4 applications. 841# Function for installing KDE4 applications.
863kde4-base_src_install() { 842kde4-base_src_install() {
864 debug-print-function ${FUNCNAME} "$@" 843 debug-print-function ${FUNCNAME} "$@"
865
866 # Prefix support, for usage in ebuilds
867 if [[ ${EAPI} == 2 ]] && ! use prefix; then
868 ED=${D}
869 fi
870 844
871 if [[ -n ${KMSAVELIBS} ]] ; then 845 if [[ -n ${KMSAVELIBS} ]] ; then
872 install_library_dependencies 846 install_library_dependencies
873 fi 847 fi
874 848
875 # Install common documentation of KDE4 applications 849 # Install common documentation of KDE4 applications
876 local doc 850 local doc
877 if ! has kde4-meta ${INHERITED}; then 851 if ! has kde4-meta ${INHERITED}; then
878 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do 852 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
879 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}" 853 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
880 done 854 done
881 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do 855 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
882 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})" 856 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
883 done 857 done
884 fi 858 fi
885 859
886 cmake-utils_src_install 860 cmake-utils_src_install
861
862 # We don't want ${PREFIX}/share/doc/HTML to be compressed,
863 # because then khelpcenter can't find the docs
864 [[ -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
865 docompress -x ${PREFIX}/share/doc/HTML
866}
867
868# @FUNCTION: kde4-base_pkg_preinst
869# @DESCRIPTION:
870# Function storing icon caches
871kde4-base_pkg_preinst() {
872 debug-print-function ${FUNCNAME} "$@"
873
874 gnome2_icon_savelist
875 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
876 subversion_pkg_preinst
877 fi
887} 878}
888 879
889# @FUNCTION: kde4-base_pkg_postinst 880# @FUNCTION: kde4-base_pkg_postinst
890# @DESCRIPTION: 881# @DESCRIPTION:
891# Function to rebuild the KDE System Configuration Cache after an application has been installed. 882# Function to rebuild the KDE System Configuration Cache after an application has been installed.
892kde4-base_pkg_postinst() { 883kde4-base_pkg_postinst() {
893 debug-print-function ${FUNCNAME} "$@" 884 debug-print-function ${FUNCNAME} "$@"
894 885
886 gnome2_icon_cache_update
887 fdo-mime_desktop_database_update
888 fdo-mime_mime_database_update
895 buildsycoca 889 buildsycoca
896 890
897 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 891 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
898 echo 892 if [[ ${KDE_BUILD_TYPE} = live ]]; then
899 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
900 einfo "Use it at your own risk."
901 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
902 echo
903 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
904 # warning about kdeprefix for non-live users
905 echo
906 ewarn "WARNING! You have the kdeprefix useflag enabled."
907 ewarn "This setting is strongly discouraged and might lead to potential trouble"
908 ewarn "with KDE update strategies."
909 ewarn "You are using this setup at your own risk and the kde team does not"
910 ewarn "take responsibilities for dead kittens."
911 echo
912 fi
913 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
914 # warn about not supported approach
915 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
916 echo 893 echo
894 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
895 einfo "Use it at your own risk."
896 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
897 echo
898 fi
899 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
900 if [[ ${KDEBASE} != kde-base ]] && \
901 ! has_version 'kde-base/kdebase-runtime-meta' && \
902 ! has_version 'kde-base/kdebase-startkde'; then
903 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
904 echo
917 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\"" 905 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
918 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above." 906 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
919 ewarn "With this setting you are unsupported by KDE team." 907 ewarn "With this setting you are unsupported by KDE team."
920 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID." 908 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
909 fi
921 fi 910 fi
922 fi 911 fi
923} 912}
924 913
925# @FUNCTION: kde4-base_pkg_postrm 914# @FUNCTION: kde4-base_pkg_postrm
926# @DESCRIPTION: 915# @DESCRIPTION:
927# Function to rebuild the KDE System Configuration Cache after an application has been removed. 916# Function to rebuild the KDE System Configuration Cache after an application has been removed.
928kde4-base_pkg_postrm() { 917kde4-base_pkg_postrm() {
929 debug-print-function ${FUNCNAME} "$@" 918 debug-print-function ${FUNCNAME} "$@"
930 919
920 gnome2_icon_cache_update
921 fdo-mime_desktop_database_update
922 fdo-mime_mime_database_update
931 buildsycoca 923 buildsycoca
932} 924}
925
926fi

Legend:
Removed from v.1.84  
changed lines
  Added in v.1.145

  ViewVC Help
Powered by ViewVC 1.1.20