/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.8 Revision 1.84
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.8 2008/04/04 22:15:24 zlin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.84 2011/01/28 05:05:13 tampakrap Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# eclass will fail with version older than 2.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# Do we need an X server? Valid values are "always", "optional", and "manual".
19# "tests" is a synonym for "optional". While virtualx.eclass supports in principle
20# also the use of an X server during other ebuild phases, we only use it in
21# src_test here. Most likely you'll want to set "optional", which introduces the
22# use-flag "test" (if not already present), adds dependencies conditional on that
23# use-flag, and automatically runs (only) the ebuild test phase with a virtual X server
24# present. This makes things a lot more comfortable than the bare virtualx eclass.
17 25
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 26# In case the variable is not set in the ebuild, let virtualx eclass not do anything
27: ${VIRTUALX_REQUIRED:=manual}
19 28
20kde4-base_set_qt_dependencies() { 29inherit kde4-functions base virtualx eutils
21 local qt qtcore qtgui qt3support qtsvg qttest qtopengl qtdepend qtopengldepend
22 30
23 # use dependencies 31get_build_type
32if [[ ${BUILD_TYPE} = live ]]; then
33 if [[ ${KDEBASE} = kdevelop ]]; then
34 inherit git
35 else
36 inherit subversion
37 fi
38fi
39
40# @ECLASS-VARIABLE: CMAKE_REQUIRED
41# @DESCRIPTION:
42# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
43# Please note that if it's set to 'never' you need to explicitly override following phases:
44# src_configure, src_compile, src_test and src_install.
45# Defaults to 'always'.
46: ${CMAKE_REQUIRED:=always}
47if [[ ${CMAKE_REQUIRED} = always ]]; then
48 buildsystem_eclass="cmake-utils"
49 export_fns="src_configure src_compile src_test src_install"
50fi
51
52# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
53if [[ -n ${KDE_MINIMAL} ]]; then
54 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
55 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
56 done
57 unset slot
58 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
59else
60 KDE_MINIMAL_VALID=1
61fi
62
63# @ECLASS-VARIABLE: KDE_MINIMAL
64# @DESCRIPTION:
65# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
66# version for apps to work. Currently defaults to 4.4
67# One may override this variable to raise version requirements.
68# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
69# Note that it is fixed to ${SLOT} for kde-base packages.
70KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
71
72# Set slot for packages in kde-base, koffice and kdevelop
73case ${KDEBASE} in
74 kde-base)
75 # Determine SLOT from PVs
24 case "${EAPI}" in 76 case ${PV} in
25 kdebuild-1) 77 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
26 qt="[accessibility][dbus][debug?][gif][jpeg][png][qt3support][ssl][zlib]" 78 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;;
27 qtcore="[debug?][qt3support][ssl]" 79 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;;
28 qtgui="[accessibility][dbus][debug?]" 80 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;;
29 qt3support="[accessibility][debug?]" 81 9999*) SLOT="live" ;; # regular live
30 qtsvg="[debug?]" 82 *) die "Unsupported ${PV}" ;;
31 qttest="[debug?]"
32 qtopengl="[debug?]"
33 case "${OPENGL_REQUIRED}" in
34 always)
35 qt="${qt}[opengl]"
36 ;;
37 optional)
38 qt="${qt}[opengl?]"
39 ;;
40 esac 83 esac
84 KDE_MINIMAL="${SLOT}"
41 ;; 85 ;;
86 koffice)
87 SLOT="2"
88 ;;
89 kdevelop)
90 if [[ ${BUILD_TYPE} = live ]]; then
91 # @ECLASS-VARIABLE: KDEVELOP_VERSION
92 # @DESCRIPTION:
93 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
94 # Applies to KDEBASE=kdevelop only.
95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
96 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
97 # @DESCRIPTION:
98 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
99 # Applies to KDEBASE=kdevelop only.
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
101 else
102 case ${PN} in
103 kdevelop|quanta)
104 KDEVELOP_VERSION=${PV}
105 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
106 ;;
107 kdevplatform)
108 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
109 KDEVPLATFORM_VERSION=${PV}
110 ;;
111 *)
112 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
113 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
114 esac
115 fi
116 SLOT="4"
117 ;;
42 esac 118esac
43 119
44 # split qt 120slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
45 qtdepend="
46 x11-libs/qt-core:4${qtcore}
47 x11-libs/qt-gui:4${qtgui}
48 x11-libs/qt-qt3support:4${qt3support}
49 x11-libs/qt-svg:4${qtsvg}
50 x11-libs/qt-test:4${qttest}"
51 qtopengldepend="x11-libs/qt-opengl:4${qtopengl}"
52 121
53 # allow monolithic qt for PV < 4.1 122inherit ${buildsystem_eclass}
54 case "${PV}" in
55 scm|9999.4|4.1*) : ;;
56 *)
57 qtdepend="|| ( ( ${qtdepend} ) >=x11-libs/qt-4.3.3:4${qt} )"
58 qtopengldepend="|| ( ${qtopengldepend} >=x11-libs/qt-4.3.3:4 )"
59 ;;
60 esac
61 123
62 # opengl dependencies 124EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
63 case "${OPENGL_REQUIRED}" in
64 always)
65 qtdepend="${qtdepend}
66 ${qtopengldepend}"
67 ;;
68 optional)
69 IUSE="${IUSE} opengl"
70 qtdepend="${qtdepend}
71 opengl? ( ${qtopengldepend} )"
72 ;;
73 *)
74 OPENGL_REQUIRED="never"
75 ;;
76 esac
77 125
78 COMMONDEPEND="${COMMONDEPEND} ${qtdepend}" 126unset buildsystem_eclass
79} 127unset export_fns
80kde4-base_set_qt_dependencies
81 128
82DEPEND="${DEPEND} ${COMMONDEPEND} 129# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
83 >=dev-util/cmake-2.4.7-r1 130# @DESCRIPTION:
84 dev-util/pkgconfig 131# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
85 x11-libs/libXt 132# This variable must be set before inheriting any eclasses. Defaults to 'never'.
86 x11-proto/xf86vidmodeproto" 133DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
87RDEPEND="${RDEPEND} ${COMMONDEPEND}" 134
135# @ECLASS-VARIABLE: QTHELP_REQUIRED
136# @DESCRIPTION:
137# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
138# This variable must be set before inheriting any eclasses. Defaults to 'never'.
139QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
88 140
89# @ECLASS-VARIABLE: OPENGL_REQUIRED 141# @ECLASS-VARIABLE: OPENGL_REQUIRED
90# @DESCRIPTION: 142# @DESCRIPTION:
91# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 143# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
92# This variable must be set before inheriting any eclasses. Defaults to 'never'. 144# This variable must be set before inheriting any eclasses. Defaults to 'never'.
93OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 145OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
94 146
147# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
148# @DESCRIPTION:
149# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
150# This variable must be set before inheriting any eclasses. Defaults to 'never'.
151MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
152
153# @ECLASS-VARIABLE: WEBKIT_REQUIRED
154# @DESCRIPTION:
155# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
156# This variable must be set before inheriting any eclasses. Defaults to 'never'.
157WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
158
95# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 159# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
96# @DESCRIPTION: 160# @DESCRIPTION:
97# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 161# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
98# This variable must be set before inheriting any eclasses. Defaults to 'never'. 162# This variable must be set before inheriting any eclasses. Defaults to 'never'.
99CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 163CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
100 164
101case "${CPPUNIT_REQUIRED}" in 165# @ECLASS-VARIABLE: KDE_REQUIRED
166# @DESCRIPTION:
167# Is kde required? Possible values are 'always', 'optional' and 'never'.
168# This variable must be set before inheriting any eclasses. Defaults to 'always'
169# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
170# Note that for kde-base packages this variable is fixed to 'always'.
171KDE_REQUIRED="${KDE_REQUIRED:-always}"
172
173# @ECLASS-VARIABLE: KDE_HANDBOOK
174# @DESCRIPTION:
175# Set to enable handbook in application. Possible values are 'always', 'optional'
176# (handbook USE flag) and 'never'.
177# This variable must be set before inheriting any eclasses. Defaults to 'never'.
178# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
179# ensures buildtime and runtime dependencies.
180KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
181
182# Setup packages inheriting this eclass
183case ${KDEBASE} in
184 kde-base)
185 HOMEPAGE="http://www.kde.org/"
186 LICENSE="GPL-2"
187 if [[ $BUILD_TYPE = live ]]; then
188 # Disable tests for live ebuilds
189 RESTRICT+=" test"
190 # Live ebuilds in kde-base default to kdeprefix by default
191 IUSE+=" +kdeprefix"
192 else
193 # All other ebuild types default to -kdeprefix as before
194 IUSE+=" kdeprefix"
195 fi
196 # This code is to prevent portage from searching GENTOO_MIRRORS for
197 # packages that will never be mirrored. (As they only will ever be in
198 # the overlay).
199 case ${PV} in
200 *9999* | 4.?.[6-9]?)
201 RESTRICT+=" mirror"
202 ;;
203 esac
204 # Block installation of other SLOTS unless kdeprefix
205 RDEPEND+=" $(block_other_slots)"
206 ;;
207 koffice)
208 HOMEPAGE="http://www.koffice.org/"
209 LICENSE="GPL-2"
210 ;;
211 kdevelop)
212 HOMEPAGE="http://www.kdevelop.org/"
213 LICENSE="GPL-2"
214 ;;
215esac
216
217# @ECLASS-VARIABLE: QT_MINIMAL
218# @DESCRIPTION:
219# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1...
220# 4.6.0 for 4.4, 4.6.3 for 4.5, and 4.7.0 for 4.6 and later
221if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
222 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
223elif slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
224 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
225else
226 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
227fi
228
229# Declarative dependencies
230qtdeclarativedepend="
231 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
232"
233case ${DECLARATIVE_REQUIRED} in
102 always) 234 always)
103 DEPEND="${DEPEND} dev-util/cppunit" 235 COMMONDEPEND+=" ${qtdeclarativedepend}"
104 ;; 236 ;;
105 optional) 237 optional)
106 IUSE="${IUSE} test" 238 IUSE+=" declarative"
107 DEPEND="${DEPEND} 239 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
108 test? ( dev-util/cppunit )"
109 ;; 240 ;;
110 *) 241 *) ;;
111 CPPUNIT_REQUIRED="never" 242esac
243unset qtdeclarativedepend
244
245# QtHelp dependencies
246qthelpdepend="
247 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
248"
249case ${QTHELP_REQUIRED} in
250 always)
251 COMMONDEPEND+=" ${qthelpdepend}"
112 ;; 252 ;;
253 optional)
254 IUSE+=" qthelp"
255 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
256 ;;
113esac 257esac
258unset qthelpdepend
114 259
115# @ECLASS-VARIABLE: NEED_KDE 260# OpenGL dependencies
261qtopengldepend="
262 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
263"
264case ${OPENGL_REQUIRED} in
265 always)
266 COMMONDEPEND+=" ${qtopengldepend}"
267 ;;
268 optional)
269 IUSE+=" opengl"
270 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
271 ;;
272 *) ;;
273esac
274unset qtopengldepend
275
276# MultiMedia dependencies
277qtmultimediadepend="
278 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
279"
280case ${MULTIMEDIA_REQUIRED} in
281 always)
282 COMMONDEPEND+=" ${qtmultimediadepend}"
283 ;;
284 optional)
285 IUSE+=" multimedia"
286 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
287 ;;
288 *) ;;
289esac
290unset qtmultimediadepend
291
292# WebKit dependencies
293case ${KDE_REQUIRED} in
294 always)
295 qtwebkitusedeps="[kde]"
296 ;;
297 optional)
298 qtwebkitusedeps="[kde?]"
299 ;;
300 *) ;;
301esac
302qtwebkitdepend="
303 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
304"
305unset qtwebkitusedeps
306case ${WEBKIT_REQUIRED} in
307 always)
308 COMMONDEPEND+=" ${qtwebkitdepend}"
309 ;;
310 optional)
311 IUSE+=" webkit"
312 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
313 ;;
314 *) ;;
315esac
316unset qtwebkitdepend
317
318# CppUnit dependencies
319cppuintdepend="
320 dev-util/cppunit
321"
322case ${CPPUNIT_REQUIRED} in
323 always)
324 DEPEND+=" ${cppuintdepend}"
325 ;;
326 optional)
327 IUSE+=" test"
328 DEPEND+=" test? ( ${cppuintdepend} )"
329 ;;
330 *) ;;
331esac
332unset cppuintdepend
333
334# KDE dependencies
335# Qt accessibility classes are needed in various places, bug 325461
336kdecommondepend="
337 dev-lang/perl
338 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
339 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
340 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
341 >=x11-libs/qt-script-${QT_MINIMAL}:4
342 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
343 >=x11-libs/qt-svg-${QT_MINIMAL}:4
344 >=x11-libs/qt-test-${QT_MINIMAL}:4
345 !aqua? (
346 x11-libs/libXext
347 x11-libs/libXt
348 x11-libs/libXxf86vm
349 )
350"
351
352if [[ ${PN} != kdelibs ]]; then
353 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
354 if [[ ${KDEBASE} = kdevelop ]]; then
355 if [[ ${PN} != kdevplatform ]]; then
356 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
116# @DESCRIPTION: 357 # @DESCRIPTION:
117# This variable sets the version of KDE4 which will be used by the eclass. 358 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
118# This variable must be set by the ebuild, for all categories except for "kde-base". 359 # Applies to KDEBASE=kdevelop only.
119# For kde-base packages, if it is not set by the ebuild, 360 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
120# it's assumed that the required KDE4 version is the latest, non-live, available. 361 case ${KDEVPLATFORM_REQUIRED} in
121# 362 always)
122# @CODE 363 kdecommondepend+="
123# Acceptable values are: 364 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
124# - latest - Use latest version in the portage tree 365 "
125# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 366 ;;
126# - svn - Use svn release (live ebuilds) 367 *) ;;
127# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value. 368 esac
128# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value. 369 fi
129# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
130# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
131# @CODE
132#
133# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
134# koffice, so you must set it explicitly in the ebuild, in all other cases.
135if [[ -z ${NEED_KDE} ]]; then
136 if [[ -n ${KDEBASE} ]]; then
137 NEED_KDE="latest"
138 else
139 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
140 fi 370 fi
141fi 371fi
142export NEED_KDE 372kdedepend="
373 dev-util/automoc
374 dev-util/pkgconfig
375 !aqua? (
376 >=x11-libs/libXtst-1.1.0
377 x11-proto/xf86vidmodeproto
378 )
379"
380kderdepend=""
143 381
144case ${NEED_KDE} in
145 latest)
146 # Should only be used by 'kde-base'-ebuilds
147 if [[ "${KDEBASE}" == "kde-base" ]]; then
148 case ${PV} in
149 3.9*) _kdedir="3.9" ;;
150 4*) _kdedir="4.0" ;;
151 *) die "NEED_KDE=latest not supported for PV=${PV}" ;;
152 esac
153 _operator=">="
154 _pv="-${PV}:kde-4"
155 else
156 _kdedir="4.0"
157 _pv=":kde-4"
158 fi
159 ;;
160 scm|svn|9999*|:kde-svn)
161 _kdedir="svn"
162 _pv=":kde-svn"
163 export NEED_KDE="svn"
164 ;;
165 *:kde-svn)
166 _kdedir="svn"
167 _operator=">="
168 _pv="-${NEED_KDE}"
169 export NEED_KDE="svn"
170 ;;
171 # The ebuild handles dependencies, KDEDIR, SLOT.
172 none)
173 :
174 ;;
175 # NEED_KDE=":${SLOT}"
176 :kde-4)
177 _kdedir="4.0"
178 _pv="${NEED_KDE}"
179 ;;
180 # NEED_KDE="${PV}:${SLOT}"
181 *:kde-4)
182 _kdedir="4.0"
183 _operator=">="
184 _pv="-${NEED_KDE}"
185 ;;
186 3.9*)
187 _kdedir="3.9"
188 _operator=">="
189 _pv="-${NEED_KDE}:kde-4"
190 ;;
191 4*)
192 _kdedir="4.0"
193 _operator=">="
194 _pv="-${NEED_KDE}:kde-4"
195 ;;
196 *) die "NEED_KDE=${NEED_KDE} currently not supported."
197 ;;
198esac
199
200if [[ ${NEED_KDE} != none ]]; then
201 KDEDIR="/usr/kde/${_kdedir}"
202 KDEDIRS="/usr:/usr/local:${KDEDIR}"
203
204 if [[ -n ${KDEBASE} ]]; then
205 if [[ ${NEED_KDE} = svn ]]; then
206 SLOT="kde-svn"
207 else
208 SLOT="kde-4"
209 fi
210 fi
211
212 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs"
213 if [[ ${PN} != "kdelibs" ]]; then 382if [[ ${PN} != oxygen-icons ]]; then
214 DEPEND="${DEPEND} 383 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
215 ${_operator}kde-base/kdelibs${_pv}"
216 RDEPEND="${RDEPEND}
217 ${_operator}kde-base/kdelibs${_pv}"
218 if [[ ${PN} != "kdepimlibs" ]]; then
219 DEPEND="${DEPEND}
220 ${_operator}kde-base/kdepimlibs${_pv}"
221 RDEPEND="${RDEPEND}
222 ${_operator}kde-base/kdepimlibs${_pv}"
223 fi
224 fi
225
226 unset _operator _pv _kdedir
227fi 384fi
385
386kdehandbookdepend="
387 app-text/docbook-xml-dtd:4.2
388 app-text/docbook-xsl-stylesheets
389"
390kdehandbookrdepend="
391 $(add_kdebase_dep kdelibs 'handbook')
392"
393case ${KDE_HANDBOOK} in
394 always)
395 kdedepend+=" ${kdehandbookdepend}"
396 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
397 ;;
398 optional)
399 IUSE+=" +handbook"
400 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
401 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
402 ;;
403 *) ;;
404esac
405unset kdehandbookdepend kdehandbookrdepend
406
407case ${KDE_REQUIRED} in
408 always)
409 IUSE+=" aqua"
410 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
411 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
412 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
413 ;;
414 optional)
415 IUSE+=" aqua kde"
416 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
417 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
418 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
419 ;;
420 *) ;;
421esac
422
423unset kdecommondepend kdedepend kderdepend
424
425debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
426debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
427debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
428
429# Accumulate dependencies set by this eclass
430DEPEND+=" ${COMMONDEPEND}"
431RDEPEND+=" ${COMMONDEPEND}"
432unset COMMONDEPEND
433
434# Add experimental kdeenablefinal, disabled by default
435IUSE+=" kdeenablefinal"
228 436
229# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 437# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
230# koffice ebuild, the URI should be set in the ebuild itself 438# koffice ebuild, the URI should be set in the ebuild itself
231if [[ -n ${KDEBASE} ]]; then 439case ${BUILD_TYPE} in
440 live)
441 SRC_URI=""
442 if has subversion ${INHERITED}; then
443 # Determine branch URL based on live type
444 local branch_prefix
445 case ${PV} in
446 9999*)
447 # trunk
448 branch_prefix="trunk/KDE"
449 ;;
450 *)
451 # branch
452 branch_prefix="branches/KDE/${SLOT}"
453 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
454 # @DESCRIPTION
455 # Suffix appended to ESVN_PROJECT depending on fetched branch.
456 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
457 ESVN_PROJECT_SUFFIX="-${PV}"
458 ;;
459 esac
460 # @ECLASS-VARIABLE: ESVN_MIRROR
461 # @DESCRIPTION:
462 # This variable allows easy overriding of default kde mirror service
463 # (anonsvn) with anything else you might want to use.
464 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
465 # Split ebuild, or extragear stuff
232 if [[ -n ${KMNAME} ]]; then 466 if [[ -n ${KMNAME} ]]; then
467 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
468 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
469 KMMODULE="${PN}"
470 fi
471 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
472 case ${KMNAME} in
473 kdebase-*)
474 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
475 ;;
476 kdelibs-*)
477 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
478 ;;
479 kdereview*)
480 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
481 ;;
482 kdesupport)
483 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
484 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
485 ;;
486 kde*)
487 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
488 ;;
489 extragear*|playground*)
490 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
491 # build packages from same svn location.
492 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
493 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
494 ;;
495 koffice)
496 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
497 ;;
498 *)
499 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
500 ;;
501 esac
502 else
503 # kdelibs, kdepimlibs
504 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
505 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
506 fi
507 # @ECLASS-VARIABLE: ESVN_UP_FREQ
508 # @DESCRIPTION:
509 # This variable is used for specifying the timeout between svn synces
510 # for kde-base and koffice modules. Does not affect misc apps.
511 # Default value is 1 hour.
512 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
513 elif has git ${INHERITED}; then
514 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
515 KMMODULE="${PN}"
516 fi
517 case ${KDEBASE} in
518 kdevelop)
519 EGIT_REPO_URI="git://git.kde.org/${KMMODULE}"
520 ;;
521 esac
522 fi
523 ;;
524 *)
525 if [[ -n ${KDEBASE} ]]; then
526 if [[ -n ${KMNAME} ]]; then
527 case ${KMNAME} in
528 kdebase-apps)
529 _kmname="kdebase" ;;
530 *)
233 _kmname=${KMNAME} 531 _kmname="${KMNAME}" ;;
532 esac
533 else
534 _kmname=${PN}
535 fi
536 _kmname_pv="${_kmname}-${PV}"
537 case ${KDEBASE} in
538 kde-base)
539 case ${PV} in
540 4.5.93)
541 # Only kdepim and kdepim-runtime 4.6beta here
542 SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname}-4.6beta3.tar.bz2"
543 ;;
544 4.[456].8[05] | 4.[456].9[023568])
545 # Unstable KDE SC releases
546 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
547 ;;
548 4.4.6 | 4.4.7 | 4.4.8 | 4.4.9 | 4.4.10)
549 # Only kdepim here
550 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
551 ;;
552 *)
553 # Stable KDE SC releases
554 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
555 ;;
556 esac
557 ;;
558 koffice)
559 case ${PV} in
560 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
561 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
562 esac
563 ;;
564 kdevelop)
565 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
566 ;;
567 esac
568 unset _kmname _kmname_pv
569 fi
570 ;;
571esac
572
573debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
574
575# @ECLASS-VARIABLE: PREFIX
576# @DESCRIPTION:
577# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
578# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
579# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
580
581# @FUNCTION: kde4-base_pkg_setup
582# @DESCRIPTION:
583# Do the basic kdeprefix KDEDIR settings and determine with which kde should
584# optional applications link
585kde4-base_pkg_setup() {
586 debug-print-function ${FUNCNAME} "$@"
587
588 # Prefix compat:
589 if [[ ${EAPI} == 2 ]] && ! use prefix; then
590 EPREFIX=
591 EROOT=${ROOT}
592 fi
593
594 # Append missing trailing slash character
595 [[ ${EROOT} = */ ]] || EROOT+="/"
596
597 # QA ebuilds
598 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
599
600 # Don't set KDEHOME during compilation, it will cause access violations
601 unset KDEHOME
602
603 if [[ ${KDEBASE} = kde-base ]]; then
604 if use kdeprefix; then
605 KDEDIR=/usr/kde/${SLOT}
606 else
607 KDEDIR=/usr
608 fi
609 : ${PREFIX:=${KDEDIR}}
234 else 610 else
235 _kmname=${PN} 611 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
612 KDEDIR=
613 local kde_minimal_met
614 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
615 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
616 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
617 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
618 KDEDIR=/usr/kde/${slot}
619 else
620 KDEDIR=/usr
621 fi
622 break;
623 fi
624 done
625 unset slot
626
627 # Bail out if kdelibs required but not found
628 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
629 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
630 else
631 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
236 fi 632 fi
237 _kmname_pv="${_kmname}-${PV}" 633
238 if [[ ${NEED_KDE} != "svn" ]]; then 634 : ${PREFIX:=/usr}
239 case ${KDEBASE} in 635 fi
240 kde-base) 636 EKDEDIR=${EPREFIX}${KDEDIR}
637
638 # Point pkg-config path to KDE *.pc files
639 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
640 # Point to correct QT plugins path
641 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
642
643 # Fix XDG collision with sandbox
644 export XDG_CONFIG_HOME="${T}"
645}
646
647# @FUNCTION: kde4-base_src_unpack
648# @DESCRIPTION:
649# This function unpacks the source tarballs for KDE4 applications.
650kde4-base_src_unpack() {
651 debug-print-function ${FUNCNAME} "$@"
652
653 if [[ ${BUILD_TYPE} = live ]]; then
654 if has subversion ${INHERITED}; then
655 migrate_store_dir
656 subversion_src_unpack
657 elif has git ${INHERITED}; then
658 git_src_unpack
659 fi
660 elif [[ ${EAPI} == 2 ]]; then
661 local file
662 for file in ${A}; do
663 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
664 # directly, so we do it ourselves (using the exact same code as portage)
241 case ${PV} in 665 case ${file} in
242 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 666 *.tar.xz)
667 echo ">>> Unpacking ${file} to ${PWD}"
668 xz -dc "${DISTDIR}"/${file} | tar xof -
669 assert "failed unpacking ${file}"
670 ;;
671 *)
672 unpack ${file}
673 ;;
243 esac 674 esac
244 ;;
245 koffice)
246 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2"
247 ;;
248 esac
249 fi
250 unset _kmname _kmname_pv
251fi
252
253debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
254debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
255
256# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
257# If KMNAME is not set then this is not a split package
258if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
259 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
260 DEPEND="${DEPEND} !${_x}:${SLOT}"
261 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
262 done 675 done
263 unset _x
264fi
265
266debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
267
268# @ECLASS-VARIABLE: PREFIX
269# @DESCRIPTION:
270# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
271# Applications installed by the other ebuilds go into /usr/ by default, this value
272# can be superseded by defining PREFIX before inheriting kde4-base.
273if [[ -n ${KDEBASE} ]]; then
274 PREFIX=${KDEDIR}
275else
276 # if PREFIX is not defined we set it to the default value of /usr
277 PREFIX="${PREFIX:-/usr}"
278fi
279
280debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
281
282# @FUNCTION: kde4-base_pkg_setup
283# @DESCRIPTION:
284# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
285# kde4-functions_check_use from kde4-functions.eclass to print appropriate
286# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
287# $KDE4_BUILT_WITH_USE_CHECK are missing.
288kde4-base_pkg_setup() {
289 debug-print-function $FUNCNAME "$@"
290
291 case "${EAPI}" in
292 kdebuild-1)
293 [[ -n ${QT4_BUILT_WITH_USE_CHECK} || -n ${KDE4_BUILT_WITH_USE_CHECK} ]] && \
294 die "built_with_use illegal in this EAPI!"
295 ;;
296 *)
297 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
298 if has_version '<x11-libs/qt-4.4_alpha:4'; then
299 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
300 else 676 else
301 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 677 # For EAPI >= 3, we can just use unpack() directly
302 x11-libs/qt-core qt3support ssl 678 unpack ${A}
303 x11-libs/qt-gui accessibility dbus
304 x11-libs/qt-qt3support accessibility"
305 fi 679 fi
306
307 if has debug ${IUSE//+} && use debug; then
308 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
309 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug"
310 else
311 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
312 x11-libs/qt-core:4 debug
313 x11-libs/qt-gui:4 debug
314 x11-libs/qt-qt3support:4 debug
315 x11-libs/qt-svg:4 debug
316 x11-libs/qt-test:4 debug"
317 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
318 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
319 x11-libs/qt-opengl:4 debug"
320 fi
321 fi
322 fi
323
324 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
325 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
326 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
327 fi
328 fi
329 kde4-functions_check_use
330 ;;
331 esac
332} 680}
333 681
334# @FUNCTION: kde4-base_apply_patches
335# @DESCRIPTION:
336# This function applies patches.
337#
338# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
339# directory, provided they follow this format:
340# @CODE
341# - Monolithic ebuilds, (from kde-base)
342# - $CATEGORY=kde-base:
343# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
344# - $CATEGORY=!kde-base:
345# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
346# - Split ebuilds:
347# - $CATEGORY=kde-base:
348# Apply ${PN}-${SLOT}-*{diff,patch}
349# - $CATEGORY!=kde-base:
350# Apply ${PN}-${PV}-*{diff,patch}
351# @CODE
352#
353# If ${PATCHES} is non-zero all patches in it get applied. If there is more
354# than one patch please make ${PATCHES} an array for proper quoting.
355kde4-base_apply_patches() {
356 local _patchdir _packages _p
357 _patchdir="${WORKDIR}/patches/"
358 if [[ -d "${_patchdir}" ]]; then
359 if is-parent-package ${CATEGORY}/${PN} ; then
360 _packages="$(get-child-packages ${CATEGORY}/${PN})"
361 _packages="${_packages//${CATEGORY}\//} ${PN}"
362 else
363 _packages="${PN}"
364 fi
365 if [[ ${#PATCHES[@]} -gt 1 ]]; then
366 for _p in ${_packages}; do
367 PATCHES=( "${PATCHES[@]}" $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null) )
368 if [[ -n "${KDEBASE}" ]]; then
369 PATCHES=( "${PATCHES[@]}" $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null) )
370 fi
371 done
372 else
373 for _p in ${_packages}; do
374 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
375 if [[ -n "${KDEBASE}" ]]; then
376 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
377 fi
378 done
379 fi
380 fi
381 [[ -n ${PATCHES[@]} ]] && base_src_unpack autopatch
382}
383
384# @FUNCTION: kde4-base_src_unpack 682# @FUNCTION: kde4-base_src_prepare
385# @DESCRIPTION: 683# @DESCRIPTION:
386# This function unpacks the source tarballs for KDE4 applications. 684# General pre-configure and pre-compile function for KDE4 applications.
387#
388# If no argument is passed to this function, then standard src_unpack is
389# executed. Otherwise options are passed to base_src_unpack.
390#
391# In addition it calls kde4-base_apply_patches when no arguments are passed to
392# this function.
393#
394# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and 685# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
686# enable_selected_linguas() and enable_selected_doc_linguas()
395# enable_selected_linguas() in kde4-functions.eclass(5) for further details. 687# in kde4-functions.eclass(5) for further details.
396kde4-base_src_unpack() { 688kde4-base_src_prepare() {
397 debug-print-function $FUNCNAME "$@" 689 debug-print-function ${FUNCNAME} "$@"
398
399 [[ -z "${KDE_S}" ]] && KDE_S="${S}"
400
401 if [[ -z $* ]]; then
402 # Unpack first and deal with KDE patches after examing possible patch sets.
403 # To be picked up, patches need to conform to the guidelines stated before.
404 # Monolithic ebuilds will use the split ebuild patches.
405 [[ -d "${KDE_S}" ]] || unpack ${A}
406 kde4-base_apply_patches
407 else
408 # Call base_src_unpack, which unpacks and patches
409 # step by step transparently as defined in the ebuild.
410 base_src_unpack $*
411 fi
412
413 # Updated cmake dir
414 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then
415 ebegin "Updating cmake/ directory..."
416 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory"
417 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory"
418 eend 0
419 fi
420 690
421 # Only enable selected languages, used for KDE extragear apps. 691 # Only enable selected languages, used for KDE extragear apps.
422 if [[ -n ${KDE_LINGUAS} ]]; then 692 if [[ -n ${KDE_LINGUAS} ]]; then
423 enable_selected_linguas 693 enable_selected_linguas
424 fi 694 fi
695
696 # Enable/disable handbooks for kde4-base packages
697 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
698 # kdelibs inherits kde4-base but handle installing the handbook itself
699 if ! has kde4-meta ${INHERITED}; then
700 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
701 fi
702
703 # SCM bootstrap
704 if [[ ${BUILD_TYPE} = live ]]; then
705 if has subversion ${INHERITED}; then
706 subversion_src_prepare
707 elif has git ${INHERITED}; then
708 git_src_prepare
709 fi
710 fi
711
712 # Apply patches
713 base_src_prepare
714
715 # Save library dependencies
716 if [[ -n ${KMSAVELIBS} ]] ; then
717 save_library_dependencies
718 fi
719
720 # Inject library dependencies
721 if [[ -n ${KMLOADLIBS} ]] ; then
722 load_library_dependencies
723 fi
724
725 # Replace KDE4Workspace library targets
726 find "${S}" -name CMakeLists.txt \
727 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
728 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
729 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
730 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
731 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
732 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
733 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
734 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
735 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
736 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
737 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
738 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
739 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
740 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
741 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
742 || die 'failed to replace KDE4Workspace library targets'
743
744 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
745 if [[ -z ${KDEBASE} ]]; then
746 find "${S}" -name "*.docbook" \
747 -exec sed -i -r \
748 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
749 || die 'failed to fix DocBook variant version'
750 fi
751}
752
753# @FUNCTION: kde4-base_src_configure
754# @DESCRIPTION:
755# Function for configuring the build of KDE4 applications.
756kde4-base_src_configure() {
757 debug-print-function ${FUNCNAME} "$@"
758
759 # Build tests in src_test only, where we override this value
760 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
761
762 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
763 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
764 fi
765
766 if has debug ${IUSE//+} && use debug; then
767 # Set "real" debug mode
768 CMAKE_BUILD_TYPE="Debugfull"
769 else
770 # Handle common release builds
771 append-cppflags -DQT_NO_DEBUG
772 fi
773
774 # Set distribution name
775 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
776
777 # Here we set the install prefix
778 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
779
780 # Use colors
781 QTEST_COLORED=1
782
783 # Shadow existing /usr installations
784 unset KDEDIRS
785
786 # Handle kdeprefix-ed KDE
787 if [[ ${KDEDIR} != /usr ]]; then
788 # Override some environment variables - only when kdeprefix is different,
789 # to not break ccache/distcc
790 PATH="${EKDEDIR}/bin:${PATH}"
791
792 # Append library search path
793 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
794
795 # Append full RPATH
796 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
797
798 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
799 # when more are present
800 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
801 fi
802
803 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
804 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
805 #kde-config -path data unavailable when cross-compiling
806 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
807
808 # Handle kdeprefix in application itself
809 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
810 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
811 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
812 fi
813
814 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
815 mycmakeargs=(${mycmakeargs})
816 fi
817
818 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
819
820 cmake-utils_src_configure
425} 821}
426 822
427# @FUNCTION: kde4-base_src_compile 823# @FUNCTION: kde4-base_src_compile
428# @DESCRIPTION: 824# @DESCRIPTION:
429# General function for compiling KDE4 applications. 825# General function for compiling KDE4 applications.
430kde4-base_src_compile() { 826kde4-base_src_compile() {
431 debug-print-function ${FUNCNAME} "$@" 827 debug-print-function ${FUNCNAME} "$@"
432 828
433 kde4-base_src_configure
434 kde4-base_src_make
435}
436
437# @FUNCTION: kde4-base_src_configure
438# @DESCRIPTION:
439# Function for configuring the build of KDE4 applications.
440kde4-base_src_configure() {
441 debug-print-function ${FUNCNAME} "$@"
442
443 # Final flag handling
444 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
445 echo "Activating enable-final flag"
446 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
447 fi
448
449 # Enable generation of HTML handbook
450 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
451 echo "Enabling building of HTML handbook"
452 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
453 fi
454
455 # Build tests in src_test only, where we override this value
456 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
457
458 # Set distribution name
459 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
460
461 # runpath linking
462 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
463
464 # Here we set the install prefix
465 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
466
467 # Set environment
468 QTEST_COLORED=1
469 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
470
471 cmake-utils_src_configureout
472}
473
474# @FUNCTION: kde4-base_src_make
475# @DESCRIPTION:
476# Function for building KDE4 applications.
477# Options are passed to cmake-utils_src_make.
478kde4-base_src_make() {
479 debug-print-function ${FUNCNAME} "$@"
480
481 cmake-utils_src_make "$@" 829 cmake-utils_src_compile "$@"
482} 830}
483 831
484# @FUNCTION: kde4-base_src_test 832# @FUNCTION: kde4-base_src_test
485# @DESCRIPTION: 833# @DESCRIPTION:
486# Function for testing KDE4 applications. 834# Function for testing KDE4 applications.
487kde4-base_src_test() { 835kde4-base_src_test() {
488 debug-print-function ${FUNCNAME} "$@" 836 debug-print-function ${FUNCNAME} "$@"
489 837
490 # Override this value, set in kde4-base_src_configure() 838 # Override this value, set in kde4-base_src_configure()
491 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 839 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
492 cmake-utils_src_compile 840 cmake-utils_src_configure
841 kde4-base_src_compile
493 842
843 if [[ ${VIRTUALX_REQUIRED} == always ]] ||
844 ( [[ ${VIRTUALX_REQUIRED} != manual ]] && use test ); then
845
846 if [[ ${maketype} ]]; then
847 # surprise- we are already INSIDE virtualmake!!!
848 ewarn "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
849 ewarn " You may NOT set maketype or call virtualmake from the ebuild. Applying workaround."
850 cmake-utils_src_test
851 else
852 export maketype="cmake-utils_src_test"
853 virtualmake
854 fi
855 else
494 cmake-utils_src_test 856 cmake-utils_src_test
857 fi
495} 858}
496 859
497# @FUNCTION: kde4-base_src_install 860# @FUNCTION: kde4-base_src_install
498# @DESCRIPTION: 861# @DESCRIPTION:
499# Function for installing KDE4 applications. 862# Function for installing KDE4 applications.
500kde4-base_src_install() { 863kde4-base_src_install() {
501 debug-print-function ${FUNCNAME} "$@" 864 debug-print-function ${FUNCNAME} "$@"
502 865
503 kde4-base_src_make_doc 866 # Prefix support, for usage in ebuilds
867 if [[ ${EAPI} == 2 ]] && ! use prefix; then
868 ED=${D}
869 fi
870
871 if [[ -n ${KMSAVELIBS} ]] ; then
872 install_library_dependencies
873 fi
874
875 # Install common documentation of KDE4 applications
876 local doc
877 if ! has kde4-meta ${INHERITED}; then
878 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
879 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
880 done
881 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
882 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
883 done
884 fi
885
504 cmake-utils_src_install 886 cmake-utils_src_install
505} 887}
506 888
507# @FUNCTION: kde4-base_src_make_doc
508# @DESCRIPTION:
509# Function for installing the documentation of KDE4 applications.
510kde4-base_src_make_doc() {
511 debug-print-function ${FUNCNAME} "$@"
512
513 local doc
514 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
515 [[ -s $doc ]] && dodoc ${doc}
516 done
517
518 if [[ -z ${KMNAME} ]]; then
519 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
520 if [[ -s $doc ]]; then
521 local doc_complete=${doc}
522 doc="${doc#*/}"
523 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
524 fi
525 done
526 fi
527
528 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
529 # work around bug #97196
530 dodir /usr/share/doc/kde && \
531 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
532 die "Failed to move docs to kde/ failed."
533 fi
534}
535
536# @FUNCTION: kde4-base_pkg_postinst 889# @FUNCTION: kde4-base_pkg_postinst
537# @DESCRIPTION: 890# @DESCRIPTION:
538# Function to rebuild the KDE System Configuration Cache after an application has been installed. 891# Function to rebuild the KDE System Configuration Cache after an application has been installed.
539kde4-base_pkg_postinst() { 892kde4-base_pkg_postinst() {
893 debug-print-function ${FUNCNAME} "$@"
894
895 buildsycoca
896
897 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
898 echo
899 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
900 einfo "Use it at your own risk."
901 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
902 echo
903 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
904 # warning about kdeprefix for non-live users
905 echo
906 ewarn "WARNING! You have the kdeprefix useflag enabled."
907 ewarn "This setting is strongly discouraged and might lead to potential trouble"
908 ewarn "with KDE update strategies."
909 ewarn "You are using this setup at your own risk and the kde team does not"
910 ewarn "take responsibilities for dead kittens."
911 echo
912 fi
913 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
914 # warn about not supported approach
915 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
916 echo
917 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
918 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
919 ewarn "With this setting you are unsupported by KDE team."
920 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
921 fi
922 fi
923}
924
925# @FUNCTION: kde4-base_pkg_postrm
926# @DESCRIPTION:
927# Function to rebuild the KDE System Configuration Cache after an application has been removed.
928kde4-base_pkg_postrm() {
929 debug-print-function ${FUNCNAME} "$@"
930
540 buildsycoca 931 buildsycoca
541} 932}
542
543# @FUNCTION: kde4-base_pkg_postrm
544# @DESCRIPTION:
545# Function to rebuild the KDE System Configuration Cache after an application has been removed.
546kde4-base_pkg_postrm() {
547 buildsycoca
548}

Legend:
Removed from v.1.8  
changed lines
  Added in v.1.84

  ViewVC Help
Powered by ViewVC 1.1.20