/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.9 Revision 1.154
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2015 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.9 2008/04/06 21:36:53 zlin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.154 2015/06/03 22:36:30 mrueg Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds currently support EAPI 5. This will be
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# reviewed over time as new EAPI versions are approved.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16if [[ -z ${_KDE4_BASE_ECLASS} ]]; then
17_KDE4_BASE_ECLASS=1
17 18
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 19# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
20# @DESCRIPTION:
21# If set to "none", do nothing.
22# For any other value, add selinux to IUSE, and depending on that useflag
23# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
24: ${KDE_SELINUX_MODULE:=none}
19 25
20kde4-base_set_qt_dependencies() { 26# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
21 local qt qtcore qtgui qt3support qtsvg qttest qtopengl qtdepend qtopengldepend 27# @DESCRIPTION:
28# If defined, launch and use a private dbus session during src_test.
22 29
23 # use dependencies 30# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
24 case "${EAPI}" in 31# @DESCRIPTION:
25 kdebuild-1) 32# For proper description see virtualx.eclass manpage.
26 qt="[accessibility][dbus][debug?][gif][jpeg][png][qt3support][ssl][zlib]" 33# Here we redefine default value to be manual, if your package needs virtualx
27 qtcore="[debug?][qt3support][ssl]" 34# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
28 qtgui="[accessibility][dbus][debug?]" 35: ${VIRTUALX_REQUIRED:=manual}
29 qt3support="[accessibility][debug?]" 36
30 qtsvg="[debug?]" 37inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils virtualx versionator eutils multilib
31 qttest="[debug?]" 38
32 qtopengl="[debug?]" 39if [[ ${KDE_BUILD_TYPE} = live ]]; then
33 case "${OPENGL_REQUIRED}" in 40 case ${KDE_SCM} in
34 always) 41 svn) inherit subversion ;;
35 qt="${qt}[opengl]" 42 git) inherit git-r3 ;;
36 ;;
37 optional)
38 qt="${qt}[opengl?]"
39 ;;
40 esac
41 ;;
42 esac 43 esac
44fi
43 45
44 # split qt 46# @ECLASS-VARIABLE: CMAKE_REQUIRED
45 qtdepend=" 47# @DESCRIPTION:
46 x11-libs/qt-core:4${qtcore} 48# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
47 x11-libs/qt-gui:4${qtgui} 49# Please note that if it's set to 'never' you need to explicitly override following phases:
48 x11-libs/qt-qt3support:4${qt3support} 50# src_configure, src_compile, src_test and src_install.
49 x11-libs/qt-svg:4${qtsvg} 51# Defaults to 'always'.
50 x11-libs/qt-test:4${qttest}" 52: ${CMAKE_REQUIRED:=always}
51 qtopengldepend="x11-libs/qt-opengl:4${qtopengl}" 53if [[ ${CMAKE_REQUIRED} = always ]]; then
54 buildsystem_eclass="cmake-utils"
55 export_fns="src_configure src_compile src_test src_install"
56fi
52 57
53 # allow monolithic qt for PV < 4.1 58# @ECLASS-VARIABLE: KDE_MINIMAL
59# @DESCRIPTION:
60# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
61# version for apps to work. Currently defaults to 4.4
62# One may override this variable to raise version requirements.
63# Note that it is fixed to ${PV} for kde-base packages.
64KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
65
66# Set slot for KDEBASE known packages
67case ${KDEBASE} in
68 kde-base)
69 SLOT=4/$(get_version_component_range 1-2)
70 KDE_MINIMAL="${PV}"
71 ;;
72 kdevelop)
73 if [[ ${KDE_BUILD_TYPE} = live ]]; then
74 # @ECLASS-VARIABLE: KDEVELOP_VERSION
75 # @DESCRIPTION:
76 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
77 # Applies to KDEBASE=kdevelop only.
78 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.9999}"
79 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
80 # @DESCRIPTION:
81 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
82 # Applies to KDEBASE=kdevelop only.
83 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-4.9999}"
84 else
54 case "${PV}" in 85 case ${PN} in
55 scm|9999.4|4.1*) : ;; 86 kdevelop)
87 KDEVELOP_VERSION=${PV}
88 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
89 ;;
90 kdevplatform|kdevelop-php*|kdevelop-python)
91 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
92 KDEVPLATFORM_VERSION=${PV}
93 ;;
56 *) 94 *)
57 qtdepend="|| ( ( ${qtdepend} ) >=x11-libs/qt-4.3.3:4${qt} )" 95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
58 qtopengldepend="|| ( ${qtopengldepend} >=x11-libs/qt-4.3.3:4 )" 96 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
97 esac
98 fi
99 SLOT="4"
59 ;; 100 ;;
60 esac 101esac
61 102
62 # opengl dependencies 103inherit ${buildsystem_eclass}
63 case "${OPENGL_REQUIRED}" in
64 always)
65 qtdepend="${qtdepend}
66 ${qtopengldepend}"
67 ;;
68 optional)
69 IUSE="${IUSE} opengl"
70 qtdepend="${qtdepend}
71 opengl? ( ${qtopengldepend} )"
72 ;;
73 *)
74 OPENGL_REQUIRED="never"
75 ;;
76 esac
77 104
78 COMMONDEPEND="${COMMONDEPEND} ${qtdepend}" 105EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
79}
80kde4-base_set_qt_dependencies
81 106
82DEPEND="${DEPEND} ${COMMONDEPEND} 107unset buildsystem_eclass
83 >=dev-util/cmake-2.4.7-r1 108unset export_fns
84 dev-util/pkgconfig 109
85 x11-libs/libXt 110# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
86 x11-proto/xf86vidmodeproto" 111# @DESCRIPTION:
87RDEPEND="${RDEPEND} ${COMMONDEPEND}" 112# Is qtdeclarative required? Possible values are 'always', 'optional' and 'never'.
113# This variable must be set before inheriting any eclasses. Defaults to 'never'.
114DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
115
116# @ECLASS-VARIABLE: QTHELP_REQUIRED
117# @DESCRIPTION:
118# Is qthelp required? Possible values are 'always', 'optional' and 'never'.
119# This variable must be set before inheriting any eclasses. Defaults to 'never'.
120QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
88 121
89# @ECLASS-VARIABLE: OPENGL_REQUIRED 122# @ECLASS-VARIABLE: OPENGL_REQUIRED
90# @DESCRIPTION: 123# @DESCRIPTION:
91# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 124# Is qtopengl required? Possible values are 'always', 'optional' and 'never'.
92# This variable must be set before inheriting any eclasses. Defaults to 'never'. 125# This variable must be set before inheriting any eclasses. Defaults to 'never'.
93OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 126OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
127
128# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
129# @DESCRIPTION:
130# Is qtmultimedia required? Possible values are 'always', 'optional' and 'never'.
131# This variable must be set before inheriting any eclasses. Defaults to 'never'.
132MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
94 133
95# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 134# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
96# @DESCRIPTION: 135# @DESCRIPTION:
97# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 136# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
98# This variable must be set before inheriting any eclasses. Defaults to 'never'. 137# This variable must be set before inheriting any eclasses. Defaults to 'never'.
99CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 138CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
100 139
101case "${CPPUNIT_REQUIRED}" in 140# @ECLASS-VARIABLE: KDE_REQUIRED
141# @DESCRIPTION:
142# Is kde required? Possible values are 'always', 'optional' and 'never'.
143# This variable must be set before inheriting any eclasses. Defaults to 'always'
144# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
145# Note that for kde-base packages this variable is fixed to 'always'.
146KDE_REQUIRED="${KDE_REQUIRED:-always}"
147
148# @ECLASS-VARIABLE: KDE_HANDBOOK
149# @DESCRIPTION:
150# Set to enable handbook in application. Possible values are 'always', 'optional'
151# (handbook USE flag) and 'never'.
152# This variable must be set before inheriting any eclasses. Defaults to 'never'.
153# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
154# ensures buildtime and runtime dependencies.
155KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
156
157# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
158# @DESCRIPTION:
159# Set this varible if you want your live package to manage its
160# translations. (Mostly all kde ebuilds does not ship documentation
161# and translations in live ebuilds)
162if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
163 # Kdebase actualy provides the handbooks even for live stuff
164 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
165 KDE_LINGUAS=""
166fi
167
168# Setup packages inheriting this eclass
169case ${KDEBASE} in
170 kde-base)
171 HOMEPAGE="http://www.kde.org/"
172 LICENSE="GPL-2"
173 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
174 # Disable tests for live ebuilds by default
175 RESTRICT+=" test"
176 fi
177
178 # This code is to prevent portage from searching GENTOO_MIRRORS for
179 # packages that will never be mirrored. (As they only will ever be in
180 # the overlay).
181 case ${PV} in
182 *9999* | 4.?.[6-9]? | 4.??.[6-9]? | ??.?.[6-9]? | ??.??.[6-9]?)
183 RESTRICT+=" mirror"
184 ;;
185 esac
186 ;;
187 kdevelop)
188 HOMEPAGE="http://www.kdevelop.org/"
189 LICENSE="GPL-2"
190 ;;
191esac
192
193# @ECLASS-VARIABLE: QT_MINIMAL
194# @DESCRIPTION:
195# Determine version of qt we enforce as minimal for the package.
196QT_MINIMAL="${QT_MINIMAL:-4.8.5}"
197
198# Declarative dependencies
199qtdeclarativedepend="
200 >=dev-qt/qtdeclarative-${QT_MINIMAL}:4
201"
202case ${DECLARATIVE_REQUIRED} in
102 always) 203 always)
103 DEPEND="${DEPEND} dev-util/cppunit" 204 COMMONDEPEND+=" ${qtdeclarativedepend}"
104 ;; 205 ;;
105 optional) 206 optional)
106 IUSE="${IUSE} test" 207 IUSE+=" declarative"
107 DEPEND="${DEPEND} 208 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
108 test? ( dev-util/cppunit )"
109 ;; 209 ;;
210 *) ;;
211esac
212unset qtdeclarativedepend
213
214# QtHelp dependencies
215qthelpdepend="
216 >=dev-qt/qthelp-${QT_MINIMAL}:4
217"
218case ${QTHELP_REQUIRED} in
219 always)
220 COMMONDEPEND+=" ${qthelpdepend}"
221 ;;
222 optional)
223 IUSE+=" qthelp"
224 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
225 ;;
226esac
227unset qthelpdepend
228
229# OpenGL dependencies
230qtopengldepend="
231 >=dev-qt/qtopengl-${QT_MINIMAL}:4
232"
233case ${OPENGL_REQUIRED} in
234 always)
235 COMMONDEPEND+=" ${qtopengldepend}"
236 ;;
237 optional)
238 IUSE+=" opengl"
239 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
240 ;;
241 *) ;;
242esac
243unset qtopengldepend
244
245# MultiMedia dependencies
246qtmultimediadepend="
247 >=dev-qt/qtmultimedia-${QT_MINIMAL}:4
248"
249case ${MULTIMEDIA_REQUIRED} in
250 always)
251 COMMONDEPEND+=" ${qtmultimediadepend}"
252 ;;
253 optional)
254 IUSE+=" multimedia"
255 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
256 ;;
257 *) ;;
258esac
259unset qtmultimediadepend
260
261# CppUnit dependencies
262cppuintdepend="
263 dev-util/cppunit
264"
265case ${CPPUNIT_REQUIRED} in
266 always)
267 DEPEND+=" ${cppuintdepend}"
268 ;;
269 optional)
270 IUSE+=" test"
271 DEPEND+=" test? ( ${cppuintdepend} )"
272 ;;
273 *) ;;
274esac
275unset cppuintdepend
276
277# KDE dependencies
278# Qt accessibility classes are needed in various places, bug 325461
279kdecommondepend="
280 dev-lang/perl
281 >=dev-qt/qt3support-${QT_MINIMAL}:4[accessibility]
282 >=dev-qt/qtcore-${QT_MINIMAL}:4[qt3support,ssl]
283 >=dev-qt/qtdbus-${QT_MINIMAL}:4
284 >=dev-qt/designer-${QT_MINIMAL}:4
285 >=dev-qt/qtgui-${QT_MINIMAL}:4[accessibility,dbus(+)]
286 >=dev-qt/qtscript-${QT_MINIMAL}:4
287 >=dev-qt/qtsql-${QT_MINIMAL}:4[qt3support]
288 >=dev-qt/qtsvg-${QT_MINIMAL}:4
289 >=dev-qt/qttest-${QT_MINIMAL}:4
290 >=dev-qt/qtwebkit-${QT_MINIMAL}:4
291"
292
293if [[ ${PN} != kdelibs ]]; then
294 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
295 if [[ ${KDEBASE} = kdevelop ]]; then
296 if [[ ${PN} != kdevplatform ]]; then
297 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
298 # @DESCRIPTION:
299 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
300 # Applies to KDEBASE=kdevelop only.
301 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
302 case ${KDEVPLATFORM_REQUIRED} in
303 always)
304 kdecommondepend+="
305 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}:4
306 "
307 ;;
308 *) ;;
309 esac
310 fi
311 fi
312fi
313
314kdedepend="
315 dev-util/automoc
316 virtual/pkgconfig
317 !aqua? (
318 >=x11-libs/libXtst-1.1.0
319 x11-proto/xf86vidmodeproto
320 )
321"
322
323kderdepend=""
324
325if [[ ${CATEGORY} == kde-apps ]]; then
326 kderdepend+=" !kde-base/${PN}"
327fi
328
329# all packages needs oxygen icons for basic iconset
330if [[ ${PN} != oxygen-icons ]]; then
331 kderdepend+=" || ( kde-apps/oxygen-icons $(add_kdebase_dep oxygen-icons '' 4.14.3) )"
332fi
333
334# add a dependency over kde-l10n
335if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} ]]; then
336 for _lingua in ${KDE_LINGUAS}; do
337 # if our package has linguas, pull in kde-l10n with selected lingua enabled,
338 # but only for selected ones.
339 # this can't be done on one line because if user doesn't use any localisation
340 # then he is probably not interested in kde-l10n at all.
341 kderdepend+="
342 linguas_${_lingua}? ( || ( kde-apps/kde4-l10n[linguas_${_lingua}(+)] $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") ) )
343 "
344 done
345 unset _lingua
346fi
347
348kdehandbookdepend="
349 app-text/docbook-xml-dtd:4.2
350 app-text/docbook-xsl-stylesheets
351"
352kdehandbookrdepend="
353 $(add_kdebase_dep kdelibs 'handbook')
354"
355case ${KDE_HANDBOOK} in
356 always)
357 kdedepend+=" ${kdehandbookdepend}"
358 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
359 ;;
360 optional)
361 IUSE+=" +handbook"
362 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
363 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
364 ;;
365 *) ;;
366esac
367unset kdehandbookdepend kdehandbookrdepend
368
369case ${KDE_SELINUX_MODULE} in
370 none) ;;
110 *) 371 *)
111 CPPUNIT_REQUIRED="never" 372 IUSE+=" selinux"
373 kderdepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
112 ;; 374 ;;
113esac 375esac
114 376
115# @ECLASS-VARIABLE: NEED_KDE 377# We always need the aqua useflag because otherwise we cannot = refer to it inside
116# @DESCRIPTION: 378# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
117# This variable sets the version of KDE4 which will be used by the eclass. 379# (where referring to a use flag not in IUSE masks the ebuild).
118# This variable must be set by the ebuild, for all categories except for "kde-base". 380# The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
119# For kde-base packages, if it is not set by the ebuild, 381IUSE+=" aqua"
120# it's assumed that the required KDE4 version is the latest, non-live, available.
121#
122# @CODE
123# Acceptable values are:
124# - latest - Use latest version in the portage tree
125# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice.
126# - svn - Use svn release (live ebuilds)
127# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value.
128# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value.
129# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
130# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
131# @CODE
132#
133# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
134# koffice, so you must set it explicitly in the ebuild, in all other cases.
135if [[ -z ${NEED_KDE} ]]; then
136 if [[ -n ${KDEBASE} ]]; then
137 NEED_KDE="latest"
138 else
139 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
140 fi
141fi
142export NEED_KDE
143 382
144case ${NEED_KDE} in 383case ${KDE_REQUIRED} in
145 latest) 384 always)
146 # Should only be used by 'kde-base'-ebuilds 385 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
147 if [[ "${KDEBASE}" == "kde-base" ]]; then 386 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
148 case ${PV} in 387 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
149 3.9*) _kdedir="3.9" ;;
150 4*) _kdedir="4.0" ;;
151 *) die "NEED_KDE=latest not supported for PV=${PV}" ;;
152 esac
153 _operator=">="
154 _pv="-${PV}:kde-4"
155 else
156 _kdedir="4.0"
157 _pv=":kde-4"
158 fi
159 ;; 388 ;;
160 scm|svn|9999*|:kde-svn) 389 optional)
161 _kdedir="svn" 390 IUSE+=" kde"
162 _pv=":kde-svn" 391 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
163 export NEED_KDE="svn" 392 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
393 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
164 ;; 394 ;;
165 *:kde-svn) 395 *) ;;
166 _kdedir="svn"
167 _operator=">="
168 _pv="-${NEED_KDE}"
169 export NEED_KDE="svn"
170 ;;
171 # The ebuild handles dependencies, KDEDIR, SLOT.
172 none)
173 :
174 ;;
175 # NEED_KDE=":${SLOT}"
176 :kde-4)
177 _kdedir="4.0"
178 _pv="${NEED_KDE}"
179 ;;
180 # NEED_KDE="${PV}:${SLOT}"
181 *:kde-4)
182 _kdedir="4.0"
183 _operator=">="
184 _pv="-${NEED_KDE}"
185 ;;
186 3.9*)
187 _kdedir="3.9"
188 _operator=">="
189 _pv="-${NEED_KDE}:kde-4"
190 ;;
191 4*)
192 _kdedir="4.0"
193 _operator=">="
194 _pv="-${NEED_KDE}:kde-4"
195 ;;
196 *) die "NEED_KDE=${NEED_KDE} currently not supported."
197 ;;
198esac 396esac
199 397
200if [[ ${NEED_KDE} != none ]]; then 398unset kdecommondepend kdedepend kderdepend
201 KDEDIR="/usr/kde/${_kdedir}"
202 KDEDIRS="/usr:/usr/local:${KDEDIR}"
203 399
204 if [[ -n ${KDEBASE} ]]; then 400debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
205 if [[ ${NEED_KDE} = svn ]]; then 401debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
206 SLOT="kde-svn" 402debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
207 else
208 SLOT="kde-4"
209 fi
210 fi
211 403
212 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 404# Accumulate dependencies set by this eclass
213 if [[ ${PN} != "kdelibs" ]]; then
214 DEPEND="${DEPEND} 405DEPEND+=" ${COMMONDEPEND}"
215 ${_operator}kde-base/kdelibs${_pv}"
216 RDEPEND="${RDEPEND} 406RDEPEND+=" ${COMMONDEPEND}"
217 ${_operator}kde-base/kdelibs${_pv}" 407unset COMMONDEPEND
218 if [[ ${PN} != "kdepimlibs" ]]; then
219 DEPEND="${DEPEND}
220 ${_operator}kde-base/kdepimlibs${_pv}"
221 RDEPEND="${RDEPEND}
222 ${_operator}kde-base/kdepimlibs${_pv}"
223 fi
224 fi
225
226 unset _operator _pv _kdedir
227fi
228 408
229# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 409# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
230# koffice ebuild, the URI should be set in the ebuild itself 410# kdevelop ebuild, the URI should be set in the ebuild itself
231if [[ -n ${KDEBASE} ]]; then 411_calculate_src_uri() {
412 debug-print-function ${FUNCNAME} "$@"
413
414 local _kmname _kmname_pv
415
416 # we calculate URI only for known KDEBASE modules
417 [[ -n ${KDEBASE} ]] || return
418
419 # calculate tarball module name
232 if [[ -n ${KMNAME} ]]; then 420 if [[ -n ${KMNAME} ]]; then
233 _kmname=${KMNAME} 421 _kmname="${KMNAME}"
234 else 422 else
235 _kmname=${PN} 423 _kmname=${PN}
236 fi 424 fi
237 _kmname_pv="${_kmname}-${PV}" 425 _kmname_pv="${_kmname}-${PV}"
238 if [[ ${NEED_KDE} != "svn" ]]; then
239 case ${KDEBASE} in 426 case ${KDEBASE} in
240 kde-base) 427 kde-base)
241 case ${PV} in 428 case ${PV} in
429 4.4.11.1)
430 # KDEPIM 4.4, special case
431 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
432 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
433 4.?.[6-9]? | 4.??.[6-9]?)
434 # Unstable KDE SC releases
242 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 435 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
436 4.11.14)
437 # Part of 4.14 actually, sigh. Not stable for next release!
438 SRC_URI="mirror://kde/stable/4.14.3/src/${_kmname_pv}.tar.xz" ;;
439 4.11.17)
440 # Part of 14.12.3 actually, sigh. Not stable for next release!
441 SRC_URI="mirror://kde/stable/applications/14.12.3/src/${_kmname_pv}.tar.xz" ;;
442 4.11.18)
443 # Part of 15.04.0 actually, sigh. Not stable for next release!
444 SRC_URI="mirror://kde/stable/applications/15.04.0/src/${_kmname_pv}.tar.xz" ;;
445 4.11.19)
446 # Part of 15.04.1 actually, sigh. Not stable for next release!
447 SRC_URI="mirror://kde/stable/applications/15.04.1/src/${_kmname_pv}.tar.xz" ;;
448 4.11.20)
449 # Part of 15.04.2 actually, sigh. Not stable for next release!
450 SRC_URI="mirror://kde/stable/applications/15.04.2/src/${_kmname_pv}.tar.xz" ;;
451 4.14.6)
452 # Part of 14.12.3 actually, sigh. Not stable for next release!
453 SRC_URI="mirror://kde/stable/applications/14.12.3/src/${_kmname_pv}.tar.xz" ;;
454 4.14.7)
455 # Part of 15.04.0 actually, sigh. Not stable for next release!
456 SRC_URI="mirror://kde/stable/applications/15.04.0/src/${_kmname_pv}.tar.xz" ;;
457 4.14.8)
458 # Part of 15.04.1 actually, sigh. Not stable for next release!
459 SRC_URI="mirror://kde/stable/applications/15.04.1/src/${_kmname_pv}.tar.xz" ;;
460 4.14.9)
461 # Part of 15.04.2 actually, sigh. Not stable for next release!
462 SRC_URI="mirror://kde/stable/applications/15.04.2/src/${_kmname_pv}.tar.xz" ;;
463 ??.?.[6-9]? | ??.??.[4-9]?)
464 # Unstable KDE Applications releases
465 SRC_URI="mirror://kde/unstable/applications/${PV}/src/${_kmname}-${PV}.tar.xz" ;;
466 *)
467 if [[ ${CATEGORY} == kde-apps ]]; then
468 # Stable KDE Applications releases
469 SRC_URI="mirror://kde/stable/applications/${PV}/src/${_kmname}-${PV}.tar.xz"
470 else
471 # Stable KDE SC releases
472 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz"
473 fi
474 ;;
243 esac 475 esac
244 ;; 476 ;;
245 koffice) 477 kdevelop|kdevelop-php*|kdevplatform)
246 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" 478 case ${KDEVELOP_VERSION} in
479 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz" ;;
480 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz" ;;
481 esac
247 ;; 482 ;;
483 esac
484}
485
486_calculate_live_repo() {
487 debug-print-function ${FUNCNAME} "$@"
488
489 SRC_URI=""
490 case ${KDE_SCM} in
491 svn)
492 # Determine branch URL based on live type
493 local branch_prefix
494 case ${PV} in
495 9999*)
496 # trunk
497 branch_prefix="trunk/KDE"
498 ;;
499 *)
500 # branch
501 branch_prefix="branches/KDE/$(get_kde_version)"
502 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
503 # @DESCRIPTION
504 # Suffix appended to ESVN_PROJECT depending on fetched branch.
505 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
506 ESVN_PROJECT_SUFFIX="-${PV}"
507 ;;
508 esac
509 # @ECLASS-VARIABLE: ESVN_MIRROR
510 # @DESCRIPTION:
511 # This variable allows easy overriding of default kde mirror service
512 # (anonsvn) with anything else you might want to use.
513 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
514 # Split ebuild, or extragear stuff
515 if [[ -n ${KMNAME} ]]; then
516 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
517 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
518 KMMODULE="${PN}"
519 fi
520 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
521 case ${KMNAME} in
522 kdebase-*)
523 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
524 ;;
525 kdelibs-*)
526 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
527 ;;
528 kdereview*)
529 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
530 ;;
531 kdesupport)
532 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
533 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
534 ;;
535 kde*)
536 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
537 ;;
538 extragear*|playground*)
539 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
540 # build packages from same svn location.
541 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
542 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
543 ;;
544 *)
545 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
546 ;;
547 esac
548 else
549 # kdelibs, kdepimlibs
550 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
551 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
552 fi
553 # @ECLASS-VARIABLE: ESVN_UP_FREQ
554 # @DESCRIPTION:
555 # This variable is used for specifying the timeout between svn synces
556 # for kde-base modules. Does not affect misc apps.
557 # Default value is 1 hour.
558 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
559 ;;
560 git)
561 local _kmname
562 # @ECLASS-VARIABLE: EGIT_MIRROR
563 # @DESCRIPTION:
564 # This variable allows easy overriding of default kde mirror service
565 # (anongit) with anything else you might want to use.
566 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
567
568 # @ECLASS-VARIABLE: EGIT_REPONAME
569 # @DESCRIPTION:
570 # This variable allows overriding of default repository
571 # name. Specify only if this differ from PN and KMNAME.
572 if [[ -n ${EGIT_REPONAME} ]]; then
573 # the repository and kmname different
574 _kmname=${EGIT_REPONAME}
575 elif [[ -n ${KMNAME} ]]; then
576 _kmname=${KMNAME}
577 else
578 _kmname=${PN}
579 fi
580
581 # default branching
582 [[ ${PV} != 4.9999* && ${PV} != 9999 && ${KDEBASE} == kde-base ]] && \
583 EGIT_BRANCH="KDE/$(get_kde_version)"
584
585 # Applications branching
586 [[ ${PV} == ??.??.49.9999 && ${KDEBASE} == kde-base ]] && \
587 EGIT_BRANCH="Applications/$(get_kde_version)"
588
589 # default repo uri
590 EGIT_REPO_URI+=( "${EGIT_MIRROR}/${_kmname}" )
591
592 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
593 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
594 ;;
595 esac
596}
597
598case ${KDE_BUILD_TYPE} in
599 live) _calculate_live_repo ;;
600 *) _calculate_src_uri ;;
601esac
602
603debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
604
605# @ECLASS-VARIABLE: PREFIX
606# @DESCRIPTION:
607# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
608# kde-base packages go into KDE4 installation directory (/usr).
609# No matter the PREFIX, package will be built against KDE installed in /usr.
610
611# @FUNCTION: kde4-base_pkg_setup
612# @DESCRIPTION:
613# Do some basic settings
614kde4-base_pkg_setup() {
615 debug-print-function ${FUNCNAME} "$@"
616
617 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
618 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
619 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
620 fi
621
622 # Don't set KDEHOME during compilation, it will cause access violations
623 unset KDEHOME
624
625 # Check if gcc compiler is fresh enough.
626 # In theory should be in pkg_pretend but we check it only for kdelibs there
627 # and for others we do just quick scan in pkg_setup because pkg_pretend
628 # executions consume quite some time (ie. when merging 300 packages at once will cause 300 checks)
629 if [[ ${MERGE_TYPE} != binary ]]; then
630 [[ $(gcc-major-version) -lt 4 ]] || \
631 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 6 ]] ) \
632 && die "Sorry, but gcc-4.6 and earlier wont work for some KDE packages."
633 fi
634
635 KDEDIR=/usr
636 : ${PREFIX:=/usr}
637 EKDEDIR=${EPREFIX}/usr
638
639 # Point to correct QT plugins path
640 QT_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/kde4/plugins/"
641
642 # Fix XDG collision with sandbox
643 export XDG_CONFIG_HOME="${T}"
644}
645
646# @FUNCTION: kde4-base_src_unpack
647# @DESCRIPTION:
648# This function unpacks the source tarballs for KDE4 applications.
649kde4-base_src_unpack() {
650 debug-print-function ${FUNCNAME} "$@"
651
652 if [[ ${KDE_BUILD_TYPE} = live ]]; then
653 case ${KDE_SCM} in
654 svn)
655 subversion_src_unpack
656 ;;
657 git)
658 git-r3_src_unpack
659 ;;
248 esac 660 esac
249 fi
250 unset _kmname _kmname_pv
251fi
252
253debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
254debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
255
256# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
257# If KMNAME is not set then this is not a split package
258if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
259 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
260 DEPEND="${DEPEND} !${_x}:${SLOT}"
261 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
262 done
263 unset _x
264fi
265
266debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
267
268# @ECLASS-VARIABLE: PREFIX
269# @DESCRIPTION:
270# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
271# Applications installed by the other ebuilds go into /usr/ by default, this value
272# can be superseded by defining PREFIX before inheriting kde4-base.
273if [[ -n ${KDEBASE} ]]; then
274 PREFIX=${KDEDIR}
275else
276 # if PREFIX is not defined we set it to the default value of /usr
277 PREFIX="${PREFIX:-/usr}"
278fi
279
280debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
281
282# @FUNCTION: kde4-base_pkg_setup
283# @DESCRIPTION:
284# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
285# kde4-functions_check_use from kde4-functions.eclass to print appropriate
286# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
287# $KDE4_BUILT_WITH_USE_CHECK are missing.
288kde4-base_pkg_setup() {
289 debug-print-function $FUNCNAME "$@"
290
291 case "${EAPI}" in
292 kdebuild-1)
293 [[ -n ${QT4_BUILT_WITH_USE_CHECK} || -n ${KDE4_BUILT_WITH_USE_CHECK} ]] && \
294 die "built_with_use illegal in this EAPI!"
295 ;;
296 *)
297 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
298 if has_version '<x11-libs/qt-4.4_alpha:4'; then
299 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
300 else 661 else
301 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 662 unpack ${A}
302 x11-libs/qt-core qt3support ssl
303 x11-libs/qt-gui accessibility dbus
304 x11-libs/qt-qt3support accessibility"
305 fi 663 fi
306
307 if has debug ${IUSE//+} && use debug; then
308 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
309 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug"
310 else
311 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
312 x11-libs/qt-core:4 debug
313 x11-libs/qt-gui:4 debug
314 x11-libs/qt-qt3support:4 debug
315 x11-libs/qt-svg:4 debug
316 x11-libs/qt-test:4 debug"
317 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
318 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
319 x11-libs/qt-opengl:4 debug"
320 fi
321 fi
322 fi
323
324 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
325 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
326 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
327 fi
328 fi
329 kde4-functions_check_use
330 ;;
331 esac
332} 664}
333 665
334# @FUNCTION: kde4-base_apply_patches
335# @DESCRIPTION:
336# This function applies patches.
337#
338# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
339# directory, provided they follow this format:
340# @CODE
341# - Monolithic ebuilds, (from kde-base)
342# - $CATEGORY=kde-base:
343# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
344# - $CATEGORY=!kde-base:
345# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
346# - Split ebuilds:
347# - $CATEGORY=kde-base:
348# Apply ${PN}-${SLOT}-*{diff,patch}
349# - $CATEGORY!=kde-base:
350# Apply ${PN}-${PV}-*{diff,patch}
351# @CODE
352#
353# If ${PATCHES} is non-zero all patches in it get applied. If there is more
354# than one patch please make ${PATCHES} an array for proper quoting.
355kde4-base_apply_patches() {
356 local _patchdir _packages _p
357 _patchdir="${WORKDIR}/patches/"
358 if [[ -d "${_patchdir}" ]]; then
359 if is-parent-package ${CATEGORY}/${PN} ; then
360 _packages="$(get-child-packages ${CATEGORY}/${PN})"
361 _packages="${_packages//${CATEGORY}\//} ${PN}"
362 else
363 _packages="${PN}"
364 fi
365 if [[ ${#PATCHES[@]} -gt 1 ]]; then
366 for _p in ${_packages}; do
367 PATCHES=( "${PATCHES[@]}" $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null) )
368 if [[ -n "${KDEBASE}" ]]; then
369 PATCHES=( "${PATCHES[@]}" $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null) )
370 fi
371 done
372 else
373 for _p in ${_packages}; do
374 PATCHES=(${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null))
375 if [[ -n "${KDEBASE}" ]]; then
376 PATCHES=(${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null))
377 fi
378 done
379 fi
380 fi
381 [[ -n ${PATCHES[@]} ]] && base_src_unpack autopatch
382}
383
384# @FUNCTION: kde4-base_src_unpack 666# @FUNCTION: kde4-base_src_prepare
385# @DESCRIPTION: 667# @DESCRIPTION:
386# This function unpacks the source tarballs for KDE4 applications. 668# General pre-configure and pre-compile function for KDE4 applications.
387#
388# If no argument is passed to this function, then standard src_unpack is
389# executed. Otherwise options are passed to base_src_unpack.
390#
391# In addition it calls kde4-base_apply_patches when no arguments are passed to
392# this function.
393#
394# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and 669# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
670# enable_selected_linguas() and enable_selected_doc_linguas()
395# enable_selected_linguas() in kde4-functions.eclass(5) for further details. 671# in kde4-functions.eclass(5) for further details.
396kde4-base_src_unpack() { 672kde4-base_src_prepare() {
397 debug-print-function $FUNCNAME "$@" 673 debug-print-function ${FUNCNAME} "$@"
398 674
399 [[ -z "${KDE_S}" ]] && KDE_S="${S}" 675 # enable handbook and linguas only when not using live ebuild
400
401 if [[ -z $* ]]; then
402 # Unpack first and deal with KDE patches after examing possible patch sets.
403 # To be picked up, patches need to conform to the guidelines stated before.
404 # Monolithic ebuilds will use the split ebuild patches.
405 [[ -d "${KDE_S}" ]] || unpack ${A}
406 kde4-base_apply_patches
407 else
408 # Call base_src_unpack, which unpacks and patches
409 # step by step transparently as defined in the ebuild.
410 base_src_unpack $*
411 fi
412
413 # Updated cmake dir
414 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then
415 ebegin "Updating cmake/ directory..."
416 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory"
417 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory"
418 eend 0
419 fi
420 676
421 # Only enable selected languages, used for KDE extragear apps. 677 # Only enable selected languages, used for KDE extragear apps.
422 if [[ -n ${KDE_LINGUAS} ]]; then 678 if [[ -n ${KDE_LINGUAS} ]]; then
423 enable_selected_linguas 679 enable_selected_linguas
424 fi 680 fi
681
682 # Enable/disable handbooks for kde4-base packages
683 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
684 # kdelibs inherits kde4-base but handle installing the handbook itself
685 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
686 if [[ ${KDEBASE} == kde-base ]]; then
687 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
688 # documentation in kde4-functions
689 : ${KDE_DOC_DIRS:=doc}
690 local dir
691 for dir in ${KDE_DOC_DIRS}; do
692 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
693 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
694 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
695 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
696 -i CMakeLists.txt || die "failed to comment out handbook"
697 done
698 fi
699 else
700 enable_selected_doc_linguas
701 fi
702 fi
703
704 # SCM bootstrap
705 if [[ ${KDE_BUILD_TYPE} = live ]]; then
706 case ${KDE_SCM} in
707 svn) subversion_src_prepare ;;
708 esac
709 fi
710
711 # Apply patches, cmake-utils does the job already
712 cmake-utils_src_prepare
713
714 # Save library dependencies
715 if [[ -n ${KMSAVELIBS} ]] ; then
716 save_library_dependencies
717 fi
718
719 # Inject library dependencies
720 if [[ -n ${KMLOADLIBS} ]] ; then
721 load_library_dependencies
722 fi
723
724 # Hack for manuals relying on outdated DTD, only outside kde-base/...
725 if [[ -z ${KDEBASE} ]]; then
726 find "${S}" -name "*.docbook" \
727 -exec sed -i -r \
728 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
729 || die 'failed to fix DocBook variant version'
730 fi
731}
732
733# @FUNCTION: kde4-base_src_configure
734# @DESCRIPTION:
735# Function for configuring the build of KDE4 applications.
736kde4-base_src_configure() {
737 debug-print-function ${FUNCNAME} "$@"
738
739 # Build tests in src_test only, where we override this value
740 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
741
742 if use_if_iuse debug; then
743 # Set "real" debug mode
744 CMAKE_KDE_BUILD_TYPE="Debugfull"
745 else
746 # Handle common release builds
747 append-cppflags -DQT_NO_DEBUG
748 fi
749
750 # Set distribution name
751 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
752
753 # Here we set the install prefix
754 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
755
756 # Use colors
757 QTEST_COLORED=1
758
759 # Shadow existing installations
760 unset KDEDIRS
761
762 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
763 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
764 #kde-config -path data unavailable when cross-compiling
765 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
766
767 # sysconf needs to be /etc, not /usr/etc
768 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
769
770 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
771 if [[ ${mycmakeargs} ]]; then
772 eqawarn "mycmakeargs should always be declared as an array, not a string"
773 fi
774 mycmakeargs=(${mycmakeargs})
775 fi
776
777 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
778
779 cmake-utils_src_configure
425} 780}
426 781
427# @FUNCTION: kde4-base_src_compile 782# @FUNCTION: kde4-base_src_compile
428# @DESCRIPTION: 783# @DESCRIPTION:
429# General function for compiling KDE4 applications. 784# General function for compiling KDE4 applications.
430kde4-base_src_compile() { 785kde4-base_src_compile() {
431 debug-print-function ${FUNCNAME} "$@" 786 debug-print-function ${FUNCNAME} "$@"
432 787
433 kde4-base_src_configure
434 kde4-base_src_make
435}
436
437# @FUNCTION: kde4-base_src_configure
438# @DESCRIPTION:
439# Function for configuring the build of KDE4 applications.
440kde4-base_src_configure() {
441 debug-print-function ${FUNCNAME} "$@"
442
443 # Final flag handling
444 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
445 echo "Activating enable-final flag"
446 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
447 fi
448
449 # Enable generation of HTML handbook
450 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
451 echo "Enabling building of HTML handbook"
452 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
453 fi
454
455 # Build tests in src_test only, where we override this value
456 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
457
458 # Set distribution name
459 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
460
461 # runpath linking
462 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
463
464 # Here we set the install prefix
465 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
466
467 # Set environment
468 QTEST_COLORED=1
469 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
470
471 cmake-utils_src_configureout
472}
473
474# @FUNCTION: kde4-base_src_make
475# @DESCRIPTION:
476# Function for building KDE4 applications.
477# Options are passed to cmake-utils_src_make.
478kde4-base_src_make() {
479 debug-print-function ${FUNCNAME} "$@"
480
481 cmake-utils_src_make "$@" 788 cmake-utils_src_compile "$@"
482} 789}
483 790
484# @FUNCTION: kde4-base_src_test 791# @FUNCTION: kde4-base_src_test
485# @DESCRIPTION: 792# @DESCRIPTION:
486# Function for testing KDE4 applications. 793# Function for testing KDE4 applications.
487kde4-base_src_test() { 794kde4-base_src_test() {
488 debug-print-function ${FUNCNAME} "$@" 795 debug-print-function ${FUNCNAME} "$@"
489 796
797 local kded4_pid
798
799 _test_runner() {
800 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
801 export $(dbus-launch)
802 kded4 2>&1 > /dev/null &
803 kded4_pid=$!
804 fi
805
806 cmake-utils_src_test
807 }
808
809 # When run as normal user during ebuild development with the ebuild command, the
810 # kde tests tend to access the session DBUS. This however is not possible in a real
811 # emerge or on the tinderbox.
812 # > make sure it does not happen, so bad tests can be recognized and disabled
813 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
814
490 # Override this value, set in kde4-base_src_configure() 815 # Override this value, set in kde4-base_src_configure()
491 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 816 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
492 cmake-utils_src_compile 817 cmake-utils_src_configure
818 kde4-base_src_compile
493 819
494 cmake-utils_src_test 820 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
821 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
822 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
823 # surprise- we are already INSIDE virtualmake!!!
824 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
825 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
826 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
827 debug-print " kde4-base.eclass docs for details... Applying workaround."
828 _test_runner
829 else
830 VIRTUALX_COMMAND="_test_runner" virtualmake
831 fi
832 else
833 _test_runner
834 fi
835
836 if [ -n "${kded4_pid}" ] ; then
837 kill ${kded4_pid}
838 fi
839
840 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
841 kill ${DBUS_SESSION_BUS_PID}
842 fi
495} 843}
496 844
497# @FUNCTION: kde4-base_src_install 845# @FUNCTION: kde4-base_src_install
498# @DESCRIPTION: 846# @DESCRIPTION:
499# Function for installing KDE4 applications. 847# Function for installing KDE4 applications.
500kde4-base_src_install() { 848kde4-base_src_install() {
501 debug-print-function ${FUNCNAME} "$@" 849 debug-print-function ${FUNCNAME} "$@"
502 850
503 kde4-base_src_make_doc 851 if [[ -n ${KMSAVELIBS} ]] ; then
852 install_library_dependencies
853 fi
854
855 # Install common documentation of KDE4 applications
856 local doc
857 if ! has kde4-meta ${INHERITED}; then
858 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
859 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
860 done
861 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
862 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
863 done
864 fi
865
504 cmake-utils_src_install 866 cmake-utils_src_install
505}
506 867
507# @FUNCTION: kde4-base_src_make_doc 868 # We don't want ${PREFIX}/share/doc/HTML to be compressed,
508# @DESCRIPTION: 869 # because then khelpcenter can't find the docs
509# Function for installing the documentation of KDE4 applications. 870 [[ -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
510kde4-base_src_make_doc() { 871 docompress -x ${PREFIX}/share/doc/HTML
511 debug-print-function ${FUNCNAME} "$@" 872}
512 873
513 local doc 874# @FUNCTION: kde4-base_pkg_preinst
514 for doc in AUTHORS ChangeLog* README* NEWS TODO; do 875# @DESCRIPTION:
515 [[ -s $doc ]] && dodoc ${doc} 876# Function storing icon caches
516 done 877kde4-base_pkg_preinst() {
878 debug-print-function ${FUNCNAME} "$@"
517 879
518 if [[ -z ${KMNAME} ]]; then 880 gnome2_icon_savelist
519 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do 881 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
520 if [[ -s $doc ]]; then 882 subversion_pkg_preinst
521 local doc_complete=${doc}
522 doc="${doc#*/}"
523 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
524 fi
525 done
526 fi
527
528 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
529 # work around bug #97196
530 dodir /usr/share/doc/kde && \
531 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
532 die "Failed to move docs to kde/ failed."
533 fi 883 fi
534} 884}
535 885
536# @FUNCTION: kde4-base_pkg_postinst 886# @FUNCTION: kde4-base_pkg_postinst
537# @DESCRIPTION: 887# @DESCRIPTION:
538# Function to rebuild the KDE System Configuration Cache after an application has been installed. 888# Function to rebuild the KDE System Configuration Cache after an application has been installed.
539kde4-base_pkg_postinst() { 889kde4-base_pkg_postinst() {
890 debug-print-function ${FUNCNAME} "$@"
891
892 gnome2_icon_cache_update
893 fdo-mime_desktop_database_update
894 fdo-mime_mime_database_update
540 buildsycoca 895 buildsycoca
896
897 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
898 if [[ ${KDE_BUILD_TYPE} = live ]]; then
899 echo
900 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
901 einfo "Use it at your own risk."
902 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
903 echo
904 fi
905 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
906 if [[ ${KDEBASE} != kde-base ]] && \
907 ! has_version 'kde-base/kdebase-runtime-meta' && \
908 ! has_version 'kde-base/kdebase-startkde'; then
909 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
910 echo
911 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
912 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
913 ewarn "With this setting you are unsupported by KDE team."
914 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
915 fi
916 fi
917 fi
541} 918}
542 919
543# @FUNCTION: kde4-base_pkg_postrm 920# @FUNCTION: kde4-base_pkg_postrm
544# @DESCRIPTION: 921# @DESCRIPTION:
545# Function to rebuild the KDE System Configuration Cache after an application has been removed. 922# Function to rebuild the KDE System Configuration Cache after an application has been removed.
546kde4-base_pkg_postrm() { 923kde4-base_pkg_postrm() {
924 debug-print-function ${FUNCNAME} "$@"
925
926 gnome2_icon_cache_update
927 fdo-mime_desktop_database_update
928 fdo-mime_mime_database_update
547 buildsycoca 929 buildsycoca
548} 930}
931
932fi

Legend:
Removed from v.1.9  
changed lines
  Added in v.1.154

  ViewVC Help
Powered by ViewVC 1.1.20