/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.93 Revision 1.124
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2013 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.93 2011/05/23 22:56:36 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.124 2013/03/03 00:22:56 pesa Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed 13# NOTE: KDE 4 ebuilds currently support EAPIs 3, 4, and 5. This will be
14# over time as new EAPI versions are approved. 14# reviewed over time as new EAPI versions are approved.
15
16# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
17# @DESCRIPTION:
18# If set to "none", do nothing.
19# For any other value, add selinux to IUSE, and depending on that useflag
20# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
21: ${KDE_SELINUX_MODULE:=none}
22
23# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
24# @DESCRIPTION:
25# If defined, launch and use a private dbus session during src_test.
15 26
16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED 27# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION: 28# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage. 29# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx 30# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test. 31# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual} 32: ${VIRTUALX_REQUIRED:=manual}
22 33
23inherit kde4-functions toolchain-funcs fdo-mime gnome2-utils base virtualx versionator eutils 34inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils base virtualx versionator eutils multilib
24 35
25if [[ ${BUILD_TYPE} = live ]]; then 36if [[ ${KDE_BUILD_TYPE} = live ]]; then
26 case ${KDE_SCM} in 37 case ${KDE_SCM} in
27 svn) inherit subversion ;; 38 svn) inherit subversion ;;
28 git) inherit git-2 ;; 39 git) inherit git-2 ;;
29 esac 40 esac
30fi 41fi
39if [[ ${CMAKE_REQUIRED} = always ]]; then 50if [[ ${CMAKE_REQUIRED} = always ]]; then
40 buildsystem_eclass="cmake-utils" 51 buildsystem_eclass="cmake-utils"
41 export_fns="src_configure src_compile src_test src_install" 52 export_fns="src_configure src_compile src_test src_install"
42fi 53fi
43 54
44# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
45if [[ -n ${KDE_MINIMAL} ]]; then
46 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
47 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
48 done
49 unset slot
50 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
51else
52 KDE_MINIMAL_VALID=1
53fi
54
55# @ECLASS-VARIABLE: KDE_MINIMAL 55# @ECLASS-VARIABLE: KDE_MINIMAL
56# @DESCRIPTION: 56# @DESCRIPTION:
57# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal 57# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
58# version for apps to work. Currently defaults to 4.4 58# version for apps to work. Currently defaults to 4.4
59# One may override this variable to raise version requirements. 59# One may override this variable to raise version requirements.
60# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
61# Note that it is fixed to ${SLOT} for kde-base packages. 60# Note that it is fixed to ${PV} for kde-base packages.
62KDE_MINIMAL="${KDE_MINIMAL:-4.4}" 61KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
63 62
64# Set slot for KDEBASE known packages 63# Set slot for KDEBASE known packages
65case ${KDEBASE} in 64case ${KDEBASE} in
66 kde-base) 65 kde-base)
67 SLOT=$(_calculate_kde_slot) 66 SLOT=4
68 [[ -z ${SLOT} ]] && die "Unsupported ${PV}"
69 KDE_MINIMAL="${SLOT}" 67 KDE_MINIMAL="${PV}"
70 ;;
71 koffice)
72 SLOT="2"
73 ;; 68 ;;
74 kdevelop) 69 kdevelop)
75 if [[ ${BUILD_TYPE} = live ]]; then 70 if [[ ${KDE_BUILD_TYPE} = live ]]; then
76 # @ECLASS-VARIABLE: KDEVELOP_VERSION 71 # @ECLASS-VARIABLE: KDEVELOP_VERSION
77 # @DESCRIPTION: 72 # @DESCRIPTION:
78 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages. 73 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
79 # Applies to KDEBASE=kdevelop only. 74 # Applies to KDEBASE=kdevelop only.
80 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}" 75 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
87 case ${PN} in 82 case ${PN} in
88 kdevelop|quanta) 83 kdevelop|quanta)
89 KDEVELOP_VERSION=${PV} 84 KDEVELOP_VERSION=${PV}
90 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)" 85 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
91 ;; 86 ;;
92 kdevplatform) 87 kdevplatform|kdevelop-php*)
93 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)" 88 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
94 KDEVPLATFORM_VERSION=${PV} 89 KDEVPLATFORM_VERSION=${PV}
95 ;; 90 ;;
96 *) 91 *)
97 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}" 92 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
109unset buildsystem_eclass 104unset buildsystem_eclass
110unset export_fns 105unset export_fns
111 106
112# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED 107# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
113# @DESCRIPTION: 108# @DESCRIPTION:
114# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'. 109# Is qtdeclarative required? Possible values are 'always', 'optional' and 'never'.
115# This variable must be set before inheriting any eclasses. Defaults to 'never'. 110# This variable must be set before inheriting any eclasses. Defaults to 'never'.
116DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}" 111DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
117 112
118# @ECLASS-VARIABLE: QTHELP_REQUIRED 113# @ECLASS-VARIABLE: QTHELP_REQUIRED
119# @DESCRIPTION: 114# @DESCRIPTION:
120# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'. 115# Is qthelp required? Possible values are 'always', 'optional' and 'never'.
121# This variable must be set before inheriting any eclasses. Defaults to 'never'. 116# This variable must be set before inheriting any eclasses. Defaults to 'never'.
122QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}" 117QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
123 118
124# @ECLASS-VARIABLE: OPENGL_REQUIRED 119# @ECLASS-VARIABLE: OPENGL_REQUIRED
125# @DESCRIPTION: 120# @DESCRIPTION:
126# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 121# Is qtopengl required? Possible values are 'always', 'optional' and 'never'.
127# This variable must be set before inheriting any eclasses. Defaults to 'never'. 122# This variable must be set before inheriting any eclasses. Defaults to 'never'.
128OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 123OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
129 124
130# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED 125# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
131# @DESCRIPTION: 126# @DESCRIPTION:
132# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'. 127# Is qtmultimedia required? Possible values are 'always', 'optional' and 'never'.
133# This variable must be set before inheriting any eclasses. Defaults to 'never'. 128# This variable must be set before inheriting any eclasses. Defaults to 'never'.
134MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}" 129MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
135
136# @ECLASS-VARIABLE: WEBKIT_REQUIRED
137# @DESCRIPTION:
138# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
139# This variable must be set before inheriting any eclasses. Defaults to 'never'.
140WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
141 130
142# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 131# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
143# @DESCRIPTION: 132# @DESCRIPTION:
144# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 133# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
145# This variable must be set before inheriting any eclasses. Defaults to 'never'. 134# This variable must be set before inheriting any eclasses. Defaults to 'never'.
165# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE 154# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
166# @DESCRIPTION: 155# @DESCRIPTION:
167# Set this varible if you want your live package to manage its 156# Set this varible if you want your live package to manage its
168# translations. (Mostly all kde ebuilds does not ship documentation 157# translations. (Mostly all kde ebuilds does not ship documentation
169# and translations in live ebuilds) 158# and translations in live ebuilds)
170if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then 159if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
171 # Kdebase actualy provides the handbooks even for live stuff 160 # Kdebase actualy provides the handbooks even for live stuff
172 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never 161 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
173 KDE_LINGUAS="" 162 KDE_LINGUAS=""
174fi 163fi
175 164
176# Setup packages inheriting this eclass 165# Setup packages inheriting this eclass
177case ${KDEBASE} in 166case ${KDEBASE} in
178 kde-base) 167 kde-base)
179 HOMEPAGE="http://www.kde.org/" 168 HOMEPAGE="http://www.kde.org/"
180 LICENSE="GPL-2" 169 LICENSE="GPL-2"
181 if [[ $BUILD_TYPE = live ]]; then 170 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
182 # Disable tests for live ebuilds 171 # Disable tests for live ebuilds by default
183 RESTRICT+=" test" 172 RESTRICT+=" test"
184 # Live ebuilds in kde-base default to kdeprefix by default
185 IUSE+=" +kdeprefix"
186 else
187 # All other ebuild types default to -kdeprefix as before
188 IUSE+=" kdeprefix"
189 fi 173 fi
174
190 # This code is to prevent portage from searching GENTOO_MIRRORS for 175 # This code is to prevent portage from searching GENTOO_MIRRORS for
191 # packages that will never be mirrored. (As they only will ever be in 176 # packages that will never be mirrored. (As they only will ever be in
192 # the overlay). 177 # the overlay).
193 case ${PV} in 178 case ${PV} in
194 *9999* | 4.?.[6-9]?) 179 *9999* | 4.?.[6-9]?)
195 RESTRICT+=" mirror" 180 RESTRICT+=" mirror"
196 ;; 181 ;;
197 esac 182 esac
198 # Block installation of other SLOTS unless kdeprefix
199 RDEPEND+=" $(block_other_slots)"
200 ;;
201 koffice)
202 HOMEPAGE="http://www.koffice.org/"
203 LICENSE="GPL-2"
204 ;; 183 ;;
205 kdevelop) 184 kdevelop)
206 HOMEPAGE="http://www.kdevelop.org/" 185 HOMEPAGE="http://www.kdevelop.org/"
207 LICENSE="GPL-2" 186 LICENSE="GPL-2"
208 ;; 187 ;;
209esac 188esac
210 189
211# @ECLASS-VARIABLE: QT_MINIMAL 190# @ECLASS-VARIABLE: QT_MINIMAL
212# @DESCRIPTION: 191# @DESCRIPTION:
213# Determine version of qt we enforce as minimal for the package. 192# Determine version of qt we enforce as minimal for the package.
214if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then 193if version_is_at_least 4.8.50 "${KDE_MINIMAL}"; then
194 # Upstream has added an *undeclared* dependency on Qt 4.8...
215 QT_MINIMAL="${QT_MINIMAL:-4.7.0}" 195 QT_MINIMAL="${QT_MINIMAL:-4.8.0}"
216else 196else
217 QT_MINIMAL="${QT_MINIMAL:-4.6.3}" 197 QT_MINIMAL="${QT_MINIMAL:-4.7.4}"
218fi 198fi
219 199
220# Declarative dependencies 200# Declarative dependencies
221qtdeclarativedepend=" 201qtdeclarativedepend="
222 >=x11-libs/qt-declarative-${QT_MINIMAL}:4 202 >=dev-qt/qtdeclarative-${QT_MINIMAL}:4
223" 203"
224case ${DECLARATIVE_REQUIRED} in 204case ${DECLARATIVE_REQUIRED} in
225 always) 205 always)
226 COMMONDEPEND+=" ${qtdeclarativedepend}" 206 COMMONDEPEND+=" ${qtdeclarativedepend}"
227 ;; 207 ;;
233esac 213esac
234unset qtdeclarativedepend 214unset qtdeclarativedepend
235 215
236# QtHelp dependencies 216# QtHelp dependencies
237qthelpdepend=" 217qthelpdepend="
238 >=x11-libs/qt-assistant-${QT_MINIMAL}:4 218 >=dev-qt/qthelp-${QT_MINIMAL}:4
239" 219"
240case ${QTHELP_REQUIRED} in 220case ${QTHELP_REQUIRED} in
241 always) 221 always)
242 COMMONDEPEND+=" ${qthelpdepend}" 222 COMMONDEPEND+=" ${qthelpdepend}"
243 ;; 223 ;;
248esac 228esac
249unset qthelpdepend 229unset qthelpdepend
250 230
251# OpenGL dependencies 231# OpenGL dependencies
252qtopengldepend=" 232qtopengldepend="
253 >=x11-libs/qt-opengl-${QT_MINIMAL}:4 233 >=dev-qt/qtopengl-${QT_MINIMAL}:4
254" 234"
255case ${OPENGL_REQUIRED} in 235case ${OPENGL_REQUIRED} in
256 always) 236 always)
257 COMMONDEPEND+=" ${qtopengldepend}" 237 COMMONDEPEND+=" ${qtopengldepend}"
258 ;; 238 ;;
264esac 244esac
265unset qtopengldepend 245unset qtopengldepend
266 246
267# MultiMedia dependencies 247# MultiMedia dependencies
268qtmultimediadepend=" 248qtmultimediadepend="
269 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4 249 >=dev-qt/qtmultimedia-${QT_MINIMAL}:4
270" 250"
271case ${MULTIMEDIA_REQUIRED} in 251case ${MULTIMEDIA_REQUIRED} in
272 always) 252 always)
273 COMMONDEPEND+=" ${qtmultimediadepend}" 253 COMMONDEPEND+=" ${qtmultimediadepend}"
274 ;; 254 ;;
277 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )" 257 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
278 ;; 258 ;;
279 *) ;; 259 *) ;;
280esac 260esac
281unset qtmultimediadepend 261unset qtmultimediadepend
282
283# WebKit dependencies
284case ${KDE_REQUIRED} in
285 always)
286 qtwebkitusedeps="[kde]"
287 ;;
288 optional)
289 qtwebkitusedeps="[kde?]"
290 ;;
291 *) ;;
292esac
293qtwebkitdepend="
294 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
295"
296unset qtwebkitusedeps
297case ${WEBKIT_REQUIRED} in
298 always)
299 COMMONDEPEND+=" ${qtwebkitdepend}"
300 ;;
301 optional)
302 IUSE+=" webkit"
303 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
304 ;;
305 *) ;;
306esac
307unset qtwebkitdepend
308 262
309# CppUnit dependencies 263# CppUnit dependencies
310cppuintdepend=" 264cppuintdepend="
311 dev-util/cppunit 265 dev-util/cppunit
312" 266"
324 278
325# KDE dependencies 279# KDE dependencies
326# Qt accessibility classes are needed in various places, bug 325461 280# Qt accessibility classes are needed in various places, bug 325461
327kdecommondepend=" 281kdecommondepend="
328 dev-lang/perl 282 dev-lang/perl
283 >=dev-qt/qt3support-${QT_MINIMAL}:4[accessibility]
329 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl] 284 >=dev-qt/qtcore-${QT_MINIMAL}:4[qt3support,ssl]
285 >=dev-qt/qtdbus-${QT_MINIMAL}:4
330 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus] 286 >=dev-qt/qtgui-${QT_MINIMAL}:4[accessibility,dbus]
331 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
332 >=x11-libs/qt-script-${QT_MINIMAL}:4 287 >=dev-qt/qtscript-${QT_MINIMAL}:4
333 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support] 288 >=dev-qt/qtsql-${QT_MINIMAL}:4[qt3support]
334 >=x11-libs/qt-svg-${QT_MINIMAL}:4 289 >=dev-qt/qtsvg-${QT_MINIMAL}:4
335 >=x11-libs/qt-test-${QT_MINIMAL}:4 290 >=dev-qt/qttest-${QT_MINIMAL}:4
291 >=dev-qt/qtwebkit-${QT_MINIMAL}:4
336 !aqua? ( 292 !aqua? (
337 x11-libs/libXext 293 x11-libs/libXext
338 x11-libs/libXt 294 x11-libs/libXt
339 x11-libs/libXxf86vm 295 x11-libs/libXxf86vm
340 x11-libs/libXcomposite 296 x11-libs/libXcomposite
297 x11-libs/libxkbfile
341 ) 298 )
342" 299"
343 300
344if [[ ${PN} != kdelibs ]]; then 301if [[ ${PN} != kdelibs ]]; then
345 kdecommondepend+=" $(add_kdebase_dep kdelibs)" 302 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
362 fi 319 fi
363fi 320fi
364 321
365kdedepend=" 322kdedepend="
366 dev-util/automoc 323 dev-util/automoc
367 dev-util/pkgconfig 324 virtual/pkgconfig
368 !aqua? ( 325 !aqua? (
369 >=x11-libs/libXtst-1.1.0 326 >=x11-libs/libXtst-1.1.0
370 x11-proto/xf86vidmodeproto 327 x11-proto/xf86vidmodeproto
371 ) 328 )
372" 329"
411 ;; 368 ;;
412 *) ;; 369 *) ;;
413esac 370esac
414unset kdehandbookdepend kdehandbookrdepend 371unset kdehandbookdepend kdehandbookrdepend
415 372
373case ${KDE_SELINUX_MODULE} in
374 none) ;;
375 *)
376 IUSE+=" selinux"
377 kdecommondepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
378 ;;
379esac
380
381# We always need the aqua useflag because otherwise we cannot = refer to it inside
382# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
383# (where referring to a use flag not in IUSE masks the ebuild).
384# The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
385IUSE+=" aqua"
386
416case ${KDE_REQUIRED} in 387case ${KDE_REQUIRED} in
417 always) 388 always)
418 IUSE+=" aqua"
419 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}" 389 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
420 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}" 390 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
421 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}" 391 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
422 ;; 392 ;;
423 optional) 393 optional)
424 IUSE+=" aqua kde" 394 IUSE+=" kde"
425 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 395 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
426 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )" 396 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
427 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )" 397 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
428 ;; 398 ;;
429 *) ;; 399 *) ;;
438# Accumulate dependencies set by this eclass 408# Accumulate dependencies set by this eclass
439DEPEND+=" ${COMMONDEPEND}" 409DEPEND+=" ${COMMONDEPEND}"
440RDEPEND+=" ${COMMONDEPEND}" 410RDEPEND+=" ${COMMONDEPEND}"
441unset COMMONDEPEND 411unset COMMONDEPEND
442 412
443# Add experimental kdeenablefinal, masked by default
444IUSE+=" kdeenablefinal"
445
446# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 413# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
447# koffice ebuild, the URI should be set in the ebuild itself 414# kdevelop ebuild, the URI should be set in the ebuild itself
448_calculate_src_uri() { 415_calculate_src_uri() {
449 debug-print-function ${FUNCNAME} "$@" 416 debug-print-function ${FUNCNAME} "$@"
450 417
451 local _kmname _kmname_pv 418 local _kmname _kmname_pv
452 419
467 fi 434 fi
468 _kmname_pv="${_kmname}-${PV}" 435 _kmname_pv="${_kmname}-${PV}"
469 case ${KDEBASE} in 436 case ${KDEBASE} in
470 kde-base) 437 kde-base)
471 case ${PV} in 438 case ${PV} in
472 4.[456].8[05] | 4.[456].9[023568]) 439 4.4.11.1)
440 # KDEPIM 4.4, special case
441 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
442 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
443 4.?.[6-9]? | 4.??.[6-9]?)
473 # Unstable KDE SC releases 444 # Unstable KDE SC releases
445 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
446 4.[1-7].[12345])
447 # Stable KDE SC with old .bz2 support
474 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" 448 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
475 # KDEPIM IS SPECIAL
476 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname_pv}.tar.bz2"
477 ;;
478 4.4.[6789] | 4.4.1?*)
479 # Stable kdepim releases
480 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
481 ;;
482 *) 449 *)
483 # Stable KDE SC releases 450 # Stable KDE SC releases
484 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" 451 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz" ;;
485 ;;
486 esac 452 esac
487 ;; 453 ;;
488 koffice) 454 kdevelop|kdevelop-php*|kdevplatform)
489 case ${PV} in 455 case ${KDEVELOP_VERSION} in
490 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 456 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
491 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 457 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
492 esac 458 esac
493 ;;
494 kdevelop)
495 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
496 ;; 459 ;;
497 esac 460 esac
498} 461}
499 462
500_calculate_live_repo() { 463_calculate_live_repo() {
510 # trunk 473 # trunk
511 branch_prefix="trunk/KDE" 474 branch_prefix="trunk/KDE"
512 ;; 475 ;;
513 *) 476 *)
514 # branch 477 # branch
515 branch_prefix="branches/KDE/${SLOT}" 478 branch_prefix="branches/KDE/$(get_kde_version)"
516 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX 479 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
517 # @DESCRIPTION 480 # @DESCRIPTION
518 # Suffix appended to ESVN_PROJECT depending on fetched branch. 481 # Suffix appended to ESVN_PROJECT depending on fetched branch.
519 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise. 482 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
520 ESVN_PROJECT_SUFFIX="-${PV}" 483 ESVN_PROJECT_SUFFIX="-${PV}"
553 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta 516 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
554 # build packages from same svn location. 517 # build packages from same svn location.
555 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 518 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
556 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 519 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
557 ;; 520 ;;
558 koffice)
559 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
560 ;;
561 *) 521 *)
562 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 522 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
563 ;; 523 ;;
564 esac 524 esac
565 else 525 else
568 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 528 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
569 fi 529 fi
570 # @ECLASS-VARIABLE: ESVN_UP_FREQ 530 # @ECLASS-VARIABLE: ESVN_UP_FREQ
571 # @DESCRIPTION: 531 # @DESCRIPTION:
572 # This variable is used for specifying the timeout between svn synces 532 # This variable is used for specifying the timeout between svn synces
573 # for kde-base and koffice modules. Does not affect misc apps. 533 # for kde-base modules. Does not affect misc apps.
574 # Default value is 1 hour. 534 # Default value is 1 hour.
575 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1} 535 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
576 ;; 536 ;;
577 git) 537 git)
578 local _kmname 538 local _kmname
579 # @ECLASS-VARIABLE: EGIT_MIRROR 539 # @ECLASS-VARIABLE: EGIT_MIRROR
580 # @DESCRIPTION: 540 # @DESCRIPTION:
594 else 554 else
595 _kmname=${PN} 555 _kmname=${PN}
596 fi 556 fi
597 557
598 # default branching 558 # default branching
599 case ${PV} in 559 [[ ${PV} != 9999* && ${KDEBASE} == kde-base ]] && \
600 9999*) ;; 560 EGIT_BRANCH="KDE/$(get_kde_version)"
601 *)
602 # set EGIT_BRANCH and EGIT_COMMIT to ${SLOT}
603 case ${_kmname} in
604 kdeplasma-addons | kdepim | kdepim-runtime | kdepimlibs)
605 EGIT_BRANCH="${SLOT}"
606 ;;
607 *) EGIT_BRANCH="KDE/${SLOT}" ;;
608 esac
609 ;;
610 esac
611 561
562 # default repo uri
612 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}" 563 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
613 564
614 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}" 565 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
615 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}" 566 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
616 ;; 567 ;;
617 esac 568 esac
618} 569}
619 570
620case ${BUILD_TYPE} in 571case ${KDE_BUILD_TYPE} in
621 live) _calculate_live_repo ;; 572 live) _calculate_live_repo ;;
622 *) _calculate_src_uri ;; 573 *) _calculate_src_uri ;;
623esac 574esac
624 575
625debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}" 576debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
626 577
627# @ECLASS-VARIABLE: PREFIX 578# @ECLASS-VARIABLE: PREFIX
628# @DESCRIPTION: 579# @DESCRIPTION:
629# Set the installation PREFIX for non kde-base applications. It defaults to /usr. 580# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
630# kde-base packages go into KDE4 installation directory (KDEDIR) by default. 581# kde-base packages go into KDE4 installation directory (/usr).
631# No matter the PREFIX, package will be built against KDE installed in KDEDIR. 582# No matter the PREFIX, package will be built against KDE installed in /usr.
632 583
633# @FUNCTION: kde4-base_pkg_setup 584# @FUNCTION: kde4-base_pkg_setup
634# @DESCRIPTION: 585# @DESCRIPTION:
635# Do the basic kdeprefix KDEDIR settings and determine with which kde should 586# Do some basic settings
636# optional applications link
637kde4-base_pkg_setup() { 587kde4-base_pkg_setup() {
638 debug-print-function ${FUNCNAME} "$@" 588 debug-print-function ${FUNCNAME} "$@"
639 589
640 # QA ebuilds 590 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
641 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})." 591 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
592 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
593 fi
642 594
643 # Don't set KDEHOME during compilation, it will cause access violations 595 # Don't set KDEHOME during compilation, it will cause access violations
644 unset KDEHOME 596 unset KDEHOME
645 597
646 # Check if gcc compiler is fresh enough. 598 # Check if gcc compiler is fresh enough.
647 # In theory should be in pkg_pretend but we check it only for kdelibs there 599 # In theory should be in pkg_pretend but we check it only for kdelibs there
648 # and for others we do just quick scan in pkg_setup because pkg_pretend 600 # and for others we do just quick scan in pkg_setup because pkg_pretend
649 # executions consume quite some time. 601 # executions consume quite some time.
602 # We can only do this for EAPI 4 or later because the MERGE_TYPE variable
603 # is otherwise undefined.
604 if [[ ${EAPI:-0} != 3 ]]; then
605 if [[ ${MERGE_TYPE} != binary ]]; then
650 [[ $(gcc-major-version) -lt 4 ]] || \ 606 [[ $(gcc-major-version) -lt 4 ]] || \
651 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \ 607 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \
652 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)." 608 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)."
653
654 if [[ ${KDEBASE} = kde-base ]]; then
655 if use kdeprefix; then
656 KDEDIR=/usr/kde/${SLOT}
657 else
658 KDEDIR=/usr
659 fi 609 fi
660 : ${PREFIX:=${KDEDIR}}
661 else
662 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
663 KDEDIR=
664 local kde_minimal_met
665 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
666 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
667 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
668 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
669 KDEDIR=/usr/kde/${slot}
670 else
671 KDEDIR=/usr
672 fi
673 break;
674 fi
675 done
676 unset slot
677
678 # Bail out if kdelibs required but not found
679 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
680 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
681 else
682 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
683 fi 610 fi
684 611
612 KDEDIR=/usr
685 : ${PREFIX:=/usr} 613 : ${PREFIX:=/usr}
686 fi 614 EKDEDIR=${EPREFIX}/usr
687 EKDEDIR=${EPREFIX}${KDEDIR}
688 615
689 # Point pkg-config path to KDE *.pc files
690 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
691 # Point to correct QT plugins path 616 # Point to correct QT plugins path
692 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/" 617 QT_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/kde4/plugins/"
693 618
694 # Fix XDG collision with sandbox 619 # Fix XDG collision with sandbox
695 export XDG_CONFIG_HOME="${T}" 620 export XDG_CONFIG_HOME="${T}"
696} 621}
697 622
699# @DESCRIPTION: 624# @DESCRIPTION:
700# This function unpacks the source tarballs for KDE4 applications. 625# This function unpacks the source tarballs for KDE4 applications.
701kde4-base_src_unpack() { 626kde4-base_src_unpack() {
702 debug-print-function ${FUNCNAME} "$@" 627 debug-print-function ${FUNCNAME} "$@"
703 628
704 if [[ ${BUILD_TYPE} = live ]]; then 629 if [[ ${KDE_BUILD_TYPE} = live ]]; then
705 case ${KDE_SCM} in 630 case ${KDE_SCM} in
706 svn) 631 svn)
707 migrate_store_dir 632 migrate_store_dir
708 subversion_src_unpack 633 subversion_src_unpack
709 ;; 634 ;;
733 fi 658 fi
734 659
735 # Enable/disable handbooks for kde4-base packages 660 # Enable/disable handbooks for kde4-base packages
736 # kde-l10n inherits kde4-base but is metpackage, so no check for doc 661 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
737 # kdelibs inherits kde4-base but handle installing the handbook itself 662 # kdelibs inherits kde4-base but handle installing the handbook itself
738 if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then 663 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
739 if [[ ${KDEBASE} == kde-base ]]; then 664 if [[ ${KDEBASE} == kde-base ]]; then
740 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then 665 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
741 # documentation in kde4-functions 666 # documentation in kde4-functions
742 : ${KDE_DOC_DIRS:=doc} 667 : ${KDE_DOC_DIRS:=doc}
743 local dir 668 local dir
753 enable_selected_doc_linguas 678 enable_selected_doc_linguas
754 fi 679 fi
755 fi 680 fi
756 681
757 # SCM bootstrap 682 # SCM bootstrap
758 if [[ ${BUILD_TYPE} = live ]]; then 683 if [[ ${KDE_BUILD_TYPE} = live ]]; then
759 case ${KDE_SCM} in 684 case ${KDE_SCM} in
760 svn) subversion_src_prepare ;; 685 svn) subversion_src_prepare ;;
761 esac 686 esac
762 fi 687 fi
763 688
772 # Inject library dependencies 697 # Inject library dependencies
773 if [[ -n ${KMLOADLIBS} ]] ; then 698 if [[ -n ${KMLOADLIBS} ]] ; then
774 load_library_dependencies 699 load_library_dependencies
775 fi 700 fi
776 701
777 # Replace KDE4Workspace library targets
778 find "${S}" -name CMakeLists.txt \
779 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
780 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
781 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
782 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
783 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
784 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
785 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
786 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
787 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
788 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
789 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
790 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
791 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
792 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
793 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
794 || die 'failed to replace KDE4Workspace library targets'
795
796 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/... 702 # Hack for manuals relying on outdated DTD, only outside kde-base/...
797 if [[ -z ${KDEBASE} ]]; then 703 if [[ -z ${KDEBASE} ]]; then
798 find "${S}" -name "*.docbook" \ 704 find "${S}" -name "*.docbook" \
799 -exec sed -i -r \ 705 -exec sed -i -r \
800 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \ 706 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
801 || die 'failed to fix DocBook variant version' 707 || die 'failed to fix DocBook variant version'
809 debug-print-function ${FUNCNAME} "$@" 715 debug-print-function ${FUNCNAME} "$@"
810 716
811 # Build tests in src_test only, where we override this value 717 # Build tests in src_test only, where we override this value
812 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF) 718 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
813 719
814 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then 720 if use_if_iuse debug; then
815 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
816 fi
817
818 if has debug ${IUSE//+} && use debug; then
819 # Set "real" debug mode 721 # Set "real" debug mode
820 CMAKE_BUILD_TYPE="Debugfull" 722 CMAKE_KDE_BUILD_TYPE="Debugfull"
821 else 723 else
822 # Handle common release builds 724 # Handle common release builds
823 append-cppflags -DQT_NO_DEBUG 725 append-cppflags -DQT_NO_DEBUG
824 fi 726 fi
825 727
830 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}") 732 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
831 733
832 # Use colors 734 # Use colors
833 QTEST_COLORED=1 735 QTEST_COLORED=1
834 736
835 # Shadow existing /usr installations 737 # Shadow existing installations
836 unset KDEDIRS 738 unset KDEDIRS
837 739
838 # Handle kdeprefix-ed KDE
839 if [[ ${KDEDIR} != /usr ]]; then
840 # Override some environment variables - only when kdeprefix is different,
841 # to not break ccache/distcc
842 PATH="${EKDEDIR}/bin:${PATH}"
843
844 # Append library search path
845 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
846
847 # Append full RPATH
848 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
849
850 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
851 # when more are present
852 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
853 fi
854
855 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling 740 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
856 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4) 741 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
857 #kde-config -path data unavailable when cross-compiling 742 #kde-config -path data unavailable when cross-compiling
858 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/) 743 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
859 744
860 # Handle kdeprefix in application itself
861 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
862 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 745 # sysconf needs to be /etc, not /usr/etc
863 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc) 746 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
864 fi
865 747
866 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then 748 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
749 if [[ ${mycmakeargs} ]]; then
750 eqawarn "mycmakeargs should always be declared as an array, not a string"
751 fi
867 mycmakeargs=(${mycmakeargs}) 752 mycmakeargs=(${mycmakeargs})
868 fi 753 fi
869 754
870 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}") 755 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
871 756
884# @FUNCTION: kde4-base_src_test 769# @FUNCTION: kde4-base_src_test
885# @DESCRIPTION: 770# @DESCRIPTION:
886# Function for testing KDE4 applications. 771# Function for testing KDE4 applications.
887kde4-base_src_test() { 772kde4-base_src_test() {
888 debug-print-function ${FUNCNAME} "$@" 773 debug-print-function ${FUNCNAME} "$@"
774
775 local kded4_pid
776
777 _test_runner() {
778 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
779 export $(dbus-launch)
780 kded4 2>&1 > /dev/null &
781 kded4_pid=$!
782 fi
783
784 cmake-utils_src_test
785 }
786
787 # When run as normal user during ebuild development with the ebuild command, the
788 # kde tests tend to access the session DBUS. This however is not possible in a real
789 # emerge or on the tinderbox.
790 # > make sure it does not happen, so bad tests can be recognized and disabled
791 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
889 792
890 # Override this value, set in kde4-base_src_configure() 793 # Override this value, set in kde4-base_src_configure()
891 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON) 794 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
892 cmake-utils_src_configure 795 cmake-utils_src_configure
893 kde4-base_src_compile 796 kde4-base_src_compile
894
895 # When run as normal user during ebuild development with the ebuild command, the
896 # kde tests tend to access the session DBUS. This however is not possible in a real
897 # emerge or on the tinderbox.
898 # > make sure it does not happen, so bad tests can be recognized and disabled
899 unset DBUS_SESSION_BUS_ADDRESS
900 797
901 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then 798 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
902 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default 799 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
903 if [[ ${VIRTUALX_COMMAND} != emake ]]; then 800 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
904 # surprise- we are already INSIDE virtualmake!!! 801 # surprise- we are already INSIDE virtualmake!!!
905 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality." 802 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
906 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild." 803 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
907 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the" 804 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
908 debug-print " kde4-base.eclass docs for details... Applying workaround." 805 debug-print " kde4-base.eclass docs for details... Applying workaround."
909 cmake-utils_src_test 806 _test_runner
910 else 807 else
911 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake 808 VIRTUALX_COMMAND="_test_runner" virtualmake
912 fi 809 fi
913 else 810 else
914 cmake-utils_src_test 811 _test_runner
812 fi
813
814 if [ -n "${kded4_pid}" ] ; then
815 kill ${kded4_pid}
816 fi
817
818 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
819 kill ${DBUS_SESSION_BUS_PID}
915 fi 820 fi
916} 821}
917 822
918# @FUNCTION: kde4-base_src_install 823# @FUNCTION: kde4-base_src_install
919# @DESCRIPTION: 824# @DESCRIPTION:
949# Function storing icon caches 854# Function storing icon caches
950kde4-base_pkg_preinst() { 855kde4-base_pkg_preinst() {
951 debug-print-function ${FUNCNAME} "$@" 856 debug-print-function ${FUNCNAME} "$@"
952 857
953 gnome2_icon_savelist 858 gnome2_icon_savelist
859 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
860 subversion_pkg_preinst
861 fi
954} 862}
955 863
956# @FUNCTION: kde4-base_pkg_postinst 864# @FUNCTION: kde4-base_pkg_postinst
957# @DESCRIPTION: 865# @DESCRIPTION:
958# Function to rebuild the KDE System Configuration Cache after an application has been installed. 866# Function to rebuild the KDE System Configuration Cache after an application has been installed.
963 fdo-mime_desktop_database_update 871 fdo-mime_desktop_database_update
964 fdo-mime_mime_database_update 872 fdo-mime_mime_database_update
965 buildsycoca 873 buildsycoca
966 874
967 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 875 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
968 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
969 echo
970 ewarn "WARNING! you have kdeenable final useflag enabled."
971 ewarn "This useflag needs to be enabled on ALL kde using packages and"
972 ewarn "is known to cause issues."
973 ewarn "You are using this setup at your own risk and the kde team does not"
974 ewarn "take responsibilities for dead kittens."
975 echo
976 fi
977 if [[ ${BUILD_TYPE} = live ]]; then 876 if [[ ${KDE_BUILD_TYPE} = live ]]; then
978 echo 877 echo
979 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}" 878 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
980 einfo "Use it at your own risk." 879 einfo "Use it at your own risk."
981 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!" 880 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
982 echo 881 echo
992 ewarn "With this setting you are unsupported by KDE team." 891 ewarn "With this setting you are unsupported by KDE team."
993 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID." 892 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
994 fi 893 fi
995 fi 894 fi
996 fi 895 fi
997 if has kdeprefix ${IUSE//+} && use kdeprefix; then
998 # warning about kdeprefix
999 echo
1000 ewarn "WARNING! You have the kdeprefix useflag enabled."
1001 eerror "This setting will be removed on or about 2011-06-06."
1002 ewarn "You are using this setup at your own risk and the kde team does not"
1003 ewarn "take responsibilities for dead kittens."
1004 echo
1005 fi
1006} 896}
1007 897
1008# @FUNCTION: kde4-base_pkg_postrm 898# @FUNCTION: kde4-base_pkg_postrm
1009# @DESCRIPTION: 899# @DESCRIPTION:
1010# Function to rebuild the KDE System Configuration Cache after an application has been removed. 900# Function to rebuild the KDE System Configuration Cache after an application has been removed.

Legend:
Removed from v.1.93  
changed lines
  Added in v.1.124

  ViewVC Help
Powered by ViewVC 1.1.20