/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Contents of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.155 - (show annotations) (download)
Thu Jun 4 18:49:42 2015 UTC (2 years, 5 months ago) by kensington
Branch: MAIN
Changes since 1.154: +4 -4 lines
Move various kde-base packages to kde-apps.

1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.154 2015/06/03 22:36:30 mrueg Exp $
4
5 # @ECLASS: kde4-base.eclass
6 # @MAINTAINER:
7 # kde@gentoo.org
8 # @BLURB: This eclass provides functions for kde 4.X ebuilds
9 # @DESCRIPTION:
10 # The kde4-base.eclass provides support for building KDE4 based ebuilds
11 # and KDE4 applications.
12 #
13 # NOTE: KDE 4 ebuilds currently support EAPI 5. This will be
14 # reviewed over time as new EAPI versions are approved.
15
16 if [[ -z ${_KDE4_BASE_ECLASS} ]]; then
17 _KDE4_BASE_ECLASS=1
18
19 # @ECLASS-VARIABLE: KDE_SELINUX_MODULE
20 # @DESCRIPTION:
21 # If set to "none", do nothing.
22 # For any other value, add selinux to IUSE, and depending on that useflag
23 # add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
24 : ${KDE_SELINUX_MODULE:=none}
25
26 # @ECLASS-VARIABLE: VIRTUALDBUS_TEST
27 # @DESCRIPTION:
28 # If defined, launch and use a private dbus session during src_test.
29
30 # @ECLASS-VARIABLE: VIRTUALX_REQUIRED
31 # @DESCRIPTION:
32 # For proper description see virtualx.eclass manpage.
33 # Here we redefine default value to be manual, if your package needs virtualx
34 # for tests you should proceed with setting VIRTUALX_REQUIRED=test.
35 : ${VIRTUALX_REQUIRED:=manual}
36
37 inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils virtualx versionator eutils multilib
38
39 if [[ ${KDE_BUILD_TYPE} = live ]]; then
40 case ${KDE_SCM} in
41 svn) inherit subversion ;;
42 git) inherit git-r3 ;;
43 esac
44 fi
45
46 # @ECLASS-VARIABLE: CMAKE_REQUIRED
47 # @DESCRIPTION:
48 # Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
49 # Please note that if it's set to 'never' you need to explicitly override following phases:
50 # src_configure, src_compile, src_test and src_install.
51 # Defaults to 'always'.
52 : ${CMAKE_REQUIRED:=always}
53 if [[ ${CMAKE_REQUIRED} = always ]]; then
54 buildsystem_eclass="cmake-utils"
55 export_fns="src_configure src_compile src_test src_install"
56 fi
57
58 # @ECLASS-VARIABLE: KDE_MINIMAL
59 # @DESCRIPTION:
60 # This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
61 # version for apps to work. Currently defaults to 4.4
62 # One may override this variable to raise version requirements.
63 # Note that it is fixed to ${PV} for kde-base packages.
64 KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
65
66 # Set slot for KDEBASE known packages
67 case ${KDEBASE} in
68 kde-base)
69 SLOT=4/$(get_version_component_range 1-2)
70 KDE_MINIMAL="${PV}"
71 ;;
72 kdevelop)
73 if [[ ${KDE_BUILD_TYPE} = live ]]; then
74 # @ECLASS-VARIABLE: KDEVELOP_VERSION
75 # @DESCRIPTION:
76 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
77 # Applies to KDEBASE=kdevelop only.
78 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.9999}"
79 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
80 # @DESCRIPTION:
81 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
82 # Applies to KDEBASE=kdevelop only.
83 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-4.9999}"
84 else
85 case ${PN} in
86 kdevelop)
87 KDEVELOP_VERSION=${PV}
88 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
89 ;;
90 kdevplatform|kdevelop-php*|kdevelop-python)
91 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
92 KDEVPLATFORM_VERSION=${PV}
93 ;;
94 *)
95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
96 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
97 esac
98 fi
99 SLOT="4"
100 ;;
101 esac
102
103 inherit ${buildsystem_eclass}
104
105 EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
106
107 unset buildsystem_eclass
108 unset export_fns
109
110 # @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
111 # @DESCRIPTION:
112 # Is qtdeclarative required? Possible values are 'always', 'optional' and 'never'.
113 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
114 DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
115
116 # @ECLASS-VARIABLE: QTHELP_REQUIRED
117 # @DESCRIPTION:
118 # Is qthelp required? Possible values are 'always', 'optional' and 'never'.
119 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
120 QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
121
122 # @ECLASS-VARIABLE: OPENGL_REQUIRED
123 # @DESCRIPTION:
124 # Is qtopengl required? Possible values are 'always', 'optional' and 'never'.
125 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
126 OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
127
128 # @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
129 # @DESCRIPTION:
130 # Is qtmultimedia required? Possible values are 'always', 'optional' and 'never'.
131 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
132 MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
133
134 # @ECLASS-VARIABLE: CPPUNIT_REQUIRED
135 # @DESCRIPTION:
136 # Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
137 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
138 CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
139
140 # @ECLASS-VARIABLE: KDE_REQUIRED
141 # @DESCRIPTION:
142 # Is kde required? Possible values are 'always', 'optional' and 'never'.
143 # This variable must be set before inheriting any eclasses. Defaults to 'always'
144 # If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
145 # Note that for kde-base packages this variable is fixed to 'always'.
146 KDE_REQUIRED="${KDE_REQUIRED:-always}"
147
148 # @ECLASS-VARIABLE: KDE_HANDBOOK
149 # @DESCRIPTION:
150 # Set to enable handbook in application. Possible values are 'always', 'optional'
151 # (handbook USE flag) and 'never'.
152 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
153 # It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
154 # ensures buildtime and runtime dependencies.
155 KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
156
157 # @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
158 # @DESCRIPTION:
159 # Set this varible if you want your live package to manage its
160 # translations. (Mostly all kde ebuilds does not ship documentation
161 # and translations in live ebuilds)
162 if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
163 # Kdebase actualy provides the handbooks even for live stuff
164 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
165 KDE_LINGUAS=""
166 fi
167
168 # Setup packages inheriting this eclass
169 case ${KDEBASE} in
170 kde-base)
171 HOMEPAGE="http://www.kde.org/"
172 LICENSE="GPL-2"
173 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
174 # Disable tests for live ebuilds by default
175 RESTRICT+=" test"
176 fi
177
178 # This code is to prevent portage from searching GENTOO_MIRRORS for
179 # packages that will never be mirrored. (As they only will ever be in
180 # the overlay).
181 case ${PV} in
182 *9999* | 4.?.[6-9]? | 4.??.[6-9]? | ??.?.[6-9]? | ??.??.[6-9]?)
183 RESTRICT+=" mirror"
184 ;;
185 esac
186 ;;
187 kdevelop)
188 HOMEPAGE="http://www.kdevelop.org/"
189 LICENSE="GPL-2"
190 ;;
191 esac
192
193 # @ECLASS-VARIABLE: QT_MINIMAL
194 # @DESCRIPTION:
195 # Determine version of qt we enforce as minimal for the package.
196 QT_MINIMAL="${QT_MINIMAL:-4.8.5}"
197
198 # Declarative dependencies
199 qtdeclarativedepend="
200 >=dev-qt/qtdeclarative-${QT_MINIMAL}:4
201 "
202 case ${DECLARATIVE_REQUIRED} in
203 always)
204 COMMONDEPEND+=" ${qtdeclarativedepend}"
205 ;;
206 optional)
207 IUSE+=" declarative"
208 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
209 ;;
210 *) ;;
211 esac
212 unset qtdeclarativedepend
213
214 # QtHelp dependencies
215 qthelpdepend="
216 >=dev-qt/qthelp-${QT_MINIMAL}:4
217 "
218 case ${QTHELP_REQUIRED} in
219 always)
220 COMMONDEPEND+=" ${qthelpdepend}"
221 ;;
222 optional)
223 IUSE+=" qthelp"
224 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
225 ;;
226 esac
227 unset qthelpdepend
228
229 # OpenGL dependencies
230 qtopengldepend="
231 >=dev-qt/qtopengl-${QT_MINIMAL}:4
232 "
233 case ${OPENGL_REQUIRED} in
234 always)
235 COMMONDEPEND+=" ${qtopengldepend}"
236 ;;
237 optional)
238 IUSE+=" opengl"
239 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
240 ;;
241 *) ;;
242 esac
243 unset qtopengldepend
244
245 # MultiMedia dependencies
246 qtmultimediadepend="
247 >=dev-qt/qtmultimedia-${QT_MINIMAL}:4
248 "
249 case ${MULTIMEDIA_REQUIRED} in
250 always)
251 COMMONDEPEND+=" ${qtmultimediadepend}"
252 ;;
253 optional)
254 IUSE+=" multimedia"
255 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
256 ;;
257 *) ;;
258 esac
259 unset qtmultimediadepend
260
261 # CppUnit dependencies
262 cppuintdepend="
263 dev-util/cppunit
264 "
265 case ${CPPUNIT_REQUIRED} in
266 always)
267 DEPEND+=" ${cppuintdepend}"
268 ;;
269 optional)
270 IUSE+=" test"
271 DEPEND+=" test? ( ${cppuintdepend} )"
272 ;;
273 *) ;;
274 esac
275 unset cppuintdepend
276
277 # KDE dependencies
278 # Qt accessibility classes are needed in various places, bug 325461
279 kdecommondepend="
280 dev-lang/perl
281 >=dev-qt/qt3support-${QT_MINIMAL}:4[accessibility]
282 >=dev-qt/qtcore-${QT_MINIMAL}:4[qt3support,ssl]
283 >=dev-qt/qtdbus-${QT_MINIMAL}:4
284 >=dev-qt/designer-${QT_MINIMAL}:4
285 >=dev-qt/qtgui-${QT_MINIMAL}:4[accessibility,dbus(+)]
286 >=dev-qt/qtscript-${QT_MINIMAL}:4
287 >=dev-qt/qtsql-${QT_MINIMAL}:4[qt3support]
288 >=dev-qt/qtsvg-${QT_MINIMAL}:4
289 >=dev-qt/qttest-${QT_MINIMAL}:4
290 >=dev-qt/qtwebkit-${QT_MINIMAL}:4
291 "
292
293 if [[ ${PN} != kdelibs ]]; then
294 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
295 if [[ ${KDEBASE} = kdevelop ]]; then
296 if [[ ${PN} != kdevplatform ]]; then
297 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
298 # @DESCRIPTION:
299 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
300 # Applies to KDEBASE=kdevelop only.
301 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
302 case ${KDEVPLATFORM_REQUIRED} in
303 always)
304 kdecommondepend+="
305 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}:4
306 "
307 ;;
308 *) ;;
309 esac
310 fi
311 fi
312 fi
313
314 kdedepend="
315 dev-util/automoc
316 virtual/pkgconfig
317 !aqua? (
318 >=x11-libs/libXtst-1.1.0
319 x11-proto/xf86vidmodeproto
320 )
321 "
322
323 kderdepend=""
324
325 if [[ ${CATEGORY} == kde-apps ]]; then
326 kderdepend+=" !kde-base/${PN}"
327 fi
328
329 # all packages needs oxygen icons for basic iconset
330 if [[ ${PN} != oxygen-icons ]]; then
331 kderdepend+=" kde-apps/oxygen-icons"
332 fi
333
334 # add a dependency over kde-l10n
335 if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} ]]; then
336 for _lingua in ${KDE_LINGUAS}; do
337 # if our package has linguas, pull in kde-l10n with selected lingua enabled,
338 # but only for selected ones.
339 # this can't be done on one line because if user doesn't use any localisation
340 # then he is probably not interested in kde-l10n at all.
341 kderdepend+="
342 linguas_${_lingua}? ( $(add_kdeapps_dep kde4-l10n "linguas_${_lingua}(+)") )
343 "
344 done
345 unset _lingua
346 fi
347
348 kdehandbookdepend="
349 app-text/docbook-xml-dtd:4.2
350 app-text/docbook-xsl-stylesheets
351 "
352 kdehandbookrdepend="
353 $(add_kdebase_dep kdelibs 'handbook')
354 "
355 case ${KDE_HANDBOOK} in
356 always)
357 kdedepend+=" ${kdehandbookdepend}"
358 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
359 ;;
360 optional)
361 IUSE+=" +handbook"
362 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
363 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
364 ;;
365 *) ;;
366 esac
367 unset kdehandbookdepend kdehandbookrdepend
368
369 case ${KDE_SELINUX_MODULE} in
370 none) ;;
371 *)
372 IUSE+=" selinux"
373 kderdepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
374 ;;
375 esac
376
377 # We always need the aqua useflag because otherwise we cannot = refer to it inside
378 # add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
379 # (where referring to a use flag not in IUSE masks the ebuild).
380 # The only alternative would be to prohibit using add_kdebase_dep if KDE_REQUIRED=never
381 IUSE+=" aqua"
382
383 case ${KDE_REQUIRED} in
384 always)
385 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
386 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
387 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
388 ;;
389 optional)
390 IUSE+=" kde"
391 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
392 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
393 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
394 ;;
395 *) ;;
396 esac
397
398 unset kdecommondepend kdedepend kderdepend
399
400 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
401 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
402 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
403
404 # Accumulate dependencies set by this eclass
405 DEPEND+=" ${COMMONDEPEND}"
406 RDEPEND+=" ${COMMONDEPEND}"
407 unset COMMONDEPEND
408
409 # Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
410 # kdevelop ebuild, the URI should be set in the ebuild itself
411 _calculate_src_uri() {
412 debug-print-function ${FUNCNAME} "$@"
413
414 local _kmname _kmname_pv
415
416 # we calculate URI only for known KDEBASE modules
417 [[ -n ${KDEBASE} ]] || return
418
419 # calculate tarball module name
420 if [[ -n ${KMNAME} ]]; then
421 _kmname="${KMNAME}"
422 else
423 _kmname=${PN}
424 fi
425 _kmname_pv="${_kmname}-${PV}"
426 case ${KDEBASE} in
427 kde-base)
428 case ${PV} in
429 4.4.11.1)
430 # KDEPIM 4.4, special case
431 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
432 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
433 4.?.[6-9]? | 4.??.[6-9]?)
434 # Unstable KDE SC releases
435 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
436 4.11.14)
437 # Part of 4.14 actually, sigh. Not stable for next release!
438 SRC_URI="mirror://kde/stable/4.14.3/src/${_kmname_pv}.tar.xz" ;;
439 4.11.17)
440 # Part of 14.12.3 actually, sigh. Not stable for next release!
441 SRC_URI="mirror://kde/stable/applications/14.12.3/src/${_kmname_pv}.tar.xz" ;;
442 4.11.18)
443 # Part of 15.04.0 actually, sigh. Not stable for next release!
444 SRC_URI="mirror://kde/stable/applications/15.04.0/src/${_kmname_pv}.tar.xz" ;;
445 4.11.19)
446 # Part of 15.04.1 actually, sigh. Not stable for next release!
447 SRC_URI="mirror://kde/stable/applications/15.04.1/src/${_kmname_pv}.tar.xz" ;;
448 4.11.20)
449 # Part of 15.04.2 actually, sigh. Not stable for next release!
450 SRC_URI="mirror://kde/stable/applications/15.04.2/src/${_kmname_pv}.tar.xz" ;;
451 4.14.6)
452 # Part of 14.12.3 actually, sigh. Not stable for next release!
453 SRC_URI="mirror://kde/stable/applications/14.12.3/src/${_kmname_pv}.tar.xz" ;;
454 4.14.7)
455 # Part of 15.04.0 actually, sigh. Not stable for next release!
456 SRC_URI="mirror://kde/stable/applications/15.04.0/src/${_kmname_pv}.tar.xz" ;;
457 4.14.8)
458 # Part of 15.04.1 actually, sigh. Not stable for next release!
459 SRC_URI="mirror://kde/stable/applications/15.04.1/src/${_kmname_pv}.tar.xz" ;;
460 4.14.9)
461 # Part of 15.04.2 actually, sigh. Not stable for next release!
462 SRC_URI="mirror://kde/stable/applications/15.04.2/src/${_kmname_pv}.tar.xz" ;;
463 ??.?.[6-9]? | ??.??.[4-9]?)
464 # Unstable KDE Applications releases
465 SRC_URI="mirror://kde/unstable/applications/${PV}/src/${_kmname}-${PV}.tar.xz" ;;
466 *)
467 if [[ ${CATEGORY} == kde-apps ]]; then
468 # Stable KDE Applications releases
469 SRC_URI="mirror://kde/stable/applications/${PV}/src/${_kmname}-${PV}.tar.xz"
470 else
471 # Stable KDE SC releases
472 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz"
473 fi
474 ;;
475 esac
476 ;;
477 kdevelop|kdevelop-php*|kdevplatform)
478 case ${KDEVELOP_VERSION} in
479 4.[123].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz" ;;
480 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz" ;;
481 esac
482 ;;
483 esac
484 }
485
486 _calculate_live_repo() {
487 debug-print-function ${FUNCNAME} "$@"
488
489 SRC_URI=""
490 case ${KDE_SCM} in
491 svn)
492 # Determine branch URL based on live type
493 local branch_prefix
494 case ${PV} in
495 9999*)
496 # trunk
497 branch_prefix="trunk/KDE"
498 ;;
499 *)
500 # branch
501 branch_prefix="branches/KDE/$(get_kde_version)"
502 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
503 # @DESCRIPTION
504 # Suffix appended to ESVN_PROJECT depending on fetched branch.
505 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
506 ESVN_PROJECT_SUFFIX="-${PV}"
507 ;;
508 esac
509 # @ECLASS-VARIABLE: ESVN_MIRROR
510 # @DESCRIPTION:
511 # This variable allows easy overriding of default kde mirror service
512 # (anonsvn) with anything else you might want to use.
513 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
514 # Split ebuild, or extragear stuff
515 if [[ -n ${KMNAME} ]]; then
516 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
517 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
518 KMMODULE="${PN}"
519 fi
520 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
521 case ${KMNAME} in
522 kdebase-*)
523 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
524 ;;
525 kdelibs-*)
526 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
527 ;;
528 kdereview*)
529 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
530 ;;
531 kdesupport)
532 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
533 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
534 ;;
535 kde*)
536 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
537 ;;
538 extragear*|playground*)
539 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
540 # build packages from same svn location.
541 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
542 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
543 ;;
544 *)
545 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
546 ;;
547 esac
548 else
549 # kdelibs, kdepimlibs
550 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
551 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
552 fi
553 # @ECLASS-VARIABLE: ESVN_UP_FREQ
554 # @DESCRIPTION:
555 # This variable is used for specifying the timeout between svn synces
556 # for kde-base modules. Does not affect misc apps.
557 # Default value is 1 hour.
558 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
559 ;;
560 git)
561 local _kmname
562 # @ECLASS-VARIABLE: EGIT_MIRROR
563 # @DESCRIPTION:
564 # This variable allows easy overriding of default kde mirror service
565 # (anongit) with anything else you might want to use.
566 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
567
568 # @ECLASS-VARIABLE: EGIT_REPONAME
569 # @DESCRIPTION:
570 # This variable allows overriding of default repository
571 # name. Specify only if this differ from PN and KMNAME.
572 if [[ -n ${EGIT_REPONAME} ]]; then
573 # the repository and kmname different
574 _kmname=${EGIT_REPONAME}
575 elif [[ -n ${KMNAME} ]]; then
576 _kmname=${KMNAME}
577 else
578 _kmname=${PN}
579 fi
580
581 # default branching
582 [[ ${PV} != 4.9999* && ${PV} != 9999 && ${KDEBASE} == kde-base ]] && \
583 EGIT_BRANCH="KDE/$(get_kde_version)"
584
585 # Applications branching
586 [[ ${PV} == ??.??.49.9999 && ${KDEBASE} == kde-base ]] && \
587 EGIT_BRANCH="Applications/$(get_kde_version)"
588
589 # default repo uri
590 EGIT_REPO_URI+=( "${EGIT_MIRROR}/${_kmname}" )
591
592 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
593 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
594 ;;
595 esac
596 }
597
598 case ${KDE_BUILD_TYPE} in
599 live) _calculate_live_repo ;;
600 *) _calculate_src_uri ;;
601 esac
602
603 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
604
605 # @ECLASS-VARIABLE: PREFIX
606 # @DESCRIPTION:
607 # Set the installation PREFIX for non kde-base applications. It defaults to /usr.
608 # kde-base packages go into KDE4 installation directory (/usr).
609 # No matter the PREFIX, package will be built against KDE installed in /usr.
610
611 # @FUNCTION: kde4-base_pkg_setup
612 # @DESCRIPTION:
613 # Do some basic settings
614 kde4-base_pkg_setup() {
615 debug-print-function ${FUNCNAME} "$@"
616
617 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
618 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
619 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
620 fi
621
622 # Don't set KDEHOME during compilation, it will cause access violations
623 unset KDEHOME
624
625 # Check if gcc compiler is fresh enough.
626 # In theory should be in pkg_pretend but we check it only for kdelibs there
627 # and for others we do just quick scan in pkg_setup because pkg_pretend
628 # executions consume quite some time (ie. when merging 300 packages at once will cause 300 checks)
629 if [[ ${MERGE_TYPE} != binary ]]; then
630 [[ $(gcc-major-version) -lt 4 ]] || \
631 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 6 ]] ) \
632 && die "Sorry, but gcc-4.6 and earlier wont work for some KDE packages."
633 fi
634
635 KDEDIR=/usr
636 : ${PREFIX:=/usr}
637 EKDEDIR=${EPREFIX}/usr
638
639 # Point to correct QT plugins path
640 QT_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/kde4/plugins/"
641
642 # Fix XDG collision with sandbox
643 export XDG_CONFIG_HOME="${T}"
644 }
645
646 # @FUNCTION: kde4-base_src_unpack
647 # @DESCRIPTION:
648 # This function unpacks the source tarballs for KDE4 applications.
649 kde4-base_src_unpack() {
650 debug-print-function ${FUNCNAME} "$@"
651
652 if [[ ${KDE_BUILD_TYPE} = live ]]; then
653 case ${KDE_SCM} in
654 svn)
655 subversion_src_unpack
656 ;;
657 git)
658 git-r3_src_unpack
659 ;;
660 esac
661 else
662 unpack ${A}
663 fi
664 }
665
666 # @FUNCTION: kde4-base_src_prepare
667 # @DESCRIPTION:
668 # General pre-configure and pre-compile function for KDE4 applications.
669 # It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
670 # enable_selected_linguas() and enable_selected_doc_linguas()
671 # in kde4-functions.eclass(5) for further details.
672 kde4-base_src_prepare() {
673 debug-print-function ${FUNCNAME} "$@"
674
675 # enable handbook and linguas only when not using live ebuild
676
677 # Only enable selected languages, used for KDE extragear apps.
678 if [[ -n ${KDE_LINGUAS} ]]; then
679 enable_selected_linguas
680 fi
681
682 # Enable/disable handbooks for kde4-base packages
683 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
684 # kdelibs inherits kde4-base but handle installing the handbook itself
685 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
686 if [[ ${KDEBASE} == kde-base ]]; then
687 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
688 # documentation in kde4-functions
689 : ${KDE_DOC_DIRS:=doc}
690 local dir
691 for dir in ${KDE_DOC_DIRS}; do
692 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
693 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
694 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
695 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
696 -i CMakeLists.txt || die "failed to comment out handbook"
697 done
698 fi
699 else
700 enable_selected_doc_linguas
701 fi
702 fi
703
704 # SCM bootstrap
705 if [[ ${KDE_BUILD_TYPE} = live ]]; then
706 case ${KDE_SCM} in
707 svn) subversion_src_prepare ;;
708 esac
709 fi
710
711 # Apply patches, cmake-utils does the job already
712 cmake-utils_src_prepare
713
714 # Save library dependencies
715 if [[ -n ${KMSAVELIBS} ]] ; then
716 save_library_dependencies
717 fi
718
719 # Inject library dependencies
720 if [[ -n ${KMLOADLIBS} ]] ; then
721 load_library_dependencies
722 fi
723
724 # Hack for manuals relying on outdated DTD, only outside kde-base/...
725 if [[ -z ${KDEBASE} ]]; then
726 find "${S}" -name "*.docbook" \
727 -exec sed -i -r \
728 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
729 || die 'failed to fix DocBook variant version'
730 fi
731 }
732
733 # @FUNCTION: kde4-base_src_configure
734 # @DESCRIPTION:
735 # Function for configuring the build of KDE4 applications.
736 kde4-base_src_configure() {
737 debug-print-function ${FUNCNAME} "$@"
738
739 # Build tests in src_test only, where we override this value
740 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
741
742 if use_if_iuse debug; then
743 # Set "real" debug mode
744 CMAKE_KDE_BUILD_TYPE="Debugfull"
745 else
746 # Handle common release builds
747 append-cppflags -DQT_NO_DEBUG
748 fi
749
750 # Set distribution name
751 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
752
753 # Here we set the install prefix
754 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
755
756 # Use colors
757 QTEST_COLORED=1
758
759 # Shadow existing installations
760 unset KDEDIRS
761
762 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
763 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
764 #kde-config -path data unavailable when cross-compiling
765 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
766
767 # sysconf needs to be /etc, not /usr/etc
768 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
769
770 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
771 if [[ ${mycmakeargs} ]]; then
772 eqawarn "mycmakeargs should always be declared as an array, not a string"
773 fi
774 mycmakeargs=(${mycmakeargs})
775 fi
776
777 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
778
779 cmake-utils_src_configure
780 }
781
782 # @FUNCTION: kde4-base_src_compile
783 # @DESCRIPTION:
784 # General function for compiling KDE4 applications.
785 kde4-base_src_compile() {
786 debug-print-function ${FUNCNAME} "$@"
787
788 cmake-utils_src_compile "$@"
789 }
790
791 # @FUNCTION: kde4-base_src_test
792 # @DESCRIPTION:
793 # Function for testing KDE4 applications.
794 kde4-base_src_test() {
795 debug-print-function ${FUNCNAME} "$@"
796
797 local kded4_pid
798
799 _test_runner() {
800 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
801 export $(dbus-launch)
802 kded4 2>&1 > /dev/null &
803 kded4_pid=$!
804 fi
805
806 cmake-utils_src_test
807 }
808
809 # When run as normal user during ebuild development with the ebuild command, the
810 # kde tests tend to access the session DBUS. This however is not possible in a real
811 # emerge or on the tinderbox.
812 # > make sure it does not happen, so bad tests can be recognized and disabled
813 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
814
815 # Override this value, set in kde4-base_src_configure()
816 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
817 cmake-utils_src_configure
818 kde4-base_src_compile
819
820 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
821 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
822 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
823 # surprise- we are already INSIDE virtualmake!!!
824 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
825 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
826 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
827 debug-print " kde4-base.eclass docs for details... Applying workaround."
828 _test_runner
829 else
830 VIRTUALX_COMMAND="_test_runner" virtualmake
831 fi
832 else
833 _test_runner
834 fi
835
836 if [ -n "${kded4_pid}" ] ; then
837 kill ${kded4_pid}
838 fi
839
840 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
841 kill ${DBUS_SESSION_BUS_PID}
842 fi
843 }
844
845 # @FUNCTION: kde4-base_src_install
846 # @DESCRIPTION:
847 # Function for installing KDE4 applications.
848 kde4-base_src_install() {
849 debug-print-function ${FUNCNAME} "$@"
850
851 if [[ -n ${KMSAVELIBS} ]] ; then
852 install_library_dependencies
853 fi
854
855 # Install common documentation of KDE4 applications
856 local doc
857 if ! has kde4-meta ${INHERITED}; then
858 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
859 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
860 done
861 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
862 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
863 done
864 fi
865
866 cmake-utils_src_install
867
868 # We don't want ${PREFIX}/share/doc/HTML to be compressed,
869 # because then khelpcenter can't find the docs
870 [[ -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
871 docompress -x ${PREFIX}/share/doc/HTML
872 }
873
874 # @FUNCTION: kde4-base_pkg_preinst
875 # @DESCRIPTION:
876 # Function storing icon caches
877 kde4-base_pkg_preinst() {
878 debug-print-function ${FUNCNAME} "$@"
879
880 gnome2_icon_savelist
881 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
882 subversion_pkg_preinst
883 fi
884 }
885
886 # @FUNCTION: kde4-base_pkg_postinst
887 # @DESCRIPTION:
888 # Function to rebuild the KDE System Configuration Cache after an application has been installed.
889 kde4-base_pkg_postinst() {
890 debug-print-function ${FUNCNAME} "$@"
891
892 gnome2_icon_cache_update
893 fdo-mime_desktop_database_update
894 fdo-mime_mime_database_update
895 buildsycoca
896
897 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
898 if [[ ${KDE_BUILD_TYPE} = live ]]; then
899 echo
900 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
901 einfo "Use it at your own risk."
902 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
903 echo
904 fi
905 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
906 if [[ ${KDEBASE} != kde-base ]] && \
907 ! has_version 'kde-apps/kdebase-runtime-meta' && \
908 ! has_version 'kde-base/kdebase-startkde'; then
909 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
910 echo
911 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
912 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
913 ewarn "With this setting you are unsupported by KDE team."
914 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
915 fi
916 fi
917 fi
918 }
919
920 # @FUNCTION: kde4-base_pkg_postrm
921 # @DESCRIPTION:
922 # Function to rebuild the KDE System Configuration Cache after an application has been removed.
923 kde4-base_pkg_postrm() {
924 debug-print-function ${FUNCNAME} "$@"
925
926 gnome2_icon_cache_update
927 fdo-mime_desktop_database_update
928 fdo-mime_mime_database_update
929 buildsycoca
930 }
931
932 fi

  ViewVC Help
Powered by ViewVC 1.1.20