/[gentoo-x86]/eclass/kernel-2.eclass
Gentoo

Diff of /eclass/kernel-2.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.286
1# Copyright 1999-2013 Gentoo Foundation 1# Copyright 1999-2013 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.285 2013/07/15 14:04:31 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.286 2013/07/31 21:18:41 hasufell Exp $
4 4
5# Description: kernel.eclass rewrite for a clean base regarding the 2.6 5# Description: kernel.eclass rewrite for a clean base regarding the 2.6
6# series of kernel with back-compatibility for 2.4 6# series of kernel with back-compatibility for 2.4
7# 7#
8# Original author: John Mylchreest <johnm@gentoo.org> 8# Original author: John Mylchreest <johnm@gentoo.org>
812 fi 812 fi
813 813
814 # optionally display security unsupported message 814 # optionally display security unsupported message
815 # Start with why 815 # Start with why
816 if [[ ${K_SECURITY_UNSUPPORTED} = deblob ]]; then 816 if [[ ${K_SECURITY_UNSUPPORTED} = deblob ]]; then
817 ewarn "Deblobbed kernels are UNSUPPORTED by Gentoo Security." 817 ewarn "Deblobbed kernels may not be up-to-date security wise"
818 ewarn "as they depend on external scripts."
818 elif [[ -n ${K_SECURITY_UNSUPPORTED} ]]; then 819 elif [[ -n ${K_SECURITY_UNSUPPORTED} ]]; then
819 ewarn "${PN} is UNSUPPORTED by Gentoo Security." 820 ewarn "${PN} is UNSUPPORTED by Gentoo Security."
820 fi 821 fi
821 # And now the general message. 822 # And now the general message.
822 if [[ -n ${K_SECURITY_UNSUPPORTED} ]]; then 823 if [[ -n ${K_SECURITY_UNSUPPORTED} ]]; then

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.286

  ViewVC Help
Powered by ViewVC 1.1.20