/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.110 Revision 1.127
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/mysql.eclass,v 1.110 2009/07/06 18:18:00 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/mysql.eclass,v 1.127 2010/02/01 01:07:08 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass
6# @MAINTAINER:
5# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
6# Maintainer: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
7# - Luca Longinotti <chtekk@gentoo.org> 9# - Luca Longinotti <chtekk@gentoo.org>
8# - Robin H. Johnson <robbat2@gentoo.org> 10# - Robin H. Johnson <robbat2@gentoo.org>
11# @BLURB: This eclass provides most of the functions for mysql ebuilds
12# @DESCRIPTION:
13# The mysql.eclass provides almost all the code to build the mysql ebuilds
14# including the src_unpack, src_prepare, src_configure, src_compile,
15# scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
16# phase hooks.
9 17
10WANT_AUTOCONF="latest" 18WANT_AUTOCONF="latest"
11WANT_AUTOMAKE="latest" 19WANT_AUTOMAKE="latest"
12 20
13inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator 21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
14 22
15# Shorten the path because the socket path length must be shorter than 107 chars 23# Shorten the path because the socket path length must be shorter than 107 chars
16# and we will run a mysql server during test phase 24# and we will run a mysql server during test phase
17S="${WORKDIR}/mysql" 25S="${WORKDIR}/mysql"
18 26
21 EGIT_PROJECT=mysql-extras 29 EGIT_PROJECT=mysql-extras
22 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git" 30 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
23 inherit git 31 inherit git
24fi 32fi
25 33
34case "${EAPI:-0}" in
35 2)
36 EXPORT_FUNCTIONS pkg_setup \
37 src_unpack src_prepare \
38 src_configure src_compile \
39 src_install \
40 pkg_preinst pkg_postinst \
41 pkg_config pkg_postrm
42 IUSE_DEFAULT_ON='+'
43 ;;
44 0 | 1)
45 EXPORT_FUNCTIONS pkg_setup \
46 src_unpack \
47 src_compile \
48 src_install \
49 pkg_preinst pkg_postinst \
50 pkg_config pkg_postrm
51 ;;
52 *)
53 die "Unsupported EAPI: ${EAPI}" ;;
54esac
55
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION:
26# MYSQL_VERSION_ID will be: 58# MYSQL_VERSION_ID will be:
27# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
28# This is an important part, because many of the choices the MySQL ebuild will do 60# This is an important part, because many of the choices the MySQL ebuild will do
29# depend on this variable. 61# depend on this variable.
30# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803" 62# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
39 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}" 71 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
40done 72done
41# strip leading "0" (otherwise it's considered an octal number by BASH) 73# strip leading "0" (otherwise it's considered an octal number by BASH)
42MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"} 74MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
43 75
76# @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
77# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no).
44# Community features are available in mysql-community 80# Community features are available in mysql-community
45# AND in the re-merged mysql-5.0.82 and newer 81# AND in the re-merged mysql-5.0.82 and newer
46if [ "${PN}" == "mysql-community" ]; then 82if [ "${PN}" == "mysql-community" ]; then
47 MYSQL_COMMUNITY_FEATURES=1 83 MYSQL_COMMUNITY_FEATURES=1
48elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
49 MYSQL_COMMUNITY_FEATURES=1 85 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ]; then
89 MYSQL_COMMUNITY_FEATURES=1
50else 90else
51 MYSQL_COMMUNITY_FEATURES=0 91 MYSQL_COMMUNITY_FEATURES=0
52fi 92fi
93
94# @ECLASS-VARIABLE: XTRADB_VER
95# @DESCRIPTION:
96# Version of the XTRADB storage engine
97XTRADB_VER="${XTRADB_VER}"
98
99# @ECLASS-VARIABLE: PERCONA_VER
100# @DESCRIPTION:
101# Designation by PERCONA for a MySQL version to apply an XTRADB release
102PERCONA_VER="${PERCONA_VER}"
53 103
54# Be warned, *DEPEND are version-dependant 104# Be warned, *DEPEND are version-dependant
55# These are used for both runtime and compiletime 105# These are used for both runtime and compiletime
56DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d ) 106DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
57 userland_GNU? ( sys-process/procps ) 107 userland_GNU? ( sys-process/procps )
96fi 146fi
97 147
98# Define correct SRC_URIs 148# Define correct SRC_URIs
99SRC_URI="${SERVER_URI}" 149SRC_URI="${SERVER_URI}"
100 150
101[[ ${MY_EXTRAS_VER} != live ]] && SRC_URI="${SRC_URI} 151# Gentoo patches to MySQL
152[[ ${MY_EXTRAS_VER} != live ]] \
153&& SRC_URI="${SRC_URI}
102 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 154 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
103 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 155 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
156 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
157
158# PBXT engine
104mysql_version_is_at_least "5.1.12" \ 159mysql_version_is_at_least "5.1.12" \
105&& [[ -n "${PBXT_VERSION}" ]] \ 160&& [[ -n "${PBXT_VERSION}" ]] \
106&& SRC_URI="${SRC_URI} pbxt? ( mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz )" 161&& PBXT_P="pbxt-${PBXT_VERSION}" \
162&& PBXT_SRC_URI="mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
163&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )"
164
165# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
166mysql_version_is_at_least "5.1.26" \
167&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
168&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
169&& XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
170&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )"
107 171
108DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 172DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
109HOMEPAGE="http://www.mysql.com/" 173HOMEPAGE="http://www.mysql.com/"
110LICENSE="GPL-2" 174LICENSE="GPL-2"
111SLOT="0" 175SLOT="0"
112IUSE="big-tables debug embedded minimal perl selinux ssl static" 176IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static"
113 177
114mysql_version_is_at_least "4.1" \ 178mysql_version_is_at_least "4.1" \
115&& IUSE="${IUSE} latin1" 179&& IUSE="${IUSE} latin1"
116 180
117mysql_version_is_at_least "4.1.3" \ 181mysql_version_is_at_least "4.1.3" \
125 189
126mysql_version_is_at_least "5.1" \ 190mysql_version_is_at_least "5.1" \
127|| IUSE="${IUSE} berkdb" 191|| IUSE="${IUSE} berkdb"
128 192
129mysql_version_is_at_least "5.1.12" \ 193mysql_version_is_at_least "5.1.12" \
194&& [[ -n "${PBXT_VERSION}" ]] \
130&& IUSE="${IUSE} pbxt" 195&& IUSE="${IUSE} pbxt"
131 196
197mysql_version_is_at_least "5.1.26" \
198&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
199&& IUSE="${IUSE} xtradb"
200
132[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 201[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
133&& IUSE="${IUSE} community profiling" 202&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
134
135EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \
136 pkg_postinst pkg_config pkg_postrm
137 203
138# 204#
139# HELPER FUNCTIONS: 205# HELPER FUNCTIONS:
140# 206#
141 207
208# @FUNCTION: mysql_disable_test
209# @DESCRIPTION:
210# Helper function to disable specific tests.
142mysql_disable_test() { 211mysql_disable_test() {
212 local rawtestname testname testsuite reason mysql_disable_file
143 local testname="${1}" ; shift 213 rawtestname="${1}" ; shift
144 local reason="${@}" 214 reason="${@}"
215 ewarn "test '${rawtestname}' disabled: '${reason}'"
216
217 testsuite="${rawtestname/.*}"
218 testname="${rawtestname/*.}"
145 local mysql_disable_file="${S}/mysql-test/t/disabled.def" 219 mysql_disable_file="${S}/mysql-test/t/disabled.def"
220 einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
146 echo ${testname} : ${reason} >> "${mysql_disable_file}" 221 echo ${testname} : ${reason} >> "${mysql_disable_file}"
147 ewarn "test '${testname}' disabled: '${reason}'"
148}
149 222
223 # ${S}/mysql-tests/t/disabled.def
224 #
225 # ${S}/mysql-tests/suite/federated/disabled.def
226 #
227 # ${S}/mysql-tests/suite/jp/t/disabled.def
228 # ${S}/mysql-tests/suite/ndb/t/disabled.def
229 # ${S}/mysql-tests/suite/rpl/t/disabled.def
230 # ${S}/mysql-tests/suite/parts/t/disabled.def
231 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
232 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
233 # ${S}/mysql-tests/suite/binlog/t/disabled.def
234 # ${S}/mysql-tests/suite/innodb/t/disabled.def
235 if [ -n "${testsuite}" ]; then
236 for mysql_disable_file in \
237 ${S}/mysql-test/suite/${testsuite}/disabled.def \
238 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
239 FAILED ; do
240 [ -f "${mysql_disable_file}" ] && break
241 done
242 if [ "${mysql_disabled_file}" != "FAILED" ]; then
243 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
244 else
245 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
246 fi
247 fi
248}
249
250# @FUNCTION: mysql_init_vars
251# @DESCRIPTION:
150# void mysql_init_vars() 252# void mysql_init_vars()
151#
152# Initialize global variables 253# Initialize global variables
153# 2005-11-19 <vivo@gentoo.org> 254# 2005-11-19 <vivo@gentoo.org>
154
155mysql_init_vars() { 255mysql_init_vars() {
156 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"} 256 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"}
157 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"} 257 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"}
158 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"} 258 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"}
159 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"} 259 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"}
186 PREVIOUS_DATADIR="yes" 286 PREVIOUS_DATADIR="yes"
187 else 287 else
188 PREVIOUS_DATADIR="no" 288 PREVIOUS_DATADIR="no"
189 fi 289 fi
190 export PREVIOUS_DATADIR 290 export PREVIOUS_DATADIR
291 fi
292 else
293 if [[ ${EBUILD_PHASE} == "config" ]]; then
294 local new_MY_DATADIR
295 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
296 | sed -ne '/datadir/s|^--datadir=||p' \
297 | tail -n1`
298
299 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
300 ewarn "MySQL MY_DATADIR has changed"
301 ewarn "from ${MY_DATADIR}"
302 ewarn "to ${new_MY_DATADIR}"
303 MY_DATADIR="${new_MY_DATADIR}"
304 fi
191 fi 305 fi
192 fi 306 fi
193 307
194 MY_SOURCEDIR=${SERVER_URI##*/} 308 MY_SOURCEDIR=${SERVER_URI##*/}
195 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 309 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
395 fi 509 fi
396 510
397 myconf="${myconf} --with-plugins=${plugins}" 511 myconf="${myconf} --with-plugins=${plugins}"
398} 512}
399 513
400pbxt_src_compile() { 514pbxt_src_configure() {
401 mysql_init_vars 515 mysql_init_vars
402 516
403 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 517 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
404 518
405 einfo "Reconfiguring dir '${PWD}'" 519 einfo "Reconfiguring dir '${PWD}'"
408 local myconf="" 522 local myconf=""
409 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 523 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}"
410 use debug && myconf="${myconf} --with-debug=full" 524 use debug && myconf="${myconf} --with-debug=full"
411 # TODO: is it safe/needed to use econf here ? 525 # TODO: is it safe/needed to use econf here ?
412 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 526 ./configure ${myconf} || die "Problem configuring PBXT storage engine"
527}
528
529pbxt_src_compile() {
530 # Be backwards compatible for now
531 if [[ $EAPI != 2 ]]; then
532 pbxt_src_configure
533 fi
413 # TODO: is it safe/needed to use emake here ? 534 # TODO: is it safe/needed to use emake here ?
414 make || die "Problem making PBXT storage engine (${myconf})" 535 make || die "Problem making PBXT storage engine (${myconf})"
415 536
416 popd 537 popd
417 # TODO: modify test suite for PBXT 538 # TODO: modify test suite for PBXT
424} 545}
425 546
426# 547#
427# EBUILD FUNCTIONS 548# EBUILD FUNCTIONS
428# 549#
550# @FUNCTION: mysql_pkg_setup
551# @DESCRIPTION:
552# Perform some basic tests and tasks during pkg_setup phase:
553# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
554# check for conflicting use flags
555# create new user and group for mysql
556# warn about deprecated features
429mysql_pkg_setup() { 557mysql_pkg_setup() {
430 if hasq test ${FEATURES} ; then 558 if hasq test ${FEATURES} ; then
431 if ! use minimal ; then 559 if ! use minimal ; then
432 if [[ $UID -eq 0 ]]; then 560 if [[ $UID -eq 0 ]]; then
433 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root." 561 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
454 && use minimal ; then 582 && use minimal ; then
455 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 583 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
456 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 584 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
457 fi 585 fi
458 586
587 # Bug #290570 fun. Upstream made us need a fairly new GCC4.
588 if mysql_version_is_at_least "5.0.83" ; then
589 GCC_VER=$(gcc-version)
590 case ${GCC_VER} in
591 2*|3*|4.0|4.1|4.2) die "Active GCC too old! Must have at least GCC4.3" ;;
592 esac
593 fi
594
459 # This should come after all of the die statements 595 # This should come after all of the die statements
460 enewgroup mysql 60 || die "problem adding 'mysql' group" 596 enewgroup mysql 60 || die "problem adding 'mysql' group"
461 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 597 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
462 598
463 mysql_check_version_range "4.0 to 5.0.99.99" \ 599 mysql_check_version_range "4.0 to 5.0.99.99" \
464 && use berkdb \ 600 && use berkdb \
465 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 601 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
466} 602}
467 603
604# @FUNCTION: mysql_src_unpack
605# @DESCRIPTION:
606# Unpack the source code and call mysql_src_prepare for EAPI < 2.
468mysql_src_unpack() { 607mysql_src_unpack() {
469 # Initialize the proper variables first 608 # Initialize the proper variables first
470 mysql_init_vars 609 mysql_init_vars
471 610
472 unpack ${A} 611 unpack ${A}
473 # Grab the patches 612 # Grab the patches
474 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack 613 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
475 614
476 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}" 615 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
616
617 # Be backwards compatible for now
618 case ${EAPI:-0} in
619 2) : ;;
620 0 | 1) mysql_src_prepare ;;
621 esac
622}
623
624# @FUNCTION: mysql_src_prepare
625# @DESCRIPTION:
626# Apply patches to the source code and remove unneeded bundled libs.
627mysql_src_prepare() {
477 cd "${S}" 628 cd "${S}"
478 629
479 # Apply the patches for this MySQL version 630 # Apply the patches for this MySQL version
480 EPATCH_SUFFIX="patch" 631 EPATCH_SUFFIX="patch"
481 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory" 632 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
495 find . -name 'Makefile.am' \ 646 find . -name 'Makefile.am' \
496 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 647 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
497 648
498 if mysql_version_is_at_least "4.1" ; then 649 if mysql_version_is_at_least "4.1" ; then
499 # Remove what needs to be recreated, so we're sure it's actually done 650 # Remove what needs to be recreated, so we're sure it's actually done
651 einfo "Cleaning up old buildscript files"
500 find . -name Makefile \ 652 find . -name Makefile \
501 -o -name Makefile.in \ 653 -o -name Makefile.in \
502 -o -name configure \ 654 -o -name configure \
503 -exec rm -f {} \; 655 -exec rm -f {} \;
504 rm -f "ltmain.sh" 656 rm -f "ltmain.sh"
505 rm -f "scripts/mysqlbug" 657 rm -f "scripts/mysqlbug"
506 fi 658 fi
507 659
508 local rebuilddirlist d 660 local rebuilddirlist d
509 661
662 if mysql_version_is_at_least "5.1.26" && use xtradb ; then
663 einfo "Replacing InnoDB with Percona XtraDB"
664 pushd "${S}"/storage
665 i="innobase"
666 o="${WORKDIR}/storage-${i}.mysql-upstream"
667 # Have we been here already?
668 [ -h "${i}" ] && rm -f "${i}"
669 # Or maybe we haven't
670 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
671 ln -s "${WORKDIR}/${XTRADB_P}" "${i}"
672 popd
673 fi
674
510 if mysql_version_is_at_least "5.1.12" ; then 675 if mysql_version_is_at_least "5.1.12" ; then
676 einfo "Updating innobase cmake"
511 rebuilddirlist="." 677 rebuilddirlist="."
512 # TODO: check this with a cmake expert 678 # TODO: check this with a cmake expert
513 cmake \ 679 cmake \
514 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 680 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
515 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 681 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
525 popd &>/dev/null 691 popd &>/dev/null
526 done 692 done
527 693
528 if mysql_check_version_range "4.1 to 5.0.99.99" \ 694 if mysql_check_version_range "4.1 to 5.0.99.99" \
529 && use berkdb ; then 695 && use berkdb ; then
696 einfo "Fixing up berkdb buildsystem"
530 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 697 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
531 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \ 698 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
532 || die "Could not copy libtool.m4 to bdb/dist/" 699 || die "Could not copy libtool.m4 to bdb/dist/"
533 #These files exist only with libtool-2*, and need to be included. 700 #These files exist only with libtool-2*, and need to be included.
534 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then 701 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
542 || die "Failed bdb reconfigure" 709 || die "Failed bdb reconfigure"
543 popd &>/dev/null 710 popd &>/dev/null
544 fi 711 fi
545} 712}
546 713
714# @FUNCTION: mysql_src_configure
715# @DESCRIPTION:
716# Configure mysql to build the code for Gentoo respecting the use flags.
547mysql_src_compile() { 717mysql_src_configure() {
548 # Make sure the vars are correctly initialized 718 # Make sure the vars are correctly initialized
549 mysql_init_vars 719 mysql_init_vars
550 720
551 # $myconf is modified by the configure_* functions 721 # $myconf is modified by the configure_* functions
552 local myconf="" 722 local myconf=""
577 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing" 747 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
578 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti" 748 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
579 mysql_version_is_at_least "5.0" \ 749 mysql_version_is_at_least "5.0" \
580 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 750 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
581 export CXXFLAGS 751 export CXXFLAGS
752
753 # bug #283926, with GCC4.4, this is required to get correct behavior.
754 append-flags -fno-strict-aliasing
582 755
583 econf \ 756 econf \
584 --libexecdir="/usr/sbin" \ 757 --libexecdir="/usr/sbin" \
585 --sysconfdir="${MY_SYSCONFDIR}" \ 758 --sysconfdir="${MY_SYSCONFDIR}" \
586 --localstatedir="${MY_LOCALSTATEDIR}" \ 759 --localstatedir="${MY_LOCALSTATEDIR}" \
597 # TODO: Move this before autoreconf !!! 770 # TODO: Move this before autoreconf !!!
598 find . -type f -name Makefile -print0 \ 771 find . -type f -name Makefile -print0 \
599 | xargs -0 -n100 sed -i \ 772 | xargs -0 -n100 sed -i \
600 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 773 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
601 774
775 if [[ $EAPI == 2 ]]; then
776 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure
777 fi
778}
779
780# @FUNCTION: mysql_src_compile
781# @DESCRIPTION:
782# Compile the mysql code.
783mysql_src_compile() {
784 # Be backwards compatible for now
785 case ${EAPI:-0} in
786 2) : ;;
787 0 | 1) mysql_src_configure ;;
788 esac
789
602 emake || die "emake failed" 790 emake || die "emake failed"
603 791
604 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile 792 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile
605} 793}
606 794
795# @FUNCTION: mysql_src_install
796# @DESCRIPTION:
797# Install mysql.
607mysql_src_install() { 798mysql_src_install() {
608 # Make sure the vars are correctly initialized 799 # Make sure the vars are correctly initialized
609 mysql_init_vars 800 mysql_init_vars
610 801
611 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 802 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed"
697 fi 888 fi
698 889
699 mysql_lib_symlinks "${D}" 890 mysql_lib_symlinks "${D}"
700} 891}
701 892
893# @FUNCTION: mysql_pkg_preinst
894# @DESCRIPTION:
895# Create the user and groups for mysql - die if that fails.
702mysql_pkg_preinst() { 896mysql_pkg_preinst() {
703 enewgroup mysql 60 || die "problem adding 'mysql' group" 897 enewgroup mysql 60 || die "problem adding 'mysql' group"
704 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 898 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
705} 899}
706 900
901# @FUNCTION: mysql_pkg_postinst
902# @DESCRIPTION:
903# Run post-installation tasks:
904# create the dir for logfiles if non-existant
905# touch the logfiles and secure them
906# install scripts
907# issue required steps for optional features
908# issue deprecation warnings
707mysql_pkg_postinst() { 909mysql_pkg_postinst() {
708 # Make sure the vars are correctly initialized 910 # Make sure the vars are correctly initialized
709 mysql_init_vars 911 mysql_init_vars
710 912
711 # Check FEATURES="collision-protect" before removing this 913 # Check FEATURES="collision-protect" before removing this
757 mysql_check_version_range "4.0 to 5.0.99.99" \ 959 mysql_check_version_range "4.0 to 5.0.99.99" \
758 && use berkdb \ 960 && use berkdb \
759 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 961 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
760} 962}
761 963
964# @FUNCTION: mysql_pkg_config
965# @DESCRIPTION:
966# Configure mysql environment.
762mysql_pkg_config() { 967mysql_pkg_config() {
968 local old_MY_DATADIR="${MY_DATADIR}"
969
763 # Make sure the vars are correctly initialized 970 # Make sure the vars are correctly initialized
764 mysql_init_vars 971 mysql_init_vars
765 972
766 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR" 973 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
767 974
768 if built_with_use ${CATEGORY}/${PN} minimal ; then 975 if built_with_use ${CATEGORY}/${PN} minimal ; then
769 die "Minimal builds do NOT include the MySQL server" 976 die "Minimal builds do NOT include the MySQL server"
977 fi
978
979 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
980 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
981 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
982
983 if [[ -d "${old_MY_DATADIR_s}" ]]; then
984 if [[ -d "${MY_DATADIR_s}" ]]; then
985 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
986 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
987 else
988 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
989 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
990 || die "Moving MY_DATADIR failed"
991 fi
992 else
993 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
994 if [[ -d "${MY_DATADIR_s}" ]]; then
995 ewarn "Attempting to use ${MY_DATADIR_s}"
996 else
997 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
998 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
999 fi
1000 fi
770 fi 1001 fi
771 1002
772 local pwd1="a" 1003 local pwd1="a"
773 local pwd2="b" 1004 local pwd2="b"
774 local maxtry=5 1005 local maxtry=5
875 einfo "Stopping the server ..." 1106 einfo "Stopping the server ..."
876 wait %1 1107 wait %1
877 einfo "Done" 1108 einfo "Done"
878} 1109}
879 1110
1111# @FUNCTION: mysql_pkg_postrm
1112# @DESCRIPTION:
1113# Remove mysql symlinks.
880mysql_pkg_postrm() { 1114mysql_pkg_postrm() {
881 : # mysql_lib_symlinks "${D}" 1115 : # mysql_lib_symlinks "${D}"
882} 1116}

Legend:
Removed from v.1.110  
changed lines
  Added in v.1.127

  ViewVC Help
Powered by ViewVC 1.1.20