/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.155
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/mysql.eclass,v 1.121 2009/12/09 18:54:05 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/mysql.eclass,v 1.155 2010/11/02 20:27:41 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
16# phase hooks. 16# phase hooks.
17 17
18WANT_AUTOCONF="latest" 18WANT_AUTOCONF="latest"
19WANT_AUTOMAKE="latest" 19WANT_AUTOMAKE="latest"
20 20
21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator 21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
22
23# Shorten the path because the socket path length must be shorter than 107 chars
24# and we will run a mysql server during test phase
25S="${WORKDIR}/mysql"
26
27[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
28if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
29 EGIT_PROJECT=mysql-extras
30 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
31 inherit git
32fi
22 33
23case "${EAPI:-0}" in 34case "${EAPI:-0}" in
24 2) 35 2)
25 EXPORT_FUNCTIONS pkg_setup \ 36 EXPORT_FUNCTIONS pkg_setup \
26 src_unpack src_prepare \ 37 src_unpack src_prepare \
40 ;; 51 ;;
41 *) 52 *)
42 die "Unsupported EAPI: ${EAPI}" ;; 53 die "Unsupported EAPI: ${EAPI}" ;;
43esac 54esac
44 55
45# Shorten the path because the socket path length must be shorter than 107 chars
46# and we will run a mysql server during test phase
47S="${WORKDIR}/mysql"
48 56
49[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z" 57# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
50if [[ "${MY_EXTRAS_VER}" == "live" ]]; then 58# @DESCRIPTION:
51 EGIT_PROJECT=mysql-extras 59# Upstream MySQL considers the first two parts of the version number to be the
52 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git" 60# major version. Upgrades that change major version should always run
53 inherit git 61# mysql_upgrade.
62MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
63
64# Cluster is a special case...
65if [[ "${PN}" == "mysql-cluster" ]]; then
66 case $PV in
67 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
68 esac
54fi 69fi
70
55 71
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID 72# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION: 73# @DESCRIPTION:
58# MYSQL_VERSION_ID will be: 74# MYSQL_VERSION_ID will be:
59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 75# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
77# @DESCRIPTION: 93# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes) 94# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no). 95# and 0 (no).
80# Community features are available in mysql-community 96# Community features are available in mysql-community
81# AND in the re-merged mysql-5.0.82 and newer 97# AND in the re-merged mysql-5.0.82 and newer
82if [ "${PN}" == "mysql-community" ]; then 98if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
83 MYSQL_COMMUNITY_FEATURES=1 99 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 100elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1 101 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then 102elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1 103 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ]; then 104elif [ "${PV#5.4}" != "${PV}" ] ; then
105 MYSQL_COMMUNITY_FEATURES=1
106elif [ "${PV#5.5}" != "${PV}" ] ; then
107 MYSQL_COMMUNITY_FEATURES=1
108elif [ "${PV#6}" != "${PV}" ] ; then
109 MYSQL_COMMUNITY_FEATURES=1
110elif [ "${PV#7}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1 111 MYSQL_COMMUNITY_FEATURES=1
90else 112else
91 MYSQL_COMMUNITY_FEATURES=0 113 MYSQL_COMMUNITY_FEATURES=0
92fi 114fi
93 115
108 >=sys-apps/sed-4 130 >=sys-apps/sed-4
109 >=sys-apps/texinfo-4.7-r1 131 >=sys-apps/texinfo-4.7-r1
110 >=sys-libs/readline-4.1 132 >=sys-libs/readline-4.1
111 >=sys-libs/zlib-1.2.3" 133 >=sys-libs/zlib-1.2.3"
112 134
135[[ "${PN}" == "mariadb" ]] \
136&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
137
113# Having different flavours at the same time is not a good idea 138# Having different flavours at the same time is not a good idea
114for i in "" "-community" ; do 139for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
115 [[ "${i}" == ${PN#mysql} ]] || 140 [[ "${i}" == ${PN} ]] ||
116 DEPEND="${DEPEND} !dev-db/mysql${i}" 141 DEPEND="${DEPEND} !dev-db/${i}"
117done 142done
118 143
119RDEPEND="${DEPEND} 144RDEPEND="${DEPEND}
120 !minimal? ( dev-db/mysql-init-scripts ) 145 !minimal? ( dev-db/mysql-init-scripts )
121 selinux? ( sec-policy/selinux-mysql )" 146 selinux? ( sec-policy/selinux-mysql )"
130 155
131# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 156# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
132PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 157PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
133 158
134# For other stuff to bring us in 159# For other stuff to bring us in
135PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})" 160PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
136 161
137# Work out the default SERVER_URI correctly 162# Work out the default SERVER_URI correctly
138if [ -z "${SERVER_URI}" ]; then 163if [ -z "${SERVER_URI}" ]; then
164 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
165 if [ "${PN}" == "mariadb" ]; then
166 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
167 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
168 SERVER_URI="
169 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
170 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
171 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
172 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
173 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
174 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
175 "
139 # The community build is on the mirrors 176 # The community and cluster builds are on the mirrors
140 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 177 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
141 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz" 178 if [[ "${PN}" == "mysql-cluster" ]] ; then
179 URI_DIR="MySQL-Cluster"
180 URI_FILE="mysql-cluster-gpl"
181 else
182 URI_DIR="MySQL"
183 URI_FILE="mysql"
184 fi
185 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
186 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
187 # Recently upstream switched to an archive site, and not on mirrors
188 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
189 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
142 # The (old) enterprise source is on the primary site only 190 # The (old) enterprise source is on the primary site only
143 elif [ "${PN}" == "mysql" ]; then 191 elif [ "${PN}" == "mysql" ]; then
144 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz" 192 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
145 fi 193 fi
146fi 194fi
147 195
148# Define correct SRC_URIs 196# Define correct SRC_URIs
149SRC_URI="${SERVER_URI}" 197SRC_URI="${SERVER_URI}"
150 198
151[[ ${MY_EXTRAS_VER} != live ]] && SRC_URI="${SRC_URI} 199# Gentoo patches to MySQL
200[[ ${MY_EXTRAS_VER} != live ]] \
201&& SRC_URI="${SRC_URI}
152 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 202 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
153 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 203 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
154PBXT_SRC_URI="mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz" 204 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
155mysql_version_is_at_least "5.1.12" \
156&& [[ -n "${PBXT_VERSION}" ]] \
157&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URIPBXT_SRC_URI} )"
158
159# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
160XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/percona-xtradb-${XTRADB_VER}.tar.gz"
161mysql_version_is_at_least "5.1.26" \
162&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
163&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )"
164 205
165DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 206DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
166HOMEPAGE="http://www.mysql.com/" 207HOMEPAGE="http://www.mysql.com/"
208if [[ "${PN}" == "mariadb" ]]; then
209 HOMEPAGE="http://askmonty.org/"
210 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
211fi
212if [[ "${PN}" == "mysql-community" ]]; then
213 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
214fi
167LICENSE="GPL-2" 215LICENSE="GPL-2"
168SLOT="0" 216SLOT="0"
169IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static" 217IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
170 218
171mysql_version_is_at_least "4.1" \ 219mysql_version_is_at_least "4.1" \
172&& IUSE="${IUSE} latin1" 220&& IUSE="${IUSE} latin1"
173 221
174mysql_version_is_at_least "4.1.3" \ 222if mysql_version_is_at_least "4.1.3" ; then
175&& IUSE="${IUSE} cluster extraengine" 223 IUSE="${IUSE} extraengine"
224 if [[ "${PN}" != "mysql-cluster" ]] ; then
225 IUSE="${IUSE} cluster"
226 fi
227fi
176 228
177mysql_version_is_at_least "5.0" \ 229mysql_version_is_at_least "5.0" \
178|| IUSE="${IUSE} raid" 230|| IUSE="${IUSE} raid"
179 231
180mysql_version_is_at_least "5.0.18" \ 232mysql_version_is_at_least "5.0.18" \
181&& IUSE="${IUSE} max-idx-128" 233&& IUSE="${IUSE} max-idx-128"
182 234
183mysql_version_is_at_least "5.1" \ 235mysql_version_is_at_least "5.1" \
184|| IUSE="${IUSE} berkdb" 236|| IUSE="${IUSE} berkdb"
185 237
186mysql_version_is_at_least "5.1.12" \
187&& [[ -n "${PBXT_VERSION}" ]] \
188&& IUSE="${IUSE} pbxt"
189
190mysql_version_is_at_least "5.1.26" \
191&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
192&& IUSE="${IUSE} xtradb"
193
194[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 238[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
195&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling" 239&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
240
241[[ "${PN}" == "mariadb" ]] \
242&& IUSE="${IUSE} libevent"
243
244# MariaDB has integrated PBXT
245# PBXT_VERSION means that we have a PBXT patch for this PV
246# PBXT was only introduced after 5.1.12
247pbxt_patch_available() {
248 [[ "${PN}" != "mariadb" ]] \
249 && mysql_version_is_at_least "5.1.12" \
250 && [[ -n "${PBXT_VERSION}" ]]
251 return $?
252}
253
254pbxt_available() {
255 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
256 return $?
257}
258
259# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
260# MariaDB has integrated XtraDB
261# XTRADB_VERS means that we have a XTRADB patch for this PV
262# XTRADB was only introduced after 5.1.26
263xtradb_patch_available() {
264 [[ "${PN}" != "mariadb" ]] \
265 && mysql_version_is_at_least "5.1.26" \
266 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
267 return $?
268}
269
270
271pbxt_patch_available \
272&& PBXT_P="pbxt-${PBXT_VERSION}" \
273&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
274&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
275
276# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
277# vs. built outside the dir
278pbxt_available \
279&& IUSE="${IUSE} pbxt" \
280&& mysql_version_is_at_least "5.1.40" \
281&& PBXT_NEWSTYLE=1
282
283xtradb_patch_available \
284&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
285&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
286&& XTRADB_SRC_B1="http://www.percona.com/" \
287&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
288&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
289&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
290&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
291&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
292&& IUSE="${IUSE} xtradb"
196 293
197# 294#
198# HELPER FUNCTIONS: 295# HELPER FUNCTIONS:
199# 296#
200 297
201# @FUNCTION: mysql_disable_test 298# @FUNCTION: mysql_disable_test
202# @DESCRIPTION: 299# @DESCRIPTION:
203# Helper function to disable specific tests. 300# Helper function to disable specific tests.
204mysql_disable_test() { 301mysql_disable_test() {
302 local rawtestname testname testsuite reason mysql_disable_file
205 local testname="${1}" ; shift 303 rawtestname="${1}" ; shift
206 local reason="${@}" 304 reason="${@}"
305 ewarn "test '${rawtestname}' disabled: '${reason}'"
306
307 testsuite="${rawtestname/.*}"
308 testname="${rawtestname/*.}"
207 local mysql_disable_file="${S}/mysql-test/t/disabled.def" 309 mysql_disable_file="${S}/mysql-test/t/disabled.def"
310 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
208 echo ${testname} : ${reason} >> "${mysql_disable_file}" 311 echo ${testname} : ${reason} >> "${mysql_disable_file}"
209 ewarn "test '${testname}' disabled: '${reason}'" 312
313 # ${S}/mysql-tests/t/disabled.def
314 #
315 # ${S}/mysql-tests/suite/federated/disabled.def
316 #
317 # ${S}/mysql-tests/suite/jp/t/disabled.def
318 # ${S}/mysql-tests/suite/ndb/t/disabled.def
319 # ${S}/mysql-tests/suite/rpl/t/disabled.def
320 # ${S}/mysql-tests/suite/parts/t/disabled.def
321 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
322 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
323 # ${S}/mysql-tests/suite/binlog/t/disabled.def
324 # ${S}/mysql-tests/suite/innodb/t/disabled.def
325 if [ -n "${testsuite}" ]; then
326 for mysql_disable_file in \
327 ${S}/mysql-test/suite/${testsuite}/disabled.def \
328 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
329 FAILED ; do
330 [ -f "${mysql_disable_file}" ] && break
331 done
332 if [ "${mysql_disabled_file}" != "FAILED" ]; then
333 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
334 else
335 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
336 fi
337 fi
210} 338}
211 339
212# @FUNCTION: mysql_init_vars 340# @FUNCTION: mysql_init_vars
213# @DESCRIPTION: 341# @DESCRIPTION:
214# void mysql_init_vars() 342# void mysql_init_vars()
265 MY_DATADIR="${new_MY_DATADIR}" 393 MY_DATADIR="${new_MY_DATADIR}"
266 fi 394 fi
267 fi 395 fi
268 fi 396 fi
269 397
398 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
270 MY_SOURCEDIR=${SERVER_URI##*/} 399 MY_SOURCEDIR=${SERVER_URI##*/}
271 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 400 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
401 fi
272 402
273 export MY_SHAREDSTATEDIR MY_SYSCONFDIR 403 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
274 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 404 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
275 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR 405 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
276} 406}
323 if use debug ; then 453 if use debug ; then
324 myconf="${myconf} --with-debug=full" 454 myconf="${myconf} --with-debug=full"
325 else 455 else
326 myconf="${myconf} --without-debug" 456 myconf="${myconf} --without-debug"
327 mysql_version_is_at_least "4.1.3" \ 457 mysql_version_is_at_least "4.1.3" \
328 && use cluster \ 458 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
329 && myconf="${myconf} --without-ndb-debug" 459 && myconf="${myconf} --without-ndb-debug"
330 fi 460 fi
331 461
332 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then 462 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
333 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}" 463 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
357 myconf="${myconf} $(use_with perl bench)" 487 myconf="${myconf} $(use_with perl bench)"
358 myconf="${myconf} --enable-assembler" 488 myconf="${myconf} --enable-assembler"
359 myconf="${myconf} --with-extra-tools" 489 myconf="${myconf} --with-extra-tools"
360 myconf="${myconf} --with-innodb" 490 myconf="${myconf} --with-innodb"
361 myconf="${myconf} --without-readline" 491 myconf="${myconf} --without-readline"
492 myconf="${myconf} $(use_with ssl openssl)"
362 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 493 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
363 494
364 # --with-vio is not needed anymore, it's on by default and 495 # --with-vio is not needed anymore, it's on by default and
365 # has been removed from configure 496 # has been removed from configure
497 # Apply to 4.x and 5.0.[0-3]
366 if use ssl ; then 498 if use ssl ; then
367 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 499 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
368 fi
369
370 if mysql_version_is_at_least "5.1.11" ; then
371 myconf="${myconf} $(use_with ssl)"
372 else
373 myconf="${myconf} $(use_with ssl openssl)"
374 fi 500 fi
375 501
376 if mysql_version_is_at_least "5.0.60" ; then 502 if mysql_version_is_at_least "5.0.60" ; then
377 if use berkdb ; then 503 if use berkdb ; then
378 elog "Berkeley DB support was disabled due to build failures" 504 elog "Berkeley DB support was disabled due to build failures"
394 myconf="${myconf} --without-berkeley-db" 520 myconf="${myconf} --without-berkeley-db"
395 fi 521 fi
396 522
397 if mysql_version_is_at_least "4.1.3" ; then 523 if mysql_version_is_at_least "4.1.3" ; then
398 myconf="${myconf} --with-geometry" 524 myconf="${myconf} --with-geometry"
525 if [[ "${PN}" != "mysql-cluster" ]] ; then
399 myconf="${myconf} $(use_with cluster ndbcluster)" 526 myconf="${myconf} $(use_with cluster ndbcluster)"
527 fi
400 fi 528 fi
401 529
402 if mysql_version_is_at_least "4.1.3" && use extraengine ; then 530 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
403 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 531 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
404 myconf="${myconf} --with-archive-storage-engine" 532 myconf="${myconf} --with-archive-storage-engine"
435 563
436configure_51() { 564configure_51() {
437 # TODO: !!!! readd --without-readline 565 # TODO: !!!! readd --without-readline
438 # the failure depend upon config/ac-macros/readline.m4 checking into 566 # the failure depend upon config/ac-macros/readline.m4 checking into
439 # readline.h instead of history.h 567 # readline.h instead of history.h
440 myconf="${myconf} $(use_with ssl)" 568 myconf="${myconf} $(use_with ssl ssl /usr)"
441 myconf="${myconf} --enable-assembler" 569 myconf="${myconf} --enable-assembler"
442 myconf="${myconf} --with-geometry" 570 myconf="${myconf} --with-geometry"
443 myconf="${myconf} --with-readline" 571 myconf="${myconf} --with-readline"
444 myconf="${myconf} --with-row-based-replication"
445 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 572 myconf="${myconf} --with-zlib-dir=/usr/"
446 myconf="${myconf} --without-pstack" 573 myconf="${myconf} --without-pstack"
574 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
575
576 # This is an explict die here, because if we just forcibly disable it, then the
577 # user's data is not accessible.
578 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
447 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 579 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
580 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
581 myconf="${myconf} $(use_enable community community-features)"
582 if use community; then
583 myconf="${myconf} $(use_enable profiling)"
584 else
585 myconf="${myconf} --disable-profiling"
586 fi
587 fi
588
589 # Scan for all available plugins
590 local plugins_avail="$(
591 LANG=C \
592 find "${S}" \
593 \( \
594 -name 'plug.in' \
595 -o -iname 'configure.in' \
596 -o -iname 'configure.ac' \
597 \) \
598 -print0 \
599 | xargs -0 sed -r -n \
600 -e '/^MYSQL_STORAGE_ENGINE/{
601 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
602 s~^([^ ]+).*~\1~gp;
603 }' \
604 | tr -s '\n' ' '
605 )"
448 606
449 # 5.1 introduces a new way to manage storage engines (plugins) 607 # 5.1 introduces a new way to manage storage engines (plugins)
450 # like configuration=none 608 # like configuration=none
609 # This base set are required, and will always be statically built.
451 local plugins="csv,myisam,myisammrg,heap" 610 local plugins_sta="csv myisam myisammrg heap"
611 local plugins_dyn=""
612 local plugins_dis="example ibmdb2i"
613
614 # These aren't actually required by the base set, but are really useful:
615 plugins_sta="${plugins_sta} archive blackhole"
616
617 # default in 5.5.4
618 if mysql_version_is_at_least "5.5.4" ; then
619 plugins_sta="${plugins_sta} partition"
620 fi
621 # Now the extras
452 if use extraengine ; then 622 if use extraengine ; then
453 # like configuration=max-no-ndb, archive and example removed in 5.1.11 623 # like configuration=max-no-ndb, archive and example removed in 5.1.11
454 plugins="${plugins},archive,blackhole,example,federated,partition" 624 # not added yet: ibmdb2i
625 # Not supporting as examples: example,daemon_example,ftexample
626 plugins_sta="${plugins_sta} partition"
627 plugins_dyn="${plugins_sta} federated"
455 628
629 if [[ "${PN}" != "mariadb" ]] ; then
456 elog "Before using the Federated storage engine, please be sure to read" 630 elog "Before using the Federated storage engine, please be sure to read"
457 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 631 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
632 else
633 elog "MariaDB includes the FederatedX engine. Be sure to read"
634 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
458 fi 635 fi
636 else
637 plugins_dis="${plugins_dis} partition federated"
638 fi
459 639
460 # Upstream specifically requests that InnoDB always be built. 640 # Upstream specifically requests that InnoDB always be built:
461 plugins="${plugins},innobase" 641 # - innobase, innodb_plugin
642 # Build falcon if available for 6.x series.
643 for i in innobase falcon ; do
644 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
645 done
646 for i in innodb_plugin ; do
647 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
648 done
462 649
463 # like configuration=max-no-ndb 650 # like configuration=max-no-ndb
464 if use cluster ; then 651 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
465 plugins="${plugins},ndbcluster" 652 plugins_sta="${plugins_sta} ndbcluster partition"
653 plugins_dis="${plugins_dis//partition}"
466 myconf="${myconf} --with-ndb-binlog" 654 myconf="${myconf} --with-ndb-binlog"
655 else
656 plugins_dis="${plugins_dis} ndbcluster"
467 fi 657 fi
468 658
469 if mysql_version_is_at_least "5.2" ; then 659 if [[ "${PN}" == "mariadb" ]] ; then
470 plugins="${plugins},falcon" 660 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
471 fi 661 # caught above.
662 plugins_sta="${plugins_sta} maria"
472 663
664 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
665 die "The ${P} package doesn't provide innobase nor xtradb"
666
667 for i in innobase xtradb ; do
668 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
669 done
670
671 myconf="${myconf} $(use_with libevent)"
672 # This is not optional, without it several upstream testcases fail.
673 # Also strongly recommended by upstream.
674 myconf="${myconf} --with-maria-tmp-tables"
675 fi
676
677 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
678 use pbxt \
679 && plugins_dyn="${plugins_dyn} pbxt" \
680 || plugins_dis="${plugins_dis} pbxt"
681 fi
682
683 use static && \
684 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
685 plugins_dyn=""
686
687 einfo "Available plugins: ${plugins_avail}"
688 einfo "Dynamic plugins: ${plugins_dyn}"
689 einfo "Static plugins: ${plugins_sta}"
690 einfo "Disabled plugins: ${plugins_dis}"
691
692 # These are the static plugins
473 myconf="${myconf} --with-plugins=${plugins}" 693 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
694 # And the disabled ones
695 for i in ${plugins_dis} ; do
696 myconf="${myconf} --without-plugin-${i}"
697 done
474} 698}
475 699
476pbxt_src_configure() { 700pbxt_src_configure() {
477 mysql_init_vars 701 mysql_init_vars
478 702
479 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 703 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
480 704
481 einfo "Reconfiguring dir '${PWD}'" 705 einfo "Reconfiguring dir '${PWD}'"
482 AT_GNUCONF_UPDATE="yes" eautoreconf 706 eautoreconf
483 707
484 local myconf="" 708 local myconf=""
485 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 709 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
486 use debug && myconf="${myconf} --with-debug=full" 710 use debug && myconf="${myconf} --with-debug=full"
487 # TODO: is it safe/needed to use econf here ?
488 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 711 econf ${myconf} || die "Problem configuring PBXT storage engine"
489} 712}
490 713
491pbxt_src_compile() { 714pbxt_src_compile() {
715
492 # Be backwards compatible for now 716 # Be backwards compatible for now
493 if [[ $EAPI != 2 ]]; then 717 if [[ $EAPI != 2 ]]; then
494 pbxt_src_configure 718 pbxt_src_configure
495 fi 719 fi
496 # TODO: is it safe/needed to use emake here ? 720 # TODO: is it safe/needed to use emake here ?
500 # TODO: modify test suite for PBXT 724 # TODO: modify test suite for PBXT
501} 725}
502 726
503pbxt_src_install() { 727pbxt_src_install() {
504 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 728 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
505 make install || die "Failed to install PBXT" 729 emake install DESTDIR="${D}" || die "Failed to install PBXT"
506 popd 730 popd
507} 731}
508 732
509# 733#
510# EBUILD FUNCTIONS 734# EBUILD FUNCTIONS
525 fi 749 fi
526 fi 750 fi
527 751
528 # Check for USE flag problems in pkg_setup 752 # Check for USE flag problems in pkg_setup
529 if use static && use ssl ; then 753 if use static && use ssl ; then
530 eerror "MySQL does not support being built statically with SSL support enabled!"
531 die "MySQL does not support being built statically with SSL support enabled!" 754 M="MySQL does not support being built statically with SSL support enabled!"
755 eerror "${M}"
756 die "${M}"
532 fi 757 fi
533 758
534 if ! mysql_version_is_at_least "5.0" \ 759 if ! mysql_version_is_at_least "5.0" \
535 && use raid \ 760 && use raid \
536 && use static ; then 761 && use static ; then
538 eerror "with RAID support enabled." 763 eerror "with RAID support enabled."
539 die "USE flags 'raid' and 'static' conflict!" 764 die "USE flags 'raid' and 'static' conflict!"
540 fi 765 fi
541 766
542 if mysql_version_is_at_least "4.1.3" \ 767 if mysql_version_is_at_least "4.1.3" \
543 && ( use cluster || use extraengine ) \ 768 && ( use cluster || use extraengine || use embedded ) \
544 && use minimal ; then 769 && use minimal ; then
545 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
546 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 770 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
771 eerror "${M}"
772 die "${M}"
773 fi
774
775 if mysql_version_is_at_least "5.1" \
776 && xtradb_patch_available \
777 && use xtradb \
778 && use embedded ; then
779 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
780 eerror "${M}"
781 die "${M}"
782 fi
783
784 # Bug #290570, 284946, 307251
785 # Upstream changes made us need a fairly new GCC4.
786 # But only for 5.0.8[3-6]!
787 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
788 GCC_VER=$(gcc-version)
789 case ${GCC_VER} in
790 2*|3*|4.0|4.1|4.2)
791 eerror "Some releases of MySQL required a very new GCC, and then"
792 eerror "later release relaxed that requirement again. Either pick a"
793 eerror "MySQL >=5.0.87, or use a newer GCC."
794 die "Active GCC too old!" ;;
795 esac
547 fi 796 fi
548 797
549 # This should come after all of the die statements 798 # This should come after all of the die statements
550 enewgroup mysql 60 || die "problem adding 'mysql' group" 799 enewgroup mysql 60 || die "problem adding 'mysql' group"
551 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 800 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
552 801
553 mysql_check_version_range "4.0 to 5.0.99.99" \ 802 mysql_check_version_range "4.0 to 5.0.99.99" \
554 && use berkdb \ 803 && use berkdb \
555 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 804 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
805
806 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
807 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
808 ewarn "5.1 series should NOT be put into production. In the near"
809 ewarn "future, it will be disabled from building."
810 ewarn ""
811 ewarn "If you need NDB support, you should instead move to the new"
812 ewarn "mysql-cluster package that represents that upstream NDB"
813 ewarn "development."
814 fi
556} 815}
557 816
558# @FUNCTION: mysql_src_unpack 817# @FUNCTION: mysql_src_unpack
559# @DESCRIPTION: 818# @DESCRIPTION:
560# Unpack the source code and call mysql_src_prepare for EAPI < 2. 819# Unpack the source code and call mysql_src_prepare for EAPI < 2.
589 # Now link in right patches 848 # Now link in right patches
590 mysql_mv_patches 849 mysql_mv_patches
591 # And apply 850 # And apply
592 epatch 851 epatch
593 852
594 # Additional checks, remove bundled zlib 853 # last -fPIC fixup, per bug #305873
854 i="${S}"/storage/innodb_plugin/plug.in
855 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
856
857 # Additional checks, remove bundled zlib (Cluster needs this, for static
858 # memory management in zlib, leave available for Cluster)
859 if [[ "${PN}" != "mysql-cluster" ]] ; then
595 rm -f "${S}/zlib/"*.[ch] 860 rm -f "${S}/zlib/"*.[ch]
596 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 861 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
862 fi
597 rm -f "scripts/mysqlbug" 863 rm -f "scripts/mysqlbug"
598 864
599 # Make charsets install in the right place 865 # Make charsets install in the right place
600 find . -name 'Makefile.am' \ 866 find . -name 'Makefile.am' \
601 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 867 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
602 868
603 if mysql_version_is_at_least "4.1" ; then 869 if mysql_version_is_at_least "4.1" ; then
604 # Remove what needs to be recreated, so we're sure it's actually done 870 # Remove what needs to be recreated, so we're sure it's actually done
871 einfo "Cleaning up old buildscript files"
605 find . -name Makefile \ 872 find . -name Makefile \
606 -o -name Makefile.in \ 873 -o -name Makefile.in \
607 -o -name configure \ 874 -o -name configure \
608 -exec rm -f {} \; 875 -exec rm -f {} \;
609 rm -f "ltmain.sh" 876 rm -f "ltmain.sh"
610 rm -f "scripts/mysqlbug" 877 rm -f "scripts/mysqlbug"
611 fi 878 fi
612 879
613 local rebuilddirlist d 880 local rebuilddirlist d
614 881
882 if xtradb_patch_available && use xtradb ; then
883 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
884 pushd "${S}"/storage >/dev/null
885 i="innobase"
886 o="${WORKDIR}/storage-${i}.mysql-upstream"
887 # Have we been here already?
888 [ -d "${o}" ] && rm -f "${i}"
889 # Or maybe we haven't
890 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
891 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
892 popd >/dev/null
893 fi
894
895 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
896 einfo "Adding storage engine: PBXT"
897 pushd "${S}"/storage >/dev/null
898 i='pbxt'
899 [ -d "${i}" ] && rm -rf "${i}"
900 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
901 popd >/dev/null
902 fi
903
615 if mysql_version_is_at_least "5.1.12" ; then 904 if mysql_version_is_at_least "5.1.12" ; then
616 rebuilddirlist="." 905 rebuilddirlist="."
906 # This does not seem to be needed presently. robbat2 2010/02/23
907 #einfo "Updating innobase cmake"
617 # TODO: check this with a cmake expert 908 ## TODO: check this with a cmake expert
618 cmake \ 909 #cmake \
619 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 910 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
620 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 911 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
621 "storage/innobase" 912 # "storage/innobase"
622 else 913 else
623 rebuilddirlist=". innobase" 914 rebuilddirlist=". innobase"
624 fi 915 fi
625 916
626 for d in ${rebuilddirlist} ; do 917 for d in ${rebuilddirlist} ; do
627 einfo "Reconfiguring dir '${d}'" 918 einfo "Reconfiguring dir '${d}'"
628 pushd "${d}" &>/dev/null 919 pushd "${d}" &>/dev/null
629 AT_GNUCONF_UPDATE="yes" eautoreconf 920 eautoreconf
630 popd &>/dev/null 921 popd &>/dev/null
631 done 922 done
632 923
633 if mysql_check_version_range "4.1 to 5.0.99.99" \ 924 if mysql_check_version_range "4.1 to 5.0.99.99" \
634 && use berkdb ; then 925 && use berkdb ; then
926 einfo "Fixing up berkdb buildsystem"
635 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 927 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
636 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \ 928 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
637 || die "Could not copy libtool.m4 to bdb/dist/" 929 || die "Could not copy libtool.m4 to bdb/dist/"
638 #These files exist only with libtool-2*, and need to be included. 930 #These files exist only with libtool-2*, and need to be included.
639 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then 931 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
688 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 980 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
689 export CXXFLAGS 981 export CXXFLAGS
690 982
691 # bug #283926, with GCC4.4, this is required to get correct behavior. 983 # bug #283926, with GCC4.4, this is required to get correct behavior.
692 append-flags -fno-strict-aliasing 984 append-flags -fno-strict-aliasing
985
986 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
987 # causes a mis-compile.
988 # Upstream bugs:
989 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
990 # http://bugs.mysql.com/bug.php?id=45205
991 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
992 append-flags -fno-omit-frame-pointer && \
993 filter-flags -fomit-frame-pointer
693 994
694 econf \ 995 econf \
695 --libexecdir="/usr/sbin" \ 996 --libexecdir="/usr/sbin" \
696 --sysconfdir="${MY_SYSCONFDIR}" \ 997 --sysconfdir="${MY_SYSCONFDIR}" \
697 --localstatedir="${MY_LOCALSTATEDIR}" \ 998 --localstatedir="${MY_LOCALSTATEDIR}" \
708 # TODO: Move this before autoreconf !!! 1009 # TODO: Move this before autoreconf !!!
709 find . -type f -name Makefile -print0 \ 1010 find . -type f -name Makefile -print0 \
710 | xargs -0 -n100 sed -i \ 1011 | xargs -0 -n100 sed -i \
711 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 1012 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
712 1013
713 if [[ $EAPI == 2 ]]; then 1014 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
714 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure 1015 pbxt_patch_available && use pbxt && pbxt_src_configure
715 fi 1016 fi
716} 1017}
717 1018
718# @FUNCTION: mysql_src_compile 1019# @FUNCTION: mysql_src_compile
719# @DESCRIPTION: 1020# @DESCRIPTION:
720# Compile the mysql code. 1021# Compile the mysql code.
721mysql_src_compile() { 1022mysql_src_compile() {
722 # Be backwards compatible for now 1023 # Be backwards compatible for now
723 case ${EAPI:-0} in 1024 case ${EAPI:-0} in
724 2) : ;; 1025 2) : ;;
725 0 | 1) mysql_src_configure ;; 1026 0 | 1) mysql_src_configure ;;
726 esac 1027 esac
727 1028
728 emake || die "emake failed" 1029 emake || die "emake failed"
729 1030
730 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile 1031 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1032 pbxt_patch_available && use pbxt && pbxt_src_compile
1033 fi
731} 1034}
732 1035
733# @FUNCTION: mysql_src_install 1036# @FUNCTION: mysql_src_install
734# @DESCRIPTION: 1037# @DESCRIPTION:
735# Install mysql. 1038# Install mysql.
736mysql_src_install() { 1039mysql_src_install() {
737 # Make sure the vars are correctly initialized 1040 # Make sure the vars are correctly initialized
738 mysql_init_vars 1041 mysql_init_vars
739 1042
740 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 1043 emake install \
1044 DESTDIR="${D}" \
1045 benchdir_root="${MY_SHAREDSTATEDIR}" \
1046 testroot="${MY_SHAREDSTATEDIR}" \
1047 || die "emake install failed"
741 1048
742 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install 1049 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1050 pbxt_patch_available && use pbxt && pbxt_src_install
1051 fi
743 1052
744 # Convenience links 1053 # Convenience links
745 einfo "Making Convenience links for mysqlcheck multi-call binary" 1054 einfo "Making Convenience links for mysqlcheck multi-call binary"
746 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 1055 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
747 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 1056 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
751 einfo "Removing duplicate /usr/share/mysql files" 1060 einfo "Removing duplicate /usr/share/mysql files"
752 rm -Rf "${D}/usr/share/info" 1061 rm -Rf "${D}/usr/share/info"
753 for removeme in "mysql-log-rotate" mysql.server* \ 1062 for removeme in "mysql-log-rotate" mysql.server* \
754 binary-configure* my-*.cnf mi_test_all* 1063 binary-configure* my-*.cnf mi_test_all*
755 do 1064 do
756 rm -f "${D}"/usr/share/mysql/${removeme} 1065 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
757 done 1066 done
758 1067
759 # Clean up stuff for a minimal build 1068 # Clean up stuff for a minimal build
760 if use minimal ; then 1069 if use minimal ; then
761 einfo "Remove all extra content for minimal build" 1070 einfo "Remove all extra content for minimal build"
763 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 1072 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
764 rm -f "${D}/usr/sbin/mysqld" 1073 rm -f "${D}/usr/sbin/mysqld"
765 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 1074 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
766 fi 1075 fi
767 1076
1077 # Unless they explicitly specific USE=test, then do not install the
1078 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1079 # validation of your database configuration after tuning it.
1080 if use !test ; then
1081 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1082 fi
1083
768 # Configuration stuff 1084 # Configuration stuff
769 if mysql_version_is_at_least "4.1" ; then 1085 case ${MYSQL_PV_MAJOR} in
770 mysql_mycnf_version="4.1"
771 else
772 mysql_mycnf_version="4.0" 1086 3*|4.0) mysql_mycnf_version="4.0" ;;
773 fi 1087 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
774 einfo "Building default my.cnf" 1088 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1089 esac
1090 einfo "Building default my.cnf (${mysql_mycnf_version})"
775 insinto "${MY_SYSCONFDIR}" 1091 insinto "${MY_SYSCONFDIR}"
776 doins scripts/mysqlaccess.conf 1092 doins scripts/mysqlaccess.conf
1093 mycnf_src="my.cnf-${mysql_mycnf_version}"
777 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \ 1094 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
778 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 1095 "${FILESDIR}/${mycnf_src}" \
779 > "${TMPDIR}/my.cnf.ok" 1096 > "${TMPDIR}/my.cnf.ok"
780 if mysql_version_is_at_least "4.1" && use latin1 ; then 1097 if use latin1 ; then
781 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 1098 sed -i \
1099 -e "/character-set/s|utf8|latin1|g" \
1100 "${TMPDIR}/my.cnf.ok"
782 fi 1101 fi
783 newins "${TMPDIR}/my.cnf.ok" my.cnf 1102 newins "${TMPDIR}/my.cnf.ok" my.cnf
784 1103
785 # Minimal builds don't have the MySQL server 1104 # Minimal builds don't have the MySQL server
786 if ! use minimal ; then 1105 if ! use minimal ; then
801 done 1120 done
802 fi 1121 fi
803 1122
804 # Docs 1123 # Docs
805 einfo "Installing docs" 1124 einfo "Installing docs"
806 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 1125 dodoc README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
807 doinfo "${S}"/Docs/mysql.info 1126 doinfo "${S}"/Docs/mysql.info
808 1127
809 # Minimal builds don't have the MySQL server 1128 # Minimal builds don't have the MySQL server
810 if ! use minimal ; then 1129 if ! use minimal ; then
811 einfo "Including support files and sample configurations" 1130 einfo "Including support files and sample configurations"
813 for script in \ 1132 for script in \
814 "${S}"/support-files/my-*.cnf \ 1133 "${S}"/support-files/my-*.cnf \
815 "${S}"/support-files/magic \ 1134 "${S}"/support-files/magic \
816 "${S}"/support-files/ndb-config-2-node.ini 1135 "${S}"/support-files/ndb-config-2-node.ini
817 do 1136 do
818 dodoc "${script}" 1137 [[ -f "$script" ]] && dodoc "${script}"
819 done 1138 done
820 1139
821 docinto "scripts" 1140 docinto "scripts"
822 for script in "${S}"/scripts/mysql* ; do 1141 for script in "${S}"/scripts/mysql* ; do
823 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1142 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
824 done 1143 done
825 1144
826 fi 1145 fi
827 1146
828 mysql_lib_symlinks "${D}" 1147 mysql_lib_symlinks "${D}"
862 for script in \ 1181 for script in \
863 support-files/my-*.cnf \ 1182 support-files/my-*.cnf \
864 support-files/magic \ 1183 support-files/magic \
865 support-files/ndb-config-2-node.ini 1184 support-files/ndb-config-2-node.ini
866 do 1185 do
1186 [[ -f "${script}" ]] \
867 dodoc "${script}" 1187 && dodoc "${script}"
868 done 1188 done
869 1189
870 docinto "scripts" 1190 docinto "scripts"
871 for script in scripts/mysql* ; do 1191 for script in scripts/mysql* ; do
1192 [[ -f "${script}" ]] \
872 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1193 && [[ "${script%.sh}" == "${script}" ]] \
1194 && dodoc "${script}"
873 done 1195 done
874 1196
875 einfo 1197 einfo
876 elog "You might want to run:" 1198 elog "You might want to run:"
877 elog "\"emerge --config =${CATEGORY}/${PF}\"" 1199 elog "\"emerge --config =${CATEGORY}/${PF}\""
878 elog "if this is a new install." 1200 elog "if this is a new install."
879 einfo 1201 einfo
880 fi
881 1202
882 if mysql_version_is_at_least "5.1.12" && use pbxt ; then 1203 einfo
1204 elog "If you are upgrading major versions, you should run the"
1205 elog "mysql_upgrade tool."
1206 einfo
1207 fi
1208
1209 if pbxt_available && use pbxt ; then
883 # TODO: explain it better 1210 # TODO: explain it better
884 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 1211 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
885 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 1212 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
886 elog "if, after that, you cannot start the MySQL server," 1213 elog "if, after that, you cannot start the MySQL server,"
887 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 1214 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
938 fi 1265 fi
939 fi 1266 fi
940 1267
941 local pwd1="a" 1268 local pwd1="a"
942 local pwd2="b" 1269 local pwd2="b"
1270 local MYSQL_ROOT_PASSWORD=''
943 local maxtry=5 1271 local maxtry=15
1272
1273 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1274 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1275 fi
944 1276
945 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then 1277 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
946 ewarn "You have already a MySQL database in place." 1278 ewarn "You have already a MySQL database in place."
947 ewarn "(${ROOT}/${MY_DATADIR}/*)" 1279 ewarn "(${ROOT}/${MY_DATADIR}/*)"
948 ewarn "Please rename or delete it if you wish to replace it." 1280 ewarn "Please rename or delete it if you wish to replace it."
951 1283
952 # Bug #213475 - MySQL _will_ object strenously if your machine is named 1284 # Bug #213475 - MySQL _will_ object strenously if your machine is named
953 # localhost. Also causes weird failures. 1285 # localhost. Also causes weird failures.
954 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" 1286 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
955 1287
956 einfo "Creating the mysql database and setting proper" 1288 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
957 einfo "permissions on it ..."
958 1289
959 einfo "Insert a password for the mysql 'root' user" 1290 einfo "Please provide a password for the mysql 'root' user now,"
1291 einfo "or in the MYSQL_ROOT_PASSWORD env var."
960 ewarn "Avoid [\"'\\_%] characters in the password" 1292 ewarn "Avoid [\"'\\_%] characters in the password"
961 read -rsp " >" pwd1 ; echo 1293 read -rsp " >" pwd1 ; echo
962 1294
963 einfo "Retype the password" 1295 einfo "Retype the password"
964 read -rsp " >" pwd2 ; echo 1296 read -rsp " >" pwd2 ; echo
965 1297
966 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1298 if [[ "x$pwd1" != "x$pwd2" ]] ; then
967 die "Passwords are not the same" 1299 die "Passwords are not the same"
1300 fi
1301 MYSQL_ROOT_PASSWORD="${pwd1}"
1302 unset pwd1 pwd2
968 fi 1303 fi
969 1304
970 local options="" 1305 local options=""
971 local sqltmp="$(emktemp)" 1306 local sqltmp="$(emktemp)"
972 1307
986 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 1321 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
987 || die "MySQL databases not installed" 1322 || die "MySQL databases not installed"
988 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null 1323 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
989 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null 1324 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
990 1325
1326 # Figure out which options we need to disable to do the setup
1327 helpfile="${TMPDIR}/mysqld-help"
1328 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1329 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1330 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1331 ndbcluster \
1332 ; do
1333 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1334 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1335 done
1336 # But some options changed names
1337 egrep -sq external-locking "${helpfile}" && \
1338 options="${options/skip-locking/skip-external-locking}"
1339
991 if mysql_version_is_at_least "4.1.3" ; then 1340 if mysql_version_is_at_least "4.1.3" ; then
992 options="--skip-ndbcluster"
993
994 # Filling timezones, see 1341 # Filling timezones, see
995 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1342 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
996 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1343 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
997 1344
998 if [[ -r "${help_tables}" ]] ; then 1345 if [[ -r "${help_tables}" ]] ; then
999 cat "${help_tables}" >> "${sqltmp}" 1346 cat "${help_tables}" >> "${sqltmp}"
1000 fi 1347 fi
1001 fi 1348 fi
1349
1350 einfo "Creating the mysql database and setting proper"
1351 einfo "permissions on it ..."
1002 1352
1003 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock" 1353 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1004 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid" 1354 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1005 local mysqld="${ROOT}/usr/sbin/mysqld \ 1355 local mysqld="${ROOT}/usr/sbin/mysqld \
1006 ${options} \ 1356 ${options} \
1007 --user=mysql \ 1357 --user=mysql \
1008 --skip-grant-tables \
1009 --basedir=${ROOT}/usr \ 1358 --basedir=${ROOT}/usr \
1010 --datadir=${ROOT}/${MY_DATADIR} \ 1359 --datadir=${ROOT}/${MY_DATADIR} \
1011 --skip-innodb \
1012 --skip-bdb \
1013 --skip-networking \
1014 --max_allowed_packet=8M \ 1360 --max_allowed_packet=8M \
1015 --net_buffer_length=16K \ 1361 --net_buffer_length=16K \
1362 --default-storage-engine=MyISAM \
1016 --socket=${socket} \ 1363 --socket=${socket} \
1017 --pid-file=${pidfile}" 1364 --pid-file=${pidfile}"
1365 #einfo "About to start mysqld: ${mysqld}"
1366 ebegin "Starting mysqld"
1018 ${mysqld} & 1367 ${mysqld} &
1368 rc=$?
1019 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1369 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1020 maxtry=$((${maxtry}-1)) 1370 maxtry=$((${maxtry}-1))
1021 echo -n "." 1371 echo -n "."
1022 sleep 1 1372 sleep 1
1023 done 1373 done
1374 eend $rc
1024 1375
1376 if ! [[ -S "${socket}" ]]; then
1377 die "Completely failed to start up mysqld with: ${mysqld}"
1378 fi
1379
1380 ebegin "Setting root password"
1025 # Do this from memory, as we don't want clear text passwords in temp files 1381 # Do this from memory, as we don't want clear text passwords in temp files
1026 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1382 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1027 "${ROOT}/usr/bin/mysql" \ 1383 "${ROOT}/usr/bin/mysql" \
1028 --socket=${socket} \ 1384 --socket=${socket} \
1029 -hlocalhost \ 1385 -hlocalhost \
1030 -e "${sql}" 1386 -e "${sql}"
1387 eend $?
1031 1388
1032 einfo "Loading \"zoneinfo\", this step may require a few seconds ..." 1389 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1033
1034 "${ROOT}/usr/bin/mysql" \ 1390 "${ROOT}/usr/bin/mysql" \
1035 --socket=${socket} \ 1391 --socket=${socket} \
1036 -hlocalhost \ 1392 -hlocalhost \
1037 -uroot \ 1393 -uroot \
1038 -p"${pwd1}" \ 1394 -p"${MYSQL_ROOT_PASSWORD}" \
1039 mysql < "${sqltmp}" 1395 mysql < "${sqltmp}"
1396 rc=$?
1397 eend $?
1398 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1040 1399
1041 # Stop the server and cleanup 1400 # Stop the server and cleanup
1401 einfo "Stopping the server ..."
1042 kill $(< "${pidfile}" ) 1402 kill $(< "${pidfile}" )
1043 rm -f "${sqltmp}" 1403 rm -f "${sqltmp}"
1044 einfo "Stopping the server ..."
1045 wait %1 1404 wait %1
1046 einfo "Done" 1405 einfo "Done"
1047} 1406}
1048 1407
1049# @FUNCTION: mysql_pkg_postrm 1408# @FUNCTION: mysql_pkg_postrm

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.155

  ViewVC Help
Powered by ViewVC 1.1.20