/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.46 Revision 1.132
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/mysql.eclass,v 1.46 2006/12/10 01:11:47 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/mysql.eclass,v 1.132 2010/02/02 22:16:04 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass
6# @MAINTAINER:
5# Author: Francesco Riosa <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
6# Maintainer: Luca Longinotti <chtekk@gentoo.org> 9# - Luca Longinotti <chtekk@gentoo.org>
10# - Robin H. Johnson <robbat2@gentoo.org>
11# @BLURB: This eclass provides most of the functions for mysql ebuilds
12# @DESCRIPTION:
13# The mysql.eclass provides almost all the code to build the mysql ebuilds
14# including the src_unpack, src_prepare, src_configure, src_compile,
15# scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
16# phase hooks.
7 17
8# Both MYSQL_VERSION_ID and MYSQL_PATCHSET_REV must be set in the ebuild too 18WANT_AUTOCONF="latest"
9# Note that MYSQL_VERSION_ID must be empty !!! 19WANT_AUTOMAKE="latest"
10 20
21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
22
23# Shorten the path because the socket path length must be shorter than 107 chars
24# and we will run a mysql server during test phase
25S="${WORKDIR}/mysql"
26
27[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
28if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
29 EGIT_PROJECT=mysql-extras
30 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
31 inherit git
32fi
33
34case "${EAPI:-0}" in
35 2)
36 EXPORT_FUNCTIONS pkg_setup \
37 src_unpack src_prepare \
38 src_configure src_compile \
39 src_install \
40 pkg_preinst pkg_postinst \
41 pkg_config pkg_postrm
42 IUSE_DEFAULT_ON='+'
43 ;;
44 0 | 1)
45 EXPORT_FUNCTIONS pkg_setup \
46 src_unpack \
47 src_compile \
48 src_install \
49 pkg_preinst pkg_postinst \
50 pkg_config pkg_postrm
51 ;;
52 *)
53 die "Unsupported EAPI: ${EAPI}" ;;
54esac
55
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION:
11# MYSQL_VERSION_ID will be: 58# MYSQL_VERSION_ID will be:
12# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
13# This is an important part, because many of the choices the MySQL ebuild will do 60# This is an important part, because many of the choices the MySQL ebuild will do
14# depend on this variable. 61# depend on this variable.
15# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803" 62# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
63# We also strip off upstream's trailing letter that they use to respin tarballs
16 64
17if [[ -z "${MYSQL_VERSION_ID}" ]] ; then 65MYSQL_VERSION_ID=""
66tpv="${PV%[a-z]}"
18 tpv=( ${PV//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}" 67tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
19 for vatom in 0 1 2 3 ; do 68for vatom in 0 1 2 3 ; do
20 # pad to length 2 69 # pad to length 2
21 tpv[${vatom}]="00${tpv[${vatom}]}" 70 tpv[${vatom}]="00${tpv[${vatom}]}"
22 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}" 71 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
23 done 72done
24 # strip leading "0" (otherwise it's considered an octal number by BASH) 73# strip leading "0" (otherwise it's considered an octal number by BASH)
25 MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"} 74MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
75
76# @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
77# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no).
80# Community features are available in mysql-community
81# AND in the re-merged mysql-5.0.82 and newer
82if [ "${PN}" == "mysql-community" ]; then
83 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1
90elif [ "${PV#5.5}" != "${PV}" ] ; then
91 MYSQL_COMMUNITY_FEATURES=1
92elif [ "${PV#6.0}" != "${PV}" ] ; then
93 MYSQL_COMMUNITY_FEATURES=1
94else
95 MYSQL_COMMUNITY_FEATURES=0
26fi 96fi
27 97
28inherit eutils flag-o-matic gnuconfig autotools mysql_fx 98# @ECLASS-VARIABLE: XTRADB_VER
99# @DESCRIPTION:
100# Version of the XTRADB storage engine
101XTRADB_VER="${XTRADB_VER}"
102
103# @ECLASS-VARIABLE: PERCONA_VER
104# @DESCRIPTION:
105# Designation by PERCONA for a MySQL version to apply an XTRADB release
106PERCONA_VER="${PERCONA_VER}"
29 107
30# Be warned, *DEPEND are version-dependant 108# Be warned, *DEPEND are version-dependant
109# These are used for both runtime and compiletime
31DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d ) 110DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
32 userland_GNU? ( sys-process/procps ) 111 userland_GNU? ( sys-process/procps )
33 >=sys-apps/sed-4 112 >=sys-apps/sed-4
34 >=sys-apps/texinfo-4.7-r1 113 >=sys-apps/texinfo-4.7-r1
35 >=sys-libs/readline-4.1 114 >=sys-libs/readline-4.1
36 >=sys-libs/zlib-1.2.3" 115 >=sys-libs/zlib-1.2.3"
37 116
38# LEAVE THE SURROUNDING SPACES THERE 117# Having different flavours at the same time is not a good idea
39MYSQL_MUTUALLY_EXCLUSIVE=" !dev-db/mysql !dev-db/mysql-community " 118for i in "" "-community" ; do
40DEPEND="${DEPEND} ${MYSQL_MUTUALLY_EXCLUSIVE/ !${CATEGORY}\/${PN} /}" 119 [[ "${i}" == ${PN#mysql} ]] ||
120 DEPEND="${DEPEND} !dev-db/mysql${i}"
121done
41 122
123RDEPEND="${DEPEND}
124 !minimal? ( dev-db/mysql-init-scripts )
125 selinux? ( sec-policy/selinux-mysql )"
126
127# compile-time-only
42mysql_version_is_at_least "5.01.00.00" \ 128mysql_version_is_at_least "5.1" \
43|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 129|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
44 130
45RDEPEND="${DEPEND} selinux? ( sec-policy/selinux-mysql )" 131# compile-time-only
132mysql_version_is_at_least "5.1.12" \
133&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
46 134
47# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 135# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
48PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 136PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
49 137
50# Shorten the path because the socket path length must be shorter than 107 chars 138# For other stuff to bring us in
51# and we will run a mysql server during test phase 139PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})"
52S="${WORKDIR}/mysql" # BitKeeper ebuilds
53 140
54# Define $MY_FIXED_PV for MySQL patchsets 141# Work out the default SERVER_URI correctly
55MY_FIXED_PV="${PV/_alpha/}" 142if [ -z "${SERVER_URI}" ]; then
56#MY_FIXED_PV="${MY_FIXED_PV/_beta/}" 143 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
57#MY_FIXED_PV="${MY_FIXED_PV/_rc/}" 144 # The community build is on the mirrors
58 145 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
59MY_P="${P/_/-}" 146 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${MY_PV}.tar.gz"
60MY_P="${MY_P/-alpha/-bk-}" # BitKeeper ebuilds 147 # The (old) enterprise source is on the primary site only
61MY_P="${MY_P/-community/}" 148 elif [ "${PN}" == "mysql" ]; then
149 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
150 fi
151fi
62 152
63# Define correct SRC_URIs 153# Define correct SRC_URIs
64SRC_URI="${BASE_URI}/${MY_P}${MYSQL_RERELEASE}.tar.gz" 154SRC_URI="${SERVER_URI}"
65if [[ -n "${MYSQL_PATCHSET_REV}" ]] ; then 155
66 MYSQL_PATCHSET_FILENAME="${PN}-patchset-${MY_FIXED_PV}-r${MYSQL_PATCHSET_REV}.tar.bz2" 156# Gentoo patches to MySQL
67 # We add the Gentoo mirror here, as we only use primaryuri for the MySQL tarball 157[[ ${MY_EXTRAS_VER} != live ]] \
68 SRC_URI="${SRC_URI} http://g3nt8.org/patches/${MYSQL_PATCHSET_FILENAME}" 158&& SRC_URI="${SRC_URI}
69fi 159 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
160 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
161 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
162
163# PBXT engine
164mysql_version_is_at_least "5.1.12" \
165&& [[ -n "${PBXT_VERSION}" ]] \
166&& PBXT_P="pbxt-${PBXT_VERSION}" \
167&& PBXT_SRC_URI="mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
168&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )"
169
170# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
171mysql_version_is_at_least "5.1.26" \
172&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
173&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
174&& XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
175&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )"
70 176
71DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 177DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
72HOMEPAGE="http://www.mysql.com/" 178HOMEPAGE="http://www.mysql.com/"
179LICENSE="GPL-2"
73SLOT="0" 180SLOT="0"
74LICENSE="GPL-2"
75IUSE="big-tables debug embedded minimal perl selinux srvdir ssl static" 181IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static"
76RESTRICT="confcache"
77 182
78mysql_version_is_at_least "4.01.00.00" \ 183mysql_version_is_at_least "4.1" \
79&& IUSE="${IUSE} latin1" 184&& IUSE="${IUSE} latin1"
80 185
81mysql_version_is_at_least "4.01.03.00" \ 186mysql_version_is_at_least "4.1.3" \
82&& IUSE="${IUSE} cluster extraengine" 187&& IUSE="${IUSE} cluster extraengine"
83 188
84mysql_version_is_at_least "5.00.00.00" \ 189mysql_version_is_at_least "5.0" \
85|| IUSE="${IUSE} raid" 190|| IUSE="${IUSE} raid"
86 191
87mysql_version_is_at_least "5.00.18.00" \ 192mysql_version_is_at_least "5.0.18" \
88&& IUSE="${IUSE} max-idx-128" 193&& IUSE="${IUSE} max-idx-128"
89 194
90mysql_version_is_at_least "5.01.00.00" \ 195mysql_version_is_at_least "5.1" \
91&& IUSE="${IUSE} innodb"
92
93mysql_version_is_at_least "5.01.00.00" \
94|| IUSE="${IUSE} berkdb" 196|| IUSE="${IUSE} berkdb"
95 197
96EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \ 198mysql_version_is_at_least "5.1.12" \
97 pkg_postinst pkg_config pkg_postrm 199&& [[ -n "${PBXT_VERSION}" ]] \
200&& IUSE="${IUSE} pbxt"
201
202mysql_version_is_at_least "5.1.26" \
203&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
204&& IUSE="${IUSE} xtradb"
205
206[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
207&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
98 208
99# 209#
100# HELPER FUNCTIONS: 210# HELPER FUNCTIONS:
101# 211#
102 212
213# @FUNCTION: mysql_disable_test
214# @DESCRIPTION:
215# Helper function to disable specific tests.
216mysql_disable_test() {
217 local rawtestname testname testsuite reason mysql_disable_file
218 rawtestname="${1}" ; shift
219 reason="${@}"
220 ewarn "test '${rawtestname}' disabled: '${reason}'"
221
222 testsuite="${rawtestname/.*}"
223 testname="${rawtestname/*.}"
224 mysql_disable_file="${S}/mysql-test/t/disabled.def"
225 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
226 echo ${testname} : ${reason} >> "${mysql_disable_file}"
227
228 # ${S}/mysql-tests/t/disabled.def
229 #
230 # ${S}/mysql-tests/suite/federated/disabled.def
231 #
232 # ${S}/mysql-tests/suite/jp/t/disabled.def
233 # ${S}/mysql-tests/suite/ndb/t/disabled.def
234 # ${S}/mysql-tests/suite/rpl/t/disabled.def
235 # ${S}/mysql-tests/suite/parts/t/disabled.def
236 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
237 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
238 # ${S}/mysql-tests/suite/binlog/t/disabled.def
239 # ${S}/mysql-tests/suite/innodb/t/disabled.def
240 if [ -n "${testsuite}" ]; then
241 for mysql_disable_file in \
242 ${S}/mysql-test/suite/${testsuite}/disabled.def \
243 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
244 FAILED ; do
245 [ -f "${mysql_disable_file}" ] && break
246 done
247 if [ "${mysql_disabled_file}" != "FAILED" ]; then
248 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
249 else
250 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
251 fi
252 fi
253}
254
255# @FUNCTION: mysql_init_vars
256# @DESCRIPTION:
103# void mysql_init_vars() 257# void mysql_init_vars()
104#
105# Initialize global variables 258# Initialize global variables
106# 2005-11-19 <vivo@gentoo.org> 259# 2005-11-19 <vivo@gentoo.org>
107
108mysql_init_vars() { 260mysql_init_vars() {
109 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"} 261 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"}
110 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"} 262 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"}
111 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"} 263 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"}
112 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"} 264 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"}
113 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql"} 265 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql"}
114 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql"} 266 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql"}
115 267
116 if [[ -z "${DATADIR}" ]] ; then 268 if [[ -z "${MY_DATADIR}" ]] ; then
117 DATADIR="" 269 MY_DATADIR=""
118 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then 270 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then
119 DATADIR=`"my_print_defaults" mysqld 2>/dev/null \ 271 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
120 | sed -ne '/datadir/s|^--datadir=||p' \ 272 | sed -ne '/datadir/s|^--datadir=||p' \
121 | tail -n1` 273 | tail -n1`
122 if [[ -z "${DATADIR}" ]] ; then 274 if [[ -z "${MY_DATADIR}" ]] ; then
123 if useq "srvdir" ; then
124 DATADIR="${ROOT}/srv/localhost/mysql/datadir"
125 else
126 DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \ 275 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \
127 | sed -e 's/.*=\s*//'` 276 | sed -e 's/.*=\s*//' \
128 fi 277 | tail -n1`
129 fi 278 fi
130 fi 279 fi
131 if [[ -z "${DATADIR}" ]] ; then 280 if [[ -z "${MY_DATADIR}" ]] ; then
132 if useq "srvdir" ; then
133 DATADIR="${ROOT}/srv/localhost/mysql/datadir"
134 else
135 DATADIR="${MY_LOCALSTATEDIR}" 281 MY_DATADIR="${MY_LOCALSTATEDIR}"
136 fi
137 einfo "Using default DATADIR" 282 einfo "Using default MY_DATADIR"
138 fi 283 fi
139 elog "MySQL DATADIR is ${DATADIR}" 284 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
140 285
141 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then 286 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
142 if [[ -e "${DATADIR}" ]] ; then 287 if [[ -e "${MY_DATADIR}" ]] ; then
143 elog "Previous datadir found, it's YOUR job to change" 288 # If you get this and you're wondering about it, see bug #207636
144 elog "ownership and take care of it" 289 elog "MySQL datadir found in ${MY_DATADIR}"
290 elog "A new one will not be created."
145 PREVIOUS_DATADIR="yes" 291 PREVIOUS_DATADIR="yes"
146 else 292 else
147 PREVIOUS_DATADIR="no" 293 PREVIOUS_DATADIR="no"
148 fi 294 fi
149 export PREVIOUS_DATADIR 295 export PREVIOUS_DATADIR
150 fi 296 fi
297 else
298 if [[ ${EBUILD_PHASE} == "config" ]]; then
299 local new_MY_DATADIR
300 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
301 | sed -ne '/datadir/s|^--datadir=||p' \
302 | tail -n1`
303
304 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
305 ewarn "MySQL MY_DATADIR has changed"
306 ewarn "from ${MY_DATADIR}"
307 ewarn "to ${new_MY_DATADIR}"
308 MY_DATADIR="${new_MY_DATADIR}"
309 fi
151 fi 310 fi
311 fi
312
313 MY_SOURCEDIR=${SERVER_URI##*/}
314 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
152 315
153 export MY_SHAREDSTATEDIR MY_SYSCONFDIR 316 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
154 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 317 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
155 export MY_INCLUDEDIR 318 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
156 export DATADIR
157} 319}
158 320
159configure_minimal() { 321configure_minimal() {
160 # These are things we exclude from a minimal build, please 322 # These are things we exclude from a minimal build, please
161 # note that the server actually does get built and installed, 323 # note that the server actually does get built and installed,
162 # but we then delete it before packaging. 324 # but we then delete it before packaging.
163 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication" 325 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
164 326
165 for i in ${minimal_exclude_list} ; do 327 for i in ${minimal_exclude_list} ; do
166 myconf="${myconf} --without-${i}" 328 myconf="${myconf} --without-${i}"
167 done 329 done
168 myconf="${myconf} --with-extra-charsets=none" 330 myconf="${myconf} --with-extra-charsets=none"
169 myconf="${myconf} --enable-local-infile" 331 myconf="${myconf} --enable-local-infile"
332
333 if use static ; then
334 myconf="${myconf} --with-client-ldflags=-all-static"
335 myconf="${myconf} --disable-shared --with-pic"
336 else
337 myconf="${myconf} --enable-shared --enable-static"
338 fi
339
340 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
341 myconf="${myconf} --with-charset=utf8"
342 myconf="${myconf} --with-collation=utf8_general_ci"
343 else
344 myconf="${myconf} --with-charset=latin1"
345 myconf="${myconf} --with-collation=latin1_swedish_ci"
346 fi
170} 347}
171 348
172configure_common() { 349configure_common() {
173 myconf="${myconf} $(use_with big-tables)" 350 myconf="${myconf} $(use_with big-tables)"
174 myconf="${myconf} --enable-local-infile" 351 myconf="${myconf} --enable-local-infile"
176 myconf="${myconf} --with-mysqld-user=mysql" 353 myconf="${myconf} --with-mysqld-user=mysql"
177 myconf="${myconf} --with-server" 354 myconf="${myconf} --with-server"
178 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock" 355 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock"
179 myconf="${myconf} --without-libwrap" 356 myconf="${myconf} --without-libwrap"
180 357
181 if useq "static" ; then 358 if use static ; then
182 myconf="${myconf} --with-mysqld-ldflags=-all-static" 359 myconf="${myconf} --with-mysqld-ldflags=-all-static"
183 myconf="${myconf} --with-client-ldflags=-all-static" 360 myconf="${myconf} --with-client-ldflags=-all-static"
184 myconf="${myconf} --disable-shared" 361 myconf="${myconf} --disable-shared --with-pic"
185 else 362 else
186 myconf="${myconf} --enable-shared --enable-static" 363 myconf="${myconf} --enable-shared --enable-static"
187 fi 364 fi
188 365
189 if useq "debug" ; then 366 if use debug ; then
190 myconf="${myconf} --with-debug=full" 367 myconf="${myconf} --with-debug=full"
191 else 368 else
192 myconf="${myconf} --without-debug" 369 myconf="${myconf} --without-debug"
193 mysql_version_is_at_least "4.01.03.00" \ 370 mysql_version_is_at_least "4.1.3" \
194 && useq "cluster" \ 371 && use cluster \
195 && myconf="${myconf} --without-ndb-debug" 372 && myconf="${myconf} --without-ndb-debug"
196 fi 373 fi
197 374
375 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
376 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
377 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
378 ewarn "You MUST file bugs without these variables set."
379 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
380 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
198 if mysql_version_is_at_least "4.01.00.00" && ! useq "latin1" ; then 381 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
199 myconf="${myconf} --with-charset=utf8" 382 myconf="${myconf} --with-charset=utf8"
200 myconf="${myconf} --with-collation=utf8_general_ci" 383 myconf="${myconf} --with-collation=utf8_general_ci"
201 else 384 else
202 myconf="${myconf} --with-charset=latin1" 385 myconf="${myconf} --with-charset=latin1"
203 myconf="${myconf} --with-collation=latin1_swedish_ci" 386 myconf="${myconf} --with-collation=latin1_swedish_ci"
204 fi 387 fi
205 388
206 if useq "embedded" ; then 389 if use embedded ; then
207 myconf="${myconf} --with-embedded-privilege-control" 390 myconf="${myconf} --with-embedded-privilege-control"
208 myconf="${myconf} --with-embedded-server" 391 myconf="${myconf} --with-embedded-server"
209 else 392 else
210 myconf="${myconf} --without-embedded-privilege-control" 393 myconf="${myconf} --without-embedded-privilege-control"
211 myconf="${myconf} --without-embedded-server" 394 myconf="${myconf} --without-embedded-server"
217 myconf="${myconf} $(use_with perl bench)" 400 myconf="${myconf} $(use_with perl bench)"
218 myconf="${myconf} --enable-assembler" 401 myconf="${myconf} --enable-assembler"
219 myconf="${myconf} --with-extra-tools" 402 myconf="${myconf} --with-extra-tools"
220 myconf="${myconf} --with-innodb" 403 myconf="${myconf} --with-innodb"
221 myconf="${myconf} --without-readline" 404 myconf="${myconf} --without-readline"
222 mysql_version_is_at_least "5.00.00.00" || myconf="${myconf} $(use_with raid)" 405 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
223 406
224 if useq "ssl" ; then
225 # --with-vio is not needed anymore, it's on by default and 407 # --with-vio is not needed anymore, it's on by default and
226 # has been removed from configure 408 # has been removed from configure
409 if use ssl ; then
227 mysql_version_is_at_least "5.00.04.00" || myconf="${myconf} --with-vio" 410 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
411 fi
412
413 if mysql_version_is_at_least "5.1.11" ; then
414 myconf="${myconf} $(use_with ssl)"
415 else
416 myconf="${myconf} $(use_with ssl openssl)"
417 fi
418
228 if mysql_version_is_at_least "5.00.06.00" ; then 419 if mysql_version_is_at_least "5.0.60" ; then
229 # myconf="${myconf} --with-yassl" 420 if use berkdb ; then
421 elog "Berkeley DB support was disabled due to build failures"
422 elog "on multiple arches, go to a version earlier than 5.0.60"
423 elog "if you want it again. Gentoo bug #224067."
424 fi
230 myconf="${myconf} --with-openssl" 425 myconf="${myconf} --without-berkeley-db"
426 elif use berkdb ; then
427 # The following fix is due to a bug with bdb on SPARC's. See:
428 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
429 # It comes down to non-64-bit safety problems.
430 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
431 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
432 myconf="${myconf} --without-berkeley-db"
231 else 433 else
232 myconf="${myconf} --with-openssl" 434 myconf="${myconf} --with-berkeley-db=./bdb"
233 fi 435 fi
234 else 436 else
235 myconf="${myconf} --without-openssl"
236 fi
237
238 # The following fix is due to a bug with bdb on SPARC's. See:
239 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
240 # It comes down to non-64-bit safety problems.
241 if useq "sparc" || useq "alpha" || useq "hppa" || useq "mips" || useq "amd64" ; then
242 elog "Berkeley DB support was disabled due to incompatible arch"
243 myconf="${myconf} --without-berkeley-db" 437 myconf="${myconf} --without-berkeley-db"
244 else
245 if useq "berkdb" ; then
246 myconf="${myconf} --with-berkeley-db=./bdb"
247 else
248 myconf="${myconf} --without-berkeley-db"
249 fi 438 fi
250 fi
251 439
252 if mysql_version_is_at_least "4.01.03.00" ; then 440 if mysql_version_is_at_least "4.1.3" ; then
253 myconf="${myconf} --with-geometry" 441 myconf="${myconf} --with-geometry"
254 myconf="${myconf} $(use_with cluster ndbcluster)" 442 myconf="${myconf} $(use_with cluster ndbcluster)"
255 fi 443 fi
256 444
257 if mysql_version_is_at_least "4.01.03.00" && useq "extraengine" ; then 445 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
258 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 446 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
259 myconf="${myconf} --with-archive-storage-engine" 447 myconf="${myconf} --with-archive-storage-engine"
260 448
261 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html 449 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
262 myconf="${myconf} --with-csv-storage-engine" 450 myconf="${myconf} --with-csv-storage-engine"
265 myconf="${myconf} --with-blackhole-storage-engine" 453 myconf="${myconf} --with-blackhole-storage-engine"
266 454
267 # http://dev.mysql.com/doc/mysql/en/federated-storage-engine.html 455 # http://dev.mysql.com/doc/mysql/en/federated-storage-engine.html
268 # http://dev.mysql.com/doc/mysql/en/federated-description.html 456 # http://dev.mysql.com/doc/mysql/en/federated-description.html
269 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html 457 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
270 if mysql_version_is_at_least "5.00.03.00" ; then 458 if mysql_version_is_at_least "5.0.3" ; then
271 elog "Before using the Federated storage engine, please be sure to read" 459 elog "Before using the Federated storage engine, please be sure to read"
272 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html" 460 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
273 myconf="${myconf} --with-federated-storage-engine" 461 myconf="${myconf} --with-federated-storage-engine"
274 fi 462 fi
275 fi 463 fi
276 464
465 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
466 myconf="${myconf} `use_enable community community-features`"
467 if use community; then
468 myconf="${myconf} `use_enable profiling`"
469 else
470 myconf="${myconf} --disable-profiling"
471 fi
472 fi
473
277 mysql_version_is_at_least "5.00.18.00" \ 474 mysql_version_is_at_least "5.0.18" \
278 && useq "max-idx-128" \ 475 && use max-idx-128 \
279 && myconf="${myconf} --with-max-indexes=128" 476 && myconf="${myconf} --with-max-indexes=128"
280} 477}
281 478
282configure_51() { 479configure_51() {
283 # TODO: !!!! readd --without-readline 480 # TODO: !!!! readd --without-readline
288 myconf="${myconf} --with-geometry" 485 myconf="${myconf} --with-geometry"
289 myconf="${myconf} --with-readline" 486 myconf="${myconf} --with-readline"
290 myconf="${myconf} --with-row-based-replication" 487 myconf="${myconf} --with-row-based-replication"
291 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 488 myconf="${myconf} --with-zlib=/usr/$(get_libdir)"
292 myconf="${myconf} --without-pstack" 489 myconf="${myconf} --without-pstack"
293 useq "max-idx-128" && myconf="${myconf} --with-max-indexes=128" 490 use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
294 491
295 # 5.1 introduces a new way to manage storage engines (plugins) 492 # 5.1 introduces a new way to manage storage engines (plugins)
296 # like configuration=none 493 # like configuration=none
297 local plugins="csv,myisam,myisammrg,heap" 494 local plugins="csv,myisam,myisammrg,heap"
298 if useq "extraengine" ; then 495 if use extraengine ; then
299 # like configuration=max-no-ndb, archive and example removed in 5.1.11 496 # like configuration=max-no-ndb, archive and example removed in 5.1.11
497 # not added yet: ibmdb2i
498 # Not supporting as examples: example,daemon_example,ftexample
300 plugins="${plugins},archive,blackhole,example,federated,ftexample,partition" 499 plugins="${plugins},archive,blackhole,federated,partition"
301 500
302 elog "Before using the Federated storage engine, please be sure to read" 501 elog "Before using the Federated storage engine, please be sure to read"
303 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 502 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
304 fi 503 fi
305 504
306 if useq "innodb" ; then 505 # Upstream specifically requests that InnoDB always be built:
307 plugins="${plugins},innobase" 506 # - innobase, innodb_plugin
308 fi 507 # Build falcon if available for 6.x series.
508 for i in innobase innodb_plugin falcon ; do
509 [ -e "${S}"/storage/${i} ] && plugins="${plugins},${i}"
510 done
309 511
310 # like configuration=max-no-ndb 512 # like configuration=max-no-ndb
311 if useq "cluster" ; then 513 if use cluster ; then
312 plugins="${plugins},ndbcluster" 514 plugins="${plugins},ndbcluster"
313 myconf="${myconf} --with-ndb-binlog" 515 myconf="${myconf} --with-ndb-binlog"
314 fi 516 fi
315 517
316 myconf="${myconf} --with-plugins=${plugins}" 518 myconf="${myconf} --with-plugins=${plugins}"
519}
520
521pbxt_src_configure() {
522 mysql_init_vars
523
524 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
525
526 einfo "Reconfiguring dir '${PWD}'"
527 AT_GNUCONF_UPDATE="yes" eautoreconf
528
529 local myconf=""
530 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}"
531 use debug && myconf="${myconf} --with-debug=full"
532 # TODO: is it safe/needed to use econf here ?
533 ./configure ${myconf} || die "Problem configuring PBXT storage engine"
534}
535
536pbxt_src_compile() {
537 # Be backwards compatible for now
538 if [[ $EAPI != 2 ]]; then
539 pbxt_src_configure
540 fi
541 # TODO: is it safe/needed to use emake here ?
542 make || die "Problem making PBXT storage engine (${myconf})"
543
544 popd
545 # TODO: modify test suite for PBXT
546}
547
548pbxt_src_install() {
549 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
550 make install || die "Failed to install PBXT"
551 popd
317} 552}
318 553
319# 554#
320# EBUILD FUNCTIONS 555# EBUILD FUNCTIONS
321# 556#
322 557# @FUNCTION: mysql_pkg_setup
558# @DESCRIPTION:
559# Perform some basic tests and tasks during pkg_setup phase:
560# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
561# check for conflicting use flags
562# create new user and group for mysql
563# warn about deprecated features
323mysql_pkg_setup() { 564mysql_pkg_setup() {
324 enewgroup mysql 60 || die "problem adding 'mysql' group" 565 if hasq test ${FEATURES} ; then
325 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 566 if ! use minimal ; then
326 567 if [[ $UID -eq 0 ]]; then
327 if mysql_version_is_at_least "5.01.12.00" && useq "innodb" ; then 568 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
328 eerror "InnoDB now uses cmake to build, this is a TODO item, will be fixed shortly!" 569 fi
329 die "InnoDB now uses cmake to build, this is a TODO item, will be fixed shortly!" 570 fi
330 fi 571 fi
331 572
332 # Check for USE flag problems in pkg_setup 573 # Check for USE flag problems in pkg_setup
333 if useq "static" && useq "ssl" ; then 574 if use static && use ssl ; then
334 eerror "MySQL does not support being built statically with SSL support enabled!" 575 eerror "MySQL does not support being built statically with SSL support enabled!"
335 die "MySQL does not support being built statically with SSL support enabled!" 576 die "MySQL does not support being built statically with SSL support enabled!"
336 fi 577 fi
337 578
338 if ! mysql_version_is_at_least "5.00.00.00" \ 579 if ! mysql_version_is_at_least "5.0" \
339 && useq "raid" \ 580 && use raid \
340 && useq "static" ; then 581 && use static ; then
341 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically" 582 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
342 eerror "with RAID support enabled." 583 eerror "with RAID support enabled."
343 die "USE flags 'raid' and 'static' conflict!" 584 die "USE flags 'raid' and 'static' conflict!"
344 fi 585 fi
345 586
346 if mysql_version_is_at_least "4.01.03.00" \ 587 if mysql_version_is_at_least "4.1.3" \
347 && ( useq "cluster" || useq "extraengine" ) \ 588 && ( use cluster || use extraengine ) \
348 && useq "minimal" ; then 589 && use minimal ; then
349 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 590 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
350 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 591 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
351 fi 592 fi
352 593
594 # Bug #290570 fun. Upstream made us need a fairly new GCC4.
595 if mysql_version_is_at_least "5.0.83" ; then
596 GCC_VER=$(gcc-version)
597 case ${GCC_VER} in
598 2*|3*|4.0|4.1|4.2) die "Active GCC too old! Must have at least GCC4.3" ;;
599 esac
600 fi
601
602 # This should come after all of the die statements
603 enewgroup mysql 60 || die "problem adding 'mysql' group"
604 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
605
353 mysql_check_version_range "4.00.00.00 to 5.00.99.99" \ 606 mysql_check_version_range "4.0 to 5.0.99.99" \
354 && useq "berkdb" \ 607 && use berkdb \
355 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 608 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
356} 609}
357 610
611# @FUNCTION: mysql_src_unpack
612# @DESCRIPTION:
613# Unpack the source code and call mysql_src_prepare for EAPI < 2.
358mysql_src_unpack() { 614mysql_src_unpack() {
359 # Initialize the proper variables first 615 # Initialize the proper variables first
360 mysql_init_vars 616 mysql_init_vars
361 617
362 unpack ${A} 618 unpack ${A}
619 # Grab the patches
620 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
363 621
364 mv -f "${WORKDIR}/${MY_P}${MYSQL_RERELEASE}" "${S}" 622 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
623
624 # Be backwards compatible for now
625 case ${EAPI:-0} in
626 2) : ;;
627 0 | 1) mysql_src_prepare ;;
628 esac
629}
630
631# @FUNCTION: mysql_src_prepare
632# @DESCRIPTION:
633# Apply patches to the source code and remove unneeded bundled libs.
634mysql_src_prepare() {
365 cd "${S}" 635 cd "${S}"
366 636
367 # Apply the patches for this MySQL version 637 # Apply the patches for this MySQL version
368 if [[ -d "${WORKDIR}/${MY_FIXED_PV}" ]] ; then 638 EPATCH_SUFFIX="patch"
369 EPATCH_SOURCE="${WORKDIR}/${MY_FIXED_PV}" EPATCH_SUFFIX="patch" epatch 639 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
370 fi 640 # Clean out old items
641 rm -f "${EPATCH_SOURCE}"/*
642 # Now link in right patches
643 mysql_mv_patches
644 # And apply
645 epatch
371 646
372 # Additional checks, remove bundled zlib 647 # Additional checks, remove bundled zlib
373 rm -f "${S}/zlib/"*.[ch] 648 rm -f "${S}/zlib/"*.[ch]
374 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 649 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
375 rm -f "scripts/mysqlbug" 650 rm -f "scripts/mysqlbug"
376 651
377 # Make charsets install in the right place 652 # Make charsets install in the right place
378 find . -name 'Makefile.am' \ 653 find . -name 'Makefile.am' \
379 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 654 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
380 655
381 # Manage mysqlmanager
382 mysql_version_is_at_least "5.00.15.00" \
383 && sed -i -e "s!@GENTOO_EXT@!!g" \
384 -e "s!@GENTOO_SOCK_PATH@!var/run/mysqld!g" \
385 "${S}/server-tools/instance-manager/Makefile.am"
386
387 if mysql_version_is_at_least "4.01.00.00" ; then 656 if mysql_version_is_at_least "4.1" ; then
388 # Remove what needs to be recreated, so we're sure it's actually done 657 # Remove what needs to be recreated, so we're sure it's actually done
658 einfo "Cleaning up old buildscript files"
389 find . -name Makefile \ 659 find . -name Makefile \
390 -o -name Makefile.in \ 660 -o -name Makefile.in \
391 -o -name configure \ 661 -o -name configure \
392 -exec rm -f {} \; 662 -exec rm -f {} \;
393 rm -f "ltmain.sh" 663 rm -f "ltmain.sh"
394 rm -f "scripts/mysqlbug" 664 rm -f "scripts/mysqlbug"
395 fi 665 fi
396 666
397 local rebuilddirlist bdbdir d 667 local rebuilddirlist d
398 668
669 if mysql_version_is_at_least "5.1.26" && use xtradb ; then
670 einfo "Replacing InnoDB with Percona XtraDB"
671 pushd "${S}"/storage
672 i="innobase"
673 o="${WORKDIR}/storage-${i}.mysql-upstream"
674 # Have we been here already?
675 [ -h "${i}" ] && rm -f "${i}"
676 # Or maybe we haven't
677 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
678 ln -s "${WORKDIR}/${XTRADB_P}" "${i}"
679 popd
680 fi
681
399 if mysql_version_is_at_least "5.01.12.00" ; then 682 if mysql_version_is_at_least "5.1.12" ; then
400 # TODO: innodb is using cmake now? 683 einfo "Updating innobase cmake"
401 rebuilddirlist="." 684 rebuilddirlist="."
402 bdbdir='' 685 # TODO: check this with a cmake expert
686 cmake \
687 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
688 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
689 "storage/innobase"
403 else 690 else
404 rebuilddirlist=". innobase" 691 rebuilddirlist=". innobase"
405 bdbdir='bdb/dist'
406 fi 692 fi
407 693
408 for d in ${rebuilddirlist} ; do 694 for d in ${rebuilddirlist} ; do
409 einfo "Reconfiguring dir '${d}'" 695 einfo "Reconfiguring dir '${d}'"
410 pushd "${d}" &>/dev/null 696 pushd "${d}" &>/dev/null
411 AT_GNUCONF_UPDATE="yes" eautoreconf 697 AT_GNUCONF_UPDATE="yes" eautoreconf
412 popd &>/dev/null 698 popd &>/dev/null
413 done 699 done
414 700
415 if mysql_check_version_range "4.01.00.00 to 5.00.99.99" \ 701 if mysql_check_version_range "4.1 to 5.0.99.99" \
416 && useq "berkdb" ; then 702 && use berkdb ; then
703 einfo "Fixing up berkdb buildsystem"
417 [[ -w "${bdbdir}/ltmain.sh" ]] && cp -f "ltmain.sh" "${bdbdir}/ltmain.sh" 704 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
418 pushd "${bdbdir}" \ 705 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
706 || die "Could not copy libtool.m4 to bdb/dist/"
707 #These files exist only with libtool-2*, and need to be included.
708 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
709 cat "/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
710 cat "/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
711 cat "/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
712 cat "/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
713 fi
714 pushd "bdb/dist" &>/dev/null
419 && sh s_all \ 715 sh s_all \
420 || die "Failed bdb reconfigure" \ 716 || die "Failed bdb reconfigure"
421 &>/dev/null
422 popd &>/dev/null 717 popd &>/dev/null
423 fi 718 fi
424} 719}
425 720
721# @FUNCTION: mysql_src_configure
722# @DESCRIPTION:
723# Configure mysql to build the code for Gentoo respecting the use flags.
426mysql_src_compile() { 724mysql_src_configure() {
427 # Make sure the vars are correctly initialized 725 # Make sure the vars are correctly initialized
428 mysql_init_vars 726 mysql_init_vars
429 727
430 # $myconf is modified by the configure_* functions 728 # $myconf is modified by the configure_* functions
431 local myconf="" 729 local myconf=""
432 730
433 if useq "minimal" ; then 731 if use minimal ; then
434 configure_minimal 732 configure_minimal
435 else 733 else
436 configure_common 734 configure_common
437 if mysql_version_is_at_least "5.01.10.00" ; then 735 if mysql_version_is_at_least "5.1.10" ; then
438 configure_51 736 configure_51
439 else 737 else
440 configure_40_41_50 738 configure_40_41_50
441 fi 739 fi
442 fi 740 fi
445 filter-flags "-O" "-O[01]" 743 filter-flags "-O" "-O[01]"
446 744
447 # glib-2.3.2_pre fix, bug #16496 745 # glib-2.3.2_pre fix, bug #16496
448 append-flags "-DHAVE_ERRNO_AS_DEFINE=1" 746 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
449 747
450 append-flags "-fno-exceptions -fno-strict-aliasing" 748 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
749 # fail badly during cluster startup.
750 if [[ $(gcc-major-version) -lt 4 ]]; then
751 filter-flags "-fstack-protector-all"
752 fi
753
754 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
451 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti" 755 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
452 mysql_version_is_at_least "5.00.00.00" \ 756 mysql_version_is_at_least "5.0" \
453 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 757 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
454 export CXXFLAGS 758 export CXXFLAGS
759
760 # bug #283926, with GCC4.4, this is required to get correct behavior.
761 append-flags -fno-strict-aliasing
455 762
456 econf \ 763 econf \
457 --libexecdir="/usr/sbin" \ 764 --libexecdir="/usr/sbin" \
458 --sysconfdir="${MY_SYSCONFDIR}" \ 765 --sysconfdir="${MY_SYSCONFDIR}" \
459 --localstatedir="${MY_LOCALSTATEDIR}" \ 766 --localstatedir="${MY_LOCALSTATEDIR}" \
470 # TODO: Move this before autoreconf !!! 777 # TODO: Move this before autoreconf !!!
471 find . -type f -name Makefile -print0 \ 778 find . -type f -name Makefile -print0 \
472 | xargs -0 -n100 sed -i \ 779 | xargs -0 -n100 sed -i \
473 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 780 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
474 781
782 if [[ $EAPI == 2 ]]; then
783 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure
784 fi
785}
786
787# @FUNCTION: mysql_src_compile
788# @DESCRIPTION:
789# Compile the mysql code.
790mysql_src_compile() {
791 # Be backwards compatible for now
792 case ${EAPI:-0} in
793 2) : ;;
794 0 | 1) mysql_src_configure ;;
795 esac
796
475 emake || die "emake failed" 797 emake || die "emake failed"
476}
477 798
799 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile
800}
801
802# @FUNCTION: mysql_src_install
803# @DESCRIPTION:
804# Install mysql.
478mysql_src_install() { 805mysql_src_install() {
479 # Make sure the vars are correctly initialized 806 # Make sure the vars are correctly initialized
480 mysql_init_vars 807 mysql_init_vars
481 808
482 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 809 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed"
483 810
484 insinto "${MY_INCLUDEDIR}" 811 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install
485 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h
486 812
487 # Convenience links 813 # Convenience links
814 einfo "Making Convenience links for mysqlcheck multi-call binary"
488 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 815 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
489 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 816 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
490 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize" 817 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
491 818
492 # Various junk (my-*.cnf moved elsewhere) 819 # Various junk (my-*.cnf moved elsewhere)
820 einfo "Removing duplicate /usr/share/mysql files"
493 rm -Rf "${D}/usr/share/info" 821 rm -Rf "${D}/usr/share/info"
494 for removeme in "mysql-log-rotate" mysql.server* \ 822 for removeme in "mysql-log-rotate" mysql.server* \
495 binary-configure* my-*.cnf mi_test_all* 823 binary-configure* my-*.cnf mi_test_all*
496 do 824 do
497 rm -f "${D}"/usr/share/mysql/${removeme} 825 rm -f "${D}"/usr/share/mysql/${removeme}
498 done 826 done
499 827
500 # Clean up stuff for a minimal build 828 # Clean up stuff for a minimal build
501 if useq "minimal" ; then 829 if use minimal ; then
830 einfo "Remove all extra content for minimal build"
502 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench} 831 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
503 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 832 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
504 rm -f "${D}/usr/sbin/mysqld" 833 rm -f "${D}/usr/sbin/mysqld"
505 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 834 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
506 fi 835 fi
507 836
508 # Configuration stuff 837 # Configuration stuff
509 if mysql_version_is_at_least "4.01.00.00" ; then 838 if mysql_version_is_at_least "4.1" ; then
510 mysql_mycnf_version="4.1" 839 mysql_mycnf_version="4.1"
511 else 840 else
512 mysql_mycnf_version="4.0" 841 mysql_mycnf_version="4.0"
513 fi 842 fi
843 einfo "Building default my.cnf"
514 insinto "${MY_SYSCONFDIR}" 844 insinto "${MY_SYSCONFDIR}"
515 doins "scripts/mysqlaccess.conf" 845 doins scripts/mysqlaccess.conf
516 sed -e "s!@DATADIR@!${DATADIR}!g" \ 846 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
517 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 847 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \
518 > "${TMPDIR}/my.cnf.ok" 848 > "${TMPDIR}/my.cnf.ok"
519 if mysql_version_is_at_least "4.01.00.00" && useq "latin1" ; then 849 if mysql_version_is_at_least "4.1" && use latin1 ; then
520 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 850 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok"
521 fi 851 fi
522 newins "${TMPDIR}/my.cnf.ok" my.cnf 852 newins "${TMPDIR}/my.cnf.ok" my.cnf
523 853
524 insinto "/etc/conf.d"
525 newins "${FILESDIR}/mysql.conf.d" "mysql"
526 mysql_version_is_at_least "5.00.11.00" \
527 && newins "${FILESDIR}/mysqlmanager.conf.d" "mysqlmanager"
528
529 # Minimal builds don't have the MySQL server 854 # Minimal builds don't have the MySQL server
530 if ! useq "minimal" ; then 855 if ! use minimal ; then
531 exeinto "/etc/init.d" 856 einfo "Creating initial directories"
532 newexe "${FILESDIR}/mysql.rc6" "mysql"
533 mysql_version_is_at_least "5.00.11.00" \
534 && newexe "${FILESDIR}/mysqlmanager.rc6" "mysqlmanager"
535
536 insinto "/etc/logrotate.d"
537 newins "${FILESDIR}/logrotate.mysql" "mysql"
538
539 # Empty directories ... 857 # Empty directories ...
540 diropts "-m0750" 858 diropts "-m0750"
541 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 859 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
542 dodir "${DATADIR}" 860 dodir "${MY_DATADIR}"
543 keepdir "${DATADIR}" 861 keepdir "${MY_DATADIR}"
544 chown -R mysql:mysql "${D}/${DATADIR}" 862 chown -R mysql:mysql "${D}/${MY_DATADIR}"
545 fi 863 fi
546 864
547 diropts "-m0755" 865 diropts "-m0755"
548 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do 866 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do
549 dodir "${folder}" 867 dodir "${folder}"
551 chown -R mysql:mysql "${D}/${folder}" 869 chown -R mysql:mysql "${D}/${folder}"
552 done 870 done
553 fi 871 fi
554 872
555 # Docs 873 # Docs
874 einfo "Installing docs"
556 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 875 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
876 doinfo "${S}"/Docs/mysql.info
557 877
558 # Minimal builds don't have the MySQL server 878 # Minimal builds don't have the MySQL server
559 if ! useq "minimal" ; then 879 if ! use minimal ; then
880 einfo "Including support files and sample configurations"
881 docinto "support-files"
882 for script in \
883 "${S}"/support-files/my-*.cnf \
884 "${S}"/support-files/magic \
885 "${S}"/support-files/ndb-config-2-node.ini
886 do
887 dodoc "${script}"
888 done
889
890 docinto "scripts"
891 for script in "${S}"/scripts/mysql* ; do
892 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
893 done
894
895 fi
896
897 mysql_lib_symlinks "${D}"
898}
899
900# @FUNCTION: mysql_pkg_preinst
901# @DESCRIPTION:
902# Create the user and groups for mysql - die if that fails.
903mysql_pkg_preinst() {
904 enewgroup mysql 60 || die "problem adding 'mysql' group"
905 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
906}
907
908# @FUNCTION: mysql_pkg_postinst
909# @DESCRIPTION:
910# Run post-installation tasks:
911# create the dir for logfiles if non-existant
912# touch the logfiles and secure them
913# install scripts
914# issue required steps for optional features
915# issue deprecation warnings
916mysql_pkg_postinst() {
917 # Make sure the vars are correctly initialized
918 mysql_init_vars
919
920 # Check FEATURES="collision-protect" before removing this
921 [[ -d "${ROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
922
923 # Secure the logfiles
924 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
925 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
926 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
927
928 # Minimal builds don't have the MySQL server
929 if ! use minimal ; then
560 docinto "support-files" 930 docinto "support-files"
561 for script in \ 931 for script in \
562 support-files/my-*.cnf \ 932 support-files/my-*.cnf \
563 support-files/magic \ 933 support-files/magic \
564 support-files/ndb-config-2-node.ini 934 support-files/ndb-config-2-node.ini
568 938
569 docinto "scripts" 939 docinto "scripts"
570 for script in scripts/mysql* ; do 940 for script in scripts/mysql* ; do
571 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 941 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
572 done 942 done
573 fi
574 943
575 ROOT="${D}" mysql_lib_symlinks
576}
577
578mysql_pkg_preinst() {
579 enewgroup mysql 60 || die "problem adding 'mysql' group"
580 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
581}
582
583mysql_pkg_postinst() {
584 # Make sure the vars are correctly initialized
585 mysql_init_vars
586
587 # Check FEATURES="collision-protect" before removing this
588 [[ -d "${ROOT}/var/log/mysql" ]] \
589 || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
590
591 # Secure the logfiles
592 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
593 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
594 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
595
596 if ! useq "minimal" ; then
597 # Your friendly public service announcement ...
598 einfo 944 einfo
599 elog "You might want to run:" 945 elog "You might want to run:"
600 elog "\"emerge --config =${CATEGORY}/${PF}\"" 946 elog "\"emerge --config =${CATEGORY}/${PF}\""
601 elog "if this is a new install." 947 elog "if this is a new install."
602 einfo 948 einfo
603 mysql_version_is_at_least "5.01.00.00" \
604 || elog "InnoDB is *not* optional as of MySQL-4.0.24, at the request of upstream."
605 fi 949 fi
950
951 if mysql_version_is_at_least "5.1.12" && use pbxt ; then
952 # TODO: explain it better
953 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
954 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
955 elog "if, after that, you cannot start the MySQL server,"
956 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
957 elog "use the MySQL upgrade script to restore the table"
958 elog "or execute the following SQL command:"
959 elog " CREATE TABLE IF NOT EXISTS plugin ("
960 elog " name char(64) binary DEFAULT '' NOT NULL,"
961 elog " dl char(128) DEFAULT '' NOT NULL,"
962 elog " PRIMARY KEY (name)"
963 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
964 fi
965
606 mysql_check_version_range "4.00.00.00 to 5.00.99.99" \ 966 mysql_check_version_range "4.0 to 5.0.99.99" \
607 && useq "berkdb" \ 967 && use berkdb \
608 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 968 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
609} 969}
610 970
971# @FUNCTION: mysql_pkg_config
972# @DESCRIPTION:
973# Configure mysql environment.
611mysql_pkg_config() { 974mysql_pkg_config() {
975 local old_MY_DATADIR="${MY_DATADIR}"
976
612 # Make sure the vars are correctly initialized 977 # Make sure the vars are correctly initialized
613 mysql_init_vars 978 mysql_init_vars
614 979
615 [[ -z "${DATADIR}" ]] && die "Sorry, unable to find DATADIR" 980 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
616 981
617 if built_with_use dev-db/mysql minimal ; then 982 if built_with_use ${CATEGORY}/${PN} minimal ; then
618 die "Minimal builds do NOT include the MySQL server" 983 die "Minimal builds do NOT include the MySQL server"
984 fi
985
986 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
987 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
988 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
989
990 if [[ -d "${old_MY_DATADIR_s}" ]]; then
991 if [[ -d "${MY_DATADIR_s}" ]]; then
992 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
993 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
994 else
995 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
996 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
997 || die "Moving MY_DATADIR failed"
998 fi
999 else
1000 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
1001 if [[ -d "${MY_DATADIR_s}" ]]; then
1002 ewarn "Attempting to use ${MY_DATADIR_s}"
1003 else
1004 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
1005 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
1006 fi
1007 fi
619 fi 1008 fi
620 1009
621 local pwd1="a" 1010 local pwd1="a"
622 local pwd2="b" 1011 local pwd2="b"
623 local maxtry=5 1012 local maxtry=5
624 1013
625 if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then 1014 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
626 ewarn "You have already a MySQL database in place." 1015 ewarn "You have already a MySQL database in place."
627 ewarn "(${ROOT}/${DATADIR}/*)" 1016 ewarn "(${ROOT}/${MY_DATADIR}/*)"
628 ewarn "Please rename or delete it if you wish to replace it." 1017 ewarn "Please rename or delete it if you wish to replace it."
629 die "MySQL database already exists!" 1018 die "MySQL database already exists!"
630 fi 1019 fi
1020
1021 # Bug #213475 - MySQL _will_ object strenously if your machine is named
1022 # localhost. Also causes weird failures.
1023 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
631 1024
632 einfo "Creating the mysql database and setting proper" 1025 einfo "Creating the mysql database and setting proper"
633 einfo "permissions on it ..." 1026 einfo "permissions on it ..."
634 1027
635 einfo "Insert a password for the mysql 'root' user" 1028 einfo "Insert a password for the mysql 'root' user"
651 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \ 1044 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
652 || touch "${TMPDIR}/fill_help_tables.sql" 1045 || touch "${TMPDIR}/fill_help_tables.sql"
653 help_tables="${TMPDIR}/fill_help_tables.sql" 1046 help_tables="${TMPDIR}/fill_help_tables.sql"
654 1047
655 pushd "${TMPDIR}" &>/dev/null 1048 pushd "${TMPDIR}" &>/dev/null
656 "${ROOT}/usr/bin/mysql_install_db" | grep -B5 -A999 -i "ERROR" 1049 "${ROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
1050 if [ $? -ne 0 ]; then
1051 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
1052 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
1053 fi
657 popd &>/dev/null 1054 popd &>/dev/null
658 [[ -f "${ROOT}/${DATADIR}/mysql/user.frm" ]] \ 1055 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
659 || die "MySQL databases not installed" 1056 || die "MySQL databases not installed"
660 chown -R mysql:mysql "${ROOT}/${DATADIR}" 2> /dev/null 1057 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
661 chmod 0750 "${ROOT}/${DATADIR}" 2> /dev/null 1058 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
662 1059
663 if mysql_version_is_at_least "4.01.03.00" ; then 1060 if mysql_version_is_at_least "4.1.3" ; then
664 options="--skip-ndbcluster" 1061 options="--skip-ndbcluster"
665 1062
666 # Filling timezones, see 1063 # Filling timezones, see
667 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1064 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
668 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1065 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
677 local mysqld="${ROOT}/usr/sbin/mysqld \ 1074 local mysqld="${ROOT}/usr/sbin/mysqld \
678 ${options} \ 1075 ${options} \
679 --user=mysql \ 1076 --user=mysql \
680 --skip-grant-tables \ 1077 --skip-grant-tables \
681 --basedir=${ROOT}/usr \ 1078 --basedir=${ROOT}/usr \
682 --datadir=${ROOT}/${DATADIR} \ 1079 --datadir=${ROOT}/${MY_DATADIR} \
683 --skip-innodb \ 1080 --skip-innodb \
684 --skip-bdb \ 1081 --skip-bdb \
685 --skip-networking \ 1082 --skip-networking \
686 --max_allowed_packet=8M \ 1083 --max_allowed_packet=8M \
687 --net_buffer_length=16K \ 1084 --net_buffer_length=16K \
716 einfo "Stopping the server ..." 1113 einfo "Stopping the server ..."
717 wait %1 1114 wait %1
718 einfo "Done" 1115 einfo "Done"
719} 1116}
720 1117
1118# @FUNCTION: mysql_pkg_postrm
1119# @DESCRIPTION:
1120# Remove mysql symlinks.
721mysql_pkg_postrm() { 1121mysql_pkg_postrm() {
722 mysql_lib_symlinks 1122 : # mysql_lib_symlinks "${D}"
723} 1123}

Legend:
Removed from v.1.46  
changed lines
  Added in v.1.132

  ViewVC Help
Powered by ViewVC 1.1.20