/[gentoo-x86]/eclass/php5-sapi-r1.eclass
Gentoo

Contents of /eclass/php5-sapi-r1.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.27 - (hide annotations) (download)
Mon Nov 30 04:19:36 2009 UTC (9 years, 10 months ago) by abcd
Branch: MAIN
CVS Tags: HEAD
Changes since 1.26: +1 -1 lines
FILE REMOVED
Remove eclasses that have been marked as deprecated for >=2 years; schedule other deprecated eclasses for removal

1 stuart 1.1 # Copyright 1999-2005 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 abcd 1.27 # $Header: /var/cvsroot/gentoo-x86/eclass/php5-sapi-r1.eclass,v 1.26 2008/01/06 19:30:24 swegener Exp $
4 stuart 1.1 #
5 robbat2 1.8 # eclass/php5-sapi-r1.eclass
6 stuart 1.1 # Eclass for building different php5 SAPI instances
7     #
8     # Based on robbat2's work on the php4 sapi eclass
9     #
10     # Author(s) Stuart Herbert
11     # <stuart@gentoo.org>
12     #
13     # ========================================================================
14    
15 swegener 1.26 # DEPRECATED!!!
16 jokey 1.25 # STOP USING THIS ECLASS, use php5_2-sapi eclass instead!
17 stuart 1.1
18 jokey 1.25 inherit php5_2-sapi
19 stuart 1.1
20 jokey 1.25 deprecation_warning() {
21 swegener 1.26 eerror "Please upgrade ${PF} to use php5_2-sapi eclass instead!"
22 jokey 1.25 }
23 stuart 1.1
24 robbat2 1.8 php5-sapi-r1_check_awkward_uses() {
25 jokey 1.25 deprecation_warning
26     php5_2-sapi_check_use_flags
27 stuart 1.1 }
28    
29 robbat2 1.8 php5-sapi-r1_pkg_setup() {
30 jokey 1.25 deprecation_warning
31     php5_2-sapi_pkg_setup
32 stuart 1.1 }
33    
34 robbat2 1.8 php5-sapi-r1_src_unpack() {
35 jokey 1.25 deprecation_warning
36     php5_2-sapi_src_unpack
37 stuart 1.1 }
38    
39 robbat2 1.8 php5-sapi-r1_src_compile() {
40 jokey 1.25 deprecation_warning
41     php5_2-sapi_src_compile
42 stuart 1.1 }
43    
44 robbat2 1.8 php5-sapi-r1_src_install() {
45 jokey 1.25 deprecation_warning
46     php5_2-sapi_src_install
47 stuart 1.1 }
48    
49 robbat2 1.8 php5-sapi-r1_pkg_postinst() {
50 jokey 1.25 deprecation_warning
51     php5_2-sapi_pkg_postinst
52 stuart 1.1 }

  ViewVC Help
Powered by ViewVC 1.1.20