/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Diff of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.111 Revision 1.132
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.111 2011/12/27 16:04:27 pesa Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.132 2012/06/07 15:36:49 pesa Exp $
4 4
5# @ECLASS: qt4-build.eclass 5# @ECLASS: qt4-build.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Qt herd <qt@gentoo.org> 7# Qt herd <qt@gentoo.org>
8# @BLURB: Eclass for Qt4 split ebuilds. 8# @BLURB: Eclass for Qt4 split ebuilds.
9# @DESCRIPTION: 9# @DESCRIPTION:
10# This eclass contains various functions that are used when building Qt4. 10# This eclass contains various functions that are used when building Qt4.
11 11
12case ${EAPI} in
13 2|3|4) : ;;
14 *) die "qt4-build.eclass requires EAPI 2, 3 or 4." ;;
15esac
16
12inherit base eutils multilib toolchain-funcs flag-o-matic versionator 17inherit base eutils flag-o-matic multilib toolchain-funcs versionator
18
19if [[ ${PV} == *9999* ]]; then
20 QT4_BUILD_TYPE="live"
21 inherit git-2
22else
23 QT4_BUILD_TYPE="release"
24fi
25
26HOMEPAGE="http://qt-project.org/ http://qt.nokia.com/"
27LICENSE="|| ( LGPL-2.1 GPL-3 )"
13 28
14MY_PV=${PV/_/-} 29MY_PV=${PV/_/-}
15MY_P=qt-everywhere-opensource-src-${MY_PV} 30MY_P=qt-everywhere-opensource-src-${MY_PV}
16 31
17HOMEPAGE="http://qt.nokia.com/ http://qt-project.org/" 32case ${QT4_BUILD_TYPE} in
33 live)
34 EGIT_REPO_URI="git://gitorious.org/qt/qt.git
35 https://git.gitorious.org/qt/qt.git"
36 EGIT_BRANCH="${PV%.9999}"
37 ;;
38 release)
39 if version_is_at_least 4.8.1; then
40 SRC_URI="http://releases.qt-project.org/qt4/source/${MY_P}.tar.gz"
41 else
18SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz" 42 SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
19LICENSE="|| ( LGPL-2.1 GPL-3 )" 43 fi
44 ;;
45esac
20 46
21IUSE="aqua debug pch" 47IUSE="aqua debug pch"
22
23[[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]] && 48if [[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]]; then
24[[ ${CATEGORY}/${PN} != x11-themes/qgtkstyle ]] &&
25 IUSE+=" +exceptions" 49 IUSE+=" +exceptions"
26 50fi
27if version_is_at_least 4.7.99999999; then 51if version_is_at_least 4.8; then
28 IUSE+=" c++0x qpa" 52 IUSE+=" c++0x qpa"
29fi 53fi
30 54
31DEPEND="dev-util/pkgconfig" 55DEPEND="virtual/pkgconfig"
56if [[ ${QT4_BUILD_TYPE} == live ]]; then
57 DEPEND+=" dev-lang/perl"
58fi
59
32RDEPEND=" 60RDEPEND="
33 !<x11-libs/qt-assistant-${PV} 61 !<x11-libs/qt-assistant-${PV}:4
34 !>x11-libs/qt-assistant-${PV}-r9999 62 !>x11-libs/qt-assistant-${PV}-r9999:4
63 !<x11-libs/qt-bearer-${PV}:4
64 !>x11-libs/qt-bearer-${PV}-r9999:4
35 !<x11-libs/qt-core-${PV} 65 !<x11-libs/qt-core-${PV}:4
36 !>x11-libs/qt-core-${PV}-r9999 66 !>x11-libs/qt-core-${PV}-r9999:4
37 !<x11-libs/qt-dbus-${PV} 67 !<x11-libs/qt-dbus-${PV}:4
38 !>x11-libs/qt-dbus-${PV}-r9999 68 !>x11-libs/qt-dbus-${PV}-r9999:4
39 !<x11-libs/qt-declarative-${PV} 69 !<x11-libs/qt-declarative-${PV}:4
40 !>x11-libs/qt-declarative-${PV}-r9999 70 !>x11-libs/qt-declarative-${PV}-r9999:4
41 !<x11-libs/qt-demo-${PV} 71 !<x11-libs/qt-demo-${PV}:4
42 !>x11-libs/qt-demo-${PV}-r9999 72 !>x11-libs/qt-demo-${PV}-r9999:4
43 !<x11-libs/qt-gui-${PV} 73 !<x11-libs/qt-gui-${PV}:4
44 !>x11-libs/qt-gui-${PV}-r9999 74 !>x11-libs/qt-gui-${PV}-r9999:4
45 !<x11-libs/qt-multimedia-${PV} 75 !<x11-libs/qt-multimedia-${PV}:4
46 !>x11-libs/qt-multimedia-${PV}-r9999 76 !>x11-libs/qt-multimedia-${PV}-r9999:4
47 !<x11-libs/qt-opengl-${PV} 77 !<x11-libs/qt-opengl-${PV}:4
48 !>x11-libs/qt-opengl-${PV}-r9999 78 !>x11-libs/qt-opengl-${PV}-r9999:4
79 !<x11-libs/qt-openvg-${PV}:4
80 !>x11-libs/qt-openvg-${PV}-r9999:4
49 !<x11-libs/qt-phonon-${PV} 81 !<x11-libs/qt-phonon-${PV}:4
50 !>x11-libs/qt-phonon-${PV}-r9999 82 !>x11-libs/qt-phonon-${PV}-r9999:4
51 !<x11-libs/qt-qt3support-${PV} 83 !<x11-libs/qt-qt3support-${PV}:4
52 !>x11-libs/qt-qt3support-${PV}-r9999 84 !>x11-libs/qt-qt3support-${PV}-r9999:4
53 !<x11-libs/qt-script-${PV} 85 !<x11-libs/qt-script-${PV}:4
54 !>x11-libs/qt-script-${PV}-r9999 86 !>x11-libs/qt-script-${PV}-r9999:4
55 !<x11-libs/qt-sql-${PV} 87 !<x11-libs/qt-sql-${PV}:4
56 !>x11-libs/qt-sql-${PV}-r9999 88 !>x11-libs/qt-sql-${PV}-r9999:4
57 !<x11-libs/qt-svg-${PV} 89 !<x11-libs/qt-svg-${PV}:4
58 !>x11-libs/qt-svg-${PV}-r9999 90 !>x11-libs/qt-svg-${PV}-r9999:4
59 !<x11-libs/qt-test-${PV} 91 !<x11-libs/qt-test-${PV}:4
60 !>x11-libs/qt-test-${PV}-r9999 92 !>x11-libs/qt-test-${PV}-r9999:4
61 !<x11-libs/qt-webkit-${PV} 93 !<x11-libs/qt-webkit-${PV}:4
62 !>x11-libs/qt-webkit-${PV}-r9999 94 !>x11-libs/qt-webkit-${PV}-r9999:4
63 !<x11-libs/qt-xmlpatterns-${PV} 95 !<x11-libs/qt-xmlpatterns-${PV}:4
64 !>x11-libs/qt-xmlpatterns-${PV}-r9999 96 !>x11-libs/qt-xmlpatterns-${PV}-r9999:4
65" 97"
66 98
67S=${WORKDIR}/${MY_P} 99S=${WORKDIR}/${MY_P}
68 100
69# @FUNCTION: qt4-build_pkg_setup 101# @FUNCTION: qt4-build_pkg_setup
72qt4-build_pkg_setup() { 104qt4-build_pkg_setup() {
73 [[ ${EAPI} == 2 ]] && use !prefix && EPREFIX= 105 [[ ${EAPI} == 2 ]] && use !prefix && EPREFIX=
74 106
75 # Protect users by not allowing downgrades between releases 107 # Protect users by not allowing downgrades between releases
76 # Downgrading revisions within the same release should be allowed 108 # Downgrading revisions within the same release should be allowed
77 if has_version '>'${CATEGORY}/${P}-r9999; then 109 if has_version ">${CATEGORY}/${P}-r9999:4"; then
78 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 110 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
111 eerror
79 eerror "Sanity check to keep you from breaking your system:" 112 eerror "Sanity check to keep you from breaking your system:"
80 eerror " Downgrading Qt is completely unsupported and will break your system!" 113 eerror " Downgrading Qt is completely unsupported and will break your system!"
114 eerror
81 die "aborting to save your system" 115 die "aborting to save your system"
82 else 116 else
83 ewarn "Downgrading Qt is completely unsupported and will break your system!" 117 ewarn "Downgrading Qt is completely unsupported and will break your system!"
84 fi 118 fi
85 fi 119 fi
86 120
87 if [[ ${PN} == "qt-webkit" ]]; then 121 if [[ ${PN} == qt-webkit ]]; then
88 eshopts_push -s extglob 122 eshopts_push -s extglob
89 if is-flagq '-g?(gdb)?([1-9])'; then 123 if is-flagq '-g?(gdb)?([1-9])'; then
90 echo 124 echo
91 ewarn "You have enabled debug info (probably have -g or -ggdb in your \$C{,XX}FLAGS)." 125 ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
92 ewarn "You may experience really long compilation times and/or increased memory usage." 126 ewarn "You may experience really long compilation times and/or increased memory usage."
93 ewarn "If compilation fails, please try removing -g{,gdb} before reporting a bug." 127 ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
94 ewarn "For more info check out bug #307861" 128 ewarn "For more info check out bug #307861"
95 echo 129 echo
96 fi 130 fi
97 eshopts_pop 131 eshopts_pop
98 fi 132 fi
108 [[ ${CHOST} == *-apple-darwin* ]] && \ 142 [[ ${CHOST} == *-apple-darwin* ]] && \
109 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm 143 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm
110 ${QT4_EXTRACT_DIRECTORIES}" 144 ${QT4_EXTRACT_DIRECTORIES}"
111 fi 145 fi
112 146
113 # Make sure ebuilds use the required EAPI
114 if [[ ${EAPI} != [23] ]]; then
115 eerror "The qt4-build eclass requires EAPI=2 or EAPI=3, but this ebuild is using"
116 eerror "EAPI=${EAPI:-0}. The ebuild author or editor failed. This ebuild needs to be"
117 eerror "fixed. Using qt4-build eclass without EAPI=2 or EAPI=3 will fail."
118 die "qt4-build eclass requires EAPI=2 or EAPI=3"
119 fi
120
121 if ! version_is_at_least 4.1 $(gcc-version); then 147 if ! version_is_at_least 4.1 $(gcc-version); then
122 ewarn "Using a GCC version lower than 4.1 is not supported!" 148 ewarn "Using a GCC version lower than 4.1 is not supported."
123 fi 149 fi
124} 150}
125 151
126# @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES 152# @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES
127# @DESCRIPTION: 153# @DESCRIPTION:
136# @FUNCTION: qt4-build_src_unpack 162# @FUNCTION: qt4-build_src_unpack
137# @DESCRIPTION: 163# @DESCRIPTION:
138# Unpacks the sources. 164# Unpacks the sources.
139qt4-build_src_unpack() { 165qt4-build_src_unpack() {
140 setqtenv 166 setqtenv
141 local target targets= 167
168 case ${QT4_BUILD_TYPE} in
169 live)
170 git-2_src_unpack
171 ;;
172 release)
173 local tarball="${MY_P}.tar.gz" target= targets=
142 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \ 174 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \
143 src/{qbase,qt_targets,qt_install}.pri bin config.tests mkspecs qmake \ 175 src/{qbase,qt_targets,qt_install}.pri bin config.tests \
144 ${QT4_EXTRACT_DIRECTORIES}; do 176 mkspecs qmake ${QT4_EXTRACT_DIRECTORIES}
177 do
145 targets+=" ${MY_P}/${target}" 178 targets+="${MY_P}/${target} "
146 done 179 done
147 180
181 ebegin "Unpacking parts of ${tarball}:" ${targets//${MY_P}\/}
148 echo tar xzf "${DISTDIR}"/${MY_P}.tar.gz ${targets} 182 tar -xzf "${DISTDIR}/${tarball}" ${targets}
149 tar xzf "${DISTDIR}"/${MY_P}.tar.gz ${targets} || die 183 eend $? || die "failed to unpack"
184 ;;
185 esac
150} 186}
151 187
152# @ECLASS-VARIABLE: PATCHES 188# @ECLASS-VARIABLE: PATCHES
153# @DEFAULT_UNSET 189# @DEFAULT_UNSET
154# @DESCRIPTION: 190# @DESCRIPTION:
166# @DESCRIPTION: 202# @DESCRIPTION:
167# Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix 203# Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix
168# the build system in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified in /etc/make.conf. 204# the build system in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified in /etc/make.conf.
169qt4-build_src_prepare() { 205qt4-build_src_prepare() {
170 setqtenv 206 setqtenv
171 cd "${S}"
172 207
208 if [[ ${QT4_BUILD_TYPE} == live ]]; then
209 QTDIR="." ./bin/syncqt || die "syncqt failed"
210 fi
211
173 if version_is_at_least "4.7"; then 212 if version_is_at_least 4.7; then
174 # fix libX11 dependency on non X packages 213 # fix libX11 dependency on non X packages
175 local nolibx11_pkgs="qt-core qt-dbus qt-script qt-sql qt-test qt-xmlpatterns" 214 local nolibx11_pkgs="qt-core qt-dbus qt-script qt-sql qt-test qt-xmlpatterns"
176 has ${PN} ${nolibx11_pkgs} && qt_nolibx11 215 has ${PN} ${nolibx11_pkgs} && qt_nolibx11
177 216
178 qt_assistant_cleanup 217 qt_assistant_cleanup
191 skip_qmake_build 230 skip_qmake_build
192 skip_project_generation 231 skip_project_generation
193 symlink_binaries_to_buildtree 232 symlink_binaries_to_buildtree
194 fi 233 fi
195 234
196 if [[ ${CHOST} == *86*-apple-darwin* ]] ; then 235 if [[ ${CHOST} == *86*-apple-darwin* ]]; then
197 # qmake bus errors with -O2 but -O3 works 236 # qmake bus errors with -O2 or -O3 but -O1 works
237 # Bug 373061
198 replace-flags -O2 -O3 238 replace-flags -O[23] -O1
199 fi 239 fi
200 240
201 # Bug 178652 241 # Bug 178652
202 if [[ $(gcc-major-version) == 3 ]] && use amd64; then 242 if [[ $(gcc-major-version) == 3 ]] && use amd64; then
203 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS" 243 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
204 append-flags -fno-gcse 244 append-flags -fno-gcse
205 fi 245 fi
206 246
207 if use_if_iuse c++0x; then 247 if use_if_iuse c++0x; then
248 echo
208 ewarn "You are about to build Qt4 using the C++11 standard. Even though" 249 ewarn "You are about to build Qt4 using the C++11 standard. Even though"
209 ewarn "this is an official standard, some of the reverse dependencies" 250 ewarn "this is an official standard, some of the reverse dependencies"
210 ewarn "may fail to compile or link againt the Qt4 libraries. Before" 251 ewarn "may fail to compile or link againt the Qt4 libraries. Before"
211 ewarn "reporting a bug, make sure your bug is reproducible with c++0x" 252 ewarn "reporting a bug, make sure your bug is reproducible with c++0x"
212 ewarn "disabled." 253 ewarn "disabled."
254 echo
213 append-flags -std=c++0x 255 append-flags -std=c++0x
214 fi 256 fi
215 257
216 # Unsupported old gcc versions - hardened needs this :( 258 # Unsupported old gcc versions - hardened needs this :(
217 if [[ $(gcc-major-version) -lt 4 ]] ; then 259 if [[ $(gcc-major-version) -lt 4 ]]; then
218 ewarn "Appending -fno-stack-protector to CXXFLAGS" 260 ewarn "Appending -fno-stack-protector to CXXFLAGS"
219 append-cxxflags -fno-stack-protector 261 append-cxxflags -fno-stack-protector
220 # Bug 253127 262 # Bug 253127
221 sed -e "/^QMAKE_CFLAGS\t/ s:$: -fno-stack-protector-all:" \ 263 sed -e "/^QMAKE_CFLAGS\t/ s:$: -fno-stack-protector-all:" \
222 -i mkspecs/common/g++.conf || die 264 -i mkspecs/common/g++.conf || die
233 CC='$(tc-getCC)'\n\ 275 CC='$(tc-getCC)'\n\
234 CXX='$(tc-getCXX)'\n\ 276 CXX='$(tc-getCXX)'\n\
235 CFLAGS='${CFLAGS}'\n\ 277 CFLAGS='${CFLAGS}'\n\
236 CXXFLAGS='${CXXFLAGS}'\n\ 278 CXXFLAGS='${CXXFLAGS}'\n\
237 LDFLAGS='${LDFLAGS}'\n" \ 279 LDFLAGS='${LDFLAGS}'\n" \
280 -i configure \
238 -i configure || die "sed SYSTEM_VARIABLES failed" 281 || die "sed SYSTEM_VARIABLES failed"
239 282
240 # Bug 321335 283 # Respect CC, CXX, LINK and *FLAGS in config.tests
241 find config.tests/unix -name '*.test' -type f -exec grep -lZ \$MAKE '{}' \; | xargs -0 \ 284 find config.tests/unix -name '*.test' -type f -print0 | xargs -0 \
242 sed -e "s:\(\$MAKE\):\1 CC='$(tc-getCC)' CXX='$(tc-getCXX)' LINK='$(tc-getCXX)':g" \ 285 sed -i -e "/bin\/qmake/ s: \"QT_BUILD_TREE=: \
243 -i || die "sed test compilers failed" 286 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \
287 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \
288 || die "sed config.tests failed"
289
290 if ! version_is_at_least 4.8; then
291 # Strip predefined CFLAGS from mkspecs (bugs 312689 and 352778)
292 sed -i -e '/^QMAKE_CFLAGS_RELEASE/s:+=.*:+=:' mkspecs/common/g++.conf || die
293 fi
244 294
245 # Bug 172219 295 # Bug 172219
246 sed -e "s:X11R6/::" -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die 296 sed -e 's:/X11R6/:/:' -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
247 297
248 if [[ ${CHOST} == *-darwin* ]]; then 298 if [[ ${CHOST} == *-darwin* ]]; then
249 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib 299 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib
250 # crippled (by design) :/ 300 # crippled (by design) :/
301 local mac_gpp_conf=
302 if [[ -f mkspecs/common/mac-g++.conf ]]; then
303 # qt < 4.8 has mac-g++.conf
304 mac_gpp_conf="mkspecs/common/mac-g++.conf"
305 elif [[ -f mkspecs/common/g++-macx.conf ]]; then
306 # qt >= 4.8 has g++-macx.conf
307 mac_gpp_conf="mkspecs/common/g++-macx.conf"
308 else
309 die "no known conf file for mac found"
310 fi
311 sed \
251 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \ 312 -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
252 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \ 313 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
253 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \ 314 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \
254 -e "s:-arch\s\w*::g" \ 315 -e "s:-arch\s\w*::g" \
255 -i mkspecs/common/mac-g++.conf || die "sed mkspecs/common/mac-g++.conf failed" 316 -i ${mac_gpp_conf} \
317 || die "sed ${mac_gpp_conf} failed"
256 318
257 # Fix configure's -arch settings that appear in qmake/Makefile and also 319 # Fix configure's -arch settings that appear in qmake/Makefile and also
258 # fix arch handling (automagically duplicates our -arch arg and breaks 320 # fix arch handling (automagically duplicates our -arch arg and breaks
259 # pch). Additionally disable Xarch support. 321 # pch). Additionally disable Xarch support.
322 local mac_gcc_confs="${mac_gpp_conf}"
323 if [[ -f mkspecs/common/gcc-base-macx.conf ]]; then
324 mac_gcc_confs+=" mkspecs/common/gcc-base-macx.conf"
325 fi
260 sed \ 326 sed \
261 -e "s:-arch i386::" \ 327 -e "s:-arch i386::" \
262 -e "s:-arch ppc::" \ 328 -e "s:-arch ppc::" \
263 -e "s:-arch x86_64::" \ 329 -e "s:-arch x86_64::" \
264 -e "s:-arch ppc64::" \ 330 -e "s:-arch ppc64::" \
265 -e "s:-arch \$i::" \ 331 -e "s:-arch \$i::" \
266 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \ 332 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \
267 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \ 333 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \
268 -e "s:-Xarch_x86_64::g" \ 334 -e "s:-Xarch_x86_64::g" \
269 -e "s:-Xarch_ppc64::g" \ 335 -e "s:-Xarch_ppc64::g" \
270 -i configure mkspecs/common/mac-g++.conf || die "sed -arch/-Xarch failed" 336 -i configure ${mac_gcc_confs} \
337 || die "sed -arch/-Xarch failed"
271 338
272 # On Snow Leopard don't fall back to 10.5 deployment target. 339 # On Snow Leopard don't fall back to 10.5 deployment target.
273 if [[ ${CHOST} == *-apple-darwin10 ]] ; then 340 if [[ ${CHOST} == *-apple-darwin10 ]]; then
274 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \ 341 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \
275 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \ 342 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \
276 -i configure mkspecs/common/mac-g++.conf || die "sed deployment target failed" 343 -i configure ${mac_gpp_conf} \
344 || die "sed deployment target failed"
277 fi 345 fi
278 fi 346 fi
279 347
280 # this one is needed for all systems with a separate -liconv, apart from 348 # this one is needed for all systems with a separate -liconv, apart from
281 # Darwin, for which the sources already cater for -liconv 349 # Darwin, for which the sources already cater for -liconv
282 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]] ; then 350 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]]; then
283 sed \ 351 sed -e 's|mac:\(LIBS += -liconv\)|\1|g' \
284 -e "s|mac:LIBS += -liconv|LIBS += -liconv|g" \
285 -i config.tests/unix/iconv/iconv.pro \ 352 -i config.tests/unix/iconv/iconv.pro \
286 || die "sed on iconv.pro failed" 353 || die "sed iconv.pro failed"
287 fi 354 fi
288 355
289 # we need some patches for Solaris 356 # we need some patches for Solaris
290 sed -i \
291 -e '/^QMAKE_LFLAGS_THREAD/a\QMAKE_LFLAGS_DYNAMIC_LIST = -Wl,--dynamic-list,' \ 357 sed -i -e '/^QMAKE_LFLAGS_THREAD/a\QMAKE_LFLAGS_DYNAMIC_LIST = -Wl,--dynamic-list,' \
292 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die 358 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
293 # use GCC over SunStudio 359 # use GCC over SunStudio
294 sed -i -e '/PLATFORM=solaris-cc/s/cc/g++/' configure || die 360 sed -i -e '/PLATFORM=solaris-cc/s/cc/g++/' configure || die
295 # don't flirt with non-Prefix stuff, we're quite possessive 361 # do not flirt with non-Prefix stuff, we're quite possessive
296 sed -i -e '/^QMAKE_\(LIB\|INC\)DIR\(_X11\|_OPENGL\|\)\t/s/=.*$/=/' \ 362 sed -i -e '/^QMAKE_\(LIB\|INC\)DIR\(_X11\|_OPENGL\|\)\t/s/=.*$/=/' \
297 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die 363 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
298 # strip predefined CFLAGS from qmake ( bug #312689 )
299 sed -i '/^QMAKE_CFLAGS_RELEASE/s:+=.*:+=:' mkspecs/common/g++.conf
300 364
301 base_src_prepare 365 base_src_prepare
302} 366}
303 367
304# @FUNCTION: qt4-build_src_configure 368# @FUNCTION: qt4-build_src_configure
305# @DESCRIPTION: 369# @DESCRIPTION:
306# Default configure phase 370# Default configure phase
307qt4-build_src_configure() { 371qt4-build_src_configure() {
308 setqtenv 372 setqtenv
309 myconf="$(standard_configure_options) ${myconf}" 373
374 local conf="
375 -prefix ${QTPREFIXDIR}
376 -bindir ${QTBINDIR}
377 -libdir ${QTLIBDIR}
378 -docdir ${QTDOCDIR}
379 -headerdir ${QTHEADERDIR}
380 -plugindir ${QTPLUGINDIR}
381 $(version_is_at_least 4.7 && echo -importdir ${QTIMPORTDIR})
382 -datadir ${QTDATADIR}
383 -translationdir ${QTTRANSDIR}
384 -sysconfdir ${QTSYSCONFDIR}
385 -examplesdir ${QTEXAMPLESDIR}
386 -demosdir ${QTDEMOSDIR}
387 -opensource -confirm-license
388 -shared -fast -largefile -stl -verbose
389 -nomake examples -nomake demos"
390
391 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
392 # $(tc-arch). Therefore we convert it to supported values.
393 case "$(tc-arch)" in
394 amd64|x64-*) conf+=" -arch x86_64" ;;
395 ppc-macos) conf+=" -arch ppc" ;;
396 ppc|ppc64|ppc-*) conf+=" -arch powerpc" ;;
397 sparc|sparc-*|sparc64-*) conf+=" -arch sparc" ;;
398 x86-macos) conf+=" -arch x86" ;;
399 x86|x86-*) conf+=" -arch i386" ;;
400 alpha|arm|ia64|mips|s390) conf+=" -arch $(tc-arch)" ;;
401 hppa|sh) conf+=" -arch generic" ;;
402 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
403 esac
404
405 conf+=" -platform $(qt_mkspecs_dir)"
406
407 [[ $(get_libdir) != lib ]] && conf+=" -L${EPREFIX}/usr/$(get_libdir)"
408
409 # debug/release
410 if use debug; then
411 conf+=" -debug"
412 else
413 conf+=" -release"
414 fi
415 conf+=" -no-separate-debug-info"
416
417 # exceptions USE flag
418 conf+=" $(in_iuse exceptions && qt_use exceptions || echo -exceptions)"
419
420 # disable rpath on Qt >= 4.8 (bug 380415)
421 # but leave it enabled on prefix (bug 417169)
422 version_is_at_least 4.8 && use !prefix && conf+=" -no-rpath"
423
424 # precompiled headers don't work on hardened, where the flag is masked
425 conf+=" $(qt_use pch)"
426
427 # -reduce-relocations
428 # This flag seems to introduce major breakage to applications,
429 # mostly to be seen as a core dump with the message "QPixmap: Must
430 # construct a QApplication before a QPaintDevice" on Solaris.
431 # -- Daniel Vergien
432 [[ ${CHOST} != *-solaris* ]] && conf+=" -reduce-relocations"
310 433
311 # this one is needed for all systems with a separate -liconv, apart from 434 # this one is needed for all systems with a separate -liconv, apart from
312 # Darwin, for which the sources already cater for -liconv 435 # Darwin, for which the sources already cater for -liconv
313 use !elibc_glibc && [[ ${CHOST} != *-darwin* ]] && \ 436 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]]; then
314 myconf+=" -liconv" 437 conf+=" -liconv"
438 fi
315 439
316 if use_if_iuse glib; then 440 if use_if_iuse glib; then
317 # use -I, -L and -l from configure
318 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)" 441 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)"
319 # avoid the -pthread argument 442 # avoid the -pthread argument
320 myconf+=" ${glibflags//-pthread}" 443 conf+=" ${glibflags//-pthread}"
321 unset glibflags 444 unset glibflags
322 fi 445 fi
323 446
324 if use_if_iuse qpa; then 447 if use_if_iuse qpa; then
325 ewarn 448 echo
326 ewarn "The qpa useflag enables the Qt Platform Abstraction, formely" 449 ewarn "The qpa useflag enables the Qt Platform Abstraction, formely"
327 ewarn "known as Qt Lighthouse. If you are not sure what that is, then" 450 ewarn "known as Qt Lighthouse. If you are not sure what that is, then"
328 ewarn "disable it before reporting any bugs related to this useflag." 451 ewarn "disable it before reporting any bugs related to this useflag."
329 ewarn 452 echo
330 myconf+=" -qpa" 453 conf+=" -qpa"
331 fi 454 fi
332 455
333 if use aqua ; then 456 if use aqua; then
334 # On (snow) leopard use the new (frameworked) cocoa code. 457 # On (snow) leopard use the new (frameworked) cocoa code.
335 if [[ ${CHOST##*-darwin} -ge 9 ]] ; then 458 if [[ ${CHOST##*-darwin} -ge 9 ]]; then
336 myconf+=" -cocoa -framework" 459 conf+=" -cocoa -framework"
460 # We need the source's headers, not the installed ones.
461 conf+=" -I${S}/include"
462 # Add hint for the framework location.
463 conf+=" -F${QTLIBDIR}"
337 464
338 # We are crazy and build cocoa + qt3support :-) 465 # We are crazy and build cocoa + qt3support :-)
339 if use qt3support; then 466 if use qt3support; then
340 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \ 467 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \
341 -i configure 468 -i configure || die
342 fi 469 fi
343 470 else
344 # We need the source's headers, not the installed ones. 471 conf+=" -no-framework"
345 myconf+=" -I${S}/include"
346
347 # Add hint for the framework location.
348 myconf+=" -F${QTLIBDIR}"
349 fi 472 fi
350 else 473 else
351 # freetype2 include dir is non-standard, thus include it on configure 474 # freetype2 include dir is non-standard, thus pass it to configure
352 # use -I from configure
353 myconf+=" $(pkg-config --cflags freetype2)" 475 conf+=" $(pkg-config --cflags-only-I freetype2)"
354 fi 476 fi
355 477
478 conf+=" ${myconf}"
479 myconf=
480
356 echo ./configure ${myconf} 481 echo ./configure ${conf}
357 ./configure ${myconf} || die "./configure failed" 482 ./configure ${conf} || die "./configure failed"
358 myconf=""
359 483
360 prepare_directories ${QT4_TARGET_DIRECTORIES} 484 prepare_directories ${QT4_TARGET_DIRECTORIES}
361} 485}
362 486
363# @FUNCTION: qt4-build_src_compile 487# @FUNCTION: qt4-build_src_compile
371 495
372# @FUNCTION: qt4-build_src_test 496# @FUNCTION: qt4-build_src_test
373# @DESCRIPTION: 497# @DESCRIPTION:
374# Runs tests only in target directories. 498# Runs tests only in target directories.
375qt4-build_src_test() { 499qt4-build_src_test() {
500 # QtMultimedia does not have any test suite (bug #332299)
501 [[ ${PN} == qt-multimedia ]] && return
502
376 for dir in ${QT4_TARGET_DIRECTORIES}; do 503 for dir in ${QT4_TARGET_DIRECTORIES}; do
377 emake -j1 check -C ${dir} 504 emake -j1 check -C ${dir}
378 done 505 done
379} 506}
380 507
381# @FUNCTION: fix_includes 508# @FUNCTION: fix_includes
382# @DESCRIPTION: 509# @DESCRIPTION:
383# For MacOS X we need to add some symlinks when frameworks are 510# For MacOS X we need to add some symlinks when frameworks are
384# being used, to avoid complications with some more or less stupid packages. 511# being used, to avoid complications with some more or less stupid packages.
385fix_includes() { 512fix_includes() {
386 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then 513 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
514 local frw dest f h rdir
387 # Some packages tend to include <Qt/...> 515 # Some packages tend to include <Qt/...>
388 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt 516 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt
389 517
390 # Fake normal headers when frameworks are installed... eases life later on 518 # Fake normal headers when frameworks are installed... eases life later
391 local dest f 519 # on, make sure we use relative links though, as some ebuilds assume
520 # these dirs exist in src_install to add additional files
521 f=${QTHEADERDIR}
522 h=${QTLIBDIR}
523 while [[ -n ${f} && ${f%%/*} == ${h%%/*} ]] ; do
524 f=${f#*/}
525 h=${h#*/}
526 done
527 rdir=${h}
528 f="../"
529 while [[ ${h} == */* ]] ; do
530 f="${f}../"
531 h=${h#*/}
532 done
533 rdir="${f}${rdir}"
534
392 for frw in "${D}${QTLIBDIR}"/*.framework; do 535 for frw in "${D}${QTLIBDIR}"/*.framework; do
393 [[ -e "${frw}"/Headers ]] || continue 536 [[ -e "${frw}"/Headers ]] || continue
394 f=$(basename ${frw}) 537 f=$(basename ${frw})
395 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework} 538 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework}
396 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers "${dest}" 539 dosym "${rdir}"/${f}/Headers "${dest}"
397 540
398 # Link normal headers as well. 541 # Link normal headers as well.
399 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do 542 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do
400 h=$(basename ${hdr}) 543 h=$(basename ${hdr})
401 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers/${h} "${QTHEADERDIR#${EPREFIX}}"/Qt/${h} 544 dosym "../${rdir}"/${f}/Headers/${h} \
545 "${QTHEADERDIR#${EPREFIX}}"/Qt/${h}
402 done 546 done
403 done 547 done
404 fi 548 fi
405} 549}
406 550
415 install_qconfigs 559 install_qconfigs
416 fix_library_files 560 fix_library_files
417 fix_includes 561 fix_includes
418 562
419 # remove .la files since we are building only shared Qt libraries 563 # remove .la files since we are building only shared Qt libraries
420 find "${D}"${QTLIBDIR} -name "*.la" -print0 | xargs -0 rm 564 find "${D}"${QTLIBDIR} -type f -name '*.la' -print0 | xargs -0 rm -f
421} 565}
422 566
423# @FUNCTION: setqtenv 567# @FUNCTION: setqtenv
424# @INTERNAL 568# @INTERNAL
425setqtenv() { 569setqtenv() {
439 QTDEMOSDIR=${QTDATADIR}/demos 583 QTDEMOSDIR=${QTDATADIR}/demos
440 QMAKE_LIBDIR_QT=${QTLIBDIR} 584 QMAKE_LIBDIR_QT=${QTLIBDIR}
441 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4 585 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4
442 586
443 PLATFORM=$(qt_mkspecs_dir) 587 PLATFORM=$(qt_mkspecs_dir)
444
445 unset QMAKESPEC 588 unset QMAKESPEC
446}
447 589
448# @FUNCTION: standard_configure_options 590 export XDG_CONFIG_HOME="${T}"
449# @INTERNAL
450# @DESCRIPTION:
451# Sets up some standard configure options, like libdir (if necessary), whether
452# debug info is wanted or not.
453standard_configure_options() {
454 local myconf="-prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR}
455 -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR}
456 -importdir ${QTIMPORTDIR} -datadir ${QTDATADIR} -translationdir ${QTTRANSDIR}
457 -sysconfdir ${QTSYSCONFDIR} -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR}
458 -opensource -confirm-license -shared -fast -largefile -stl -verbose
459 -platform $(qt_mkspecs_dir) -nomake examples -nomake demos"
460
461 [[ $(get_libdir) != lib ]] && myconf+=" -L${EPREFIX}/usr/$(get_libdir)"
462
463 # debug/release
464 if use debug; then
465 myconf+=" -debug"
466 else
467 myconf+=" -release"
468 fi
469 myconf+=" -no-separate-debug-info"
470
471 # exceptions USE flag
472 local exceptions="-exceptions"
473 in_iuse exceptions && exceptions="$(qt_use exceptions)"
474 myconf+=" ${exceptions}"
475
476 # disable RPATH on Qt >= 4.8 (bug 380415)
477 version_is_at_least 4.8 && myconf+=" -no-rpath"
478
479 # precompiled headers don't work on hardened, where the flag is masked
480 myconf+=" $(qt_use pch)"
481
482 # -reduce-relocations
483 # This flag seems to introduce major breakage to applications,
484 # mostly to be seen as a core dump with the message "QPixmap: Must
485 # construct a QApplication before a QPaintDevice" on Solaris.
486 # -- Daniel Vergien
487 [[ ${CHOST} != *-solaris* ]] && myconf+=" -reduce-relocations"
488
489 use aqua && myconf+=" -no-framework"
490
491 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
492 # $(tc-arch). Therefore we convert it to supported values.
493 case "$(tc-arch)" in
494 amd64|x64-*) myconf+=" -arch x86_64" ;;
495 ppc-macos) myconf+=" -arch ppc" ;;
496 ppc|ppc64|ppc-*) myconf+=" -arch powerpc" ;;
497 sparc|sparc-*|sparc64-*) myconf+=" -arch sparc" ;;
498 x86-macos) myconf+=" -arch x86" ;;
499 x86|x86-*) myconf+=" -arch i386" ;;
500 alpha|arm|ia64|mips|s390) myconf+=" -arch $(tc-arch)" ;;
501 hppa|sh) myconf+=" -arch generic" ;;
502 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
503 esac
504
505 echo "${myconf}"
506} 591}
507 592
508# @FUNCTION: prepare_directories 593# @FUNCTION: prepare_directories
509# @USAGE: < directories > 594# @USAGE: < directories >
510# @INTERNAL 595# @INTERNAL
597# @FUNCTION: generate_qconfigs 682# @FUNCTION: generate_qconfigs
598# @INTERNAL 683# @INTERNAL
599# @DESCRIPTION: 684# @DESCRIPTION:
600# Generates gentoo-specific qconfig.{h,pri}. 685# Generates gentoo-specific qconfig.{h,pri}.
601generate_qconfigs() { 686generate_qconfigs() {
602 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${CATEGORY}/${PN} == x11-libs/qt-core ]]; then 687 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${PN} == qt-core ]]; then
603 local x qconfig_add qconfig_remove qconfig_new 688 local x qconfig_add qconfig_remove qconfig_new
604 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do 689 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do
605 [[ -f ${x} ]] || continue 690 [[ -f ${x} ]] || continue
606 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")" 691 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")"
607 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")" 692 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")"
738# @RETURN: the specs-directory w/o path 823# @RETURN: the specs-directory w/o path
739# @DESCRIPTION: 824# @DESCRIPTION:
740# Allows us to define which mkspecs dir we want to use. 825# Allows us to define which mkspecs dir we want to use.
741qt_mkspecs_dir() { 826qt_mkspecs_dir() {
742 local spec= 827 local spec=
828
743 case ${CHOST} in 829 case "${CHOST}" in
744 *-freebsd*|*-dragonfly*) 830 *-freebsd*|*-dragonfly*)
745 spec=freebsd ;; 831 spec=freebsd ;;
746 *-openbsd*) 832 *-openbsd*)
747 spec=openbsd ;; 833 spec=openbsd ;;
748 *-netbsd*) 834 *-netbsd*)
759 *-solaris*) 845 *-solaris*)
760 spec=solaris ;; 846 spec=solaris ;;
761 *-linux-*|*-linux) 847 *-linux-*|*-linux)
762 spec=linux ;; 848 spec=linux ;;
763 *) 849 *)
764 die "Unknown CHOST, no platform chosen" 850 die "${FUNCNAME}(): Unknown CHOST '${CHOST}'" ;;
765 esac 851 esac
766 852
767 CXX=$(tc-getCXX) 853 case "$(tc-getCXX)" in
768 if [[ ${CXX} == *g++* ]]; then 854 *g++*)
769 spec+=-g++ 855 spec+=-g++ ;;
770 elif [[ ${CXX} == *icpc* ]]; then 856 *icpc*)
771 spec+=-icc 857 spec+=-icc ;;
772 else 858 *)
773 die "Unknown compiler '${CXX}'" 859 die "${FUNCNAME}(): Unknown compiler '$(tc-getCXX)'" ;;
774 fi 860 esac
775 if [[ -n ${LIBDIR/lib} ]]; then
776 spec+=-${LIBDIR/lib}
777 fi
778 861
779 # Add -64 for 64bit profiles 862 # Add -64 for 64bit profiles
780 if use x64-freebsd || 863 if use x64-freebsd ||
781 use amd64-linux || 864 use amd64-linux ||
782 use x64-macos || 865 use x64-macos ||
795# Tries to clean up tools.pro for qt-assistant ebuilds. 878# Tries to clean up tools.pro for qt-assistant ebuilds.
796# Meant to be called in src_prepare(). 879# Meant to be called in src_prepare().
797# Since Qt 4.7.4 this function is a no-op. 880# Since Qt 4.7.4 this function is a no-op.
798qt_assistant_cleanup() { 881qt_assistant_cleanup() {
799 # apply patching to qt-assistant ebuilds only 882 # apply patching to qt-assistant ebuilds only
800 [[ ${PN} != "qt-assistant" ]] && return 883 [[ ${PN} != qt-assistant ]] && return
801 884
802 # no longer needed for 4.7.4 and later 885 # no longer needed for 4.7.4 and later
803 version_is_at_least "4.7.4" && return 886 version_is_at_least 4.7.4 && return
804 887
805 # different versions (and branches...) may need different handling, 888 # different versions (and branches...) may need different handling,
806 # add a case if you need special handling 889 # add a case if you need special handling
807 case "${MY_PV_EXTRA}" in 890 case "${MY_PV_EXTRA}" in
808 *kde-qt*) 891 *kde-qt*)

Legend:
Removed from v.1.111  
changed lines
  Added in v.1.132

  ViewVC Help
Powered by ViewVC 1.1.20