/[gentoo-x86]/games-rpg/nwn-cep/nwn-cep-2.0.ebuild
Gentoo

Contents of /games-rpg/nwn-cep/nwn-cep-2.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.9 - (show annotations) (download)
Sat Apr 19 07:32:58 2014 UTC (4 years, 2 months ago) by ulm
Branch: MAIN
CVS Tags: HEAD
Changes since 1.8: +4 -3 lines
Fix LICENSE, add mirror and bindist restrictions, bug 505734.

(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)

1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-cep/nwn-cep-2.0.ebuild,v 1.8 2012/10/07 11:26:09 pacho Exp $
4
5 EAPI=2
6 inherit eutils games unpacker
7
8 DESCRIPTION="High quality custom content addon for Neverwinter Nights"
9 HOMEPAGE="http://nwvault.ign.com/cep/"
10 SRC_URI="http://vnfiles.ign.com/nwvault.ign.com/fms/files/hakpaks/7000/CEPv2_full.rar"
11
12 LICENSE="all-rights-reserved"
13 SLOT="2"
14 KEYWORDS="-* amd64 x86"
15 IUSE=""
16 RESTRICT="mirror bindist"
17
18 DEPEND=""
19 RDEPEND=">=games-rpg/nwn-1.68"
20
21 S=${WORKDIR}
22
23 dir=${GAMES_PREFIX_OPT}/nwn
24
25 pkg_setup() {
26 games_pkg_setup
27 if ! has_version 'games-rpg/nwn-data[hou,sou]' ; then
28 eerror "${P} requires NWN v1.68, Shadows of Undrentide, and Hordes of"
29 eerror "the Underdark. Please make sure you have all three before using"
30 eerror "this patch."
31 die "Requirements not met"
32 fi
33 }
34
35 src_install() {
36 local i
37 for i in hak tlk erf
38 do
39 insinto "${dir}"/${i}
40 doins *.${i} || die "${i} failed"
41 done
42 insinto "${dir}"/modules
43 doins *.mod || die "mod failed"
44 insinto "${dir}"/cep
45 doins *.pdf || die "pdf failed"
46 prepgamesdirs
47 }

  ViewVC Help
Powered by ViewVC 1.1.20