/[gentoo-x86]/gnome-extra/libgda/libgda-5.2.2.ebuild
Gentoo

Contents of /gnome-extra/libgda/libgda-5.2.2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Sun Dec 28 15:50:28 2014 UTC (3 years, 9 months ago) by titanofold
Branch: MAIN
Changes since 1.4: +2 -2 lines
Rename virtual/postgresql to dev-db/postgresql

(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)

1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-5.2.2.ebuild,v 1.4 2014/11/03 12:46:44 titanofold Exp $
4
5 EAPI="5"
6 GNOME2_LA_PUNT="yes"
7 GCONF_DEBUG="yes"
8 PYTHON_COMPAT=( python{2_6,2_7} )
9 #VALA_MIN_API_VERSION="0.18"
10 #VALA_MAX_API_VERSION="0.18" # configure explicitly checks for 0.18
11 #VALA_USE_DEPEND="vapigen"
12
13 inherit autotools db-use eutils flag-o-matic gnome2 java-pkg-opt-2 python-single-r1 # vala
14
15 DESCRIPTION="GNOME database access library"
16 HOMEPAGE="http://www.gnome-db.org/"
17 LICENSE="GPL-2+ LGPL-2+"
18
19 IUSE="berkdb bindist canvas firebird gtk graphviz http +introspection json ldap libsecret mdb mysql oci8 postgres reports sourceview ssl" # vala
20 REQUIRED_USE="
21 reports? ( ${PYTHON_REQUIRED_USE} )
22 canvas? ( gtk )
23 firebird? ( !bindist )
24 graphviz? ( gtk )
25 sourceview? ( gtk )
26 "
27 # firebird license is not GPL compatible
28
29 SLOT="5/4" # subslot = libgda-5.0 soname version
30 KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
31
32 RDEPEND="
33 app-text/iso-codes
34 >=dev-libs/glib-2.32:2
35 >=dev-libs/libxml2-2
36 dev-libs/libxslt
37 sys-libs/readline:=
38 sys-libs/ncurses:=
39 berkdb? ( sys-libs/db )
40 !bindist? ( firebird? ( dev-db/firebird ) )
41 gtk? (
42 >=x11-libs/gtk+-3.0.0:3
43 canvas? ( x11-libs/goocanvas:2.0= )
44 sourceview? ( x11-libs/gtksourceview:3.0 )
45 graphviz? ( media-gfx/graphviz )
46 )
47 http? ( >=net-libs/libsoup-2.24:2.4 )
48 introspection? ( >=dev-libs/gobject-introspection-1.30 )
49 json? ( dev-libs/json-glib )
50 ldap? ( net-nds/openldap:= )
51 libsecret? ( app-crypt/libsecret )
52 mdb? ( >app-office/mdbtools-0.5:= )
53 mysql? ( virtual/mysql:= )
54 postgres? ( dev-db/postgresql:= )
55 reports? (
56 ${PYTHON_DEPS}
57 dev-java/fop
58 dev-python/reportlab )
59 ssl? ( dev-libs/openssl:= )
60 >=dev-db/sqlite-3.6.22:3=
61 "
62 # vala? ( dev-libs/libgee:0.8 )
63 DEPEND="${RDEPEND}
64 >=app-text/gnome-doc-utils-0.9
65 dev-util/gtk-doc-am
66 >=dev-util/intltool-0.40.6
67 virtual/pkgconfig
68 java? ( virtual/jdk:1.6 )"
69 # vala? ( $(vala_depend) )
70
71 # FIXME: lots of tests failing. Check if they still fail in 5.1.2
72 RESTRICT="test"
73
74 pkg_setup() {
75 java-pkg-opt-2_pkg_setup
76 use reports && python-single-r1_pkg_setup
77 }
78
79 src_prepare() {
80 use berkdb && append-cppflags "-I$(db_includedir)"
81
82 use reports ||
83 sed -e '/SUBDIRS =/ s/trml2html//' \
84 -e '/SUBDIRS =/ s/trml2pdf//' \
85 -i libgda-report/RML/Makefile.{am,in} || die
86
87 # Prevent file collisions with libgda:4
88 epatch "${FILESDIR}/${PN}-4.99.1-gda-browser-doc-collision.patch"
89 epatch "${FILESDIR}/${PN}-4.99.1-control-center-icon-collision.patch"
90 # Move files with mv (since epatch can't handle rename diffs) and
91 # update pre-generated gtk-doc files (for non-git versions of libgda)
92 local f
93 for f in tools/browser/doc/gda-browser* ; do
94 mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
95 done
96 for f in tools/browser/doc/html/gda-browser.devhelp* ; do
97 sed -e 's:name="gda-browser":name="gda-browser-5.0":' \
98 -i ${f} || die "sed ${f} failed"
99 mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
100 done
101 for f in control-center/data/*_gda-control-center.png ; do
102 mv ${f} ${f/_gda-control-center.png/_gda-control-center-5.0.png} ||
103 die "mv ${f} failed"
104 done
105
106 eautoreconf
107 gnome2_src_prepare
108 java-pkg-opt-2_src_prepare
109 # use vala && vala_src_prepare
110 }
111
112 src_configure() {
113 gnome2_src_configure \
114 --with-help \
115 --disable-static \
116 --enable-system-sqlite \
117 $(use_with berkdb bdb /usr) \
118 $(use_with canvas goocanvas) \
119 $(use_with firebird firebird /usr) \
120 $(use_with graphviz) \
121 $(use_with gtk ui) \
122 $(use_with http libsoup) \
123 $(use_enable introspection) \
124 "$(use_with java java $JAVA_HOME)" \
125 $(use_enable json) \
126 $(use_with ldap) \
127 $(use_with libsecret) \
128 $(use_with mdb mdb /usr) \
129 $(use_with mysql mysql /usr) \
130 $(use_with oci8 oracle) \
131 $(use_with postgres postgres /usr) \
132 $(use_enable ssl crypto) \
133 $(use_with sourceview gtksourceview) \
134 --disable-default-binary \
135 --disable-vala
136 # vala bindings fail to build
137 }
138
139 pkg_preinst() {
140 gnome2_pkg_preinst
141 java-pkg-opt-2_pkg_preinst
142 }
143
144 src_install() {
145 gnome2_src_install
146 if use reports; then
147 for t in trml2{html,pdf}; do
148 python_scriptinto /usr/share/libgda-5.0/gda_${t}
149 python_doscript libgda-report/RML/${t}/${t}.py
150 done
151 fi
152 }

  ViewVC Help
Powered by ViewVC 1.1.20