/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Contents of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.102 - (hide annotations) (download)
Sun Jan 2 14:40:08 2011 UTC (6 years, 10 months ago) by aballier
Branch: MAIN
Changes since 1.101: +4 -3 lines
bump alsa requirements, bug #344999 by Yang Dehua <yangdh@cableplus.com.cn>

(Portage version: 2.2.0_alpha11/cvs/Linux x86_64)

1 aballier 1.102 # Copyright 1999-2011 Gentoo Foundation
2 aballier 1.1 # Distributed under the terms of the GNU General Public License v2
3 aballier 1.102 # $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.101 2010/12/26 13:57:23 aballier Exp $
4 aballier 1.1
5 zmedico 1.80 EAPI="3"
6 aballier 1.1
7     SCM=""
8     if [ "${PV%9999}" != "${PV}" ] ; then
9     SCM=git
10     EGIT_BOOTSTRAP="bootstrap"
11 aballier 1.52 EGIT_BRANCH=master
12     EGIT_PROJECT=${P}
13 aballier 1.1 if [ "${PV%.9999}" != "${PV}" ] ; then
14 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc/vlc-${PV%.9999}.git"
15 aballier 1.1 else
16 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
17 aballier 1.1 fi
18     fi
19    
20 aballier 1.100 inherit eutils multilib autotools toolchain-funcs gnome2 qt4-r2 flag-o-matic ${SCM}
21 aballier 1.1
22     MY_PV="${PV/_/-}"
23     MY_PV="${MY_PV/-beta/-test}"
24     MY_P="${PN}-${MY_PV}"
25    
26 aballier 1.94 PATCHLEVEL="89"
27 aballier 1.1 DESCRIPTION="VLC media player - Video player and streamer"
28     HOMEPAGE="http://www.videolan.org/vlc/"
29     if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
30     SRC_URI=""
31     elif [[ "${MY_P}" == "${P}" ]]; then
32     SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
33     else
34     SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.bz2"
35     fi
36    
37     SRC_URI="${SRC_URI}
38 aballier 1.47 mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
39 aballier 1.1
40     LICENSE="GPL-2"
41     SLOT="0"
42    
43 aballier 1.89 if [ "${PV%9999}" = "${PV}" ] ; then
44     KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
45     else
46     KEYWORDS=""
47     fi
48 aballier 1.59 IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddb dbus dc1394
49 aballier 1.36 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
50 aballier 1.99 +gcrypt gme gnome gnutls httpd ieee1394 jack kate kde libass libcaca
51 aballier 1.90 libnotify libproxy libtiger libv4l2 lirc live lua matroska mmx
52 aballier 1.96 modplug mp3 mpeg mtp musepack ncurses ogg opengl optimisememory oss
53 aballier 1.38 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
54 aballier 1.101 schroedinger sdl sdl-image shine shout sid skins speex sqlite sse stream
55 aballier 1.90 svg taglib theora truetype twolame udev upnp v4l2 vaapi vcdx vlm
56 aballier 1.74 vorbis win32codecs wma-fixed +X x264 +xcb xml xosd xv zvbi"
57 aballier 1.1
58     RDEPEND="
59     sys-libs/zlib
60 aballier 1.20 >=media-libs/libdvbpsi-0.1.6
61 aballier 1.1 a52? ( >=media-libs/a52dec-0.7.4-r3 )
62     aalib? ( media-libs/aalib )
63     aac? ( >=media-libs/faad2-2.6.1 )
64 aballier 1.102 alsa? ( >=media-libs/alsa-lib-1.0.23 )
65 aballier 1.69 avahi? ( >=net-dns/avahi-0.6[dbus] )
66 aballier 1.1 bidi? ( >=dev-libs/fribidi-0.10.4 )
67     cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
68     dbus? ( >=sys-apps/dbus-1.0.2 )
69 aballier 1.79 dc1394? ( >=sys-libs/libraw1394-2.0.1 >=media-libs/libdc1394-2.0.2 )
70 aballier 1.1 dirac? ( >=media-video/dirac-0.10.0 )
71 aballier 1.37 directfb? ( dev-libs/DirectFB sys-libs/zlib )
72 aballier 1.1 dts? ( media-libs/libdca )
73 aballier 1.70 dvd? ( media-libs/libdvdread >=media-libs/libdvdnav-0.1.9 )
74 aballier 1.36 elibc_glibc? ( >=sys-libs/glibc-2.8 )
75 aballier 1.87 ffmpeg? ( >=media-video/ffmpeg-0.6 )
76 aballier 1.79 flac? ( media-libs/libogg >=media-libs/flac-1.1.2 )
77 aballier 1.1 fluidsynth? ( media-sound/fluidsynth )
78     fontconfig? ( media-libs/fontconfig )
79 pva 1.16 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
80 aballier 1.99 gme? ( media-libs/game-music-emu )
81 aballier 1.1 gnome? ( gnome-base/gnome-vfs )
82 aballier 1.77 gnutls? ( >=net-libs/gnutls-1.7.4 >=dev-libs/libgcrypt-1.2.0 )
83 aballier 1.18 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
84 aballier 1.1 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
85     kate? ( >=media-libs/libkate-0.1.1 )
86 aballier 1.31 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
87 aballier 1.54 libcaca? ( >=media-libs/libcaca-0.99_beta14 )
88 aballier 1.1 libnotify? ( x11-libs/libnotify )
89 aballier 1.13 libproxy? ( net-libs/libproxy )
90 aballier 1.17 libtiger? ( media-libs/libtiger )
91 aballier 1.1 lirc? ( app-misc/lirc )
92 aballier 1.95 live? ( >=media-plugins/live-2010.10.15 )
93 aballier 1.1 lua? ( >=dev-lang/lua-5.1 )
94 aballier 1.93 matroska? ( >=dev-libs/libebml-1.0.0 >=media-libs/libmatroska-1.0.0 )
95 aballier 1.81 modplug? ( >=media-libs/libmodplug-0.8.8.1 )
96 aballier 1.1 mp3? ( media-libs/libmad )
97     mpeg? ( >=media-libs/libmpeg2-0.3.2 )
98 aballier 1.73 mtp? ( >=media-libs/libmtp-1.0.0 )
99 ssuominen 1.44 musepack? ( >=media-sound/musepack-tools-444 )
100 aballier 1.1 ncurses? ( sys-libs/ncurses )
101     ogg? ( media-libs/libogg )
102 scarabeus 1.92 opengl? ( virtual/opengl || ( <x11-libs/libX11-1.3.99.901[xcb] >=x11-libs/libX11-1.3.99.901 ) )
103 aballier 1.37 png? ( media-libs/libpng sys-libs/zlib )
104 aballier 1.21 projectm? ( media-libs/libprojectm )
105 aballier 1.99 pulseaudio? ( >=media-sound/pulseaudio-0.9.22 )
106 aballier 1.35 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
107 aballier 1.1 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
108 aballier 1.79 samba? ( || ( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-3.4 ) )
109 aballier 1.12 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
110 aballier 1.1 sdl? ( >=media-libs/libsdl-1.2.8
111 aballier 1.37 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
112 aballier 1.1 shout? ( media-libs/libshout )
113 aballier 1.101 sid? ( media-libs/libsidplay:2 )
114 aballier 1.69 skins? (
115     x11-libs/qt-gui:4 x11-libs/qt-core:4
116     x11-libs/libXext x11-libs/libX11
117     media-libs/freetype media-fonts/dejavu
118     )
119 aballier 1.1 speex? ( media-libs/speex )
120 aballier 1.54 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
121 aballier 1.1 svg? ( >=gnome-base/librsvg-2.9.0 )
122 aballier 1.37 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
123 aballier 1.6 theora? ( >=media-libs/libtheora-1.0_beta3 )
124 aballier 1.79 truetype? ( media-libs/freetype media-fonts/dejavu )
125 aballier 1.1 twolame? ( media-sound/twolame )
126 aballier 1.45 udev? ( >=sys-fs/udev-142 )
127 aballier 1.1 upnp? ( net-libs/libupnp )
128     v4l2? ( libv4l2? ( media-libs/libv4l ) )
129 aballier 1.87 vaapi? ( x11-libs/libva >=media-video/ffmpeg-0.6 )
130 aballier 1.59 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 )
131 aballier 1.1 vorbis? ( media-libs/libvorbis )
132     win32codecs? ( media-libs/win32codecs )
133 aballier 1.74 X? ( x11-libs/libX11 )
134 aballier 1.40 x264? ( >=media-libs/x264-0.0.20090923 )
135 aballier 1.2 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
136 aballier 1.1 xml? ( dev-libs/libxml2 )
137     xosd? ( x11-libs/xosd )
138     zvbi? ( >=media-libs/zvbi-0.2.25 )
139     "
140    
141     DEPEND="${RDEPEND}
142 aballier 1.84 !!<=media-video/vlc-1.1.99999
143 aballier 1.102 alsa? ( >=media-sound/alsa-headers-1.0.23 )
144 aballier 1.1 dvb? ( sys-kernel/linux-headers )
145 aballier 1.68 kde? ( >=kde-base/kdelibs-4 )
146 aballier 1.28 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
147 aballier 1.2 xcb? ( x11-proto/xproto )
148 aballier 1.1 dev-util/pkgconfig"
149    
150     S="${WORKDIR}/${MY_P}"
151    
152 aballier 1.5 # Displays a warning if the first use flag is set but the second is not
153 aballier 1.1 vlc_use_needs() {
154     use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
155     }
156    
157     # Notify the user that some useflag have been forced on
158     vlc_use_force() {
159     use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
160     }
161    
162 aballier 1.69 # Use when $1 depends strictly on $2
163     # if use $1 then enable $2
164 aballier 1.1 vlc_use_enable_force() {
165 aballier 1.69 use $1 && echo "--enable-$2"
166 aballier 1.1 }
167    
168     pkg_setup() {
169 aballier 1.69 # Useflags we need to forcefuly enable
170     vlc_use_force remoteosd gcrypt
171 aballier 1.77 vlc_use_force gnutls gcrypt
172 aballier 1.69 vlc_use_force skins truetype
173 aballier 1.1 vlc_use_force skins qt4
174 aballier 1.69 vlc_use_force vlm stream
175 aballier 1.71 vlc_use_force vaapi ffmpeg
176 aballier 1.69
177     # Useflags that will be automagically discarded if deps are not met
178 aballier 1.1 vlc_use_needs bidi truetype
179 aballier 1.69 vlc_use_needs cddb cdda
180 aballier 1.1 vlc_use_needs fontconfig truetype
181     vlc_use_needs libv4l2 v4l2
182 aballier 1.17 vlc_use_needs libtiger kate
183 aballier 1.39 vlc_use_needs xv xcb
184 aballier 1.69
185 aballier 1.100 if use !qt4 && use !skins ; then
186 aballier 1.1 ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
187     ewarn "graphical interface. Maybe that is not what you want..."
188     fi
189     }
190    
191     src_unpack() {
192     unpack ${A}
193     if [ "${PV%9999}" != "${PV}" ] ; then
194     git_src_unpack
195     fi
196 aballier 1.22 }
197 aballier 1.1
198 aballier 1.22 src_prepare() {
199     if [ "${PV%9999}" != "${PV}" ] ; then
200     git_src_prepare
201     fi
202 aballier 1.1 # Make it build with libtool 1.5
203     rm -f m4/lt* m4/libtool.m4
204    
205     EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
206 aballier 1.47 eautoreconf
207 aballier 1.1 }
208    
209 aballier 1.22 src_configure() {
210 aballier 1.1
211     # It would fail if -fforce-addr is used due to too few registers...
212     use x86 && filter-flags -fforce-addr
213    
214 aballier 1.101 # needs libresid-builder from libsidplay:2 which is in another directory...
215     # FIXME!
216     use sid && append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
217    
218 aballier 1.1 econf \
219 aballier 1.97 --docdir=/usr/share/doc/${PF} \
220 aballier 1.1 $(use_enable a52) \
221     $(use_enable aalib aa) \
222     $(use_enable aac faad) \
223     $(use_enable alsa) \
224     $(use_enable altivec) \
225     $(use_enable atmo) \
226     $(use_enable avahi bonjour) \
227     $(use_enable bidi fribidi) \
228     $(use_enable cdda vcd) \
229     $(use_enable cddb libcddb) \
230     $(use_enable dbus) $(use_enable dbus dbus-control) \
231     $(use_enable dirac) \
232     $(use_enable directfb) \
233     $(use_enable dc1394) \
234     $(use_enable debug) \
235     $(use_enable dts dca) \
236     $(use_enable dvb) \
237     $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
238     $(use_enable fbcon fb) \
239 aballier 1.10 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
240 aballier 1.1 $(use_enable flac) \
241     $(use_enable fluidsynth) \
242     $(use_enable fontconfig) \
243 aballier 1.99 $(use_enable gme) \
244 aballier 1.1 $(use_enable gnome gnomevfs) \
245     $(use_enable gnutls) \
246     $(use_enable httpd) \
247 aballier 1.18 $(use_enable ieee1394 dv) \
248 aballier 1.1 $(use_enable jack) \
249     $(use_enable kate) \
250 aballier 1.68 $(use_with kde kde-solid) \
251 aballier 1.1 $(use_enable libass) \
252     $(use_enable libcaca caca) \
253 pva 1.14 $(use_enable gcrypt libgcrypt) \
254 aballier 1.1 $(use_enable libnotify notify) \
255 aballier 1.13 $(use_enable libproxy) \
256 aballier 1.1 --disable-libtar \
257 aballier 1.17 $(use_enable libtiger tiger) \
258 aballier 1.1 $(use_enable libv4l2) \
259     $(use_enable lirc) \
260     $(use_enable live live555) \
261     $(use_enable lua) \
262     $(use_enable matroska mkv) \
263     $(use_enable mmx) \
264     $(use_enable modplug mod) \
265     $(use_enable mp3 mad) \
266     $(use_enable mpeg libmpeg2) \
267     $(use_enable mtp) \
268     $(use_enable musepack mpc) \
269     $(use_enable ncurses) \
270     $(use_enable ogg) \
271 aballier 1.83 $(use_enable opengl glx) \
272 aballier 1.1 $(use_enable optimisememory optimize-memory) \
273     $(use_enable oss) \
274     $(use_enable png) \
275     --disable-portaudio \
276 aballier 1.21 $(use_enable projectm) \
277 aballier 1.1 $(use_enable pulseaudio pulse) \
278     $(use_enable pvr) \
279     $(use_enable qt4) \
280 aballier 1.69 $(use_enable remoteosd) \
281 aballier 1.1 $(use_enable rtsp realrtsp) \
282     $(use_enable run-as-root) \
283     $(use_enable samba smb) \
284     $(use_enable schroedinger) \
285     $(use_enable sdl) \
286     $(use_enable sdl-image) \
287     $(use_enable shine) \
288 aballier 1.101 $(use_enable sid) \
289 aballier 1.1 $(use_enable shout) \
290     $(use_enable skins skins2) \
291     $(use_enable speex) \
292 aballier 1.50 $(use_enable sqlite) \
293 aballier 1.1 $(use_enable sse) \
294     $(use_enable stream sout) \
295     $(use_enable svg) \
296     $(use_enable taglib) \
297     $(use_enable theora) \
298     $(use_enable truetype freetype) \
299     $(use_enable twolame) \
300 aballier 1.43 $(use_enable udev) \
301 aballier 1.1 $(use_enable upnp) \
302     $(use_enable v4l2) \
303     $(use_enable vcdx) \
304 aballier 1.71 $(use_enable vaapi libva) \
305 aballier 1.69 $(use_enable vlm) \
306 aballier 1.1 $(use_enable vorbis) \
307     $(use_enable win32codecs loader) \
308     $(use_enable wma-fixed) \
309 aballier 1.74 $(use_with X x) \
310 aballier 1.1 $(use_enable x264) \
311 aballier 1.2 $(use_enable xcb) \
312 aballier 1.1 $(use_enable xml libxml2) \
313     $(use_enable xosd) \
314     $(use_enable xv xvideo) \
315 aballier 1.26 $(use_enable zvbi) $(use_enable !zvbi telx) \
316 aballier 1.1 --disable-snapshot \
317     --disable-growl \
318     --disable-optimizations \
319     --enable-fast-install \
320 aballier 1.69 $(vlc_use_enable_force vlm sout) \
321     $(vlc_use_enable_force skins qt4) \
322     $(vlc_use_enable_force skins freetype) \
323 aballier 1.71 $(vlc_use_enable_force remoteosd libgcrypt) \
324 aballier 1.77 $(vlc_use_enable_force gnutls libgcrypt) \
325 aballier 1.96 $(vlc_use_enable_force vaapi avcodec)
326 aballier 1.1 }
327    
328     src_install() {
329     emake DESTDIR="${D}" install || die "make install failed"
330    
331 aballier 1.48 dodoc AUTHORS HACKING THANKS NEWS README \
332 aballier 1.66 doc/fortunes.txt doc/intf-vcd.txt
333 aballier 1.1
334 aballier 1.86 # Punt useless libtool's .la files
335     find "${D}" -name '*.la' -delete
336 aballier 1.1 }
337 aballier 1.61
338     pkg_postinst() {
339     gnome2_pkg_postinst
340    
341     if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
342 aballier 1.67 einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
343 aballier 1.75 "/usr/$(get_libdir)/vlc/vlc-cache-gen" -f "/usr/$(get_libdir)/vlc/plugins/"
344 aballier 1.61 else
345     ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
346     ewarn "Please run /usr/$(get_libdir)/vlc/vlc-cache-gen manually"
347     ewarn "If you do not do it, vlc will take a long time to load."
348     fi
349     }

  ViewVC Help
Powered by ViewVC 1.1.20