/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Contents of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.37 - (hide annotations) (download)
Fri Aug 21 10:29:01 2009 UTC (7 years, 11 months ago) by aballier
Branch: MAIN
Changes since 1.36: +6 -7 lines
Add zlib deps for modules that require it, not really needed because we undconditionnally depend on it but its cleaner
(Portage version: 2.2_rc38/cvs/Linux x86_64)

1 aballier 1.1 # Copyright 1999-2009 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 aballier 1.37 # $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.36 2009/08/21 10:11:40 aballier Exp $
4 aballier 1.1
5 aballier 1.22 EAPI="2"
6 aballier 1.1
7     SCM=""
8     if [ "${PV%9999}" != "${PV}" ] ; then
9     SCM=git
10     EGIT_REPO_URI="git://git.videolan.org/vlc.git"
11     EGIT_BOOTSTRAP="bootstrap"
12     if [ "${PV%.9999}" != "${PV}" ] ; then
13     EGIT_BRANCH=${PV%.9999}-bugfix
14     else
15     EGIT_BRANCH=master
16     fi
17     fi
18    
19     inherit eutils multilib autotools toolchain-funcs gnome2 nsplugins qt4 flag-o-matic ${SCM}
20    
21     MY_PV="${PV/_/-}"
22     MY_PV="${MY_PV/-beta/-test}"
23     MY_P="${PN}-${MY_PV}"
24     VLC_SNAPSHOT_TIME="0013"
25    
26 aballier 1.25 PATCHLEVEL="68"
27 aballier 1.1 M4_TARBALL_VERSION="1"
28     DESCRIPTION="VLC media player - Video player and streamer"
29     HOMEPAGE="http://www.videolan.org/vlc/"
30     if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31     SRC_URI=""
32     elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org
33     SRC_URI="http://nightlies.videolan.org/build/source/trunk-${PV/*_alpha/}-${VLC_SNAPSHOT_TIME}/${PN}-snapshot-${PV/*_alpha/}.tar.bz2"
34     MY_P="${P/_alpha*/}-git"
35     elif [[ "${MY_P}" == "${P}" ]]; then
36     SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
37     else
38     SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.bz2"
39     fi
40    
41     SRC_URI="${SRC_URI}
42     mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2
43     mirror://gentoo/${PN}-m4-${M4_TARBALL_VERSION}.tar.bz2"
44    
45     LICENSE="GPL-2"
46     SLOT="0"
47    
48     KEYWORDS=""
49     IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394
50 aballier 1.36 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
51 aballier 1.18 +gcrypt ggi gnome gnutls hal httpd id3tag ieee1394 jack kate libass libcaca
52     libnotify libproxy libsysfs libtiger libv4l2 lirc live lua matroska mmx
53     modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
54 aballier 1.21 pda png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
55     schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream
56     svg svga taglib theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm
57 aballier 1.32 vorbis win32codecs wma-fixed X x264 xcb xml xosd xv zvbi"
58 aballier 1.1
59     RDEPEND="
60 aballier 1.24 !!<=media-video/vlc-1.0.99999
61 aballier 1.1 sys-libs/zlib
62 aballier 1.20 >=media-libs/libdvbpsi-0.1.6
63 aballier 1.1 a52? ( >=media-libs/a52dec-0.7.4-r3 )
64     aalib? ( media-libs/aalib )
65     aac? ( >=media-libs/faad2-2.6.1 )
66     alsa? ( media-libs/alsa-lib )
67     avahi? ( >=net-dns/avahi-0.6 )
68     bidi? ( >=dev-libs/fribidi-0.10.4 )
69     cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
70     cddax? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
71     cdio? ( >=dev-libs/libcdio-0.78.2 )
72     dbus? ( >=sys-apps/dbus-1.0.2 )
73 aballier 1.18 dc1394? ( >=sys-libs/libraw1394-2.0.1
74     >=media-libs/libdc1394-2.0.2 )
75 aballier 1.1 dirac? ( >=media-video/dirac-0.10.0 )
76 aballier 1.37 directfb? ( dev-libs/DirectFB sys-libs/zlib )
77 aballier 1.1 dts? ( media-libs/libdca )
78     dvd? ( media-libs/libdvdread
79     media-libs/libdvdcss
80     >=media-libs/libdvdnav-0.1.9
81     media-libs/libdvdplay )
82 aballier 1.36 elibc_glibc? ( >=sys-libs/glibc-2.8 )
83 aballier 1.1 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
84     flac? ( media-libs/libogg
85     >=media-libs/flac-1.1.2 )
86     fluidsynth? ( media-sound/fluidsynth )
87     fontconfig? ( media-libs/fontconfig )
88 pva 1.16 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
89 aballier 1.1 ggi? ( media-libs/libggi )
90     gnome? ( gnome-base/gnome-vfs )
91 aballier 1.8 gnutls? ( >=net-libs/gnutls-1.7.4 )
92 aballier 1.1 hal? ( sys-apps/hal )
93 aballier 1.37 id3tag? ( media-libs/libid3tag sys-libs/zlib )
94 aballier 1.18 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
95 aballier 1.1 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
96     kate? ( >=media-libs/libkate-0.1.1 )
97 aballier 1.31 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
98 aballier 1.1 libcaca? ( media-libs/libcaca )
99     libnotify? ( x11-libs/libnotify )
100 aballier 1.13 libproxy? ( net-libs/libproxy )
101 aballier 1.1 libsysfs? ( sys-fs/sysfsutils )
102 aballier 1.17 libtiger? ( media-libs/libtiger )
103 aballier 1.1 lirc? ( app-misc/lirc )
104     live? ( >=media-plugins/live-2008.07.06 )
105     lua? ( >=dev-lang/lua-5.1 )
106     matroska? (
107     >=dev-libs/libebml-0.7.6
108     >=media-libs/libmatroska-0.8.0 )
109     modplug? ( media-libs/libmodplug )
110     mp3? ( media-libs/libmad )
111     mpeg? ( >=media-libs/libmpeg2-0.3.2 )
112     mtp? ( >=media-libs/libmtp-0.3.0 )
113 ssuominen 1.27 musepack? ( || ( >=media-sound/musepack-tools-444
114     media-libs/libmpcdec ) )
115 aballier 1.1 ncurses? ( sys-libs/ncurses )
116     nsplugin? (
117     seamonkey? ( =www-client/seamonkey-1* )
118     !seamonkey? ( >=net-libs/xulrunner-1.8 )
119     )
120     ogg? ( media-libs/libogg )
121     pda? ( x11-libs/gtk+:2 )
122 aballier 1.37 png? ( media-libs/libpng sys-libs/zlib )
123 aballier 1.21 projectm? ( media-libs/libprojectm )
124 aballier 1.9 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
125 aballier 1.35 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
126 aballier 1.1 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
127     samba? ( net-fs/samba )
128 aballier 1.12 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
129 aballier 1.1 sdl? ( >=media-libs/libsdl-1.2.8
130 aballier 1.37 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
131 aballier 1.1 shout? ( media-libs/libshout )
132 aballier 1.35 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 )
133 aballier 1.1 speex? ( media-libs/speex )
134     svg? ( >=gnome-base/librsvg-2.9.0 )
135     svga? ( media-libs/svgalib )
136 aballier 1.37 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
137 aballier 1.6 theora? ( >=media-libs/libtheora-1.0_beta3 )
138 aballier 1.1 truetype? ( media-libs/freetype
139 aballier 1.25 media-fonts/dejavu )
140 aballier 1.1 twolame? ( media-sound/twolame )
141     upnp? ( net-libs/libupnp )
142     v4l2? ( libv4l2? ( media-libs/libv4l ) )
143     vcdinfo? ( >=media-video/vcdimager-0.7.22 )
144     vorbis? ( media-libs/libvorbis )
145     win32codecs? ( media-libs/win32codecs )
146     X? (
147     x11-libs/libX11
148 aballier 1.34 opengl? ( virtual/opengl x11-libs/libXext )
149 aballier 1.1 )
150     x264? ( media-libs/x264 )
151 aballier 1.2 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
152 aballier 1.1 xml? ( dev-libs/libxml2 )
153     xosd? ( x11-libs/xosd )
154     zvbi? ( >=media-libs/zvbi-0.2.25 )
155     "
156    
157     # Disabled features and reasons:
158     # xvmc? ( x11-libs/libXvMC )
159     # Will probably compile only on x86
160    
161     DEPEND="${RDEPEND}
162     dvb? ( sys-kernel/linux-headers )
163     v4l? ( sys-kernel/linux-headers )
164 aballier 1.28 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
165 aballier 1.2 xcb? ( x11-proto/xproto )
166 aballier 1.1 dev-util/pkgconfig"
167    
168     S="${WORKDIR}/${MY_P}"
169    
170 aballier 1.5 # Displays a warning if the first use flag is set but the second is not
171 aballier 1.1 vlc_use_needs() {
172     use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
173     }
174    
175     # Notify the user that some useflag have been forced on
176     vlc_use_force() {
177     use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
178     }
179    
180     # Use when $2 depends strictly on $3
181     # if use $1 then enable $2 and $3, otherwise disable $2
182     vlc_use_enable_force() {
183     if use $1 ; then
184     echo "--enable-$2 --enable-$3"
185     else
186     echo "--disable-$2"
187     fi
188     }
189    
190     pkg_setup() {
191 aballier 1.23 if has_version '<=media-video/vlc-1.0.99999'; then
192     eerror "Please unmerge vlc-1.0.x first before installing ${P}"
193 aballier 1.11 eerror "If you don't do that, some plugins will get linked against"
194     eerror "the old ${PN} version and will not work."
195 aballier 1.23 die "Unmerge vlc 1.0.x first"
196 aballier 1.11 fi
197 aballier 1.1 vlc_use_needs skins truetype
198     vlc_use_force skins qt4
199     vlc_use_needs cddax cdio
200     vlc_use_needs vcdx cdio
201     vlc_use_needs vcdx vcdinfo
202     vlc_use_needs vcdinfo cdio
203     vlc_use_needs bidi truetype
204 pva 1.14 vlc_use_force remoteosd gcrypt
205 aballier 1.1 vlc_use_needs fontconfig truetype
206     vlc_use_needs libv4l2 v4l2
207 aballier 1.17 vlc_use_needs libtiger kate
208 aballier 1.1 use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
209 aballier 1.5 if use qt4 || use skins ; then
210     qt4_pkg_setup
211 aballier 1.1 else
212     ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
213     ewarn "graphical interface. Maybe that is not what you want..."
214     fi
215     }
216    
217     src_unpack() {
218     unpack ${A}
219     if [ "${PV%9999}" != "${PV}" ] ; then
220     git_src_unpack
221     fi
222 aballier 1.22 }
223 aballier 1.1
224 aballier 1.22 src_prepare() {
225     if [ "${PV%9999}" != "${PV}" ] ; then
226     git_src_prepare
227     fi
228 aballier 1.1 # Make it build with libtool 1.5
229     rm -f m4/lt* m4/libtool.m4
230    
231     EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
232     AT_M4DIR="m4 ${WORKDIR}/${PN}-m4" eautoreconf
233     }
234    
235 aballier 1.22 src_configure() {
236 aballier 1.1
237     # It would fail if -fforce-addr is used due to too few registers...
238     use x86 && filter-flags -fforce-addr
239    
240     local MOZILLA_PC
241    
242     if use nsplugin; then
243     if use seamonkey; then
244     MOZILLA_PC=seamonkey-plugin
245     else
246     if has_version 'net-libs/xulrunner:1.9' ; then
247     MOZILLA_PC=libxul
248     else
249     MOZILLA_PC=xulrunner-plugin
250     fi
251     fi
252     fi
253    
254     econf \
255     $(use_enable a52) \
256     $(use_enable aalib aa) \
257     $(use_enable aac faad) \
258     $(use_enable alsa) \
259     $(use_enable altivec) \
260     --disable-asademux \
261     $(use_enable atmo) \
262     $(use_enable avahi bonjour) \
263     $(use_enable bidi fribidi) \
264     $(use_enable cdda vcd) \
265     $(use_enable cddax)\
266     $(use_enable cddb libcddb) \
267     $(use_enable cdio libcdio) \
268     $(use_enable dbus) $(use_enable dbus dbus-control) \
269     $(use_enable dirac) \
270     $(use_enable directfb) \
271     $(use_enable dc1394) \
272     $(use_enable debug) \
273     $(use_enable dts dca) \
274     $(use_enable dvb) \
275     $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
276     $(use_enable fbcon fb) \
277 aballier 1.10 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
278 aballier 1.1 $(use_enable flac) \
279     $(use_enable fluidsynth) \
280     $(use_enable fontconfig) \
281     $(use_enable ggi) \
282     $(use_enable gnome gnomevfs) \
283     $(use_enable gnutls) \
284     $(use_enable hal) \
285     $(use_enable httpd) \
286     $(use_enable id3tag) \
287 aballier 1.18 $(use_enable ieee1394 dv) \
288 aballier 1.1 $(use_enable jack) \
289     $(use_enable kate) \
290     $(use_enable libass) \
291     $(use_enable libcaca caca) \
292 pva 1.14 $(use_enable gcrypt libgcrypt) \
293 aballier 1.1 $(use_enable libnotify notify) \
294 aballier 1.13 $(use_enable libproxy) \
295 aballier 1.1 --disable-libtar \
296 aballier 1.17 $(use_enable libtiger tiger) \
297 aballier 1.1 $(use_enable libsysfs) \
298     $(use_enable libv4l2) \
299     $(use_enable lirc) \
300     $(use_enable live live555) \
301     $(use_enable lua) \
302     $(use_enable matroska mkv) \
303     $(use_enable mmx) \
304     $(use_enable modplug mod) \
305     $(use_enable mp3 mad) \
306     $(use_enable mpeg libmpeg2) \
307     $(use_enable mtp) \
308     $(use_enable musepack mpc) \
309     $(use_enable ncurses) \
310     $(use_enable nsplugin mozilla) --with-mozilla-pkg="${MOZILLA_PC}" \
311     $(use_enable ogg) \
312 aballier 1.30 $(use_enable opengl glx) $(use_enable opengl) \
313 aballier 1.1 $(use_enable optimisememory optimize-memory) \
314     $(use_enable oss) \
315     $(use_enable pda) \
316     $(use_enable png) \
317     --disable-portaudio \
318 aballier 1.21 $(use_enable projectm) \
319 aballier 1.1 $(use_enable pulseaudio pulse) \
320     $(use_enable pvr) \
321     $(use_enable qt4) \
322     $(use_enable rtsp realrtsp) \
323     $(use_enable run-as-root) \
324     $(use_enable samba smb) \
325     $(use_enable schroedinger) \
326     $(use_enable sdl) \
327     $(use_enable sdl-image) \
328     $(use_enable shine) \
329     $(use_enable shout) \
330     $(use_enable skins skins2) \
331     $(use_enable speex) \
332     $(use_enable sse) \
333     $(use_enable stream sout) \
334     $(use_enable svg) \
335     $(use_enable svga svgalib) \
336     $(use_enable taglib) \
337     $(use_enable theora) \
338     $(use_enable truetype freetype) \
339     $(use_enable twolame) \
340     $(use_enable upnp) \
341     $(use_enable v4l) \
342     $(use_enable v4l2) \
343     $(use_enable vcdinfo) \
344     $(use_enable vcdx) \
345     $(use_enable vorbis) \
346     $(use_enable win32codecs loader) \
347     $(use_enable wma-fixed) \
348     $(use_enable X x11) $(use_enable X screen) \
349     $(use_enable x264) \
350 aballier 1.2 $(use_enable xcb) \
351 aballier 1.1 $(use_enable xml libxml2) \
352     $(use_enable xosd) \
353     $(use_enable xv xvideo) \
354     --disable-xvmc \
355 aballier 1.26 $(use_enable zvbi) $(use_enable !zvbi telx) \
356 aballier 1.1 --disable-snapshot \
357     --disable-growl \
358     --disable-optimizations \
359     --enable-fast-install \
360     $(vlc_use_enable_force vlm vlm sout) \
361     $(vlc_use_enable_force skins skins2 qt4) \
362 alexxy 1.15 $(vlc_use_enable_force remoteosd remoteosd libgcrypt)
363 aballier 1.1 }
364    
365     src_install() {
366     emake DESTDIR="${D}" install || die "make install failed"
367    
368     dodoc AUTHORS MAINTAINERS HACKING THANKS NEWS README \
369     doc/fortunes.txt doc/intf-cdda.txt doc/intf-vcd.txt
370    
371     rm -rf "${D}/usr/share/doc/vlc" \
372     "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico}
373    
374     if use nsplugin; then
375     dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
376     mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
377     "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
378     fi
379    
380     use skins || rm -rf "${D}/usr/share/vlc/skins2"
381    
382     for res in 16 32 48; do
383     insinto /usr/share/icons/hicolor/${res}x${res}/apps/
384     newins "${S}"/share/vlc${res}x${res}.png vlc.png
385     done
386     }

  ViewVC Help
Powered by ViewVC 1.1.20