/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Contents of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.56 - (hide annotations) (download)
Tue Jan 12 21:48:40 2010 UTC (7 years, 10 months ago) by aballier
Branch: MAIN
Changes since 1.55: +2 -2 lines
Add missing libXt and libXpm deps for the mozilla plugin, bug #300152, by Donnie Lunder <speedy@carboncode.com>
(Portage version: 2.2_rc61/cvs/Linux x86_64)

1 aballier 1.52 # Copyright 1999-2010 Gentoo Foundation
2 aballier 1.1 # Distributed under the terms of the GNU General Public License v2
3 aballier 1.56 # $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.55 2010/01/10 17:04:46 aballier Exp $
4 aballier 1.1
5 aballier 1.22 EAPI="2"
6 aballier 1.1
7     SCM=""
8     if [ "${PV%9999}" != "${PV}" ] ; then
9     SCM=git
10     EGIT_BOOTSTRAP="bootstrap"
11 aballier 1.52 EGIT_BRANCH=master
12     EGIT_PROJECT=${P}
13 aballier 1.1 if [ "${PV%.9999}" != "${PV}" ] ; then
14 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc/vlc-${PV%.9999}.git"
15 aballier 1.1 else
16 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
17 aballier 1.1 fi
18     fi
19    
20     inherit eutils multilib autotools toolchain-funcs gnome2 nsplugins qt4 flag-o-matic ${SCM}
21    
22     MY_PV="${PV/_/-}"
23     MY_PV="${MY_PV/-beta/-test}"
24     MY_P="${PN}-${MY_PV}"
25     VLC_SNAPSHOT_TIME="0013"
26    
27 aballier 1.55 PATCHLEVEL="80"
28 aballier 1.1 DESCRIPTION="VLC media player - Video player and streamer"
29     HOMEPAGE="http://www.videolan.org/vlc/"
30     if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31     SRC_URI=""
32     elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org
33     SRC_URI="http://nightlies.videolan.org/build/source/trunk-${PV/*_alpha/}-${VLC_SNAPSHOT_TIME}/${PN}-snapshot-${PV/*_alpha/}.tar.bz2"
34     MY_P="${P/_alpha*/}-git"
35     elif [[ "${MY_P}" == "${P}" ]]; then
36     SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
37     else
38     SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.bz2"
39     fi
40    
41     SRC_URI="${SRC_URI}
42 aballier 1.47 mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
43 aballier 1.1
44     LICENSE="GPL-2"
45     SLOT="0"
46    
47     KEYWORDS=""
48 aballier 1.53 IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddb cdio dbus dc1394
49 aballier 1.36 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
50 aballier 1.46 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate libass libcaca
51 aballier 1.48 libnotify libproxy libsysfs libtiger libv4l libv4l2 lirc live lua matroska mmx
52 aballier 1.18 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
53 aballier 1.38 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
54 aballier 1.55 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream
55 aballier 1.43 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vcdinfo vcdx vlm
56 aballier 1.51 vorbis win32codecs wma-fixed x264 +xcb xml xosd xv zvbi"
57 aballier 1.1
58     RDEPEND="
59 aballier 1.24 !!<=media-video/vlc-1.0.99999
60 aballier 1.1 sys-libs/zlib
61 aballier 1.20 >=media-libs/libdvbpsi-0.1.6
62 aballier 1.1 a52? ( >=media-libs/a52dec-0.7.4-r3 )
63     aalib? ( media-libs/aalib )
64     aac? ( >=media-libs/faad2-2.6.1 )
65     alsa? ( media-libs/alsa-lib )
66     avahi? ( >=net-dns/avahi-0.6 )
67     bidi? ( >=dev-libs/fribidi-0.10.4 )
68     cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
69     cdio? ( >=dev-libs/libcdio-0.78.2 )
70     dbus? ( >=sys-apps/dbus-1.0.2 )
71 aballier 1.18 dc1394? ( >=sys-libs/libraw1394-2.0.1
72     >=media-libs/libdc1394-2.0.2 )
73 aballier 1.1 dirac? ( >=media-video/dirac-0.10.0 )
74 aballier 1.37 directfb? ( dev-libs/DirectFB sys-libs/zlib )
75 aballier 1.1 dts? ( media-libs/libdca )
76     dvd? ( media-libs/libdvdread
77     >=media-libs/libdvdnav-0.1.9
78     media-libs/libdvdplay )
79 aballier 1.36 elibc_glibc? ( >=sys-libs/glibc-2.8 )
80 aballier 1.1 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
81     flac? ( media-libs/libogg
82     >=media-libs/flac-1.1.2 )
83     fluidsynth? ( media-sound/fluidsynth )
84     fontconfig? ( media-libs/fontconfig )
85 pva 1.16 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
86 aballier 1.1 ggi? ( media-libs/libggi )
87     gnome? ( gnome-base/gnome-vfs )
88 aballier 1.8 gnutls? ( >=net-libs/gnutls-1.7.4 )
89 aballier 1.37 id3tag? ( media-libs/libid3tag sys-libs/zlib )
90 aballier 1.18 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
91 aballier 1.1 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
92     kate? ( >=media-libs/libkate-0.1.1 )
93 aballier 1.31 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
94 aballier 1.54 libcaca? ( >=media-libs/libcaca-0.99_beta14 )
95 aballier 1.1 libnotify? ( x11-libs/libnotify )
96 aballier 1.13 libproxy? ( net-libs/libproxy )
97 aballier 1.1 libsysfs? ( sys-fs/sysfsutils )
98 aballier 1.17 libtiger? ( media-libs/libtiger )
99 aballier 1.1 lirc? ( app-misc/lirc )
100     live? ( >=media-plugins/live-2008.07.06 )
101     lua? ( >=dev-lang/lua-5.1 )
102     matroska? (
103     >=dev-libs/libebml-0.7.6
104     >=media-libs/libmatroska-0.8.0 )
105 aballier 1.54 modplug? ( >=media-libs/libmodplug-0.8 )
106 aballier 1.1 mp3? ( media-libs/libmad )
107     mpeg? ( >=media-libs/libmpeg2-0.3.2 )
108     mtp? ( >=media-libs/libmtp-0.3.0 )
109 ssuominen 1.44 musepack? ( >=media-sound/musepack-tools-444 )
110 aballier 1.1 ncurses? ( sys-libs/ncurses )
111 aballier 1.56 nsplugin? ( >=net-libs/xulrunner-1.8 x11-libs/libXpm x11-libs/libXt )
112 aballier 1.1 ogg? ( media-libs/libogg )
113 aballier 1.51 opengl? ( virtual/opengl )
114 aballier 1.37 png? ( media-libs/libpng sys-libs/zlib )
115 aballier 1.21 projectm? ( media-libs/libprojectm )
116 aballier 1.9 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
117 aballier 1.35 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
118 aballier 1.1 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
119 patrick 1.42 samba? ( || ( >=net-fs/samba-libs-3.4[smbclient]
120     <net-fs/samba-3.4 ) )
121 aballier 1.12 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
122 aballier 1.1 sdl? ( >=media-libs/libsdl-1.2.8
123 aballier 1.37 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
124 aballier 1.1 shout? ( media-libs/libshout )
125 aballier 1.35 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 )
126 aballier 1.1 speex? ( media-libs/speex )
127 aballier 1.54 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
128 aballier 1.1 svg? ( >=gnome-base/librsvg-2.9.0 )
129     svga? ( media-libs/svgalib )
130 aballier 1.37 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
131 aballier 1.6 theora? ( >=media-libs/libtheora-1.0_beta3 )
132 aballier 1.1 truetype? ( media-libs/freetype
133 aballier 1.25 media-fonts/dejavu )
134 aballier 1.1 twolame? ( media-sound/twolame )
135 aballier 1.45 udev? ( >=sys-fs/udev-142 )
136 aballier 1.1 upnp? ( net-libs/libupnp )
137     v4l2? ( libv4l2? ( media-libs/libv4l ) )
138 aballier 1.48 v4l? ( libv4l? ( media-libs/libv4l ) )
139 aballier 1.1 vcdinfo? ( >=media-video/vcdimager-0.7.22 )
140     vorbis? ( media-libs/libvorbis )
141     win32codecs? ( media-libs/win32codecs )
142 aballier 1.40 x264? ( >=media-libs/x264-0.0.20090923 )
143 aballier 1.2 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
144 aballier 1.1 xml? ( dev-libs/libxml2 )
145     xosd? ( x11-libs/xosd )
146     zvbi? ( >=media-libs/zvbi-0.2.25 )
147     "
148    
149     DEPEND="${RDEPEND}
150     dvb? ( sys-kernel/linux-headers )
151     v4l? ( sys-kernel/linux-headers )
152 aballier 1.28 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
153 aballier 1.2 xcb? ( x11-proto/xproto )
154 aballier 1.1 dev-util/pkgconfig"
155    
156     S="${WORKDIR}/${MY_P}"
157    
158 aballier 1.5 # Displays a warning if the first use flag is set but the second is not
159 aballier 1.1 vlc_use_needs() {
160     use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
161     }
162    
163     # Notify the user that some useflag have been forced on
164     vlc_use_force() {
165     use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
166     }
167    
168     # Use when $2 depends strictly on $3
169     # if use $1 then enable $2 and $3, otherwise disable $2
170     vlc_use_enable_force() {
171     if use $1 ; then
172     echo "--enable-$2 --enable-$3"
173     else
174     echo "--disable-$2"
175     fi
176     }
177    
178     pkg_setup() {
179 aballier 1.23 if has_version '<=media-video/vlc-1.0.99999'; then
180     eerror "Please unmerge vlc-1.0.x first before installing ${P}"
181 aballier 1.11 eerror "If you don't do that, some plugins will get linked against"
182     eerror "the old ${PN} version and will not work."
183 aballier 1.23 die "Unmerge vlc 1.0.x first"
184 aballier 1.11 fi
185 aballier 1.1 vlc_use_needs skins truetype
186     vlc_use_force skins qt4
187     vlc_use_needs vcdx cdio
188     vlc_use_needs vcdx vcdinfo
189     vlc_use_needs vcdinfo cdio
190     vlc_use_needs bidi truetype
191 pva 1.14 vlc_use_force remoteosd gcrypt
192 aballier 1.1 vlc_use_needs fontconfig truetype
193     vlc_use_needs libv4l2 v4l2
194 aballier 1.48 vlc_use_needs libv4l v4l
195 aballier 1.17 vlc_use_needs libtiger kate
196 aballier 1.39 vlc_use_needs xv xcb
197 aballier 1.53 vlc_use_needs cddb cdda
198 aballier 1.5 if use qt4 || use skins ; then
199     qt4_pkg_setup
200 aballier 1.1 else
201     ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
202     ewarn "graphical interface. Maybe that is not what you want..."
203     fi
204     }
205    
206     src_unpack() {
207     unpack ${A}
208     if [ "${PV%9999}" != "${PV}" ] ; then
209     git_src_unpack
210     fi
211 aballier 1.22 }
212 aballier 1.1
213 aballier 1.22 src_prepare() {
214     if [ "${PV%9999}" != "${PV}" ] ; then
215     git_src_prepare
216     fi
217 aballier 1.1 # Make it build with libtool 1.5
218     rm -f m4/lt* m4/libtool.m4
219    
220     EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
221 aballier 1.47 eautoreconf
222 aballier 1.1 }
223    
224 aballier 1.22 src_configure() {
225 aballier 1.1
226     # It would fail if -fforce-addr is used due to too few registers...
227     use x86 && filter-flags -fforce-addr
228    
229     local MOZILLA_PC
230    
231     if use nsplugin; then
232 aballier 1.55 if has_version 'net-libs/xulrunner:1.9' ; then
233     MOZILLA_PC=libxul
234 aballier 1.1 else
235 aballier 1.55 MOZILLA_PC=xulrunner-plugin
236 aballier 1.1 fi
237     fi
238    
239     econf \
240     $(use_enable a52) \
241     $(use_enable aalib aa) \
242     $(use_enable aac faad) \
243     $(use_enable alsa) \
244     $(use_enable altivec) \
245     --disable-asademux \
246     $(use_enable atmo) \
247     $(use_enable avahi bonjour) \
248     $(use_enable bidi fribidi) \
249     $(use_enable cdda vcd) \
250     $(use_enable cddb libcddb) \
251     $(use_enable cdio libcdio) \
252     $(use_enable dbus) $(use_enable dbus dbus-control) \
253     $(use_enable dirac) \
254     $(use_enable directfb) \
255     $(use_enable dc1394) \
256     $(use_enable debug) \
257     $(use_enable dts dca) \
258     $(use_enable dvb) \
259     $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
260     $(use_enable fbcon fb) \
261 aballier 1.10 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
262 aballier 1.1 $(use_enable flac) \
263     $(use_enable fluidsynth) \
264     $(use_enable fontconfig) \
265     $(use_enable ggi) \
266     $(use_enable gnome gnomevfs) \
267     $(use_enable gnutls) \
268     $(use_enable httpd) \
269     $(use_enable id3tag) \
270 aballier 1.18 $(use_enable ieee1394 dv) \
271 aballier 1.1 $(use_enable jack) \
272     $(use_enable kate) \
273     $(use_enable libass) \
274     $(use_enable libcaca caca) \
275 pva 1.14 $(use_enable gcrypt libgcrypt) \
276 aballier 1.1 $(use_enable libnotify notify) \
277 aballier 1.13 $(use_enable libproxy) \
278 aballier 1.1 --disable-libtar \
279 aballier 1.17 $(use_enable libtiger tiger) \
280 aballier 1.1 $(use_enable libsysfs) \
281 aballier 1.48 $(use_enable libv4l) \
282 aballier 1.1 $(use_enable libv4l2) \
283     $(use_enable lirc) \
284     $(use_enable live live555) \
285     $(use_enable lua) \
286     $(use_enable matroska mkv) \
287     $(use_enable mmx) \
288     $(use_enable modplug mod) \
289     $(use_enable mp3 mad) \
290     $(use_enable mpeg libmpeg2) \
291     $(use_enable mtp) \
292     $(use_enable musepack mpc) \
293     $(use_enable ncurses) \
294     $(use_enable nsplugin mozilla) --with-mozilla-pkg="${MOZILLA_PC}" \
295     $(use_enable ogg) \
296 aballier 1.30 $(use_enable opengl glx) $(use_enable opengl) \
297 aballier 1.1 $(use_enable optimisememory optimize-memory) \
298     $(use_enable oss) \
299     $(use_enable png) \
300     --disable-portaudio \
301 aballier 1.21 $(use_enable projectm) \
302 aballier 1.1 $(use_enable pulseaudio pulse) \
303     $(use_enable pvr) \
304     $(use_enable qt4) \
305     $(use_enable rtsp realrtsp) \
306     $(use_enable run-as-root) \
307     $(use_enable samba smb) \
308     $(use_enable schroedinger) \
309     $(use_enable sdl) \
310     $(use_enable sdl-image) \
311     $(use_enable shine) \
312     $(use_enable shout) \
313     $(use_enable skins skins2) \
314     $(use_enable speex) \
315 aballier 1.50 $(use_enable sqlite) \
316 aballier 1.1 $(use_enable sse) \
317     $(use_enable stream sout) \
318     $(use_enable svg) \
319     $(use_enable svga svgalib) \
320     $(use_enable taglib) \
321     $(use_enable theora) \
322     $(use_enable truetype freetype) \
323     $(use_enable twolame) \
324 aballier 1.43 $(use_enable udev) \
325 aballier 1.1 $(use_enable upnp) \
326     $(use_enable v4l) \
327     $(use_enable v4l2) \
328     $(use_enable vcdinfo) \
329     $(use_enable vcdx) \
330     $(use_enable vorbis) \
331     $(use_enable win32codecs loader) \
332     $(use_enable wma-fixed) \
333     $(use_enable x264) \
334 aballier 1.2 $(use_enable xcb) \
335 aballier 1.1 $(use_enable xml libxml2) \
336     $(use_enable xosd) \
337     $(use_enable xv xvideo) \
338 aballier 1.26 $(use_enable zvbi) $(use_enable !zvbi telx) \
339 aballier 1.1 --disable-snapshot \
340     --disable-growl \
341     --disable-optimizations \
342     --enable-fast-install \
343     $(vlc_use_enable_force vlm vlm sout) \
344     $(vlc_use_enable_force skins skins2 qt4) \
345 alexxy 1.15 $(vlc_use_enable_force remoteosd remoteosd libgcrypt)
346 aballier 1.1 }
347    
348     src_install() {
349     emake DESTDIR="${D}" install || die "make install failed"
350    
351 aballier 1.48 dodoc AUTHORS HACKING THANKS NEWS README \
352 aballier 1.1 doc/fortunes.txt doc/intf-cdda.txt doc/intf-vcd.txt
353    
354     rm -rf "${D}/usr/share/doc/vlc" \
355     "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico}
356    
357     if use nsplugin; then
358     dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
359     mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
360     "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
361     fi
362    
363     use skins || rm -rf "${D}/usr/share/vlc/skins2"
364    
365     for res in 16 32 48; do
366     insinto /usr/share/icons/hicolor/${res}x${res}/apps/
367     newins "${S}"/share/vlc${res}x${res}.png vlc.png
368     done
369     }

  ViewVC Help
Powered by ViewVC 1.1.20