/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Contents of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.70 - (hide annotations) (download)
Fri May 14 16:39:41 2010 UTC (7 years, 5 months ago) by aballier
Branch: MAIN
Changes since 1.69: +2 -4 lines
Remove useless dvdplay dep. by Matt Michalowski <me@mattm.id.au>, bug #319477
(Portage version: 2.2_rc67/cvs/Linux x86_64)

1 aballier 1.52 # Copyright 1999-2010 Gentoo Foundation
2 aballier 1.1 # Distributed under the terms of the GNU General Public License v2
3 aballier 1.70 # $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.69 2010/04/23 16:18:09 aballier Exp $
4 aballier 1.1
5 aballier 1.22 EAPI="2"
6 aballier 1.1
7     SCM=""
8     if [ "${PV%9999}" != "${PV}" ] ; then
9     SCM=git
10     EGIT_BOOTSTRAP="bootstrap"
11 aballier 1.52 EGIT_BRANCH=master
12     EGIT_PROJECT=${P}
13 aballier 1.1 if [ "${PV%.9999}" != "${PV}" ] ; then
14 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc/vlc-${PV%.9999}.git"
15 aballier 1.1 else
16 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
17 aballier 1.1 fi
18     fi
19    
20     inherit eutils multilib autotools toolchain-funcs gnome2 nsplugins qt4 flag-o-matic ${SCM}
21    
22     MY_PV="${PV/_/-}"
23     MY_PV="${MY_PV/-beta/-test}"
24     MY_P="${PN}-${MY_PV}"
25     VLC_SNAPSHOT_TIME="0013"
26    
27 aballier 1.64 PATCHLEVEL="85"
28 aballier 1.1 DESCRIPTION="VLC media player - Video player and streamer"
29     HOMEPAGE="http://www.videolan.org/vlc/"
30     if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31     SRC_URI=""
32     elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org
33     SRC_URI="http://nightlies.videolan.org/build/source/trunk-${PV/*_alpha/}-${VLC_SNAPSHOT_TIME}/${PN}-snapshot-${PV/*_alpha/}.tar.bz2"
34     MY_P="${P/_alpha*/}-git"
35     elif [[ "${MY_P}" == "${P}" ]]; then
36     SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
37     else
38     SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.bz2"
39     fi
40    
41     SRC_URI="${SRC_URI}
42 aballier 1.47 mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
43 aballier 1.1
44     LICENSE="GPL-2"
45     SLOT="0"
46    
47     KEYWORDS=""
48 aballier 1.59 IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddb dbus dc1394
49 aballier 1.36 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
50 aballier 1.68 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate kde libass libcaca
51 aballier 1.60 libnotify libproxy libtiger libv4l libv4l2 lirc live lua matroska mmx
52 aballier 1.18 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
53 aballier 1.38 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
54 aballier 1.55 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream
55 aballier 1.59 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vcdx vlm
56 aballier 1.51 vorbis win32codecs wma-fixed x264 +xcb xml xosd xv zvbi"
57 aballier 1.1
58     RDEPEND="
59 aballier 1.24 !!<=media-video/vlc-1.0.99999
60 aballier 1.1 sys-libs/zlib
61 aballier 1.20 >=media-libs/libdvbpsi-0.1.6
62 aballier 1.1 a52? ( >=media-libs/a52dec-0.7.4-r3 )
63     aalib? ( media-libs/aalib )
64     aac? ( >=media-libs/faad2-2.6.1 )
65     alsa? ( media-libs/alsa-lib )
66 aballier 1.69 avahi? ( >=net-dns/avahi-0.6[dbus] )
67 aballier 1.1 bidi? ( >=dev-libs/fribidi-0.10.4 )
68     cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
69     dbus? ( >=sys-apps/dbus-1.0.2 )
70 aballier 1.18 dc1394? ( >=sys-libs/libraw1394-2.0.1
71     >=media-libs/libdc1394-2.0.2 )
72 aballier 1.1 dirac? ( >=media-video/dirac-0.10.0 )
73 aballier 1.37 directfb? ( dev-libs/DirectFB sys-libs/zlib )
74 aballier 1.1 dts? ( media-libs/libdca )
75 aballier 1.70 dvd? ( media-libs/libdvdread >=media-libs/libdvdnav-0.1.9 )
76 aballier 1.36 elibc_glibc? ( >=sys-libs/glibc-2.8 )
77 aballier 1.1 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
78     flac? ( media-libs/libogg
79     >=media-libs/flac-1.1.2 )
80     fluidsynth? ( media-sound/fluidsynth )
81     fontconfig? ( media-libs/fontconfig )
82 pva 1.16 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
83 aballier 1.1 ggi? ( media-libs/libggi )
84     gnome? ( gnome-base/gnome-vfs )
85 aballier 1.8 gnutls? ( >=net-libs/gnutls-1.7.4 )
86 aballier 1.37 id3tag? ( media-libs/libid3tag sys-libs/zlib )
87 aballier 1.18 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
88 aballier 1.1 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
89     kate? ( >=media-libs/libkate-0.1.1 )
90 aballier 1.31 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
91 aballier 1.54 libcaca? ( >=media-libs/libcaca-0.99_beta14 )
92 aballier 1.1 libnotify? ( x11-libs/libnotify )
93 aballier 1.13 libproxy? ( net-libs/libproxy )
94 aballier 1.17 libtiger? ( media-libs/libtiger )
95 aballier 1.1 lirc? ( app-misc/lirc )
96     live? ( >=media-plugins/live-2008.07.06 )
97     lua? ( >=dev-lang/lua-5.1 )
98     matroska? (
99     >=dev-libs/libebml-0.7.6
100     >=media-libs/libmatroska-0.8.0 )
101 aballier 1.54 modplug? ( >=media-libs/libmodplug-0.8 )
102 aballier 1.1 mp3? ( media-libs/libmad )
103     mpeg? ( >=media-libs/libmpeg2-0.3.2 )
104     mtp? ( >=media-libs/libmtp-0.3.0 )
105 ssuominen 1.44 musepack? ( >=media-sound/musepack-tools-444 )
106 aballier 1.1 ncurses? ( sys-libs/ncurses )
107 aballier 1.65 nsplugin? ( >=net-libs/xulrunner-1.9.2 x11-libs/libXpm x11-libs/libXt )
108 aballier 1.1 ogg? ( media-libs/libogg )
109 aballier 1.51 opengl? ( virtual/opengl )
110 aballier 1.37 png? ( media-libs/libpng sys-libs/zlib )
111 aballier 1.21 projectm? ( media-libs/libprojectm )
112 aballier 1.9 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
113 aballier 1.35 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
114 aballier 1.1 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
115 patrick 1.63 samba? ( || ( >=net-fs/samba-3.4.6[smbclient]
116 patrick 1.42 <net-fs/samba-3.4 ) )
117 aballier 1.12 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
118 aballier 1.1 sdl? ( >=media-libs/libsdl-1.2.8
119 aballier 1.37 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
120 aballier 1.1 shout? ( media-libs/libshout )
121 aballier 1.69 skins? (
122     x11-libs/qt-gui:4 x11-libs/qt-core:4
123     x11-libs/libXext x11-libs/libX11
124     media-libs/freetype media-fonts/dejavu
125     )
126 aballier 1.1 speex? ( media-libs/speex )
127 aballier 1.54 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
128 aballier 1.1 svg? ( >=gnome-base/librsvg-2.9.0 )
129     svga? ( media-libs/svgalib )
130 aballier 1.37 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
131 aballier 1.6 theora? ( >=media-libs/libtheora-1.0_beta3 )
132 aballier 1.1 truetype? ( media-libs/freetype
133 aballier 1.25 media-fonts/dejavu )
134 aballier 1.1 twolame? ( media-sound/twolame )
135 aballier 1.45 udev? ( >=sys-fs/udev-142 )
136 aballier 1.1 upnp? ( net-libs/libupnp )
137     v4l2? ( libv4l2? ( media-libs/libv4l ) )
138 aballier 1.48 v4l? ( libv4l? ( media-libs/libv4l ) )
139 aballier 1.59 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 )
140 aballier 1.1 vorbis? ( media-libs/libvorbis )
141     win32codecs? ( media-libs/win32codecs )
142 aballier 1.40 x264? ( >=media-libs/x264-0.0.20090923 )
143 aballier 1.2 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
144 aballier 1.1 xml? ( dev-libs/libxml2 )
145     xosd? ( x11-libs/xosd )
146     zvbi? ( >=media-libs/zvbi-0.2.25 )
147     "
148    
149     DEPEND="${RDEPEND}
150     dvb? ( sys-kernel/linux-headers )
151 aballier 1.68 kde? ( >=kde-base/kdelibs-4 )
152 aballier 1.1 v4l? ( sys-kernel/linux-headers )
153 aballier 1.28 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
154 aballier 1.2 xcb? ( x11-proto/xproto )
155 aballier 1.1 dev-util/pkgconfig"
156    
157     S="${WORKDIR}/${MY_P}"
158    
159 aballier 1.5 # Displays a warning if the first use flag is set but the second is not
160 aballier 1.1 vlc_use_needs() {
161     use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
162     }
163    
164     # Notify the user that some useflag have been forced on
165     vlc_use_force() {
166     use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
167     }
168    
169 aballier 1.69 # Use when $1 depends strictly on $2
170     # if use $1 then enable $2
171 aballier 1.1 vlc_use_enable_force() {
172 aballier 1.69 use $1 && echo "--enable-$2"
173 aballier 1.1 }
174    
175     pkg_setup() {
176 aballier 1.23 if has_version '<=media-video/vlc-1.0.99999'; then
177     eerror "Please unmerge vlc-1.0.x first before installing ${P}"
178 aballier 1.11 eerror "If you don't do that, some plugins will get linked against"
179     eerror "the old ${PN} version and will not work."
180 aballier 1.23 die "Unmerge vlc 1.0.x first"
181 aballier 1.11 fi
182 aballier 1.69
183     # Useflags we need to forcefuly enable
184     vlc_use_force remoteosd gcrypt
185     vlc_use_force skins truetype
186 aballier 1.1 vlc_use_force skins qt4
187 aballier 1.69 vlc_use_force vlm stream
188    
189     # Useflags that will be automagically discarded if deps are not met
190 aballier 1.1 vlc_use_needs bidi truetype
191 aballier 1.69 vlc_use_needs cddb cdda
192 aballier 1.1 vlc_use_needs fontconfig truetype
193     vlc_use_needs libv4l2 v4l2
194 aballier 1.48 vlc_use_needs libv4l v4l
195 aballier 1.17 vlc_use_needs libtiger kate
196 aballier 1.39 vlc_use_needs xv xcb
197 aballier 1.69
198 aballier 1.5 if use qt4 || use skins ; then
199     qt4_pkg_setup
200 aballier 1.1 else
201     ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
202     ewarn "graphical interface. Maybe that is not what you want..."
203     fi
204     }
205    
206     src_unpack() {
207     unpack ${A}
208     if [ "${PV%9999}" != "${PV}" ] ; then
209     git_src_unpack
210     fi
211 aballier 1.22 }
212 aballier 1.1
213 aballier 1.22 src_prepare() {
214     if [ "${PV%9999}" != "${PV}" ] ; then
215     git_src_prepare
216     fi
217 aballier 1.1 # Make it build with libtool 1.5
218     rm -f m4/lt* m4/libtool.m4
219    
220     EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
221 aballier 1.47 eautoreconf
222 aballier 1.1 }
223    
224 aballier 1.22 src_configure() {
225 aballier 1.1
226     # It would fail if -fforce-addr is used due to too few registers...
227     use x86 && filter-flags -fforce-addr
228    
229     econf \
230     $(use_enable a52) \
231     $(use_enable aalib aa) \
232     $(use_enable aac faad) \
233     $(use_enable alsa) \
234     $(use_enable altivec) \
235     --disable-asademux \
236     $(use_enable atmo) \
237     $(use_enable avahi bonjour) \
238     $(use_enable bidi fribidi) \
239     $(use_enable cdda vcd) \
240     $(use_enable cddb libcddb) \
241     $(use_enable dbus) $(use_enable dbus dbus-control) \
242     $(use_enable dirac) \
243     $(use_enable directfb) \
244     $(use_enable dc1394) \
245     $(use_enable debug) \
246     $(use_enable dts dca) \
247     $(use_enable dvb) \
248     $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
249     $(use_enable fbcon fb) \
250 aballier 1.10 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
251 aballier 1.1 $(use_enable flac) \
252     $(use_enable fluidsynth) \
253     $(use_enable fontconfig) \
254     $(use_enable ggi) \
255     $(use_enable gnome gnomevfs) \
256     $(use_enable gnutls) \
257     $(use_enable httpd) \
258     $(use_enable id3tag) \
259 aballier 1.18 $(use_enable ieee1394 dv) \
260 aballier 1.1 $(use_enable jack) \
261     $(use_enable kate) \
262 aballier 1.68 $(use_with kde kde-solid) \
263 aballier 1.1 $(use_enable libass) \
264     $(use_enable libcaca caca) \
265 pva 1.14 $(use_enable gcrypt libgcrypt) \
266 aballier 1.1 $(use_enable libnotify notify) \
267 aballier 1.13 $(use_enable libproxy) \
268 aballier 1.1 --disable-libtar \
269 aballier 1.17 $(use_enable libtiger tiger) \
270 aballier 1.48 $(use_enable libv4l) \
271 aballier 1.1 $(use_enable libv4l2) \
272     $(use_enable lirc) \
273     $(use_enable live live555) \
274     $(use_enable lua) \
275     $(use_enable matroska mkv) \
276     $(use_enable mmx) \
277     $(use_enable modplug mod) \
278     $(use_enable mp3 mad) \
279     $(use_enable mpeg libmpeg2) \
280     $(use_enable mtp) \
281     $(use_enable musepack mpc) \
282     $(use_enable ncurses) \
283 aballier 1.65 $(use_enable nsplugin mozilla) --with-mozilla-pkg=libxul \
284 aballier 1.1 $(use_enable ogg) \
285 aballier 1.30 $(use_enable opengl glx) $(use_enable opengl) \
286 aballier 1.1 $(use_enable optimisememory optimize-memory) \
287     $(use_enable oss) \
288     $(use_enable png) \
289     --disable-portaudio \
290 aballier 1.21 $(use_enable projectm) \
291 aballier 1.1 $(use_enable pulseaudio pulse) \
292     $(use_enable pvr) \
293     $(use_enable qt4) \
294 aballier 1.69 $(use_enable remoteosd) \
295 aballier 1.1 $(use_enable rtsp realrtsp) \
296     $(use_enable run-as-root) \
297     $(use_enable samba smb) \
298     $(use_enable schroedinger) \
299     $(use_enable sdl) \
300     $(use_enable sdl-image) \
301     $(use_enable shine) \
302     $(use_enable shout) \
303     $(use_enable skins skins2) \
304     $(use_enable speex) \
305 aballier 1.50 $(use_enable sqlite) \
306 aballier 1.1 $(use_enable sse) \
307     $(use_enable stream sout) \
308     $(use_enable svg) \
309     $(use_enable svga svgalib) \
310     $(use_enable taglib) \
311     $(use_enable theora) \
312     $(use_enable truetype freetype) \
313     $(use_enable twolame) \
314 aballier 1.43 $(use_enable udev) \
315 aballier 1.1 $(use_enable upnp) \
316     $(use_enable v4l) \
317     $(use_enable v4l2) \
318     $(use_enable vcdx) \
319 aballier 1.69 $(use_enable vlm) \
320 aballier 1.1 $(use_enable vorbis) \
321     $(use_enable win32codecs loader) \
322     $(use_enable wma-fixed) \
323     $(use_enable x264) \
324 aballier 1.2 $(use_enable xcb) \
325 aballier 1.1 $(use_enable xml libxml2) \
326     $(use_enable xosd) \
327     $(use_enable xv xvideo) \
328 aballier 1.26 $(use_enable zvbi) $(use_enable !zvbi telx) \
329 aballier 1.1 --disable-snapshot \
330     --disable-growl \
331     --disable-optimizations \
332     --enable-fast-install \
333 aballier 1.69 $(vlc_use_enable_force vlm sout) \
334     $(vlc_use_enable_force skins qt4) \
335     $(vlc_use_enable_force skins freetype) \
336     $(vlc_use_enable_force remoteosd libgcrypt)
337 aballier 1.1 }
338    
339     src_install() {
340     emake DESTDIR="${D}" install || die "make install failed"
341    
342 aballier 1.48 dodoc AUTHORS HACKING THANKS NEWS README \
343 aballier 1.66 doc/fortunes.txt doc/intf-vcd.txt
344 aballier 1.1
345     rm -rf "${D}/usr/share/doc/vlc" \
346     "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico}
347    
348     if use nsplugin; then
349     dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
350     mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
351     "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
352     fi
353    
354     use skins || rm -rf "${D}/usr/share/vlc/skins2"
355    
356     for res in 16 32 48; do
357     insinto /usr/share/icons/hicolor/${res}x${res}/apps/
358     newins "${S}"/share/vlc${res}x${res}.png vlc.png
359     done
360     }
361 aballier 1.61
362     pkg_postinst() {
363     gnome2_pkg_postinst
364    
365     if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
366 aballier 1.67 einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
367     "/usr/$(get_libdir)/vlc/vlc-cache-gen" "/usr/$(get_libdir)/vlc/plugins/"
368 aballier 1.61 else
369     ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
370     ewarn "Please run /usr/$(get_libdir)/vlc/vlc-cache-gen manually"
371     ewarn "If you do not do it, vlc will take a long time to load."
372     fi
373     }

  ViewVC Help
Powered by ViewVC 1.1.20