/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Contents of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.91 - (hide annotations) (download)
Thu Sep 9 11:03:43 2010 UTC (7 years, 2 months ago) by scarabeus
Branch: MAIN
Changes since 1.90: +2 -2 lines
Update deps on libX11[xcb].

(Portage version: 2.2_rc78/cvs/Linux x86_64)

1 aballier 1.52 # Copyright 1999-2010 Gentoo Foundation
2 aballier 1.1 # Distributed under the terms of the GNU General Public License v2
3 scarabeus 1.91 # $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.90 2010/07/26 09:56:55 aballier Exp $
4 aballier 1.1
5 zmedico 1.80 EAPI="3"
6 aballier 1.1
7     SCM=""
8     if [ "${PV%9999}" != "${PV}" ] ; then
9     SCM=git
10     EGIT_BOOTSTRAP="bootstrap"
11 aballier 1.52 EGIT_BRANCH=master
12     EGIT_PROJECT=${P}
13 aballier 1.1 if [ "${PV%.9999}" != "${PV}" ] ; then
14 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc/vlc-${PV%.9999}.git"
15 aballier 1.1 else
16 aballier 1.52 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
17 aballier 1.1 fi
18     fi
19    
20     inherit eutils multilib autotools toolchain-funcs gnome2 nsplugins qt4 flag-o-matic ${SCM}
21    
22     MY_PV="${PV/_/-}"
23     MY_PV="${MY_PV/-beta/-test}"
24     MY_P="${PN}-${MY_PV}"
25     VLC_SNAPSHOT_TIME="0013"
26    
27 aballier 1.82 PATCHLEVEL="86"
28 aballier 1.1 DESCRIPTION="VLC media player - Video player and streamer"
29     HOMEPAGE="http://www.videolan.org/vlc/"
30     if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31     SRC_URI=""
32     elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org
33     SRC_URI="http://nightlies.videolan.org/build/source/trunk-${PV/*_alpha/}-${VLC_SNAPSHOT_TIME}/${PN}-snapshot-${PV/*_alpha/}.tar.bz2"
34     MY_P="${P/_alpha*/}-git"
35     elif [[ "${MY_P}" == "${P}" ]]; then
36     SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
37     else
38     SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.bz2"
39     fi
40    
41     SRC_URI="${SRC_URI}
42 aballier 1.47 mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
43 aballier 1.1
44     LICENSE="GPL-2"
45     SLOT="0"
46    
47 aballier 1.89 if [ "${PV%9999}" = "${PV}" ] ; then
48     KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
49     else
50     KEYWORDS=""
51     fi
52 aballier 1.59 IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddb dbus dc1394
53 aballier 1.36 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
54 aballier 1.85 +gcrypt gnome gnutls httpd ieee1394 jack kate kde libass libcaca
55 aballier 1.90 libnotify libproxy libtiger libv4l2 lirc live lua matroska mmx
56 aballier 1.18 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
57 aballier 1.38 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
58 aballier 1.55 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream
59 aballier 1.90 svg taglib theora truetype twolame udev upnp v4l2 vaapi vcdx vlm
60 aballier 1.74 vorbis win32codecs wma-fixed +X x264 +xcb xml xosd xv zvbi"
61 aballier 1.1
62     RDEPEND="
63     sys-libs/zlib
64 aballier 1.20 >=media-libs/libdvbpsi-0.1.6
65 aballier 1.1 a52? ( >=media-libs/a52dec-0.7.4-r3 )
66     aalib? ( media-libs/aalib )
67     aac? ( >=media-libs/faad2-2.6.1 )
68     alsa? ( media-libs/alsa-lib )
69 aballier 1.69 avahi? ( >=net-dns/avahi-0.6[dbus] )
70 aballier 1.1 bidi? ( >=dev-libs/fribidi-0.10.4 )
71     cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
72     dbus? ( >=sys-apps/dbus-1.0.2 )
73 aballier 1.79 dc1394? ( >=sys-libs/libraw1394-2.0.1 >=media-libs/libdc1394-2.0.2 )
74 aballier 1.1 dirac? ( >=media-video/dirac-0.10.0 )
75 aballier 1.37 directfb? ( dev-libs/DirectFB sys-libs/zlib )
76 aballier 1.1 dts? ( media-libs/libdca )
77 aballier 1.70 dvd? ( media-libs/libdvdread >=media-libs/libdvdnav-0.1.9 )
78 aballier 1.36 elibc_glibc? ( >=sys-libs/glibc-2.8 )
79 aballier 1.87 ffmpeg? ( >=media-video/ffmpeg-0.6 )
80 aballier 1.79 flac? ( media-libs/libogg >=media-libs/flac-1.1.2 )
81 aballier 1.1 fluidsynth? ( media-sound/fluidsynth )
82     fontconfig? ( media-libs/fontconfig )
83 pva 1.16 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
84 aballier 1.1 gnome? ( gnome-base/gnome-vfs )
85 aballier 1.77 gnutls? ( >=net-libs/gnutls-1.7.4 >=dev-libs/libgcrypt-1.2.0 )
86 aballier 1.18 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
87 aballier 1.1 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
88     kate? ( >=media-libs/libkate-0.1.1 )
89 aballier 1.31 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
90 aballier 1.54 libcaca? ( >=media-libs/libcaca-0.99_beta14 )
91 aballier 1.1 libnotify? ( x11-libs/libnotify )
92 aballier 1.13 libproxy? ( net-libs/libproxy )
93 aballier 1.17 libtiger? ( media-libs/libtiger )
94 aballier 1.1 lirc? ( app-misc/lirc )
95     live? ( >=media-plugins/live-2008.07.06 )
96     lua? ( >=dev-lang/lua-5.1 )
97 aballier 1.79 matroska? ( >=dev-libs/libebml-0.7.6 >=media-libs/libmatroska-0.8.0 )
98 aballier 1.81 modplug? ( >=media-libs/libmodplug-0.8.8.1 )
99 aballier 1.1 mp3? ( media-libs/libmad )
100     mpeg? ( >=media-libs/libmpeg2-0.3.2 )
101 aballier 1.73 mtp? ( >=media-libs/libmtp-1.0.0 )
102 ssuominen 1.44 musepack? ( >=media-sound/musepack-tools-444 )
103 aballier 1.1 ncurses? ( sys-libs/ncurses )
104 aballier 1.88 nsplugin? ( >=net-libs/xulrunner-1.9.2 x11-libs/libXpm x11-libs/libXt x11-libs/libxcb x11-libs/xcb-util )
105 aballier 1.1 ogg? ( media-libs/libogg )
106 scarabeus 1.91 opengl? ( virtual/opengl || ( <=x11-libs/libX11-1.3.5[xcb] >x11-libs/libX11-1.3.5 ) )
107 aballier 1.37 png? ( media-libs/libpng sys-libs/zlib )
108 aballier 1.21 projectm? ( media-libs/libprojectm )
109 aballier 1.74 pulseaudio? ( >=media-sound/pulseaudio-0.9.11
110     !X? ( >=media-sound/pulseaudio-0.9.11[-X] ) )
111 aballier 1.35 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
112 aballier 1.1 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
113 aballier 1.79 samba? ( || ( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-3.4 ) )
114 aballier 1.12 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
115 aballier 1.1 sdl? ( >=media-libs/libsdl-1.2.8
116 aballier 1.37 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
117 aballier 1.1 shout? ( media-libs/libshout )
118 aballier 1.69 skins? (
119     x11-libs/qt-gui:4 x11-libs/qt-core:4
120     x11-libs/libXext x11-libs/libX11
121     media-libs/freetype media-fonts/dejavu
122     )
123 aballier 1.1 speex? ( media-libs/speex )
124 aballier 1.54 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
125 aballier 1.1 svg? ( >=gnome-base/librsvg-2.9.0 )
126 aballier 1.37 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
127 aballier 1.6 theora? ( >=media-libs/libtheora-1.0_beta3 )
128 aballier 1.79 truetype? ( media-libs/freetype media-fonts/dejavu )
129 aballier 1.1 twolame? ( media-sound/twolame )
130 aballier 1.45 udev? ( >=sys-fs/udev-142 )
131 aballier 1.1 upnp? ( net-libs/libupnp )
132     v4l2? ( libv4l2? ( media-libs/libv4l ) )
133 aballier 1.87 vaapi? ( x11-libs/libva >=media-video/ffmpeg-0.6 )
134 aballier 1.59 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 )
135 aballier 1.1 vorbis? ( media-libs/libvorbis )
136     win32codecs? ( media-libs/win32codecs )
137 aballier 1.74 X? ( x11-libs/libX11 )
138 aballier 1.40 x264? ( >=media-libs/x264-0.0.20090923 )
139 aballier 1.2 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
140 aballier 1.1 xml? ( dev-libs/libxml2 )
141     xosd? ( x11-libs/xosd )
142     zvbi? ( >=media-libs/zvbi-0.2.25 )
143     "
144    
145     DEPEND="${RDEPEND}
146 aballier 1.84 !!<=media-video/vlc-1.1.99999
147 aballier 1.1 dvb? ( sys-kernel/linux-headers )
148 aballier 1.68 kde? ( >=kde-base/kdelibs-4 )
149 aballier 1.28 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
150 aballier 1.2 xcb? ( x11-proto/xproto )
151 aballier 1.1 dev-util/pkgconfig"
152    
153     S="${WORKDIR}/${MY_P}"
154    
155 aballier 1.5 # Displays a warning if the first use flag is set but the second is not
156 aballier 1.1 vlc_use_needs() {
157     use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
158     }
159    
160     # Notify the user that some useflag have been forced on
161     vlc_use_force() {
162     use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
163     }
164    
165 aballier 1.69 # Use when $1 depends strictly on $2
166     # if use $1 then enable $2
167 aballier 1.1 vlc_use_enable_force() {
168 aballier 1.69 use $1 && echo "--enable-$2"
169 aballier 1.1 }
170    
171     pkg_setup() {
172 aballier 1.69 # Useflags we need to forcefuly enable
173     vlc_use_force remoteosd gcrypt
174 aballier 1.77 vlc_use_force gnutls gcrypt
175 aballier 1.69 vlc_use_force skins truetype
176 aballier 1.1 vlc_use_force skins qt4
177 aballier 1.69 vlc_use_force vlm stream
178 aballier 1.71 vlc_use_force vaapi ffmpeg
179 aballier 1.88 vlc_use_force nsplugin xcb
180 aballier 1.69
181     # Useflags that will be automagically discarded if deps are not met
182 aballier 1.1 vlc_use_needs bidi truetype
183 aballier 1.69 vlc_use_needs cddb cdda
184 aballier 1.1 vlc_use_needs fontconfig truetype
185     vlc_use_needs libv4l2 v4l2
186 aballier 1.17 vlc_use_needs libtiger kate
187 aballier 1.39 vlc_use_needs xv xcb
188 aballier 1.69
189 aballier 1.5 if use qt4 || use skins ; then
190     qt4_pkg_setup
191 aballier 1.1 else
192     ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
193     ewarn "graphical interface. Maybe that is not what you want..."
194     fi
195     }
196    
197     src_unpack() {
198     unpack ${A}
199     if [ "${PV%9999}" != "${PV}" ] ; then
200     git_src_unpack
201     fi
202 aballier 1.22 }
203 aballier 1.1
204 aballier 1.22 src_prepare() {
205     if [ "${PV%9999}" != "${PV}" ] ; then
206     git_src_prepare
207     fi
208 aballier 1.1 # Make it build with libtool 1.5
209     rm -f m4/lt* m4/libtool.m4
210    
211     EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
212 aballier 1.47 eautoreconf
213 aballier 1.1 }
214    
215 aballier 1.22 src_configure() {
216 aballier 1.1
217     # It would fail if -fforce-addr is used due to too few registers...
218     use x86 && filter-flags -fforce-addr
219    
220     econf \
221     $(use_enable a52) \
222     $(use_enable aalib aa) \
223     $(use_enable aac faad) \
224     $(use_enable alsa) \
225     $(use_enable altivec) \
226     --disable-asademux \
227     $(use_enable atmo) \
228     $(use_enable avahi bonjour) \
229     $(use_enable bidi fribidi) \
230     $(use_enable cdda vcd) \
231     $(use_enable cddb libcddb) \
232     $(use_enable dbus) $(use_enable dbus dbus-control) \
233     $(use_enable dirac) \
234     $(use_enable directfb) \
235     $(use_enable dc1394) \
236     $(use_enable debug) \
237     $(use_enable dts dca) \
238     $(use_enable dvb) \
239     $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
240     $(use_enable fbcon fb) \
241 aballier 1.10 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
242 aballier 1.1 $(use_enable flac) \
243     $(use_enable fluidsynth) \
244     $(use_enable fontconfig) \
245     $(use_enable gnome gnomevfs) \
246     $(use_enable gnutls) \
247     $(use_enable httpd) \
248 aballier 1.18 $(use_enable ieee1394 dv) \
249 aballier 1.1 $(use_enable jack) \
250     $(use_enable kate) \
251 aballier 1.68 $(use_with kde kde-solid) \
252 aballier 1.1 $(use_enable libass) \
253     $(use_enable libcaca caca) \
254 pva 1.14 $(use_enable gcrypt libgcrypt) \
255 aballier 1.1 $(use_enable libnotify notify) \
256 aballier 1.13 $(use_enable libproxy) \
257 aballier 1.1 --disable-libtar \
258 aballier 1.17 $(use_enable libtiger tiger) \
259 aballier 1.1 $(use_enable libv4l2) \
260     $(use_enable lirc) \
261     $(use_enable live live555) \
262     $(use_enable lua) \
263     $(use_enable matroska mkv) \
264     $(use_enable mmx) \
265     $(use_enable modplug mod) \
266     $(use_enable mp3 mad) \
267     $(use_enable mpeg libmpeg2) \
268     $(use_enable mtp) \
269     $(use_enable musepack mpc) \
270     $(use_enable ncurses) \
271 aballier 1.65 $(use_enable nsplugin mozilla) --with-mozilla-pkg=libxul \
272 aballier 1.1 $(use_enable ogg) \
273 aballier 1.83 $(use_enable opengl glx) \
274 aballier 1.1 $(use_enable optimisememory optimize-memory) \
275     $(use_enable oss) \
276     $(use_enable png) \
277     --disable-portaudio \
278 aballier 1.21 $(use_enable projectm) \
279 aballier 1.1 $(use_enable pulseaudio pulse) \
280     $(use_enable pvr) \
281     $(use_enable qt4) \
282 aballier 1.69 $(use_enable remoteosd) \
283 aballier 1.1 $(use_enable rtsp realrtsp) \
284     $(use_enable run-as-root) \
285     $(use_enable samba smb) \
286     $(use_enable schroedinger) \
287     $(use_enable sdl) \
288     $(use_enable sdl-image) \
289     $(use_enable shine) \
290     $(use_enable shout) \
291     $(use_enable skins skins2) \
292     $(use_enable speex) \
293 aballier 1.50 $(use_enable sqlite) \
294 aballier 1.1 $(use_enable sse) \
295     $(use_enable stream sout) \
296     $(use_enable svg) \
297     $(use_enable taglib) \
298     $(use_enable theora) \
299     $(use_enable truetype freetype) \
300     $(use_enable twolame) \
301 aballier 1.43 $(use_enable udev) \
302 aballier 1.1 $(use_enable upnp) \
303     $(use_enable v4l2) \
304     $(use_enable vcdx) \
305 aballier 1.71 $(use_enable vaapi libva) \
306 aballier 1.69 $(use_enable vlm) \
307 aballier 1.1 $(use_enable vorbis) \
308     $(use_enable win32codecs loader) \
309     $(use_enable wma-fixed) \
310 aballier 1.74 $(use_with X x) \
311 aballier 1.1 $(use_enable x264) \
312 aballier 1.2 $(use_enable xcb) \
313 aballier 1.1 $(use_enable xml libxml2) \
314     $(use_enable xosd) \
315     $(use_enable xv xvideo) \
316 aballier 1.26 $(use_enable zvbi) $(use_enable !zvbi telx) \
317 aballier 1.1 --disable-snapshot \
318     --disable-growl \
319     --disable-optimizations \
320     --enable-fast-install \
321 aballier 1.69 $(vlc_use_enable_force vlm sout) \
322     $(vlc_use_enable_force skins qt4) \
323     $(vlc_use_enable_force skins freetype) \
324 aballier 1.71 $(vlc_use_enable_force remoteosd libgcrypt) \
325 aballier 1.77 $(vlc_use_enable_force gnutls libgcrypt) \
326 aballier 1.88 $(vlc_use_enable_force vaapi avcodec) \
327     $(vlc_use_enable_force nsplugin xcb)
328 aballier 1.1 }
329    
330     src_install() {
331     emake DESTDIR="${D}" install || die "make install failed"
332    
333 aballier 1.48 dodoc AUTHORS HACKING THANKS NEWS README \
334 aballier 1.66 doc/fortunes.txt doc/intf-vcd.txt
335 aballier 1.1
336     rm -rf "${D}/usr/share/doc/vlc" \
337     "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico}
338    
339     if use nsplugin; then
340     dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
341     mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
342     "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
343     fi
344    
345     use skins || rm -rf "${D}/usr/share/vlc/skins2"
346 aballier 1.86
347     # Punt useless libtool's .la files
348     find "${D}" -name '*.la' -delete
349 aballier 1.1 }
350 aballier 1.61
351     pkg_postinst() {
352     gnome2_pkg_postinst
353    
354     if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
355 aballier 1.67 einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
356 aballier 1.75 "/usr/$(get_libdir)/vlc/vlc-cache-gen" -f "/usr/$(get_libdir)/vlc/plugins/"
357 aballier 1.61 else
358     ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
359     ewarn "Please run /usr/$(get_libdir)/vlc/vlc-cache-gen manually"
360     ewarn "If you do not do it, vlc will take a long time to load."
361     fi
362     }

  ViewVC Help
Powered by ViewVC 1.1.20