/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.103 Revision 1.105
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.103 2011/02/16 13:21:28 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.105 2011/02/16 15:20:56 aballier Exp $
4 4
5EAPI="3" 5EAPI="4"
6 6
7SCM="" 7SCM=""
8if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
9 SCM=git 9 SCM=git
10 EGIT_BOOTSTRAP="bootstrap" 10 EGIT_BOOTSTRAP="bootstrap"
15 else 15 else
16 EGIT_REPO_URI="git://git.videolan.org/vlc.git" 16 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
17 fi 17 fi
18fi 18fi
19 19
20inherit eutils multilib autotools toolchain-funcs gnome2 qt4-r2 flag-o-matic ${SCM} 20inherit eutils multilib autotools toolchain-funcs flag-o-matic ${SCM}
21 21
22MY_PV="${PV/_/-}" 22MY_PV="${PV/_/-}"
23MY_PV="${MY_PV/-beta/-test}" 23MY_PV="${MY_PV/-beta/-test}"
24MY_P="${PN}-${MY_PV}" 24MY_P="${PN}-${MY_PV}"
25 25
62 aalib? ( media-libs/aalib ) 62 aalib? ( media-libs/aalib )
63 aac? ( >=media-libs/faad2-2.6.1 ) 63 aac? ( >=media-libs/faad2-2.6.1 )
64 alsa? ( >=media-libs/alsa-lib-1.0.23 ) 64 alsa? ( >=media-libs/alsa-lib-1.0.23 )
65 avahi? ( >=net-dns/avahi-0.6[dbus] ) 65 avahi? ( >=net-dns/avahi-0.6[dbus] )
66 bidi? ( >=dev-libs/fribidi-0.10.4 ) 66 bidi? ( >=dev-libs/fribidi-0.10.4 )
67 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) ) 67 cddb? ( >=media-libs/libcddb-1.2.0 )
68 dbus? ( >=sys-apps/dbus-1.0.2 ) 68 dbus? ( >=sys-apps/dbus-1.0.2 )
69 dc1394? ( >=sys-libs/libraw1394-2.0.1 >=media-libs/libdc1394-2.0.2 ) 69 dc1394? ( >=sys-libs/libraw1394-2.0.1 >=media-libs/libdc1394-2.0.2 )
70 dirac? ( >=media-video/dirac-0.10.0 ) 70 dirac? ( >=media-video/dirac-0.10.0 )
71 directfb? ( dev-libs/DirectFB sys-libs/zlib ) 71 directfb? ( dev-libs/DirectFB sys-libs/zlib )
72 dts? ( media-libs/libdca ) 72 dts? ( media-libs/libdca )
77 fluidsynth? ( media-sound/fluidsynth ) 77 fluidsynth? ( media-sound/fluidsynth )
78 fontconfig? ( media-libs/fontconfig ) 78 fontconfig? ( media-libs/fontconfig )
79 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 ) 79 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
80 gme? ( media-libs/game-music-emu ) 80 gme? ( media-libs/game-music-emu )
81 gnome? ( gnome-base/gnome-vfs ) 81 gnome? ( gnome-base/gnome-vfs )
82 gnutls? ( >=net-libs/gnutls-1.7.4 >=dev-libs/libgcrypt-1.2.0 ) 82 gnutls? ( >=net-libs/gnutls-1.7.4 )
83 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 ) 83 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
84 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 ) 84 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
85 kate? ( >=media-libs/libkate-0.1.1 ) 85 kate? ( >=media-libs/libkate-0.1.1 )
86 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig ) 86 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
87 libcaca? ( >=media-libs/libcaca-0.99_beta14 ) 87 libcaca? ( >=media-libs/libcaca-0.99_beta14 )
97 mpeg? ( >=media-libs/libmpeg2-0.3.2 ) 97 mpeg? ( >=media-libs/libmpeg2-0.3.2 )
98 mtp? ( >=media-libs/libmtp-1.0.0 ) 98 mtp? ( >=media-libs/libmtp-1.0.0 )
99 musepack? ( >=media-sound/musepack-tools-444 ) 99 musepack? ( >=media-sound/musepack-tools-444 )
100 ncurses? ( sys-libs/ncurses ) 100 ncurses? ( sys-libs/ncurses )
101 ogg? ( media-libs/libogg ) 101 ogg? ( media-libs/libogg )
102 opengl? ( virtual/opengl || ( <x11-libs/libX11-1.3.99.901[xcb] >=x11-libs/libX11-1.3.99.901 ) ) 102 opengl? ( virtual/opengl || ( >=x11-libs/libX11-1.3.99.901 <x11-libs/libX11-1.3.99.901[xcb] ) )
103 png? ( media-libs/libpng sys-libs/zlib ) 103 png? ( media-libs/libpng sys-libs/zlib )
104 projectm? ( media-libs/libprojectm ) 104 projectm? ( media-libs/libprojectm )
105 pulseaudio? ( >=media-sound/pulseaudio-0.9.22 ) 105 pulseaudio? ( >=media-sound/pulseaudio-0.9.22 )
106 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 ) 106 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
107 samba? ( || ( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-3.4 ) ) 107 samba? ( || ( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-3.4 ) )
108 schroedinger? ( >=media-libs/schroedinger-1.0.6 ) 108 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
109 sdl? ( >=media-libs/libsdl-1.2.8 109 sdl? ( >=media-libs/libsdl-1.2.8
110 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) ) 110 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
111 shout? ( media-libs/libshout ) 111 shout? ( media-libs/libshout )
112 sid? ( media-libs/libsidplay:2 ) 112 sid? ( media-libs/libsidplay:2 )
113 skins? (
114 x11-libs/qt-gui:4 x11-libs/qt-core:4
115 x11-libs/libXext x11-libs/libX11
116 media-libs/freetype media-fonts/dejavu
117 )
118 speex? ( media-libs/speex ) 113 speex? ( media-libs/speex )
119 sqlite? ( >=dev-db/sqlite-3.6.0:3 ) 114 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
120 svg? ( >=gnome-base/librsvg-2.9.0 ) 115 svg? ( >=gnome-base/librsvg-2.9.0 )
121 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib ) 116 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
122 theora? ( >=media-libs/libtheora-1.0_beta3 ) 117 theora? ( >=media-libs/libtheora-1.0_beta3 )
123 truetype? ( media-libs/freetype media-fonts/dejavu ) 118 truetype? ( media-libs/freetype media-fonts/dejavu )
124 twolame? ( media-sound/twolame ) 119 twolame? ( media-sound/twolame )
125 udev? ( >=sys-fs/udev-142 ) 120 udev? ( >=sys-fs/udev-142 )
126 upnp? ( net-libs/libupnp ) 121 upnp? ( net-libs/libupnp )
127 v4l2? ( libv4l2? ( media-libs/libv4l ) ) 122 libv4l2? ( media-libs/libv4l )
128 vaapi? ( x11-libs/libva >=media-video/ffmpeg-0.6 ) 123 vaapi? ( x11-libs/libva )
129 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 ) 124 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 )
130 vorbis? ( media-libs/libvorbis ) 125 vorbis? ( media-libs/libvorbis )
131 win32codecs? ( media-libs/win32codecs ) 126 win32codecs? ( media-libs/win32codecs )
132 X? ( x11-libs/libX11 ) 127 X? ( x11-libs/libX11 )
133 x264? ( >=media-libs/x264-0.0.20090923 ) 128 x264? ( >=media-libs/x264-0.0.20090923 )
144 kde? ( >=kde-base/kdelibs-4 ) 139 kde? ( >=kde-base/kdelibs-4 )
145 v4l2? ( >=sys-kernel/linux-headers-2.6.25 ) 140 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
146 xcb? ( x11-proto/xproto ) 141 xcb? ( x11-proto/xproto )
147 dev-util/pkgconfig" 142 dev-util/pkgconfig"
148 143
144REQUIRED_USE="
145 bidi? ( truetype )
146 cddb? ( cdda )
147 fontconfig? ( truetype )
148 gnutls? ( gcrypt )
149 libtiger? ( kate )
150 libv4l2? ( v4l2 )
151 qt4? ( X )
152 skins? ( truetype qt4 )
153 vaapi? ( ffmpeg )
154 vlm? ( stream )
155 xv? ( xcb )
156"
157
149S="${WORKDIR}/${MY_P}" 158S="${WORKDIR}/${MY_P}"
150
151# Displays a warning if the first use flag is set but the second is not
152vlc_use_needs() {
153 use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
154}
155
156# Notify the user that some useflag have been forced on
157vlc_use_force() {
158 use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
159}
160
161# Use when $1 depends strictly on $2
162# if use $1 then enable $2
163vlc_use_enable_force() {
164 use $1 && echo "--enable-$2"
165}
166
167pkg_setup() {
168 # Useflags we need to forcefuly enable
169 vlc_use_force gnutls gcrypt
170 vlc_use_force skins truetype
171 vlc_use_force skins qt4
172 vlc_use_force vlm stream
173 vlc_use_force vaapi ffmpeg
174
175 # Useflags that will be automagically discarded if deps are not met
176 vlc_use_needs bidi truetype
177 vlc_use_needs cddb cdda
178 vlc_use_needs fontconfig truetype
179 vlc_use_needs libv4l2 v4l2
180 vlc_use_needs libtiger kate
181 vlc_use_needs xv xcb
182
183 if use !qt4 && use !skins ; then
184 ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
185 ewarn "graphical interface. Maybe that is not what you want..."
186 fi
187}
188 159
189src_unpack() { 160src_unpack() {
190 unpack ${A} 161 unpack ${A}
191 if [ "${PV%9999}" != "${PV}" ] ; then 162 if [ "${PV%9999}" != "${PV}" ] ; then
192 git_src_unpack 163 git_src_unpack
203 EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches" 174 EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
204 eautoreconf 175 eautoreconf
205} 176}
206 177
207src_configure() { 178src_configure() {
208
209 # It would fail if -fforce-addr is used due to too few registers...
210 use x86 && filter-flags -fforce-addr
211
212 # needs libresid-builder from libsidplay:2 which is in another directory... 179 # needs libresid-builder from libsidplay:2 which is in another directory...
213 # FIXME! 180 # FIXME!
214 use sid && append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/" 181 use sid && append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
215 182
216 econf \ 183 econf \
311 $(use_enable xv xvideo) \ 278 $(use_enable xv xvideo) \
312 $(use_enable zvbi) $(use_enable !zvbi telx) \ 279 $(use_enable zvbi) $(use_enable !zvbi telx) \
313 --disable-snapshot \ 280 --disable-snapshot \
314 --disable-growl \ 281 --disable-growl \
315 --disable-optimizations \ 282 --disable-optimizations \
316 --enable-fast-install \ 283 --enable-fast-install
317 $(vlc_use_enable_force vlm sout) \
318 $(vlc_use_enable_force skins qt4) \
319 $(vlc_use_enable_force skins freetype) \
320 $(vlc_use_enable_force gnutls libgcrypt) \
321 $(vlc_use_enable_force vaapi avcodec)
322} 284}
323 285
324src_install() { 286src_install() {
325 emake DESTDIR="${D}" install || die "make install failed" 287 emake DESTDIR="${D}" install || die "make install failed"
326 288
330 # Punt useless libtool's .la files 292 # Punt useless libtool's .la files
331 find "${D}" -name '*.la' -delete 293 find "${D}" -name '*.la' -delete
332} 294}
333 295
334pkg_postinst() { 296pkg_postinst() {
335 gnome2_pkg_postinst
336
337 if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then 297 if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
338 einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/" 298 einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
339 "/usr/$(get_libdir)/vlc/vlc-cache-gen" -f "/usr/$(get_libdir)/vlc/plugins/" 299 "/usr/$(get_libdir)/vlc/vlc-cache-gen" -f "/usr/$(get_libdir)/vlc/plugins/"
340 else 300 else
341 ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)" 301 ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"

Legend:
Removed from v.1.103  
changed lines
  Added in v.1.105

  ViewVC Help
Powered by ViewVC 1.1.20