/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.2 Revision 1.16
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.2 2009/03/08 18:17:28 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.16 2009/06/28 19:33:36 pva Exp $
4 4
5EAPI="1" 5EAPI="1"
6
7WANT_AUTOMAKE=latest
8WANT_AUTOCONF=latest
9 6
10SCM="" 7SCM=""
11if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
12 SCM=git 9 SCM=git
13 EGIT_REPO_URI="git://git.videolan.org/vlc.git" 10 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
48LICENSE="GPL-2" 45LICENSE="GPL-2"
49SLOT="0" 46SLOT="0"
50 47
51KEYWORDS="" 48KEYWORDS=""
52IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394 49IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394
53 debug dirac directfb dts dvb dvd fbcon fluidsynth +ffmpeg flac fontconfig ggi gnome gnutls hal httpd 50 debug dirac directfb dts dvb dvd fbcon fluidsynth +ffmpeg flac fontconfig +gcrypt ggi gnome gnutls hal httpd
54 id3tag jack kate libass libcaca +libgcrypt libnotify libsysfs libv4l2 lirc live lua matroska mmx modplug mp3 mpeg mtp 51 id3tag jack kate libass libcaca libnotify libproxy libsysfs libv4l2 lirc live lua matroska mmx modplug mp3 mpeg mtp
55 musepack ncurses nsplugin ogg opengl optimisememory oss pda png pulseaudio pvr +qt4 52 musepack ncurses nsplugin ogg opengl optimisememory oss pda png pulseaudio pvr +qt4
56 remoteosd rtsp run-as-root samba schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream svg svga taglib 53 remoteosd rtsp run-as-root samba schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream svg svga taglib
57 theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs wma-fixed 54 theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs wma-fixed
58 X x264 xcb xinerama xml xosd xv zvbi" 55 X x264 xcb xinerama xml xosd xv zvbi"
59 56
82 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 ) 79 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
83 flac? ( media-libs/libogg 80 flac? ( media-libs/libogg
84 >=media-libs/flac-1.1.2 ) 81 >=media-libs/flac-1.1.2 )
85 fluidsynth? ( media-sound/fluidsynth ) 82 fluidsynth? ( media-sound/fluidsynth )
86 fontconfig? ( media-libs/fontconfig ) 83 fontconfig? ( media-libs/fontconfig )
84 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
87 ggi? ( media-libs/libggi ) 85 ggi? ( media-libs/libggi )
88 gnome? ( gnome-base/gnome-vfs ) 86 gnome? ( gnome-base/gnome-vfs )
89 gnutls? ( >=net-libs/gnutls-1.3.3 ) 87 gnutls? ( >=net-libs/gnutls-1.7.4 )
90 hal? ( sys-apps/hal ) 88 hal? ( sys-apps/hal )
91 id3tag? ( media-libs/libid3tag 89 id3tag? ( media-libs/libid3tag
92 sys-libs/zlib ) 90 sys-libs/zlib )
93 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 ) 91 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
94 kate? ( >=media-libs/libkate-0.1.1 ) 92 kate? ( >=media-libs/libkate-0.1.1 )
95 libass? ( >=media-libs/libass-0.9.5 media-libs/fontconfig ) 93 libass? ( >=media-libs/libass-0.9.5 media-libs/fontconfig )
96 libcaca? ( media-libs/libcaca ) 94 libcaca? ( media-libs/libcaca )
97 libgcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
98 libnotify? ( x11-libs/libnotify ) 95 libnotify? ( x11-libs/libnotify )
96 libproxy? ( net-libs/libproxy )
99 libsysfs? ( sys-fs/sysfsutils ) 97 libsysfs? ( sys-fs/sysfsutils )
100 lirc? ( app-misc/lirc ) 98 lirc? ( app-misc/lirc )
101 live? ( >=media-plugins/live-2008.07.06 ) 99 live? ( >=media-plugins/live-2008.07.06 )
102 lua? ( >=dev-lang/lua-5.1 ) 100 lua? ( >=dev-lang/lua-5.1 )
103 matroska? ( 101 matroska? (
114 !seamonkey? ( >=net-libs/xulrunner-1.8 ) 112 !seamonkey? ( >=net-libs/xulrunner-1.8 )
115 ) 113 )
116 ogg? ( media-libs/libogg ) 114 ogg? ( media-libs/libogg )
117 pda? ( x11-libs/gtk+:2 ) 115 pda? ( x11-libs/gtk+:2 )
118 png? ( media-libs/libpng ) 116 png? ( media-libs/libpng )
119 pulseaudio? ( >=media-sound/pulseaudio-0.9.8 ) 117 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
120 qt4? ( || ( ( x11-libs/qt-gui x11-libs/qt-core ) =x11-libs/qt-4.3*:4 ) ) 118 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
121 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 ) 119 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
122 samba? ( net-fs/samba ) 120 samba? ( net-fs/samba )
123 schroedinger? ( >=media-libs/schroedinger-1.0 ) 121 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
124 sdl? ( >=media-libs/libsdl-1.2.8 122 sdl? ( >=media-libs/libsdl-1.2.8
125 sdl-image? ( media-libs/sdl-image ) ) 123 sdl-image? ( media-libs/sdl-image ) )
126 shout? ( media-libs/libshout ) 124 shout? ( media-libs/libshout )
127 skins? ( || ( ( x11-libs/qt-gui x11-libs/qt-core ) =x11-libs/qt-4.3*:4 ) ) 125 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
128 speex? ( media-libs/speex ) 126 speex? ( media-libs/speex )
129 svg? ( >=gnome-base/librsvg-2.9.0 ) 127 svg? ( >=gnome-base/librsvg-2.9.0 )
130 svga? ( media-libs/svgalib ) 128 svga? ( media-libs/svgalib )
131 taglib? ( media-libs/taglib ) 129 taglib? ( >=media-libs/taglib-1.5 )
132 theora? ( media-libs/libtheora ) 130 theora? ( >=media-libs/libtheora-1.0_beta3 )
133 truetype? ( media-libs/freetype 131 truetype? ( media-libs/freetype
134 media-fonts/ttf-bitstream-vera ) 132 media-fonts/ttf-bitstream-vera )
135 twolame? ( media-sound/twolame ) 133 twolame? ( media-sound/twolame )
136 upnp? ( net-libs/libupnp ) 134 upnp? ( net-libs/libupnp )
137 v4l2? ( libv4l2? ( media-libs/libv4l ) ) 135 v4l2? ( libv4l2? ( media-libs/libv4l ) )
164 xcb? ( x11-proto/xproto ) 162 xcb? ( x11-proto/xproto )
165 dev-util/pkgconfig" 163 dev-util/pkgconfig"
166 164
167S="${WORKDIR}/${MY_P}" 165S="${WORKDIR}/${MY_P}"
168 166
169# Dispalys a warning if the first use flag is set but not the second 167# Displays a warning if the first use flag is set but the second is not
170vlc_use_needs() { 168vlc_use_needs() {
171 use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled." 169 use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
172} 170}
173 171
174# Notify the user that some useflag have been forced on 172# Notify the user that some useflag have been forced on
185 echo "--disable-$2" 183 echo "--disable-$2"
186 fi 184 fi
187} 185}
188 186
189pkg_setup() { 187pkg_setup() {
188 if has_version '<=media-video/vlc-0.9.9999'; then
189 eerror "Please unmerge vlc-0.9.x first before installing ${P}"
190 eerror "If you don't do that, some plugins will get linked against"
191 eerror "the old ${PN} version and will not work."
192 die "Unmerge vlc 0.9.x first"
193 fi
190 vlc_use_needs skins truetype 194 vlc_use_needs skins truetype
191 vlc_use_force skins qt4 195 vlc_use_force skins qt4
192 vlc_use_needs cddax cdio 196 vlc_use_needs cddax cdio
193 vlc_use_needs vcdx cdio 197 vlc_use_needs vcdx cdio
194 vlc_use_needs vcdx vcdinfo 198 vlc_use_needs vcdx vcdinfo
195 vlc_use_needs vcdinfo cdio 199 vlc_use_needs vcdinfo cdio
196 vlc_use_needs bidi truetype 200 vlc_use_needs bidi truetype
197 vlc_use_force remoteosd libgcrypt 201 vlc_use_force remoteosd gcrypt
198 vlc_use_needs fontconfig truetype 202 vlc_use_needs fontconfig truetype
199 vlc_use_needs libv4l2 v4l2 203 vlc_use_needs libv4l2 v4l2
200 use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled." 204 use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
201 if ( use qt4 || use skins ) ; then 205 if use qt4 || use skins ; then
202 QT4_BUILT_WITH_USE_CHECK="png" qt4_pkg_setup 206 qt4_pkg_setup
203 else 207 else
204 ewarn "You have disabled the qt4 useflag, ${PN} will not have any" 208 ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
205 ewarn "graphical interface. Maybe that is not what you want..." 209 ewarn "graphical interface. Maybe that is not what you want..."
206 fi 210 fi
207} 211}
208 212
209src_unpack() { 213src_unpack() {
210 unpack ${A} 214 unpack ${A}
211 if [ "${PV%9999}" != "${PV}" ] ; then 215 if [ "${PV%9999}" != "${PV}" ] ; then
212 git_src_unpack 216 git_src_unpack
213 else 217 fi
214 cd "${S}" 218 cd "${S}"
215 fi
216 219
217 # Make it build with libtool 1.5 220 # Make it build with libtool 1.5
218 rm -f m4/lt* m4/libtool.m4 221 rm -f m4/lt* m4/libtool.m4
219 222
220 EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches" 223 EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
263 $(use_enable dts dca) \ 266 $(use_enable dts dca) \
264 --disable-dv \ 267 --disable-dv \
265 $(use_enable dvb) \ 268 $(use_enable dvb) \
266 $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \ 269 $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
267 $(use_enable fbcon fb) \ 270 $(use_enable fbcon fb) \
268 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) --disable-imgresample $(use_enable ffmpeg postproc) \ 271 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
269 $(use_enable flac) \ 272 $(use_enable flac) \
270 $(use_enable fluidsynth) \ 273 $(use_enable fluidsynth) \
271 $(use_enable fontconfig) \ 274 $(use_enable fontconfig) \
272 $(use_enable ggi) \ 275 $(use_enable ggi) \
273 $(use_enable gnome gnomevfs) \ 276 $(use_enable gnome gnomevfs) \
277 $(use_enable id3tag) \ 280 $(use_enable id3tag) \
278 $(use_enable jack) \ 281 $(use_enable jack) \
279 $(use_enable kate) \ 282 $(use_enable kate) \
280 $(use_enable libass) \ 283 $(use_enable libass) \
281 $(use_enable libcaca caca) \ 284 $(use_enable libcaca caca) \
282 $(use_enable libgcrypt) \ 285 $(use_enable gcrypt libgcrypt) \
283 $(use_enable libnotify notify) \ 286 $(use_enable libnotify notify) \
284 --disable-libproxy \ 287 $(use_enable libproxy) \
285 --disable-libtar \ 288 --disable-libtar \
286 $(use_enable libsysfs) \ 289 $(use_enable libsysfs) \
287 $(use_enable libv4l2) \ 290 $(use_enable libv4l2) \
288 $(use_enable lirc) \ 291 $(use_enable lirc) \
289 $(use_enable live live555) \ 292 $(use_enable live live555) \

Legend:
Removed from v.1.2  
changed lines
  Added in v.1.16

  ViewVC Help
Powered by ViewVC 1.1.20