/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.22 Revision 1.28
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.22 2009/07/21 09:24:59 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.28 2009/07/27 07:14:05 aballier Exp $
4 4
5EAPI="2" 5EAPI="2"
6 6
7SCM="" 7SCM=""
8if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
21MY_PV="${PV/_/-}" 21MY_PV="${PV/_/-}"
22MY_PV="${MY_PV/-beta/-test}" 22MY_PV="${MY_PV/-beta/-test}"
23MY_P="${PN}-${MY_PV}" 23MY_P="${PN}-${MY_PV}"
24VLC_SNAPSHOT_TIME="0013" 24VLC_SNAPSHOT_TIME="0013"
25 25
26PATCHLEVEL="63" 26PATCHLEVEL="68"
27M4_TARBALL_VERSION="1" 27M4_TARBALL_VERSION="1"
28DESCRIPTION="VLC media player - Video player and streamer" 28DESCRIPTION="VLC media player - Video player and streamer"
29HOMEPAGE="http://www.videolan.org/vlc/" 29HOMEPAGE="http://www.videolan.org/vlc/"
30if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild 30if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31 SRC_URI="" 31 SRC_URI=""
55 schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream 55 schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream
56 svg svga taglib theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm 56 svg svga taglib theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm
57 vorbis win32codecs wma-fixed X x264 xcb xinerama xml xosd xv zvbi" 57 vorbis win32codecs wma-fixed X x264 xcb xinerama xml xosd xv zvbi"
58 58
59RDEPEND=" 59RDEPEND="
60 !!<=media-video/vlc-1.0.99999
60 sys-libs/zlib 61 sys-libs/zlib
61 >=media-libs/libdvbpsi-0.1.6 62 >=media-libs/libdvbpsi-0.1.6
62 a52? ( >=media-libs/a52dec-0.7.4-r3 ) 63 a52? ( >=media-libs/a52dec-0.7.4-r3 )
63 aalib? ( media-libs/aalib ) 64 aalib? ( media-libs/aalib )
64 aac? ( >=media-libs/faad2-2.6.1 ) 65 aac? ( >=media-libs/faad2-2.6.1 )
107 >=media-libs/libmatroska-0.8.0 ) 108 >=media-libs/libmatroska-0.8.0 )
108 modplug? ( media-libs/libmodplug ) 109 modplug? ( media-libs/libmodplug )
109 mp3? ( media-libs/libmad ) 110 mp3? ( media-libs/libmad )
110 mpeg? ( >=media-libs/libmpeg2-0.3.2 ) 111 mpeg? ( >=media-libs/libmpeg2-0.3.2 )
111 mtp? ( >=media-libs/libmtp-0.3.0 ) 112 mtp? ( >=media-libs/libmtp-0.3.0 )
113 musepack? ( || ( >=media-sound/musepack-tools-444
112 musepack? ( media-libs/libmpcdec ) 114 media-libs/libmpcdec ) )
113 ncurses? ( sys-libs/ncurses ) 115 ncurses? ( sys-libs/ncurses )
114 nsplugin? ( 116 nsplugin? (
115 seamonkey? ( =www-client/seamonkey-1* ) 117 seamonkey? ( =www-client/seamonkey-1* )
116 !seamonkey? ( >=net-libs/xulrunner-1.8 ) 118 !seamonkey? ( >=net-libs/xulrunner-1.8 )
117 ) 119 )
132 svg? ( >=gnome-base/librsvg-2.9.0 ) 134 svg? ( >=gnome-base/librsvg-2.9.0 )
133 svga? ( media-libs/svgalib ) 135 svga? ( media-libs/svgalib )
134 taglib? ( >=media-libs/taglib-1.5 ) 136 taglib? ( >=media-libs/taglib-1.5 )
135 theora? ( >=media-libs/libtheora-1.0_beta3 ) 137 theora? ( >=media-libs/libtheora-1.0_beta3 )
136 truetype? ( media-libs/freetype 138 truetype? ( media-libs/freetype
137 media-fonts/ttf-bitstream-vera ) 139 media-fonts/dejavu )
138 twolame? ( media-sound/twolame ) 140 twolame? ( media-sound/twolame )
139 upnp? ( net-libs/libupnp ) 141 upnp? ( net-libs/libupnp )
140 v4l2? ( libv4l2? ( media-libs/libv4l ) ) 142 v4l2? ( libv4l2? ( media-libs/libv4l ) )
141 vcdinfo? ( >=media-video/vcdimager-0.7.22 ) 143 vcdinfo? ( >=media-video/vcdimager-0.7.22 )
142 vorbis? ( media-libs/libvorbis ) 144 vorbis? ( media-libs/libvorbis )
160# Will probably compile only on x86 162# Will probably compile only on x86
161 163
162DEPEND="${RDEPEND} 164DEPEND="${RDEPEND}
163 dvb? ( sys-kernel/linux-headers ) 165 dvb? ( sys-kernel/linux-headers )
164 v4l? ( sys-kernel/linux-headers ) 166 v4l? ( sys-kernel/linux-headers )
165 v4l2? ( sys-kernel/linux-headers ) 167 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
166 X? ( xinerama? ( x11-proto/xineramaproto ) ) 168 X? ( xinerama? ( x11-proto/xineramaproto ) )
167 xcb? ( x11-proto/xproto ) 169 xcb? ( x11-proto/xproto )
168 dev-util/pkgconfig" 170 dev-util/pkgconfig"
169 171
170S="${WORKDIR}/${MY_P}" 172S="${WORKDIR}/${MY_P}"
188 echo "--disable-$2" 190 echo "--disable-$2"
189 fi 191 fi
190} 192}
191 193
192pkg_setup() { 194pkg_setup() {
193 if has_version '<=media-video/vlc-0.9.9999'; then 195 if has_version '<=media-video/vlc-1.0.99999'; then
194 eerror "Please unmerge vlc-0.9.x first before installing ${P}" 196 eerror "Please unmerge vlc-1.0.x first before installing ${P}"
195 eerror "If you don't do that, some plugins will get linked against" 197 eerror "If you don't do that, some plugins will get linked against"
196 eerror "the old ${PN} version and will not work." 198 eerror "the old ${PN} version and will not work."
197 die "Unmerge vlc 0.9.x first" 199 die "Unmerge vlc 1.0.x first"
198 fi 200 fi
199 vlc_use_needs skins truetype 201 vlc_use_needs skins truetype
200 vlc_use_force skins qt4 202 vlc_use_force skins qt4
201 vlc_use_needs cddax cdio 203 vlc_use_needs cddax cdio
202 vlc_use_needs vcdx cdio 204 vlc_use_needs vcdx cdio
354 $(use_enable xinerama) \ 356 $(use_enable xinerama) \
355 $(use_enable xml libxml2) \ 357 $(use_enable xml libxml2) \
356 $(use_enable xosd) \ 358 $(use_enable xosd) \
357 $(use_enable xv xvideo) \ 359 $(use_enable xv xvideo) \
358 --disable-xvmc \ 360 --disable-xvmc \
359 $(use_enable zvbi) \ 361 $(use_enable zvbi) $(use_enable !zvbi telx) \
360 --disable-snapshot \ 362 --disable-snapshot \
361 --disable-growl \ 363 --disable-growl \
362 --disable-optimizations \ 364 --disable-optimizations \
363 --enable-fast-install \ 365 --enable-fast-install \
364 $(vlc_use_enable_force vlm vlm sout) \ 366 $(vlc_use_enable_force vlm vlm sout) \

Legend:
Removed from v.1.22  
changed lines
  Added in v.1.28

  ViewVC Help
Powered by ViewVC 1.1.20