/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.60 Revision 1.69
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.60 2010/02/23 10:48:06 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.69 2010/04/23 16:18:09 aballier Exp $
4 4
5EAPI="2" 5EAPI="2"
6 6
7SCM="" 7SCM=""
8if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
22MY_PV="${PV/_/-}" 22MY_PV="${PV/_/-}"
23MY_PV="${MY_PV/-beta/-test}" 23MY_PV="${MY_PV/-beta/-test}"
24MY_P="${PN}-${MY_PV}" 24MY_P="${PN}-${MY_PV}"
25VLC_SNAPSHOT_TIME="0013" 25VLC_SNAPSHOT_TIME="0013"
26 26
27PATCHLEVEL="80" 27PATCHLEVEL="85"
28DESCRIPTION="VLC media player - Video player and streamer" 28DESCRIPTION="VLC media player - Video player and streamer"
29HOMEPAGE="http://www.videolan.org/vlc/" 29HOMEPAGE="http://www.videolan.org/vlc/"
30if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild 30if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31 SRC_URI="" 31 SRC_URI=""
32elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org 32elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org
45SLOT="0" 45SLOT="0"
46 46
47KEYWORDS="" 47KEYWORDS=""
48IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddb dbus dc1394 48IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddb dbus dc1394
49 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig 49 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
50 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate libass libcaca 50 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate kde libass libcaca
51 libnotify libproxy libtiger libv4l libv4l2 lirc live lua matroska mmx 51 libnotify libproxy libtiger libv4l libv4l2 lirc live lua matroska mmx
52 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss 52 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
53 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba 53 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
54 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream 54 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream
55 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vcdx vlm 55 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vcdx vlm
61 >=media-libs/libdvbpsi-0.1.6 61 >=media-libs/libdvbpsi-0.1.6
62 a52? ( >=media-libs/a52dec-0.7.4-r3 ) 62 a52? ( >=media-libs/a52dec-0.7.4-r3 )
63 aalib? ( media-libs/aalib ) 63 aalib? ( media-libs/aalib )
64 aac? ( >=media-libs/faad2-2.6.1 ) 64 aac? ( >=media-libs/faad2-2.6.1 )
65 alsa? ( media-libs/alsa-lib ) 65 alsa? ( media-libs/alsa-lib )
66 avahi? ( >=net-dns/avahi-0.6 ) 66 avahi? ( >=net-dns/avahi-0.6[dbus] )
67 bidi? ( >=dev-libs/fribidi-0.10.4 ) 67 bidi? ( >=dev-libs/fribidi-0.10.4 )
68 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) ) 68 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
69 dbus? ( >=sys-apps/dbus-1.0.2 ) 69 dbus? ( >=sys-apps/dbus-1.0.2 )
70 dc1394? ( >=sys-libs/libraw1394-2.0.1 70 dc1394? ( >=sys-libs/libraw1394-2.0.1
71 >=media-libs/libdc1394-2.0.2 ) 71 >=media-libs/libdc1394-2.0.2 )
104 mp3? ( media-libs/libmad ) 104 mp3? ( media-libs/libmad )
105 mpeg? ( >=media-libs/libmpeg2-0.3.2 ) 105 mpeg? ( >=media-libs/libmpeg2-0.3.2 )
106 mtp? ( >=media-libs/libmtp-0.3.0 ) 106 mtp? ( >=media-libs/libmtp-0.3.0 )
107 musepack? ( >=media-sound/musepack-tools-444 ) 107 musepack? ( >=media-sound/musepack-tools-444 )
108 ncurses? ( sys-libs/ncurses ) 108 ncurses? ( sys-libs/ncurses )
109 nsplugin? ( >=net-libs/xulrunner-1.8 x11-libs/libXpm x11-libs/libXt <net-libs/xulrunner-1.9.2 ) 109 nsplugin? ( >=net-libs/xulrunner-1.9.2 x11-libs/libXpm x11-libs/libXt )
110 ogg? ( media-libs/libogg ) 110 ogg? ( media-libs/libogg )
111 opengl? ( virtual/opengl ) 111 opengl? ( virtual/opengl )
112 png? ( media-libs/libpng sys-libs/zlib ) 112 png? ( media-libs/libpng sys-libs/zlib )
113 projectm? ( media-libs/libprojectm ) 113 projectm? ( media-libs/libprojectm )
114 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 ) 114 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
115 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 ) 115 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
116 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 ) 116 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
117 samba? ( || ( >=net-fs/samba-libs-3.4[smbclient] 117 samba? ( || ( >=net-fs/samba-3.4.6[smbclient]
118 <net-fs/samba-3.4 ) ) 118 <net-fs/samba-3.4 ) )
119 schroedinger? ( >=media-libs/schroedinger-1.0.6 ) 119 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
120 sdl? ( >=media-libs/libsdl-1.2.8 120 sdl? ( >=media-libs/libsdl-1.2.8
121 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) ) 121 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
122 shout? ( media-libs/libshout ) 122 shout? ( media-libs/libshout )
123 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 ) 123 skins? (
124 x11-libs/qt-gui:4 x11-libs/qt-core:4
125 x11-libs/libXext x11-libs/libX11
126 media-libs/freetype media-fonts/dejavu
127 )
124 speex? ( media-libs/speex ) 128 speex? ( media-libs/speex )
125 sqlite? ( >=dev-db/sqlite-3.6.0:3 ) 129 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
126 svg? ( >=gnome-base/librsvg-2.9.0 ) 130 svg? ( >=gnome-base/librsvg-2.9.0 )
127 svga? ( media-libs/svgalib ) 131 svga? ( media-libs/svgalib )
128 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib ) 132 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
144 zvbi? ( >=media-libs/zvbi-0.2.25 ) 148 zvbi? ( >=media-libs/zvbi-0.2.25 )
145 " 149 "
146 150
147DEPEND="${RDEPEND} 151DEPEND="${RDEPEND}
148 dvb? ( sys-kernel/linux-headers ) 152 dvb? ( sys-kernel/linux-headers )
153 kde? ( >=kde-base/kdelibs-4 )
149 v4l? ( sys-kernel/linux-headers ) 154 v4l? ( sys-kernel/linux-headers )
150 v4l2? ( >=sys-kernel/linux-headers-2.6.25 ) 155 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
151 xcb? ( x11-proto/xproto ) 156 xcb? ( x11-proto/xproto )
152 dev-util/pkgconfig" 157 dev-util/pkgconfig"
153 158
161# Notify the user that some useflag have been forced on 166# Notify the user that some useflag have been forced on
162vlc_use_force() { 167vlc_use_force() {
163 use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled." 168 use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
164} 169}
165 170
166# Use when $2 depends strictly on $3 171# Use when $1 depends strictly on $2
167# if use $1 then enable $2 and $3, otherwise disable $2 172# if use $1 then enable $2
168vlc_use_enable_force() { 173vlc_use_enable_force() {
169 if use $1 ; then 174 use $1 && echo "--enable-$2"
170 echo "--enable-$2 --enable-$3"
171 else
172 echo "--disable-$2"
173 fi
174} 175}
175 176
176pkg_setup() { 177pkg_setup() {
177 if has_version '<=media-video/vlc-1.0.99999'; then 178 if has_version '<=media-video/vlc-1.0.99999'; then
178 eerror "Please unmerge vlc-1.0.x first before installing ${P}" 179 eerror "Please unmerge vlc-1.0.x first before installing ${P}"
179 eerror "If you don't do that, some plugins will get linked against" 180 eerror "If you don't do that, some plugins will get linked against"
180 eerror "the old ${PN} version and will not work." 181 eerror "the old ${PN} version and will not work."
181 die "Unmerge vlc 1.0.x first" 182 die "Unmerge vlc 1.0.x first"
182 fi 183 fi
184
185 # Useflags we need to forcefuly enable
186 vlc_use_force remoteosd gcrypt
183 vlc_use_needs skins truetype 187 vlc_use_force skins truetype
184 vlc_use_force skins qt4 188 vlc_use_force skins qt4
189 vlc_use_force vlm stream
190
191 # Useflags that will be automagically discarded if deps are not met
185 vlc_use_needs bidi truetype 192 vlc_use_needs bidi truetype
186 vlc_use_force remoteosd gcrypt 193 vlc_use_needs cddb cdda
187 vlc_use_needs fontconfig truetype 194 vlc_use_needs fontconfig truetype
188 vlc_use_needs libv4l2 v4l2 195 vlc_use_needs libv4l2 v4l2
189 vlc_use_needs libv4l v4l 196 vlc_use_needs libv4l v4l
190 vlc_use_needs libtiger kate 197 vlc_use_needs libtiger kate
191 vlc_use_needs xv xcb 198 vlc_use_needs xv xcb
192 vlc_use_needs cddb cdda 199
193 if use qt4 || use skins ; then 200 if use qt4 || use skins ; then
194 qt4_pkg_setup 201 qt4_pkg_setup
195 else 202 else
196 ewarn "You have disabled the qt4 useflag, ${PN} will not have any" 203 ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
197 ewarn "graphical interface. Maybe that is not what you want..." 204 ewarn "graphical interface. Maybe that is not what you want..."
218 225
219src_configure() { 226src_configure() {
220 227
221 # It would fail if -fforce-addr is used due to too few registers... 228 # It would fail if -fforce-addr is used due to too few registers...
222 use x86 && filter-flags -fforce-addr 229 use x86 && filter-flags -fforce-addr
223
224 local MOZILLA_PC
225
226 if use nsplugin; then
227 if has_version 'net-libs/xulrunner:1.9' ; then
228 MOZILLA_PC=libxul
229 else
230 MOZILLA_PC=xulrunner-plugin
231 fi
232 fi
233 230
234 econf \ 231 econf \
235 $(use_enable a52) \ 232 $(use_enable a52) \
236 $(use_enable aalib aa) \ 233 $(use_enable aalib aa) \
237 $(use_enable aac faad) \ 234 $(use_enable aac faad) \
262 $(use_enable httpd) \ 259 $(use_enable httpd) \
263 $(use_enable id3tag) \ 260 $(use_enable id3tag) \
264 $(use_enable ieee1394 dv) \ 261 $(use_enable ieee1394 dv) \
265 $(use_enable jack) \ 262 $(use_enable jack) \
266 $(use_enable kate) \ 263 $(use_enable kate) \
264 $(use_with kde kde-solid) \
267 $(use_enable libass) \ 265 $(use_enable libass) \
268 $(use_enable libcaca caca) \ 266 $(use_enable libcaca caca) \
269 $(use_enable gcrypt libgcrypt) \ 267 $(use_enable gcrypt libgcrypt) \
270 $(use_enable libnotify notify) \ 268 $(use_enable libnotify notify) \
271 $(use_enable libproxy) \ 269 $(use_enable libproxy) \
282 $(use_enable mp3 mad) \ 280 $(use_enable mp3 mad) \
283 $(use_enable mpeg libmpeg2) \ 281 $(use_enable mpeg libmpeg2) \
284 $(use_enable mtp) \ 282 $(use_enable mtp) \
285 $(use_enable musepack mpc) \ 283 $(use_enable musepack mpc) \
286 $(use_enable ncurses) \ 284 $(use_enable ncurses) \
287 $(use_enable nsplugin mozilla) --with-mozilla-pkg="${MOZILLA_PC}" \ 285 $(use_enable nsplugin mozilla) --with-mozilla-pkg=libxul \
288 $(use_enable ogg) \ 286 $(use_enable ogg) \
289 $(use_enable opengl glx) $(use_enable opengl) \ 287 $(use_enable opengl glx) $(use_enable opengl) \
290 $(use_enable optimisememory optimize-memory) \ 288 $(use_enable optimisememory optimize-memory) \
291 $(use_enable oss) \ 289 $(use_enable oss) \
292 $(use_enable png) \ 290 $(use_enable png) \
293 --disable-portaudio \ 291 --disable-portaudio \
294 $(use_enable projectm) \ 292 $(use_enable projectm) \
295 $(use_enable pulseaudio pulse) \ 293 $(use_enable pulseaudio pulse) \
296 $(use_enable pvr) \ 294 $(use_enable pvr) \
297 $(use_enable qt4) \ 295 $(use_enable qt4) \
296 $(use_enable remoteosd) \
298 $(use_enable rtsp realrtsp) \ 297 $(use_enable rtsp realrtsp) \
299 $(use_enable run-as-root) \ 298 $(use_enable run-as-root) \
300 $(use_enable samba smb) \ 299 $(use_enable samba smb) \
301 $(use_enable schroedinger) \ 300 $(use_enable schroedinger) \
302 $(use_enable sdl) \ 301 $(use_enable sdl) \
317 $(use_enable udev) \ 316 $(use_enable udev) \
318 $(use_enable upnp) \ 317 $(use_enable upnp) \
319 $(use_enable v4l) \ 318 $(use_enable v4l) \
320 $(use_enable v4l2) \ 319 $(use_enable v4l2) \
321 $(use_enable vcdx) \ 320 $(use_enable vcdx) \
321 $(use_enable vlm) \
322 $(use_enable vorbis) \ 322 $(use_enable vorbis) \
323 $(use_enable win32codecs loader) \ 323 $(use_enable win32codecs loader) \
324 $(use_enable wma-fixed) \ 324 $(use_enable wma-fixed) \
325 $(use_enable x264) \ 325 $(use_enable x264) \
326 $(use_enable xcb) \ 326 $(use_enable xcb) \
330 $(use_enable zvbi) $(use_enable !zvbi telx) \ 330 $(use_enable zvbi) $(use_enable !zvbi telx) \
331 --disable-snapshot \ 331 --disable-snapshot \
332 --disable-growl \ 332 --disable-growl \
333 --disable-optimizations \ 333 --disable-optimizations \
334 --enable-fast-install \ 334 --enable-fast-install \
335 $(vlc_use_enable_force vlm vlm sout) \ 335 $(vlc_use_enable_force vlm sout) \
336 $(vlc_use_enable_force skins skins2 qt4) \ 336 $(vlc_use_enable_force skins qt4) \
337 $(vlc_use_enable_force skins freetype) \
337 $(vlc_use_enable_force remoteosd remoteosd libgcrypt) 338 $(vlc_use_enable_force remoteosd libgcrypt)
338} 339}
339 340
340src_install() { 341src_install() {
341 emake DESTDIR="${D}" install || die "make install failed" 342 emake DESTDIR="${D}" install || die "make install failed"
342 343
343 dodoc AUTHORS HACKING THANKS NEWS README \ 344 dodoc AUTHORS HACKING THANKS NEWS README \
344 doc/fortunes.txt doc/intf-cdda.txt doc/intf-vcd.txt 345 doc/fortunes.txt doc/intf-vcd.txt
345 346
346 rm -rf "${D}/usr/share/doc/vlc" \ 347 rm -rf "${D}/usr/share/doc/vlc" \
347 "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico} 348 "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico}
348 349
349 if use nsplugin; then 350 if use nsplugin; then
357 for res in 16 32 48; do 358 for res in 16 32 48; do
358 insinto /usr/share/icons/hicolor/${res}x${res}/apps/ 359 insinto /usr/share/icons/hicolor/${res}x${res}/apps/
359 newins "${S}"/share/vlc${res}x${res}.png vlc.png 360 newins "${S}"/share/vlc${res}x${res}.png vlc.png
360 done 361 done
361} 362}
363
364pkg_postinst() {
365 gnome2_pkg_postinst
366
367 if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
368 einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
369 "/usr/$(get_libdir)/vlc/vlc-cache-gen" "/usr/$(get_libdir)/vlc/plugins/"
370 else
371 ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
372 ewarn "Please run /usr/$(get_libdir)/vlc/vlc-cache-gen manually"
373 ewarn "If you do not do it, vlc will take a long time to load."
374 fi
375}

Legend:
Removed from v.1.60  
changed lines
  Added in v.1.69

  ViewVC Help
Powered by ViewVC 1.1.20