/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.68 Revision 1.72
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.68 2010/04/12 16:36:12 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.72 2010/05/19 07:32:11 aballier Exp $
4 4
5EAPI="2" 5EAPI="2"
6 6
7SCM="" 7SCM=""
8if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
50 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate kde libass libcaca 50 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate kde libass libcaca
51 libnotify libproxy libtiger libv4l libv4l2 lirc live lua matroska mmx 51 libnotify libproxy libtiger libv4l libv4l2 lirc live lua matroska mmx
52 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss 52 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
53 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba 53 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
54 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream 54 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream
55 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vcdx vlm 55 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vaapi vcdx vlm
56 vorbis win32codecs wma-fixed x264 +xcb xml xosd xv zvbi" 56 vorbis win32codecs wma-fixed x264 +xcb xml xosd xv zvbi"
57 57
58RDEPEND=" 58RDEPEND="
59 !!<=media-video/vlc-1.0.99999 59 !!<=media-video/vlc-1.0.99999
60 sys-libs/zlib 60 sys-libs/zlib
61 >=media-libs/libdvbpsi-0.1.6 61 >=media-libs/libdvbpsi-0.1.6
62 a52? ( >=media-libs/a52dec-0.7.4-r3 ) 62 a52? ( >=media-libs/a52dec-0.7.4-r3 )
63 aalib? ( media-libs/aalib ) 63 aalib? ( media-libs/aalib )
64 aac? ( >=media-libs/faad2-2.6.1 ) 64 aac? ( >=media-libs/faad2-2.6.1 )
65 alsa? ( media-libs/alsa-lib ) 65 alsa? ( media-libs/alsa-lib )
66 avahi? ( >=net-dns/avahi-0.6 ) 66 avahi? ( >=net-dns/avahi-0.6[dbus] )
67 bidi? ( >=dev-libs/fribidi-0.10.4 ) 67 bidi? ( >=dev-libs/fribidi-0.10.4 )
68 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) ) 68 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
69 dbus? ( >=sys-apps/dbus-1.0.2 ) 69 dbus? ( >=sys-apps/dbus-1.0.2 )
70 dc1394? ( >=sys-libs/libraw1394-2.0.1 70 dc1394? ( >=sys-libs/libraw1394-2.0.1
71 >=media-libs/libdc1394-2.0.2 ) 71 >=media-libs/libdc1394-2.0.2 )
72 dirac? ( >=media-video/dirac-0.10.0 ) 72 dirac? ( >=media-video/dirac-0.10.0 )
73 directfb? ( dev-libs/DirectFB sys-libs/zlib ) 73 directfb? ( dev-libs/DirectFB sys-libs/zlib )
74 dts? ( media-libs/libdca ) 74 dts? ( media-libs/libdca )
75 dvd? ( media-libs/libdvdread 75 dvd? ( media-libs/libdvdread >=media-libs/libdvdnav-0.1.9 )
76 >=media-libs/libdvdnav-0.1.9
77 media-libs/libdvdplay )
78 elibc_glibc? ( >=sys-libs/glibc-2.8 ) 76 elibc_glibc? ( >=sys-libs/glibc-2.8 )
79 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 ) 77 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
80 flac? ( media-libs/libogg 78 flac? ( media-libs/libogg
81 >=media-libs/flac-1.1.2 ) 79 >=media-libs/flac-1.1.2 )
82 fluidsynth? ( media-sound/fluidsynth ) 80 fluidsynth? ( media-sound/fluidsynth )
109 nsplugin? ( >=net-libs/xulrunner-1.9.2 x11-libs/libXpm x11-libs/libXt ) 107 nsplugin? ( >=net-libs/xulrunner-1.9.2 x11-libs/libXpm x11-libs/libXt )
110 ogg? ( media-libs/libogg ) 108 ogg? ( media-libs/libogg )
111 opengl? ( virtual/opengl ) 109 opengl? ( virtual/opengl )
112 png? ( media-libs/libpng sys-libs/zlib ) 110 png? ( media-libs/libpng sys-libs/zlib )
113 projectm? ( media-libs/libprojectm ) 111 projectm? ( media-libs/libprojectm )
114 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 ) 112 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 x11-libs/libX11 )
115 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 ) 113 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
116 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 ) 114 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
117 samba? ( || ( >=net-fs/samba-3.4.6[smbclient] 115 samba? ( || ( >=net-fs/samba-3.4.6[smbclient]
118 <net-fs/samba-3.4 ) ) 116 <net-fs/samba-3.4 ) )
119 schroedinger? ( >=media-libs/schroedinger-1.0.6 ) 117 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
120 sdl? ( >=media-libs/libsdl-1.2.8 118 sdl? ( >=media-libs/libsdl-1.2.8
121 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) ) 119 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
122 shout? ( media-libs/libshout ) 120 shout? ( media-libs/libshout )
123 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 ) 121 skins? (
122 x11-libs/qt-gui:4 x11-libs/qt-core:4
123 x11-libs/libXext x11-libs/libX11
124 media-libs/freetype media-fonts/dejavu
125 )
124 speex? ( media-libs/speex ) 126 speex? ( media-libs/speex )
125 sqlite? ( >=dev-db/sqlite-3.6.0:3 ) 127 sqlite? ( >=dev-db/sqlite-3.6.0:3 )
126 svg? ( >=gnome-base/librsvg-2.9.0 ) 128 svg? ( >=gnome-base/librsvg-2.9.0 )
127 svga? ( media-libs/svgalib ) 129 svga? ( media-libs/svgalib )
128 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib ) 130 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
132 twolame? ( media-sound/twolame ) 134 twolame? ( media-sound/twolame )
133 udev? ( >=sys-fs/udev-142 ) 135 udev? ( >=sys-fs/udev-142 )
134 upnp? ( net-libs/libupnp ) 136 upnp? ( net-libs/libupnp )
135 v4l2? ( libv4l2? ( media-libs/libv4l ) ) 137 v4l2? ( libv4l2? ( media-libs/libv4l ) )
136 v4l? ( libv4l? ( media-libs/libv4l ) ) 138 v4l? ( libv4l? ( media-libs/libv4l ) )
139 vaapi? ( x11-libs/libva >=media-video/ffmpeg-0.5_p22846 )
137 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 ) 140 vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 )
138 vorbis? ( media-libs/libvorbis ) 141 vorbis? ( media-libs/libvorbis )
139 win32codecs? ( media-libs/win32codecs ) 142 win32codecs? ( media-libs/win32codecs )
140 x264? ( >=media-libs/x264-0.0.20090923 ) 143 x264? ( >=media-libs/x264-0.0.20090923 )
141 xcb? ( x11-libs/libxcb x11-libs/xcb-util ) 144 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
162# Notify the user that some useflag have been forced on 165# Notify the user that some useflag have been forced on
163vlc_use_force() { 166vlc_use_force() {
164 use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled." 167 use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
165} 168}
166 169
167# Use when $2 depends strictly on $3 170# Use when $1 depends strictly on $2
168# if use $1 then enable $2 and $3, otherwise disable $2 171# if use $1 then enable $2
169vlc_use_enable_force() { 172vlc_use_enable_force() {
170 if use $1 ; then 173 use $1 && echo "--enable-$2"
171 echo "--enable-$2 --enable-$3"
172 else
173 echo "--disable-$2"
174 fi
175} 174}
176 175
177pkg_setup() { 176pkg_setup() {
178 if has_version '<=media-video/vlc-1.0.99999'; then 177 if has_version '<=media-video/vlc-1.0.99999'; then
179 eerror "Please unmerge vlc-1.0.x first before installing ${P}" 178 eerror "Please unmerge vlc-1.0.x first before installing ${P}"
180 eerror "If you don't do that, some plugins will get linked against" 179 eerror "If you don't do that, some plugins will get linked against"
181 eerror "the old ${PN} version and will not work." 180 eerror "the old ${PN} version and will not work."
182 die "Unmerge vlc 1.0.x first" 181 die "Unmerge vlc 1.0.x first"
183 fi 182 fi
183
184 # Useflags we need to forcefuly enable
185 vlc_use_force remoteosd gcrypt
184 vlc_use_needs skins truetype 186 vlc_use_force skins truetype
185 vlc_use_force skins qt4 187 vlc_use_force skins qt4
188 vlc_use_force vlm stream
189 vlc_use_force vaapi ffmpeg
190
191 # Useflags that will be automagically discarded if deps are not met
186 vlc_use_needs bidi truetype 192 vlc_use_needs bidi truetype
187 vlc_use_force remoteosd gcrypt 193 vlc_use_needs cddb cdda
188 vlc_use_needs fontconfig truetype 194 vlc_use_needs fontconfig truetype
189 vlc_use_needs libv4l2 v4l2 195 vlc_use_needs libv4l2 v4l2
190 vlc_use_needs libv4l v4l 196 vlc_use_needs libv4l v4l
191 vlc_use_needs libtiger kate 197 vlc_use_needs libtiger kate
192 vlc_use_needs xv xcb 198 vlc_use_needs xv xcb
193 vlc_use_needs cddb cdda 199
194 if use qt4 || use skins ; then 200 if use qt4 || use skins ; then
195 qt4_pkg_setup 201 qt4_pkg_setup
196 else 202 else
197 ewarn "You have disabled the qt4 useflag, ${PN} will not have any" 203 ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
198 ewarn "graphical interface. Maybe that is not what you want..." 204 ewarn "graphical interface. Maybe that is not what you want..."
285 --disable-portaudio \ 291 --disable-portaudio \
286 $(use_enable projectm) \ 292 $(use_enable projectm) \
287 $(use_enable pulseaudio pulse) \ 293 $(use_enable pulseaudio pulse) \
288 $(use_enable pvr) \ 294 $(use_enable pvr) \
289 $(use_enable qt4) \ 295 $(use_enable qt4) \
296 $(use_enable remoteosd) \
290 $(use_enable rtsp realrtsp) \ 297 $(use_enable rtsp realrtsp) \
291 $(use_enable run-as-root) \ 298 $(use_enable run-as-root) \
292 $(use_enable samba smb) \ 299 $(use_enable samba smb) \
293 $(use_enable schroedinger) \ 300 $(use_enable schroedinger) \
294 $(use_enable sdl) \ 301 $(use_enable sdl) \
309 $(use_enable udev) \ 316 $(use_enable udev) \
310 $(use_enable upnp) \ 317 $(use_enable upnp) \
311 $(use_enable v4l) \ 318 $(use_enable v4l) \
312 $(use_enable v4l2) \ 319 $(use_enable v4l2) \
313 $(use_enable vcdx) \ 320 $(use_enable vcdx) \
321 $(use_enable vaapi libva) \
322 $(use_enable vlm) \
314 $(use_enable vorbis) \ 323 $(use_enable vorbis) \
315 $(use_enable win32codecs loader) \ 324 $(use_enable win32codecs loader) \
316 $(use_enable wma-fixed) \ 325 $(use_enable wma-fixed) \
317 $(use_enable x264) \ 326 $(use_enable x264) \
318 $(use_enable xcb) \ 327 $(use_enable xcb) \
322 $(use_enable zvbi) $(use_enable !zvbi telx) \ 331 $(use_enable zvbi) $(use_enable !zvbi telx) \
323 --disable-snapshot \ 332 --disable-snapshot \
324 --disable-growl \ 333 --disable-growl \
325 --disable-optimizations \ 334 --disable-optimizations \
326 --enable-fast-install \ 335 --enable-fast-install \
327 $(vlc_use_enable_force vlm vlm sout) \ 336 $(vlc_use_enable_force vlm sout) \
328 $(vlc_use_enable_force skins skins2 qt4) \ 337 $(vlc_use_enable_force skins qt4) \
338 $(vlc_use_enable_force skins freetype) \
329 $(vlc_use_enable_force remoteosd remoteosd libgcrypt) 339 $(vlc_use_enable_force remoteosd libgcrypt) \
340 $(vlc_use_enable_force vaapi avcodec)
330} 341}
331 342
332src_install() { 343src_install() {
333 emake DESTDIR="${D}" install || die "make install failed" 344 emake DESTDIR="${D}" install || die "make install failed"
334 345

Legend:
Removed from v.1.68  
changed lines
  Added in v.1.72

  ViewVC Help
Powered by ViewVC 1.1.20