/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.79 Revision 1.80
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.79 2010/06/25 11:30:50 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.80 2010/07/03 04:48:09 zmedico Exp $
4 4
5EAPI="2" 5EAPI="3"
6 6
7SCM="" 7SCM=""
8if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
9 SCM=git 9 SCM=git
10 EGIT_BOOTSTRAP="bootstrap" 10 EGIT_BOOTSTRAP="bootstrap"
54 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream 54 schroedinger sdl sdl-image shine shout skins speex sqlite sse stream
55 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vaapi vcdx vlm 55 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vaapi vcdx vlm
56 vorbis win32codecs wma-fixed +X x264 +xcb xml xosd xv zvbi" 56 vorbis win32codecs wma-fixed +X x264 +xcb xml xosd xv zvbi"
57 57
58RDEPEND=" 58RDEPEND="
59 !!<=media-video/vlc-1.0.99999
60 sys-libs/zlib 59 sys-libs/zlib
61 >=media-libs/libdvbpsi-0.1.6 60 >=media-libs/libdvbpsi-0.1.6
62 a52? ( >=media-libs/a52dec-0.7.4-r3 ) 61 a52? ( >=media-libs/a52dec-0.7.4-r3 )
63 aalib? ( media-libs/aalib ) 62 aalib? ( media-libs/aalib )
64 aac? ( >=media-libs/faad2-2.6.1 ) 63 aac? ( >=media-libs/faad2-2.6.1 )
142 xosd? ( x11-libs/xosd ) 141 xosd? ( x11-libs/xosd )
143 zvbi? ( >=media-libs/zvbi-0.2.25 ) 142 zvbi? ( >=media-libs/zvbi-0.2.25 )
144 " 143 "
145 144
146DEPEND="${RDEPEND} 145DEPEND="${RDEPEND}
146 !!<=media-video/vlc-1.0.99999
147 dvb? ( sys-kernel/linux-headers ) 147 dvb? ( sys-kernel/linux-headers )
148 kde? ( >=kde-base/kdelibs-4 ) 148 kde? ( >=kde-base/kdelibs-4 )
149 v4l? ( sys-kernel/linux-headers ) 149 v4l? ( sys-kernel/linux-headers )
150 v4l2? ( >=sys-kernel/linux-headers-2.6.25 ) 150 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
151 xcb? ( x11-proto/xproto ) 151 xcb? ( x11-proto/xproto )
168vlc_use_enable_force() { 168vlc_use_enable_force() {
169 use $1 && echo "--enable-$2" 169 use $1 && echo "--enable-$2"
170} 170}
171 171
172pkg_setup() { 172pkg_setup() {
173 if has_version '<=media-video/vlc-1.0.99999'; then
174 eerror "Please unmerge vlc-1.0.x first before installing ${P}"
175 eerror "If you don't do that, some plugins will get linked against"
176 eerror "the old ${PN} version and will not work."
177 die "Unmerge vlc 1.0.x first"
178 fi
179
180 # Useflags we need to forcefuly enable 173 # Useflags we need to forcefuly enable
181 vlc_use_force remoteosd gcrypt 174 vlc_use_force remoteosd gcrypt
182 vlc_use_force gnutls gcrypt 175 vlc_use_force gnutls gcrypt
183 vlc_use_force skins truetype 176 vlc_use_force skins truetype
184 vlc_use_force skins qt4 177 vlc_use_force skins qt4

Legend:
Removed from v.1.79  
changed lines
  Added in v.1.80

  ViewVC Help
Powered by ViewVC 1.1.20