/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Diff of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.8 Revision 1.25
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.8 2009/05/10 10:26:14 aballier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.25 2009/07/23 18:45:17 aballier Exp $
4 4
5EAPI="1" 5EAPI="2"
6 6
7SCM="" 7SCM=""
8if [ "${PV%9999}" != "${PV}" ] ; then 8if [ "${PV%9999}" != "${PV}" ] ; then
9 SCM=git 9 SCM=git
10 EGIT_REPO_URI="git://git.videolan.org/vlc.git" 10 EGIT_REPO_URI="git://git.videolan.org/vlc.git"
21MY_PV="${PV/_/-}" 21MY_PV="${PV/_/-}"
22MY_PV="${MY_PV/-beta/-test}" 22MY_PV="${MY_PV/-beta/-test}"
23MY_P="${PN}-${MY_PV}" 23MY_P="${PN}-${MY_PV}"
24VLC_SNAPSHOT_TIME="0013" 24VLC_SNAPSHOT_TIME="0013"
25 25
26PATCHLEVEL="59" 26PATCHLEVEL="68"
27M4_TARBALL_VERSION="1" 27M4_TARBALL_VERSION="1"
28DESCRIPTION="VLC media player - Video player and streamer" 28DESCRIPTION="VLC media player - Video player and streamer"
29HOMEPAGE="http://www.videolan.org/vlc/" 29HOMEPAGE="http://www.videolan.org/vlc/"
30if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild 30if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
31 SRC_URI="" 31 SRC_URI=""
45LICENSE="GPL-2" 45LICENSE="GPL-2"
46SLOT="0" 46SLOT="0"
47 47
48KEYWORDS="" 48KEYWORDS=""
49IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394 49IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394
50 debug dirac directfb dts dvb dvd fbcon fluidsynth +ffmpeg flac fontconfig ggi gnome gnutls hal httpd 50 debug dirac directfb dts dvb dvd fbcon fluidsynth +ffmpeg flac fontconfig
51 id3tag jack kate libass libcaca +libgcrypt libnotify libsysfs libv4l2 lirc live lua matroska mmx modplug mp3 mpeg mtp 51 +gcrypt ggi gnome gnutls hal httpd id3tag ieee1394 jack kate libass libcaca
52 musepack ncurses nsplugin ogg opengl optimisememory oss pda png pulseaudio pvr +qt4 52 libnotify libproxy libsysfs libtiger libv4l2 lirc live lua matroska mmx
53 remoteosd rtsp run-as-root samba schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream svg svga taglib 53 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
54 theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs wma-fixed 54 pda png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
55 X x264 xcb xinerama xml xosd xv zvbi" 55 schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream
56 svg svga taglib theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm
57 vorbis win32codecs wma-fixed X x264 xcb xinerama xml xosd xv zvbi"
56 58
57RDEPEND=" 59RDEPEND="
60 !!<=media-video/vlc-1.0.99999
58 sys-libs/zlib 61 sys-libs/zlib
59 media-libs/libdvbpsi 62 >=media-libs/libdvbpsi-0.1.6
60 a52? ( >=media-libs/a52dec-0.7.4-r3 ) 63 a52? ( >=media-libs/a52dec-0.7.4-r3 )
61 aalib? ( media-libs/aalib ) 64 aalib? ( media-libs/aalib )
62 aac? ( >=media-libs/faad2-2.6.1 ) 65 aac? ( >=media-libs/faad2-2.6.1 )
63 alsa? ( media-libs/alsa-lib ) 66 alsa? ( media-libs/alsa-lib )
64 avahi? ( >=net-dns/avahi-0.6 ) 67 avahi? ( >=net-dns/avahi-0.6 )
65 bidi? ( >=dev-libs/fribidi-0.10.4 ) 68 bidi? ( >=dev-libs/fribidi-0.10.4 )
66 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) ) 69 cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
67 cddax? ( cddb? ( >=media-libs/libcddb-1.2.0 ) ) 70 cddax? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
68 cdio? ( >=dev-libs/libcdio-0.78.2 ) 71 cdio? ( >=dev-libs/libcdio-0.78.2 )
69 dbus? ( >=sys-apps/dbus-1.0.2 ) 72 dbus? ( >=sys-apps/dbus-1.0.2 )
70 dc1394? ( sys-libs/libraw1394 73 dc1394? ( >=sys-libs/libraw1394-2.0.1
71 <media-libs/libdc1394-1.9.99 ) 74 >=media-libs/libdc1394-2.0.2 )
72 dirac? ( >=media-video/dirac-0.10.0 ) 75 dirac? ( >=media-video/dirac-0.10.0 )
73 directfb? ( dev-libs/DirectFB ) 76 directfb? ( dev-libs/DirectFB )
74 dts? ( media-libs/libdca ) 77 dts? ( media-libs/libdca )
75 dvd? ( media-libs/libdvdread 78 dvd? ( media-libs/libdvdread
76 media-libs/libdvdcss 79 media-libs/libdvdcss
79 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 ) 82 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
80 flac? ( media-libs/libogg 83 flac? ( media-libs/libogg
81 >=media-libs/flac-1.1.2 ) 84 >=media-libs/flac-1.1.2 )
82 fluidsynth? ( media-sound/fluidsynth ) 85 fluidsynth? ( media-sound/fluidsynth )
83 fontconfig? ( media-libs/fontconfig ) 86 fontconfig? ( media-libs/fontconfig )
87 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
84 ggi? ( media-libs/libggi ) 88 ggi? ( media-libs/libggi )
85 gnome? ( gnome-base/gnome-vfs ) 89 gnome? ( gnome-base/gnome-vfs )
86 gnutls? ( >=net-libs/gnutls-1.7.4 ) 90 gnutls? ( >=net-libs/gnutls-1.7.4 )
87 hal? ( sys-apps/hal ) 91 hal? ( sys-apps/hal )
88 id3tag? ( media-libs/libid3tag 92 id3tag? ( media-libs/libid3tag
89 sys-libs/zlib ) 93 sys-libs/zlib )
94 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
90 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 ) 95 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
91 kate? ( >=media-libs/libkate-0.1.1 ) 96 kate? ( >=media-libs/libkate-0.1.1 )
92 libass? ( >=media-libs/libass-0.9.5 media-libs/fontconfig ) 97 libass? ( >=media-libs/libass-0.9.5 media-libs/fontconfig )
93 libcaca? ( media-libs/libcaca ) 98 libcaca? ( media-libs/libcaca )
94 libgcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
95 libnotify? ( x11-libs/libnotify ) 99 libnotify? ( x11-libs/libnotify )
100 libproxy? ( net-libs/libproxy )
96 libsysfs? ( sys-fs/sysfsutils ) 101 libsysfs? ( sys-fs/sysfsutils )
102 libtiger? ( media-libs/libtiger )
97 lirc? ( app-misc/lirc ) 103 lirc? ( app-misc/lirc )
98 live? ( >=media-plugins/live-2008.07.06 ) 104 live? ( >=media-plugins/live-2008.07.06 )
99 lua? ( >=dev-lang/lua-5.1 ) 105 lua? ( >=dev-lang/lua-5.1 )
100 matroska? ( 106 matroska? (
101 >=dev-libs/libebml-0.7.6 107 >=dev-libs/libebml-0.7.6
111 !seamonkey? ( >=net-libs/xulrunner-1.8 ) 117 !seamonkey? ( >=net-libs/xulrunner-1.8 )
112 ) 118 )
113 ogg? ( media-libs/libogg ) 119 ogg? ( media-libs/libogg )
114 pda? ( x11-libs/gtk+:2 ) 120 pda? ( x11-libs/gtk+:2 )
115 png? ( media-libs/libpng ) 121 png? ( media-libs/libpng )
122 projectm? ( media-libs/libprojectm )
116 pulseaudio? ( >=media-sound/pulseaudio-0.9.8 ) 123 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
117 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 ) 124 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
118 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 ) 125 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
119 samba? ( net-fs/samba ) 126 samba? ( net-fs/samba )
120 schroedinger? ( >=media-libs/schroedinger-1.0 ) 127 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
121 sdl? ( >=media-libs/libsdl-1.2.8 128 sdl? ( >=media-libs/libsdl-1.2.8
122 sdl-image? ( media-libs/sdl-image ) ) 129 sdl-image? ( media-libs/sdl-image ) )
123 shout? ( media-libs/libshout ) 130 shout? ( media-libs/libshout )
124 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 ) 131 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
125 speex? ( media-libs/speex ) 132 speex? ( media-libs/speex )
126 svg? ( >=gnome-base/librsvg-2.9.0 ) 133 svg? ( >=gnome-base/librsvg-2.9.0 )
127 svga? ( media-libs/svgalib ) 134 svga? ( media-libs/svgalib )
128 taglib? ( >=media-libs/taglib-1.5 ) 135 taglib? ( >=media-libs/taglib-1.5 )
129 theora? ( >=media-libs/libtheora-1.0_beta3 ) 136 theora? ( >=media-libs/libtheora-1.0_beta3 )
130 truetype? ( media-libs/freetype 137 truetype? ( media-libs/freetype
131 media-fonts/ttf-bitstream-vera ) 138 media-fonts/dejavu )
132 twolame? ( media-sound/twolame ) 139 twolame? ( media-sound/twolame )
133 upnp? ( net-libs/libupnp ) 140 upnp? ( net-libs/libupnp )
134 v4l2? ( libv4l2? ( media-libs/libv4l ) ) 141 v4l2? ( libv4l2? ( media-libs/libv4l ) )
135 vcdinfo? ( >=media-video/vcdimager-0.7.22 ) 142 vcdinfo? ( >=media-video/vcdimager-0.7.22 )
136 vorbis? ( media-libs/libvorbis ) 143 vorbis? ( media-libs/libvorbis )
182 echo "--disable-$2" 189 echo "--disable-$2"
183 fi 190 fi
184} 191}
185 192
186pkg_setup() { 193pkg_setup() {
194 if has_version '<=media-video/vlc-1.0.99999'; then
195 eerror "Please unmerge vlc-1.0.x first before installing ${P}"
196 eerror "If you don't do that, some plugins will get linked against"
197 eerror "the old ${PN} version and will not work."
198 die "Unmerge vlc 1.0.x first"
199 fi
187 vlc_use_needs skins truetype 200 vlc_use_needs skins truetype
188 vlc_use_force skins qt4 201 vlc_use_force skins qt4
189 vlc_use_needs cddax cdio 202 vlc_use_needs cddax cdio
190 vlc_use_needs vcdx cdio 203 vlc_use_needs vcdx cdio
191 vlc_use_needs vcdx vcdinfo 204 vlc_use_needs vcdx vcdinfo
192 vlc_use_needs vcdinfo cdio 205 vlc_use_needs vcdinfo cdio
193 vlc_use_needs bidi truetype 206 vlc_use_needs bidi truetype
194 vlc_use_force remoteosd libgcrypt 207 vlc_use_force remoteosd gcrypt
195 vlc_use_needs fontconfig truetype 208 vlc_use_needs fontconfig truetype
196 vlc_use_needs libv4l2 v4l2 209 vlc_use_needs libv4l2 v4l2
210 vlc_use_needs libtiger kate
197 use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled." 211 use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
198 if use qt4 || use skins ; then 212 if use qt4 || use skins ; then
199 qt4_pkg_setup 213 qt4_pkg_setup
200 else 214 else
201 ewarn "You have disabled the qt4 useflag, ${PN} will not have any" 215 ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
206src_unpack() { 220src_unpack() {
207 unpack ${A} 221 unpack ${A}
208 if [ "${PV%9999}" != "${PV}" ] ; then 222 if [ "${PV%9999}" != "${PV}" ] ; then
209 git_src_unpack 223 git_src_unpack
210 fi 224 fi
211 cd "${S}" 225}
212 226
227src_prepare() {
228 if [ "${PV%9999}" != "${PV}" ] ; then
229 git_src_prepare
230 fi
213 # Make it build with libtool 1.5 231 # Make it build with libtool 1.5
214 rm -f m4/lt* m4/libtool.m4 232 rm -f m4/lt* m4/libtool.m4
215 233
216 EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches" 234 EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
217 AT_M4DIR="m4 ${WORKDIR}/${PN}-m4" eautoreconf 235 AT_M4DIR="m4 ${WORKDIR}/${PN}-m4" eautoreconf
218} 236}
219 237
220src_compile () { 238src_configure() {
221 239
222 # It would fail if -fforce-addr is used due to too few registers... 240 # It would fail if -fforce-addr is used due to too few registers...
223 use x86 && filter-flags -fforce-addr 241 use x86 && filter-flags -fforce-addr
224 242
225 local MOZILLA_PC 243 local MOZILLA_PC
255 $(use_enable dirac) \ 273 $(use_enable dirac) \
256 $(use_enable directfb) \ 274 $(use_enable directfb) \
257 $(use_enable dc1394) \ 275 $(use_enable dc1394) \
258 $(use_enable debug) \ 276 $(use_enable debug) \
259 $(use_enable dts dca) \ 277 $(use_enable dts dca) \
260 --disable-dv \
261 $(use_enable dvb) \ 278 $(use_enable dvb) \
262 $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \ 279 $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
263 $(use_enable fbcon fb) \ 280 $(use_enable fbcon fb) \
264 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) --disable-imgresample $(use_enable ffmpeg postproc) \ 281 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
265 $(use_enable flac) \ 282 $(use_enable flac) \
266 $(use_enable fluidsynth) \ 283 $(use_enable fluidsynth) \
267 $(use_enable fontconfig) \ 284 $(use_enable fontconfig) \
268 $(use_enable ggi) \ 285 $(use_enable ggi) \
269 $(use_enable gnome gnomevfs) \ 286 $(use_enable gnome gnomevfs) \
270 $(use_enable gnutls) \ 287 $(use_enable gnutls) \
271 $(use_enable hal) \ 288 $(use_enable hal) \
272 $(use_enable httpd) \ 289 $(use_enable httpd) \
273 $(use_enable id3tag) \ 290 $(use_enable id3tag) \
291 $(use_enable ieee1394 dv) \
274 $(use_enable jack) \ 292 $(use_enable jack) \
275 $(use_enable kate) \ 293 $(use_enable kate) \
276 $(use_enable libass) \ 294 $(use_enable libass) \
277 $(use_enable libcaca caca) \ 295 $(use_enable libcaca caca) \
278 $(use_enable libgcrypt) \ 296 $(use_enable gcrypt libgcrypt) \
279 $(use_enable libnotify notify) \ 297 $(use_enable libnotify notify) \
280 --disable-libproxy \ 298 $(use_enable libproxy) \
281 --disable-libtar \ 299 --disable-libtar \
300 $(use_enable libtiger tiger) \
282 $(use_enable libsysfs) \ 301 $(use_enable libsysfs) \
283 $(use_enable libv4l2) \ 302 $(use_enable libv4l2) \
284 $(use_enable lirc) \ 303 $(use_enable lirc) \
285 $(use_enable live live555) \ 304 $(use_enable live live555) \
286 $(use_enable lua) \ 305 $(use_enable lua) \
298 $(use_enable optimisememory optimize-memory) \ 317 $(use_enable optimisememory optimize-memory) \
299 $(use_enable oss) \ 318 $(use_enable oss) \
300 $(use_enable pda) \ 319 $(use_enable pda) \
301 $(use_enable png) \ 320 $(use_enable png) \
302 --disable-portaudio \ 321 --disable-portaudio \
322 $(use_enable projectm) \
303 $(use_enable pulseaudio pulse) \ 323 $(use_enable pulseaudio pulse) \
304 $(use_enable pvr) \ 324 $(use_enable pvr) \
305 $(use_enable qt4) \ 325 $(use_enable qt4) \
306 $(use_enable rtsp realrtsp) \ 326 $(use_enable rtsp realrtsp) \
307 $(use_enable run-as-root) \ 327 $(use_enable run-as-root) \
343 --disable-optimizations \ 363 --disable-optimizations \
344 --enable-fast-install \ 364 --enable-fast-install \
345 $(vlc_use_enable_force vlm vlm sout) \ 365 $(vlc_use_enable_force vlm vlm sout) \
346 $(vlc_use_enable_force skins skins2 qt4) \ 366 $(vlc_use_enable_force skins skins2 qt4) \
347 $(vlc_use_enable_force remoteosd remoteosd libgcrypt) 367 $(vlc_use_enable_force remoteosd remoteosd libgcrypt)
348
349 emake || die "make of VLC failed"
350} 368}
351 369
352src_install() { 370src_install() {
353 emake DESTDIR="${D}" install || die "make install failed" 371 emake DESTDIR="${D}" install || die "make install failed"
354 372

Legend:
Removed from v.1.8  
changed lines
  Added in v.1.25

  ViewVC Help
Powered by ViewVC 1.1.20