/[gentoo-x86]/net-irc/irssi/ChangeLog
Gentoo

Contents of /net-irc/irssi/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.110 - (show annotations) (download)
Sat Mar 17 18:10:33 2007 UTC (10 years, 10 months ago) by beandog
Branch: MAIN
Changes since 1.109: +4 -1 lines
amd64 stable, bug 169090
(Portage version: 2.1.2.2)

1 # ChangeLog for net-irc/irssi
2 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.109 2007/03/06 08:57:00 corsair Exp $
4
5 17 Mar 2007; Steve Dibb <beandog@gentoo.org> irssi-0.8.10-r4.ebuild:
6 amd64 stable, bug 169090
7
8 06 Mar 2007; Markus Rothe <corsair@gentoo.org> irssi-0.8.10-r4.ebuild:
9 Stable on ppc64; bug #169090
10
11 03 Mar 2007; Andrej Kacian <ticho@gentoo.org> irssi-0.8.10-r4.ebuild:
12 Stable on x86, bug #169090.
13
14 *irssi-0.8.11_rc1 (22 Feb 2007)
15
16 22 Feb 2007; Sven Wegener <swegener@gentoo.org> irssi-0.8.10-r3.ebuild,
17 irssi-0.8.10-r4.ebuild, +irssi-0.8.11_rc1.ebuild:
18 Version bump, bug #167820.
19
20 17 Jan 2007; Fabian Groffen <grobian@gentoo.org> irssi-0.8.10-r3.ebuild,
21 irssi-0.8.10-r4.ebuild:
22 Dropped ppc-macos keyword, see you in prefix
23
24 11 Jan 2007; Gustavo Zacarias <gustavoz@gentoo.org>
25 irssi-0.8.10-r4.ebuild:
26 Stable on sparc
27
28 07 Jan 2007; Sven Wegener <swegener@gentoo.org> irssi-0.8.10-r3.ebuild,
29 irssi-0.8.10-r4.ebuild:
30 Drop the extern inline workaround, 0.8.10 doesn't use them anymore.
31
32 24 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
33 irssi-0.8.10-r4.ebuild:
34 Stable on ppc.
35
36 20 Dec 2006; Jeroen Roovers <jer@gentoo.org> irssi-0.8.10-r4.ebuild:
37 Stable for HPPA.
38
39 14 Dec 2006; Alexander H. Færøy <eroyf@gentoo.org>
40 irssi-0.8.10-r4.ebuild:
41 Stable on IA64 and MIPS.
42
43 22 Oct 2006; Sven Wegener <swegener@gentoo.org>
44 -files/irssi-socks-fix.patch, -irssi-0.8.10.ebuild:
45 Cleanup.
46
47 20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> irssi-0.8.10-r4.ebuild:
48 Stable on Alpha.
49
50 13 Oct 2006; Sven Wegener <swegener@gentoo.org> irssi-0.8.10.ebuild,
51 irssi-0.8.10-r3.ebuild, irssi-0.8.10-r4.ebuild:
52 Adust the irssi and silc-client blockers.
53
54 *irssi-0.8.10-r4 (13 Oct 2006)
55
56 13 Oct 2006; Sven Wegener <swegener@gentoo.org>
57 +files/irssi-0.8.10-line-split.patch, +irssi-0.8.10-r4.ebuild:
58 Revision bump. Pull in a patch from upstream that should fix bug #101640.
59
60 03 Aug 2006; Gustavo Zacarias <gustavoz@gentoo.org>
61 irssi-0.8.10-r3.ebuild:
62 Stable on sparc
63
64 22 Jul 2006; Simon Stelling <blubb@gentoo.org> irssi-0.8.10-r3.ebuild:
65 stable on amd64
66
67 09 Jul 2006; Joshua Kinard <kumba@gentoo.org> irssi-0.8.10-r3.ebuild:
68 Marked stable on mips.
69
70 06 Jul 2006; Markus Rothe <corsair@gentoo.org> irssi-0.8.10-r3.ebuild:
71 Stable on ppc64
72
73 29 Jun 2006; Guy Martin <gmsoft@gentoo.org> irssi-0.8.10-r3.ebuild:
74 Stable on hppa.
75
76 25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org>
77 irssi-0.8.10-r3.ebuild:
78 ppc stable
79
80 22 Jun 2006; Emanuele Giaquinta <exg@gentoo.org> irssi-0.8.10-r3.ebuild:
81 Add ~ppc-macos keyword.
82
83 18 Jun 2006; Andrej Kacian <ticho@gentoo.org> irssi-0.8.10-r3.ebuild:
84 Stable on x86. Bug #137189.
85
86 28 May 2006; Sven Wegener <swegener@gentoo.org> -irssi-0.8.10-r2.ebuild:
87 Cleanup.
88
89 *irssi-0.8.10-r3 (05 May 2006)
90
91 05 May 2006; Emanuele Giaquinta <exg@gentoo.org>
92 +files/irssi-0.8.10-dcc-segv.patch, +irssi-0.8.10-r3.ebuild:
93 Add patch from upstream to fix segv on /quit with glib-2.10.
94
95 30 Apr 2006; Sven Wegener <swegener@gentoo.org>
96 -files/irssi-0.8.9-64bit-exec-fix.patch, -files/0.8.9-gcc4-fix.patch,
97 -irssi-0.8.9-r1.ebuild:
98 Cleanup.
99
100 08 Apr 2006; Bryan Østergaard <kloeri@gentoo.org irssi-0.8.10.ebuild:
101 Stable on alpha.
102
103 07 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> irssi-0.8.10-r2.ebuild:
104 Add ~x86-fbsd keyword.
105
106 25 Mar 2006; Sven Wegener <swegener@gentoo.org> irssi-0.8.10-r2.ebuild:
107 Drop myconf from econf, we don't need it anymore.
108
109 18 Mar 2006; Sven Wegener <swegener@gentoo.org> irssi-0.8.9-r1.ebuild,
110 irssi-0.8.10.ebuild, irssi-0.8.10-r2.ebuild:
111 Remove the old irssi-cvs blocker.
112
113 *irssi-0.8.10-r2 (18 Mar 2006)
114
115 18 Mar 2006; Sven Wegener <swegener@gentoo.org> -irssi-0.8.10-r1.ebuild,
116 +irssi-0.8.10-r2.ebuild:
117 Another revision bump to partly revert the last commit. Using ncurses for
118 all things causes too much trouble.
119
120 *irssi-0.8.10-r1 (17 Mar 2006)
121
122 17 Mar 2006; Sven Wegener <swegener@gentoo.org> +irssi-0.8.10-r1.ebuild:
123 Revision bump. Some general ebuild cleanup, depend on newer dante to remove
124 our socks patch and disable using terminfo directly, which should fix some
125 color weirdness.
126
127 26 Feb 2006; Joshua Kinard <kumba@gentoo.org> irssi-0.8.10.ebuild:
128 Marked stable on mips.
129
130 21 Feb 2006; Luis Medinas <metalgod@gentoo.org> irssi-0.8.10.ebuild:
131 Stable on amd64.
132
133 21 Feb 2006; Lars Weiler <pylon@gentoo.org> irssi-0.8.10.ebuild:
134 Stable on ppc.
135
136 21 Feb 2006; Jeroen Roovers <jer@gentoo.org> irssi-0.8.10.ebuild:
137 Stable on hppa.
138
139 20 Feb 2006; Markus Rothe <corsair@gentoo.org> irssi-0.8.10.ebuild:
140 Stable on ppc64
141
142 20 Feb 2006; Gustavo Zacarias <gustavoz@gentoo.org> irssi-0.8.10.ebuild:
143 Stable on sparc
144
145 19 Feb 2006; Sven Wegener <swegener@gentoo.org> metadata.xml,
146 irssi-0.8.10.ebuild:
147 Marked stable on x86.
148
149 *irssi-0.8.10 (11 Dec 2005)
150
151 11 Dec 2005; Sven Wegener <swegener@gentoo.org> -irssi-0.8.10_rc6.ebuild,
152 -irssi-0.8.10_rc7.ebuild, +irssi-0.8.10.ebuild:
153 Version bump.
154
155 28 Nov 2005; <mcumming@gentoo.org> irssi-0.8.10_rc6.ebuild,
156 irssi-0.8.10_rc7.ebuild, irssi-0.8.9-r1.ebuild:
157 Switched from perl-module to perl-app eclass
158
159 13 Nov 2005; Sven Wegener <swegener@gentoo.org>
160 +files/0.8.9-gcc4-fix.patch, irssi-0.8.9-r1.ebuild:
161 Apply the gcc4 patch to 0.8.9 too, bug #110361.
162
163 *irssi-0.8.10_rc7 (10 Nov 2005)
164
165 10 Nov 2005; Sven Wegener <swegener@gentoo.org> +irssi-0.8.10_rc7.ebuild:
166 Version bump.
167
168 14 Oct 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.10_rc6.ebuild:
169 Remove unused configure options and no longer needed perl build-time
170 dependency.
171
172 *irssi-0.8.10_rc6 (13 Oct 2005)
173
174 13 Oct 2005; Sven Wegener <swegener@gentoo.org>
175 -files/irssi-0.8.10_rc5-gcc4.patch, -irssi-0.8.10_rc5-r1.ebuild,
176 +irssi-0.8.10_rc6.ebuild:
177 Version bump.
178
179 13 Jun 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.9-r1.ebuild,
180 irssi-0.8.10_rc5-r1.ebuild:
181 Irssi uses extern inlines and that needs at least -O in CFLAGS.
182
183 19 May 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.9-r1.ebuild,
184 irssi-0.8.10_rc5-r1.ebuild:
185 Added a call to fixlocalpod to fix the collision-protect bug #68367.
186
187 17 May 2005; Sven Wegener <swegener@gentoo.org>
188 +files/irssi-0.8.10_rc5-gcc4.patch, irssi-0.8.10_rc5-r1.ebuild:
189 Pull in gcc-4 patch from upstream svn. Closes bug #92918.
190
191 15 May 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.9-r1.ebuild,
192 irssi-0.8.10_rc5-r1.ebuild:
193 Removed obsolete gettext support.
194
195 14 May 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.9-r1.ebuild,
196 irssi-0.8.10_rc5-r1.ebuild:
197 Added blocker for net-irc/irssi-svn
198
199 22 Apr 2005; Alin Nastac <mrness@gentoo.org> irssi-0.8.9-r1.ebuild,
200 irssi-0.8.10_rc5-r1.ebuild:
201 net-misc/dante -> net-proxy/dante
202
203 06 Mar 2005; Gustavo Zacarias <gustavoz@gentoo.org> irssi-0.8.9-r1.ebuild:
204 Apply socks patch to 0.8.9 too to fix LiveCD
205
206 01 Mar 2005; Sven Wegener <swegener@gentoo.org>
207 +files/irssi-socks-fix.patch, irssi-0.8.10_rc5-r1.ebuild,
208 -irssi-0.8.10_rc5.ebuild:
209 Added a patch that fixes wrong include order if socks support is enabled.
210 Closes bug #83522.
211
212 22 Jan 2005; Sven Wegener <swegener@gentoo.org>
213 irssi-0.8.10_rc5-r1.ebuild:
214 Added a call to syntax.pl to generate updated help files.
215
216 *irssi-0.8.10_rc5-r1 (21 Jan 2005)
217
218 21 Jan 2005; Sven Wegener <swegener@gentoo.org>
219 +irssi-0.8.10_rc5-r1.ebuild:
220 Pull in all CVS changes from 0.8.10_rc5 to now. Includes several bugfixes
221 (logging, memleak and more), updated help (recode) and some new features.
222 Read upstream's ChangeLog for more information. Closes bug #78917.
223
224 07 Jan 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.10_rc5.ebuild:
225 Removed blockers on irssi-charconv and irssi-recode.
226
227 13 Nov 2004; Sven Wegener <swegener@gentoo.org>
228 -files/irssi-0.8.6-configure.patch, -files/irssi-0.8.8-configure.patch,
229 irssi-0.8.10_rc5.ebuild, -irssi-0.8.6-r6.ebuild, irssi-0.8.9-r1.ebuild,
230 -irssi-0.8.9.ebuild:
231 Moved all stable KEYWORDS to 0.8.9-r1 to allow the removal of old ebuilds.
232
233 07 Nov 2004; Joshua Kinard <kumba@gentoo.org> irssi-0.8.9-r1.ebuild:
234 Marked stable on mips.
235
236 31 Oct 2004; Kito <kito@gentoo.org> irssi-0.8.10_rc5.ebuild:
237 added ~ppc-macos
238
239 *irssi-0.8.10_rc5 (12 Sep 2004)
240
241 12 Sep 2004; Sven Wegener <swegener@gentoo.org> +irssi-0.8.10_rc5.ebuild:
242 Version bump to 0.8.10_rc5. This version has the features of
243 net-irc/irssi-charconv and net-irc/irssi-recode integrated, so we block them.
244 Closes bug #63367.
245
246 *irssi-0.8.9-r1 (24 Jul 2004)
247
248 24 Jul 2004; Sven Wegener <swegener@gentoo.org>
249 +files/irssi-0.8.9-64bit-exec-fix.patch, +irssi-0.8.9-r1.ebuild:
250 Added backported fix from upstream CVS, which fixes the /exec command bug on
251 64-bit arches. Closes bug #57785.
252
253 08 Jul 2004; Sven Wegener <swegener@gentoo.org> -irssi-0.8.6-r5.ebuild,
254 irssi-0.8.6-r6.ebuild, irssi-0.8.9.ebuild:
255 Updated dependencies and ebuild cleanup.
256
257 18 Jun 2004; Sven Wegener <swegener@gentoo.org> irssi-0.8.9.ebuild:
258 Added dev-libs/glib to RDEPEND. Closes bug #54323.
259
260 27 Apr 2004; Aron Griffis <agriffis@gentoo.org> irssi-0.8.6-r5.ebuild,
261 irssi-0.8.6-r6.ebuild:
262 Add inherit eutils
263
264 12 Apr 2004; <randy@gentoo.org> irssi-0.8.9.ebuild:
265 Adding s390 keywords
266
267 05 Mar 2004; Tom Gall <tgall@gentoo.org> irssi-0.8.9.ebuild:
268 marked stable on ppc64
269
270 21 Feb 2004; Seemant Kulleen <seemant@gentoo.org> irssi-0.8.9.ebuild:
271 added perl, ssl and socks to RDEPENDS for livecd irssi to run properly
272
273 15 Jan 2004; Jon Portnoy <avenj@gentoo.org> irssi-0.8.9.ebuild :
274 Stable on AMD64.
275
276 09 Jan 2004; Jason Wever <weeve@gentoo.org> irssi-0.8.9.ebuild:
277 Marked stable on sparc.
278
279 09 Jan 2004; root <root@gentoo.org> irssi-0.8.9.ebuild:
280 Marked stable on hppa.
281
282 05 Jan 2004; Aron Griffis <agriffis@gentoo.org> irssi-0.8.9.ebuild:
283 Use glib2 (this ebuild accidentally regressed from 0.8.6-r6). Don't
284 build the bot, which is apparently broken and unsupported. Mark
285 stable on x86, alpha and ia64. These changes fix bugs 33603, 35614
286 and 35532 and follow discussion with Greg F. in December.
287
288 12 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.9.ebuild:
289 Fixed patch problem, closes bug #35657
290
291 *irssi-0.8.9 (11 Dec 2003)
292
293 11 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild,
294 irssi-0.8.8.ebuild, irssi-0.8.9.ebuild:
295 Version Bump, fixes ssl bug #35532
296
297 11 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild,
298 irssi-0.8.8.ebuild:
299 Removed because of remoate crash bug
300
301 *irssi-0.8.8-r1 (26 Nov 2003)
302
303 26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild:
304 Force glib2, removed bot (obsolete).
305
306 *irssi-0.8.6-r6 (26 Nov 2003)
307
308 26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r6.ebuild:
309 Removed --with-bot, no used anymore and it was broken. Forced usage of glib2.
310 This closes bug #33603.
311
312 23 Nov 2003; Martin Holzer <mholzer@gentoo.org> irssi-0.8.8.ebuild,
313 files/irssi-0.8.8-configure.patch:
314 fixing head -1 issue. Closes #34186.
315
316 *irssi-0.8.8 (23 Nov 2003)
317
318 23 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8.ebuild:
319 Version bump.
320
321 *irssi-0.8.6-r5 (11 Nov 2003)
322
323 11 Nov 2003; Chuck Short <zul@gentoo.org> irssi-0.8.6-r5.ebuild:
324 New version, fixes use handling and new socks functionaility at compile time.
325 Ebuild submitted by Aron Griffis <agriffis@gentoo.org>
326 Closes bug #33230.
327
328 *irssi-0.8.6-r4 (05 Oct 2003)
329
330 05 Oct 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r4.ebuild:
331 Fix for use=perl, this closes bug #30029
332
333 01 Oct 2003; Tavis Ormandy <taviso@gentoo.org> irssi-0.8.6-r3.ebuild:
334 Stable on alpha
335
336 *irssi-0.8.6-r3 (30 Sep 2003)
337
338 30 Sep 2003; Joshua Kinard <kumba@gentoo.org> irssi-0.8.6-r3.ebuild:
339 Changed ~mips to mips in KEYWORDS
340
341 18 Sep 2003; Jon Portnoy <avenj@gentoo.org> :
342 ia64 keywords.
343
344 21 Aug 2003; <chuck@gentoo.org> :
345 Added SSL suport, closes bug #26343.
346
347 *irssi-0.8.6-r2 (10 Feb 2003)
348
349 07 Aug 2003; Tavis Ormandy <taviso@gentoo.org> irssi-0.8.6-r2.ebuild:
350 stable on alpha
351
352 18 Jul 2003; Olivier Crete <tester@gentoo.org> irssi-0.8.6-r2.ebuild,
353 files/irssi-0.8.6-configure.patch:
354 Fix tail use to make it posix compliant
355
356 18 Jul 2003; John Mylchreest <johnm@gentoo.org>; irssi-0.8.6-r2.ebuild:
357 adding irssi-cvs block
358
359 19 Jun 2003; <msterret@gentoo.org> irssi-0.8.6-r2.ebuild:
360 Ugly hack to work around compression of the html files. (bug 23048)
361
362 01 Jun 2003; Joshua Kinard <kumba@gentoo.org> irssi-0.8.6-r2.ebuild:
363 Added ~mips to KEYWORDS
364
365 11 Feb 2003; Guy Martin <gmsoft@gentoo.org> irssi-0.8.6-r2.ebuild :
366 Added hppa to keywords.
367
368 04 Apr 2003; Jason Wever <weeve@gentoo.org> irssi-0.8.6-r2.ebuild:
369 Changed ~sparc keyword to sparc.
370
371 10 Feb 2003; Peter Johanson <latexer@gentoo.org> :
372 Added ~alpha to KEYWORDS.
373
374 10 Feb 2002; Tobias Eichert <viz@gentoo.org> :
375 Removed older irssi ebuilds and revisions to
376 make the directory more concise..now we
377 have an ebuild for irssi-0.8.5 and irssi-0.8.6.
378 Changed =dev-libs/glib-2.2* dependency to
379 >=dev-libs/glib-1.2.
380 Changed "~x86" to "x86" in KEYWORDS.
381
382 10 Feb 2003; Tobias Eichert <viz@gentoo.org> irssi-0.8.6-r2.ebuild:
383 Removed glib-1.2* as a dependency. Therefor added glib-2.2*.
384 Closes bug #13991.
385
386 *irssi-0.8.6-r1 (22 Dec 2002)
387
388 22 Dec 2002; Maik Schreiber <blizzy@gentoo.org> : Obey USE="-ssl" (bug
389 #12566).
390
391 21 Dec 2002; Maik Schreiber <blizzy@gentoo.org> irssi-0.8.6.ebuild: Changed
392 "~x86" to "x86" in KEYWORDS.
393
394 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
395
396 *irssi-0.8.6 (19 Nov 2002)
397
398 19 Nov 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
399
400 20 Oct 2002; Mike Frysinger <vapier@gentoo.org> irssi-0.8.5-r2.ebuild :
401 Added 'prepalldocs' to src_install since `make install` was putting them there
402
403 16 Sep 2002; Maarten Thibaut <murphy@gentoo.org> irssi-0.8.5-r2.ebuild :
404 Added sparc/sparc64 keywords.
405
406 13 Sep 2002; Michael Cummings <mcummings@gentoo.org>: Corrected perl
407 syntax to use perl eclass for perl Makefile.PL actions, bug 7868.
408
409 *irssi-0.8.5-r2 (12 Sep 2002)
410
411 10 Feb 2003; Peter Johanson <latexer@gentoo.org> :
412 Added ~alpha to KEYWORDS.
413
414 12 Sep 2002; Daniel Robbins <drobbins@gentoo.org>: new rev bump with
415 configuration flag fixes: several use/configure combos were toggled, the
416 ebuild had "--enable-perl" instead of "--with-perl", etc. Lamer's socks
417 stuff has been commented out for the time being so that I can unmask
418 this now (but is being kept so that it can be uncommented later.)
419
420 *irssi-0.8.5-r1 (15 Jul 2002)
421
422 24 Jul 2002; Mark Guertin <gerk@gentoo.org>: Added ppc to keywords
423
424 15 Jul 2002; Ben Lutgens <lamer@gentoo.org> ChangeLog: Incremented the
425 version number. Anyone with socks in use gets an additional depend on
426 net-misc/dante-1.1.13. It's needed for libsocks.so and socks.h (otherwise
427 toggling the option --with-socks does no good) needs more socks testing
428 however so it's getting masked)
429
430 *irssi-0.8.5 (23 Jun 2002)
431
432 23 Jun 2002; lamer <lamer@gentoo.org>: Updated to latest version from
433 upstream. Fixes a topic string overflow DoS attack. Upgrade now.
434
435 11 Apr 2002; Spider <spider@gentoo.org>: Update all glib dependencies to use
436 glib-1.2* in preparation of unmasking the glib-2.0.1 packages

  ViewVC Help
Powered by ViewVC 1.1.20