/[gentoo-x86]/net-irc/irssi/ChangeLog
Gentoo

Contents of /net-irc/irssi/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.41 - (show annotations) (download)
Fri Jan 9 04:17:12 2004 UTC (14 years, 9 months ago) by gmsoft
Branch: MAIN
Changes since 1.40: +4 -1 lines
Marked stable on hppa.

1 # ChangeLog for net-irc/irssi
2 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
3 # $Header: /home/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.40 2004/01/05 18:39:43 agriffis Exp $
4
5 09 Jan 2004; root <root@gentoo.org> irssi-0.8.9.ebuild:
6 Marked stable on hppa.
7
8 05 Jan 2004; Aron Griffis <agriffis@gentoo.org> irssi-0.8.9.ebuild:
9 Use glib2 (this ebuild accidentally regressed from 0.8.6-r6). Don't
10 build the bot, which is apparently broken and unsupported. Mark
11 stable on x86, alpha and ia64. These changes fix bugs 33603, 35614
12 and 35532 and follow discussion with Greg F. in December.
13
14 12 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.9.ebuild:
15 Fixed patch problem, closes bug #35657
16
17 *irssi-0.8.9 (11 Dec 2003)
18
19 11 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild,
20 irssi-0.8.8.ebuild, irssi-0.8.9.ebuild:
21 Version Bump, fixes ssl bug #35532
22
23 11 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild,
24 irssi-0.8.8.ebuild:
25 Removed because of remoate crash bug
26
27 *irssi-0.8.8-r1 (26 Nov 2003)
28
29 26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild:
30 Force glib2, removed bot (obsolete).
31
32 *irssi-0.8.6-r6 (26 Nov 2003)
33
34 26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r6.ebuild:
35 Removed --with-bot, no used anymore and it was broken. Forced usage of glib2.
36 This closes bug #33603.
37
38 23 Nov 2003; Martin Holzer <mholzer@gentoo.org> irssi-0.8.8.ebuild,
39 files/irssi-0.8.8-configure.patch:
40 fixing head -1 issue. Closes #34186.
41
42 *irssi-0.8.8 (23 Nov 2003)
43
44 23 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8.ebuild:
45 Version bump.
46
47 *irssi-0.8.6-r5 (11 Nov 2003)
48
49 11 Nov 2003; Chuck Short <zul@gentoo.org> irssi-0.8.6-r5.ebuild:
50 New version, fixes use handling and new socks functionaility at compile time.
51 Ebuild submitted by Aron Griffis <agriffis@gentoo.org>
52 Closes bug #33230.
53
54 *irssi-0.8.6-r4 (05 Oct 2003)
55
56 05 Oct 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r4.ebuild:
57 Fix for use=perl, this closes bug #30029
58
59 01 Oct 2003; Tavis Ormandy <taviso@gentoo.org> irssi-0.8.6-r3.ebuild:
60 Stable on alpha
61
62 *irssi-0.8.6-r3 (30 Sep 2003)
63
64 30 Sep 2003; Joshua Kinard <kumba@gentoo.org> irssi-0.8.6-r3.ebuild:
65 Changed ~mips to mips in KEYWORDS
66
67 18 Sep 2003; Jon Portnoy <avenj@gentoo.org> :
68 ia64 keywords.
69
70 21 Aug 2003; <chuck@gentoo.org> :
71 Added SSL suport, closes bug #26343.
72
73 *irssi-0.8.6-r2 (10 Feb 2003)
74
75 07 Aug 2003; Tavis Ormandy <taviso@gentoo.org> irssi-0.8.6-r2.ebuild:
76 stable on alpha
77
78 18 Jul 2003; Olivier Crete <tester@gentoo.org> irssi-0.8.6-r2.ebuild,
79 files/irssi-0.8.6-configure.patch:
80 Fix tail use to make it posix compliant
81
82 18 Jul 2003; John Mylchreest <johnm@gentoo.org>; irssi-0.8.6-r2.ebuild:
83 adding irssi-cvs block
84
85 19 Jun 2003; <msterret@gentoo.org> irssi-0.8.6-r2.ebuild:
86 Ugly hack to work around compression of the html files. (bug 23048)
87
88 01 Jun 2003; Joshua Kinard <kumba@gentoo.org> irssi-0.8.6-r2.ebuild:
89 Added ~mips to KEYWORDS
90
91 11 Feb 2003; Guy Martin <gmsoft@gentoo.org> irssi-0.8.6-r2.ebuild :
92 Added hppa to keywords.
93
94 04 Apr 2003; Jason Wever <weeve@gentoo.org> irssi-0.8.6-r2.ebuild:
95 Changed ~sparc keyword to sparc.
96
97 10 Feb 2003; Peter Johanson <latexer@gentoo.org> :
98 Added ~alpha to KEYWORDS.
99
100 10 Feb 2002; Tobias Eichert <viz@gentoo.org> :
101 Removed older irssi ebuilds and revisions to
102 make the directory more concise..now we
103 have an ebuild for irssi-0.8.5 and irssi-0.8.6.
104 Changed =dev-libs/glib-2.2* dependency to
105 >=dev-libs/glib-1.2.
106 Changed "~x86" to "x86" in KEYWORDS.
107
108 10 Feb 2003; Tobias Eichert <viz@gentoo.org> irssi-0.8.6-r2.ebuild:
109 Removed glib-1.2* as a dependency. Therefor added glib-2.2*.
110 Closes bug #13991.
111
112 *irssi-0.8.6-r1 (22 Dec 2002)
113
114 22 Dec 2002; Maik Schreiber <blizzy@gentoo.org> : Obey USE="-ssl" (bug
115 #12566).
116
117 21 Dec 2002; Maik Schreiber <blizzy@gentoo.org> irssi-0.8.6.ebuild: Changed
118 "~x86" to "x86" in KEYWORDS.
119
120 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
121
122 *irssi-0.8.6 (19 Nov 2002)
123
124 19 Nov 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
125
126 20 Oct 2002; Mike Frysinger <vapier@gentoo.org> irssi-0.8.5-r2.ebuild :
127 Added 'prepalldocs' to src_install since `make install` was putting them there
128
129 16 Sep 2002; Maarten Thibaut <murphy@gentoo.org> irssi-0.8.5-r2.ebuild :
130 Added sparc/sparc64 keywords.
131
132 13 Sep 2002; Michael Cummings <mcummings@gentoo.org>: Corrected perl
133 syntax to use perl eclass for perl Makefile.PL actions, bug 7868.
134
135 *irssi-0.8.5-r2 (12 Sep 2002)
136
137 10 Feb 2003; Peter Johanson <latexer@gentoo.org> :
138 Added ~alpha to KEYWORDS.
139
140 12 Sep 2002; Daniel Robbins <drobbins@gentoo.org>: new rev bump with
141 configuration flag fixes: several use/configure combos were toggled, the
142 ebuild had "--enable-perl" instead of "--with-perl", etc. Lamer's socks
143 stuff has been commented out for the time being so that I can unmask
144 this now (but is being kept so that it can be uncommented later.)
145
146 *irssi-0.8.5-r1 (15 Jul 2002)
147
148 24 Jul 2002; Mark Guertin <gerk@gentoo.org>: Added ppc to keywords
149
150 15 Jul 2002; Ben Lutgens <lamer@gentoo.org> ChangeLog: Incremented the
151 version number. Anyone with socks in use gets an additional depend on
152 net-misc/dante-1.1.13. It's needed for libsocks.so and socks.h (otherwise
153 toggling the option --with-socks does no good) needs more socks testing
154 however so it's getting masked)
155
156 *irssi-0.8.5 (23 Jun 2002)
157
158 23 Jun 2002; lamer <lamer@gentoo.org>: Updated to latest version from
159 upstream. Fixes a topic string overflow DoS attack. Upgrade now.
160
161 11 Apr 2002; Spider <spider@gentoo.org>: Update all glib dependencies to use
162 glib-1.2* in preparation of unmasking the glib-2.0.1 packages

  ViewVC Help
Powered by ViewVC 1.1.20