/[gentoo-x86]/net-misc/gns3-server/gns3-server-1.3.0.ebuild
Gentoo

Contents of /net-misc/gns3-server/gns3-server-1.3.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Sat Apr 18 06:33:37 2015 UTC (4 years, 7 months ago) by bman
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +1 -1 lines
FILE REMOVED
rm old; add gns3-server-1.3.1

(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 8EE88A22)

1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/gns3-server/gns3-server-1.3.0.ebuild,v 1.1 2015/04/06 09:51:09 bman Exp $
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{3_3,3_4} )
8
9 inherit distutils-r1 eutils
10
11 DESCRIPTION="GNS3 server to asynchronously manage emulators"
12 HOMEPAGE="http://www.gns3.net/"
13 SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 RDEPEND=">=app-emulation/dynamips-0.2.12
20 >=dev-python/aiohttp-0.14.4[${PYTHON_USEDEP}]
21 >=dev-python/netifaces-0.8-r2[${PYTHON_USEDEP}]
22 >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
23 >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
24 >=dev-python/libcloud-0.14.1[${PYTHON_USEDEP}]
25 >=dev-python/raven-5.2.0[${PYTHON_USEDEP}]
26 >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
27 >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]"
28
29 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
30
31 python_prepare_all() {
32 # avoid file collisions caused by required tests
33 sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" -i setup.py || die
34 distutils-r1_python_prepare_all
35 }
36
37 pkg_postinst() {
38 ewarn "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
39 ewarn ""
40 ewarn "The following is a list of packages that can be added:"
41 ewarn "app-emulation/qemu, app-emulation/virtualbox, and net-analyzer/wireshark"
42 ewarn ""
43 ewarn "The following packages are currently unsupported:"
44 ewarn "iouyap and vpcs"
45 }

  ViewVC Help
Powered by ViewVC 1.1.20