/[gentoo-x86]/net-misc/openssh/openssh-4.5_p1-r1.ebuild
Gentoo

Contents of /net-misc/openssh/openssh-4.5_p1-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (show annotations) (download)
Sat Sep 29 06:53:26 2007 UTC (12 years, 2 months ago) by vapier
Branch: MAIN
CVS Tags: HEAD
Changes since 1.5: +1 -1 lines
FILE REMOVED
old
(Portage version: 2.1.3.9)

1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.5_p1-r1.ebuild,v 1.5 2007/07/23 05:30:11 vapier Exp $
4
5 WANT_AUTOCONF="latest"
6 WANT_AUTOMAKE="latest"
7 # Please leave pam at end, so that dopamd and newpamd from eutils eclass are not used
8 inherit eutils flag-o-matic ccc multilib autotools pam
9
10 # Make it more portable between straight releases
11 # and _p? releases.
12 PARCH=${P/_/}
13
14 X509_PATCH="${PARCH}+x509-5.5.2.diff.gz"
15 SECURID_PATCH="${PARCH/4.5/4.4}+SecurID_v1.3.2.patch"
16 LDAP_PATCH="${PARCH/-4.5p1/-lpk-4.4p1}-0.3.7.patch"
17 HPN_PATCH="${PARCH}-hpn12v14.diff.gz"
18
19 DESCRIPTION="Port of OpenBSD's free SSH release"
20 HOMEPAGE="http://www.openssh.com/"
21 SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
22 X509? ( http://roumenpetrov.info/openssh/x509-5.5.2/${X509_PATCH} )
23 ldap? ( http://dev.inversepath.com/openssh-lpk/${LDAP_PATCH} )
24 hpn? ( http://www.psc.edu/networking/projects/hpn-ssh/${HPN_PATCH} )
25 smartcard? ( http://omniti.com/~jesus/projects/${SECURID_PATCH} )"
26
27 LICENSE="as-is"
28 SLOT="0"
29 KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
30 IUSE="static pam tcpd kerberos skey selinux chroot X509 ldap smartcard hpn libedit X"
31
32 RDEPEND="pam? ( virtual/pam )
33 kerberos? ( virtual/krb5 )
34 selinux? ( >=sys-libs/libselinux-1.28 )
35 skey? ( >=app-admin/skey-1.1.5-r1 )
36 ldap? ( net-nds/openldap )
37 libedit? ( dev-libs/libedit )
38 >=dev-libs/openssl-0.9.6d
39 >=sys-libs/zlib-1.2.3
40 smartcard? ( dev-libs/opensc )
41 tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
42 X? ( x11-apps/xauth )
43 userland_GNU? ( sys-apps/shadow )"
44 DEPEND="${RDEPEND}
45 dev-util/pkgconfig
46 virtual/os-headers
47 sys-devel/autoconf"
48 PROVIDE="virtual/ssh"
49
50 S=${WORKDIR}/${PARCH}
51
52 pkg_setup() {
53 # this sucks, but i'd rather have people unable to `emerge -u openssh`
54 # than not be able to log in to their server any more
55 local fail=""
56 [[ -z ${X509_PATCH} ]] && use X509 && fail="${fail} X509"
57 [[ -z ${SECURID_PATCH} ]] && use smartcard && fail="${fail} smartcard"
58 if [[ -n ${fail} ]] ; then
59 eerror "Sorry, but this version does not yet support features"
60 eerror "that you requested: ${fail}"
61 eerror "Please mask ${PF} for now and check back later:"
62 eerror " # echo '=${CATEGORY}/${PF}' >> /etc/portage/package.mask"
63 die "booooo"
64 fi
65 }
66
67 src_unpack() {
68 unpack ${PARCH}.tar.gz
69 cd "${S}"
70
71 sed -i \
72 -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
73 pathnames.h || die
74
75 use X509 && epatch "${DISTDIR}"/${X509_PATCH} "${FILESDIR}"/${PN}-4.4_p1-x509-hpn-glue.patch
76 use chroot && epatch "${FILESDIR}"/openssh-4.3_p1-chroot.patch
77 use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch
78 if ! use X509 ; then
79 if [[ -n ${SECURID_PATCH} ]] && use smartcard ; then
80 epatch "${DISTDIR}"/${SECURID_PATCH} \
81 "${FILESDIR}"/${PN}-4.3_p2-securid-updates.patch \
82 "${FILESDIR}"/${PN}-4.3_p2-securid-hpn-glue.patch
83 use ldap && epatch "${FILESDIR}"/openssh-4.0_p1-smartcard-ldap-happy.patch
84 fi
85 if use ldap ; then
86 epatch "${DISTDIR}"/${LDAP_PATCH} "${FILESDIR}"/${PN}-4.4_p1-ldap-hpn-glue.patch
87 fi
88 elif [[ -n ${SECURID_PATCH} ]] && use smartcard || use ldap ; then
89 ewarn "Sorry, X509 and smartcard/ldap don't get along, disabling smartcard/ldap"
90 fi
91 [[ -n ${HPN_PATCH} ]] && use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
92
93 sed -i "s:-lcrypto:$(pkg-config --libs openssl):" configure{,.ac} || die
94
95 eautoreconf
96 }
97
98 src_compile() {
99 addwrite /dev/ptmx
100 addpredict /etc/skey/skeykeys #skey configure code triggers this
101
102 local myconf=""
103 if use static ; then
104 append-ldflags -static
105 use pam && ewarn "Disabling pam support becuse of static flag"
106 myconf="${myconf} --without-pam"
107 else
108 myconf="${myconf} $(use_with pam)"
109 fi
110
111 econf \
112 --with-ldflags="${LDFLAGS}" \
113 --disable-strip \
114 --sysconfdir=/etc/ssh \
115 --libexecdir=/usr/$(get_libdir)/misc \
116 --datadir=/usr/share/openssh \
117 --disable-suid-ssh \
118 --with-privsep-path=/var/empty \
119 --with-privsep-user=sshd \
120 --with-md5-passwords \
121 $(use_with ldap) \
122 $(use_with libedit) \
123 $(use_with kerberos kerberos5 /usr) \
124 $(use_with tcpd tcp-wrappers) \
125 $(use_with selinux) \
126 $(use_with skey) \
127 $(use_with smartcard opensc) \
128 ${myconf} \
129 || die "bad configure"
130 emake || die "compile problem"
131 }
132
133 src_install() {
134 emake install-nokeys DESTDIR="${D}" || die
135 fperms 600 /etc/ssh/sshd_config
136 dobin contrib/ssh-copy-id
137 newinitd "${FILESDIR}"/sshd.rc6 sshd
138 newconfd "${FILESDIR}"/sshd.confd sshd
139 keepdir /var/empty
140
141 newpamd "${FILESDIR}"/sshd.pam_include sshd
142 dosed "/^#Protocol /s:.*:Protocol 2:" /etc/ssh/sshd_config
143 use pam \
144 && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config \
145 && dosed "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" /etc/ssh/sshd_config
146
147 doman contrib/ssh-copy-id.1
148 dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
149
150 diropts -m 0700
151 dodir /etc/skel/.ssh
152 }
153
154 pkg_postinst() {
155 enewgroup sshd 22
156 enewuser sshd 22 -1 /var/empty sshd
157
158 ewarn "Remember to merge your config files in /etc/ssh/ and then"
159 ewarn "restart sshd: '/etc/init.d/sshd restart'."
160 if use pam ; then
161 echo
162 ewarn "Please be aware users need a valid shell in /etc/passwd"
163 ewarn "in order to be allowed to login."
164 fi
165 }

  ViewVC Help
Powered by ViewVC 1.1.20