/[gentoo-x86]/net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild
Gentoo

Contents of /net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.4 - (show annotations) (download)
Wed Apr 8 18:20:12 2015 UTC (4 years, 10 months ago) by mgorny
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +3 -3 lines
Drop old Python implementations

(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)

1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild,v 1.3 2014/07/23 15:24:25 ago Exp $
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit gnome2 eutils python-any-r1
10
11 DESCRIPTION="A Jabber/XMPP connection manager, with handling of single and multi user chats and voice calls"
12 HOMEPAGE="http://telepathy.freedesktop.org"
13 SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
18 IUSE="gnutls +jingle plugins test"
19
20 # Prevent false positives due nested configure
21 QA_CONFIGURE_OPTIONS=".*"
22
23 # FIXME: missing sasl-2 for tests ? (automagic)
24 # missing libiphb for wocky ?
25 # x11-libs/gtksourceview:3.0 needed by telepathy-gabble-xmpp-console, bug #495184
26 RDEPEND="
27 >=dev-libs/glib-2.32:2
28 >=sys-apps/dbus-1.1.0
29 >=dev-libs/dbus-glib-0.82
30 >=net-libs/telepathy-glib-0.19.9
31
32 dev-db/sqlite:3
33 dev-libs/libxml2
34
35 gnutls? ( >=net-libs/gnutls-2.10.2 )
36 !gnutls? ( >=dev-libs/openssl-0.9.8g:0[-bindist] )
37 jingle? ( || ( net-libs/libsoup:2.4[ssl]
38 >=net-libs/libsoup-2.33.1 )
39 >=net-libs/libnice-0.0.11 )
40 plugins? ( x11-libs/gtksourceview:3.0[introspection] )
41
42 !<net-im/telepathy-mission-control-5.5.0
43 "
44 DEPEND="${RDEPEND}
45 ${PYTHON_DEPS}
46 >=dev-util/gtk-doc-am-1.17
47 dev-libs/libxslt
48 test? ( >=dev-python/twisted-core-0.8.2
49 >=dev-python/twisted-words-0.8.2
50 >=dev-python/dbus-python-0.83 )
51 "
52
53 pkg_setup() {
54 python-any-r1_pkg_setup
55 }
56
57 src_configure() {
58 gnome2_src_configure \
59 --disable-coding-style-checks \
60 --disable-static \
61 --disable-Werror \
62 --enable-file-transfer \
63 $(use_enable jingle voip) \
64 $(use_enable jingle google-relay) \
65 $(use_enable plugins) \
66 --with-tls=$(usex gnutls gnutls openssl)
67 }
68
69 src_test() {
70 # Twisted tests fail, upstream bug #30565
71 emake -C tests check-TESTS
72 }

  ViewVC Help
Powered by ViewVC 1.1.20