/[gentoo-x86]/net-wireless/wpa_supplicant/wpa_supplicant-0.7.3.ebuild
Gentoo

Contents of /net-wireless/wpa_supplicant/wpa_supplicant-0.7.3.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Sun Jun 19 15:38:14 2011 UTC (9 years ago) by alexxy
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +1 -1 lines
FILE REMOVED
[net-wireless/wpa_supplicant] Fix for nm09 and systemd bug #371875

(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.7.3.ebuild,v 1.1 2010/09/08 17:34:33 gurligebis Exp $
4
5 EAPI="2"
6
7 inherit eutils toolchain-funcs qt4-r2
8
9 DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
10 HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
11 SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
12 LICENSE="|| ( GPL-2 BSD )"
13
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
16 IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
17
18 RDEPEND="dbus? ( sys-apps/dbus )
19 kernel_linux? (
20 eap-sim? ( sys-apps/pcsc-lite )
21 madwifi? ( ||
22 ( >net-wireless/madwifi-ng-tools-0.9.3
23 net-wireless/madwifi-old )
24 )
25 dev-libs/libnl
26 )
27 !kernel_linux? ( net-libs/libpcap )
28 qt4? ( x11-libs/qt-gui:4
29 x11-libs/qt-svg:4 )
30 readline? ( sys-libs/ncurses sys-libs/readline )
31 ssl? ( dev-libs/openssl )
32 !ssl? ( gnutls? ( net-libs/gnutls ) )
33 !ssl? ( !gnutls? ( dev-libs/libtommath ) )"
34 DEPEND="${RDEPEND}
35 dev-util/pkgconfig"
36
37 S="${WORKDIR}/${P}/${PN}"
38
39 pkg_setup() {
40 if use fasteap && (use gnutls || use ssl) ; then
41 die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
42 fi
43
44 if use gnutls && use ssl ; then
45 einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
46 fi
47 }
48
49 src_prepare() {
50 # net/bpf.h needed for net-libs/libpcap on Gentoo/FreeBSD
51 sed -i \
52 -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
53 ../src/l2_packet/l2_packet_freebsd.c || die
54
55 # People seem to take the example configuration file too literally (bug #102361)
56 sed -i \
57 -e "s:^\(opensc_engine_path\):#\1:" \
58 -e "s:^\(pkcs11_engine_path\):#\1:" \
59 -e "s:^\(pkcs11_module_path\):#\1:" \
60 wpa_supplicant.conf || die
61
62 # Change configuration to match Gentoo locations (bug #143750)
63 sed -i \
64 -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
65 -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
66 wpa_supplicant.conf || die
67
68 epatch "${FILESDIR}/${P}-dbus_path_fix.patch"
69
70 # bug (320097)
71 epatch "${FILESDIR}/do-not-call-dbus-functions-with-NULL-path.patch"
72 }
73
74 src_configure() {
75 # Toolchain setup
76 echo "CC = $(tc-getCC)" > .config
77
78 # Basic setup
79 echo "CONFIG_CTRL_IFACE=y" >> .config
80 echo "CONFIG_BACKEND=file" >> .config
81
82 # Basic authentication methods
83 # NOTE: we don't set GPSK or SAKE as they conflict
84 # with the below options
85 echo "CONFIG_EAP_GTC=y" >> .config
86 echo "CONFIG_EAP_MD5=y" >> .config
87 echo "CONFIG_EAP_OTP=y" >> .config
88 echo "CONFIG_EAP_PAX=y" >> .config
89 echo "CONFIG_EAP_PSK=y" >> .config
90 echo "CONFIG_EAP_TLV=y" >> .config
91 echo "CONFIG_IEEE8021X_EAPOL=y" >> .config
92 echo "CONFIG_PKCS12=y" >> .config
93 echo "CONFIG_PEERKEY=y" >> .config
94 echo "CONFIG_EAP_LEAP=y" >> .config
95 echo "CONFIG_EAP_MSCHAPV2=y" >> .config
96 echo "CONFIG_EAP_PEAP=y" >> .config
97 echo "CONFIG_EAP_TLS=y" >> .config
98 echo "CONFIG_EAP_TTLS=y" >> .config
99
100 if use dbus ; then
101 echo "CONFIG_CTRL_IFACE_DBUS=y" >> .config
102 fi
103
104 if use debug ; then
105 echo "CONFIG_DEBUG_FILE=y" >> .config
106 fi
107
108 if use eap-sim ; then
109 # Smart card authentication
110 echo "CONFIG_EAP_SIM=y" >> .config
111 echo "CONFIG_EAP_AKA=y" >> .config
112 echo "CONFIG_EAP_AKA_PRIME=y" >> .config
113 echo "CONFIG_PCSC=y" >> .config
114 fi
115
116 if use fasteap ; then
117 echo "CONFIG_EAP_FAST=y" >> .config
118 fi
119
120 if use readline ; then
121 # readline/history support for wpa_cli
122 echo "CONFIG_READLINE=y" >> .config
123 fi
124
125 # SSL authentication methods
126 if use ssl ; then
127 echo "CONFIG_TLS=openssl" >> .config
128 echo "CONFIG_SMARTCARD=y" >> .config
129 elif use gnutls ; then
130 echo "CONFIG_TLS=gnutls" >> .config
131 echo "CONFIG_GNUTLS_EXTRA=y" >> .config
132 else
133 echo "CONFIG_TLS=internal" >> .config
134 fi
135
136 if use kernel_linux ; then
137 # Linux specific drivers
138 echo "CONFIG_DRIVER_ATMEL=y" >> .config
139 #echo "CONFIG_DRIVER_BROADCOM=y" >> .config
140 #echo "CONFIG_DRIVER_HERMES=y" >> .config
141 echo "CONFIG_DRIVER_HOSTAP=y" >> .config
142 echo "CONFIG_DRIVER_IPW=y" >> .config
143 echo "CONFIG_DRIVER_NDISWRAPPER=y" >> .config
144 echo "CONFIG_DRIVER_NL80211=y" >> .config
145 #echo "CONFIG_DRIVER_PRISM54=y" >> .config
146 echo "CONFIG_DRIVER_RALINK=y" >> .config
147 echo "CONFIG_DRIVER_WEXT=y" >> .config
148 echo "CONFIG_DRIVER_WIRED=y" >> .config
149
150 if use madwifi ; then
151 # Add include path for madwifi-driver headers
152 echo "CFLAGS += -I/usr/include/madwifi" >> .config
153 echo "CONFIG_DRIVER_MADWIFI=y" >> .config
154 fi
155
156 if use ps3 ; then
157 echo "CONFIG_DRIVER_PS3=y" >> .config
158 fi
159
160 elif use kernel_FreeBSD ; then
161 # FreeBSD specific driver
162 echo "CONFIG_DRIVER_BSD=y" >> .config
163 fi
164
165 # Wi-Fi Protected Setup (WPS)
166 if use wps ; then
167 echo "CONFIG_WPS=y" >> .config
168 fi
169
170 # Enable mitigation against certain attacks against TKIP
171 echo "CONFIG_DELAYED_MIC_ERROR_REPORT=y" >> .config
172
173 if use qt4 ; then
174 cd "${S}"/wpa_gui-qt4
175 eqmake4 wpa_gui.pro
176 fi
177 }
178
179 src_compile() {
180 einfo "Building wpa_supplicant"
181 emake || die "emake failed"
182
183 if use qt4 ; then
184 cd "${S}"/wpa_gui-qt4
185 einfo "Building wpa_gui"
186 emake || die "wpa_gui compilation failed"
187 fi
188 }
189
190 src_install() {
191 dosbin wpa_supplicant || die
192 dobin wpa_cli wpa_passphrase || die
193
194 # baselayout-1 compat
195 if has_version "<sys-apps/baselayout-2.0.0"; then
196 dodir /sbin
197 dosym /usr/sbin/wpa_supplicant /sbin/wpa_supplicant || die
198 dodir /bin
199 dosym /usr/bin/wpa_cli /bin/wpa_cli || die
200 fi
201
202 if has_version ">=sys-apps/openrc-0.5.0"; then
203 newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
204 newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
205 fi
206
207 exeinto /etc/wpa_supplicant/
208 newexe "${FILESDIR}/wpa_cli.sh" wpa_cli.sh
209
210 dodoc ChangeLog {eap_testing,todo}.txt README{,-WPS} \
211 wpa_supplicant.conf || die "dodoc failed"
212
213 doman doc/docbook/*.{5,8} || die "doman failed"
214
215 if use qt4 ; then
216 into /usr
217 dobin wpa_gui-qt4/wpa_gui || die
218 doicon wpa_gui-qt4/icons/wpa_gui.svg || die "Icon not found"
219 make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
220 fi
221
222 if use dbus ; then
223 cd "${S}"/dbus
224 insinto /etc/dbus-1/system.d
225 newins dbus-wpa_supplicant.conf wpa_supplicant.conf || die
226 insinto /usr/share/dbus-1/system-services
227 doins fi.epitest.hostap.WPASupplicant.service || die
228 keepdir /var/run/wpa_supplicant
229 fi
230 }
231
232 pkg_postinst() {
233 einfo "If this is a clean installation of wpa_supplicant, you"
234 einfo "have to create a configuration file named"
235 einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
236 einfo
237 einfo "An example configuration file is available for reference in"
238 einfo "/usr/share/doc/${PF}/"
239
240 if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
241 echo
242 ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
243 ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
244 fi
245
246 if use madwifi ; then
247 echo
248 einfo "This package compiles against the headers installed by"
249 einfo "madwifi-old, madwifi-ng or madwifi-ng-tools."
250 einfo "You should re-emerge ${PN} after upgrading these packages."
251 fi
252 }

  ViewVC Help
Powered by ViewVC 1.1.20