/[gentoo-x86]/sci-geosciences/grass/grass-6.3.0.ebuild
Gentoo

Diff of /sci-geosciences/grass/grass-6.3.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.20 Revision 1.21
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/Attic/grass-6.3.0.ebuild,v 1.20 2011/02/26 21:03:51 armin76 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/Attic/grass-6.3.0.ebuild,v 1.21 2011/03/10 19:14:03 jlec Exp $
4 4
5EAPI=1 5EAPI=1
6 6
7inherit eutils distutils fdo-mime versionator wxwidgets 7inherit eutils distutils fdo-mime versionator wxwidgets
8 8
16 16
17LICENSE="GPL-2" 17LICENSE="GPL-2"
18SLOT="6" 18SLOT="6"
19KEYWORDS="amd64 ppc ~ppc64 x86" 19KEYWORDS="amd64 ppc ~ppc64 x86"
20 20
21IUSE="ffmpeg fftw gmath jpeg largefile motif mysql nls odbc opengl png \ 21IUSE="ffmpeg fftw gmath jpeg motif mysql nls odbc opengl png \
22postgres python readline sqlite tiff truetype wxwidgets X" 22postgres python readline sqlite tiff truetype wxwidgets X"
23 23
24RESTRICT="strip" 24RESTRICT="strip"
25 25
26RDEPEND=">=sys-libs/zlib-1.1.4 26RDEPEND=">=sys-libs/zlib-1.1.4
212 $(use_enable amd64 64bit) \ 212 $(use_enable amd64 64bit) \
213 $(use_with fftw) \ 213 $(use_with fftw) \
214 $(use_with gmath blas) \ 214 $(use_with gmath blas) \
215 $(use_with gmath lapack) \ 215 $(use_with gmath lapack) \
216 $(use_with jpeg) \ 216 $(use_with jpeg) \
217 $(use_enable largefile) \
218 $(use_with motif) \ 217 $(use_with motif) \
219 $(use_with nls) \ 218 $(use_with nls) \
220 $(use_with odbc) \ 219 $(use_with odbc) \
221 $(use_with png) \ 220 $(use_with png) \
222 $(use_with postgres) \ 221 $(use_with postgres) \
223 $(use_with readline) \ 222 $(use_with readline) \
224 $(use_with tiff) || die "configure failed!" 223 $(use_with tiff) \
224 --enable-largefile \
225 225
226 if use wxwidgets; then 226 if use wxwidgets; then
227 # can't use die here since we need to hack the vdigit build 227 # can't use die here since we need to hack the vdigit build
228 emake -j1 228 emake -j1
229 ln -sf "${LIBGDI}" dist.${CHOST}/lib/libgdi.so \ 229 ln -sf "${LIBGDI}" dist.${CHOST}/lib/libgdi.so \

Legend:
Removed from v.1.20  
changed lines
  Added in v.1.21

  ViewVC Help
Powered by ViewVC 1.1.20