/[gentoo-x86]/sci-mathematics/Macaulay2/Macaulay2-1.0.ebuild
Gentoo

Diff of /sci-mathematics/Macaulay2/Macaulay2-1.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.2 Revision 1.3
1# Copyright 1999-2008 Gentoo Foundation 1# Copyright 1999-2008 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/Attic/Macaulay2-1.0.ebuild,v 1.2 2008/01/07 06:27:55 mr_bones_ Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/Attic/Macaulay2-1.0.ebuild,v 1.3 2008/01/16 11:28:47 markusle Exp $
4 4
5inherit elisp-common eutils flag-o-matic toolchain-funcs autotools 5inherit elisp-common eutils flag-o-matic toolchain-funcs autotools
6 6
7IUSE="emacs" 7IUSE="emacs"
8 8
31 31
32pkg_setup() { 32pkg_setup() {
33 33
34 # boehm-gc currently is broken with USE='threads' 34 # boehm-gc currently is broken with USE='threads'
35 # (see bug #195335) causing Macaulay2 to fail 35 # (see bug #195335) causing Macaulay2 to fail
36 if built_with_use =dev-libs/boehm-gc-7* threads; then 36 if built_with_use "dev-libs/boehm-gc" "threads" \
37 && has_version "=dev-libs/boehm-gc-7*"; then
37 echo 38 echo
38 eerror "dev-libs/boehm-gc-7* with USE=\"threads\" is" 39 eerror "dev-libs/boehm-gc-7* with USE=\"threads\" is"
39 eerror "currently broken (see bug #195335) causing" 40 eerror "currently broken (see bug #195335) causing"
40 eerror "Macaulay to fail building. Please re-emerge" 41 eerror "Macaulay to fail building. Please re-emerge"
41 eerror "dev-libs/boehm-gc-7* with USE=\"-threads\"!" 42 eerror "dev-libs/boehm-gc-7* with USE=\"-threads\"!"

Legend:
Removed from v.1.2  
changed lines
  Added in v.1.3

  ViewVC Help
Powered by ViewVC 1.1.20