/[gentoo-x86]/sys-apps/policycoreutils/ChangeLog
Gentoo

Diff of /sys-apps/policycoreutils/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.52 Revision 1.115
1# ChangeLog for sys-apps/policycoreutils 1# ChangeLog for sys-apps/policycoreutils
2# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.52 2006/01/17 01:11:34 pebenito Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.115 2013/04/16 10:04:05 swift Exp $
4
5 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
6 -policycoreutils-2.1.10-r1.ebuild, -policycoreutils-2.1.10-r3.ebuild,
7 -policycoreutils-2.1.10-r4.ebuild, -policycoreutils-2.1.10.ebuild:
8 Some cleanup (older release unstables)
9
10 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
11 policycoreutils-2.1.13-r9.ebuild:
12 Stabilize policycoreutils-2.1.13-r9
13
14*policycoreutils-2.1.13-r9 (19 Mar 2013)
15
16 19 Mar 2013; Sven Vermeulen <swift@gentoo.org>
17 +policycoreutils-2.1.13-r9.ebuild:
18 Fix bug #457786 - Link runscript_selinux with crypt
19
20*policycoreutils-2.1.13-r8 (10 Mar 2013)
21
22 10 Mar 2013; Sven Vermeulen <swift@gentoo.org>
23 +policycoreutils-2.1.13-r8.ebuild:
24 Adding selinux_gentoo init script for initramfs and cpu/online support
25 (#456914)
26
27*policycoreutils-2.1.13-r7 (09 Mar 2013)
28
29 09 Mar 2013; Sven Vermeulen <swift@gentoo.org>
30 +policycoreutils-2.1.13-r7.ebuild:
31 Update policycoreutils-extras to fix build failure when not building with PAM
32 support, see bug #457786
33
34*policycoreutils-2.1.13-r6 (30 Dec 2012)
35
36 30 Dec 2012; Sven Vermeulen +policycoreutils-2.1.13-r6.ebuild,
37 policycoreutils-2.1.13-r5.ebuild:
38 Stabilize r5, get r6 available as well which fixes rlpkg to include zfs
39 support
40
41*policycoreutils-2.1.13-r5 (17 Nov 2012)
42
43 17 Nov 2012; <swift@gentoo.org> policycoreutils-2.1.13-r4.ebuild,
44 +policycoreutils-2.1.13-r5.ebuild:
45 Stabilization, move sesandbox support to next release
46
47*policycoreutils-2.1.13-r4 (14 Oct 2012)
48
49 14 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r4.ebuild:
50 Remove support for python3 until upstream supports it
51
52 13 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.13-r3.ebuild:
53 Supporting user-provided patches using epatch_user
54
55*policycoreutils-2.1.13-r3 (09 Oct 2012)
56
57 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
58 Introducing new upstream release
59
60 06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
61 Stabilize
62
63*policycoreutils-2.1.10-r5 (08 Sep 2012)
64
65 08 Sep 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r5.ebuild:
66 Fix bug #427596 and #430806
67
68 10 Jul 2012; <swift@gentoo.org> policycoreutils-2.1.10-r3.ebuild:
69 Stabilization, drop libcgroup dependency along the way
70
71*policycoreutils-2.1.10-r4 (10 Jul 2012)
72
73 10 Jul 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r4.ebuild:
74 Support refpolicy style audit2allow (#417199)
75
76 26 Jun 2012; Mike Gilbert <floppym@gentoo.org>
77 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild,
78 policycoreutils-2.1.10.ebuild:
79 Restrict pypy per Arfrever.
80
81*policycoreutils-2.1.10-r3 (25 Jun 2012)
82
83 25 Jun 2012; <swift@gentoo.org>
84 +files/policycoreutils-extra-1.21-fix-python3.patch,
85 +policycoreutils-2.1.10-r3.ebuild:
86 Improve support for python3, fixes bug #416301
87
88 13 May 2012; <swift@gentoo.org> -policycoreutils-2.1.0-r1.ebuild,
89 -policycoreutils-2.1.0-r2.ebuild:
90 Removing obsoleted ebuilds
91
92*policycoreutils-2.1.10-r1 (29 Apr 2012)
93
94 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild,
95 +policycoreutils-2.1.10-r1.ebuild:
96 Remove dependency on libcgroup (but drop sesandbox support along the way)
97
98 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild:
99 Stabilization
100
101*policycoreutils-2.1.10 (31 Mar 2012)
102
103 31 Mar 2012; <swift@gentoo.org> +policycoreutils-2.1.10.ebuild, metadata.xml:
104 Bump to version 2.1.10
105
106 26 Feb 2012; <swift@gentoo.org> policycoreutils-2.1.0-r2.ebuild:
107 Stabilization
108
109 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild,
110 metadata.xml:
111 Mark audit as a local USE flag
112
113*policycoreutils-2.1.0-r2 (14 Jan 2012)
114
115 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild:
116 Override auto-detection of pam and audit, use USE flags for this
117
118 12 Nov 2011; <swift@gentoo.org> -policycoreutils-2.0.82.ebuild,
119 -policycoreutils-2.0.82-r1.ebuild, -policycoreutils-2.0.85.ebuild,
120 -policycoreutils-2.1.0.ebuild:
121 removing obsoleted ebuilds
122
123 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.1.0-r1.ebuild:
124 Stabilization (tracker #384231)
125
126 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.0.82-r1.ebuild:
127 Stabilize 2.0.82-r1 to fix #372807
128
129*policycoreutils-2.1.0-r1 (17 Sep 2011)
130
131 17 Sep 2011; <swift@gentoo.org> +policycoreutils-2.1.0-r1.ebuild:
132 Add /var/lib/selinux directory, needed for 'semodule permissive' support (bug
133 #381755)
134
135 02 Sep 2011; <swift@gentoo.org> policycoreutils-2.0.85.ebuild,
136 policycoreutils-2.1.0.ebuild:
137 Update patch locations to dev.g.o instead of files/ folder
138
139 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
140 -policycoreutils-2.0.55.ebuild, -policycoreutils-2.0.69.ebuild,
141 -policycoreutils-2.0.69-r1.ebuild, -policycoreutils-2.0.69-r2.ebuild,
142 -files/policycoreutils-2.0.69-setfiles.diff:
143 Removed deprecated versions
144
145*policycoreutils-2.1.0 (03 Aug 2011)
146
147 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
148 +policycoreutils-2.1.0.ebuild:
149 Bump to 20110727 SELinux userspace release
150
151*policycoreutils-2.0.85 (15 Jul 2011)
152
153 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
154 +policycoreutils-2.0.85.ebuild,
155 +files/policycoreutils-2.0.85-fix-seunshare-vuln.patch.gz,
156 +files/policycoreutils-2.0.85-sesandbox.patch.gz:
157 Add fix for bug #374897 and initial support for python3
158
159 08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
160 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
161 policycoreutils-2.0.69-r1.ebuild, policycoreutils-2.0.69-r2.ebuild:
162 Convert from "useq" to "use".
163
164*policycoreutils-2.0.82-r1 (30 Jun 2011)
165
166 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
167 +policycoreutils-2.0.82-r1.ebuild:
168 Overwrite invalid .po files with valid ones, fixes bug #372807
169
170 16 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
171 policycoreutils-2.0.82.ebuild:
172 Drop use_nls dependency on gettext. Its mandatory. See bug #299681.
173 Also put gettext in COMMON_DEPS, it is more than a RDEPEND.
174
175 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
176 policycoreutils-2.0.82.ebuild:
177 Stable amd64 x86
178
179 16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
180 Updated metadata info.
181
182 08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
183 policycoreutils-2.0.82.ebuild:
184 Set SUPPORT_PYTHON_ABIS (bug #353762). Fix dependencies. Fix installation
185 with FEATURES="multilib-strict".
186
187*policycoreutils-2.0.82 (05 Feb 2011)
188
189 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
190 +policycoreutils-2.0.82.ebuild:
191 New upstream release.
192
193*policycoreutils-2.0.69-r2 (05 Feb 2011)
194
195 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
196 +policycoreutils-2.0.69-r2.ebuild,
197 +files/policycoreutils-2.0.69-setfiles.diff:
198 Fixed bug #300613
199
200 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
201 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
202 policycoreutils-2.0.69-r1.ebuild:
203 Delete calls to deprecated python_version().
204
205*policycoreutils-2.0.69-r1 (20 Sep 2009)
206
207 20 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
208 +policycoreutils-2.0.69-r1.ebuild:
209 Update rlpkg for ext4 and btrfs.
210
211 14 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
212 policycoreutils-2.0.69.ebuild:
213 Fix libsemanage DEP.
214
215 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
216 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild:
217 Add python_need_rebuild.
218
219*policycoreutils-2.0.69 (02 Aug 2009)
220
221 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
222 +policycoreutils-2.0.69.ebuild:
223 New upstream release.
224
225 18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
226 -policycoreutils-1.34.15.ebuild, policycoreutils-2.0.55.ebuild:
227 Mark stable. Remove old ebuilds.
228
229*policycoreutils-2.0.55 (03 Oct 2008)
230
231 03 Oct 2008; Chris PeBenito <pebenito@gentoo.org>
232 +policycoreutils-2.0.55.ebuild:
233 Initial commit of policycoreutils 2.0.
234
235 29 May 2008; Ali Polatel <hawking@gentoo.org>
236 policycoreutils-1.34.15.ebuild:
237 python_mod_optimize is ROOT aware. Fixed python_mod_cleanup.
238
239 26 May 2008; Chris PeBenito <pebenito@gentoo.org>
240 policycoreutils-1.34.15.ebuild:
241 Fix libsemanage dependency.
242
243 13 May 2008; Chris PeBenito <pebenito@gentoo.org>
244 -files/policycoreutils-1.28-quietlp.diff,
245 -files/policycoreutils-1.32-quietlp.diff,
246 -files/policycoreutils-unsigned-char-ppc.diff,
247 -policycoreutils-1.28.ebuild, -policycoreutils-1.30-r1.ebuild,
248 -policycoreutils-1.34.1.ebuild, -policycoreutils-1.34.11.ebuild,
249 policycoreutils-1.34.15.ebuild:
250 Mark 1.34.15 stable, clear old ebuilds.
251
252*policycoreutils-1.34.15 (29 Jan 2008)
253
254 29 Jan 2008; Chris PeBenito <pebenito@gentoo.org>
255 +policycoreutils-1.34.15.ebuild:
256 New upstream bugfix release.
257
258 19 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
259 policycoreutils-1.34.11.ebuild:
260 Fix quoting in unpack.
261
262*policycoreutils-1.34.11 (18 Oct 2007)
263
264 18 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
265 +policycoreutils-1.34.11.ebuild:
266 New upstream release.
267
268 04 Jun 2007; Chris PeBenito <pebenito@gentoo.org>
269 policycoreutils-1.34.1.ebuild:
270 Mark stable.
271
272*policycoreutils-1.34.1 (15 Feb 2007)
273
274 15 Feb 2007; Chris PeBenito <pebenito@gentoo.org>
275 +policycoreutils-1.34.1.ebuild:
276 New upstream release.
277
278 24 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
279 policycoreutils-1.30.30.ebuild:
280 Fix glibc handling.
281
282 09 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
283 policycoreutils-1.30.30.ebuild:
284 Stable to make repoman happy.
285
286*policycoreutils-1.30.30 (05 Oct 2006)
287
288 05 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
289 +files/policycoreutils-1.32-quietlp.diff, +policycoreutils-1.30.30.ebuild:
290 Add SVN snapshot and updated extras in preparation for reference policy.
291
292 31 Jul 2006; Chris PeBenito <pebenito@gentoo.org>
293 policycoreutils-1.30-r1.ebuild:
294 Mark stable, long overdue.
295
296*policycoreutils-1.30-r1 (28 Mar 2006)
297
298 28 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
299 -policycoreutils-1.30.ebuild, +policycoreutils-1.30-r1.ebuild:
300 Fix install location of python site packages.
301
302 22 Feb 2006; Stephen Bennett <spb@gentoo.org> policycoreutils-1.28.ebuild:
303 Alpha stable
304
305 19 Feb 2006; Joshua Kinard <kumba@gentoo.org> policycoreutils-1.28.ebuild:
306 Marked stable on mips.
307
308*policycoreutils-1.30 (18 Mar 2006)
309
310 18 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
311 +policycoreutils-1.30.ebuild:
312 New upstream release.
313
314 05 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
315 +files/policycoreutils-unsigned-char-ppc.diff,
316 policycoreutils-1.28.ebuild:
317 Add patch to fix #121689.
4 318
5 17 Jan 2006; Chris PeBenito <pebenito@gentoo.org> 319 17 Jan 2006; Chris PeBenito <pebenito@gentoo.org>
6 policycoreutils-1.28.ebuild: 320 policycoreutils-1.28.ebuild:
7 Mark stable, x86, amd64, ppc, sparc. 321 Mark stable, x86, amd64, ppc, sparc.
8 322
260*policycoreutils-1.0 (03 Aug 2003) 574*policycoreutils-1.0 (03 Aug 2003)
261 575
262 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml, 576 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml,
263 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff: 577 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff:
264 Initial commit 578 Initial commit
265

Legend:
Removed from v.1.52  
changed lines
  Added in v.1.115

  ViewVC Help
Powered by ViewVC 1.1.20