/[gentoo-x86]/sys-apps/policycoreutils/ChangeLog
Gentoo

Diff of /sys-apps/policycoreutils/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.52 Revision 1.130
1# ChangeLog for sys-apps/policycoreutils 1# ChangeLog for sys-apps/policycoreutils
2# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.52 2006/01/17 01:11:34 pebenito Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.130 2014/01/12 21:01:41 swift Exp $
4
5*policycoreutils-2.1.14-r5 (12 Jan 2014)
6
7 12 Jan 2014; Sven Vermeulen <swift@gentoo.org>
8 +policycoreutils-2.1.14-r5.ebuild:
9 Backport BUILD_DIR change to 2.1.14 (needed to have runscript_selinux follow
10 USE flag info)
11
12*policycoreutils-2.2.5-r2 (12 Jan 2014)
13
14 12 Jan 2014; Sven Vermeulen <swift@gentoo.org>
15 +policycoreutils-2.2.5-r2.ebuild:
16 Use python builddir locations for installation, otherwise a non-built
17 directory will be used, dismissing all configuration variables mentioned
18 earlier
19
20 23 Dec 2013; Sven Vermeulen <swift@gentoo.org>
21 -policycoreutils-2.1.13-r3.ebuild, -policycoreutils-2.1.13-r4.ebuild,
22 -policycoreutils-2.1.13-r5.ebuild, -policycoreutils-2.1.13-r6.ebuild,
23 -policycoreutils-2.1.13-r7.ebuild, -policycoreutils-2.1.13-r8.ebuild,
24 -policycoreutils-2.1.13-r9.ebuild, -policycoreutils-2.1.13-r10.ebuild,
25 -policycoreutils-2.1.13-r11.ebuild:
26 Cleanup old versions
27
28*policycoreutils-2.2.5-r1 (10 Dec 2013)
29
30 10 Dec 2013; Sven Vermeulen <swift@gentoo.org>
31 +policycoreutils-2.2.5-r1.ebuild:
32 Adding 2.2.5 release
33
34*policycoreutils-2.2.1-r1 (04 Nov 2013)
35
36 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
37 +policycoreutils-2.2.1-r1.ebuild:
38 New policycoreutils release
39
40 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
41 policycoreutils-2.1.14-r4.ebuild:
42 Stabilize
43
44*policycoreutils-2.1.14-r4 (13 Aug 2013)
45
46 13 Aug 2013; Sven Vermeulen <swift@gentoo.org>
47 +policycoreutils-2.1.14-r4.ebuild:
48 Document setfiles in rlpkg, improve selocal resilience
49
50 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
51 -policycoreutils-2.1.10-r5.ebuild:
52 Summer cleaning
53
54*policycoreutils-2.1.14-r3 (07 Jul 2013)
55
56 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
57 +policycoreutils-2.1.14-r3.ebuild:
58 Switch to python-r1 eclass, add in mcstrans (bug #472912)
59
60 16 Jun 2013; Sven Vermeulen <swift@gentoo.org>
61 policycoreutils-2.1.14-r2.ebuild:
62 Stabilization
63
64 10 May 2013; Sven Vermeulen <swift@gentoo.org> metadata.xml:
65 Add in CPE data for policycoreutils, historical CVEs use redhat as
66 application vendor
67
68*policycoreutils-2.1.14-r2 (07 May 2013)
69
70 07 May 2013; Sven Vermeulen <swift@gentoo.org>
71 +policycoreutils-2.1.14-r2.ebuild:
72 Fix bugs 467268 (yum bindings), 468832 (key error), 468830 (mls range
73 dependency)
74
75*policycoreutils-2.1.14-r1 (25 Apr 2013)
76
77 25 Apr 2013; Sven Vermeulen <swift@gentoo.org>
78 +policycoreutils-2.1.14-r1.ebuild:
79 New upstream release
80
81*policycoreutils-2.1.13-r11 (19 Apr 2013)
82
83 19 Apr 2013; Sven Vermeulen <swift@gentoo.org>
84 +policycoreutils-2.1.13-r11.ebuild:
85 Add selocal command to policycoreutils
86
87*policycoreutils-2.1.13-r10 (16 Apr 2013)
88
89 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
90 +policycoreutils-2.1.13-r10.ebuild:
91 Fix bugs #463222 (newrole O_RDWR) and #464808 (hardcoded python3.1 in rlpkg)
92
93 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
94 -policycoreutils-2.1.10-r1.ebuild, -policycoreutils-2.1.10-r3.ebuild,
95 -policycoreutils-2.1.10-r4.ebuild, -policycoreutils-2.1.10.ebuild:
96 Some cleanup (older release unstables)
97
98 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
99 policycoreutils-2.1.13-r9.ebuild:
100 Stabilize policycoreutils-2.1.13-r9
101
102*policycoreutils-2.1.13-r9 (19 Mar 2013)
103
104 19 Mar 2013; Sven Vermeulen <swift@gentoo.org>
105 +policycoreutils-2.1.13-r9.ebuild:
106 Fix bug #457786 - Link runscript_selinux with crypt
107
108*policycoreutils-2.1.13-r8 (10 Mar 2013)
109
110 10 Mar 2013; Sven Vermeulen <swift@gentoo.org>
111 +policycoreutils-2.1.13-r8.ebuild:
112 Adding selinux_gentoo init script for initramfs and cpu/online support
113 (#456914)
114
115*policycoreutils-2.1.13-r7 (09 Mar 2013)
116
117 09 Mar 2013; Sven Vermeulen <swift@gentoo.org>
118 +policycoreutils-2.1.13-r7.ebuild:
119 Update policycoreutils-extras to fix build failure when not building with PAM
120 support, see bug #457786
121
122*policycoreutils-2.1.13-r6 (30 Dec 2012)
123
124 30 Dec 2012; Sven Vermeulen +policycoreutils-2.1.13-r6.ebuild,
125 policycoreutils-2.1.13-r5.ebuild:
126 Stabilize r5, get r6 available as well which fixes rlpkg to include zfs
127 support
128
129*policycoreutils-2.1.13-r5 (17 Nov 2012)
130
131 17 Nov 2012; <swift@gentoo.org> policycoreutils-2.1.13-r4.ebuild,
132 +policycoreutils-2.1.13-r5.ebuild:
133 Stabilization, move sesandbox support to next release
134
135*policycoreutils-2.1.13-r4 (14 Oct 2012)
136
137 14 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r4.ebuild:
138 Remove support for python3 until upstream supports it
139
140 13 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.13-r3.ebuild:
141 Supporting user-provided patches using epatch_user
142
143*policycoreutils-2.1.13-r3 (09 Oct 2012)
144
145 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
146 Introducing new upstream release
147
148 06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
149 Stabilize
150
151*policycoreutils-2.1.10-r5 (08 Sep 2012)
152
153 08 Sep 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r5.ebuild:
154 Fix bug #427596 and #430806
155
156 10 Jul 2012; <swift@gentoo.org> policycoreutils-2.1.10-r3.ebuild:
157 Stabilization, drop libcgroup dependency along the way
158
159*policycoreutils-2.1.10-r4 (10 Jul 2012)
160
161 10 Jul 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r4.ebuild:
162 Support refpolicy style audit2allow (#417199)
163
164 26 Jun 2012; Mike Gilbert <floppym@gentoo.org>
165 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild,
166 policycoreutils-2.1.10.ebuild:
167 Restrict pypy per Arfrever.
168
169*policycoreutils-2.1.10-r3 (25 Jun 2012)
170
171 25 Jun 2012; <swift@gentoo.org>
172 +files/policycoreutils-extra-1.21-fix-python3.patch,
173 +policycoreutils-2.1.10-r3.ebuild:
174 Improve support for python3, fixes bug #416301
175
176 13 May 2012; <swift@gentoo.org> -policycoreutils-2.1.0-r1.ebuild,
177 -policycoreutils-2.1.0-r2.ebuild:
178 Removing obsoleted ebuilds
179
180*policycoreutils-2.1.10-r1 (29 Apr 2012)
181
182 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild,
183 +policycoreutils-2.1.10-r1.ebuild:
184 Remove dependency on libcgroup (but drop sesandbox support along the way)
185
186 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild:
187 Stabilization
188
189*policycoreutils-2.1.10 (31 Mar 2012)
190
191 31 Mar 2012; <swift@gentoo.org> +policycoreutils-2.1.10.ebuild, metadata.xml:
192 Bump to version 2.1.10
193
194 26 Feb 2012; <swift@gentoo.org> policycoreutils-2.1.0-r2.ebuild:
195 Stabilization
196
197 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild,
198 metadata.xml:
199 Mark audit as a local USE flag
200
201*policycoreutils-2.1.0-r2 (14 Jan 2012)
202
203 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild:
204 Override auto-detection of pam and audit, use USE flags for this
205
206 12 Nov 2011; <swift@gentoo.org> -policycoreutils-2.0.82.ebuild,
207 -policycoreutils-2.0.82-r1.ebuild, -policycoreutils-2.0.85.ebuild,
208 -policycoreutils-2.1.0.ebuild:
209 removing obsoleted ebuilds
210
211 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.1.0-r1.ebuild:
212 Stabilization (tracker #384231)
213
214 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.0.82-r1.ebuild:
215 Stabilize 2.0.82-r1 to fix #372807
216
217*policycoreutils-2.1.0-r1 (17 Sep 2011)
218
219 17 Sep 2011; <swift@gentoo.org> +policycoreutils-2.1.0-r1.ebuild:
220 Add /var/lib/selinux directory, needed for 'semodule permissive' support (bug
221 #381755)
222
223 02 Sep 2011; <swift@gentoo.org> policycoreutils-2.0.85.ebuild,
224 policycoreutils-2.1.0.ebuild:
225 Update patch locations to dev.g.o instead of files/ folder
226
227 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
228 -policycoreutils-2.0.55.ebuild, -policycoreutils-2.0.69.ebuild,
229 -policycoreutils-2.0.69-r1.ebuild, -policycoreutils-2.0.69-r2.ebuild,
230 -files/policycoreutils-2.0.69-setfiles.diff:
231 Removed deprecated versions
232
233*policycoreutils-2.1.0 (03 Aug 2011)
234
235 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
236 +policycoreutils-2.1.0.ebuild:
237 Bump to 20110727 SELinux userspace release
238
239*policycoreutils-2.0.85 (15 Jul 2011)
240
241 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
242 +policycoreutils-2.0.85.ebuild,
243 +files/policycoreutils-2.0.85-fix-seunshare-vuln.patch.gz,
244 +files/policycoreutils-2.0.85-sesandbox.patch.gz:
245 Add fix for bug #374897 and initial support for python3
246
247 08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
248 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
249 policycoreutils-2.0.69-r1.ebuild, policycoreutils-2.0.69-r2.ebuild:
250 Convert from "useq" to "use".
251
252*policycoreutils-2.0.82-r1 (30 Jun 2011)
253
254 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
255 +policycoreutils-2.0.82-r1.ebuild:
256 Overwrite invalid .po files with valid ones, fixes bug #372807
257
258 16 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
259 policycoreutils-2.0.82.ebuild:
260 Drop use_nls dependency on gettext. Its mandatory. See bug #299681.
261 Also put gettext in COMMON_DEPS, it is more than a RDEPEND.
262
263 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
264 policycoreutils-2.0.82.ebuild:
265 Stable amd64 x86
266
267 16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
268 Updated metadata info.
269
270 08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
271 policycoreutils-2.0.82.ebuild:
272 Set SUPPORT_PYTHON_ABIS (bug #353762). Fix dependencies. Fix installation
273 with FEATURES="multilib-strict".
274
275*policycoreutils-2.0.82 (05 Feb 2011)
276
277 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
278 +policycoreutils-2.0.82.ebuild:
279 New upstream release.
280
281*policycoreutils-2.0.69-r2 (05 Feb 2011)
282
283 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
284 +policycoreutils-2.0.69-r2.ebuild,
285 +files/policycoreutils-2.0.69-setfiles.diff:
286 Fixed bug #300613
287
288 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
289 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
290 policycoreutils-2.0.69-r1.ebuild:
291 Delete calls to deprecated python_version().
292
293*policycoreutils-2.0.69-r1 (20 Sep 2009)
294
295 20 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
296 +policycoreutils-2.0.69-r1.ebuild:
297 Update rlpkg for ext4 and btrfs.
298
299 14 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
300 policycoreutils-2.0.69.ebuild:
301 Fix libsemanage DEP.
302
303 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
304 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild:
305 Add python_need_rebuild.
306
307*policycoreutils-2.0.69 (02 Aug 2009)
308
309 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
310 +policycoreutils-2.0.69.ebuild:
311 New upstream release.
312
313 18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
314 -policycoreutils-1.34.15.ebuild, policycoreutils-2.0.55.ebuild:
315 Mark stable. Remove old ebuilds.
316
317*policycoreutils-2.0.55 (03 Oct 2008)
318
319 03 Oct 2008; Chris PeBenito <pebenito@gentoo.org>
320 +policycoreutils-2.0.55.ebuild:
321 Initial commit of policycoreutils 2.0.
322
323 29 May 2008; Ali Polatel <hawking@gentoo.org>
324 policycoreutils-1.34.15.ebuild:
325 python_mod_optimize is ROOT aware. Fixed python_mod_cleanup.
326
327 26 May 2008; Chris PeBenito <pebenito@gentoo.org>
328 policycoreutils-1.34.15.ebuild:
329 Fix libsemanage dependency.
330
331 13 May 2008; Chris PeBenito <pebenito@gentoo.org>
332 -files/policycoreutils-1.28-quietlp.diff,
333 -files/policycoreutils-1.32-quietlp.diff,
334 -files/policycoreutils-unsigned-char-ppc.diff,
335 -policycoreutils-1.28.ebuild, -policycoreutils-1.30-r1.ebuild,
336 -policycoreutils-1.34.1.ebuild, -policycoreutils-1.34.11.ebuild,
337 policycoreutils-1.34.15.ebuild:
338 Mark 1.34.15 stable, clear old ebuilds.
339
340*policycoreutils-1.34.15 (29 Jan 2008)
341
342 29 Jan 2008; Chris PeBenito <pebenito@gentoo.org>
343 +policycoreutils-1.34.15.ebuild:
344 New upstream bugfix release.
345
346 19 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
347 policycoreutils-1.34.11.ebuild:
348 Fix quoting in unpack.
349
350*policycoreutils-1.34.11 (18 Oct 2007)
351
352 18 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
353 +policycoreutils-1.34.11.ebuild:
354 New upstream release.
355
356 04 Jun 2007; Chris PeBenito <pebenito@gentoo.org>
357 policycoreutils-1.34.1.ebuild:
358 Mark stable.
359
360*policycoreutils-1.34.1 (15 Feb 2007)
361
362 15 Feb 2007; Chris PeBenito <pebenito@gentoo.org>
363 +policycoreutils-1.34.1.ebuild:
364 New upstream release.
365
366 24 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
367 policycoreutils-1.30.30.ebuild:
368 Fix glibc handling.
369
370 09 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
371 policycoreutils-1.30.30.ebuild:
372 Stable to make repoman happy.
373
374*policycoreutils-1.30.30 (05 Oct 2006)
375
376 05 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
377 +files/policycoreutils-1.32-quietlp.diff, +policycoreutils-1.30.30.ebuild:
378 Add SVN snapshot and updated extras in preparation for reference policy.
379
380 31 Jul 2006; Chris PeBenito <pebenito@gentoo.org>
381 policycoreutils-1.30-r1.ebuild:
382 Mark stable, long overdue.
383
384*policycoreutils-1.30-r1 (28 Mar 2006)
385
386 28 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
387 -policycoreutils-1.30.ebuild, +policycoreutils-1.30-r1.ebuild:
388 Fix install location of python site packages.
389
390 22 Feb 2006; Stephen Bennett <spb@gentoo.org> policycoreutils-1.28.ebuild:
391 Alpha stable
392
393 19 Feb 2006; Joshua Kinard <kumba@gentoo.org> policycoreutils-1.28.ebuild:
394 Marked stable on mips.
395
396*policycoreutils-1.30 (18 Mar 2006)
397
398 18 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
399 +policycoreutils-1.30.ebuild:
400 New upstream release.
401
402 05 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
403 +files/policycoreutils-unsigned-char-ppc.diff,
404 policycoreutils-1.28.ebuild:
405 Add patch to fix #121689.
4 406
5 17 Jan 2006; Chris PeBenito <pebenito@gentoo.org> 407 17 Jan 2006; Chris PeBenito <pebenito@gentoo.org>
6 policycoreutils-1.28.ebuild: 408 policycoreutils-1.28.ebuild:
7 Mark stable, x86, amd64, ppc, sparc. 409 Mark stable, x86, amd64, ppc, sparc.
8 410
260*policycoreutils-1.0 (03 Aug 2003) 662*policycoreutils-1.0 (03 Aug 2003)
261 663
262 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml, 664 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml,
263 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff: 665 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff:
264 Initial commit 666 Initial commit
265

Legend:
Removed from v.1.52  
changed lines
  Added in v.1.130

  ViewVC Help
Powered by ViewVC 1.1.20