/[gentoo-x86]/sys-apps/policycoreutils/ChangeLog
Gentoo

Diff of /sys-apps/policycoreutils/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.52 Revision 1.135
1# ChangeLog for sys-apps/policycoreutils 1# ChangeLog for sys-apps/policycoreutils
2# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.52 2006/01/17 01:11:34 pebenito Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.135 2014/05/09 20:32:10 swift Exp $
4
5*policycoreutils-2.3 (09 May 2014)
6
7 09 May 2014; Sven Vermeulen <swift@gentoo.org> +policycoreutils-2.3.ebuild:
8 Bump to 2.3
9
10*policycoreutils-2.3_rc1-r1 (09 May 2014)
11
12 09 May 2014; Sven Vermeulen <swift@gentoo.org>
13 +policycoreutils-2.2.5-r4.ebuild, +policycoreutils-2.3_rc1-r1.ebuild:
14 Do not build seunshare/sesandbox, cfr bug #509896
15
16*policycoreutils-2.3_rc1 (28 Apr 2014)
17
18 28 Apr 2014; Sven Vermeulen <swift@gentoo.org>
19 +policycoreutils-2.3_rc1.ebuild:
20 2.3-rc1 release
21
22*policycoreutils-2.2.5-r3 (19 Apr 2014)
23
24 19 Apr 2014; Sven Vermeulen <swift@gentoo.org>
25 +policycoreutils-2.2.5-r3.ebuild, policycoreutils-2.2.5-r1.ebuild:
26 Fix bug #507992 - Do not push out restorecond init script if restorecond
27 should not be installed
28
29 20 Jan 2014; Sven Vermeulen <swift@gentoo.org>
30 policycoreutils-2.2.5-r2.ebuild:
31 Stabilize for amd64 and x86
32
33*policycoreutils-2.1.14-r5 (12 Jan 2014)
34
35 12 Jan 2014; Sven Vermeulen <swift@gentoo.org>
36 +policycoreutils-2.1.14-r5.ebuild:
37 Backport BUILD_DIR change to 2.1.14 (needed to have runscript_selinux follow
38 USE flag info)
39
40*policycoreutils-2.2.5-r2 (12 Jan 2014)
41
42 12 Jan 2014; Sven Vermeulen <swift@gentoo.org>
43 +policycoreutils-2.2.5-r2.ebuild:
44 Use python builddir locations for installation, otherwise a non-built
45 directory will be used, dismissing all configuration variables mentioned
46 earlier
47
48 23 Dec 2013; Sven Vermeulen <swift@gentoo.org>
49 -policycoreutils-2.1.13-r3.ebuild, -policycoreutils-2.1.13-r4.ebuild,
50 -policycoreutils-2.1.13-r5.ebuild, -policycoreutils-2.1.13-r6.ebuild,
51 -policycoreutils-2.1.13-r7.ebuild, -policycoreutils-2.1.13-r8.ebuild,
52 -policycoreutils-2.1.13-r9.ebuild, -policycoreutils-2.1.13-r10.ebuild,
53 -policycoreutils-2.1.13-r11.ebuild:
54 Cleanup old versions
55
56*policycoreutils-2.2.5-r1 (10 Dec 2013)
57
58 10 Dec 2013; Sven Vermeulen <swift@gentoo.org>
59 +policycoreutils-2.2.5-r1.ebuild:
60 Adding 2.2.5 release
61
62*policycoreutils-2.2.1-r1 (04 Nov 2013)
63
64 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
65 +policycoreutils-2.2.1-r1.ebuild:
66 New policycoreutils release
67
68 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
69 policycoreutils-2.1.14-r4.ebuild:
70 Stabilize
71
72*policycoreutils-2.1.14-r4 (13 Aug 2013)
73
74 13 Aug 2013; Sven Vermeulen <swift@gentoo.org>
75 +policycoreutils-2.1.14-r4.ebuild:
76 Document setfiles in rlpkg, improve selocal resilience
77
78 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
79 -policycoreutils-2.1.10-r5.ebuild:
80 Summer cleaning
81
82*policycoreutils-2.1.14-r3 (07 Jul 2013)
83
84 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
85 +policycoreutils-2.1.14-r3.ebuild:
86 Switch to python-r1 eclass, add in mcstrans (bug #472912)
87
88 16 Jun 2013; Sven Vermeulen <swift@gentoo.org>
89 policycoreutils-2.1.14-r2.ebuild:
90 Stabilization
91
92 10 May 2013; Sven Vermeulen <swift@gentoo.org> metadata.xml:
93 Add in CPE data for policycoreutils, historical CVEs use redhat as
94 application vendor
95
96*policycoreutils-2.1.14-r2 (07 May 2013)
97
98 07 May 2013; Sven Vermeulen <swift@gentoo.org>
99 +policycoreutils-2.1.14-r2.ebuild:
100 Fix bugs 467268 (yum bindings), 468832 (key error), 468830 (mls range
101 dependency)
102
103*policycoreutils-2.1.14-r1 (25 Apr 2013)
104
105 25 Apr 2013; Sven Vermeulen <swift@gentoo.org>
106 +policycoreutils-2.1.14-r1.ebuild:
107 New upstream release
108
109*policycoreutils-2.1.13-r11 (19 Apr 2013)
110
111 19 Apr 2013; Sven Vermeulen <swift@gentoo.org>
112 +policycoreutils-2.1.13-r11.ebuild:
113 Add selocal command to policycoreutils
114
115*policycoreutils-2.1.13-r10 (16 Apr 2013)
116
117 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
118 +policycoreutils-2.1.13-r10.ebuild:
119 Fix bugs #463222 (newrole O_RDWR) and #464808 (hardcoded python3.1 in rlpkg)
120
121 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
122 -policycoreutils-2.1.10-r1.ebuild, -policycoreutils-2.1.10-r3.ebuild,
123 -policycoreutils-2.1.10-r4.ebuild, -policycoreutils-2.1.10.ebuild:
124 Some cleanup (older release unstables)
125
126 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
127 policycoreutils-2.1.13-r9.ebuild:
128 Stabilize policycoreutils-2.1.13-r9
129
130*policycoreutils-2.1.13-r9 (19 Mar 2013)
131
132 19 Mar 2013; Sven Vermeulen <swift@gentoo.org>
133 +policycoreutils-2.1.13-r9.ebuild:
134 Fix bug #457786 - Link runscript_selinux with crypt
135
136*policycoreutils-2.1.13-r8 (10 Mar 2013)
137
138 10 Mar 2013; Sven Vermeulen <swift@gentoo.org>
139 +policycoreutils-2.1.13-r8.ebuild:
140 Adding selinux_gentoo init script for initramfs and cpu/online support
141 (#456914)
142
143*policycoreutils-2.1.13-r7 (09 Mar 2013)
144
145 09 Mar 2013; Sven Vermeulen <swift@gentoo.org>
146 +policycoreutils-2.1.13-r7.ebuild:
147 Update policycoreutils-extras to fix build failure when not building with PAM
148 support, see bug #457786
149
150*policycoreutils-2.1.13-r6 (30 Dec 2012)
151
152 30 Dec 2012; Sven Vermeulen +policycoreutils-2.1.13-r6.ebuild,
153 policycoreutils-2.1.13-r5.ebuild:
154 Stabilize r5, get r6 available as well which fixes rlpkg to include zfs
155 support
156
157*policycoreutils-2.1.13-r5 (17 Nov 2012)
158
159 17 Nov 2012; <swift@gentoo.org> policycoreutils-2.1.13-r4.ebuild,
160 +policycoreutils-2.1.13-r5.ebuild:
161 Stabilization, move sesandbox support to next release
162
163*policycoreutils-2.1.13-r4 (14 Oct 2012)
164
165 14 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r4.ebuild:
166 Remove support for python3 until upstream supports it
167
168 13 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.13-r3.ebuild:
169 Supporting user-provided patches using epatch_user
170
171*policycoreutils-2.1.13-r3 (09 Oct 2012)
172
173 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
174 Introducing new upstream release
175
176 06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
177 Stabilize
178
179*policycoreutils-2.1.10-r5 (08 Sep 2012)
180
181 08 Sep 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r5.ebuild:
182 Fix bug #427596 and #430806
183
184 10 Jul 2012; <swift@gentoo.org> policycoreutils-2.1.10-r3.ebuild:
185 Stabilization, drop libcgroup dependency along the way
186
187*policycoreutils-2.1.10-r4 (10 Jul 2012)
188
189 10 Jul 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r4.ebuild:
190 Support refpolicy style audit2allow (#417199)
191
192 26 Jun 2012; Mike Gilbert <floppym@gentoo.org>
193 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild,
194 policycoreutils-2.1.10.ebuild:
195 Restrict pypy per Arfrever.
196
197*policycoreutils-2.1.10-r3 (25 Jun 2012)
198
199 25 Jun 2012; <swift@gentoo.org>
200 +files/policycoreutils-extra-1.21-fix-python3.patch,
201 +policycoreutils-2.1.10-r3.ebuild:
202 Improve support for python3, fixes bug #416301
203
204 13 May 2012; <swift@gentoo.org> -policycoreutils-2.1.0-r1.ebuild,
205 -policycoreutils-2.1.0-r2.ebuild:
206 Removing obsoleted ebuilds
207
208*policycoreutils-2.1.10-r1 (29 Apr 2012)
209
210 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild,
211 +policycoreutils-2.1.10-r1.ebuild:
212 Remove dependency on libcgroup (but drop sesandbox support along the way)
213
214 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild:
215 Stabilization
216
217*policycoreutils-2.1.10 (31 Mar 2012)
218
219 31 Mar 2012; <swift@gentoo.org> +policycoreutils-2.1.10.ebuild, metadata.xml:
220 Bump to version 2.1.10
221
222 26 Feb 2012; <swift@gentoo.org> policycoreutils-2.1.0-r2.ebuild:
223 Stabilization
224
225 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild,
226 metadata.xml:
227 Mark audit as a local USE flag
228
229*policycoreutils-2.1.0-r2 (14 Jan 2012)
230
231 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild:
232 Override auto-detection of pam and audit, use USE flags for this
233
234 12 Nov 2011; <swift@gentoo.org> -policycoreutils-2.0.82.ebuild,
235 -policycoreutils-2.0.82-r1.ebuild, -policycoreutils-2.0.85.ebuild,
236 -policycoreutils-2.1.0.ebuild:
237 removing obsoleted ebuilds
238
239 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.1.0-r1.ebuild:
240 Stabilization (tracker #384231)
241
242 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.0.82-r1.ebuild:
243 Stabilize 2.0.82-r1 to fix #372807
244
245*policycoreutils-2.1.0-r1 (17 Sep 2011)
246
247 17 Sep 2011; <swift@gentoo.org> +policycoreutils-2.1.0-r1.ebuild:
248 Add /var/lib/selinux directory, needed for 'semodule permissive' support (bug
249 #381755)
250
251 02 Sep 2011; <swift@gentoo.org> policycoreutils-2.0.85.ebuild,
252 policycoreutils-2.1.0.ebuild:
253 Update patch locations to dev.g.o instead of files/ folder
254
255 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
256 -policycoreutils-2.0.55.ebuild, -policycoreutils-2.0.69.ebuild,
257 -policycoreutils-2.0.69-r1.ebuild, -policycoreutils-2.0.69-r2.ebuild,
258 -files/policycoreutils-2.0.69-setfiles.diff:
259 Removed deprecated versions
260
261*policycoreutils-2.1.0 (03 Aug 2011)
262
263 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
264 +policycoreutils-2.1.0.ebuild:
265 Bump to 20110727 SELinux userspace release
266
267*policycoreutils-2.0.85 (15 Jul 2011)
268
269 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
270 +policycoreutils-2.0.85.ebuild,
271 +files/policycoreutils-2.0.85-fix-seunshare-vuln.patch.gz,
272 +files/policycoreutils-2.0.85-sesandbox.patch.gz:
273 Add fix for bug #374897 and initial support for python3
274
275 08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
276 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
277 policycoreutils-2.0.69-r1.ebuild, policycoreutils-2.0.69-r2.ebuild:
278 Convert from "useq" to "use".
279
280*policycoreutils-2.0.82-r1 (30 Jun 2011)
281
282 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
283 +policycoreutils-2.0.82-r1.ebuild:
284 Overwrite invalid .po files with valid ones, fixes bug #372807
285
286 16 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
287 policycoreutils-2.0.82.ebuild:
288 Drop use_nls dependency on gettext. Its mandatory. See bug #299681.
289 Also put gettext in COMMON_DEPS, it is more than a RDEPEND.
290
291 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
292 policycoreutils-2.0.82.ebuild:
293 Stable amd64 x86
294
295 16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
296 Updated metadata info.
297
298 08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
299 policycoreutils-2.0.82.ebuild:
300 Set SUPPORT_PYTHON_ABIS (bug #353762). Fix dependencies. Fix installation
301 with FEATURES="multilib-strict".
302
303*policycoreutils-2.0.82 (05 Feb 2011)
304
305 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
306 +policycoreutils-2.0.82.ebuild:
307 New upstream release.
308
309*policycoreutils-2.0.69-r2 (05 Feb 2011)
310
311 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
312 +policycoreutils-2.0.69-r2.ebuild,
313 +files/policycoreutils-2.0.69-setfiles.diff:
314 Fixed bug #300613
315
316 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
317 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
318 policycoreutils-2.0.69-r1.ebuild:
319 Delete calls to deprecated python_version().
320
321*policycoreutils-2.0.69-r1 (20 Sep 2009)
322
323 20 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
324 +policycoreutils-2.0.69-r1.ebuild:
325 Update rlpkg for ext4 and btrfs.
326
327 14 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
328 policycoreutils-2.0.69.ebuild:
329 Fix libsemanage DEP.
330
331 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
332 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild:
333 Add python_need_rebuild.
334
335*policycoreutils-2.0.69 (02 Aug 2009)
336
337 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
338 +policycoreutils-2.0.69.ebuild:
339 New upstream release.
340
341 18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
342 -policycoreutils-1.34.15.ebuild, policycoreutils-2.0.55.ebuild:
343 Mark stable. Remove old ebuilds.
344
345*policycoreutils-2.0.55 (03 Oct 2008)
346
347 03 Oct 2008; Chris PeBenito <pebenito@gentoo.org>
348 +policycoreutils-2.0.55.ebuild:
349 Initial commit of policycoreutils 2.0.
350
351 29 May 2008; Ali Polatel <hawking@gentoo.org>
352 policycoreutils-1.34.15.ebuild:
353 python_mod_optimize is ROOT aware. Fixed python_mod_cleanup.
354
355 26 May 2008; Chris PeBenito <pebenito@gentoo.org>
356 policycoreutils-1.34.15.ebuild:
357 Fix libsemanage dependency.
358
359 13 May 2008; Chris PeBenito <pebenito@gentoo.org>
360 -files/policycoreutils-1.28-quietlp.diff,
361 -files/policycoreutils-1.32-quietlp.diff,
362 -files/policycoreutils-unsigned-char-ppc.diff,
363 -policycoreutils-1.28.ebuild, -policycoreutils-1.30-r1.ebuild,
364 -policycoreutils-1.34.1.ebuild, -policycoreutils-1.34.11.ebuild,
365 policycoreutils-1.34.15.ebuild:
366 Mark 1.34.15 stable, clear old ebuilds.
367
368*policycoreutils-1.34.15 (29 Jan 2008)
369
370 29 Jan 2008; Chris PeBenito <pebenito@gentoo.org>
371 +policycoreutils-1.34.15.ebuild:
372 New upstream bugfix release.
373
374 19 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
375 policycoreutils-1.34.11.ebuild:
376 Fix quoting in unpack.
377
378*policycoreutils-1.34.11 (18 Oct 2007)
379
380 18 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
381 +policycoreutils-1.34.11.ebuild:
382 New upstream release.
383
384 04 Jun 2007; Chris PeBenito <pebenito@gentoo.org>
385 policycoreutils-1.34.1.ebuild:
386 Mark stable.
387
388*policycoreutils-1.34.1 (15 Feb 2007)
389
390 15 Feb 2007; Chris PeBenito <pebenito@gentoo.org>
391 +policycoreutils-1.34.1.ebuild:
392 New upstream release.
393
394 24 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
395 policycoreutils-1.30.30.ebuild:
396 Fix glibc handling.
397
398 09 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
399 policycoreutils-1.30.30.ebuild:
400 Stable to make repoman happy.
401
402*policycoreutils-1.30.30 (05 Oct 2006)
403
404 05 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
405 +files/policycoreutils-1.32-quietlp.diff, +policycoreutils-1.30.30.ebuild:
406 Add SVN snapshot and updated extras in preparation for reference policy.
407
408 31 Jul 2006; Chris PeBenito <pebenito@gentoo.org>
409 policycoreutils-1.30-r1.ebuild:
410 Mark stable, long overdue.
411
412*policycoreutils-1.30-r1 (28 Mar 2006)
413
414 28 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
415 -policycoreutils-1.30.ebuild, +policycoreutils-1.30-r1.ebuild:
416 Fix install location of python site packages.
417
418 22 Feb 2006; Stephen Bennett <spb@gentoo.org> policycoreutils-1.28.ebuild:
419 Alpha stable
420
421 19 Feb 2006; Joshua Kinard <kumba@gentoo.org> policycoreutils-1.28.ebuild:
422 Marked stable on mips.
423
424*policycoreutils-1.30 (18 Mar 2006)
425
426 18 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
427 +policycoreutils-1.30.ebuild:
428 New upstream release.
429
430 05 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
431 +files/policycoreutils-unsigned-char-ppc.diff,
432 policycoreutils-1.28.ebuild:
433 Add patch to fix #121689.
4 434
5 17 Jan 2006; Chris PeBenito <pebenito@gentoo.org> 435 17 Jan 2006; Chris PeBenito <pebenito@gentoo.org>
6 policycoreutils-1.28.ebuild: 436 policycoreutils-1.28.ebuild:
7 Mark stable, x86, amd64, ppc, sparc. 437 Mark stable, x86, amd64, ppc, sparc.
8 438
260*policycoreutils-1.0 (03 Aug 2003) 690*policycoreutils-1.0 (03 Aug 2003)
261 691
262 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml, 692 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml,
263 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff: 693 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff:
264 Initial commit 694 Initial commit
265

Legend:
Removed from v.1.52  
changed lines
  Added in v.1.135

  ViewVC Help
Powered by ViewVC 1.1.20