/[gentoo-x86]/sys-apps/policycoreutils/ChangeLog
Gentoo

Diff of /sys-apps/policycoreutils/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.71 Revision 1.127
1# ChangeLog for sys-apps/policycoreutils 1# ChangeLog for sys-apps/policycoreutils
2# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.71 2008/10/03 03:51:23 pebenito Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.127 2013/12/10 14:10:34 swift Exp $
4
5*policycoreutils-2.2.5-r1 (10 Dec 2013)
6
7 10 Dec 2013; Sven Vermeulen <swift@gentoo.org>
8 +policycoreutils-2.2.5-r1.ebuild:
9 Adding 2.2.5 release
10
11*policycoreutils-2.2.1-r1 (04 Nov 2013)
12
13 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
14 +policycoreutils-2.2.1-r1.ebuild:
15 New policycoreutils release
16
17 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
18 policycoreutils-2.1.14-r4.ebuild:
19 Stabilize
20
21*policycoreutils-2.1.14-r4 (13 Aug 2013)
22
23 13 Aug 2013; Sven Vermeulen <swift@gentoo.org>
24 +policycoreutils-2.1.14-r4.ebuild:
25 Document setfiles in rlpkg, improve selocal resilience
26
27 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
28 -policycoreutils-2.1.10-r5.ebuild:
29 Summer cleaning
30
31*policycoreutils-2.1.14-r3 (07 Jul 2013)
32
33 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
34 +policycoreutils-2.1.14-r3.ebuild:
35 Switch to python-r1 eclass, add in mcstrans (bug #472912)
36
37 16 Jun 2013; Sven Vermeulen <swift@gentoo.org>
38 policycoreutils-2.1.14-r2.ebuild:
39 Stabilization
40
41 10 May 2013; Sven Vermeulen <swift@gentoo.org> metadata.xml:
42 Add in CPE data for policycoreutils, historical CVEs use redhat as
43 application vendor
44
45*policycoreutils-2.1.14-r2 (07 May 2013)
46
47 07 May 2013; Sven Vermeulen <swift@gentoo.org>
48 +policycoreutils-2.1.14-r2.ebuild:
49 Fix bugs 467268 (yum bindings), 468832 (key error), 468830 (mls range
50 dependency)
51
52*policycoreutils-2.1.14-r1 (25 Apr 2013)
53
54 25 Apr 2013; Sven Vermeulen <swift@gentoo.org>
55 +policycoreutils-2.1.14-r1.ebuild:
56 New upstream release
57
58*policycoreutils-2.1.13-r11 (19 Apr 2013)
59
60 19 Apr 2013; Sven Vermeulen <swift@gentoo.org>
61 +policycoreutils-2.1.13-r11.ebuild:
62 Add selocal command to policycoreutils
63
64*policycoreutils-2.1.13-r10 (16 Apr 2013)
65
66 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
67 +policycoreutils-2.1.13-r10.ebuild:
68 Fix bugs #463222 (newrole O_RDWR) and #464808 (hardcoded python3.1 in rlpkg)
69
70 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
71 -policycoreutils-2.1.10-r1.ebuild, -policycoreutils-2.1.10-r3.ebuild,
72 -policycoreutils-2.1.10-r4.ebuild, -policycoreutils-2.1.10.ebuild:
73 Some cleanup (older release unstables)
74
75 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
76 policycoreutils-2.1.13-r9.ebuild:
77 Stabilize policycoreutils-2.1.13-r9
78
79*policycoreutils-2.1.13-r9 (19 Mar 2013)
80
81 19 Mar 2013; Sven Vermeulen <swift@gentoo.org>
82 +policycoreutils-2.1.13-r9.ebuild:
83 Fix bug #457786 - Link runscript_selinux with crypt
84
85*policycoreutils-2.1.13-r8 (10 Mar 2013)
86
87 10 Mar 2013; Sven Vermeulen <swift@gentoo.org>
88 +policycoreutils-2.1.13-r8.ebuild:
89 Adding selinux_gentoo init script for initramfs and cpu/online support
90 (#456914)
91
92*policycoreutils-2.1.13-r7 (09 Mar 2013)
93
94 09 Mar 2013; Sven Vermeulen <swift@gentoo.org>
95 +policycoreutils-2.1.13-r7.ebuild:
96 Update policycoreutils-extras to fix build failure when not building with PAM
97 support, see bug #457786
98
99*policycoreutils-2.1.13-r6 (30 Dec 2012)
100
101 30 Dec 2012; Sven Vermeulen +policycoreutils-2.1.13-r6.ebuild,
102 policycoreutils-2.1.13-r5.ebuild:
103 Stabilize r5, get r6 available as well which fixes rlpkg to include zfs
104 support
105
106*policycoreutils-2.1.13-r5 (17 Nov 2012)
107
108 17 Nov 2012; <swift@gentoo.org> policycoreutils-2.1.13-r4.ebuild,
109 +policycoreutils-2.1.13-r5.ebuild:
110 Stabilization, move sesandbox support to next release
111
112*policycoreutils-2.1.13-r4 (14 Oct 2012)
113
114 14 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r4.ebuild:
115 Remove support for python3 until upstream supports it
116
117 13 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.13-r3.ebuild:
118 Supporting user-provided patches using epatch_user
119
120*policycoreutils-2.1.13-r3 (09 Oct 2012)
121
122 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
123 Introducing new upstream release
124
125 06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
126 Stabilize
127
128*policycoreutils-2.1.10-r5 (08 Sep 2012)
129
130 08 Sep 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r5.ebuild:
131 Fix bug #427596 and #430806
132
133 10 Jul 2012; <swift@gentoo.org> policycoreutils-2.1.10-r3.ebuild:
134 Stabilization, drop libcgroup dependency along the way
135
136*policycoreutils-2.1.10-r4 (10 Jul 2012)
137
138 10 Jul 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r4.ebuild:
139 Support refpolicy style audit2allow (#417199)
140
141 26 Jun 2012; Mike Gilbert <floppym@gentoo.org>
142 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild,
143 policycoreutils-2.1.10.ebuild:
144 Restrict pypy per Arfrever.
145
146*policycoreutils-2.1.10-r3 (25 Jun 2012)
147
148 25 Jun 2012; <swift@gentoo.org>
149 +files/policycoreutils-extra-1.21-fix-python3.patch,
150 +policycoreutils-2.1.10-r3.ebuild:
151 Improve support for python3, fixes bug #416301
152
153 13 May 2012; <swift@gentoo.org> -policycoreutils-2.1.0-r1.ebuild,
154 -policycoreutils-2.1.0-r2.ebuild:
155 Removing obsoleted ebuilds
156
157*policycoreutils-2.1.10-r1 (29 Apr 2012)
158
159 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild,
160 +policycoreutils-2.1.10-r1.ebuild:
161 Remove dependency on libcgroup (but drop sesandbox support along the way)
162
163 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild:
164 Stabilization
165
166*policycoreutils-2.1.10 (31 Mar 2012)
167
168 31 Mar 2012; <swift@gentoo.org> +policycoreutils-2.1.10.ebuild, metadata.xml:
169 Bump to version 2.1.10
170
171 26 Feb 2012; <swift@gentoo.org> policycoreutils-2.1.0-r2.ebuild:
172 Stabilization
173
174 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild,
175 metadata.xml:
176 Mark audit as a local USE flag
177
178*policycoreutils-2.1.0-r2 (14 Jan 2012)
179
180 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild:
181 Override auto-detection of pam and audit, use USE flags for this
182
183 12 Nov 2011; <swift@gentoo.org> -policycoreutils-2.0.82.ebuild,
184 -policycoreutils-2.0.82-r1.ebuild, -policycoreutils-2.0.85.ebuild,
185 -policycoreutils-2.1.0.ebuild:
186 removing obsoleted ebuilds
187
188 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.1.0-r1.ebuild:
189 Stabilization (tracker #384231)
190
191 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.0.82-r1.ebuild:
192 Stabilize 2.0.82-r1 to fix #372807
193
194*policycoreutils-2.1.0-r1 (17 Sep 2011)
195
196 17 Sep 2011; <swift@gentoo.org> +policycoreutils-2.1.0-r1.ebuild:
197 Add /var/lib/selinux directory, needed for 'semodule permissive' support (bug
198 #381755)
199
200 02 Sep 2011; <swift@gentoo.org> policycoreutils-2.0.85.ebuild,
201 policycoreutils-2.1.0.ebuild:
202 Update patch locations to dev.g.o instead of files/ folder
203
204 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
205 -policycoreutils-2.0.55.ebuild, -policycoreutils-2.0.69.ebuild,
206 -policycoreutils-2.0.69-r1.ebuild, -policycoreutils-2.0.69-r2.ebuild,
207 -files/policycoreutils-2.0.69-setfiles.diff:
208 Removed deprecated versions
209
210*policycoreutils-2.1.0 (03 Aug 2011)
211
212 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
213 +policycoreutils-2.1.0.ebuild:
214 Bump to 20110727 SELinux userspace release
215
216*policycoreutils-2.0.85 (15 Jul 2011)
217
218 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
219 +policycoreutils-2.0.85.ebuild,
220 +files/policycoreutils-2.0.85-fix-seunshare-vuln.patch.gz,
221 +files/policycoreutils-2.0.85-sesandbox.patch.gz:
222 Add fix for bug #374897 and initial support for python3
223
224 08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
225 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
226 policycoreutils-2.0.69-r1.ebuild, policycoreutils-2.0.69-r2.ebuild:
227 Convert from "useq" to "use".
228
229*policycoreutils-2.0.82-r1 (30 Jun 2011)
230
231 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
232 +policycoreutils-2.0.82-r1.ebuild:
233 Overwrite invalid .po files with valid ones, fixes bug #372807
234
235 16 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
236 policycoreutils-2.0.82.ebuild:
237 Drop use_nls dependency on gettext. Its mandatory. See bug #299681.
238 Also put gettext in COMMON_DEPS, it is more than a RDEPEND.
239
240 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
241 policycoreutils-2.0.82.ebuild:
242 Stable amd64 x86
243
244 16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
245 Updated metadata info.
246
247 08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
248 policycoreutils-2.0.82.ebuild:
249 Set SUPPORT_PYTHON_ABIS (bug #353762). Fix dependencies. Fix installation
250 with FEATURES="multilib-strict".
251
252*policycoreutils-2.0.82 (05 Feb 2011)
253
254 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
255 +policycoreutils-2.0.82.ebuild:
256 New upstream release.
257
258*policycoreutils-2.0.69-r2 (05 Feb 2011)
259
260 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
261 +policycoreutils-2.0.69-r2.ebuild,
262 +files/policycoreutils-2.0.69-setfiles.diff:
263 Fixed bug #300613
264
265 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
266 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
267 policycoreutils-2.0.69-r1.ebuild:
268 Delete calls to deprecated python_version().
269
270*policycoreutils-2.0.69-r1 (20 Sep 2009)
271
272 20 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
273 +policycoreutils-2.0.69-r1.ebuild:
274 Update rlpkg for ext4 and btrfs.
275
276 14 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
277 policycoreutils-2.0.69.ebuild:
278 Fix libsemanage DEP.
279
280 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
281 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild:
282 Add python_need_rebuild.
283
284*policycoreutils-2.0.69 (02 Aug 2009)
285
286 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
287 +policycoreutils-2.0.69.ebuild:
288 New upstream release.
289
290 18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
291 -policycoreutils-1.34.15.ebuild, policycoreutils-2.0.55.ebuild:
292 Mark stable. Remove old ebuilds.
4 293
5*policycoreutils-2.0.55 (03 Oct 2008) 294*policycoreutils-2.0.55 (03 Oct 2008)
6 295
7 03 Oct 2008; Chris PeBenito <pebenito@gentoo.org> 296 03 Oct 2008; Chris PeBenito <pebenito@gentoo.org>
8 +policycoreutils-2.0.55.ebuild: 297 +policycoreutils-2.0.55.ebuild:
350*policycoreutils-1.0 (03 Aug 2003) 639*policycoreutils-1.0 (03 Aug 2003)
351 640
352 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml, 641 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml,
353 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff: 642 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff:
354 Initial commit 643 Initial commit
355

Legend:
Removed from v.1.71  
changed lines
  Added in v.1.127

  ViewVC Help
Powered by ViewVC 1.1.20