/[gentoo-x86]/sys-apps/policycoreutils/ChangeLog
Gentoo

Diff of /sys-apps/policycoreutils/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.101 Revision 1.132
1# ChangeLog for sys-apps/policycoreutils 1# ChangeLog for sys-apps/policycoreutils
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.101 2012/06/26 05:02:43 floppym Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.132 2014/04/19 18:40:15 swift Exp $
4
5*policycoreutils-2.2.5-r3 (19 Apr 2014)
6
7 19 Apr 2014; Sven Vermeulen <swift@gentoo.org>
8 +policycoreutils-2.2.5-r3.ebuild, policycoreutils-2.2.5-r1.ebuild:
9 Fix bug #507992 - Do not push out restorecond init script if restorecond
10 should not be installed
11
12 20 Jan 2014; Sven Vermeulen <swift@gentoo.org>
13 policycoreutils-2.2.5-r2.ebuild:
14 Stabilize for amd64 and x86
15
16*policycoreutils-2.1.14-r5 (12 Jan 2014)
17
18 12 Jan 2014; Sven Vermeulen <swift@gentoo.org>
19 +policycoreutils-2.1.14-r5.ebuild:
20 Backport BUILD_DIR change to 2.1.14 (needed to have runscript_selinux follow
21 USE flag info)
22
23*policycoreutils-2.2.5-r2 (12 Jan 2014)
24
25 12 Jan 2014; Sven Vermeulen <swift@gentoo.org>
26 +policycoreutils-2.2.5-r2.ebuild:
27 Use python builddir locations for installation, otherwise a non-built
28 directory will be used, dismissing all configuration variables mentioned
29 earlier
30
31 23 Dec 2013; Sven Vermeulen <swift@gentoo.org>
32 -policycoreutils-2.1.13-r3.ebuild, -policycoreutils-2.1.13-r4.ebuild,
33 -policycoreutils-2.1.13-r5.ebuild, -policycoreutils-2.1.13-r6.ebuild,
34 -policycoreutils-2.1.13-r7.ebuild, -policycoreutils-2.1.13-r8.ebuild,
35 -policycoreutils-2.1.13-r9.ebuild, -policycoreutils-2.1.13-r10.ebuild,
36 -policycoreutils-2.1.13-r11.ebuild:
37 Cleanup old versions
38
39*policycoreutils-2.2.5-r1 (10 Dec 2013)
40
41 10 Dec 2013; Sven Vermeulen <swift@gentoo.org>
42 +policycoreutils-2.2.5-r1.ebuild:
43 Adding 2.2.5 release
44
45*policycoreutils-2.2.1-r1 (04 Nov 2013)
46
47 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
48 +policycoreutils-2.2.1-r1.ebuild:
49 New policycoreutils release
50
51 04 Nov 2013; Sven Vermeulen <swift@gentoo.org>
52 policycoreutils-2.1.14-r4.ebuild:
53 Stabilize
54
55*policycoreutils-2.1.14-r4 (13 Aug 2013)
56
57 13 Aug 2013; Sven Vermeulen <swift@gentoo.org>
58 +policycoreutils-2.1.14-r4.ebuild:
59 Document setfiles in rlpkg, improve selocal resilience
60
61 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
62 -policycoreutils-2.1.10-r5.ebuild:
63 Summer cleaning
64
65*policycoreutils-2.1.14-r3 (07 Jul 2013)
66
67 07 Jul 2013; Sven Vermeulen <swift@gentoo.org>
68 +policycoreutils-2.1.14-r3.ebuild:
69 Switch to python-r1 eclass, add in mcstrans (bug #472912)
70
71 16 Jun 2013; Sven Vermeulen <swift@gentoo.org>
72 policycoreutils-2.1.14-r2.ebuild:
73 Stabilization
74
75 10 May 2013; Sven Vermeulen <swift@gentoo.org> metadata.xml:
76 Add in CPE data for policycoreutils, historical CVEs use redhat as
77 application vendor
78
79*policycoreutils-2.1.14-r2 (07 May 2013)
80
81 07 May 2013; Sven Vermeulen <swift@gentoo.org>
82 +policycoreutils-2.1.14-r2.ebuild:
83 Fix bugs 467268 (yum bindings), 468832 (key error), 468830 (mls range
84 dependency)
85
86*policycoreutils-2.1.14-r1 (25 Apr 2013)
87
88 25 Apr 2013; Sven Vermeulen <swift@gentoo.org>
89 +policycoreutils-2.1.14-r1.ebuild:
90 New upstream release
91
92*policycoreutils-2.1.13-r11 (19 Apr 2013)
93
94 19 Apr 2013; Sven Vermeulen <swift@gentoo.org>
95 +policycoreutils-2.1.13-r11.ebuild:
96 Add selocal command to policycoreutils
97
98*policycoreutils-2.1.13-r10 (16 Apr 2013)
99
100 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
101 +policycoreutils-2.1.13-r10.ebuild:
102 Fix bugs #463222 (newrole O_RDWR) and #464808 (hardcoded python3.1 in rlpkg)
103
104 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
105 -policycoreutils-2.1.10-r1.ebuild, -policycoreutils-2.1.10-r3.ebuild,
106 -policycoreutils-2.1.10-r4.ebuild, -policycoreutils-2.1.10.ebuild:
107 Some cleanup (older release unstables)
108
109 16 Apr 2013; Sven Vermeulen <swift@gentoo.org>
110 policycoreutils-2.1.13-r9.ebuild:
111 Stabilize policycoreutils-2.1.13-r9
112
113*policycoreutils-2.1.13-r9 (19 Mar 2013)
114
115 19 Mar 2013; Sven Vermeulen <swift@gentoo.org>
116 +policycoreutils-2.1.13-r9.ebuild:
117 Fix bug #457786 - Link runscript_selinux with crypt
118
119*policycoreutils-2.1.13-r8 (10 Mar 2013)
120
121 10 Mar 2013; Sven Vermeulen <swift@gentoo.org>
122 +policycoreutils-2.1.13-r8.ebuild:
123 Adding selinux_gentoo init script for initramfs and cpu/online support
124 (#456914)
125
126*policycoreutils-2.1.13-r7 (09 Mar 2013)
127
128 09 Mar 2013; Sven Vermeulen <swift@gentoo.org>
129 +policycoreutils-2.1.13-r7.ebuild:
130 Update policycoreutils-extras to fix build failure when not building with PAM
131 support, see bug #457786
132
133*policycoreutils-2.1.13-r6 (30 Dec 2012)
134
135 30 Dec 2012; Sven Vermeulen +policycoreutils-2.1.13-r6.ebuild,
136 policycoreutils-2.1.13-r5.ebuild:
137 Stabilize r5, get r6 available as well which fixes rlpkg to include zfs
138 support
139
140*policycoreutils-2.1.13-r5 (17 Nov 2012)
141
142 17 Nov 2012; <swift@gentoo.org> policycoreutils-2.1.13-r4.ebuild,
143 +policycoreutils-2.1.13-r5.ebuild:
144 Stabilization, move sesandbox support to next release
145
146*policycoreutils-2.1.13-r4 (14 Oct 2012)
147
148 14 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r4.ebuild:
149 Remove support for python3 until upstream supports it
150
151 13 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.13-r3.ebuild:
152 Supporting user-provided patches using epatch_user
153
154*policycoreutils-2.1.13-r3 (09 Oct 2012)
155
156 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
157 Introducing new upstream release
158
159 06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
160 Stabilize
161
162*policycoreutils-2.1.10-r5 (08 Sep 2012)
163
164 08 Sep 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r5.ebuild:
165 Fix bug #427596 and #430806
166
167 10 Jul 2012; <swift@gentoo.org> policycoreutils-2.1.10-r3.ebuild:
168 Stabilization, drop libcgroup dependency along the way
169
170*policycoreutils-2.1.10-r4 (10 Jul 2012)
171
172 10 Jul 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r4.ebuild:
173 Support refpolicy style audit2allow (#417199)
4 174
5 26 Jun 2012; Mike Gilbert <floppym@gentoo.org> 175 26 Jun 2012; Mike Gilbert <floppym@gentoo.org>
6 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild, 176 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild,
7 policycoreutils-2.1.10.ebuild: 177 policycoreutils-2.1.10.ebuild:
8 Restrict pypy per Arfrever. 178 Restrict pypy per Arfrever.

Legend:
Removed from v.1.101  
changed lines
  Added in v.1.132

  ViewVC Help
Powered by ViewVC 1.1.20