/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.128 - (hide annotations) (download)
Sat Jan 19 15:50:57 2013 UTC (4 years, 8 months ago) by ssuominen
Branch: MAIN
Changes since 1.127: +4 -1 lines
amd64 stable wrt #452688

(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 ago 1.124 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 ssuominen 1.128 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.127 2013/01/11 03:08:39 ssuominen Exp $
4    
5     19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
6     amd64 stable wrt #452688
7 ssuominen 1.127
8     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
9     -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
10     old
11 ssuominen 1.126
12     *polkit-0.110 (11 Jan 2013)
13    
14     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
15     Version bump.
16 armin76 1.125
17     06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
18     polkit-0.109-r1.ebuild:
19     Add ~sh wrt #436668
20 ago 1.124
21     01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
22     Add ~ia64, wrt bug #436668
23 ago 1.123
24     30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
25     Stable for sparc, wrt bug #436666
26 ago 1.122
27     29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
28     Stable for alpha, wrt bug #436666
29 ssuominen 1.121
30     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
31     -polkit-0.109.ebuild:
32     old
33 ssuominen 1.120
34     *polkit-0.109-r1 (21 Dec 2012)
35    
36     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
37     +files/polkit-0.109-XAUTHORITY-fallback.patch:
38     Backport XAUTHORITY fallback support from upstream git.
39 ago 1.119
40     19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
41     Add ~ia64, wrt bug #436668
42 ssuominen 1.118
43     *polkit-0.109 (19 Dec 2012)
44    
45     19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
46     Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
47 ago 1.117
48     18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
49     Stable for ia64, wrt bug #436666
50 blueness 1.116
51     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
52     stable arm, bug #436666
53 ssuominen 1.115
54     22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
55     old
56 blueness 1.114
57     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
58     stable ppc64, bug #436666
59 ago 1.113
60     22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
61     Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
62     bug #436666
63 blueness 1.112
64     21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
65     stable ppc, bug #436666, thanks peratu
66 ssuominen 1.111
67     19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
68     Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
69     but using sed to avoid eautoreconf) wrt #443798
70 naota 1.109
71 ssuominen 1.110 *polkit-0.108 (18 Nov 2012)
72    
73     18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
74     Version bump.
75    
76     28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
77 naota 1.109 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
78     Drop ~x86-fbsd due to bug #439968.
79 jer 1.108
80     15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
81     polkit-0.107-r1.ebuild:
82     Drop HPPA keywording (bug #438368).
83 zmedico 1.107
84     15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
85     Set QA_MULTILIB_PATHS for bug #424423.
86 jer 1.106
87     09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
88     Marked ~hppa (bug #436668).
89 ssuominen 1.105
90     08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
91     Use pax-mark in src_compile() instead of src_install() for src_test() wrt
92     #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
93     and emphatize it's an Portage issue instead of polkit issue in src_install()
94     message.
95 ago 1.104
96     07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
97     Stable for amd64, wrt bug #436666
98 ssuominen 1.101
99     *polkit-0.107-r1 (20 Sep 2012)
100    
101     20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
102     +files/polkit-0.107-fallback.patch:
103     Introduce upstream patch for falling back to uid 0 for authentication if list
104     of admin identities is empty.
105 ssuominen 1.100
106     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
107     -polkit-0.106-r7.ebuild:
108     old
109 ssuominen 1.99
110     *polkit-0.107 (13 Jul 2012)
111    
112     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
113     Version bump.
114 ssuominen 1.98
115     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
116     -polkit-0.106-r6.ebuild:
117     old
118 ssuominen 1.97
119     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
120     Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
121     #391865 by Maksim Melnikau
122 ssuominen 1.96
123     *polkit-0.106-r7 (02 Jul 2012)
124    
125     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
126     RESTRICT="multilib-strict" since it's not compatible with the whole
127     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
128     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
129 ssuominen 1.95
130     *polkit-0.106-r6 (01 Jul 2012)
131    
132     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
133     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
134     /usr/lib to /usr/lib64 symlink.
135 swift 1.94
136     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
137     polkit-0.106-r5.ebuild:
138     Adding dependency on SELinux policykit module if USE=selinux is set
139 ssuominen 1.92
140     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
141 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
142     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
143 ssuominen 1.91
144     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
145     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
146     old
147 ssuominen 1.90
148     *polkit-0.106-r5 (27 Jun 2012)
149    
150     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
151     Revert entire unix-group:wheel experiment back to unix-user:0 because
152     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
153     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
154     by Doug Goldstein.
155 ssuominen 1.89
156     *polkit-0.106-r4 (27 Jun 2012)
157    
158     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
159     Stop installing polkit-backend-1.pc because upstream changed
160     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
161     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
162 ssuominen 1.88
163     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
164     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
165     Palimaka
166 tetromino 1.87
167     *polkit-0.106-r3 (25 Jun 2012)
168    
169     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
170     +polkit-0.106-r3.ebuild:
171     pax-mark polkitd to fix crashes on hardened/PaX systems.
172 ssuominen 1.86
173     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
174     Convert pkg_postinst() message about polkitd home directory to new
175     user.eclass function esethome().
176 ssuominen 1.85
177     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
178     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
179 ssuominen 1.84
180     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
181     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
182 ssuominen 1.83
183     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
184     old
185 ssuominen 1.82
186     *polkit-0.106-r2 (17 Jun 2012)
187    
188     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
189     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
190     existing directories.
191 ssuominen 1.81
192     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
193     old
194 ssuominen 1.79
195 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
196    
197     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
198     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
199     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
200     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
201     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
202 ssuominen 1.78
203     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
204 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
205     #420173 and #420307.
206 ssuominen 1.77
207     *polkit-0.106 (07 Jun 2012)
208    
209     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
210 ssuominen 1.80 Version bump.
211 ssuominen 1.76
212     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
213     Improve systemd handling wrt #416317 by Christoph Brill
214 ssuominen 1.75
215     *polkit-0.105 (14 May 2012)
216    
217     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
218     Version bump.
219 jdhore 1.74
220     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
221     dev-util/pkgconfig -> virtual/pkgconfig
222 ssuominen 1.73
223     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
224     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
225     old
226 armin76 1.72
227     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
228     ia64/sh/sparc stable wrt #401513
229 ssuominen 1.71
230     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
231     ppc/ppc64 stable wrt #401513
232 klausman 1.70
233     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
234     Stable on alpha, bug #401513
235 tomka 1.69
236     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
237     marked x86 per bug 401513
238 maekke 1.68
239     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
240     arm stable, bug #401513
241 jer 1.67
242     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
243     Stable for HPPA (bug #401513).
244 ago 1.66
245     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
246     Stable for AMD64, wrt security bug #401513
247 ssuominen 1.65
248     *polkit-0.104-r1 (30 Jan 2012)
249    
250     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
251     Restore the default value of AdminIdentities from "wheel" to "0" like it was
252     in polkit-0.102 and ones before that. You should see files
253     50-localauthority.conf and 60-gentoo.conf in
254     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
255     with "man 8 pklocalauthority" as soon as possible.
256 maekke 1.64
257     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
258     arm stable, bug #397755
259 ago 1.63
260     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
261     Stable for AMD64, wrt bug #397755
262 ssuominen 1.62
263     *polkit-0.104 (05 Jan 2012)
264    
265     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
266     metadata.xml:
267     Version bump.
268 ssuominen 1.61
269     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
270     old
271 ssuominen 1.60
272     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
273     ppc/ppc64 stable wrt #387163
274 ssuominen 1.59
275     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
276     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
277 ssuominen 1.58
278     *polkit-0.103 (07 Dec 2011)
279    
280     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
281     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
282     "i.Dark_Templar"
283 armin76 1.57
284     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
285     alpha/arm/ia64/sh/sparc stable wrt #387163
286 maekke 1.56
287     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
288     arm stable, bug #387163
289 jer 1.55
290     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
291     Stable for HPPA (bug #387163).
292 phajdan.jr 1.54
293     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
294     x86 stable wrt bug #387163
295 hwoarang 1.53
296     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
297     Stable on amd64 wrt bug #387163
298 nirbheek 1.52
299     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
300     polkit-0.102.ebuild:
301     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
302 ssuominen 1.51
303     *polkit-0.102 (06 Aug 2011)
304    
305     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
306     Version bump.
307 mattst88 1.50
308     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
309     Added ~mips, bug 296548
310 eva 1.49
311     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
312     Add missing dtd to DEPEND, bug #355505.
313 armin76 1.48
314     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
315     alpha/arm/ia64/sh/sparc stable wrt #364973
316 phajdan.jr 1.47
317     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
318     polkit-0.101-r1.ebuild:
319     x86 stable wrt security bug #364973
320 jer 1.46
321     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
322     Stable for HPPA (bug #364973).
323 angelos 1.45
324     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
325     Stable on amd64 wrt bug #364973
326 xarthisius 1.44
327     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
328     ppc/ppc64 stable wrt #364973
329 nirbheek 1.43
330     *polkit-0.101-r1 (25 Apr 2011)
331    
332     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
333     +polkit-0.101-r1.ebuild:
334     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
335 xarthisius 1.42
336     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
337     ppc/ppc64 stable wrt #354509
338 armin76 1.41
339     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
340     alpha/ia64/sh/sparc stable wrt #354509
341 nirbheek 1.40
342     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
343     PDEPEND on 0.101 version of polkit-gnome
344 maekke 1.39
345     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
346     arm stable, bug #354509
347 ssuominen 1.38
348     *polkit-0.101 (11 Mar 2011)
349    
350     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
351     Version bump.
352 jer 1.37
353     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
354     Stable for HPPA (bug #354509).
355 tomka 1.36
356     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
357     x86 stable per bug 354509
358 hwoarang 1.35
359     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
360     Stable on amd64 wrt bug #354509
361 nirbheek 1.34
362     *polkit-0.100 (23 Feb 2011)
363    
364     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
365     Bump to 0.100
366 ssuominen 1.32
367     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
368 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
369 jer 1.31
370     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
371     Marked ~hppa (bug #296548).
372 ssuominen 1.30
373     *polkit-0.99-r1 (25 Dec 2010)
374    
375     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
376     Revision bump to remove static archives (.a) and libtool archives (.la).
377 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
378 nirbheek 1.27
379     *polkit-0.99 (25 Sep 2010)
380    
381     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
382     Bump to 0.99, masked due to >=glib-2.25 requirement
383 maekke 1.26
384     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
385     arm stable, bug #314899
386 armin76 1.24
387 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
388     polkit-0.96-r2.ebuild:
389     alpha/ia64/sh/sparc stable
390 josejx 1.23
391     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
392     Marked ppc/ppc64 stable.
393 klausman 1.22
394     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
395     Stable on alpha, bug #329621
396 jer 1.21
397     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
398     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
399     Stable for HPPA (bug #314899).
400 jer 1.20
401     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
402     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
403     Drop HPPA keywording (bug #324511).
404 nirbheek 1.19
405     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
406     polkit-0.96-r2.ebuild:
407     Add ewarn about ensuring that consolekit sessions are working. Either the
408     user needs to login using a login-manager with consolekit support, or use
409     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
410 nirbheek 1.18
411     *polkit-0.96-r2 (02 Jul 2010)
412    
413     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
414     +polkit-0.96-r2.ebuild, metadata.xml:
415     USE=expat was quite useless, expat is mandatory in polkit. Don't create
416     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
417     add introspection support
418 maekke 1.17
419     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
420     x86 stable, bug #314899
421 tester 1.16
422     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
423     amd64 stable, bug #314899
424 armin76 1.15
425     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
426     polkit-0.96-r1.ebuild:
427     Add ~sh
428 aballier 1.14
429     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
430     +files/polkit-0.96-getcwd.patch:
431     Fix build on fbsd and keyword it x86-fbsd
432 nirbheek 1.13
433     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
434     polkit-0.96-r1.ebuild:
435     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
436 nirbheek 1.12
437     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
438     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
439     -polkit-0.95.ebuild:
440     Remove old
441 nirbheek 1.11
442     *polkit-0.96-r1 (21 Mar 2010)
443    
444     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
445     +polkit-0.96-r1.ebuild:
446     Update with newer version of polkit-shadow patch
447 nirbheek 1.10
448     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
449     Fix minor problems with SRC_URI
450 nirbheek 1.9
451     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
452     Add experimental shadow support, bug 291116 . Patch thanks to the
453     slackware folks.
454 armin76 1.8
455     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
456     Add ~alpha/~arm/~ia64/~sparc
457 josejx 1.7
458     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
459     Marked ~ppc/~ppc64 for bug #296548.
460 nirbheek 1.6
461     *polkit-0.96 (23 Jan 2010)
462    
463     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
464     Version bump to 0.96; lots of bugfixes, see NEWS
465 jer 1.5
466     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
467     Marked ~hppa (bug #296548).
468 nirbheek 1.4
469     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
470     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
471     the user is in an active/local session via dbus methods
472 nirbheek 1.3
473     *polkit-0.95 (14 Nov 2009)
474    
475     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
476     Bump to 0.95 -- new lockdown API, last dev version till 1.0
477 nirbheek 1.2
478     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
479     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
480     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
481 eva 1.1
482     *polkit-0.94 (29 Oct 2009)
483    
484     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
485     +files/polkit-0.92-zsh-completions.patch,
486     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
487     +metadata.xml:
488     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20