/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.146 - (hide annotations) (download)
Tue Sep 10 16:16:24 2013 UTC (4 years ago) by ssuominen
Branch: MAIN
Changes since 1.145: +7 -1 lines
Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was always more about convinience than being strict requirement.

(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 ago 1.124 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 ssuominen 1.146 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.145 2013/08/09 18:44:12 axs Exp $
4    
5     10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
6     polkit-0.111-r1.ebuild:
7     Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
8     CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
9     always more about convinience than being strict requirement.
10 axs 1.145
11     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
12     dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
13     per ssuominen's approval
14 axs 1.144
15     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
16     polkit-0.111-r1.ebuild:
17     Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
18 ssuominen 1.143
19     *polkit-0.111-r1 (08 Aug 2013)
20    
21     08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
22     Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
23 ssuominen 1.142
24     *polkit-0.111 (15 May 2013)
25    
26     15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
27     Version bump by "okias" from Freenode
28 ssuominen 1.141
29     19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
30     -files/polkit-0.107-fallback.patch:
31     old
32 ago 1.140
33     19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
34     Stable for sh, wrt bug #452688
35 ssuominen 1.139
36     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
37     files/polkit-0.110-W_define.patch:
38     Include link to upstream bug.
39 ssuominen 1.138
40     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
41     +files/polkit-0.110-W_define.patch:
42     Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
43     WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
44 ago 1.137
45     09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
46     Stable for sparc, wrt bug #452688
47 vapier 1.136
48     03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
49     Add s390 keywords #457078 by Michael Palimaka.
50 ago 1.135
51     23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
52     Stable for alpha, wrt bug #452688
53 ago 1.134
54     10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
55     Stable for ppc64, wrt bug #452688
56 ago 1.133
57     09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
58     Stable for ia64, wrt bug #452688
59 ago 1.132
60     31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
61     Stable for ppc, wrt bug #452688
62 ssuominen 1.131
63     29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
64     Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
65     errors as noted by _AxS_.
66 maekke 1.130
67     26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
68     arm stable, bug #452688
69 ssuominen 1.129
70     20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
71     x86 stable wrt #452688
72 ssuominen 1.128
73     19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
74     amd64 stable wrt #452688
75 ssuominen 1.127
76     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
77     -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
78     old
79 ssuominen 1.126
80     *polkit-0.110 (11 Jan 2013)
81    
82     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
83     Version bump.
84 armin76 1.125
85     06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
86     polkit-0.109-r1.ebuild:
87     Add ~sh wrt #436668
88 ago 1.124
89     01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
90     Add ~ia64, wrt bug #436668
91 ago 1.123
92     30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
93     Stable for sparc, wrt bug #436666
94 ago 1.122
95     29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
96     Stable for alpha, wrt bug #436666
97 ssuominen 1.121
98     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
99     -polkit-0.109.ebuild:
100     old
101 ssuominen 1.120
102     *polkit-0.109-r1 (21 Dec 2012)
103    
104     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
105     +files/polkit-0.109-XAUTHORITY-fallback.patch:
106     Backport XAUTHORITY fallback support from upstream git.
107 ago 1.119
108     19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
109     Add ~ia64, wrt bug #436668
110 ssuominen 1.118
111     *polkit-0.109 (19 Dec 2012)
112    
113     19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
114     Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
115 ago 1.117
116     18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
117     Stable for ia64, wrt bug #436666
118 blueness 1.116
119     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
120     stable arm, bug #436666
121 ssuominen 1.115
122     22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
123     old
124 blueness 1.114
125     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
126     stable ppc64, bug #436666
127 ago 1.113
128     22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
129     Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
130     bug #436666
131 blueness 1.112
132     21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
133     stable ppc, bug #436666, thanks peratu
134 ssuominen 1.111
135     19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
136     Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
137     but using sed to avoid eautoreconf) wrt #443798
138 naota 1.109
139 ssuominen 1.110 *polkit-0.108 (18 Nov 2012)
140    
141     18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
142     Version bump.
143    
144     28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
145 naota 1.109 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
146     Drop ~x86-fbsd due to bug #439968.
147 jer 1.108
148     15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
149     polkit-0.107-r1.ebuild:
150     Drop HPPA keywording (bug #438368).
151 zmedico 1.107
152     15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
153     Set QA_MULTILIB_PATHS for bug #424423.
154 jer 1.106
155     09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
156     Marked ~hppa (bug #436668).
157 ssuominen 1.105
158     08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
159     Use pax-mark in src_compile() instead of src_install() for src_test() wrt
160     #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
161     and emphatize it's an Portage issue instead of polkit issue in src_install()
162     message.
163 ago 1.104
164     07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
165     Stable for amd64, wrt bug #436666
166 ssuominen 1.101
167     *polkit-0.107-r1 (20 Sep 2012)
168    
169     20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
170     +files/polkit-0.107-fallback.patch:
171     Introduce upstream patch for falling back to uid 0 for authentication if list
172     of admin identities is empty.
173 ssuominen 1.100
174     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
175     -polkit-0.106-r7.ebuild:
176     old
177 ssuominen 1.99
178     *polkit-0.107 (13 Jul 2012)
179    
180     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
181     Version bump.
182 ssuominen 1.98
183     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
184     -polkit-0.106-r6.ebuild:
185     old
186 ssuominen 1.97
187     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
188     Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
189     #391865 by Maksim Melnikau
190 ssuominen 1.96
191     *polkit-0.106-r7 (02 Jul 2012)
192    
193     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
194     RESTRICT="multilib-strict" since it's not compatible with the whole
195     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
196     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
197 ssuominen 1.95
198     *polkit-0.106-r6 (01 Jul 2012)
199    
200     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
201     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
202     /usr/lib to /usr/lib64 symlink.
203 swift 1.94
204     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
205     polkit-0.106-r5.ebuild:
206     Adding dependency on SELinux policykit module if USE=selinux is set
207 ssuominen 1.92
208     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
209 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
210     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
211 ssuominen 1.91
212     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
213     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
214     old
215 ssuominen 1.90
216     *polkit-0.106-r5 (27 Jun 2012)
217    
218     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
219     Revert entire unix-group:wheel experiment back to unix-user:0 because
220     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
221     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
222     by Doug Goldstein.
223 ssuominen 1.89
224     *polkit-0.106-r4 (27 Jun 2012)
225    
226     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
227     Stop installing polkit-backend-1.pc because upstream changed
228     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
229     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
230 ssuominen 1.88
231     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
232     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
233     Palimaka
234 tetromino 1.87
235     *polkit-0.106-r3 (25 Jun 2012)
236    
237     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
238     +polkit-0.106-r3.ebuild:
239     pax-mark polkitd to fix crashes on hardened/PaX systems.
240 ssuominen 1.86
241     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
242     Convert pkg_postinst() message about polkitd home directory to new
243     user.eclass function esethome().
244 ssuominen 1.85
245     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
246     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
247 ssuominen 1.84
248     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
249     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
250 ssuominen 1.83
251     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
252     old
253 ssuominen 1.82
254     *polkit-0.106-r2 (17 Jun 2012)
255    
256     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
257     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
258     existing directories.
259 ssuominen 1.81
260     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
261     old
262 ssuominen 1.79
263 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
264    
265     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
266     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
267     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
268     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
269     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
270 ssuominen 1.78
271     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
272 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
273     #420173 and #420307.
274 ssuominen 1.77
275     *polkit-0.106 (07 Jun 2012)
276    
277     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
278 ssuominen 1.80 Version bump.
279 ssuominen 1.76
280     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
281     Improve systemd handling wrt #416317 by Christoph Brill
282 ssuominen 1.75
283     *polkit-0.105 (14 May 2012)
284    
285     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
286     Version bump.
287 jdhore 1.74
288     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
289     dev-util/pkgconfig -> virtual/pkgconfig
290 ssuominen 1.73
291     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
292     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
293     old
294 armin76 1.72
295     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
296     ia64/sh/sparc stable wrt #401513
297 ssuominen 1.71
298     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
299     ppc/ppc64 stable wrt #401513
300 klausman 1.70
301     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
302     Stable on alpha, bug #401513
303 tomka 1.69
304     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
305     marked x86 per bug 401513
306 maekke 1.68
307     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
308     arm stable, bug #401513
309 jer 1.67
310     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
311     Stable for HPPA (bug #401513).
312 ago 1.66
313     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
314     Stable for AMD64, wrt security bug #401513
315 ssuominen 1.65
316     *polkit-0.104-r1 (30 Jan 2012)
317    
318     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
319     Restore the default value of AdminIdentities from "wheel" to "0" like it was
320     in polkit-0.102 and ones before that. You should see files
321     50-localauthority.conf and 60-gentoo.conf in
322     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
323     with "man 8 pklocalauthority" as soon as possible.
324 maekke 1.64
325     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
326     arm stable, bug #397755
327 ago 1.63
328     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
329     Stable for AMD64, wrt bug #397755
330 ssuominen 1.62
331     *polkit-0.104 (05 Jan 2012)
332    
333     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
334     metadata.xml:
335     Version bump.
336 ssuominen 1.61
337     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
338     old
339 ssuominen 1.60
340     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
341     ppc/ppc64 stable wrt #387163
342 ssuominen 1.59
343     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
344     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
345 ssuominen 1.58
346     *polkit-0.103 (07 Dec 2011)
347    
348     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
349     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
350     "i.Dark_Templar"
351 armin76 1.57
352     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
353     alpha/arm/ia64/sh/sparc stable wrt #387163
354 maekke 1.56
355     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
356     arm stable, bug #387163
357 jer 1.55
358     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
359     Stable for HPPA (bug #387163).
360 phajdan.jr 1.54
361     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
362     x86 stable wrt bug #387163
363 hwoarang 1.53
364     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
365     Stable on amd64 wrt bug #387163
366 nirbheek 1.52
367     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
368     polkit-0.102.ebuild:
369     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
370 ssuominen 1.51
371     *polkit-0.102 (06 Aug 2011)
372    
373     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
374     Version bump.
375 mattst88 1.50
376     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
377     Added ~mips, bug 296548
378 eva 1.49
379     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
380     Add missing dtd to DEPEND, bug #355505.
381 armin76 1.48
382     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
383     alpha/arm/ia64/sh/sparc stable wrt #364973
384 phajdan.jr 1.47
385     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
386     polkit-0.101-r1.ebuild:
387     x86 stable wrt security bug #364973
388 jer 1.46
389     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
390     Stable for HPPA (bug #364973).
391 angelos 1.45
392     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
393     Stable on amd64 wrt bug #364973
394 xarthisius 1.44
395     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
396     ppc/ppc64 stable wrt #364973
397 nirbheek 1.43
398     *polkit-0.101-r1 (25 Apr 2011)
399    
400     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
401     +polkit-0.101-r1.ebuild:
402     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
403 xarthisius 1.42
404     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
405     ppc/ppc64 stable wrt #354509
406 armin76 1.41
407     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
408     alpha/ia64/sh/sparc stable wrt #354509
409 nirbheek 1.40
410     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
411     PDEPEND on 0.101 version of polkit-gnome
412 maekke 1.39
413     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
414     arm stable, bug #354509
415 ssuominen 1.38
416     *polkit-0.101 (11 Mar 2011)
417    
418     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
419     Version bump.
420 jer 1.37
421     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
422     Stable for HPPA (bug #354509).
423 tomka 1.36
424     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
425     x86 stable per bug 354509
426 hwoarang 1.35
427     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
428     Stable on amd64 wrt bug #354509
429 nirbheek 1.34
430     *polkit-0.100 (23 Feb 2011)
431    
432     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
433     Bump to 0.100
434 ssuominen 1.32
435     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
436 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
437 jer 1.31
438     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
439     Marked ~hppa (bug #296548).
440 ssuominen 1.30
441     *polkit-0.99-r1 (25 Dec 2010)
442    
443     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
444     Revision bump to remove static archives (.a) and libtool archives (.la).
445 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
446 nirbheek 1.27
447     *polkit-0.99 (25 Sep 2010)
448    
449     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
450     Bump to 0.99, masked due to >=glib-2.25 requirement
451 maekke 1.26
452     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
453     arm stable, bug #314899
454 armin76 1.24
455 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
456     polkit-0.96-r2.ebuild:
457     alpha/ia64/sh/sparc stable
458 josejx 1.23
459     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
460     Marked ppc/ppc64 stable.
461 klausman 1.22
462     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
463     Stable on alpha, bug #329621
464 jer 1.21
465     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
466     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
467     Stable for HPPA (bug #314899).
468 jer 1.20
469     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
470     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
471     Drop HPPA keywording (bug #324511).
472 nirbheek 1.19
473     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
474     polkit-0.96-r2.ebuild:
475     Add ewarn about ensuring that consolekit sessions are working. Either the
476     user needs to login using a login-manager with consolekit support, or use
477     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
478 nirbheek 1.18
479     *polkit-0.96-r2 (02 Jul 2010)
480    
481     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
482     +polkit-0.96-r2.ebuild, metadata.xml:
483     USE=expat was quite useless, expat is mandatory in polkit. Don't create
484     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
485     add introspection support
486 maekke 1.17
487     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
488     x86 stable, bug #314899
489 tester 1.16
490     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
491     amd64 stable, bug #314899
492 armin76 1.15
493     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
494     polkit-0.96-r1.ebuild:
495     Add ~sh
496 aballier 1.14
497     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
498     +files/polkit-0.96-getcwd.patch:
499     Fix build on fbsd and keyword it x86-fbsd
500 nirbheek 1.13
501     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
502     polkit-0.96-r1.ebuild:
503     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
504 nirbheek 1.12
505     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
506     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
507     -polkit-0.95.ebuild:
508     Remove old
509 nirbheek 1.11
510     *polkit-0.96-r1 (21 Mar 2010)
511    
512     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
513     +polkit-0.96-r1.ebuild:
514     Update with newer version of polkit-shadow patch
515 nirbheek 1.10
516     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
517     Fix minor problems with SRC_URI
518 nirbheek 1.9
519     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
520     Add experimental shadow support, bug 291116 . Patch thanks to the
521     slackware folks.
522 armin76 1.8
523     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
524     Add ~alpha/~arm/~ia64/~sparc
525 josejx 1.7
526     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
527     Marked ~ppc/~ppc64 for bug #296548.
528 nirbheek 1.6
529     *polkit-0.96 (23 Jan 2010)
530    
531     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
532     Version bump to 0.96; lots of bugfixes, see NEWS
533 jer 1.5
534     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
535     Marked ~hppa (bug #296548).
536 nirbheek 1.4
537     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
538     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
539     the user is in an active/local session via dbus methods
540 nirbheek 1.3
541     *polkit-0.95 (14 Nov 2009)
542    
543     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
544     Bump to 0.95 -- new lockdown API, last dev version till 1.0
545 nirbheek 1.2
546     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
547     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
548     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
549 eva 1.1
550     *polkit-0.94 (29 Oct 2009)
551    
552     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
553     +files/polkit-0.92-zsh-completions.patch,
554     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
555     +metadata.xml:
556     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20