/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.147 - (hide annotations) (download)
Thu Sep 19 15:47:54 2013 UTC (4 years, 7 months ago) by cardoe
Branch: MAIN
Changes since 1.146: +6 -1 lines
Bump for CVE-2013-4288

(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 ago 1.124 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 cardoe 1.147 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.146 2013/09/10 16:16:24 ssuominen Exp $
4    
5     *polkit-0.112 (19 Sep 2013)
6    
7     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
8     Bump for CVE-2013-4288
9 ssuominen 1.146
10     10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
11     polkit-0.111-r1.ebuild:
12     Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
13     CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
14     always more about convinience than being strict requirement.
15 axs 1.145
16     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
17     dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
18     per ssuominen's approval
19 axs 1.144
20     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
21     polkit-0.111-r1.ebuild:
22     Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
23 ssuominen 1.143
24     *polkit-0.111-r1 (08 Aug 2013)
25    
26     08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
27     Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
28 ssuominen 1.142
29     *polkit-0.111 (15 May 2013)
30    
31     15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
32     Version bump by "okias" from Freenode
33 ssuominen 1.141
34     19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
35     -files/polkit-0.107-fallback.patch:
36     old
37 ago 1.140
38     19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
39     Stable for sh, wrt bug #452688
40 ssuominen 1.139
41     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
42     files/polkit-0.110-W_define.patch:
43     Include link to upstream bug.
44 ssuominen 1.138
45     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
46     +files/polkit-0.110-W_define.patch:
47     Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
48     WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
49 ago 1.137
50     09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
51     Stable for sparc, wrt bug #452688
52 vapier 1.136
53     03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
54     Add s390 keywords #457078 by Michael Palimaka.
55 ago 1.135
56     23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
57     Stable for alpha, wrt bug #452688
58 ago 1.134
59     10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
60     Stable for ppc64, wrt bug #452688
61 ago 1.133
62     09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
63     Stable for ia64, wrt bug #452688
64 ago 1.132
65     31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
66     Stable for ppc, wrt bug #452688
67 ssuominen 1.131
68     29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
69     Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
70     errors as noted by _AxS_.
71 maekke 1.130
72     26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
73     arm stable, bug #452688
74 ssuominen 1.129
75     20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
76     x86 stable wrt #452688
77 ssuominen 1.128
78     19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
79     amd64 stable wrt #452688
80 ssuominen 1.127
81     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
82     -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
83     old
84 ssuominen 1.126
85     *polkit-0.110 (11 Jan 2013)
86    
87     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
88     Version bump.
89 armin76 1.125
90     06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
91     polkit-0.109-r1.ebuild:
92     Add ~sh wrt #436668
93 ago 1.124
94     01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
95     Add ~ia64, wrt bug #436668
96 ago 1.123
97     30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
98     Stable for sparc, wrt bug #436666
99 ago 1.122
100     29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
101     Stable for alpha, wrt bug #436666
102 ssuominen 1.121
103     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
104     -polkit-0.109.ebuild:
105     old
106 ssuominen 1.120
107     *polkit-0.109-r1 (21 Dec 2012)
108    
109     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
110     +files/polkit-0.109-XAUTHORITY-fallback.patch:
111     Backport XAUTHORITY fallback support from upstream git.
112 ago 1.119
113     19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
114     Add ~ia64, wrt bug #436668
115 ssuominen 1.118
116     *polkit-0.109 (19 Dec 2012)
117    
118     19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
119     Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
120 ago 1.117
121     18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
122     Stable for ia64, wrt bug #436666
123 blueness 1.116
124     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
125     stable arm, bug #436666
126 ssuominen 1.115
127     22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
128     old
129 blueness 1.114
130     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
131     stable ppc64, bug #436666
132 ago 1.113
133     22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
134     Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
135     bug #436666
136 blueness 1.112
137     21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
138     stable ppc, bug #436666, thanks peratu
139 ssuominen 1.111
140     19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
141     Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
142     but using sed to avoid eautoreconf) wrt #443798
143 naota 1.109
144 ssuominen 1.110 *polkit-0.108 (18 Nov 2012)
145    
146     18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
147     Version bump.
148    
149     28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
150 naota 1.109 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
151     Drop ~x86-fbsd due to bug #439968.
152 jer 1.108
153     15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
154     polkit-0.107-r1.ebuild:
155     Drop HPPA keywording (bug #438368).
156 zmedico 1.107
157     15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
158     Set QA_MULTILIB_PATHS for bug #424423.
159 jer 1.106
160     09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
161     Marked ~hppa (bug #436668).
162 ssuominen 1.105
163     08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
164     Use pax-mark in src_compile() instead of src_install() for src_test() wrt
165     #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
166     and emphatize it's an Portage issue instead of polkit issue in src_install()
167     message.
168 ago 1.104
169     07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
170     Stable for amd64, wrt bug #436666
171 ssuominen 1.101
172     *polkit-0.107-r1 (20 Sep 2012)
173    
174     20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
175     +files/polkit-0.107-fallback.patch:
176     Introduce upstream patch for falling back to uid 0 for authentication if list
177     of admin identities is empty.
178 ssuominen 1.100
179     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
180     -polkit-0.106-r7.ebuild:
181     old
182 ssuominen 1.99
183     *polkit-0.107 (13 Jul 2012)
184    
185     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
186     Version bump.
187 ssuominen 1.98
188     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
189     -polkit-0.106-r6.ebuild:
190     old
191 ssuominen 1.97
192     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
193     Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
194     #391865 by Maksim Melnikau
195 ssuominen 1.96
196     *polkit-0.106-r7 (02 Jul 2012)
197    
198     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
199     RESTRICT="multilib-strict" since it's not compatible with the whole
200     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
201     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
202 ssuominen 1.95
203     *polkit-0.106-r6 (01 Jul 2012)
204    
205     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
206     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
207     /usr/lib to /usr/lib64 symlink.
208 swift 1.94
209     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
210     polkit-0.106-r5.ebuild:
211     Adding dependency on SELinux policykit module if USE=selinux is set
212 ssuominen 1.92
213     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
214 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
215     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
216 ssuominen 1.91
217     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
218     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
219     old
220 ssuominen 1.90
221     *polkit-0.106-r5 (27 Jun 2012)
222    
223     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
224     Revert entire unix-group:wheel experiment back to unix-user:0 because
225     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
226     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
227     by Doug Goldstein.
228 ssuominen 1.89
229     *polkit-0.106-r4 (27 Jun 2012)
230    
231     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
232     Stop installing polkit-backend-1.pc because upstream changed
233     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
234     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
235 ssuominen 1.88
236     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
237     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
238     Palimaka
239 tetromino 1.87
240     *polkit-0.106-r3 (25 Jun 2012)
241    
242     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
243     +polkit-0.106-r3.ebuild:
244     pax-mark polkitd to fix crashes on hardened/PaX systems.
245 ssuominen 1.86
246     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
247     Convert pkg_postinst() message about polkitd home directory to new
248     user.eclass function esethome().
249 ssuominen 1.85
250     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
251     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
252 ssuominen 1.84
253     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
254     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
255 ssuominen 1.83
256     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
257     old
258 ssuominen 1.82
259     *polkit-0.106-r2 (17 Jun 2012)
260    
261     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
262     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
263     existing directories.
264 ssuominen 1.81
265     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
266     old
267 ssuominen 1.79
268 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
269    
270     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
271     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
272     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
273     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
274     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
275 ssuominen 1.78
276     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
277 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
278     #420173 and #420307.
279 ssuominen 1.77
280     *polkit-0.106 (07 Jun 2012)
281    
282     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
283 ssuominen 1.80 Version bump.
284 ssuominen 1.76
285     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
286     Improve systemd handling wrt #416317 by Christoph Brill
287 ssuominen 1.75
288     *polkit-0.105 (14 May 2012)
289    
290     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
291     Version bump.
292 jdhore 1.74
293     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
294     dev-util/pkgconfig -> virtual/pkgconfig
295 ssuominen 1.73
296     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
297     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
298     old
299 armin76 1.72
300     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
301     ia64/sh/sparc stable wrt #401513
302 ssuominen 1.71
303     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
304     ppc/ppc64 stable wrt #401513
305 klausman 1.70
306     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
307     Stable on alpha, bug #401513
308 tomka 1.69
309     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
310     marked x86 per bug 401513
311 maekke 1.68
312     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
313     arm stable, bug #401513
314 jer 1.67
315     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
316     Stable for HPPA (bug #401513).
317 ago 1.66
318     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
319     Stable for AMD64, wrt security bug #401513
320 ssuominen 1.65
321     *polkit-0.104-r1 (30 Jan 2012)
322    
323     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
324     Restore the default value of AdminIdentities from "wheel" to "0" like it was
325     in polkit-0.102 and ones before that. You should see files
326     50-localauthority.conf and 60-gentoo.conf in
327     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
328     with "man 8 pklocalauthority" as soon as possible.
329 maekke 1.64
330     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
331     arm stable, bug #397755
332 ago 1.63
333     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
334     Stable for AMD64, wrt bug #397755
335 ssuominen 1.62
336     *polkit-0.104 (05 Jan 2012)
337    
338     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
339     metadata.xml:
340     Version bump.
341 ssuominen 1.61
342     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
343     old
344 ssuominen 1.60
345     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
346     ppc/ppc64 stable wrt #387163
347 ssuominen 1.59
348     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
349     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
350 ssuominen 1.58
351     *polkit-0.103 (07 Dec 2011)
352    
353     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
354     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
355     "i.Dark_Templar"
356 armin76 1.57
357     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
358     alpha/arm/ia64/sh/sparc stable wrt #387163
359 maekke 1.56
360     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
361     arm stable, bug #387163
362 jer 1.55
363     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
364     Stable for HPPA (bug #387163).
365 phajdan.jr 1.54
366     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
367     x86 stable wrt bug #387163
368 hwoarang 1.53
369     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
370     Stable on amd64 wrt bug #387163
371 nirbheek 1.52
372     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
373     polkit-0.102.ebuild:
374     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
375 ssuominen 1.51
376     *polkit-0.102 (06 Aug 2011)
377    
378     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
379     Version bump.
380 mattst88 1.50
381     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
382     Added ~mips, bug 296548
383 eva 1.49
384     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
385     Add missing dtd to DEPEND, bug #355505.
386 armin76 1.48
387     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
388     alpha/arm/ia64/sh/sparc stable wrt #364973
389 phajdan.jr 1.47
390     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
391     polkit-0.101-r1.ebuild:
392     x86 stable wrt security bug #364973
393 jer 1.46
394     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
395     Stable for HPPA (bug #364973).
396 angelos 1.45
397     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
398     Stable on amd64 wrt bug #364973
399 xarthisius 1.44
400     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
401     ppc/ppc64 stable wrt #364973
402 nirbheek 1.43
403     *polkit-0.101-r1 (25 Apr 2011)
404    
405     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
406     +polkit-0.101-r1.ebuild:
407     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
408 xarthisius 1.42
409     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
410     ppc/ppc64 stable wrt #354509
411 armin76 1.41
412     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
413     alpha/ia64/sh/sparc stable wrt #354509
414 nirbheek 1.40
415     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
416     PDEPEND on 0.101 version of polkit-gnome
417 maekke 1.39
418     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
419     arm stable, bug #354509
420 ssuominen 1.38
421     *polkit-0.101 (11 Mar 2011)
422    
423     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
424     Version bump.
425 jer 1.37
426     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
427     Stable for HPPA (bug #354509).
428 tomka 1.36
429     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
430     x86 stable per bug 354509
431 hwoarang 1.35
432     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
433     Stable on amd64 wrt bug #354509
434 nirbheek 1.34
435     *polkit-0.100 (23 Feb 2011)
436    
437     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
438     Bump to 0.100
439 ssuominen 1.32
440     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
441 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
442 jer 1.31
443     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
444     Marked ~hppa (bug #296548).
445 ssuominen 1.30
446     *polkit-0.99-r1 (25 Dec 2010)
447    
448     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
449     Revision bump to remove static archives (.a) and libtool archives (.la).
450 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
451 nirbheek 1.27
452     *polkit-0.99 (25 Sep 2010)
453    
454     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
455     Bump to 0.99, masked due to >=glib-2.25 requirement
456 maekke 1.26
457     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
458     arm stable, bug #314899
459 armin76 1.24
460 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
461     polkit-0.96-r2.ebuild:
462     alpha/ia64/sh/sparc stable
463 josejx 1.23
464     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
465     Marked ppc/ppc64 stable.
466 klausman 1.22
467     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
468     Stable on alpha, bug #329621
469 jer 1.21
470     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
471     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
472     Stable for HPPA (bug #314899).
473 jer 1.20
474     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
475     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
476     Drop HPPA keywording (bug #324511).
477 nirbheek 1.19
478     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
479     polkit-0.96-r2.ebuild:
480     Add ewarn about ensuring that consolekit sessions are working. Either the
481     user needs to login using a login-manager with consolekit support, or use
482     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
483 nirbheek 1.18
484     *polkit-0.96-r2 (02 Jul 2010)
485    
486     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
487     +polkit-0.96-r2.ebuild, metadata.xml:
488     USE=expat was quite useless, expat is mandatory in polkit. Don't create
489     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
490     add introspection support
491 maekke 1.17
492     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
493     x86 stable, bug #314899
494 tester 1.16
495     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
496     amd64 stable, bug #314899
497 armin76 1.15
498     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
499     polkit-0.96-r1.ebuild:
500     Add ~sh
501 aballier 1.14
502     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
503     +files/polkit-0.96-getcwd.patch:
504     Fix build on fbsd and keyword it x86-fbsd
505 nirbheek 1.13
506     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
507     polkit-0.96-r1.ebuild:
508     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
509 nirbheek 1.12
510     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
511     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
512     -polkit-0.95.ebuild:
513     Remove old
514 nirbheek 1.11
515     *polkit-0.96-r1 (21 Mar 2010)
516    
517     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
518     +polkit-0.96-r1.ebuild:
519     Update with newer version of polkit-shadow patch
520 nirbheek 1.10
521     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
522     Fix minor problems with SRC_URI
523 nirbheek 1.9
524     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
525     Add experimental shadow support, bug 291116 . Patch thanks to the
526     slackware folks.
527 armin76 1.8
528     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
529     Add ~alpha/~arm/~ia64/~sparc
530 josejx 1.7
531     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
532     Marked ~ppc/~ppc64 for bug #296548.
533 nirbheek 1.6
534     *polkit-0.96 (23 Jan 2010)
535    
536     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
537     Version bump to 0.96; lots of bugfixes, see NEWS
538 jer 1.5
539     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
540     Marked ~hppa (bug #296548).
541 nirbheek 1.4
542     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
543     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
544     the user is in an active/local session via dbus methods
545 nirbheek 1.3
546     *polkit-0.95 (14 Nov 2009)
547    
548     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
549     Bump to 0.95 -- new lockdown API, last dev version till 1.0
550 nirbheek 1.2
551     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
552     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
553     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
554 eva 1.1
555     *polkit-0.94 (29 Oct 2009)
556    
557     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
558     +files/polkit-0.92-zsh-completions.patch,
559     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
560     +metadata.xml:
561     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20