/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.151 - (hide annotations) (download)
Thu Sep 19 17:12:35 2013 UTC (4 years, 1 month ago) by ssuominen
Branch: MAIN
Changes since 1.150: +4 -1 lines
Remove wrongly committed ebuild.

(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 ago 1.124 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 ssuominen 1.151 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.150 2013/09/19 17:08:30 ssuominen Exp $
4    
5     19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild:
6     Remove wrongly committed ebuild.
7 ssuominen 1.150
8     *polkit-0.112-r1 (19 Sep 2013)
9    
10     19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
11     polkit-0.112.ebuild:
12     -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
13 cardoe 1.149
14     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
15     Remove vulnerable version
16 cardoe 1.148
17     *polkit-0.110-r1 (19 Sep 2013)
18    
19     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
20     +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
21     Bump for CVE-2013-4288
22 cardoe 1.147
23     *polkit-0.112 (19 Sep 2013)
24    
25     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
26     Bump for CVE-2013-4288
27 ssuominen 1.146
28     10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
29     polkit-0.111-r1.ebuild:
30     Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
31     CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
32     always more about convinience than being strict requirement.
33 axs 1.145
34     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
35     dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
36     per ssuominen's approval
37 axs 1.144
38     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
39     polkit-0.111-r1.ebuild:
40     Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
41 ssuominen 1.143
42     *polkit-0.111-r1 (08 Aug 2013)
43    
44     08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
45     Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
46 ssuominen 1.142
47     *polkit-0.111 (15 May 2013)
48    
49     15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
50     Version bump by "okias" from Freenode
51 ssuominen 1.141
52     19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
53     -files/polkit-0.107-fallback.patch:
54     old
55 ago 1.140
56     19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
57     Stable for sh, wrt bug #452688
58 ssuominen 1.139
59     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
60     files/polkit-0.110-W_define.patch:
61     Include link to upstream bug.
62 ssuominen 1.138
63     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
64     +files/polkit-0.110-W_define.patch:
65     Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
66     WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
67 ago 1.137
68     09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
69     Stable for sparc, wrt bug #452688
70 vapier 1.136
71     03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
72     Add s390 keywords #457078 by Michael Palimaka.
73 ago 1.135
74     23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
75     Stable for alpha, wrt bug #452688
76 ago 1.134
77     10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
78     Stable for ppc64, wrt bug #452688
79 ago 1.133
80     09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
81     Stable for ia64, wrt bug #452688
82 ago 1.132
83     31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
84     Stable for ppc, wrt bug #452688
85 ssuominen 1.131
86     29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
87     Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
88     errors as noted by _AxS_.
89 maekke 1.130
90     26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
91     arm stable, bug #452688
92 ssuominen 1.129
93     20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
94     x86 stable wrt #452688
95 ssuominen 1.128
96     19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
97     amd64 stable wrt #452688
98 ssuominen 1.127
99     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
100     -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
101     old
102 ssuominen 1.126
103     *polkit-0.110 (11 Jan 2013)
104    
105     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
106     Version bump.
107 armin76 1.125
108     06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
109     polkit-0.109-r1.ebuild:
110     Add ~sh wrt #436668
111 ago 1.124
112     01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
113     Add ~ia64, wrt bug #436668
114 ago 1.123
115     30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
116     Stable for sparc, wrt bug #436666
117 ago 1.122
118     29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
119     Stable for alpha, wrt bug #436666
120 ssuominen 1.121
121     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
122     -polkit-0.109.ebuild:
123     old
124 ssuominen 1.120
125     *polkit-0.109-r1 (21 Dec 2012)
126    
127     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
128     +files/polkit-0.109-XAUTHORITY-fallback.patch:
129     Backport XAUTHORITY fallback support from upstream git.
130 ago 1.119
131     19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
132     Add ~ia64, wrt bug #436668
133 ssuominen 1.118
134     *polkit-0.109 (19 Dec 2012)
135    
136     19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
137     Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
138 ago 1.117
139     18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
140     Stable for ia64, wrt bug #436666
141 blueness 1.116
142     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
143     stable arm, bug #436666
144 ssuominen 1.115
145     22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
146     old
147 blueness 1.114
148     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
149     stable ppc64, bug #436666
150 ago 1.113
151     22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
152     Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
153     bug #436666
154 blueness 1.112
155     21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
156     stable ppc, bug #436666, thanks peratu
157 ssuominen 1.111
158     19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
159     Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
160     but using sed to avoid eautoreconf) wrt #443798
161 naota 1.109
162 ssuominen 1.110 *polkit-0.108 (18 Nov 2012)
163    
164     18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
165     Version bump.
166    
167     28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
168 naota 1.109 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
169     Drop ~x86-fbsd due to bug #439968.
170 jer 1.108
171     15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
172     polkit-0.107-r1.ebuild:
173     Drop HPPA keywording (bug #438368).
174 zmedico 1.107
175     15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
176     Set QA_MULTILIB_PATHS for bug #424423.
177 jer 1.106
178     09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
179     Marked ~hppa (bug #436668).
180 ssuominen 1.105
181     08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
182     Use pax-mark in src_compile() instead of src_install() for src_test() wrt
183     #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
184     and emphatize it's an Portage issue instead of polkit issue in src_install()
185     message.
186 ago 1.104
187     07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
188     Stable for amd64, wrt bug #436666
189 ssuominen 1.101
190     *polkit-0.107-r1 (20 Sep 2012)
191    
192     20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
193     +files/polkit-0.107-fallback.patch:
194     Introduce upstream patch for falling back to uid 0 for authentication if list
195     of admin identities is empty.
196 ssuominen 1.100
197     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
198     -polkit-0.106-r7.ebuild:
199     old
200 ssuominen 1.99
201     *polkit-0.107 (13 Jul 2012)
202    
203     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
204     Version bump.
205 ssuominen 1.98
206     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
207     -polkit-0.106-r6.ebuild:
208     old
209 ssuominen 1.97
210     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
211     Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
212     #391865 by Maksim Melnikau
213 ssuominen 1.96
214     *polkit-0.106-r7 (02 Jul 2012)
215    
216     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
217     RESTRICT="multilib-strict" since it's not compatible with the whole
218     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
219     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
220 ssuominen 1.95
221     *polkit-0.106-r6 (01 Jul 2012)
222    
223     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
224     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
225     /usr/lib to /usr/lib64 symlink.
226 swift 1.94
227     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
228     polkit-0.106-r5.ebuild:
229     Adding dependency on SELinux policykit module if USE=selinux is set
230 ssuominen 1.92
231     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
232 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
233     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
234 ssuominen 1.91
235     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
236     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
237     old
238 ssuominen 1.90
239     *polkit-0.106-r5 (27 Jun 2012)
240    
241     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
242     Revert entire unix-group:wheel experiment back to unix-user:0 because
243     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
244     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
245     by Doug Goldstein.
246 ssuominen 1.89
247     *polkit-0.106-r4 (27 Jun 2012)
248    
249     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
250     Stop installing polkit-backend-1.pc because upstream changed
251     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
252     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
253 ssuominen 1.88
254     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
255     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
256     Palimaka
257 tetromino 1.87
258     *polkit-0.106-r3 (25 Jun 2012)
259    
260     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
261     +polkit-0.106-r3.ebuild:
262     pax-mark polkitd to fix crashes on hardened/PaX systems.
263 ssuominen 1.86
264     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
265     Convert pkg_postinst() message about polkitd home directory to new
266     user.eclass function esethome().
267 ssuominen 1.85
268     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
269     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
270 ssuominen 1.84
271     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
272     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
273 ssuominen 1.83
274     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
275     old
276 ssuominen 1.82
277     *polkit-0.106-r2 (17 Jun 2012)
278    
279     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
280     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
281     existing directories.
282 ssuominen 1.81
283     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
284     old
285 ssuominen 1.79
286 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
287    
288     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
289     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
290     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
291     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
292     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
293 ssuominen 1.78
294     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
295 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
296     #420173 and #420307.
297 ssuominen 1.77
298     *polkit-0.106 (07 Jun 2012)
299    
300     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
301 ssuominen 1.80 Version bump.
302 ssuominen 1.76
303     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
304     Improve systemd handling wrt #416317 by Christoph Brill
305 ssuominen 1.75
306     *polkit-0.105 (14 May 2012)
307    
308     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
309     Version bump.
310 jdhore 1.74
311     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
312     dev-util/pkgconfig -> virtual/pkgconfig
313 ssuominen 1.73
314     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
315     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
316     old
317 armin76 1.72
318     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
319     ia64/sh/sparc stable wrt #401513
320 ssuominen 1.71
321     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
322     ppc/ppc64 stable wrt #401513
323 klausman 1.70
324     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
325     Stable on alpha, bug #401513
326 tomka 1.69
327     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
328     marked x86 per bug 401513
329 maekke 1.68
330     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
331     arm stable, bug #401513
332 jer 1.67
333     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
334     Stable for HPPA (bug #401513).
335 ago 1.66
336     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
337     Stable for AMD64, wrt security bug #401513
338 ssuominen 1.65
339     *polkit-0.104-r1 (30 Jan 2012)
340    
341     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
342     Restore the default value of AdminIdentities from "wheel" to "0" like it was
343     in polkit-0.102 and ones before that. You should see files
344     50-localauthority.conf and 60-gentoo.conf in
345     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
346     with "man 8 pklocalauthority" as soon as possible.
347 maekke 1.64
348     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
349     arm stable, bug #397755
350 ago 1.63
351     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
352     Stable for AMD64, wrt bug #397755
353 ssuominen 1.62
354     *polkit-0.104 (05 Jan 2012)
355    
356     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
357     metadata.xml:
358     Version bump.
359 ssuominen 1.61
360     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
361     old
362 ssuominen 1.60
363     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
364     ppc/ppc64 stable wrt #387163
365 ssuominen 1.59
366     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
367     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
368 ssuominen 1.58
369     *polkit-0.103 (07 Dec 2011)
370    
371     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
372     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
373     "i.Dark_Templar"
374 armin76 1.57
375     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
376     alpha/arm/ia64/sh/sparc stable wrt #387163
377 maekke 1.56
378     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
379     arm stable, bug #387163
380 jer 1.55
381     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
382     Stable for HPPA (bug #387163).
383 phajdan.jr 1.54
384     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
385     x86 stable wrt bug #387163
386 hwoarang 1.53
387     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
388     Stable on amd64 wrt bug #387163
389 nirbheek 1.52
390     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
391     polkit-0.102.ebuild:
392     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
393 ssuominen 1.51
394     *polkit-0.102 (06 Aug 2011)
395    
396     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
397     Version bump.
398 mattst88 1.50
399     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
400     Added ~mips, bug 296548
401 eva 1.49
402     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
403     Add missing dtd to DEPEND, bug #355505.
404 armin76 1.48
405     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
406     alpha/arm/ia64/sh/sparc stable wrt #364973
407 phajdan.jr 1.47
408     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
409     polkit-0.101-r1.ebuild:
410     x86 stable wrt security bug #364973
411 jer 1.46
412     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
413     Stable for HPPA (bug #364973).
414 angelos 1.45
415     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
416     Stable on amd64 wrt bug #364973
417 xarthisius 1.44
418     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
419     ppc/ppc64 stable wrt #364973
420 nirbheek 1.43
421     *polkit-0.101-r1 (25 Apr 2011)
422    
423     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
424     +polkit-0.101-r1.ebuild:
425     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
426 xarthisius 1.42
427     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
428     ppc/ppc64 stable wrt #354509
429 armin76 1.41
430     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
431     alpha/ia64/sh/sparc stable wrt #354509
432 nirbheek 1.40
433     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
434     PDEPEND on 0.101 version of polkit-gnome
435 maekke 1.39
436     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
437     arm stable, bug #354509
438 ssuominen 1.38
439     *polkit-0.101 (11 Mar 2011)
440    
441     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
442     Version bump.
443 jer 1.37
444     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
445     Stable for HPPA (bug #354509).
446 tomka 1.36
447     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
448     x86 stable per bug 354509
449 hwoarang 1.35
450     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
451     Stable on amd64 wrt bug #354509
452 nirbheek 1.34
453     *polkit-0.100 (23 Feb 2011)
454    
455     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
456     Bump to 0.100
457 ssuominen 1.32
458     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
459 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
460 jer 1.31
461     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
462     Marked ~hppa (bug #296548).
463 ssuominen 1.30
464     *polkit-0.99-r1 (25 Dec 2010)
465    
466     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
467     Revision bump to remove static archives (.a) and libtool archives (.la).
468 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
469 nirbheek 1.27
470     *polkit-0.99 (25 Sep 2010)
471    
472     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
473     Bump to 0.99, masked due to >=glib-2.25 requirement
474 maekke 1.26
475     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
476     arm stable, bug #314899
477 armin76 1.24
478 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
479     polkit-0.96-r2.ebuild:
480     alpha/ia64/sh/sparc stable
481 josejx 1.23
482     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
483     Marked ppc/ppc64 stable.
484 klausman 1.22
485     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
486     Stable on alpha, bug #329621
487 jer 1.21
488     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
489     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
490     Stable for HPPA (bug #314899).
491 jer 1.20
492     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
493     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
494     Drop HPPA keywording (bug #324511).
495 nirbheek 1.19
496     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
497     polkit-0.96-r2.ebuild:
498     Add ewarn about ensuring that consolekit sessions are working. Either the
499     user needs to login using a login-manager with consolekit support, or use
500     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
501 nirbheek 1.18
502     *polkit-0.96-r2 (02 Jul 2010)
503    
504     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
505     +polkit-0.96-r2.ebuild, metadata.xml:
506     USE=expat was quite useless, expat is mandatory in polkit. Don't create
507     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
508     add introspection support
509 maekke 1.17
510     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
511     x86 stable, bug #314899
512 tester 1.16
513     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
514     amd64 stable, bug #314899
515 armin76 1.15
516     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
517     polkit-0.96-r1.ebuild:
518     Add ~sh
519 aballier 1.14
520     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
521     +files/polkit-0.96-getcwd.patch:
522     Fix build on fbsd and keyword it x86-fbsd
523 nirbheek 1.13
524     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
525     polkit-0.96-r1.ebuild:
526     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
527 nirbheek 1.12
528     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
529     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
530     -polkit-0.95.ebuild:
531     Remove old
532 nirbheek 1.11
533     *polkit-0.96-r1 (21 Mar 2010)
534    
535     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
536     +polkit-0.96-r1.ebuild:
537     Update with newer version of polkit-shadow patch
538 nirbheek 1.10
539     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
540     Fix minor problems with SRC_URI
541 nirbheek 1.9
542     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
543     Add experimental shadow support, bug 291116 . Patch thanks to the
544     slackware folks.
545 armin76 1.8
546     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
547     Add ~alpha/~arm/~ia64/~sparc
548 josejx 1.7
549     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
550     Marked ~ppc/~ppc64 for bug #296548.
551 nirbheek 1.6
552     *polkit-0.96 (23 Jan 2010)
553    
554     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
555     Version bump to 0.96; lots of bugfixes, see NEWS
556 jer 1.5
557     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
558     Marked ~hppa (bug #296548).
559 nirbheek 1.4
560     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
561     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
562     the user is in an active/local session via dbus methods
563 nirbheek 1.3
564     *polkit-0.95 (14 Nov 2009)
565    
566     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
567     Bump to 0.95 -- new lockdown API, last dev version till 1.0
568 nirbheek 1.2
569     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
570     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
571     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
572 eva 1.1
573     *polkit-0.94 (29 Oct 2009)
574    
575     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
576     +files/polkit-0.92-zsh-completions.patch,
577     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
578     +metadata.xml:
579     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20