/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.159 - (hide annotations) (download)
Sun Sep 22 14:25:15 2013 UTC (4 years ago) by ago
Branch: MAIN
Changes since 1.158: +4 -1 lines
Stable for alpha, wrt bug #484486

(Portage version: 2.1.12.2/cvs/Linux ppc64, RepoMan options: --include-arches="alpha", signed Manifest commit with key 7194459F)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 ago 1.124 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 ago 1.159 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.158 2013/09/22 08:00:45 ago Exp $
4    
5     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
6     Stable for alpha, wrt bug #484486
7 ago 1.158
8     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
9     Stable for ia64, wrt bug #484486
10 ago 1.157
11     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
12     Stable for ppc64, wrt bug #484486
13 ago 1.156
14     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
15     Stable for ppc, wrt bug #484486
16 ago 1.155
17     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
18     Stable for arm, wrt bug #484486
19 ago 1.154
20     21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
21     Stable for x86, wrt bug #484486
22 ago 1.153
23     21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
24     Stable for amd64, wrt bug #484486
25 ssuominen 1.151
26 ssuominen 1.152 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
27     -files/polkit-0.110-CVE-2013-4288.patch:
28     old
29 ssuominen 1.150
30     *polkit-0.112-r1 (19 Sep 2013)
31    
32     19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
33     polkit-0.112.ebuild:
34     -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
35 cardoe 1.149
36     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
37     Remove vulnerable version
38 cardoe 1.148
39     *polkit-0.110-r1 (19 Sep 2013)
40    
41     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
42     +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
43     Bump for CVE-2013-4288
44 cardoe 1.147
45     *polkit-0.112 (19 Sep 2013)
46    
47     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
48     Bump for CVE-2013-4288
49 ssuominen 1.146
50     10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
51     polkit-0.111-r1.ebuild:
52     Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
53     CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
54     always more about convinience than being strict requirement.
55 axs 1.145
56     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
57     dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
58     per ssuominen's approval
59 axs 1.144
60     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
61     polkit-0.111-r1.ebuild:
62     Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
63 ssuominen 1.143
64     *polkit-0.111-r1 (08 Aug 2013)
65    
66     08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
67     Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
68 ssuominen 1.142
69     *polkit-0.111 (15 May 2013)
70    
71     15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
72     Version bump by "okias" from Freenode
73 ssuominen 1.141
74     19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
75     -files/polkit-0.107-fallback.patch:
76     old
77 ago 1.140
78     19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
79     Stable for sh, wrt bug #452688
80 ssuominen 1.139
81     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
82     files/polkit-0.110-W_define.patch:
83     Include link to upstream bug.
84 ssuominen 1.138
85     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
86     +files/polkit-0.110-W_define.patch:
87     Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
88     WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
89 ago 1.137
90     09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
91     Stable for sparc, wrt bug #452688
92 vapier 1.136
93     03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
94     Add s390 keywords #457078 by Michael Palimaka.
95 ago 1.135
96     23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
97     Stable for alpha, wrt bug #452688
98 ago 1.134
99     10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
100     Stable for ppc64, wrt bug #452688
101 ago 1.133
102     09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
103     Stable for ia64, wrt bug #452688
104 ago 1.132
105     31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
106     Stable for ppc, wrt bug #452688
107 ssuominen 1.131
108     29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
109     Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
110     errors as noted by _AxS_.
111 maekke 1.130
112     26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
113     arm stable, bug #452688
114 ssuominen 1.129
115     20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
116     x86 stable wrt #452688
117 ssuominen 1.128
118     19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
119     amd64 stable wrt #452688
120 ssuominen 1.127
121     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
122     -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
123     old
124 ssuominen 1.126
125     *polkit-0.110 (11 Jan 2013)
126    
127     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
128     Version bump.
129 armin76 1.125
130     06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
131     polkit-0.109-r1.ebuild:
132     Add ~sh wrt #436668
133 ago 1.124
134     01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
135     Add ~ia64, wrt bug #436668
136 ago 1.123
137     30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
138     Stable for sparc, wrt bug #436666
139 ago 1.122
140     29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
141     Stable for alpha, wrt bug #436666
142 ssuominen 1.121
143     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
144     -polkit-0.109.ebuild:
145     old
146 ssuominen 1.120
147     *polkit-0.109-r1 (21 Dec 2012)
148    
149     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
150     +files/polkit-0.109-XAUTHORITY-fallback.patch:
151     Backport XAUTHORITY fallback support from upstream git.
152 ago 1.119
153     19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
154     Add ~ia64, wrt bug #436668
155 ssuominen 1.118
156     *polkit-0.109 (19 Dec 2012)
157    
158     19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
159     Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
160 ago 1.117
161     18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
162     Stable for ia64, wrt bug #436666
163 blueness 1.116
164     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
165     stable arm, bug #436666
166 ssuominen 1.115
167     22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
168     old
169 blueness 1.114
170     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
171     stable ppc64, bug #436666
172 ago 1.113
173     22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
174     Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
175     bug #436666
176 blueness 1.112
177     21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
178     stable ppc, bug #436666, thanks peratu
179 ssuominen 1.111
180     19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
181     Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
182     but using sed to avoid eautoreconf) wrt #443798
183 naota 1.109
184 ssuominen 1.110 *polkit-0.108 (18 Nov 2012)
185    
186     18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
187     Version bump.
188    
189     28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
190 naota 1.109 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
191     Drop ~x86-fbsd due to bug #439968.
192 jer 1.108
193     15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
194     polkit-0.107-r1.ebuild:
195     Drop HPPA keywording (bug #438368).
196 zmedico 1.107
197     15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
198     Set QA_MULTILIB_PATHS for bug #424423.
199 jer 1.106
200     09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
201     Marked ~hppa (bug #436668).
202 ssuominen 1.105
203     08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
204     Use pax-mark in src_compile() instead of src_install() for src_test() wrt
205     #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
206     and emphatize it's an Portage issue instead of polkit issue in src_install()
207     message.
208 ago 1.104
209     07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
210     Stable for amd64, wrt bug #436666
211 ssuominen 1.101
212     *polkit-0.107-r1 (20 Sep 2012)
213    
214     20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
215     +files/polkit-0.107-fallback.patch:
216     Introduce upstream patch for falling back to uid 0 for authentication if list
217     of admin identities is empty.
218 ssuominen 1.100
219     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
220     -polkit-0.106-r7.ebuild:
221     old
222 ssuominen 1.99
223     *polkit-0.107 (13 Jul 2012)
224    
225     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
226     Version bump.
227 ssuominen 1.98
228     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
229     -polkit-0.106-r6.ebuild:
230     old
231 ssuominen 1.97
232     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
233     Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
234     #391865 by Maksim Melnikau
235 ssuominen 1.96
236     *polkit-0.106-r7 (02 Jul 2012)
237    
238     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
239     RESTRICT="multilib-strict" since it's not compatible with the whole
240     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
241     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
242 ssuominen 1.95
243     *polkit-0.106-r6 (01 Jul 2012)
244    
245     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
246     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
247     /usr/lib to /usr/lib64 symlink.
248 swift 1.94
249     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
250     polkit-0.106-r5.ebuild:
251     Adding dependency on SELinux policykit module if USE=selinux is set
252 ssuominen 1.92
253     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
254 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
255     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
256 ssuominen 1.91
257     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
258     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
259     old
260 ssuominen 1.90
261     *polkit-0.106-r5 (27 Jun 2012)
262    
263     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
264     Revert entire unix-group:wheel experiment back to unix-user:0 because
265     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
266     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
267     by Doug Goldstein.
268 ssuominen 1.89
269     *polkit-0.106-r4 (27 Jun 2012)
270    
271     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
272     Stop installing polkit-backend-1.pc because upstream changed
273     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
274     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
275 ssuominen 1.88
276     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
277     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
278     Palimaka
279 tetromino 1.87
280     *polkit-0.106-r3 (25 Jun 2012)
281    
282     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
283     +polkit-0.106-r3.ebuild:
284     pax-mark polkitd to fix crashes on hardened/PaX systems.
285 ssuominen 1.86
286     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
287     Convert pkg_postinst() message about polkitd home directory to new
288     user.eclass function esethome().
289 ssuominen 1.85
290     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
291     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
292 ssuominen 1.84
293     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
294     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
295 ssuominen 1.83
296     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
297     old
298 ssuominen 1.82
299     *polkit-0.106-r2 (17 Jun 2012)
300    
301     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
302     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
303     existing directories.
304 ssuominen 1.81
305     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
306     old
307 ssuominen 1.79
308 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
309    
310     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
311     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
312     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
313     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
314     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
315 ssuominen 1.78
316     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
317 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
318     #420173 and #420307.
319 ssuominen 1.77
320     *polkit-0.106 (07 Jun 2012)
321    
322     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
323 ssuominen 1.80 Version bump.
324 ssuominen 1.76
325     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
326     Improve systemd handling wrt #416317 by Christoph Brill
327 ssuominen 1.75
328     *polkit-0.105 (14 May 2012)
329    
330     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
331     Version bump.
332 jdhore 1.74
333     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
334     dev-util/pkgconfig -> virtual/pkgconfig
335 ssuominen 1.73
336     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
337     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
338     old
339 armin76 1.72
340     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
341     ia64/sh/sparc stable wrt #401513
342 ssuominen 1.71
343     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
344     ppc/ppc64 stable wrt #401513
345 klausman 1.70
346     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
347     Stable on alpha, bug #401513
348 tomka 1.69
349     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
350     marked x86 per bug 401513
351 maekke 1.68
352     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
353     arm stable, bug #401513
354 jer 1.67
355     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
356     Stable for HPPA (bug #401513).
357 ago 1.66
358     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
359     Stable for AMD64, wrt security bug #401513
360 ssuominen 1.65
361     *polkit-0.104-r1 (30 Jan 2012)
362    
363     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
364     Restore the default value of AdminIdentities from "wheel" to "0" like it was
365     in polkit-0.102 and ones before that. You should see files
366     50-localauthority.conf and 60-gentoo.conf in
367     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
368     with "man 8 pklocalauthority" as soon as possible.
369 maekke 1.64
370     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
371     arm stable, bug #397755
372 ago 1.63
373     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
374     Stable for AMD64, wrt bug #397755
375 ssuominen 1.62
376     *polkit-0.104 (05 Jan 2012)
377    
378     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
379     metadata.xml:
380     Version bump.
381 ssuominen 1.61
382     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
383     old
384 ssuominen 1.60
385     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
386     ppc/ppc64 stable wrt #387163
387 ssuominen 1.59
388     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
389     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
390 ssuominen 1.58
391     *polkit-0.103 (07 Dec 2011)
392    
393     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
394     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
395     "i.Dark_Templar"
396 armin76 1.57
397     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
398     alpha/arm/ia64/sh/sparc stable wrt #387163
399 maekke 1.56
400     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
401     arm stable, bug #387163
402 jer 1.55
403     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
404     Stable for HPPA (bug #387163).
405 phajdan.jr 1.54
406     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
407     x86 stable wrt bug #387163
408 hwoarang 1.53
409     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
410     Stable on amd64 wrt bug #387163
411 nirbheek 1.52
412     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
413     polkit-0.102.ebuild:
414     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
415 ssuominen 1.51
416     *polkit-0.102 (06 Aug 2011)
417    
418     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
419     Version bump.
420 mattst88 1.50
421     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
422     Added ~mips, bug 296548
423 eva 1.49
424     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
425     Add missing dtd to DEPEND, bug #355505.
426 armin76 1.48
427     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
428     alpha/arm/ia64/sh/sparc stable wrt #364973
429 phajdan.jr 1.47
430     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
431     polkit-0.101-r1.ebuild:
432     x86 stable wrt security bug #364973
433 jer 1.46
434     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
435     Stable for HPPA (bug #364973).
436 angelos 1.45
437     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
438     Stable on amd64 wrt bug #364973
439 xarthisius 1.44
440     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
441     ppc/ppc64 stable wrt #364973
442 nirbheek 1.43
443     *polkit-0.101-r1 (25 Apr 2011)
444    
445     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
446     +polkit-0.101-r1.ebuild:
447     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
448 xarthisius 1.42
449     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
450     ppc/ppc64 stable wrt #354509
451 armin76 1.41
452     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
453     alpha/ia64/sh/sparc stable wrt #354509
454 nirbheek 1.40
455     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
456     PDEPEND on 0.101 version of polkit-gnome
457 maekke 1.39
458     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
459     arm stable, bug #354509
460 ssuominen 1.38
461     *polkit-0.101 (11 Mar 2011)
462    
463     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
464     Version bump.
465 jer 1.37
466     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
467     Stable for HPPA (bug #354509).
468 tomka 1.36
469     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
470     x86 stable per bug 354509
471 hwoarang 1.35
472     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
473     Stable on amd64 wrt bug #354509
474 nirbheek 1.34
475     *polkit-0.100 (23 Feb 2011)
476    
477     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
478     Bump to 0.100
479 ssuominen 1.32
480     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
481 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
482 jer 1.31
483     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
484     Marked ~hppa (bug #296548).
485 ssuominen 1.30
486     *polkit-0.99-r1 (25 Dec 2010)
487    
488     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
489     Revision bump to remove static archives (.a) and libtool archives (.la).
490 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
491 nirbheek 1.27
492     *polkit-0.99 (25 Sep 2010)
493    
494     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
495     Bump to 0.99, masked due to >=glib-2.25 requirement
496 maekke 1.26
497     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
498     arm stable, bug #314899
499 armin76 1.24
500 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
501     polkit-0.96-r2.ebuild:
502     alpha/ia64/sh/sparc stable
503 josejx 1.23
504     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
505     Marked ppc/ppc64 stable.
506 klausman 1.22
507     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
508     Stable on alpha, bug #329621
509 jer 1.21
510     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
511     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
512     Stable for HPPA (bug #314899).
513 jer 1.20
514     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
515     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
516     Drop HPPA keywording (bug #324511).
517 nirbheek 1.19
518     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
519     polkit-0.96-r2.ebuild:
520     Add ewarn about ensuring that consolekit sessions are working. Either the
521     user needs to login using a login-manager with consolekit support, or use
522     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
523 nirbheek 1.18
524     *polkit-0.96-r2 (02 Jul 2010)
525    
526     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
527     +polkit-0.96-r2.ebuild, metadata.xml:
528     USE=expat was quite useless, expat is mandatory in polkit. Don't create
529     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
530     add introspection support
531 maekke 1.17
532     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
533     x86 stable, bug #314899
534 tester 1.16
535     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
536     amd64 stable, bug #314899
537 armin76 1.15
538     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
539     polkit-0.96-r1.ebuild:
540     Add ~sh
541 aballier 1.14
542     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
543     +files/polkit-0.96-getcwd.patch:
544     Fix build on fbsd and keyword it x86-fbsd
545 nirbheek 1.13
546     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
547     polkit-0.96-r1.ebuild:
548     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
549 nirbheek 1.12
550     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
551     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
552     -polkit-0.95.ebuild:
553     Remove old
554 nirbheek 1.11
555     *polkit-0.96-r1 (21 Mar 2010)
556    
557     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
558     +polkit-0.96-r1.ebuild:
559     Update with newer version of polkit-shadow patch
560 nirbheek 1.10
561     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
562     Fix minor problems with SRC_URI
563 nirbheek 1.9
564     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
565     Add experimental shadow support, bug 291116 . Patch thanks to the
566     slackware folks.
567 armin76 1.8
568     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
569     Add ~alpha/~arm/~ia64/~sparc
570 josejx 1.7
571     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
572     Marked ~ppc/~ppc64 for bug #296548.
573 nirbheek 1.6
574     *polkit-0.96 (23 Jan 2010)
575    
576     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
577     Version bump to 0.96; lots of bugfixes, see NEWS
578 jer 1.5
579     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
580     Marked ~hppa (bug #296548).
581 nirbheek 1.4
582     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
583     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
584     the user is in an active/local session via dbus methods
585 nirbheek 1.3
586     *polkit-0.95 (14 Nov 2009)
587    
588     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
589     Bump to 0.95 -- new lockdown API, last dev version till 1.0
590 nirbheek 1.2
591     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
592     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
593     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
594 eva 1.1
595     *polkit-0.94 (29 Oct 2009)
596    
597     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
598     +files/polkit-0.92-zsh-completions.patch,
599     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
600     +metadata.xml:
601     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20