/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.187 - (hide annotations) (download)
Tue Nov 4 09:22:21 2014 UTC (2 years, 10 months ago) by ago
Branch: MAIN
Changes since 1.186: +4 -1 lines
Stable for sparc, wrt bug #525252

(Portage version: 2.2.8-r2/cvs/Linux x86_64, RepoMan options: --include-arches="sparc", signed Manifest commit with key 7194459F)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 pacho 1.164 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3 ago 1.187 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.186 2014/11/03 09:37:34 ago Exp $
4    
5     04 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
6     Stable for sparc, wrt bug #525252
7 ago 1.186
8     03 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
9     Stable for x86, wrt bug #525252
10 swift 1.185
11     02 Nov 2014; Sven Vermeulen <swift@gentoo.org> polkit-0.112-r2.ebuild:
12     Remove sec-policy/selinux-* dependency from DEPEND but keep in RDEPEND (bug
13     #527698)
14 ago 1.184
15     02 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
16     Stable for alpha, wrt bug #525252
17 ago 1.183
18     01 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
19     Stable for ppc, wrt bug #525252
20 ago 1.182
21     31 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
22     Stable for ppc64, wrt bug #525252
23 ago 1.181
24     30 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
25     Stable for amd64, wrt bug #525252
26 maekke 1.180
27     23 Oct 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r2.ebuild:
28     arm stable, bug #525252
29 jer 1.179
30     16 Oct 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
31     Stable for HPPA (bug #525252).
32 ssuominen 1.178
33     14 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r1.ebuild,
34     polkit-0.112-r2.ebuild:
35     Fix the arch logic for HPPA (to match how IA64 and MIPS are handled in the
36     ebuild)
37 jer 1.177
38     14 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r1.ebuild:
39     Stable for HPPA (bug #519870).
40 jer 1.176
41     13 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
42     Marked ~hppa (bug #517804).
43 ago 1.175
44     17 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
45     Stable for alpha, wrt bug #508862
46 ago 1.174
47     14 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
48     Stable for sparc, wrt bug #508862
49 ago 1.173
50     13 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
51     Stable for ia64, wrt bug #508862
52 ago 1.172
53     11 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
54     Stable for ppc64, wrt bug #508862
55 ago 1.171
56     10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
57     Stable for ppc, wrt bug #508862
58 pacho 1.170
59     06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
60     Needs to be rebuilt with systemd subslot bumps
61 ssuominen 1.169
62     15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
63     Add proper metadata for freedesktop-bugs@g.o
64 ssuominen 1.168
65     *polkit-0.112-r2 (15 Mar 2014)
66    
67     15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
68     USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
69 pacho 1.167
70     11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
71     Cleanup due #239126
72 maekke 1.166
73     25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
74     arm stable, bug #500758
75 pacho 1.165
76     23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
77     x86 stable, bug #500758
78 pacho 1.164
79     23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
80     amd64 stable, bug #500758
81 blueness 1.163
82     28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
83     Fix ia64 where the order of the configure options was overridden by mips,
84     thanks Arfrever
85 blueness 1.162
86     27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
87     Because sometimes portage is stupid
88 blueness 1.161
89     24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
90     Fix dependence on spidermonkey for mips, bug #495168
91 ago 1.160
92     23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
93     Stable for sparc, wrt bug #484486
94 ago 1.159
95     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
96     Stable for alpha, wrt bug #484486
97 ago 1.158
98     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
99     Stable for ia64, wrt bug #484486
100 ago 1.157
101     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
102     Stable for ppc64, wrt bug #484486
103 ago 1.156
104     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
105     Stable for ppc, wrt bug #484486
106 ago 1.155
107     22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
108     Stable for arm, wrt bug #484486
109 ago 1.154
110     21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
111     Stable for x86, wrt bug #484486
112 ago 1.153
113     21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
114     Stable for amd64, wrt bug #484486
115 ssuominen 1.151
116 ssuominen 1.152 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
117     -files/polkit-0.110-CVE-2013-4288.patch:
118     old
119 ssuominen 1.150
120     *polkit-0.112-r1 (19 Sep 2013)
121    
122     19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
123     polkit-0.112.ebuild:
124     -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
125 cardoe 1.149
126     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
127     Remove vulnerable version
128 cardoe 1.148
129     *polkit-0.110-r1 (19 Sep 2013)
130    
131     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
132     +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
133     Bump for CVE-2013-4288
134 cardoe 1.147
135     *polkit-0.112 (19 Sep 2013)
136    
137     19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
138     Bump for CVE-2013-4288
139 ssuominen 1.146
140     10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
141     polkit-0.111-r1.ebuild:
142     Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
143     CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
144     always more about convinience than being strict requirement.
145 axs 1.145
146     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
147     dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
148     per ssuominen's approval
149 axs 1.144
150     09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
151     polkit-0.111-r1.ebuild:
152     Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
153 ssuominen 1.143
154     *polkit-0.111-r1 (08 Aug 2013)
155    
156     08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
157     Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
158 ssuominen 1.142
159     *polkit-0.111 (15 May 2013)
160    
161     15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
162     Version bump by "okias" from Freenode
163 ssuominen 1.141
164     19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
165     -files/polkit-0.107-fallback.patch:
166     old
167 ago 1.140
168     19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
169     Stable for sh, wrt bug #452688
170 ssuominen 1.139
171     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
172     files/polkit-0.110-W_define.patch:
173     Include link to upstream bug.
174 ssuominen 1.138
175     12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
176     +files/polkit-0.110-W_define.patch:
177     Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
178     WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
179 ago 1.137
180     09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
181     Stable for sparc, wrt bug #452688
182 vapier 1.136
183     03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
184     Add s390 keywords #457078 by Michael Palimaka.
185 ago 1.135
186     23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
187     Stable for alpha, wrt bug #452688
188 ago 1.134
189     10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
190     Stable for ppc64, wrt bug #452688
191 ago 1.133
192     09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
193     Stable for ia64, wrt bug #452688
194 ago 1.132
195     31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
196     Stable for ppc, wrt bug #452688
197 ssuominen 1.131
198     29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
199     Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
200     errors as noted by _AxS_.
201 maekke 1.130
202     26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
203     arm stable, bug #452688
204 ssuominen 1.129
205     20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
206     x86 stable wrt #452688
207 ssuominen 1.128
208     19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
209     amd64 stable wrt #452688
210 ssuominen 1.127
211     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
212     -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
213     old
214 ssuominen 1.126
215     *polkit-0.110 (11 Jan 2013)
216    
217     11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
218     Version bump.
219 armin76 1.125
220     06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
221     polkit-0.109-r1.ebuild:
222     Add ~sh wrt #436668
223 ago 1.124
224     01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
225     Add ~ia64, wrt bug #436668
226 ago 1.123
227     30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
228     Stable for sparc, wrt bug #436666
229 ago 1.122
230     29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
231     Stable for alpha, wrt bug #436666
232 ssuominen 1.121
233     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
234     -polkit-0.109.ebuild:
235     old
236 ssuominen 1.120
237     *polkit-0.109-r1 (21 Dec 2012)
238    
239     21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
240     +files/polkit-0.109-XAUTHORITY-fallback.patch:
241     Backport XAUTHORITY fallback support from upstream git.
242 ago 1.119
243     19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
244     Add ~ia64, wrt bug #436668
245 ssuominen 1.118
246     *polkit-0.109 (19 Dec 2012)
247    
248     19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
249     Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
250 ago 1.117
251     18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
252     Stable for ia64, wrt bug #436666
253 blueness 1.116
254     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
255     stable arm, bug #436666
256 ssuominen 1.115
257     22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
258     old
259 blueness 1.114
260     22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
261     stable ppc64, bug #436666
262 ago 1.113
263     22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
264     Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
265     bug #436666
266 blueness 1.112
267     21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
268     stable ppc, bug #436666, thanks peratu
269 ssuominen 1.111
270     19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
271     Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
272     but using sed to avoid eautoreconf) wrt #443798
273 naota 1.109
274 ssuominen 1.110 *polkit-0.108 (18 Nov 2012)
275    
276     18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
277     Version bump.
278    
279     28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
280 naota 1.109 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
281     Drop ~x86-fbsd due to bug #439968.
282 jer 1.108
283     15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
284     polkit-0.107-r1.ebuild:
285     Drop HPPA keywording (bug #438368).
286 zmedico 1.107
287     15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
288     Set QA_MULTILIB_PATHS for bug #424423.
289 jer 1.106
290     09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
291     Marked ~hppa (bug #436668).
292 ssuominen 1.105
293     08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
294     Use pax-mark in src_compile() instead of src_install() for src_test() wrt
295     #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
296     and emphatize it's an Portage issue instead of polkit issue in src_install()
297     message.
298 ago 1.104
299     07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
300     Stable for amd64, wrt bug #436666
301 ssuominen 1.101
302     *polkit-0.107-r1 (20 Sep 2012)
303    
304     20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
305     +files/polkit-0.107-fallback.patch:
306     Introduce upstream patch for falling back to uid 0 for authentication if list
307     of admin identities is empty.
308 ssuominen 1.100
309     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
310     -polkit-0.106-r7.ebuild:
311     old
312 ssuominen 1.99
313     *polkit-0.107 (13 Jul 2012)
314    
315     13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
316     Version bump.
317 ssuominen 1.98
318     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
319     -polkit-0.106-r6.ebuild:
320     old
321 ssuominen 1.97
322     07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
323     Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
324     #391865 by Maksim Melnikau
325 ssuominen 1.96
326     *polkit-0.106-r7 (02 Jul 2012)
327    
328     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
329     RESTRICT="multilib-strict" since it's not compatible with the whole
330     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
331     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
332 ssuominen 1.95
333     *polkit-0.106-r6 (01 Jul 2012)
334    
335     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
336     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
337     /usr/lib to /usr/lib64 symlink.
338 swift 1.94
339     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
340     polkit-0.106-r5.ebuild:
341     Adding dependency on SELinux policykit module if USE=selinux is set
342 ssuominen 1.92
343     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
344 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
345     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
346 ssuominen 1.91
347     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
348     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
349     old
350 ssuominen 1.90
351     *polkit-0.106-r5 (27 Jun 2012)
352    
353     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
354     Revert entire unix-group:wheel experiment back to unix-user:0 because
355     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
356     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
357     by Doug Goldstein.
358 ssuominen 1.89
359     *polkit-0.106-r4 (27 Jun 2012)
360    
361     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
362     Stop installing polkit-backend-1.pc because upstream changed
363     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
364     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
365 ssuominen 1.88
366     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
367     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
368     Palimaka
369 tetromino 1.87
370     *polkit-0.106-r3 (25 Jun 2012)
371    
372     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
373     +polkit-0.106-r3.ebuild:
374     pax-mark polkitd to fix crashes on hardened/PaX systems.
375 ssuominen 1.86
376     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
377     Convert pkg_postinst() message about polkitd home directory to new
378     user.eclass function esethome().
379 ssuominen 1.85
380     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
381     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
382 ssuominen 1.84
383     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
384     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
385 ssuominen 1.83
386     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
387     old
388 ssuominen 1.82
389     *polkit-0.106-r2 (17 Jun 2012)
390    
391     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
392     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
393     existing directories.
394 ssuominen 1.81
395     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
396     old
397 ssuominen 1.79
398 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
399    
400     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
401     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
402     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
403     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
404     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
405 ssuominen 1.78
406     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
407 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
408     #420173 and #420307.
409 ssuominen 1.77
410     *polkit-0.106 (07 Jun 2012)
411    
412     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
413 ssuominen 1.80 Version bump.
414 ssuominen 1.76
415     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
416     Improve systemd handling wrt #416317 by Christoph Brill
417 ssuominen 1.75
418     *polkit-0.105 (14 May 2012)
419    
420     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
421     Version bump.
422 jdhore 1.74
423     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
424     dev-util/pkgconfig -> virtual/pkgconfig
425 ssuominen 1.73
426     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
427     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
428     old
429 armin76 1.72
430     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
431     ia64/sh/sparc stable wrt #401513
432 ssuominen 1.71
433     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
434     ppc/ppc64 stable wrt #401513
435 klausman 1.70
436     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
437     Stable on alpha, bug #401513
438 tomka 1.69
439     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
440     marked x86 per bug 401513
441 maekke 1.68
442     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
443     arm stable, bug #401513
444 jer 1.67
445     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
446     Stable for HPPA (bug #401513).
447 ago 1.66
448     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
449     Stable for AMD64, wrt security bug #401513
450 ssuominen 1.65
451     *polkit-0.104-r1 (30 Jan 2012)
452    
453     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
454     Restore the default value of AdminIdentities from "wheel" to "0" like it was
455     in polkit-0.102 and ones before that. You should see files
456     50-localauthority.conf and 60-gentoo.conf in
457     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
458     with "man 8 pklocalauthority" as soon as possible.
459 maekke 1.64
460     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
461     arm stable, bug #397755
462 ago 1.63
463     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
464     Stable for AMD64, wrt bug #397755
465 ssuominen 1.62
466     *polkit-0.104 (05 Jan 2012)
467    
468     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
469     metadata.xml:
470     Version bump.
471 ssuominen 1.61
472     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
473     old
474 ssuominen 1.60
475     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
476     ppc/ppc64 stable wrt #387163
477 ssuominen 1.59
478     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
479     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
480 ssuominen 1.58
481     *polkit-0.103 (07 Dec 2011)
482    
483     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
484     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
485     "i.Dark_Templar"
486 armin76 1.57
487     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
488     alpha/arm/ia64/sh/sparc stable wrt #387163
489 maekke 1.56
490     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
491     arm stable, bug #387163
492 jer 1.55
493     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
494     Stable for HPPA (bug #387163).
495 phajdan.jr 1.54
496     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
497     x86 stable wrt bug #387163
498 hwoarang 1.53
499     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
500     Stable on amd64 wrt bug #387163
501 nirbheek 1.52
502     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
503     polkit-0.102.ebuild:
504     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
505 ssuominen 1.51
506     *polkit-0.102 (06 Aug 2011)
507    
508     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
509     Version bump.
510 mattst88 1.50
511     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
512     Added ~mips, bug 296548
513 eva 1.49
514     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
515     Add missing dtd to DEPEND, bug #355505.
516 armin76 1.48
517     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
518     alpha/arm/ia64/sh/sparc stable wrt #364973
519 phajdan.jr 1.47
520     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
521     polkit-0.101-r1.ebuild:
522     x86 stable wrt security bug #364973
523 jer 1.46
524     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
525     Stable for HPPA (bug #364973).
526 angelos 1.45
527     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
528     Stable on amd64 wrt bug #364973
529 xarthisius 1.44
530     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
531     ppc/ppc64 stable wrt #364973
532 nirbheek 1.43
533     *polkit-0.101-r1 (25 Apr 2011)
534    
535     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
536     +polkit-0.101-r1.ebuild:
537     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
538 xarthisius 1.42
539     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
540     ppc/ppc64 stable wrt #354509
541 armin76 1.41
542     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
543     alpha/ia64/sh/sparc stable wrt #354509
544 nirbheek 1.40
545     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
546     PDEPEND on 0.101 version of polkit-gnome
547 maekke 1.39
548     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
549     arm stable, bug #354509
550 ssuominen 1.38
551     *polkit-0.101 (11 Mar 2011)
552    
553     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
554     Version bump.
555 jer 1.37
556     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
557     Stable for HPPA (bug #354509).
558 tomka 1.36
559     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
560     x86 stable per bug 354509
561 hwoarang 1.35
562     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
563     Stable on amd64 wrt bug #354509
564 nirbheek 1.34
565     *polkit-0.100 (23 Feb 2011)
566    
567     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
568     Bump to 0.100
569 ssuominen 1.32
570     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
571 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
572 jer 1.31
573     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
574     Marked ~hppa (bug #296548).
575 ssuominen 1.30
576     *polkit-0.99-r1 (25 Dec 2010)
577    
578     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
579     Revision bump to remove static archives (.a) and libtool archives (.la).
580 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
581 nirbheek 1.27
582     *polkit-0.99 (25 Sep 2010)
583    
584     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
585     Bump to 0.99, masked due to >=glib-2.25 requirement
586 maekke 1.26
587     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
588     arm stable, bug #314899
589 armin76 1.24
590 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
591     polkit-0.96-r2.ebuild:
592     alpha/ia64/sh/sparc stable
593 josejx 1.23
594     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
595     Marked ppc/ppc64 stable.
596 klausman 1.22
597     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
598     Stable on alpha, bug #329621
599 jer 1.21
600     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
601     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
602     Stable for HPPA (bug #314899).
603 jer 1.20
604     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
605     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
606     Drop HPPA keywording (bug #324511).
607 nirbheek 1.19
608     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
609     polkit-0.96-r2.ebuild:
610     Add ewarn about ensuring that consolekit sessions are working. Either the
611     user needs to login using a login-manager with consolekit support, or use
612     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
613 nirbheek 1.18
614     *polkit-0.96-r2 (02 Jul 2010)
615    
616     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
617     +polkit-0.96-r2.ebuild, metadata.xml:
618     USE=expat was quite useless, expat is mandatory in polkit. Don't create
619     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
620     add introspection support
621 maekke 1.17
622     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
623     x86 stable, bug #314899
624 tester 1.16
625     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
626     amd64 stable, bug #314899
627 armin76 1.15
628     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
629     polkit-0.96-r1.ebuild:
630     Add ~sh
631 aballier 1.14
632     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
633     +files/polkit-0.96-getcwd.patch:
634     Fix build on fbsd and keyword it x86-fbsd
635 nirbheek 1.13
636     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
637     polkit-0.96-r1.ebuild:
638     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
639 nirbheek 1.12
640     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
641     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
642     -polkit-0.95.ebuild:
643     Remove old
644 nirbheek 1.11
645     *polkit-0.96-r1 (21 Mar 2010)
646    
647     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
648     +polkit-0.96-r1.ebuild:
649     Update with newer version of polkit-shadow patch
650 nirbheek 1.10
651     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
652     Fix minor problems with SRC_URI
653 nirbheek 1.9
654     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
655     Add experimental shadow support, bug 291116 . Patch thanks to the
656     slackware folks.
657 armin76 1.8
658     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
659     Add ~alpha/~arm/~ia64/~sparc
660 josejx 1.7
661     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
662     Marked ~ppc/~ppc64 for bug #296548.
663 nirbheek 1.6
664     *polkit-0.96 (23 Jan 2010)
665    
666     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
667     Version bump to 0.96; lots of bugfixes, see NEWS
668 jer 1.5
669     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
670     Marked ~hppa (bug #296548).
671 nirbheek 1.4
672     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
673     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
674     the user is in an active/local session via dbus methods
675 nirbheek 1.3
676     *polkit-0.95 (14 Nov 2009)
677    
678     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
679     Bump to 0.95 -- new lockdown API, last dev version till 1.0
680 nirbheek 1.2
681     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
682     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
683     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
684 eva 1.1
685     *polkit-0.94 (29 Oct 2009)
686    
687     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
688     +files/polkit-0.92-zsh-completions.patch,
689     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
690     +metadata.xml:
691     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20